
Nasdaq Calypso
Pricing Sheet User Guide
Version 18

Revision 4.0

December 2024

Approved

©December 2024 Nasdaq, Inc. All Rights Reserved. Private and Confidential



Copyright © December 2024, Nasdaq, Inc. All rights reserved.All content in this document is owned, or licensed, by
Nasdaq, Inc. or its affiliates (‘Nasdaq’). Unauthorized use is prohibited without written permission of Nasdaq.While
reasonable efforts have been made to ensure that the contents of this document are accurate, the document is
provided strictly “as is”, and no warranties of accuracy are given concerning the contents of the information contained
in this document, including any warranty that the document will be kept up to date. Nasdaq reserves the right to
change details in this document without notice. To the extent permitted by law no liability (including liability to any
person by reason of negligence) will be accepted by Nasdaq or its employees for any direct or indirect loss or damage
caused by omissions from or inaccuracies in this document.The Pricing Sheet window allows capturing and pricing
trades using predefined strategies.

Document History

Revision Published Summary of Changes

1.0 February 2024 First revision for version 18.

2.0 June 2024 Second revision for version 18 - Added Commodity Forward to Spot Migration
details.

3.0 October 2024 Third revision for version 18 - Updates related to 'DLY - Future Contract Delivery
Period' for Commodity Swap, Commodity OTC Option trades and Commodity
Swaption trades.

4.0 December 2024 Fourth revision for version 18 - Added Capturing Structured Product Trades.

This document guides you to use the Pricing Sheet.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 2 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 3 / 359

Table of Contents
1. Pricing Sheet User Guide Overview 9

2. Out-of-the-box Strategies 10

3. Using the Pricing Sheet 17
3.1 Tour of the Pricing Sheet 17

3.1.1 The Toolbar 18

3.1.2 The Tools Panel 19

3.1.3 Keyboard Shortcuts 22

3.2 Capturing Trades 24

3.2.1 Selecting Trades 25

3.2.2 Adding and Removing Trades 26

3.2.3 One-Click Shortcut Actions for Adding and Opening Trades 28

3.2.4 Pricing Trades 29

3.2.5 Saving Trades and Hypothetical Trades 32

3.2.6 Generating Trade Strips 35

3.2.7 Viewing Trade Details 37

3.2.8 Viewing Trade Cash Flows 39

3.2.9 Viewing Strategy Attributes 40

3.2.10 Loading Saved Trades 40

3.2.11 Exporting Trade Strategies to Excel 41

3.3 Bid/Ask Volatility Pricing 42

3.3.1 Settings 43

3.3.2 Required Market Data 44

3.3.3 Recommendations for FX Options 45

3.4 Using Workspaces 45

3.5 Applying Trade Lifecycle Actions 46

3.6 Running Risk Analyses on-the-fly 46

3.7 Using the Payoff Chart 47

3.7.1 Chart Settings 48

3.7.2 Graph Properties and Controls 49

3.7.3 Tabular Display 50

4. Capturing Trades 51
4.1 "Trade" Properties 52

4.2 Manipulating Strategy Templates 58

4.3 "Product: Amount" Properties 59

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



4.4 "Product: Style" Properties 60

4.5 "Product: Info" Properties 64

4.6 "Product: Rate" Properties 64

4.7 "Product: Barrier" Properties 69

4.8 "Product: Trigger" Properties 71

4.9 "Product: Payment" Properties 73

4.10 "Product: Settlement" Properties 77

4.11 "Date" Properties 78

4.12 "Market Data" Properties 80

4.13 "Price" Properties 81

4.14 "Solver" Properties 84

4.15 "Dealt Data" Properties 85

4.16 "Keyword" Properties 86

4.17 "Pricer" Properties 86

4.18 "Product: Cliquet" Properties 87

4.19 "Product: Chooser" Properties 88

4.20 "Product: Commodity" Properties 88

4.21 Cash Settle Info 89

4.22 Trade Drilldown 93

5. Capturing Commodities Trades 95
5.1 Commodity Cap 96

5.2 Commodity Forward 99

5.3 Commodity Spot 101

5.4 Commodity OTC Option 102

5.5 Commodity Swap 106

5.6 Commodity Swaption 110

5.7 Commodity Vanilla 114

5.8 Commodity Barrier 117

5.9 Commodity Digital 119

5.10 Commodity FwdStart 121

5.11 Quantity Schedule for Commodities 124

5.12 Spread and Strike Schedule for Commodities 126

6. Capturing CRD Trades 128
6.1 CDS SNAC Trade 128

6.2 CDS Index Trade 131

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 4 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 5 / 359

6.3 CDS Index Option Trade 134

6.4 CDS Index Tranche Trade 137

6.5 Asset Swap Trade 142

7. Capturing Equity Derivatives Trades 147
7.1 Equity Reset Properties 147

7.2 Equity 148

7.3 Equity Forward 150

7.4 Equity Swap 152

7.5 Portfolio Swap 156

7.6 Equity Structured Options 158

7.6.1 Equity Vanilla 159

7.6.2 Equity Barrier 161

7.6.3 Equity Digital 162

7.6.4 Equity Asian/Lookback 163

7.6.5 Equity Cliquet 163

7.6.6 Equity Chooser 164

7.6.7 Defining an Observation Schedule 164

7.7 Correlation Swap 164

7.8 Scriptable OTC Products 166

8. Capturing ETF Trades 167
8.1 Defining ETF Products 167

8.1.1 Settings Panel 168

8.1.2 ETF Constituents Panel 169

8.2 ETF Trades 169

8.3 Positions 170

8.4 Sensitivity Analysis 171

8.5 Official P&L Report 171

9. Capturing Fixed Income Trades 172
9.1 Bond Trade 172

9.2 Treasury Lock 175

9.3 Inflation Lock 179

9.4 Search Bonds Window 181

10. Capturing FX Trades 183
10.1 FX Spot Trade 183

10.2 FX Forward Trade 187

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



10.3 FX Swap Trade 189

10.4 FX NDF Trade 190

10.5 FX Forward Start Trade 192

10.6 FX Flexi Forward Trade 194

10.7 Merchant FX Trade 195

10.8 FX Window Forward Trade 197

10.9 FX Averaging Forward Trade 199

10.10 Simple Transfer Trade 200

10.11 Split Rates and Routing 201

10.12 Rollover / Rollback History 202

11. Capturing FX Option Trades 203
11.1 Vanilla Strategies 204

11.2 Broker Butterfly and Broker Strangle Strategies 210

11.3 Accrual Strategies 210

11.3.1 Setting Accrual Details 213

11.4 Asian Strategies 215

11.4.1 Setting an Asian Observation Schedule 217

11.5 Barrier Strategies 219

11.5.1 Configuring Multiple Barriers 221

11.6 Compound Strategies 225

11.7 Digital Strategies 226

11.8 Forward Starting Strategies 229

11.9 Lookback Strategies 230

11.10 Volatility Forward Strategies 232

11.11 FX Target Redemption Forwards 233

11.11.1 Defining the FX TARF Strategy 233

11.11.2 Using the FX TARF Strategy 233

11.12 Inverting Quanto and Flexo Settled Strategies 236

11.13 Volatility and Variance Swaps Strategies 237

11.14 Volatility and Variance Options Strategies 240

12. Capturing IRD & Cash Trades 244
12.1 Cap Floor Trades 245

12.2 Spread Cap Floor Trades 253

12.3 Setting an Amortization Schedule 254

12.4 FRA Trades 254

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 6 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 7 / 359

12.5 Structured Flows Trades 256

12.6 Applying Reconvention Actions 260

12.6.1 Capitalize 262

12.6.2 Collateral Change 263

12.6.3 Disbursement 264

12.6.4 Flipper 264

12.6.5 Interest Cleanup 265

12.6.6 Maturity Date Change 266

12.6.7 Notional Change 266

12.6.8 Payment Frequency 267

12.6.9 Payment Holiday 268

12.6.10 Principal Structure 268

12.6.11 Rate Index 269

12.6.12 Rerate 270

12.7 Swap Trades 271

12.7.1 Brazilian Swaps 272

12.7.2 Inflation Swaps 276

12.7.3 Brazilian Inflation (PTAX) Swaps 278

12.7.4 Cross-Currency Swaps 279

12.7.5 Cancellable Swaps 281

12.7.6 Non-deliverable Swaps 283

12.7.7 Quanto Swaps 285

12.7.8 Real Yield Swaps 285

12.7.9 Fixed Payment Swap 286

12.7.10 Performance Swap 287

12.8 Capped Swap Trades 289

12.9 Swaption Trades 292

12.9.1 Defining a Fee Schedule 297

12.9.2 Computing the Premium Fee 298

12.10 Setting Specific Resets 301

12.11 Islamic Trades 301

12.11.1 Before you Begin 302

12.11.2 Islamic MM Trades 303

12.11.3 Islamic Swaps 305

12.11.4 Sample Message Setup 308

13. Capturing Listed Derivatives Strategies 313
13.1 ETO FX, Equity and Equity Index Trades 314

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



13.2 Bond, MM, FX, Equity, Equity Index and Commodity Future Trades 317

13.3 Bond, MM, FX, Equity, Equity Index, Commodity Future Option Trades 319

13.4 Listed FRA Trades 321

13.4.1 Defining Listed FRA Contracts 321

13.4.2 Capturing a Listed FRA Trade 325

13.5 Future Structured Flows 328

13.6 Future Swap Trades 329

13.7 Future Forward Start FX Trades 331

13.7.1 Before You Begin 331

13.7.2 Defining Future Contracts 335

13.7.3 Capturing Future Forward Start FX Trades 338

13.8 Brazilian FRC Trades 341

13.9 Generic Future and Generic Option 342

14. Capturing Structured Product Trades 344

15. Solving 346
15.1 Solving Shortcuts 346

15.1.1 Single Trade Shortcuts 346

15.1.2 Out-of-the-box Strategies Shortcuts 347

15.1.3 Multiple Trades Shortcuts 348

15.2 Advanced Solving 349

15.2.1 Advanced Solving - Single Trade 350

15.2.2 Advanced Solving - Multiple Trades 353

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 8 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 9 / 359

1. Pricing Sheet User Guide Overview
The Pricing Sheet window allows capturing and pricing trades using predefined strategies.

The Pricing Sheet window may contain multiple pricing sheets. Each pricing sheet may contain multiple trades based
on the selected strategy. Pricing Sheets are created on-the-fly, however the configuration is stored by profile for a
set of users or user groups.

 Ⓘ [NOTE: The configuration of profiles is completely independent from the actual trade capture, and needs to
be performed prior to capturing and pricing trades]

Refer to Calypso Pricing Sheet Configuration documentation for details.
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2. Out-of-the-box Strategies
The following table describes strategies that you can capture out-of-the-box using the Pricing Sheet window. All pre-
configured strategy attribute and persistence can be modified using the Strategy Builder to suit business needs.

Refer to Calypso documentation Building Custom Strategies for details.

Strategy behavior upon saving can also be controlled with default settings.

Commodities and Commodity Option Trades

Strategies Description

Commodity Forward A contract to buy or sell a fixed quantity and quality of a particular commodity for
delivery at a fixed date in the future at a fixed price.

Commodity Option A strip of Cash settled Asian or Average Rate Options. The payoff depends on an
average of Reference Prices relative to a fixed Strike.

Commodity Swap An exchange of payments between two parties.

Commodity Swaption An option on an underlying commodity swap

Credit Derivatives

Strategies Description

CDS SNAC (single name) Swap protection over credit events against premium.

CDS Index CDS on an index.

CDS Index Option Option that makes a payoff in the event a default occurs on the index.

CDS Index Option Tranche Option that makes a payoff in the event a default occurs on the index tranche.

Asset Swap Swap bond coupons against interest rate payments.

Equities and Equity Option Trades

Strategies Description

Equity Trade equities.

Equity Forward An OTC trade between two parties to buy or sell an asset at a specified price on a
forward date. The underlying can be an equity, an equity index, or a basket.

Equity Swap The Equity Swap strategy in the Pricing Sheet defines a performance leg with an
equity or equity index and the funding leg with a floating rate index or a fixed rate.

Portfolio Swap A Portfolio Swap helps standardize the handling of equity swaps. The underlying
specifics of the agreement are defined by the Portfolio Swap Contract.
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Strategies Description

Equity Structured Options An Option is an agreement between two parties to exchange one or more cash
flows based on a Payout. The Payout formula typically refers to Underlyings. Equity
Structured Options as a whole includes the individual strategies Equity Vanilla,
Equity Barrier, Equity Digital, Equity Asian/Lookback, Equity Cliquet, Equity Chooser,
Equity Compound, Equity FwdStart, Equity Variance Swap, and Equity Variance
Option.

Correlation Swap An OTC transaction between two parties to exchange the difference between a
“Strike Correlation” and the “Realized Correlation”.

Exchange Traded Fund (ETF)

Strategies Description

ETF ETF trade.

Fixed Income

Strategies Description

Bond G10 Government bonds.

Inflation bonds (excluding BRL).

Treasury Lock A Treasury Lock is a customized agreement that fixes the yield, clean price, or dirty
price of a specific treasury bond on a specific date in the future.

Inflation Lock An inflation lock is a customized agreement that fixes the yield or price on a
specified inflation bond at a specific date in the future.

Inflation locks are only supported for the Israeli CPI market.

FX

Strategies Description

FX FX spot and forwards.

Non deliverable FX forwards.

Simple Transfer Simple transfer.

FX Options

Nasdaq Calypso
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Strategies Description

Accrual Accruals are products for which the holder will receive a fraction of forwards
(physical), or a fraction of currency amount (cash).

Accruals also allow defining Fader options where the notional of the vanilla is
determined on the expiry date rather than by a predefined value.

Asian The payout is based on the average price of the underlying currency during the
specified period.

Barrier A Barrier Option is similar to Vanilla, but it has one or two barrier prices:

• Single Barrier - Greater than or less than the strike.

• Double Barrier - One price is greater than the strike; the other is less.

There are two types of barriers:

• Knock-In - The price of the underlying currency reaching the barrier activates
this option.

• Knock-Out - Starts as a Vanilla option, but terminates at any time during the
option period if the price of the underlying currency reaches the barrier. Payout
is an FX Spot deal.

The option pays out if it is knocked-out.

Broker Butterfly

Broker Strangle

"Broker" strategies are quoted with the same volatility on all legs, giving them dif-
ferent strikes for a given delta.

Butterfly Simultaneous purchase or sale of an at-the-money Straddle against an opposite
Strangle.

Compound FX option on a vanilla FX option.

Condor Simultaneous purchase or sale of one Strangle and the opposite of another
Strangle.

Digital The payout is pre-determined at the beginning of the contract, and is paid
according to whether the spot rate touches (or does not touch) the trigger level.

Digital
• One Touch (OT) - If at any time before expiration spot trades at or beyond the

trigger, then the payout is generated, else the option expires worthless.

• Double One Touch (DOT) - If at any time on or before expiration spot trades at
or below the low trigger or if at any time on or before expiration spot trades at or
above the high trigger, then the payout is generated, else the option expires
worthless.

• No touch (NT) - If at any time on or before expiration spot trades at or beyond
the trigger the option expires worthless else the payout is generated

• Double No Touch (DNT) - If at any time on or before expiration spot trades at or
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Strategies Description

below the low trigger or if at any time on or before expiration spot trades at or
above the high trigger, then the option expires worthless, else the payout is
generated

• One Touch No Touch (OTNT) - If at any time on or before expiration spot trades
at or through the knockout trigger the option expires worthless, else if at any
time on or before expiration spot trades at or through the knock in trigger a
Digital No Touch is generated.

Partial Digital
• One Touch (OT) - If at any time during the observation period spot trades at or

beyond the trigger, then the payout is generated, else the option expires
worthless.

• Double One Touch (DOT) - If at any time during the observation period spot
trades at or below the low trigger or if at any time during the observation period
spot trades at or above the high trigger, then the payout is generated, else the
option expires worthless.

• No touch (NT) - If at any time during the observation period spot trades at or
beyond the trigger the option expires worthless else the payout is generated.

• Double No Touch (DNT) - If at any time during the observation period spot
trades at or below the low trigger or if at any time during the observation period
spot trades at or above the high trigger, then the option expires worthless, else
the payout is generated

Digital (at Expiry) Trigger is active only on the day of Expiry. Payout is generated based on the Spot on
Expiry date and Trigger Type:

• ABOVE – If spot trades above the trigger level

• BELOW – If spot trades below the trigger level

• IN – If the spot trades within the two trigger levels

• OUT – If the spot trades outside the two trigger levels

Digital with Barrier A digital with barrier is a digital at expiry (or European binary) with barrier. NOTE:
Underlying Digital at expiry only supports ABOVE and BELOW as trigger type.

Forward Starting The strike is determined at a later date. Like a standard option, a Forward Start
option is paid for in the present; however the strike price is not fully determined until
an intermediate date before expiration. This date is called the fixing date.

The fixing process is done using the scheduled task FXOPTION_RATE_RESET.

Lookback The payout is based on either a fixed or floating strike:

• Fixed Strike — Call pays the maximum of the rate during the option life, minus
the strike; put pays the strike minus the minimum rate during the option life.
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Strategies Description

• Floating Strike — Call pays the rate at expiry minus the minimum of the rate
during the option life; put pays the maximum rate during the option life, minus
the rate at expiry.

Reversal Simultaneous purchase of a call and sale of a put (or the opposite), both of which
are out-of-the-money.

Spread Simultaneous purchase of one call and sale of another with the same expiration and
different strikes (the same strategy applies to puts).

Straddle Simultaneous purchase or sale of both a call and a put, with the same expiration
date and strike.

Strangle Simultaneous purchase or sale of both a call and a put with the same expiration date
but different strikes, both of which will be out-of-the-money.

Vanilla A Vanilla option is a usual option with no special features. The option can be either
European or American.

Volatility Forward Forward contract in which the buyer agrees to pay an ATM straddle at a pre-
specified date in the future at the current forward price, which is the price at which
the market believes would prevail at maturity.

FX  Averaging Forward Forward contract for currencies. The amount is based on the difference between
the strike price and the calculated average price of the underlying FX spot rate
within an agreed time period and multiplied by an agreed amount. Reset dates are
generated in regular intervals, or can be customized, and different weights can be
assigned to the prices on each reset date.

FX Swap FX swap.

FX Variance Swap Agreement between counterparties to swap a fixed rate of FX variance and a real-
ized rate of FX variance over a set period of time

FX Variance Option Capture options on swaps that reference realized FX variance. Captured the same
way as FX Variance Swaps with the addition of the Put/Call property.

IRD Trades

Strategies Description

Cap Borrower and lender agree that the borrower will pay no more than a specified
maximum interest rate to the lender with respect to floating interest rate funds.

Collar A simultaneous purchase of a cap with the sale of a floor, or a simultaneous pur-
chase of a floor with the sale of a cap.

Corridor Combination of two caps, one purchased by a borrower at a set strike and the other
sold by the borrower at a higher strike to, in effect, offset part of the premium of the
first cap.
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Strategies Description

Fixed Rate

Floating Rate

Structured flow, can be fixed or floating.

Islamic MM Islamic Money Market.

FRA Interest rate Forward Rate Agreements.

SpreadCap A Cap having a floating rate index which is the difference (spread) between two
floating indices.

SpreadCollar A Collar having a floating rate index which is the difference (spread) between two
floating indices.

Swap Vanilla Interest Rate swap and Inflation swap.

Non-deliverable swaps - An agreement between two parties to exchange a stream
of interest payments and the notional principal in one major currency for another
non-deliverable currency.

Cancelable swaps - Contains an underlying interest rate swap with the option to
cancel it on one or more cancellation dates.

Quanto swaps - The Quanto swap is an interest rate swap where the currency of the
notional on the floating leg differs from the currency of the reference index.

Brazilian swaps - Swap trade with Brazilian conventions.

Brazilian Inflation swaps - Inflation swaps are based on inflation indices with
Brazilian conventions.

Capped swaps.

Islamic swaps.

Swap Butterfly.

Swap Steepener.

Exotic Swap.

Fixed Payment Swap - Provides a property for entering a fixed amount on the fixed
leg to be paid at the end of the period, rather than using a rate and notional to
calculate payments.

Performance Swap - A set of future cash flows are exchanged between two
counterparties. The primary leg can be a single asset only, with a bond or market
index underlying. The secondary leg is currently limited to swaps.

Swaption Vanilla interest rate swaption.

Listed FRA A Forward Rate Agreement with a standardized contract that allows it to be listed on
and cleared by an exchange.
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Listed Derivatives

Strategies Description

Future Bond Listed futures based on Future contracts.

FRC Brazilian Structured Flows.

Future FX Simultaneous exchange of a spot for futures at an agreed upon price.

Future MM Future Money Market trade.

Future Equity Listed futures based on Future contracts.

Future Equity Index Listed futures based on Future contracts.

Future Commodity Listed futures based on Future contracts.

Future Swap A listed future that uses a swap for its underlying.

Future Option Bond Option on a Future Bond.

Future Option FX Listed futures based on Future contracts.

Future Option MM Option on a Future Money Market.

Future Option Equity Option on Future Equity.

Future Option Equity Index Option on an Future Equity Index.

Future Option Commodity Option on a Future Commodity.

ETO Equity Option on cash Equity

ETO Equity Index Option on a cash Equity Index.

ETO FX Option on FX.

Listed FRA A Forward Rate Agreement with a standardized contract that allows it to be listed on
and cleared by an exchange.

Future Forward Start FX Involves the trading of the first available maturity date of US Dollar Contract (basis
month) and adding or subtracting a number of points from the FX spot rate, rep-
resented by the Central Bank of Brazil's PTAX rate.
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3. Using the Pricing Sheet
The Pricing Sheet window allows capturing and pricing trades using predefined strategies based on your profile.

The Pricing Sheet window may contain multiple pricing sheets by currency pair. Each pricing sheet may contain
multiple trades based on the selected strategy. Pricing Sheets are created on-the-fly, however the configuration is
stored by the user.

 Ⓘ [NOTE: The configuration of profiles and strategies is completely independent from the actual trade
capture, and needs to be performed prior to capturing and pricing trade]

Please refer to Calypso Configuring Profiles documentation for details.

Contents

- Tour of the Pricing Sheet

- Capturing Trades

- Bid/Ask Volatility Pricing

- Using Workspaces

- Applying Trade Lifecycle Actions

- Running on-the-fly Risk Analyses

- Using the Payoff Chart

3.1 Tour of the Pricing Sheet
When you first open the pricing sheet, both the Tools Panel and Deal Entry Panel are empty of content. Before adding
trades, certain user preferences need to be configured.

To get started, point to Configuration > Profile Configuration to configure profiles and strategies.

Please refer to Calypso Configuring Profiles documentation for details.

Then choose Configuration > User Preferences to set general default values, select which pricer measures you wish
to compute, and select which trade events columns you want to display.

Please refer to Calypso Setting User Preferences documentation for details.

Once the Pricing Sheet is configured, you are ready to select a strategy to capture and price trades.

You can check which profile you are currently using by pointing to Configuration > Active Profile - Or you can select a
different profile if one is available.
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Pricing Sheet (Tour)

Adding Pricing Sheets
Aside from the ability to have several legs on one pricing sheet, you can also have multiple pricing sheets open in the
Pricing Sheet window.

• Choose Pricing Sheet > New Sheet to add another pricing sheet panel. Click X to close the sheet.

3.1 .1 The Toolbar
A number of icons represent functions available directly from the Toolbar, most of which are also available in the
menu items above. Right-click on the Toolbar to toggle on/off viewing of tool names.

To select which icons are displayed on the Toolbar, choose the Toolbar tab in User Preferences.
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3.1 .2 The Tools Panel
The Tools Panel fills the left side of the Pricing Sheet window and provides a number of tools for working with trades.
Certain default value settings can be found on the Defaults tab in the User Preferences window (Configuration > User
Preferences).

» To open one of the tools, click the associated icon at the bottom of the panel.

The tool's pane opens in the Tool Panel.

» To close the tool, click the icon again or use the X in the top left corner of the tool.

Close window

» To simply hide the tool's content without closing the tool, click the name. Data fields are hidden while the tool's
header remains on the panel. Click the tool name again to show content.

Hide tool content

The following tools are available on the Tools Panel.

Market Data
The Market Data tool shows market information used for pricing strategy legs in the Deal Entry Panel, such as spot
rates, curves, and volatility surfaces.

• Click an item in the Market Data pane to open its definition window. You can also chooseMarket Data > Display in
Market Data Manager to view all market data - click Help in the Market Data Manager's menu bar for more
information. If you modify any market data in the Market Data Manager and wish to revert those changes, you can
chooseMarket Data > Revert Pricing Env from the Pricing Sheet menu bar.

TIP: To easily revert a market data value that was manually overridden in the Market Data tool, you can
highlight the field and press the Delete key. The original value is restored.

• The "Default Rate Sides" setting at the top of the tool pane controls whether a leg of a structure should be priced
at mid or spread. This setting defaults to "Choice", however, the recommended setting is Bid/Ask. You can
change the default setting on the Defaults tab in User Preferences. The following settings are available, with
some variation among different strategies.
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– Choice - No spread is applied.

– Closing Price - Pricing sheet uses the close sides of the quote set and the volatility surface to price deals.

– Bid/Ask - Pricing sheet uses the bid and ask sides of the quote set and the volatility surface to price deals.

– Bid/Ask Vol - Pricing sheet uses the bid and ask sides of the volatility surface and only the mid value of the
quote set to price deals.

– Bid/Ask Spot - Pricing sheet uses the bid and ask sides of the quote set and only the mid value of the
volatility surface to price deals.

– Bid/Ask Spot/Fwd - Pricing sheet uses the bid and ask sides of the quote set and will set spot, pips and
other fields with bid/ask spread. The final price will be given as bid/ask spread calculated from the same
choice Vol.

This setting can also be set at the leg level. Use the Strategy Builder to add it to a custom strategy or add the
"Rate Side" property to an out-of-the-box strategy in the Profile Configuration window.

If a two-way quote is used, the side of the quote used to generate the price will be boldfaced in the display.

Pricing
The Pricing tool displays the valuation date, valuation time, the current pricing environment, and the pricing output.

• The Valuation Date defaults to the current day. Click the field to show the down arrow, and then click the arrow to
display the calendar used to change the date. Using the pause-and-play icon beside Valuation Date, you can
pause the Valuation Date and Time to keep market data at a certain date and time for pricing, and then restart
date and time.

• Click the Pricing Env field to change the pricing environment, and click the "Output 1 or 2 way" field to choose
between 1-way and 2-way output for Bid/Ask pricing.

Associated pricing functions.

– Click in the Toolbar to price trades in the pricing sheet.

– Click to refresh spot rates, and to refresh market data.

– ChooseMarket Data > Check Pricing Env to check that all required market data are available in the pricing
environment, andMarket Data > Check Past Resets to check that all required fixings are available.

ODA Shortcuts
The ODA Shortcuts icon provides quick access to the On Demand Analysis window.
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• With the ODA Shortcuts tool open in the Tools Panel, click to open the On Demand Analysis window.

Solver
The Solver provides users with an analytics solver tool to solve for certain target values for a selected trade. For
example, for an FX Option, you can solve for the strike value for a targeted customer premium.

Strip Generator
The Strip Generator allows you to generate a "strip", or new trade (or trades), based on the parameters of a reference
single- or multi-leg trade.

• The reference trade is named the "Driver", and all trades generated from it are "strips".

Leg Links
Leg Links allows you to link properties between individual legs and shows the relationships between them.

• Click to open settings and configure links between the leg used for driving properties and the leg
that is driven by those properties.

Leg Details
Leg Details provides information on a highlighted strategy leg. The information fields vary from strategy to strategy.

• Click to display a list of menu options that support the trade. When available, click to open the strategy's
supplemental panel on the right-hand side of the window. The content of this panel depends on the selected
strategy.

• Click beside Underlying to open an asset's definition window

• You can also right-click anywhere in the leg's properties and choose Trade Details to show trade details menu
options (See Right-Click Trade Menu below for other menu items). The following options are available for Trade
Details:

– Advanced Comments

– Show Comments

– Add Generic Comment

– Trade Attributes (Trade Keywords)

– Trade Fees

– Trade Audit

– Counterparty Info

– BO Browser
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– BO Bundle Browser

Comments
The Comment icon allows for adding and attaching comments to a trade leg.

• A user can also view a document attached to this comment. Click to open the Add Generic Comment window.
From there, you can run a report, view comments, and open trades back to the Pricing Sheet based on attached
comments.

Underlying Details
Underlying Details provides details on assets underlying the trade.

• Click beside Product ID to open an asset's definition window.

Rate Delta
Rate Delta displays Rate Delta sensitivity.

• Select the "Run Analysis" checkbox for sensitivity analysis. Click "X Cancel" to cancel analysis.

Property Shortcuts
Property Shortcuts provide the ability to quickly show or hide groups of properties and pricer measures in strategy
legs.

• Click to show the Properties display group checkbox list.

• Click to show the Measures display group checkbox list.

Refer to Calypso Configuring Profiles documentation for Properties Display Group details.

Refer to Calypso Setting User Preferences documentation for Pricer Measure Display Group details.

3.1 .3 Keyboard Shortcuts
The following keyboard shortcuts can be used:

F Keys
• F3: Advanced Save

• F5: Save

• F6 (or Ctrl + T): New Sheet

• F7: Add to Blotter Workspace
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• F8: Save/Update Workspace

• F9: Solve

• F10: Reserved for Pre-Deal Limit Check

• F11: Strip

• F12: Price

Ctrl + Keys
• Ctrl + W: Close current sheet

• Ctrl + K: Clear current sheet

• Ctrl + F8: Open workspace

• Ctrl + L: Remove current strategy

• Ctrl + N: Advance cursor to Enter Strategy field in blank leg.

• Ctrl + Tab/Shift: Move to previous/next sheet/tab

• Ctrl + Space bar: Select current strategy

• Ctrl + Home key: Go to cell "A1" and scroll back

• Ctrl + Y: Exit Pricing Sheet

• Ctrl + E: Toggle Events panel (See Viewing Trade Events below)

• Ctrl + O: Open Trade in Excel (See Exporting Trade Strategies to Excel below)

• Ctrl + T: New Sheet

Alt + Keys
• Alt + Down/up Arrow: Open the drop down of the selected cell

• Alt + F8: Save As NewWorkspace

• Alt + T: Trade Details

• Alt + K: Trade Attributes (Keywords)

• Alt + F: Trade Fees Details

• Alt + A: Audit

• Alt + S: Counterparty Search

• Alt + I: Counterparty Info

• Alt + B: BO Browser

• Alt + C: Generic Comment Report

• Alt + R: Trade Tree
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• Alt + V: Add Generic Comment

• Alt + X: BO Bundle Browser

Others
• Home button: Go to top of current column

• End: Go to bottom of current column

3.2 Capturing Trades
Open or select a pricing sheet.

In the pricing sheet panel, select a strategy from the "Strategy Name" property - You can select out-of-the-box
strategies, or custom strategies.

 Ⓘ [NOTE: The list of strategies available for selection depends on your profile - See Configuration > Profile
Configuration for details]

Pricing sheet (select strategy)

A strategy can contain multiple trades that will appear as multiple columns in the pricing sheet panel. You can click
to display the strategies as rows rather than columns.

Once you select a strategy, all properties defined for that strategy appear, and are ready for capture.

 Ⓘ [NOTE: If the properties do not appear, they may belong to a display group that is not selected for display -

Display groups are defined as part of your profile - You can click to select which groups you want to display.
Display groups are defined using Configuration > Profile Configuration]

You can also capture additional information on trades like cash settlement info, rate schedules, amortization
schedules, exercise schedules, etc. Right-click a trade and choose "Supplemental" to display supplemental details.

Click here for a complete description of all properties and supplemental details.

Once the properties are set, you can perform any of the following functions:

• Selecting Trades

• Adding and Removing Trades

• Pricing Trades
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• Solving

• Saving Trades

• Viewing Trade Details

• Viewing Trade Events

• Loading Saved Trades

• Applying Trade Lifecycle Actions

• Running on-the-fly Risk Analyses

3.2 .1 Se lect ing Trades
To select a trade in a pricing sheet, you can click the trade heading. A light blue frame appears around the trade to
indicate that it is selected.

Pricing sheet (select trade)

You can also click to select trades in bulk - Multiple options are available.

Cell Selection

You can also select the trade where your cell selection is - Click to select the trade where the cell selection is.

Pattern Selection
When you have a strip of options or a strategy with multiple legs, you may want to select all the legs that have the
same pattern.

First, you select the columns that determine the pattern.

Then you click to select any other column that fits the pattern.

Here is an example - Select columns 1 and 2 to determine a pattern. When clicking it also selects the other
columns because they fit the same pattern.
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3.2 .2 Adding and Removing Trades
When you select a strategy, it comes with a default number of trades (also referred to as legs). You can add and
remove trades as needed. The following functions are available.

Functions Description

Insert Leg Clicking opens the Insert a product window, where you are prompted to select a strategy.

Using the down arrow, select a strategy and click Insert. A new column is added for the
strategy.
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Functions Description

Alternatively, you can right-click any active trade heading and select Insert Strategy. Remove
Strategy and Reload Strategy options are also available.

The Insert Leg command is also available under View in the menu bar.

Copy Add • Copy Add Reverse - Copies the trade, adds it, reverses buy to sell and vise versa.

• Copy Add - Copies and adds the trade. The reconvention that exists in the original
trade will not be copied to the new trade.

• Copy Replace - Copies over a saved trade in the same column and removes the
trade ID and resets the Action property to NEW. Consequently, it is treated as a new
trade.

• Copy Reverse - Copies over the trade in the same manner as above, and reverses
buy to sell and vice versa.

• Copy To New Sheet - Copies the trade to a new pricing sheet.

• Copy Reverse To New Sheet - Copies the trade to a new sheet, and reverses buy to
sell and vise versa.

• Copy Selected To Clipboard - Copies the selected parts of a trade to the clipboard.

• Copy Add Reverse - BTB - Copies the trade, adds it, reverses buy to sell and vise
versa, without resetting the premium.

• Copy Add - BTB- Copies and adds the trade without resetting the premium.

• Copy Replace - BTB - Copies over a saved trade in the same column and removes
the trade ID and resets the Action property to NEW, without resetting the premium.
Consequently, it is treated as a new trade.

• Copy Reverse - BTB - Copies over the trade in the same manner as above, and
reverses buy to sell and vice versa, without resetting the premium.

• Copy To New Sheet - BTB - Copies the trade to a new pricing sheet without
resetting the premium.

• Copy Reverse To New Sheet - BTB - Copies the trade to a new sheet, and reverses
buy to sell and vise versa, without resetting the premium.

These commands can also be accessed from the menu bar by selecting Tools > Copy.

TIP: To prevent certain trade keywords from being copied to a new leg, list those
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Functions Description

keywords under the domain name PricingSheetKeywordsToClearUponCopy.

Remove Legs Select one or multiple trades, and click . You can choose to:

• Remove the selected legs.

• Remove all legs in the Pricing Sheet.

• Removed saved trades.

The Remove Legs command is also available under View in the menu bar.

3.2 .3 One-Cl ick Shortcut Act ions for Adding and Opening Trades
The features below provide shortcuts for various trade related actions in the Pricing Sheet.

Creating FX Spot/Forward Hedge Trades
You can create one-click FX Spot Hedge and FX Forward Hedge trades on an individual option or on multiple options
at once. The options must be priced before creating a hedge.

» To create an FX Spot Hedge or FX Forward hedge on an individual option, you can right-click the trade leg, point
to Create, and select the preferred type of hedge from the menu.

A new leg is added on the Pricing Sheet for the hedge.

» To create multiple hedges on multiple trades, highlight all relevant trades in the Pricing Sheet, select the Tools
menu, point to Create, and select the preferred type of hedge from the menu.
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For details on making FX Hedge user default settings, see "Defaults Panel" in the Setting User Preferences
documentation.

Feature for Opening FX Option Parent/Child Trades
For quick access to related trades associated with a barrier trade knock-in or an exercised spot trade, You can right-
click a trade and directly open the associated trade in the Pricing Sheet.

This feature is made available in the following two scenarios.

• For a barrier option that’s been knocked in, or a vanilla option that’s been exercised, you can right-click the trade
to open its "child" trade.

• For a vanilla option created when a barrier was knocked in, or a spot trade that was created when an option was
exercised, you can right-click the trade to open its "parent" trade.

3.2 .4 Pr ic ing Trades

» Click to price the trades. Trades with the "Price " property set to "Don't Price" are not priced.

The pricer measures selected under Configuration > User Preferences are computed and displayed in the
Results Panel.
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Pricing sheet (pricing results)

» You can select "Display Pricer Measures" in the Pricing Sheet's View menu, or click in the Toolbar to choose
the following options:

Select the checkboxes that apply to the measures you want added.

Measures
By default, only favorite pricer measures are displayed.

• Check other display groups as needed.

• Check "Detailed Data" to display pricing results per leg.

Currency
By default, the pricer measures are displayed in the currency selected under Configuration > User Preferences.

• Check "Default" to display the pricer measures in the risky currency set in the currency pair definition.
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• Check "Base" to display the pricer measures in the base currency of the pricing environment.

• Check "FX2" to display the pricer measures in the other currency of the currency pair.

The following option is also available in the Pricing window:

Option Description

Output 1 or 2 Way By default, the pricer measures are computed using mid quotes.

You can select:

• "1-way" to display pricer measures for mid quotes and close quotes.

• "2-way" to display pricer measures for bid and ask rates, provided you select the Rate
Sides "Bid/Ask," "Bid/Ask-Vol," ""Bid/Ask-Spot," or "Bid/Ask-Spot/Fwd" in the Market
Data window.

» Depending on the pricer model and strategy, double-clicking certain pricer measures will display more pricing
details on that measure. To enable this feature for a supported pricer measure, you can add the pricer measure to
the domain name PricingSheetViewerMeasures.

For details on adding domain values, see Defining Domain Data in Calypso Getting Started documentation.

Calculating Initial Margin
Optional module Margin Engine.

If you have enabled IM calculation in the User Preferences, you can choose > Price & Calc IM to calculate initial
margin requirements.

Please refer to Calypso Margin Engine documentation for complete setup and usage details.

Calculating XVA and MCPFE
Optional module Monte Carlo XVA.

If you have enabled XVA calculations in the User Preferences, you can choose > Price & Calc XVA or > Calc XVA
to calculate XVA and MC PFE.

After calculating XVA, double-clicking the XVA measures reveals a panel that displays supplementary results,
including a profile chart and graph. (This panel contains identical output as compared to the CCR Viewer panel.)

Please refer to Calypso Monte Carlo XVA documentation for complete XVA setup and usage details.

Please refer to Calypso Monte Carlo PFE documentation for complete MC PFE setup and usage details.
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Calculating SA-CCR
Optional module Regulatory Risk.

If you have enabled SA-CCR calculations in the User Preferences, you can choose > Price & Calc SA-CCR to
instantiate the SA-CCR result integration.

Please refer to the Regulatory Risk SA-CCR documentation for complete SA-CCR setup and usage details.

3.2 .5 Sav ing Trades and Hypothet ica l Trades
You can only save trades where the "Price and Save" property is set to "Active".

Click to save trades, or to save hypothetical trades.

If you click the down arrow next to the Save button, you can select Advanced Save - See details below.

You can click the button to add the trade to the Trade Blotter. You will be prompted to select a blotter workspace.

The trade keyword StrategyType contains the name of the strategy and the IDs of the trades in the strategy, as in the
example shown below:

Upon saving out-of-the-box strategies, separate trades are saved by default, and no bundle is created.

Upon saving custom strategies, the default behavior comes from the Strategy Builder.

 Ⓘ [NOTE: To change the default values for both out-of-the-box strategies and custom strategies, you need
to use the Advanced Save, provided the fields are configured in the Strategy Builder as available and user
editable for that strategy - Please refer to the Calypso Pricing Sheet Setup Guide for details]

Advanced Save - New Trades

Advanced Save - New trades
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» Review the fields described below and click Save.

Fields Description

Save as Sales Trade? Defaults to the "Sales Mode" parameter set in the Defaults panel under Configuration >
User Preferences.

If Yes, the trade keyword "ScratchPadTrade" is set to true - This keyword can be used in the
workflow configuration to set a specific workflow status. Otherwise, the system assigns the
trade status based on the default workflow.

Save as Hypo Trade? If Yes, the trade keyword "HypotheticalTrade" is set to true - This keyword can be used in
the workflow configuration to set a specific workflow status. Otherwise, the system assigns
the trade status based on the default workflow.

Save Trades in a
Bundle?

The Save Type is set by default to "Separate Trades" for out-of-the-box strategies, or
comes from the Strategy Builder for custom strategies.

It can be modified if you have configured persistence settings in the Strategy Builder for that
strategy, and if it is available and user editable.

• "Separate Trades" saves each trade separately and does not add the trades to a bundle.

• "Bundle" adds the trades to a bundle based on the following additional parameters.

The bundle name will be created by the system as "<bundle type>-<bundle number>" -
The bundle number is given by the system.

Bundle Parameters

• Bundle Comment - Enter a comment as needed.

• Create Mirror Bundle? - If Yes, a mirror trade bundle of specified type will be
automatically created, and the mirror trades will be added to that bundle.

The name of the mirror bundle will be created by the system as "Mirror Bundle <bundle
name>".

This only applies if all the trades/legs are internal trades/legs.

• Mirror Bundle Same as Origin - Only applies if "Create Mirror Bundle" is Yes.

Select Yes to add the mirror trades to the same bundle as the original trades instead of
the mirror trade bundle.

You also need to add the value “MirrorBundle to the domain "TradeBundleAttributes".
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Fields Description

• Generate Single Confirm? - If Yes, a single confirmation is generated for all the trades in
the bundle.

Refer to Calypso Trade Bundle documentation for complete setup details.

• Keep Trade Events in Bundle? - If Yes, the trades issued from trade lifecycle actions will
be added to the same bundle as the original trades (like an option trade and a physical
exercise).

• Bundle Attributes - If bundle attributes are defined for the selected bundle type, you can
enter their value.

 Ⓘ [NOTE: If the trade cache contains more than 20000 trades, we do not scan the
cache when saving a trade bundle, but perform a SQL request to get the identifiers of
the trades belonging to the trade bundle. This limit can be overridden using the domain
“TradeCacheLimitSizeForBundleSearch”]

Advanced Save - Existing Trades

Advanced Save - Existing trades

» Review the fields below and click Save.

For custom strategies, the fields default to the settings of the Strategy Persistence settings.

Fields Description

Save as Sales Trade? Defaults to the "Sales Mode" parameter set in the Defaults panel under Configuration >
User Preferences.

If Yes, the trade keyword "ScratchPadTrade" is set to true - This keyword can be used in the
workflow configuration to set a specific workflow status. Otherwise, the system assigns the
trade status based on the default workflow.

Save as Hypo Trade? If Yes, the trade keyword "HypotheticalTrade" is set to true - This keyword can be used in
the workflow configuration to set a specific workflow status. Otherwise, the system assigns
the trade status based on the default workflow.
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Sample Workflow

3.2 .6 Generat ing Trade Str ips
The strip of Pricing Sheet trades is built from one or several driver trades by simple repetition or using a schedule. Any
link or shortcut defined on the driver trades can be copied to the strip. In addition, links can be defined on the strip on-
the-fly.

Following is an example of how to capture a strip of FX options in the Pricing Sheet.

» Capture a trade in the Pricing Sheet.

» In the Strip Generator window, click a leg, or "All legs". These are the driver trades.

» Then click OK.

The Strip Generator window will show the following options:
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» Select Repetitions or Schedule.

– For Repetitions, enter the number of trades you want to add to the strip.

– For schedule, define the schedule.

Check or clear "Copy shortcuts" to copy any solving shortcuts to the strip.

See Solving Shortcuts for details.

Check or clear "Create strip links" to create links on-the-fly - You can setup the links in the "Increment" table.

For example, you can increment the strike of the strip legs by 50 pips from the first leg.

» Click Generatewhen your strip definition is ready - The trades are generated accordingly.

» Once the trades have been generated, click Apply for the generated trades to take effect.
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3.2 .7 Viewing Trade Deta i ls

Click to display the Leg Details window.

Supplemental Information

Click to display supplemental information like cash settlement info, rate schedules, amortization schedules,
exercise schedules, etc.

This is described as part of the trade capture.

Click here for details.

Trade Details

Select one or multiple trades and click in the Leg Details window.

You can choose to display:

• Show Comments - Selecting this menu item opens the Generic Comment Report.

For details on this report, see "Generic Comment Report" in Calypso Front Office Tools documentation.
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• Add Generic Comment - Opens the "Add generic comment" window.

For details on this window, see "Add Generic Comment" in the File Menu section of Front Office Tools
documentation.

• Trade Attributes - (Also called trade keywords) Opens the Trade Attributes pop-up window, where you can assign
values to trade attributes.

For details, see "Defining Trade Keywords" in Calypso Front Office Tools documentation.

• Trade Fees - Opens the Trade Fees Details window.

For details, see "Capturing Trade Fees" in Calypso Front Office Tools documentation.

• Trade Audit - Opens the Trade Audits window.

For details on this window, see "Trade Audit" in the File Menu section of Front Office Tools documentation.

• Counterparty Info - Opens the "Counter Party" window, which corresponds to the Legal Entity window.

For details, see "Defining Legal Entities" in the Calypso Getting Started documentation.

• BO Browser - Opens the Back Office Browser, which is used for viewing back office activity and applying actions
to trades.

For details, see "Back Office Browser" in Calypso Front Office Tools documentation.

Right-Click Menu
Right-click a trade in the Pricing Sheet to open the Trade Shortcuts menu.

The menu provides quick access to Supplemental Information, Trade Details, and Refresh options (View > Refresh)
for a specific trade.

• Supplemental: provides access to the same supplemental information as described above.

• Trade Details menu: provides access to the same Trade Details items as described above.

• Refresh menu: includes Refresh Quotes, Refresh Market Data, Refresh All Market Data (refreshes both quotes and
market data), Refresh Price, and Freeze Price.
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3.2 .8 Viewing Trade Cash Flows

Click to display the Trade Cash Flows panel, or choose View > Cash Flows.

It displays cashflows and fees.

Trade Events panel

You can choose the columns to be displayed in the Cash Flows panel under Configuration > User Preferences.

» You can select the column headings and set filters as needed to filter the trade events.

You can click to clear all the filters.

» You can click to refresh the list of trade events and regenerate the cashflows.

» You can check the Edit checkbox to customize the cashflows. The property "Custom Cashflows" will be set to
"true".

You can use the and icons to undo edits for selected columns or all edits, as needed.

» You can right-click to Export to Excel.

» You can view Sample Values for any "Cash Flow" Event with the Type "INTEREST" for any float swap leg. If
available, click the expand button to the left of the cashflow to view the known and forecasted rates that went
into the final calculated rates shown on the cashflows. The following columns are displayed:

– Sample Type - Averaging, Compounding, or Inflation.

– Sample Date - Observation Date of the Fixing, equivalent to the Reset Date of the Fixing.

– Rate - The Known Rate from Quote Set, if Val Date is earlier than Sample Date and Quote Value exists in
Quote Set.

– Weight - [Percentage Weight of Period End - Period End] for Averaging and Compounding. For Inflation, it is
always 1.

– Period Start - The Accrual Period Start associated with this Fixing.

– Period End - The Accrual Period End associated with this Fixing.

– Proj. Rate - The Project Rate from the Forecast Curve, if Val Date is later than Sample Date. Not valid for
Inflation.

– Rate Index - The Rate Index of the Fixing.
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– Total Rebase Factor - The product of all rebase factors that apply to the given Inflation Fixing. Only valid for
Inflation.

– Rebase Rate - [Rate / Total Rebase Factor] for the given Inflation Fixing.

3.2 .9 Viewing Strategy Attr ibutes
You can add strategy attributes to a pricing sheet provided you have defined them.

Please refer to the Calypso Pricing Sheet Setup Guide for information on defining strategy attributes.

Once defined, you can add them to a strategy in the Profile Configuration window.

3.2 .10 Loading Saved Trades
You can load saved trades and bundles into the pricing sheet using one of the following methods.

 Ⓘ [NOTE: Entering and saving a trade on today's date and entering the trade Id in the "Trades From" field will
not include the target trade in the search results. Search datetime is set to 1 second after midnight of the
"Trades From" date]

Loading a saved or bundle ID and modifying the trade or bundle will add a * to the leg number. This indicates a value
has been changed on the leg.

Loading Saved Trades

» You can enter a trade ID or a bundle ID in the "Trade/Bundle Id" field at the top of the pricing sheet, and the
corresponding trade / bundle will be loaded in the pricing sheet.

» Or you can click . You will be prompted to enter search criteria.
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Open Trades window

Enter search criteria and click Find Trades or Find Bundles.

Then select the trades or bundles you want to load, and click Open Selected. The trades will be loaded in the
pricing sheet.

3.2 .11 Export ing Trade Strateg ies to Excel
You can export strategies into an Excel file by either selecting the option in the PricingSheet menu or using a keyboard
shortcut. This feature exports all strategies open in the active Pricing Sheet, launches the Excel file, and saves a copy
of the file in the user's directory.

To export strategies in the active Pricing Sheet, select "Export to Excel" in the PricingSheet menu, or press Ctrl+O.

» The Excel file is opened and includes trade properties, pricer measures, and trade details.

» A copy of the Excel file is also saved to the user's directory.

– Click the File menu in Excel to see information about the file path where the file is saved.

– Multiple exports are not overridden but saved individually in the directory.

– Files are saved with the following file name format:

PricingSheet_Table_TradeEntry_Sheet_1_yyyyMMDD_HHMMSS.xls (H=hour; M=minute; S=second)
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3.3 Bid/Ask Volat i l i ty Pricing
The Pricing Sheet can be configured to enable bid/ask pricing with an option to display two-way output for pricing
measures. Two-way output requires market data that provides information for both bid and ask quotes.

Example of Bid/Ask pricing for an FX Vanilla strategy
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3.3.1 Sett ings
Bid/Ask pricing is specified on the Market Data tools panel for the "Default Rate Sides" property.

You can also apply bid/ask pricing to an individual leg by adding the "Rate Side" property to the strategy in the Pricing
Sheet Profiles window.

Settings for Bid/Ask pricing are as follows:

• Choice - No spread is applied.

• Closing Price - Pricing sheet uses the Close quote set and the volatility surface to price deals.

• Bid/Ask - uses market data for spot, forwards, interest rates, and volatility.

• Bid/Ask Vol - uses bid/ask market data for volatility. All other types use the Mid quote.

• Bid/Ask Spot - uses bid/ask market data for spot. All other types use the Mid quote.

• Bid/Ask Spot/Fwd - uses bid/ask market data for spot and forwards. All other types use the Mid quote.

To select between one-way and two-way pricing output, use the "Output 1 or 2 way" setting in the Pricing panel.

• 1-way - displays pricing from the mid quote.

• 2-way - displays pricing using the bid and ask quote.

Sample output for two-way pricing
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To make either of these settings the default setting, point to Configuration > User Preferences in the Pricing Sheet
menu bar to open the Configure window. On the Defaults tab go to the Pricing settings, where you can configure the
"Default Rate Sides" and "Default output pricing convention" settings according to preference.

3.3.2 Requi red Market Data
The following market data items are needed to fulfill requirements for the "Default Rate Sides" settings in the Pricing
Sheet's Market Data panel when using Bid/Ask pricing.

Spot Quotes
Both bid and ask quotes are required in the Quotes window.

To open the Quotes window from the Pricing Sheet, point toMarketData > Quotes. Make sure Bid and Ask quotes are
both populated.

For details on working in the Quotes window, see "Quotes Window" in the Calypso Analytics and Pricing
Environment documentation.

Forwards and Volatility
To check for bid/ask rates in curves and vol surfaces, you can open the Market Data Manager by pointing toMarket
Data > Display in Market Data Manager in the Pricing Sheet menu bar.
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For details on working in the Market Data Manager, see "Market Data Manager" in the Calypso Analytics and Pricing
Environment documentation.

3.3.3 Recommendat ions for FX Opt ions
• For most liquid vanilla options, up to 1 year, using Bid/Ask Vol will suffice for two-way pricing given Delta is

exchanged with the counterparty at the inception. Otherwise, use Bid/Ask for all market data.

• For longer tenor Options, use Bid/Ask for all market data (since Forward and Interest rates have a bigger impact
on the pricing of long dated Options and substantial premium bid/ask spread will come from Forward/Interest rate
bid/ask spread).

• For exotics, use Bid/Ask for all market data.

3.4 Using Workspaces
You can save all trade IDs currently in the Pricing Sheet as a workspace. Saving a workspace keeps the current view
of the trades and their order. When you close and re-open the Pricing Sheet, you can open a saved workspace with all
its trades in place.

» To save as a new workspace, click the down arrow next to the button, then select Save as new Workspace.

» To save /update an existing workspace, click the button.

» To open a workspace, select PricingSheet > Open Workspace > Choose.

Select the desired workspace and click OK.

Or you can select from a list of recently opened workspaces under PricingSheet > Open Workspace.
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To clear the list, select PricingSheet > Clear Recent.

Saved workspaces are automatically added to the Trade Blotter as a blotter workspace.

Please refer to Calypso Trade Blotter documentation for details.

3.5 Applying Trade Lifecycle Actions
You can view upcoming lifecycle activity from the Calypso Navigator using Reports > Trade Diary.

Once a trade is saved and reaches a back office status, you can apply the following actions to the trade.

Select a trade, and choose one of the following from the Processing menu:

• Processing > Allocate - To allocate the trade to set of books or a set of legal entities - It brings up the Allocation
window - Help is available from that window.

• Processing > Exercise - To exercise the trade - It brings up the Exercise window - Help is available from that
window.

• Processing > Terminate - To terminate the trade - It brings up the Termination Action report - Help is available
from that window.

• Processing > Trigger - To exercise the trade - It brings up the Exercise window - Help is available from that
window.

Other trade lifecycle actions are applied as follows:

• You can reset floating rates from the Calypso Navigator using Trade Lifecycle > Reset > Rate Reset, or using the
RATE_RESET scheduled task.

• You can set the fixing between currencies from the Calypso Navigator using Trade Lifecycle > Reset > FX Rate
Reset.

• You can expire futures from the Calypso Navigator using Trade Lifecycle > Expiration & Exercise > Future
Expiry or the FUTURE_POSITION_EXPIRY scheduled task.

• You can exercise future options and ETO FX from the Calypso Navigator using Trade Lifecycle > Expiration &
Exercise > Fut Opt / ETO Exercise.

• You can compute margin calls on the clearing accounts for Futures and Future Options using the EOD_BROKER_
STATEMENT scheduled task.

3.6 Running Risk Analyses on-the-f ly
You can run risk analyses on-the-fly on the strategies, using one of the following methods:

• Choose Analysis > On Demand Analysis, and select the Ad Hoc panel - Select the input parameters and the
analysis parameters, and click Run.

• Choose Analysis > On Demand Analysis, and select the On Demand panel - Select the input parameters and
click a predefined analysis, and click Run.
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• Choose Analysis > On Demand Analysis Shortcuts, and select a risk speed button, provided you have defined
risk speed buttons for the pricing sheet - Risk speed buttons can be defined using Analysis > On Demand
Analysis Speed Buttons.

The results will be displayed in the Calypso Workstation or saved to a file, based on the selected parameters.

Refer to Calypso On Demand Analysis documentation for complete details on using the On Demand Analysis
window and defining risk shortcuts.

3.7 Using the Payoff Chart
For FX Options trades - including vanilla and exotics - the Payoff Chart provides both a graphical and tabular
representation of payoff based on the underlying. To open the chart, click on the Toolbar. The chart is
automatically populated with information from the leg or legs on the active pricing sheet.

 Ⓘ [NOTE: Only the legs that are active for "Price" will be included in the Payoff Chart. Any legs with the Price
property set to "Don't Price" will not be included in chart output.]

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



3.7 .1 Chart Sett ings

» Select the "Show Legs" checkbox to display legs separately when there are more than one. When the checkbox is
cleared, the chart displays the Total Payoff.

» Select the "Include Premium" checkbox to include the premium or fees in the chart output.

» You can use the "Buy/Sell Direction" drop-down to determine whether the chart output is the same or the
opposite direction of the Pricing Sheet.
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For details on making default settings for these options, see "Payoff Graph" under Defaults Panel in the Setting User
Preferences documentation.

3.7 .2 Graph Propert ies and Contro ls
» Right-click anywhere in the graph to open the properties and controls menu.

Menu item Description

Properties Select Properties to open the Chart Properties window where you can edit the chart's title,
design how information is plotted on the chart's axes, and make other changes to
appearance.

Copy / Save as... / Print Select Copy to copy the graph to the system clipboard, which then allows you to paste the
image using standard keyboard or mouse controls. You can also save the graph as an image
(.png file format) or print the graph by selecting Print, which opens the Page Setup then Print
dialog box.

Zoom In / Zoom Out You can zoom in or zoom out on the graph to see either more or less detail. This feature also
allows you to zoom in or out by individual axis, thereby preserving the scale of the opposite
axis.

Auto Range Select Auto Range to stretch the scale so that the plot fills the entire range of the graph. You
can stretch the plot points to the full range by individual axis as well.

» You can manually zoom in and out using the scrolling wheel on your mouse device.

» Hovering over the plot points displays a tooltip that includes the trade ID and specific values for both axes where
the plot falls on the graph.
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3.7 .3 Tabular Disp lay
Select the 'Tabular' tab to view the same output as the graph in a table format. The same chart settings apply, such as
"Show Legs" and "Include Premium."

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 50 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 51 / 359

4. Capturing Trades
This document describes all strategy properties based on their category (filter category in Profile Configuration ), and
how to capture trades using these properties.

Some properties are common to all types of strategies, they are described below.

Some properties depend on the type of strategy:

See Capturing CRD Trades for details on CRD properties.

See Capturing CMD Trades for details on CMD properties.

See Capturing EQD Trades for details on EQD properties.

See Capturing ETF Trades for details on ETF properties.

See Capturing Fixed Income Trades for details on Fixed Income properties.

See Capturing FX Trades for details on FX properties.

See Capturing FX Option Trades for details on FX Option properties.

See Capturing IRD Trades for details on IRD properties.

See Capturing Listed Derivatives Trades for details on Listed Derivatives properties.

Contents

- Trade Properties

- Manipulating Strategy Templates

- Product: Amount Properties

- Product: Style Properties

- Product: Info Properties

- Product: Rate Properties

- Product: Barrier Properties

- Product: Trigger Properties

- Product: Payment Properties

- Product: Settlement Properties

- Date Properties

- Market Data Properties

- Price Properties

- Solver Properties

- Dealt Data Properties

- Keyword Properties
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- Pricer Properties

- Product: Cliquet Properties

- Product: Chooser Properties

- Product: Commodity Properties

- Cash Settle Info

- Trade Drilldown

4.1 "Trade" Propert ies
"Trade" properties apply to all types of strategies. They allow the trades to be saved in the system with the minimum
required information.

They can be made visible under "Common" if you want to display them for all strategies.

Sample Trade properties
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Properties Description

Strategy Name This property is always displayed.

Select an out-of-the-box strategy or a custom strategy to capture the corresponding trade.

Price This property is common to all trades and set to Price by default. The settings are as follows:

• Price - Allows the trade to be priced.

• Don't Price - Prevents the trade from being priced.

Save This property is common to all trades. Its default behavior can be configured on the Defaults
tab in Configuration > User Preferenceswith the "Default behavior for Save field on
executed trades" option. The settings on the pricing sheet are as follows:

• Save - Allows the trade to be saved.

• Don't Save - Prevents the trade from being saved.

Solve This property is always displayed, and is not set by default.

To activate the solving capability, set it to Solve. It can only be set to Solve on Active trades.

Reserve This property is always displayed, and it is set to Don't Reserve by default.

The property provides support for trade reservation in the case of a single trade or multiple
trades.

• "Reserve" - Allows a trader to put a trade in a certain status that impacts the limit even
though the trade is in pre-deal status. When a trade is saved, the trade keyword
"LimitReserved" is set to Yes.

• "Don't Reserve" - When a trade is saved, the trade keyword "LimitReserved" is set to No.

The trade keyword "LimitReserved" is utilized with this feature so that the Limits engines
can determine whether or not to process a trade.

Template Select a strategy template as needed to populate default values into the strategy. You can
only select templates created for this type of strategy.

You can create strategy templates using Configuration > Manage Strategy Template.

See Manipulating Strategy Templates for details.

 Ⓘ [NOTE: The selected template is not stored with the trade, it is only selected to
populate default values]

Internal Reference Enter a user-defined trade identifier as needed, for tracking purposes.

External Reference Enter a user-defined trade identifier as needed, for tracking purposes.

Trade Id Displays the unique ID given by the system upon saving.

Trade Version Displays the trade version given by the system upon saving, "0" is the first version of the
trade. The trade version is incremented when data are amended on the trade provided the
Audit mode is enabled.
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Properties Description

Refer to Calypso Trade Version documentation for details.

Bundle ID Displays the bundle ID created upon saving if any.

You can also display the following properties:

• Bundle Type - Displays the bundle type selected upon saving if any. You can also select
a bundle type to associate the trade with an existing bundle.

• Bundle Name - Displays the bundle name create upon saving if any. You can also select
a bundle name to associate the trade with an existing bundle.

Status Displays the workflow status of the trade.

Action Displays the action currently performed on the trade based on the workflow configuration.

You can select a different action as needed, it will be applied to the trade upon saving.

Note that actions related to trade lifecycle processes are prevented by default. The actions
Allocate, Terminate, Exercise, and Trigger can be applied from the Processing menu.

Other trade lifecycle actions have to be applied from their dedicated windows and
processes.

Sales Person Select a sales representative. Sales representatives are created in the "salesPerson"
domain. It defaults to the sales representative selected in the User Defaults.

This is mandatory for capturing sales fees.

Trader Select a trader - Traders are created in the "trader" domain. It defaults to the trader selected
in the User Defaults.

Book The default trading book can be set in the User Defaults attribute "Pricing Sheet Default
Book".

You can select another book as needed. Type in a few letters, and all books that start with
those letters will appear. You can select a book from the list.

The Search can be configured from the Calypso Navigator using Configuration > User
Access Control > User Settings under Preferences > Trade Capture > Book Search:

• Favorites Only

• Favorites Then All

• All (default)
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Properties Description

For reference, favorite books are set from the Calypso Navigator under Configuration >
Favorites > Books.

Counterpart Role The counterparty role defaults to CounterParty but you can double-click to select another
role as needed. For External trades, the role set will be the role set in the for the Premium in
Trade Details > Trade Fess.

Counterparty Type in a few letters, and all counterparties that start with those letters will appear. You can
select a counterparty from the list.

The Search can be configured from the Calypso Navigator using Configuration > User
Access Control > User Settings under Preferences > Trade Capture > Counterparty
Search.

Internal Book Type in a few letters, and all books that start with those letters will appear. You can select an
internal book from the list to capture an internal mirror trade.

The Search can be configured from the Calypso Navigator using Configuration > User
Access Control > User Settings under Preferences > Trade Capture > Book Search:

• Favorites Only

• Favorites Then All

• All (default)

For Internal Trades (trades with an internal book), the trade counterparty is set to the
processing org of the internal book for the role CounterParty. Therefore, the processing org
must have the role CounterParty.

For reference, favorite books are set from the Calypso Navigator using Configuration >
Favorites > Internal Books.

Mirror Trade ID Displays the mirror trade ID.

Broker Select a broker as needed. A broker is a legal entity of role Broker.

Only favorite brokers can be selected. Favorite brokers are selected from the Calypso
Navigator using Configuration > Favorites > Brokers.
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Properties Description

Prime Broker Select a prime broker as needed. A prime broker is a legal entity of role PrimeBroker.

Only prime brokers associated with the selected counterparty in the legal entity attribute
PrimeBrokerList can be selected. You can define multiple prime brokers in the legal entity
PrimeBrokerList separated by ";" (semicolons).

Market Type Select a Market Type as needed: None, Primary, Re-Issue, Secondary, When-Issued.

Stepin Transferor Type in a few letters, and legal entities that start with those letters will appear. You can
select a legal entity of role step-in transferor from the list.

The step-in transferor is a transferor from a Step-In Novation done through DTCC.

Subsidiary Type in a few letters, and legal entities that start with those letters will appear. You can
select a legal entity of role subsidiary from the list.

Calc Agent Type in a few letters, and legal entities that start with those letters will appear. You can
select a legal entity of role calculation agent from the list.

The calculation agent is the party who acts as the referee in the event of a disagreement
about a deal's rate reset or other payment detail. The calculation agent will be designated in
a legal agreement such as an ISDA agreement.

Trader Mirror Displays the name of the trader associated with the mirror trade book.

Trade Comment Enter a comment as applicable.

Reset Swap For details on Reset Swap properties, see ""Reset Swap" Properties" on page 274.

For details on Reset Swap properties, see "Reset Swap" Properties in Pricing Sheet
Capturing IRD Trades documentation.

Fwd Start Notional
Adjustment

For details on Fwd Start Notional Adjustment properties, see ""Fwd Start Notional
Adjustment" Properties" on page 275.

For details on Fwd Start Notional Adjustment properties, see "Fwd Start Notional
Adjustment" Properties in Pricing Sheet Capturing IRD Trades documentation.

CSA Id Displays the ID of the collateral agreement associated with the selected counterparty and
book's processing org, if any.

Collateral agreements are created from the Calypso Navigator using Configuration > Fees,
Haircuts, & Margin Calls > Margin Call.

You can also display the following properties:

• Collateral Policy - Displays the currency policy of the collateral agreement.

• Eligible Currencies - Displays the list of eligible currencies of the collateral agreement.

Discount curves can be associated with trades based on the collateral currency.

Refer to Calypso CSA Details documentation for setup details.

Manual Reset Used for equity resets. Provides a field for manually entering a value for the initial fixing.
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Properties Description

Initial Reset Used for equity resets. Allows you to choose an observation source for the initial fixing.

Equity Reset Used for equity resets. Allows you to choose an observation source for the final fixing. For
the equity ScriptableOTCProduct, this property alone is used for choosing the observation
source for the multiple resets that are used.

CCP/Clearing Broker
Combos

Enter a list of clearing brokers, separated by commas.

CCP/Clearing Broker Enter the clearing broker.

Product Code You can enter product code values for OTC trades, provided you have defined “OTC”
product codes, like MiFID codes for example.

“OTC” product codes are created using Configuration > Product > Code (menu action
product.ProductCodeWindow) with “OTC” checked.

Note that this property does not display non OTC product codes. Non OTC product codes
are defined and displayed at the product level (Bond products for example).

Negotiated Price Negotiated Price is a sub-property under the expandable Notional property. Used for Swap
trades that use ZC for the payment frequency. To enable this property so that the user can
enter a negotiated price, the payment frequency for the swap must be ZC, and the para-
meter "Discount" in Default configurations (Configuration > User Preferences > Defaults >
Swap) must be set to True. See "Defaults Panel" in Setting User Preferences doc-
umentaiton.

Fixed Amount Used with Fixed Payment Swap to indicate a payment amount for the fixed leg that will be
paid at the end of the period.

Reset Date Rule Reset Date Rule

Rate Factor Round-
ing/Rate Factor Decim-
als

Both properties are sub-properties of Rate. They can be used on both fixed and float legs of
a Swap. The Rate Factor Rounding property provides standard rounding methods found in
Calypso: NONE, NEAREST, UP, DOWN. The Rate Factor Decimals property allows for
specifying decimal precision for the first setting.

• Fixed Leg - When Calc Method is EXP, rounding = (1+fixed rate)^daycount fraction, then
taken to the number of decimal places specified.

When Calc Method is NONE, rounding = fixed rate*daycount fraction, then taken to the
number of decimal places specified.

• Floating Leg - Uses multiplicative spread factor rounding. This is available under the
following conditions: compounding = true, compounding method = Flat, Calc Methond =
EXP, multiplicative spread = true.

Rounding = (1+spread)^daycount fraction, then taken to the number of decimal places
specified.

Reset Date Rule

Payment Date Rule

These properties allow for using date rules to determine a period.

• Reset Date Rule - Determines the reset dates of the cashflows. A sub-property under
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Properties Description

Coupon Date Rule the expandable Reset Frequency property.

• Payment Date Rule - Determines the payment dates of the cashflows. A sub-property
under the expandable Payment Date Roll property.

• Coupon Date Rule - Determines the interest dates of the cashflows.

These properties correspond to those found on the Date Rules tab of the product details
window accessed from the trade window.

Average Price Supported for Future and Future Option trades.

Select the Average Price checkbox to preserve the trade price without rounding, regardless
of the Quote Type or Quote Decimals specified on the given Future Option contract. Any
trade price based calculations, including Nominal and relevant pricer measures, will use the
full decimals of the trade price.

Standard Fixed
Coupon

Used in CDS Index Tranche trades.

When selected, the associated "Spread" property becomes a drop-down listing standard
SNAC coupon values. These values can be defined using the domain
CreditDefaultSwapCoupon.SNAC.

For details on using domains, see "Defining Domain Data" in Calypso Getting Started
documentation.

When the checkbox is cleared, the "Spread" property becomes a text field that allows the
user to enter any value for the spread.

4.2 Manipulat ing Strategy Templates
To create a strategy template, select a strategy in the Pricing Sheet and set the properties as needed.

Then choose Configuration > Manage Strategy Template.

Sample Strategy Template

» Enter a template name and select whether the template is private or public.

Other users will not be able to use your private templates.

» Select whether the dates should be saved as absolute dates or relative dates (they are relative to the valuation
date).
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» Then click Save as New to save the template.

The property values will be used as default values when the template is selected in the Pricing Sheet.

To store trade keywords with the template, add the keyword names to the domain "tradeTmplKeywords".

Example:

You can select the template from the Template field for the same type of strategy used to create the template.

To modify an existing template, select a template in the pricing sheet, and modify the values of the properties as
needed.

Then choose Configuration > Manage Strategy Template.

Sample template modification

» Select "Update Existing" from the Operation field and click Update Existing.

To delete an existing template, choose Configuration > Manage Strategy Template.

» Select "Delete" from the Operation field and select a template.

» Then click Delete.

Only the user who created a template (whether it is public or private) can delete it.

4.3 "Product: Amount"  Propert ies
"Product: Amount" properties apply to all types of strategies.

They can be made visible under "Common" if you want to display them for all strategies.

Sample Product Amount properties
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Properties Description

Notional Enter the notional amount.

Ccy1 Amount Enter / displays the notional in primary currency if applicable.

Ccy2 Amount Displays / enter the notional in quoting currency if applicable.

Settle Amount Displays the trade settlement amount computed by the system.

4.4 "Product:  Style"  Propert ies
"Product: Style" properties apply to all types of strategies.

Properties Description

Trade Type The trade type: "On Market" or "Off Market".

• Off Market allows the addition of Sales Margin in terms of bp or a dollar amount, which
will be represented as a Sales Margin fee.

• On Market includes the use of an off-market-rate swap, indicated by [om] in the Rate
property.

Product Type Displays the product type based on the selected strategy.

Product Subtype The product subtype is set by the system based on the type of trade being captured. You
can however define product subtypes as needed in the domain “<product type>.subtype”.
You can set pricers and market data by product subtype.

Constants Displays any value used in solving that is entered manually like Strike, etc.

Ccy Pair Displays the currency pair when each leg is in a different currency. The default currency pair
is set in Configuration > User Preferences.

You can select another currency pair as needed.

Notional Ccy Select the currency of the notional.

Strike Ccy Enter the strike currency.

Quanto Ccy Pair Only applies to "Self Quanto" or "Quanto" set as a Settle Type.

Displays the currency pair used in the Quanto. This is Settlement Ccy/Secondary Ccy in the
defined currency pair. The currency pair is defined from the Calypso Navigator in
Configuration > Definitions > Currency Definitions.

Buy/Sell Select the direction of the trade: Buy or Sell.

Put/Call Displays /select the option direction for the primary currency.

Ccy2 Put/Call Displays / select the option direction for the quoting currency.

Compound Put/Call Select the direction of the compound option for the primary currency.

Pay/Receive Select the direction of the trade leg from the book's perspective.
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Properties Description

Notional Exchange Select Initial, Final, Amortization or any combination of the three to indicate that the notional
amount will be exchanged, otherwise there is no exchange of notional.

Amortization The amortization of the notional defaults to Bullet.

Option Type Select the option type: Cap, Floor, Collar, Corridor.

Exercise Type Select the exercise type.

Settle Type Select the settlement type at exercise. The application may automatically select it based on
the product type.

• Cash - For cash settlement (exercise against a fee).

• Physical - For physical settlement (exercise against the underlying product) - A trade on
the underlying product is automatically created.

• Cleared Physical Settlement

You can also set the following properties:

• End Settlement Date - The end settlement date.

• Settlement Lag - A number of lag days, months or years, and Business or Calendar. This
is the offset between the expiration date and the delivery date.

Examples: 3D Business, 2M Calendar, 1Y Business, etc.

• Settlement Holidays - The holiday calendar.

• Settlement Date Roll - The date roll convention.

• Expiration Time Zone - The timezone of the expiration times.

• Expiration Time - The expiration time.

• Earliest Exercise Time - The earliest exercise time.

• Latest Exercise Time - The latest exercise time.

• Automatic Exercise - A checkbox to allow automatic exercise.

• Threshold - User-specified threshold in percentage to trigger the automatic exercise.

• Partial/Multiple Exercise (European swaptions only) - A checkbox to allow partial
exercise.

• Min Notional - User-specified minimum notional that can be partially exercised.

• Max Notional - User-specified maximum notional that can be partially exercised.

Leg Type Select the leg type: Fixed or Float.

Fixed Swap Tenor Enter the fixed tenor of the swap for Fixed Tenor Swaptions.

The swap starts on the option’s delivery date and ends on the option’s delivery date + fixed
tenor.

The system currently only supports the pricing of European Fixed Tenor Swaptions.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Properties Description

Location Select the location for commodities.

Allocated Displays "Allocated" if the trade has been allocated using the Allocation process, or "Unal-
located" otherwise.

Observation Type For Accrual and Accumulator options, the choices are:

• Cash Accrual

• FX Accrual

• Vanilla Fade In - Each time the spot condition is met on a fixing date, a portion of the
notional is paid. That is, on expiry date the notional is: "n/N" x "notional amount".

• Vanilla Fade Out - Each time the spot condition is met on a fixing date, a portion of the
notional is deducted from the maximum that can be used. That is, on expiry date the
notional is: "notional amount" - ("n/N" x "notional amount").

Where:

• "notional amount" is the notional amount

• n is how many times the spot satisfies the predefined condition (whether it is meant to
be above/below a predetermined trigger, or inside/outside a predetermined range) on
the predefined fixing dates

• N is the number of fixings dates over the life of the option

Strike Type Select the strike type: Fixed, Forward Start, Average or Lookback.

Rate Type Select the rate type: Market, Average or Lookback.

Range Style Select Single for single range, or Multiple for multiple ranges.

• For Single range, you can capture the range in the Trigger properties.

• For Multiple range, right-click the trade and choose "Supplemental" to define the
ranges.

Known 1st Range Select Yes if the first range is known for a resetting range, or No otherwise.

If Yes, you can specify the first range in Trigger and Trigger2.

Flexo FX Source Only applies to the "Flexo" Settle Type.

Choose the FX rate source for Flexo type trades.

Initial FX Spot Enter the FX spot trade between the two currencies.

Principal Adjustment If there is notional exchange, you can also specify notional adjustments at every coupon
period based on FX rates.

Select None, Pay (adjustments on the Pay leg), or Rec (adjustments on the rec leg).

You can also set the following properties:

• FX Reset - Select the FX rate reset to determine the FX rates for the adjustments. FX
rate resets are defined from the Calypso Navigator using Configuration > Foreign
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Exchange > FX Rate Definitions.

• Adjust First - Check to adjust the first cashflow.

• FX Reset Use Index Reset Date - Check to set the FX reset date to the index reset date.
It is the payment begin date otherwise.

If "FX Reset Use Index Reset Date" is not checked, you can set the FX Reset Lag and FX
Reset Holidays as needed.

Call Type Select "Cancellable" for a cancellable swap, or select "None".

For a Cancellable swap, you can set the following properties:

• Buy/Sell - Select Buy or Sell, the direction of the trade from the book’s perspective.

• Exercise Type - European or American

• Expiry Date - The expiration date. If a non-business day is entered, it will automatically
move to the previous business day. For European, the trade can only be canceled on the
expiration date.

• First Exercise Date - The first exercise date. For American, the trade can be canceled
between the First Exercise Date and the Expiry Date.

• Delivery Date - The delivery date defaults to the spot date for the selected currency. It
can be modified as needed.

• Settlement Lag - The number of lag days. Whether the lag days are business days or
calendar days can also be selected.

• Settlement Holidays - User selects from the holiday calendar.

• Expiry Time - The expiration time.

• Earliest Exercise Time - The earliest exercise time.

• Latest Exercise Time - The latest exercise time.

• Expiry Timezone - The corresponding timezone and holiday calendars to the Expiry
Time.

• Fee Type - A fee type

• Fee Currency - The fee currency

• Fee - The fee amount / percentage

Custom Cashflows Displays "true" if the cashflows have been customized, or "false" otherwise.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays he contract size.

Quantity Enter the traded quantity.

Contract Select the contract.
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Contract Underlying Select the expiration date of the underlying future contract.

Contract Date Select the expiration date.

Payout Displays the Pricing Script payout selected in the strategy.

4.5 "Product:   Info" Propert ies
"Product: Info" properties apply to all types of strategies.

Sample Product Info properties

Properties Description

Product ID Type Select the product ID type to choose from when entering values in the Product ID field.

A default search type can be configured in Configuration > User Preferences under the
Defaults tab. Select the default search type form the Default Bond Product ID type drop
down.

Setting this in the trade leg specifically will override the value set in the defaults.

Product ID Enter the bond product identifier.

Underlying Displays the Bond Product details for the selected bond product. To select a bond product
double-click in this field to bring up the Search Bonds window.

Current Notional Displays the current nominal.

4.6 "Product:  Rate" Propert ies
"Product: Rate" properties apply to all types of strategies.

Properties Description

Quanto Factor Only applies to "Self Quanto" or "Quanto" set as a Settle Type. Not available with Digital and
Digital with Barrier strategies.

Enter the rate between the quoting currency and the primary currency if the settlement
currency is the primary currency.

You can enter "k" to populate it with the strike rate, "s" for spot rate, or enter a fixed rate.
The trade keyword "QuantoSource" will be populated accordingly.

Strike Enter the strike.
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The following FX Delta shortcuts are also available. Add the shortcut to the Strike property
field and press Enter.

• You can enter "atm" to solve for an at-the-money forward. This gives the at-the-money
strike for the given currency pair and tenor. The premium in Delta convention and the
Delta-neutral-or-atm-forward convention are taken from the vol surface. This is the
most commonly used shortcut because it produces the "at-the-money" strike whether
it's Delta neutral or ATMF.

• You can enter "atms" to solve for an at-the-money spot. This gives the strike equal to
the current spot rate.

• You can enter "atmf" to get the strike equal to the current outright forward.

• You can enter "dn" to set the strike to the ATM delta neutral strike generated from the
supplied vol surface and expiry date.

• You can use the strike to solve for a Delta by entering "<delta value>d", for example
"25d".

• When "<delta value>s" is entered (e.g., 10s), this gives the 25-spot-delta strike, with
premium-in-delta coming from the vol surface.

• When "<delta value>f" is entered (e.g., 10f), this gives the 25-forward-delta strike, with
premium-in-delta coming from the vol surface.

• One percentage strike shortcut: "<delta value>%s" gives the strike equal to spot plus
<delta value>%. Also, "-<delta value>%s" gives the strike equal to spot minus <delta
value>%.

Rounding
Any system generated strike (solver, shortcut entry) will respect the currency pair rounding
settings. If the user manually enters a strike, it will only be rounded based on the constraints
of the currency rounding of the amounts that the strike generates.

Example: Ccy1 amount is 10,000.00 and a strike is entered as 1.234567.

• If ccy rounding of Ccy2 is 2dp then Ccy2 amount would be 12345.67. The strike does
not need to be rounded.

• If ccy rounding of Ccy2 is 0dp (JPY for example) then Ccy2 amount would be 12346 and
the strike would need to be rounded to 1.2346.

The shortcut used will not be persisted if the trade is saved. EX: Entering "atms" in this field
will calculate the at-the-money-strike and will appear as "<strike value> [atms] when
pricing. If the trade is saved, the value is saved, but the shortcut used will not be saved.

Strike % Displays the percentage of strike with respect to "in-the-money" forward: [(FX Fwd -
Strike)/ FX Fwd]*100.

Strike Inverse Displays 1/Strike for an inverted trade.

Compound Strike Enter/displays the price of the underlying option as a percentage of the underlying primary
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amount.

Compound Strike
Amount

Compound Strike Amount = Compound Strike * Ccy 1 Amount / 100.

You can also enter a compound strike amount and the Compound Strike will be updated
accordingly.

When exercising the compound option, the compound strike amount will be passed to the
created plain vanilla as PREMIUM fee.

Formula Strike Displays the formula captured in the Strike property.

Vega Displays what the Vega would be in a Vanilla option from the trade date to the number of
days calculated from the difference of the Expiry Date and the Fixing Date of the Volatility
Forward option.

VF Vol at Trade Expiry Displays the volatility at trade expiration (from the market data).

VF Vol at Straddle
Expiry

Displays the volatility at underlying expiration (from the market data).

VF Implied Forward Vol Displays the implied forward volatility.

Agreed Forward Volat-
ility

Enter the forward volatility agreed to on the trade date. The price that is agreed upon to buy
the ATM straddle. It defaults to the calculated implied forward volatility. However, you can
modify the value.

Rate Enter the fixed rate for fixed rates, or the spread over the rate value for floating rates as
needed.

Fixed Coupon Rate For a fixed trade, enter the fixed rate.

Settlement Source Only applies if Settle Type is Physical NDF, Self Quanto, Quanto, or Flexo.

Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

Settlement Source
Time

Displays the fixing time of the selected fixing source.

Settlement Source
Quote Side

Displays the quote side of the selected fixing source.

Settlement Source Fix-
ing Rate

Displays the fixing rate of the selected fixing source, if any on the fixing date and if there is
only one fixing date.

Observation Source Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

Then right-click the FX Rate Definition and choose "Supplemental" to define the accrual
details.

Observation Source
Time

Displays the fixing time of the selected fixing source.
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Observation Source
Quote Side

Displays the quote side of the selected fixing source.

Observation Fixing
Rate

Displays the fixing rate of the selected fixing source, if any on the fixing date and if there is
only one fixing date.

Reset Source Select "Not resetting" for non-resetting ranges, or select the FX Rate Definition that will be
used to fix the rates. FX Rate Definitions are configured from the Calypso Navigator using
Configuration > Foreign Exchange > FX Rate Definitions.

Then right-click the FX Rate Definition and choose "Supplemental" to define the fixing
schedule.

Reset Source Time Displays the fixing time of the selected fixing source.

Reset Source Quote
Side

Displays the quote side of the selected fixing source.

Reset Fixing Rate Displays the fixing rate of the selected fixing source, if any on the fixing date and if there is
only one fixing date.

Rate Index Factor Enter the index factor as needed for floating rates to multiply the rate value.

Rate Index Select the rate index for floating rates.

You can set additional properties:

• Reset Timing - Select "At Start" or "In Arrears".

• Reset Lag - Enter the number of days between the actual reset date and the reset date
as defined by the reset timing, and specify Business or Calendar.

The Reset Lag will persist is terms of days. Entering "30D" and saving will be displayed
as "1M" on retrieval. Entering "d" for days, "w" for weeks, "m" for months and "y" for
years as a tenor (EX: 1m b = -1M Business) will be saved as days.

If not tenor is entered, the system will use days by default.

• Reset Holidays - Select the reset calendars.

• Reset Date Roll - Select the reset date roll.

• Spread as Multiplier - Check this checkbox to have a multiplicative spread rather than
an additive spread.

• Manual First Rate - Enter the first reset rate, if any.

• Specify Initial Inflation - Select "None", "Initial Level Date" or "Initial Level".

• Initial Level Date - Enter the initial level date.

• Initial Level - Enter the initial level.

• Inflation Calculation Method - Select the calculation method:

– IndexLevel - Index levels are not interpolated between publication dates.
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– Interpolated - Daily index levels are interpolated between reference dates. Select
the interpolation method from the Inflation Interpolated Method field.

• Inflation Interpolated Method - Only appears for the Interpolated calculation method.
The only option is "Weighted".

• Rate Rounding - Select the rate’s rounding method to override the default value from
the rate index.

• Rate Decimals - Enter the number of decimal places to override the default value from
the rate index.

• Sample Timing - Select the sample timing: "At Start" or "In Arrears".

• Convert Basis - Check this checkbox to check whether the reference index and the
trade have the same daycount convention. If not, the rate’s daycount convention is
converted to the trade’s daycount convention.

• Rate Interpolation - Select "Interpolate" to interpolate the fixing rate. The rate is
interpolated using the tenors specified in "Interpolate Tenor 1" and "Interpolate Tenor 2".

• Manual Initial Fixing - Provides options to manually control the behavior of the initial rate
reset. Use the drop-down to select either 1st Rate or Init Fixing Date.

– 1st Rate - When selected, this enables the Manual First Rate property. You can
then manually enter a rate for the first fixing.

– Init Fixing Date - When selected, this enables the Initial Fixing Date Roll, Initial
Fixing Holidays, and Initial Fixing Lag properties. These properties allow you to
specify the date roll convention, the holiday schedule for the fixing, and lag
settings.

When NONE is selected (default), the system uses the normal reset process for fixings.

Reset Frequency Select the reset frequency to sample resets at a frequency different from the payment
frequency. Otherwise, the resets are sampled at the payment frequency.

When the sampling frequency is more frequent that the payment frequency, you can define
the weight of the resets, and the duration of the sampling period.

• Reset Weighting - Select "Equal", "Weighted" or "Simple".

• Reset Day of Week - For Weekly, you can set the Reset Day of Week.

• Reset Day of Month - For Monthly, you can set the Reset Day of Month.

• Reset Cutoff Lag - The cutoff lag.

• Reset Duration:

– Match - Rates are sampled over the entire averaging period.

– Custom - Rates are sampled over a user-defined period.

• Custom Sample Period - Define the number of days of the sampling period.
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• Reset Stub - Select "Start" or "End".

Reset Date Only applies to Physical NDF settle type.

Displays "Delivery Date - Number of lag days defined in the FX Rate Definition".

It is based on the FX Rate Definition selected in Settlement Source.

It can be modified as needed.

4.7 "Product:  Barr ier" Propert ies
"Product: Barrier" properties apply to all types of strategies.

Sample Product Barrier properties

Properties Description

Barrier Duration Select the duration type:

• EXPIRY - The barrier is only observed on the expiry date. You can define multiple
volatilities. The VOLATILITY1 and VOLATILITY2 pricing parameters correspond to the
volatilities for the upper and lower barriers. Enter the volatility for the barrier if desired.
Otherwise, the pricer uses the volatility from the surface if you do not specify one in the
pricing parameters. To use the same volatility as the strike, manually enter that value in
the pricing parameters.

• FULL - The barrier is observed throughout the life of the option. The start date of the
observation is the trade date; the end date of the observation is the expiry date.

• PARTIAL - Enter the start and end dates for the observation, which can be less than the
life of the option. Enter values for Barrier/Barrier2 Start and Barrier/Barrier2 End dates.

• MULTI_PERIOD - The barrier is observed over multiple periods. Right-click a barrier
trade and choose "Supplemental" from the popup menu.
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Barrier Description Displays the description of the barrier type.

Barrier Type Select the type of barrier:

• UI - Up In

• DI - Down In

• UO - Up Out

• DO - Down Out

• DKI – Up In Down In

• DKO - Up Out Down Out

• KIKO (UI) – KIKO Up In Down Out - Knock into a UI barrier option

• KIKO (DI) - KIKO Up Out Down In - Knock into a DI barrier option

Barrier Strike rate for the single barrier, or upper barrier for a double barrier.

Barrier Start Date For a partial barrier: the start date of the barrier observation.

You can also set the Barrier Start Time.

Barrier End Date For a partial barrier: the end date of the barrier observation.

You can also set the Barrier End Time.

Barrier2 Strike rate for the lower barrier.

Barrier2 Start Date For a partial double barrier: the start date of the second barrier observation.

You can also enter the Barrier2 Start Date.

Barrier2 End Date For a partial double barrier: the end date of the second barrier observation.

You can also set the Barrier2 End Time.

Rebate Enter a rebate amount, if applicable.

You can also set the following properties:

• Rebate Ccy - Select the currency for the rebate.

– Primary Currency - Asset-or-Nothing

– Secondary Currency - Cash-or-Nothing

– Quanto Currency - When Settle Type is specified as Quanto and the Settle Ccy
property is populated with a third currency, the Rebate Ccy can also be set as the
Quanto currency.

• Rebate Timing - Select Expiry (rebate at expiration), or INSTANT (rebate when the
barrier is hit).

Barrier Monitoring Enter the barrier monitoring type, CONTINUOUS or CLOSING.
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4.8 "Product:  Tr igger" Propert ies
"Product: Trigger" properties apply to all types of strategies.

Sample Product Trigger properties

Properties Description

Trigger Duration Select the duration type:

• EXPIRY— The trigger is only observed on the expiry date. You can define multiple
volatilities. The VOLATILITY1 and VOLATILITY2 pricing parameters correspond to the
volatilities for the upper and lower triggers. Enter the volatility for the digital if desired.
Otherwise, the pricer uses the volatility from the surface if you do not specify one in the
pricing parameter. To use the same volatility as the strike, manually enter that value in
the pricing parameter(s).

• FULL— The trigger is observed throughout the life of the option. The start date of the
observation is the trade date; the end date of the observation is the expiry date.

• PARTIAL — Enter the start and end dates for the observation, which can be less than
the life of the option. Enter values for Trigger/Trigger2 Start and Trigger/Trigger2 End
dates.

Trigger Description Displays the description of the trigger type.

Trigger Type Select the trigger type.

For Digital options, the choices are:
• OT UP - One Touch Up

• OT DN - One Touch Down
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• NT UP - No Touch Up

• NT DN - No Touch Down

• DOT - Double One Touch

• DNT - Double No Touch

• OTNT (UI) - One Touch No Touch UI

• OTNT (DI) - One Touch No Touch DI

For Digital With Barrier options, the choices are ABOVE or BELOW.
For Accrual options and Accumulator options, the choices are:
• ABOVE - Payout occurs when the spot rate is above the trigger.

• BELOW - Payout occurs when the spot rate is below the trigger.

• IN - Payout occurs when the spot rate is within in the trigger range.

• OUT - Payout occurs when the spot rate is out of the trigger range.

Payout Type Select Instant (payout when the trigger is hit) or Expiry (payout at expiration).

Trigger Digital and European Binary options:
Enter the strike rate for the single trigger, or upper trigger for a double digital.

Accrual and Accumulator options:
Enter the trigger for ABOVE and LOW options, or low trigger for a range.

Trigger Start Date Enter the start date of observation for a partial digital.

Trigger End Date Enter the end date of observation for a partial digital.

Trigger Spread In case of resetting range, enter the upper spread for single range.

Trigger Included Accrual options:
For ABOVE and BELOW accruals, select Yes to monitor the trigger, or No otherwise.

Range Accruals:
Select Yes to monitor the upper value of the range, or No otherwise.

Trigger2 Digital and European Binary options:
Enter the strike rate for the lower trigger.

Accrual options and Accumulator options:
Enter the high trigger for a range.

Trigger2 Start Date Enter the start date of second trigger observation for a double partial digital.

Trigger2 End Date Enter the end date of second trigger observation for a double partial digital.
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Trigger2 Spread In case of resetting range, enter the lower spread for single range.

Trigger2 Included Range Accruals:
Select Yes to monitor the lower value of the range, or No otherwise.

4.9 "Product:  Payment" Propert ies
"Product: Payment" properties apply to all types of strategies.

Sample Product Payment properties

Properties Description

Payment Frequency Select the payment frequency.

Payment Day Count Select the payment daycount.

Payment Date Roll Select the payment date roll, when the payment date falls on a non business day.

You can also set the following properties:

• Payment Timing - Select "At Start" or "In Arrears".

• Payment Interest Calculation

– For payment timing "In Arrears", select EXP for an exponential interest calculation,
or NONE otherwise.

– For payment timing "At Start", select DISC for discounting, or NONE otherwise.

• Payment Accrual - Select the adjustment method of the accrual period:

– ADJUSTED - Adjusts the period’s end date if it falls on a non-business day,
according to the payment date roll convention. Rolling the end date adjusts the
period length, so a rolled date changes the interest amount.

– UNADJUSTED - Does not adjust the period’s end date for non-business days.

– MAT_UNADJUSTED - Adjusts the period’s end date if it falls on a weekend unless it
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is the last period (maturity), in which case it is not adjusted. Thus the adjustment
method may affect intermediate interest amounts, but it does not change the
maturity date.

– FRN - Adjusts the period’s end date for non-business days to the next business
day unless the next business day is in the following month, in which case it uses
the preceding business day.

• Payment Holidays - Select the payment calendars to determine business days for the
cashflow payment date (accrual start date).

• Settle Holidays - Select the settlement calendars to determine business days for the
cashflow settlement dates.

• Payment Lag - Enter the number of days between the interest date and the payment
date, and specify Business or Calendar.

The Payment Lag will persist is terms of days. Entering "30D" and saving will be
displayed as "1M" on retrieval. Entering "d" for days, "w" for weeks, "m" for months and
"y" for years as a tenor (EX: 1m b = -1M Business) will be saved as days.

• Payment Day - Select to enter payment details. This makes a field available next to the
Day label where you can specify which day the payment should take place. For example,
enter “5” to specify that the payment date occurs on the 5th of the month following the
swap end date.

• Payment Roll Day - Select a date roll adjustment to adjust the date, or none otherwise.

– DAY - Enter a fixed day of the month to which the date will be rolled. For example,
entering “5” forces the payment date to be on the fifth calendar day of the month.
Entering “31” indicates the last day of the month, even for months with fewer than
31 days - The selection changes to EOM.

– IMM - The payment date is rolled according to the IMM_WED date roll convention
by default. If the date roll convention is IMM_MON, then the payment date is rolled
according to the IMM_MON date roll convention.

– EOM - The last day of the month, regardless of the number of days in the month.

• Payment Rounding - Select the rounding method.

• Payment Begin Date Roll - Select a date roll for the start date.

• Payment Begin Holidays - Select a holiday calendar for the start date.

• Payment End Date Roll - Select a date roll for the end date.

• Payment End Holidays - Select a holiday calendar for the end date.

• Extra Day in First Period - Check to add a day to the first payment period. The system
uses the daycount (nominator+1)/denominator on the first cashflow - For example
ACT+1/360.

• Extra Day in Last Period - Check to add a day to the last payment period. The system
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uses the daycount (nominator+1)/denominator on the last cashflow - For example
ACT+1/360.

Exclude First Check to exclude the first caplet from the cashflows.

Cash Settle Method Only applies to cash settlement.

Select the settlement method to compute the settlement amount.

[NOTE: If you have defined cash settlement defaults (CSD), it will pick up the settlement
method from the CSD defined for the agreement specified in domain
"CashSettleDefaultsAgreements" / rate index / currency - It is ANY by default.

For example, ANY is defined in domain "CashSettleDefaultsAgreements", and you have a
CSD defined for ANY / LIBOR / USD. If the trade is LIBOR / USD and settles in Cash, then the
settlement method from the CSD will be set on the trade by default]

You can set additional properties:

• Valuation Date - Defaults to the Expiration Date.

• Valuation Lag - Enter the number of days between the valuation date and the cash settle
payment date.

• Valuation Holidays - Select the holiday calendar.

• Cash Settle Payment Date - Defaults to the Delivery Date.

• Cash Settle Currency - Select the currency of the settlement amount.

• Rate Source - You can select a rate source or none (empty). Rate sources are defined in
the "RateSource" domain.

If you select none, you have to select a set of reference banks in Rek Bank 1, Ref Bank 2,
Ref Bank 3, Ref Bank 4, Ref Bank 5 - Legal entities of role ReferenceBank.

If you select OTHER_SOURCE, you need to select a rate index in Cash Settle Rate Index.

• Quotation Rate - Select the instance of the quotation rate that you want to use: MID, BID,
or ASK.

• Settle Rate - Displays the settlement rate used to compute the settlement amount for
the cash settlement methods “Par Yield Curve - Adj.” and “Par Yield Curve - Unadj.”.

In the Option Exercise Window, there is a Settlement Rate field. You can get the value
from the pricing environment by clicking Price, or you can enter a value. If you enter a
rate, it will be displayed here.

• Cash Settle Location - Select the ISDA location.

Stub Type Select the stub period, if applicable, or none.

You can also set the following properties:

• Stub Tolerance - Enter the number of days of stub tolerance.

• Stub First Date - Enter the end date of the first period for SPECIFIC FIRST and SPECIFIC
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BOTH.

• Stub Last Date - Enter the start date of the last period for SPECIFIC LAST and SPECIFIC
BOTH.

• Stub Full Coupon Date - Enter the full coupon date for FULL COUPON.

• First Stub Interpolation - Select Interpolate to interpolate on the first period, or none
otherwise.

Choose Help > View Help for complete details.

• First Stub Tenor 1 - Select the first index tenor for interpolation of the first period.

• First Stub Tenor 2 - Select the second index tenor for interpolation of the first period.

• Last Stub Interpolation - Select Interpolate to interpolate on the last period, or none
otherwise.

Choose Help > View Help for complete details.

• Last Stub Tenor 1 - Select the first index tenor for interpolation of the last period.

• Last Stub Tenor 2 - Select the first index tenor for interpolation of the last period.

• Interpolated Rate Rounding - Select the stub rate’s rounding method.

• Interpolated Rate Decimals - Enter the number of decimal places for interpolated rate
rounding.

• Interpolation Style - Select the interpolation style:

– Index Based - The DateRoll, the holidays and the daycount are coming from the
rate index.

– Product Payment - The DateRoll, the holidays and the daycount are coming from
the coupon panel.

Choose Help > View Help for complete details.

Compounding Type Select the compounding type, if applicable, or none.

You can also set the following properties:

• Compounding Frequency - Select the compounding frequency. The compounding
frequency must be more frequent than the payment frequency.

When you select a DLY compounding frequency for a rate index that is not setup for
daily compounding, the DailyCompound calculator is used.

• Compounding Spread - Enter the spread.

• Compounding Stub - Enter the stub period on compounding period if any. Only applies to
LUN(R), BIWK(R), WK(R) compounding frequencies.

• Use Rest Period Dates - Check to compound trades based on the reset dates rather than
the payment dates.
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Properties Description

Initial Comp Calc
Notional

Compounding trades only.

When doing a partial termination, the PRINCIPAL transfer takes into account the part of
interest that is not capitalized.

On the new trade, you can adjust the initial compounding notional as needed.

Previously Accrued
Interest

Compounding trades only.

Displays the amount of interest that is not capitalized on the new trade resulting from a
partial termination.

Interest Amount Displays the interest amount of a zero coupon Fixed Rate upon pricing.

Factor Bond futures only.

Displays the cheapest to deliver factor.

Strike Included You can set the following properties:

Physical Delivery Holidays - Select the calendar(s) the application uses to determine the
business days.

Physical Delivery Lag - Specify lag days from the end date of the payment period (in
business or calendar days) for the actual payment to take place. By default, business days
are used to calculate the payment date. To specify calendar days, double-click the Bus label
to toggle to Cal.

Physical Delivery Day - Number of delivery days.

4.10 "Product:  Sett lement" Propert ies
"Product: Settlement" properties apply to many types of strategies. Only relevant settlement fields will be editable for
each property.

Properties Description

Settle Ccy Displays the settlement currency.

Calculation Ccy Select the intermediate currency to convert notional currency to settle currency. Enter:

• Calculation FX Rate

• Calculation FX Source

• Calculation FX Reset Lag

• Calculation FX Reset Holidays

Next Coupon Displays the date for the next coupon payment.

Settlement Amount Displays the settlement amount in the settlement currency.

Settlement Principal Displays the settlement principal.
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Properties Description

Settlement Accrual Displays the settlement accrual.

Accrual Days Accrual Days displays the number of days accrued in a bond's current coupon period (Set-
tlement Date - current coupon Start Date). This property is used with strategies that include
an underlying bond.

4.11 "Date"  Propert ies
"Date" properties apply to all types of strategies. Only relevant date properties will be available for applicable
strategies.

Properties Description

Trade FX Date Displays the trade date adjusted by the 5pm rule if set.

Trade Date Displays the valuation date set in the Pricing window of the pricing sheet by default.

You can modify as needed.

See Using the Pricing Sheet documentation for details.

Trade Time Displays the valuation time set in the Pricing window of the pricing sheet.

You can modify as needed.

See Using the Pricing Sheet documentation for details.

Settlement Date Select the settlement date.

Start Date Enter the start date.

End Date Enter the end date.

Expiry Date Enter the expiration date.

Expiry Displays expiration date details.

Expiry Cut Displays the default expiry timezone. The default expiry timezone is set in the Defaults panel
under Configuration > User Preferences.

Expiry Delivery Link Select one of four options in the list:

• On - Links the delivery date to the expiration date using the default set for the currency
pair, so that when one is updated, the other one is updated accordingly.

• Off - The delivery date and expiration are independent of each other.

• Equal - The delivery date and expiration date are made to equal each other.

• T+1 - The delivery date follows one day after the expiry date.

Compound Expiry Date Enter the expiry date of the compound option.

Compound Expiry Displays details about the "Compound Expiry Date".

Compound Expiry Cut Displays the default expiry timezone for the compound option. The default expiry timezone
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Properties Description

is set in the Defaults panel under Configuration > User Preferences.

Compound Term Displays the "Compound Expiry Date" as a tenor.

Compound Delivery
Date

Enter the delivery date of the compound option.

Compound Delivery Displays details about the "Compound Delivery Date".

Delivery Date The delivery date of the option. You can modify as needed.

Delivery Displays details on the delivery date.

Alternate Delivery Date Used for FX, FX Forward, and FX Swap strategies.

The Alternate Delivery Date allows you to settle the secondary currency in an FX trade on a
different date from the Trade Date. When a date is entered in this field, the secondary
currency will be settled on the entered date and the primary currency is settled on the Trade
Date. For a swap trade, the near leg Alternate Delivery Date should not be before the Trade
Date, and the far leg Alternate Delivery Date shouldn't be before the near leg Delivery Date.

For further details on this property, see "Alternate Settle Date" in the Calypso Deal Station
Trade Entry documentation.

Trade Term Displays the expiry date as a tenor.

First Exercise Date Enter the first date the option can be exercised for American options.

Reset Effective Date Enter the date at which the strike will be known.

VF Straddle Expiry
Date

Enter the expiration date of the underlying option (straddle).

VF Straddle Term Displays the "VF Straddle Expiry Date" as a tenor.

VF Straddle Cut Select the expiry timezone for the expiration date of the underlying option (straddle). Expiry
timezones are created from the Calypso Navigator using Configuration > Definitions >
Expiry Time Zone.

Fixings Displays the number of fixings for averaging the rate or strike.

You can also view the following properties:

• Schedule Start Date - The schedule start date.

• Schedule End Date - The schedule end date.

• Schedule 2 Start Date - The schedule start date.

• Schedule 2 End Date - The schedule end date.

• Payment Frequency Type - The payment frequency type.

• Fixing Policy - The fixing policy.

• Fixing Frequency - The fixing frequency.
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Properties Description

• Fixing Calender - The fixing calendar.

• Fixing Time Zone - The global time that the commodity reset is expected to be known.
This can be, but doesn't have to be, the time zone of the actual exchange or publication.

• Fixing Time - The global time that the commodity reset is expected to be known.

• First Contract - Only available to payment frequency types FutureContractFND or
FutureContractLTD.

Displays the first underlying futures contracts that will be used as fixing references.

• Last Contract - Only available to payment frequency types FutureContractFND or
FutureContractLTD.

Displays the last underlying futures contracts that will be used as fixing references.

• Intraday Policy - The Intraday Policy to be used.

• DST Name - The daylight savings.

Cash Date Enter the cash date.

Effective Date Enter the effective date.

4.12 "Market Data" Propert ies
"Market Data" properties apply to all types of strategies. Only relevant market data field will be editable for each
property.

Sample Market Data properties

Properties Description

Credit Spread (5Y) Enter a credit spread value for a 5 year tenor.

• Recovery Rate - Enter the recovery rate. This value will be used if no recovery rate for
the counterparty is found.

Volatility Displays the volatility based on the market data associated with the selected pricing
environment. You can modify this value.

FX Spot Displays the spot rate from the quote set associated with the selected pricing environment.
You can modify this value.
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Properties Description

Location Spread Displays the commodities location spread.

Adjusted FX Spot Displays the spot adjusted of location spread.

Fwd Points Displays the forward points based on the market data associated with the selected pricing
environment. You can modify this value.

You can compute forward points on-the-fly based on "Ccy 1 Rate" or "Ccy 2 Rate".

You can also compute "Ccy 1 Rate" based on forward points - Choose Configuration > Rate
Triangulation > Adjust Ccy 1 Rate. It will keep "Ccy 2 Rate" constant.

Or you can compute "Ccy 2 Rate" based on forward points - Choose Configuration > Rate
Triangulation > Adjust Ccy 2 Rate. It will keep "Ccy 1 Rate" constant.

FX Fwd Displays the forward rate based on FX Spot and Fwd Points.

Ccy 1 Rate Displays the interest rate of the primary currency based on the market data associated with
the selected pricing environment. You can modify this value.

Ccy 2 Rate Displays the interest rate of the quoting currency based on the market data associated with
the selected pricing environment. You can modify this value.

Spot Fixing price. Displays the closing rate of the underlying.

Spot Reference Displays the fixing price. Spot Rate as effective date.

4.13 "Price" Propert ies
Price properties apply to all types of strategies. Only relevant price properties will be available for applicable
strategies.

Properties Description

Exercise Fee Type For Swaptions, select a premium fee type: Amount or %.

Exercise Fee For Swaptions, enter the premium fee amount or %.

Premium Date Displays the premium payment date. The system uses the spot date by default. You can
change this to a forward date. If you use a forward date, the application adjusts the premium
amount using the discount curve from the selected pricing environment.

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.
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Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Price Format Select the currency and unit amount of the prices.

The unit amount defaults to the price format specified under Configuration > User
Preferences.

Model Premium Displays the theoretical premium computed by the pricer.

Model Price Displays the unit amount of model premium based on the selected Price Format.

You can also view the following properties:

• Model Ccy1 %

• Model Ccy1 Pips

• Model Ccy2 %

• Model Ccy2 Pips

If the Rate Side is Bid/Ask, you will see Bid/Ask prices displayed instead of the mid price.

Trader Premium Displays the theoretical premium computed by the pricer. You can modify its value.

Trader Price Displays the unit amount of trader premium based on the selected Price Format.

You can also view the following properties:

• Trader Ccy1 %

• Trader Ccy1 Pips

• Trader Ccy2 %

• Trader Ccy2 Pips

If the Rate Side is Bid/Ask, you will see Bid/Ask prices displayed instead of the mid price.

Customer Premium Displays the premium amount such that Customer Premium = Sales Premium + Trader
Premium.

Displays the customer premium such that:

• Customer Premium = Trader Premium + Sales Premium (Sell)

• Customer Premium = Trader Premium - Sales Premium (Buy)

The customer premium is the actual fee that will be paid/received.

Sub-properties for FX Options
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Properties Description

The Customer Premium property for FX Options includes two sub-properties for specifying a
third-party legal entity, or beneficiary, as the recipient. This allows for successful generation
of new transfers to the beneficiary from the Pricing Sheet strategy.

Premium Legal Entity - Select a legal entity as the recipient for the premium. Legal entities
are those defined in the Legal Entity window.

Premium Legal Entity Role - Select a role for the legal entity. Legal entity roles are the same
options provided in the "Role(s)" field of the Legal Entity window.

Customer Price Displays the unit amount of customer premium based on the selected Price Format.

You can also view the following properties:

• Customer Ccy1 %

• Customer Ccy1 Pips

• Customer Ccy2 %

• Customer Ccy2 Pips

If the Rate Side is Bid/Ask, you will see Bid/Ask prices displayed instead of the mid price.

Customer Fee Ccy Select the currency of the customer premium. It can be different from the primary and quot-
ing currencies.

Customer Fee Displays the customer premium in customer fee ccy.

You can also display:

• Customer Fee FX Rate - You can edit the FX rate between the fee currency and the
currency of the Price Format as needed.

• Customer Fee Ccy Pair - Displays the currency pair between the fee currency and the
currency of the Price Format.

• Customer Fee FX Spot Rate To Base - Displays the FX rate between the fee currency
and the base currency of the pricing environment.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.

Sales Premium Displays the Sales Fee in premium currency.

Sales Fee This property is only enabled if a Sales Person is selected. Enter the sales fee amount.

Upon saving, a fee is created. The fee type depends on the product types: FXOPT_MARGIN
for FX options, SPOT_MARGIN and FAR_MARGIN for FX, and CA_SALES_MARGIN for all
other product types.

Please refer to Calypso Fees documentation for configuring sales margins.

You can also display:

• Sales Fee Date - The date of the sales fee.

• Sales Fee Ccy - The default sales fee currency, if any. The default sales fee currency is
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set in the Defaults panel under Configuration > User Preferences. Another sales fee
currency can be entered as needed.

• Sales Fee FX Rate - The FX rate between the premium currency and the sales fee
currency in case they differ. It is automatically populated if a real-time feed is setup. If
the FX rate between the premium currency and the sales currency changes, user can
elect to recompute the premium or the sales fee using the parameter "On Sales Fee FX
Rate change" in the Defaults panel under Configuration > User Preferences.

The MarginFXRate trade keyword stores the rate used in the conversion.

Sales Location You can select the location of the sales representative. The sales location is a legal entity of
role SalesLocation. The sales fee is paid to that legal entity if selected.

If the sales location is not selected, the sales fee is paid to the counterparty of the trade if
the domain "DefaultSalesMarginFeeLE" contains the value "UseTradeCptyAsDefault".

Otherwise, it is paid to the "NONE" counterparty.

Modified Strike Displays the strike.

Negotiated Price Type Displays the negotiated price type.

Clean Price Enter the clean price (value of bond - accrued interest).

Dirty Price Enter the dirty price (value of bond + accrued interest).

Gross Price Displays inflation adjusted price. This value is for Inflation Bonds only.

Yield Enter the yield to maturity based on bond inputs.

4.14 "Solver" Propert ies
"Solver" properties apply to all types of strategies. They are only populated when solving is applied, and are not
editable.

Sample Solver properties
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Properties Description

Solve Variable Displays the property to solve for.

Solve Marking Displays "Solve" for custom solving.

Refer to Calypso Solving documentation for complete details on using the solving
capabilities.

Solve Variable Result Displays the value of the solved property.

Solve Target Displays the target property.

Solve Target Value Displays the target value that you want to obtain.

Solved Target Value Displays the computed target value.

Solve Distribution Displays the distribution method selected when solving for multiple trade.

Solve Strike Shortcut Displays the solving shortcut applied to the Strike if any.

Solve Rate Shortcut Displays the solving shortcut applied to the Rate if any.

Distributed Target
Value

Displays the distributed target value when solving for multiple trades.

4.15 "Dealt Data" Propert ies
"Dealt Data" properties apply to all types of strategies. They are only populated on saved trades, and are not editable.

Sample Dealt Data properties

Properties Description

Deal Spot Date Displays the spot date saved with the trade.

Dealt Fwd Rate Displays the forward rate saved with the trade.

Dealt Fwd Points Displays the forward points saved with the trade.

Dealt Ccy1 Rate Displays the interest rate of the primary currency saved with the trade.

Dealt Ccy2 Rate Displays the interest rate of the quoting currency saved with the trade.
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Dealt Spot Rate Displays the spot rate saved with the trade.

Dealt Location Spread Displays the commodities location spread.

Dealt Volatility Displays the volatility saved with the trade.

Dealt Model Price Displays the model price saved with the trade.

Dealt Model Premium Displays the model premium saved with the trade.

Dealt Pricing Model Displays the pricing model saved with the trade.

4.16 "Keyword" Propert ies
"Keyword" properties apply to all types of strategies.

Properties Description

@<trade keywords> These properties refer to trade keywords. The list of available keywords depends on which
keywords are defined in your system.

Enter values for trade keywords as needed.

When you add a trade keyword to domain “PricingSheetKeyword.Boolean”, it will appear as
a checkbox in the pricing sheet.

When you add a trade keyword to domain “PricingSheetKeyword.Date”, it will allow
selecting a date from a calendar.

Refer to Calypso System Keywords documentation for a description of out-of-the-box
keywords.

4.17 "Pricer" Propert ies
"Pricer" properties apply to FX Option strategies.

Properties Description

Pricer.<property> These properties display values computed by the pricers.

Pricer.Spot Spot rate used for pricing the option.

Pricer.Pts FX forward points for the Delivery Date from discount curves/FX curve. Is based on FX_
POINTS=true/false.

Pricer.Fwd FX forward rate for the Delivery Date.

Pricer.SpotDf1 Ccy1 df (Spot Date, Valuation Date).

Pricer.SpotDf2 Ccy2 df (Spot Date, Valuation Date).

Pricer.Df1 Ccy1 df (Delivery Date, Valuation Date).
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Properties Description

Pricer.Df2 Ccy2 df (Delivery Date, Valuation Date).

Pricer.SpotDate Spot Date based on the currency pair, pricing environment, time zone, Day Change Rule,
and system date/time.

Pricer.PrimDepoRt Ccy1 forward rate (Spot Date to Delivery Date) with DCF as per currency default with no
compounding up to one year - beyond one year, compounded annually.

Pricer.SecDepoRt Ccy2 forward rate (Spot Date to Delivery Date) with DCF as per currency default with no
compounding up to one year - beyond one year, compounded annually.

Pricer.ATMVol ATM vol interpolated from the FX vol surface that respects the market conventions as
defined in the surface. This is computed for display only and is not used in the pricer cal-
culations.

Pricer.RRVol The volatility of the 25 delta call minus the volatility of the 25 delta put of a RR: Vrr = Vcall –
Vput.

Pricer.BFVol The average of the volatility of the 25 delta call and the volatility of the 25 delta put minus
the ATM vol: Vbf = 0.5*(Vcall + Vput) - Vatm.

Pricer.STVol The average of the volatility of the 25 delta call and the volatility of the 25 delta put: Vst =
0.5*(Vcall + Vput).

Pricer.TimeToExp (Expiry Date – Spot Date)

Pricer.FXDate Valuation Date for the currency pair, taking into consideration the Valuation Date/Time and
the Day Change Rule specified in the pricing environment.

Pricer.ValDatetime The Valuation Date/Time based on the Time Zone specified in the pricing environment.

4.18 "Product:  Cl iquet" Propert ies
"Product: Cliquet" properties apply to all types of strategies.

Properties Description

Participation Enter the percentage of the return to return to the user.

Initial Coupon Enter the Initial Coupon. It is used as a base coupon that period returns are added to.

Global Cap The maximum return for the payoff.

Global Floor The minimum return for the payoff.

Local Cap The maximum return for any given reset period.

Local Floor The minimum return for any given reset period.
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4.19 "Product:  Chooser" Propert ies
"Product: Chooser" properties apply to all types of strategies.

Properties Description

Compound Settlement Type Enter Cash or Physical.

4.20 "Product:  Commodity" Propert ies
"Product: Commodity" properties apply to all types of strategies.

Sample Product Commodity properties

Properties Description

Averaging Method Select a method for averaging the rates used in fixing.

Please refer to Calypso Commodity Averaging Methods documentation for more details.

Averaging Rounding
Method

Select the rounding method.

Cheapest to Deliver Enter the cheapest to deliver amount.

Delivery Location This is the delivery location for storage based commodities. It is populated from the Com-
modityLocation domain value. The pricer recognizes the delivery location and prices the for-
ward according to the relevant location differentials.

Quantity Units Unit of measure that the quantity represents. You can use a different unit type than the unit
in the product definition. The quantity unit defaults to the unit defined in the commodity
definition. If a unit other than the default unit is chosen, the application requires a
conversion definition to correctly convert the units for the cashflows. Commodity positions
are always kept in the default unit in the Position Keeper.

Define the conversion definition in the Calypso Navigator using Configuration >
Commodites > Commodity Conversion.

Quote Units The commodity unit in which the reference price is quoted, i.e. USD/Barrel.

Price Underlying Price of the underlying product.

Total Quantity Displays the total quantity units over the life of the trade.
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Properties Description

Custom FX Rounding
Decimals

When populated, FX rates will be rounded to a custom number of decimal points; otherwise,
default rounding from the currency pair definition will be applied.

Custom Price Round-
ing

Enter the number of decimals to use when calculating the settlement price. Using this prop-
erty at the trade level overrides the setting at the commodity level.

4.21 Cash Sett le Info
Cash Settle Info allows defining a termination schedule (or break clauses) for a trade.

You can specify default cash settlement values by agreement / rate index / currency from the Calypso Navigator
using Configuration > Interest Rates > Cash Settlement Defaults.

Right-click a trade and choose "Supplemental" to determine cash settle info.

If cash settlement defaults have been created for the selected agreement / rate index / currency, the "Early
Termination" section will be used as default values for Cash Settlement details.

» Enter the fields described below as needed then click Save and Close. You can define multiple settlement details
for different dates.

Note that terminations are not enforced based on cash settlement details. The termination dates are for
information purposes. However, if you terminate a trade at a specified date, the cash settlement details will be
used to compute the settlement amount.

Fields Description
Mandatory / Optional Click the Mandatory or Optional radio button as needed.

Event Type Select the event type that triggers the cash settlement.
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Fields Description
The event type is populated for SwapsWire trades.

Custom default values can be populated based on the event type. Refer to the Calypso
Developer’s Guide for details. You can register new event types in the domain
"cashSettleEvent".

Comment Enter a free form comment related to the event.

Option Style Only applies to optional cash settlements. Select the option style: European, American, or
Bermudan.

• Exercise Date = Effective date of the exercise.

• Valuation Date and Time = Valuation date and time used to determine the cash
settlement amount.

• Payment Date = Payment date of the cash settlement amount.

European
» Enter the exercise date, valuation date, valuation time, payment date, and payment

currency. You can double-click the label that appears to the right of the dates to modify
the lag. It brings up the OptionCalcDialog. See OptionCalcDialog below for details.

American
» Enter the first exercise date, valuation date, valuation time, payment date, payment

currency, and last expiration date. You can double-click the label that appears to the
right of the dates to modify the lag. It brings up the OptionCalcDialog. See
OptionCalcDialog below for details.

Bermudan
» Generate a termination schedule by entering the From and To dates, selecting a

frequency (Frq), holiday calendars, and clicking Generate.

Note that the values for the dates default from the trade’s start and end dates. If you
enter a date shortcut (for example, 2y) in the To field, the application calculates the date
from the value entered in the From field.

See also legal agreement attribute "BermudanTradeDate" for defaults.

The frequency and holiday calendars default to the payment details of the trade. The
holiday calendars for the Exercise Date and Valuation Date also default to the payment
details.

OptionCalcDialog
» Select the holiday calendar.

» Enter a number of lag days, months or years in the Offset field.

Days lag “D” can be business days or calendar days. Double-click the Bus label to switch
to Cal as needed.
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Fields Description
For months lag “M” and years lag “Y”, the system uses calendar days only.

The “No Tenor” checkbox only applies to days lag, when you enter more than 31 days. If
you check the “No Tenor” checkbox, the offset will be not be converted to a tenor.

Otherwise it will be converted to a tenor. Note that the conversion is for display only.
The system always stores 35D.

» For European options only, enter the exercise fee.

For American and Bermudan options, you can enter the exercise fee in the Ex Schedule
panel.

For Bermudan options, select the frequency of the exercise dates.

Contact Details Enter free form contact information as needed.
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Fields Description
Agreement You can select an agreement type, or ANY.

It defaults to the agreement type defined in domain "CashSettleDefaultsAgreements".

If cash settlement defaults exist for the selected agreement, rate index and currency, they
will be loaded.

If a legal agreement of specified type is defined between the counterparty and the
processing organization for the specified currency and product type, it can also drive default
values on the settlement details.

 Ⓘ [NOTE: The legal agreement CANNOT be defined as "Master"]

Attribute TERMINATION_APPENDIX_MID
The attribute TERMINATION_APPENDIX_MID drives the following default values:

• Quotation Rate

If TERMINATION_APPENDIX_MID = Yes or not set, it is set to MID.

If TERMINATION_APPENDIX_MID = No, it is set to BID/ASK.

• Exercise Party Pays

If TERMINATION_APPENDIX_MID = Yes or not set, it is set to False (unchecked).

If TERMINATION_APPENDIX_MID = No, it is set to True (checked).

Attributes CASH_SETTLE_MANDATORY_DATEROLL and CASH_SETTLE_
OPTIONAL_DATEROLL
The attributes CASH_SETTLE_MANDATORY_DATEROLL (mandatory agreement) and CASH_
SETTLE_OPTIONAL_DATEROLL (optional agreement) drive the default value of the Date Roll
conventions (Ex Date and Pay Date).

You can create domains “laAdditionalField.CASH_SETTLE_MANDATORY_DATEROLL” and
“laAdditionalField.CASH_SETTLE_OPTIONAL_DATEROLL” to hold the possible values.

Attribute BermudanTradeDate
The attribute "BermudanTradeDate" controls the Bermudan “From Date”. If true, the From
Date is the Trade Date, otherwise, it is the start date of the swap.

Reviewed / Satisfied This checkbox appears checked when the trade has been reviewed from the Calypso
Navigator in Trade Lifecycle > Termination > Cash Settlement (menu action
reporting.CashSettlementWindow).

For the Bermudan option style, the Reviewed/Satisfied checkbox can be set for each date.

Ex Date Convention Select the date roll convention to be applied when the termination date falls on a non-
business day.

Date roll conventions are described in the Calypso Navigator under Help > Date Roll
Conventions.
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Fields Description
See legal agreement attributes CASH_SETTLE_MANDATORY_DATEROLL and CASH_
SETTLE_OPTIONAL_DATEROLL for defaults.

Pay Date Convention Select the date roll convention to be applied when the payment date falls on a non-business
day.

Date roll conventions are described in the Calypso Navigator under Help > Date Roll
Conventions.

See legal agreement attributes CASH_SETTLE_MANDATORY_DATEROLL and CASH_
SETTLE_OPTIONAL_DATEROLL for defaults.

Earliest Exercise Time Enter the earliest time on termination date when the option can be exercised.

Defaults to Cash Settlement Defaults if any.

Expiration Time Enter the time at which the trade is terminated.

Defaults to Cash Settlement Defaults if any.

Cash Settle Method Select a cash settlement method to compute the settlement amount.

Defaults to Cash Settlement Defaults if any.

Rate Source You can select a rate source or none (empty). You can add rate sources to the "RateSource"
domain.

If you select none, you have to select a set of reference banks.

» You can select a legal entity of role ReferenceBank.

If you select OTHER_SOURCE, you need to select a rate index from the Rate Index field.

Quotation Rate Select the instance of the quotation rate that you want to use: MID, BID, or ASK.

See legal agreement attribute TERMINATION_APPENDIX_MID for defaults.

Exercise Party Pays Check to indicate that the exercising party pays the settlement amount, otherwise the
exercising party receives the settlement amount.

See legal agreement attribute TERMINATION_APPENDIX_MID for defaults.

Location Select a location.

Defaults to Cash Settlement Defaults if any, or to the currency’s location otherwise.

4.22 Trade Dri l ldown
Most types of trades that can be captured in the Pricing Sheet can also be captured in native trade windows. When
drilling down to such a trade from a report, the native trade window will usually be invoked by default.

To invoke the Pricing Sheet by default instead, you need to define a Trade Window Configuration using Configuration
> User Access Control > Trade Window Configuration (menu action refdata.TradeWinConfigWindow) from the
Calypso Navigator.

You can modify an existing configuration or create a new configuration.
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» Select the product type, the product subtype, and enter the class name pricingSheet.PricingSheetWindow
to invoke the Pricing Sheet by default.

» Then associate the configuration with your Calypso user name under Configuration > User Access Control >
User Defaults in the Trade Window Config field.

You need to restart the Calypso Navigator in order for the change to take effect.
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5. Capturing Commodities Trades
To capture commodity trades in the Pricing Sheet, you first need to define Commodity products and resets.

Please refer to Calypso Commodities Trading for details.

Then select a Commodity strategy and set the properties as needed. You can also select a strategy template to
populate default values.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to Commodity trades are described below.

- Commodity Cap

- Commodity Forward

- Commodity Spot

- Commodity Option

- Commodity Swap

- Commodity Swaption

- Commodity Vanilla

- Commodity Barrier

- Commodity Digital

- Commodity FwdStart

- Quantity Schedule for Commodities

- Spread and Strike Schedule for Commodities

Fixing the Price of a Commodity
The price can be fixed in the Price Fixing window.
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For details on using the Price Fixing window, see "Price Fixing" in Calypso Trade Lifecycle documentation.

5.1 Commodity Cap
This strategy is no longer supported for new trade booking. Only existing trades can be opened in this strategy.

Properties
Put/Call - Date - Exercise type - Underlying details

"Product: Style" Properties

Properties Description

Buy/Sell Select the direction of the trade leg from the book's perspective.

Settle Type Select the settle type, Cash or Compo.

Cash is set by default. When Compo is selected, Settle Ccy and other FX related properties
will become editable.

Strike Enter the strike price per unit. The input fields vary depending on the Option Type that you
select.

Settlement Source Select the source to be used as a pricing reference for settlement calculations.

"Product: Date" Properties

Properties Description

Trade Date Enter the start date and time of the trade. The trade date defaults to the current date.

Settle Date Enter the maturity date for the trade. (For most emissions trades, the settle date is equal to
the allowance delivery date.)
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"Price Fixing" Properties

The several properties associated with Fixings in the Pricing Sheet are either editable or non-editable depending on
the Payment Frequency Type setting. For example, the Averaging Method and Averaging Rounding Method
properties are available for editing with all payment frequency types except for "Bullet," "Daily," and
"ThirdWednesday."

Properties Description

Payment Fre-
quency Type

Select the payment frequency type.

For the DateRule type, set the date rule in the Fixing Date Rule field.

For details on Payment Frequency Type settings, see "Commodity Payment Frequencies" in the
Calypso Commodities documentation.

Schedule Start
Date

Enter the Schedule start date

Schedule End
Date

Enter the Schedule end date

Fixing Policy Select the Fixing Policy.

Please refer to Calypso Commodity Fixing Policies documentation for more details.

Fixing Calendar Select the fixing calendar.

Fixing Time Zone The global time that the commodity reset is expected to be known. This can be, but doesn't have
to be, the time zone of the actual exchange or publication.

Fixing Time The global time that the commodity reset is expected to be known.

Fixing Date Rule Select the date rule for the DataRule payment frequency type.

First Contract Only available to payment frequency types FutureContractFND or FutureContractLTD.

Displays the first underlying futures contracts that will be used as fixing references.

Last Contract Only available to payment frequency types FutureContractFND or FutureContractLTD.

Displays the last underlying futures contracts that will be used as fixing references.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Properties Description

Intraday Policy Select the Intraday Policy to be used.

Please refer to Calypso Intraday Configuration documentation for more details.

DST Name Displays the daylight savings.

Averaging
Method

Select a method for averaging the rates used in fixing.

Please refer to Calypso Commodity Averaging Methods documentation for more details.

Averaging Round-
ing Method

Select the rounding method.

"Product: Price" Properties

Properties Description

Barrier Enter the barrier count.

Barrier Type Select the type of barrier: 'UI', 'UO', 'DI' or 'DO'.

Barrier Duration Enter Full or NONE.

Rebate The amount of the rebate per commodity unity. The rebate is entered in amount per strike
unit. For example, a rebate may be entered as "0.35 per barrel" by entering 0.35 in this field.

Rebate Currency The currency of the rebate. This should always be equal to the settlement currency of the
option.

Rebate Timing The payment schedule of the rebate. This can be paid at the original option maturity (At
Maturity) or on a date relative to the knock out event (At Instant).

"Underlying Details" Properties

Properties Description

Underlying Select the commodity reset which will drive the forward. When the reset is selected, fields
specific to the reset pre-fill with the appropriate information.

Quantity The quantity of the certificate in commodity units.

Quantity Units Unit of measure that the quantity represents. You can use a different unit type than the unit
in the product definition. The quantity unit defaults to the unit defined in the commodity
definition. If a unit other than the default unit is chosen, the application requires a
conversion definition to correctly convert the units for the cashflows. Commodity positions
are always kept in the default unit in the Position Keeper.

Define the conversion definition in the Calypso Navigator under Configuration >
Commodites > Commodity Conversion.

Conversion Rounding Round: FX conversions will be rounded.
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Properties Description

Don't round: FX conversions will not be rounded.

Total Quantity Displays the total quantity units over the life of the trade.

Physical Delivery Fre-
quency

Specify the frequency of the payment.

Custom FX Rounding
Frequency

When populated, FX rates will be rounded to a custom number of decimal points; otherwise,
default rounding from the currency pair definition will be applied.

5.2 Commodity Forward
The commodity forward trade is based on the commodity reset, not the commodity itself. You must define a reset to
construct a commodity forward trade.

Commodity forward trades without certificates do not update the position by default. You need to run the scheduled
task CMD_FWD_SETTLE on the settlement date to terminate the commodity forward trade and create a commodity
spot trade. If you want to update positions for commodity forward trades without certificates, you need to set the
environment property NEW_CMD_FWD_NO_POSITION = false. See below.

Properties
"Product: Style" Properties- Delivery Properties

"Product: Style" Properties

Properties Description

Buy/Sell Select the direction of the trade leg from the book's perspective. To buy or sell a Certificate,
right click and open the Supplemental panel. Select a certificate (sell trade) or define a
certificate (buy trade).

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Properties Description

Certificate details can be entered or a template can be used

Please refer to Calypso Certificate Template documentation for more details.

Settle Type Select the settle type, Cash or Compo.

Cash is set by default. When Compo is selected, Settle Ccy and other FX related properties
will become editable.

Strike Enter the strike price per unit.

"Price Fixing" Properties
See "Price Fixing" Properties for details.

"Underlying Details" Properties

Properties Description

Underlying Select the commodity reset which will drive the forward. When the reset is selected, fields
specific to the reset pre-fill with the appropriate information.

Quantity The quantity of the certificate in commodity units.

Cheapest to Deliver Enter the cheapest to deliver amount.

Quantity Units Unit of measure that the quantity represents. You can use a different unit type than the unit
in the product definition. The quantity unit defaults to the unit defined in the commodity
definition. If a unit other than the default unit is chosen, the application requires a
conversion definition to correctly convert the units for the cashflows. Commodity positions
are always kept in the default unit in the Position Keeper.

Define the conversion definition in the Calypso Navigator under Configuration >
Commodites > Commodity Conversion.

Quote Units The commodity unit in which the reference price is quoted, i.e. USD/Barrel.

Delivery Location This is the delivery location for storage based commodities. It is populated from the Com-
modityLocation domain value. The pricer recognizes the delivery location and prices the for-
ward according to the relevant location differentials.

Price Currency Enter the currency for the price.

Physical Delivery Date
Roll

Select the date roll convention to roll the payment dates when they fall on non-business
days. The payment calendar is used to determine business days.
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Properties Description

Date roll conventions are described in the Calypso Navigator under Help > Date Roll
Conventions.

Physical Delivery Hol-
idays

Click ... to select the calendar(s) the application uses to determine the business days.

Physical Delivery Lag Specify lag days from the end date of the payment period (in business or calendar days) for
the actual payment to take place. By default, business days are used to calculate the pay-
ment date. To specify calendar days, double-click the Bus label to toggle to Cal.

Physical Delivery Day Number of delivery days.

Scheduled Task CMD_FWD_SETTLE
This scheduled task terminates commodity forward trades without certificates on the settlement date and creates
commodity spot trades.

Select the action to be applied to the forward trade.

Commodity Forwards to Spot Migration
See Commodity Forwards Migration for details.

5.3 Commodity Spot
Select the "Commodity" strategy to enter a commodity spot trade and set the properties as needed.
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"Underlying Details" Properties

Properties Description

Underlying Select the commodity.

Quantity Enter the quantity.

Strike Enter the strike.

5.4 Commodity OTC Option
A Commodity OTC Option is a strip of Cash settled Asian or Average Rate Options. The payoff depends on an average
of Reference Prices relative to a fixed Strike.

This strategy is no longer supported for new trade booking. Only existing trades can be opened in this strategy.

Select the "Commodity" strategy to enter a Commodity OTC Option trade and set the properties as needed.
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Properties
Buy/Sell - Put/Call - Style Properties - Underlying Details - Price Fixing Details - Trigger Details
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"Product: Style" Properties

Properties Description

Buy/Sell Select the direction of the trade leg from the book's perspective.

Strike Enter the strike price per unit.

Exercise Type Select the exercise type.

"Price Fixing" Properties
See "Price Fixing" Properties for details.

"Underlying Details" Properties

Properties Description

Underlying Select the commodity reset which will drive the forward. When the reset is selected, fields
specific to the reset pre-fill with the appropriate information.

Quantity The quantity of the certificate in commodity units.

Total Quantity Displays the total quantity units over the life of the trade.

Quantity Units Unit of measure that the quantity represents. You can use a different unit type than the unit
in the product definition. The quantity unit defaults to the unit defined in the commodity
definition. If a unit other than the default unit is chosen, the application requires a
conversion definition to correctly convert the units for the cashflows. Commodity positions
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Properties Description

are always kept in the default unit in the Position Keeper.

Define the conversion definition in the Calypso Navigator under Configuration >
Commodites > Commodity Conversion.

Quantity Per Period Specify the frequency that the deal quantity is traded.

For Pay Frequency – Future Contract LTD/FND, user can select below options for ‘Per
Period’:

• Future Contract Period - Specified Quantity is applied to each period.

• DLY - Specified Quantity is applied to each day in a period. Total Quantity for the period
will be

Quantity * Number of Days in the period.

• DLY Delivery Period - Specified Quantity is applied to each day of Delivery period of
Contract. Total

Quantity for the period will be Quantity * Number of Days in Delivery period of Future
Contract.

Conversion Rounding Set to ‘Round’ to indicate that the reference unit to deal unit conversion of the price should
be rounded prior to calculating the amount for the cash flow. The default is ‘Don't Round’,
which means the rounding occurs after the amount is calculated.

Trigger Properties

Properties Description

Trigger Duration Select None or EXPIRY.

Trigger Type Select ABOVE or BELOW

Trigger Enter the trigger amount.

"Product: Payment" Properties

Properties Description

Payment Date Roll Select the date roll convention to roll the payment dates when they fall on business days.
The payment calendar is used to determine business days.

Date roll conventions are described in the Calypso Navigator under Help > Date Roll
Conventions.

Payment Holidays Click ... to select the holiday calendar(s) used to determine the business days when cal-
culating the payment date.

Payment Day Select to enter payment details. This makes a field available next to the Day label where you
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Properties Description

can specify which day the payment should take place. For example, enter “5” to specify that
the payment date occurs on the 5th of the month following the swap end date.

Payment Date Rule Select a date rule for determining the payment date if required.

Payment Frequency
Type

Select FutureContractLTD or FutureContractFND.

5.5 Commodity Swap
A Commodity Swap is an exchange of payments between two parties. It uses a Commodity Reset Definition to define
values to use for both known and projected commodity amounts. Select the commodity reset during trade capture
and define additional fixing details in the trade.
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Key Properties
Strike - Leg Type - Settle Type - Pay/Receive - Underlying Details - Fixing Details - Payment Details

Basic Steps for Capturing a Commodity Swap
• Select the underlying Commodity Reset and a Quantity for the swap.

• Configure the Leg Type if other than Fixed and Float.

• Assign Pay and Receive properties to each leg.

• Enter a Strike for the commodity.

• Select the Settle Type.

• Make selections for Fixings properties.
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• Define other basic properties such as Book and Counterparty.

"Underlying Details" Properties

Properties Description

Underlying Select the commodity reset which will drive the forward. When the reset is selected, fields
specific to the reset auto-populate with the appropriate information.

Quantity The quantity of the certificate in commodity units.

Total Quantity Displays the total quantity units over the life of the trade.

Quantity Units The unit of measure that the quantity represents.

You can use a different unit type than the unit in the product definition. The quantity unit
defaults to the unit defined in the commodity definition. If a unit other than the default unit is
chosen, the application requires a conversion definition to correctly convert the units for the
cashflows. Commodity positions are always kept in the default unit in the Position Keeper.
Define the conversion definition in the Calypso Navigator by pointing to Configuration >
Commodities > Commodity Conversion.

The "Contracts" unit represents the lot size. The conversion factor for each lot, or contract,
can be configured in the Commodity Unit Conversion window referred to above.

Quantity Per Period Specify the frequency that the deal quantity is traded.

For Pay Frequency – Future Contract LTD/FND, user can select below options for ‘Per
Period’:

• Future Contract Period - Specified Quantity is applied to each period.

• DLY - Specified Quantity is applied to each day in a period. Total Quantity for the period
will be

Quantity * Number of Days in the period.

• DLY Delivery Period - Specified Quantity is applied to each day of Delivery period of
Contract. Total

Quantity for the period will be Quantity * Number of Days in Delivery period of Future
Contract.

Rate The Rate on the Fixed leg is auto-populated when you add the Strike. Enter the rate for the
floating leg(s) where required.

Conversion Rounding Set to "Round" to indicate that the reference unit to deal unit conversion of the price should
be rounded prior to calculating the amount for the cash flow. The default is ‘Don't Round’,
which means the rounding occurs after the amount is calculated.

Commodity Reset
Factor

The factor is a multiplier representing the value of the actual commodity being used as the
underlying compared to the reference commodity defined in the selected Commodity Reset.

For details on the Commodity Reset Factor, see "Capturing Commodity Swap Trades" in
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Properties Description

the Calypso Commodities documentation.

"Product: Style" Properties

Properties Description

Strike Enter the strike price per unit.

Settle Type Select the settle type, Cash, Compo, Quanto or Flexo.

Cash is set by default. When Compo is selected, Settle Ccy and other FX related properties
will become editable. The FX rate source can be set in the Flexo FX Source property.

Leg Type Select the leg type: Fixed or Float. The Commodity Swap allows for two floating legs.

Pay/Receive Enter pay or receive for the legs. Selecting one in the first leg populates the other in the
second leg.

End Date Enter the trade's End Date.

Notional Ccy Currencies for the legs are populated automatically after selecting the underlying.

"Product: Payment" Properties

Properties Description

Payment Frequency
Type

Select FutureContractLTD or FutureContractFND.

Payment Date Roll Select the date roll convention to roll the payment dates when they fall on business days.
The payment calendar is used to determine business days.

Date roll conventions are described in the Calypso Navigator under Help > Date Roll
Conventions.

Payment Holidays Double-click in the Payment Holidays field to open the holidays list. Select the holiday
calendar(s) used to determine the business days when calculating the payment date.

Payment Lag Enter the number of business days for lag and press the Enter key to populate the field. Neg-
ative numbers are also acceptable.

Payment Day Select to enter payment details. This makes a field available next to the Day label where you
can specify which day the payment should take place. For example, enter “5” to specify that
the payment date occurs on the 5th of the month following the swap End Date.
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Properties Description

Payment Date Rule Select a date rule for determining the payment date, if required.

For details on defining date rules, see "Defining Date Rules" in the Calypso Getting Started
documentation.

"Price Fixing" Properties
See "Price Fixing" Properties for details.

5.6 Commodity Swaption
A commodity swaption is an option on an underlying commodity swap. The Commodity Swaption is captured from the
processing organization's (PO) point of view. Therefore, when the PO buys the option on an underlying swap whose
fixed leg is set to Pay, the PO is buying the right to pay the fixed rate. Alternatively, when the PO sells the option on an
underlying swap whose fixed leg is set to Pay, the PO is selling the right for the option holder to receive the fixed rate.
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Properties
Commodity Swap Properties + Buy/Sell - Put/Call - Settle Type - Exercise Type
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Basic Steps for Capturing a Commodity Swaption
• Populate properties according to Commodity Swap trade capture.

• Select Buy or Sell for the swaption.

• Choose the Settlement Type.

• Choose the Exercise Type. If the type is Bermudan with multiple expiry and delivery
dates, generate an exercise schedule.

Swaption Properties

Properties Description

Buy/Sell Select whether the Processing Organization (PO) is the buyer or seller of the option.

Settle Type Select Cash, Compo, or Physical. The value of the option on expiry equals the NPV of the
underlying swap

• Cash - For cash settlement (exercise against a fee).

• Compo- For use on swaptions that require FX conversion. The FX rate source can be set
in the Flexo FX Source property.

• Physical - For physical settlement (exercise against the underlying product) - A swap
trade on the underlying product is automatically created after exercising the option.

Put/Call This field is auto-populated and not editable. If the underlying swap has the PO paying fixed,
then the swaption is a call option. If the underlying swap has the PO receiving fixed, then the
swaption is a put option.

Exercise Type Select European, American, or Bermudan.

• European: requires an Expiry Date and Delivery Date.

• American: requires an Expiry Date, Delivery Date, and First Expiry Date.

• Bermudan: multiple sets of expiry and delivery dates can be configured in the Exercise
Schedule on the Supplemental panel. To open the Supplemental panel, right-click
anywhere in the trade and select Supplemental in the menu.
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Properties Description

– In the Supplemental panel, select the Exercise Schedule tab, fill in the Input
Parameters, and click Generate. Expiry and delivery dates are populated in the
schedule.

– Click Clear All to remove all dates from the schedule. To remove an individual row,
highlight the row, click the down arrow to the right of the button, and select Delete
Row. You can also highlight a row and select Insert Row to manually add dates to
the schedule. New rows are added above the highlighted row.

Quantity Per Period Specify the frequency that the deal quantity is traded.

For Pay Frequency – Future Contract LTD/FND, user can select below options for ‘Per
Period’:

• Future Contract Period - Specified Quantity is applied to each period.

• DLY - Specified Quantity is applied to each day in a period. Total Quantity for the period
will be

Quantity * Number of Days in the period.

• DLY Delivery Period - Specified Quantity is applied to each day of Delivery period of
Contract. Total

Quantity for the period will be Quantity * Number of Days in Delivery period of Future
Contract.

Using Two Commodity Resets
The CommoditySwaption pricer supports the use of two commodity resets so that both legs are floating legs.

• The pricer considers two commodity curves and the correlation between them, as well as two volatility surfaces.

• Currently, the pricer only calculates for NPV.
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• Greeks are not computed for float/float swap options.

Commodity Swaption with two floating legs

"Price Fixing" Properties
See "Price Fixing" Properties for details.

5.7 Commodity Vani l la
The Commodity Vanilla strategy provides an option on a standard buy/sell commodity trade. Either a commodity reset
or future commodity can be used for the underlying.

Key Properties
Underlying - Quantity - Strike - Exercise Type - Settle Type - Schedule Start/End Date
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The future commodities used as underlyings for Commodity Vanilla are defined in the Future Contract Specification
Window.

For details on creating a future contract, see "Defining Future Contracts" in Calypso Futures documentation.

Basic Steps for Capturing a Commodity Vanilla Trade
• Select the underlying Commodity Reset or Future Commodity.

• Specify the Exercise Type, either American or European.

• Enter a Strike for the commodity.

• Select the Settle Type.
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• Enter the option's maturity using the Schedule End Date property.

• Define other essential trade properties such as Put/Call, Buy/Sell, Book, Counterparty,
and payment schedule properties.

Properties Description

Properties Description

Underlying Select either a commodity reset or future commodity for the underlying.

Click the drop-down arrow in the property field to open the Underlying Product Chooser
window and then double-click one of the product types. The FutureCommodity or
CommodityReset products available as underlyings are displayed in the Underlyings pane.

Quantity Enter a value for the number of units corresponding to the commodity.

Strike Enter the strike price per unit.

Exercise Type Select American or European.

• American - You can exercise the option anytime during the life of the option.

• European - The option may only be exercised on the expiry date.

First Exercise Date When Exercise Type is "American" and Settle Type is "Physical," enter a date for the first
exercise date.

Settle Type Select Cash, Compo, or Physical.

• Cash - For cash settlement (exercise against a fee). Exercise Type is automatically set
to European.

• Compo- For use on an option that requires FX conversion. Exercise Type is
automatically set to European.

• Physical - For physical settlement (exercise against the underlying product). This
settlement type applies to both American and European exercise types.

Fixings When Settle Type is "Physical," only "Bullet" is supported for the Payment Frequency Type.

Use the Schedule End Date property to set the option expiration.

When Settle Type is either "Cash" or "Compo," all sub-properties for the Fixings property are
available.

See "Date Properties" in Pricing Sheet Strategy Properties for details.
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5.8 Commodity Barr ier
The Commodity Barrier strategy allows for trade capture and pricing of a single barrier commodity option with a full
duration.

Key Properties
Underlying - Quantity - Strike - Settle Type - Schedule Start/End Date - Barrier Type - Barrier - Rebate - Rebate
Timing

The future commodities used as underlyings for Commodity Barrier are defined in the Future Contract Specification
Window.

For details on creating a future contract, see "Defining Future Contracts" in Calypso Futures documentation.
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Basic Steps for Capturing a Commodity Barrier Trade
• Select the underlying Commodity Reset or Future Commodity.

• Enter a Strike for the commodity.

• Select the Settle Type.

• Enter the Barrier Type and then a value for the barrier.

• If applicable, enter a rebate and select the Rebate Timing.

• Define other essential trade properties such as Put/Call, Buy/Sell, Book, Counterparty,
and payment schedule properties.

Properties Description

Properties Description

Underlying Select either a commodity reset or future commodity for the underlying.

Click the drop-down arrow in the property field to open the Underlying Product Chooser
window and then double-click one of the product types. The FutureCommodity or
CommodityReset products available as underlyings are displayed in the Underlyings pane.

Quantity Enter a value for the number of units corresponding to the commodity.

Strike Enter the strike price per unit.

Exercise Type Only European is available for Commodity Barrier. The option is exercised on the expiry
date.

Settle Type Select Cash or Compo.

• Cash - For cash settlement (exercise against a fee).

• Compo - For use on an option that requires FX conversion.

Fixings Use the "Fixings" sub-properties to specify trade details related to fixings, such as defining
the option maturity using the Schedule End Date property, or setting the Payment
Frequency Type.

All Fixings sub-properties are available for the Commodity Barrier strategy.

See "Date Properties" in Pricing Sheet Strategy Properties for details.

Barrier Duration Automatically set to Full. The barrier is observed throughout the life of the option.

Barrier Type Select the type of barrier:

• UI - Up In
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Properties Description

• DI - Down In

• UO - Up Out

• DO - Down Out

Barrier Enter the barrier price used to either knock in or knock out the option.

Rebate / Rebate Ccy /
Rebate Timing

Enter a rebate amount if applicable.

You can also set the following properties:

• Rebate Ccy - Select the currency for the rebate.

• Rebate Timing - Select Expiry (rebate at expiration), or Instant (rebate when the barrier
is hit).

5.9 Commodity Digital
The Commodity Digital strategy sets a trigger to determine whether the option settles in or out of the money and uses
the Notional property to express the payout at expiration. The option is exercised at expiration, which is specified
using the Schedule End Date property, and settles in cash or compo.

Key Properties
Underlying - Notional - Settle Type - Schedule End Date - Trigger Type - Trigger
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The future commodities used as underlyings for Commodity Digital are defined in the Future Contract Specification
Window.

For details on creating a future contract, see "Defining Future Contracts" in Calypso Futures documentation.

Basic Steps for Capturing a Commodity Digital Trade
• Select the underlying Commodity Reset or Future Commodity.

• Enter a Strike for the commodity.

• Select the Settle Type.

• Enter the Trigger Type and then a value for the trigger itself. (The value entered for
either the Trigger or the Strike is propagated in kind to the second of the two
properties.)

• Define other essential trade properties such as Buy/Sell, Book, Counterparty, and
payment schedule properties.
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Properties Description

Properties Description

Underlying Select the future commodity underlying. (Only future underlyings are supported.)

Click the drop-down arrow in the property field to open the Underlying Product Chooser
window and then double-click FutureCommodity in the Product Type pane. The
FutureCommodity products available as underlyings are displayed in the Underlyings pane.

Notional Enter the settle amount for payout in the case where the option is exercised in the money.

Strike Enter the strike for the trade. This will be reflected in the Trigger property.

Fixings Three sub-properties for "Fixings" are valid for the Commodity Digital.

• Payment Frequency Type - Bullet. Commodity FwdStart supports only this type.

• Fixing Policy - Bullet. Commodity FwdStart supports only this type.

• Schedule End Date - Enter the date for option maturity. This date must be the same as
or come after the Fixing Date.

Settle Type Select Cash or Compo.

• Cash - For cash settlement (exercise against a fee).

• Compo - For use on an option that requires FX conversion.

Exercise Type Only European is available for Commodity Digital. The option is exercised on the expiry date.

Trigger Duration The Commodity Digital strategy is exercised on the expiration date, and this property is auto-
matically set to EXPIRY.

Trigger Type Select either ABOVE or BELOW to set the criteria for whether the option expires in or out of
the money.

• ABOVE - Payout occurs when the spot rate is above the trigger at expiration.

• BELOW - Payout occurs when the spot rate is below the trigger at expiration.

Trigger Enter the trigger to set the threshold for determining whether the option is in or out of the
money at expiration. The value for the trigger is reflected in the Strike property.

5.10 Commodity FwdStart
The Commodity FwdStart strategy is a vanilla commodity option that becomes active and fixes the strike price on a
specified date in the future. This strategy supports only the exercise type "European" and the settle type "Cash." The
Commodity FwdStart also provides a way to manually fix the strike rather than use the quote.

Key Properties
Underlying - Quote Type - Quantity - Notional - Strike % - Fixing Date - Schedule End Date - Manual Fixing Check /
ManualFixing
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The future commodities used as underlyings for Commodity FwdStart are defined in the Future Contract Specification
Window.

For details on creating a future contract, see "Defining Future Contracts" in Calypso Futures documentation.

Basic Steps for Capturing a Commodity Forward Start Trade
• Select the underlying Future Commodity.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 122 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 123 / 359

• Select the Quote Type - either Notional or Quantity - and enter a value for the type
selected.

• Specify the Strike %.

• Enter a Fixing Date for the strike price.

(the price can be fixed either manually or in the Price Fixing window. See below.)

• Enter the Schedule End Date to determine when the option matures.

• Define other basic trade properties such as Book, Counterparty, Buy/Sell, payment
schedule properties.

Properties Description

Properties Description

Underlying Select the future commodity underlying. (Only future underlyings are supported.)

Click the drop-down arrow in the property field to open the Underlying Product Chooser
window and then double-click FutureCommodity in the Product Type pane. The
FutureCommodity products available as underlyings are displayed in the Underlyings pane.

Quote Type Select the Quote Type for the trade, either Notional or Quantity.

Notional When Quote Type is Notional, enter a notional value for the option. See also "Total Quantity"
below on conversion to quantity.

Quantity When Quote Type is Quantity, enter a value for the number of units corresponding to the
commodity.

Quote Units This property is used for display only. Displays the commodity unit that corresponds to the
underlying once the underlying has been selected.

Total Quantity This property is used for display only. For notional quoted options, the notional is converted
into quantity on the strike fixing date and Total Quantity is populated based on the Quote
Units specification. For quantity quoted options, the Total Quantity is populated as soon as
the trade is priced.

Strike % Enter a strike percentage that will be used to calculate the strike at the time of the fixing.

Strike This property is used for display only. The Strike property is populated after the fixing. The
exception is when manual fixing is used. In this case, the strike is populated once a strike is
specified for the Manual Fixing property.

Fixing Date Enter a date in the future for fixing the strike.

Fixings Three sub-properties for "Fixings" are valid for the Commodity Forward Start.

• Payment Frequency Type - Bullet. Commodity FwdStart supports only this type.

• Fixing Policy - Bullet. Commodity FwdStart supports only this type.

• Schedule End Date - Enter the date for option maturity. This date must be the same as
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Properties Description

or come after the Fixing Date.

Settle Type Select Cash or Compo.

• Cash - For cash settlement (exercise against a fee).

• Compo - For use on an option that requires FX conversion.

Exercise Type Only European is available for Commodity FwdStart. The option is exercised on the expiry
date.

Manual Fixing Check

Manual Fixing

You have the option to select the Manual Fixing Check checkbox to enable manual fixing.
You can then specify a strike in the ManualFixing property.

This feature is enabled only after the trade has been saved.

The manual fixing is reflected in the Strike property.

5.11 Quantity Schedule for Commodit ies
The Quantity Schedule is available for Commodity Swap, Commodity Options and Commodity Swaption strategies.
The schedule provides a way to specify the deal quantity to be traded at intervals between the start and end date
based on a set frequency, such as daily, monthly, or quarterly.
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To open the Quantity Schedule, right-click a strategy leg and select "Supplemental" from the menu.

The Supplemental panel opens. Select the Quantity Schedule tab to begin.

» To set the time periods for the schedule, select a frequency from the drop-down list below the Start Date and End
Date reference fields.
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» Click Generate to generate the dates in the schedule and then enter quantity values in the Quantity field for each
interval.

» Click Apply to apply the schedule to the trade, then click Save and Close in the top right corner of the Supplemental
panel to see changes to the trade.

– The Quantity property in the strategy changes to reflect the first period in the schedule.

– Details about the deal quantity and the reference quantity can be viewed in the trade's cashflows when
those columns are configured in User Preferences. Point to View > Cash Flows to open the Cashflows
panel.

 Ⓘ [NOTE: The Payment Frequency Type "Bullet" (found in the "Fixings" sub-properties) is not supported for
this feature.]

5.12 Spread and Str ike Schedule for Commodit ies
The Spread and Strike Schedule is available for Commodity Swap, Commodity Options and Commodity Swaption
strategies. The schedule provides a way to specify the spread and strike for each time period.
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» To open the Spread/Strike Schedule, right-click a strategy leg and select "Supplemental" from the menu.

The Supplemental panel opens. Select the Spread/Strike Schedule tab to begin.

» Click Generate to generate the dates in the schedule and then enter Spread/Strike values for each period.

» Click Apply to apply the schedule to the trade, then click Save and Close in the top right corner of the Supplemental
panel to see changes to the trade.

– Details about the Spread/Strike can be viewed in the trade's cashflows when those columns are configured
in User Preferences. Point to View > Cash Flows to open the Cashflows panel.

 Ⓘ Note: Strike/Spread schedule is supported for Periodic, FutureContractFND, FutureContractLTD, Daily,
Daily Rule and Third Wednesday Pay frequency only.
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6. Capturing CRD Trades
To capture a Credit trade in the Pricing Sheet, select the Credit strategy and set the properties as needed.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Credit trades can be opened to the Pricing Sheet from the Credit Market Data window.

Please refer to Calypso Credit Derivatives Trading documentation for details.

Properties specific to Credit trades are described below.

- CDS SNAC

- CDS Index

- CDS Index Option

- CDS Index Tranche

- Asset Swap

6.1 CDS SNAC Trade
To capture CDS SNAC trades, a user enters details for the trade.

You can calculate upfront fees according to ISDA standards if you have the ISDA server configured.

Refer to Calypso's CRD documentation for more information.

Properties
Pricing Details - Settlement Details - Fee Details
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Single Name CDS trade

"Pricing" Properties

Property Description

Buy/Sell Enter Buy for buying credit protection or Sell for selling credit protection.

Notional Enter the trade notional.

"Price" Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Sample pricing parameters

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
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Properties Description

in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Trader Price Displays the unit amount of trader premium based on the selected Price Format.

Customer Price Displays the unit amount of customer premium based on the selected Price Format.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.

Sales Premium Displays the Sales Fee in premium currency.

Sales Fee This property is only enabled if you have selected a Sales Person. Enter the sales fee.

Please refer to Calypso Capturing Sales Margins documentation for setup details.

You can also display:

• Sales Fee Ccy - Displays the default sales fee currency if any. The default sales fee
currency is set in the Defaults panel under Configuration > User Preferences. You can
select another sales fee currency as needed.

The MarginFXRate trade keyword stores the rate used in the conversion.

"Settlement" Properties

Property Description

Issuer Select an Issuer by clicking the cell and entering a name or by using the search box.

Seniority Select the rating of the reference obligation.

Upfront
Fee Type

Select Spread or Upfront Fee Percentage.

If Spread is selected, enter the spread in basis points in the "Spread" cell.

If Upfront Fee Percentage is selected, enter a fee as a percentage in the "Upfront Fee Percentage" cell.

Underlying displays any applicable reference obligation on the legal entity.

City The city of the Calc Agent. This is auto populated when selecting the Settlement Matrix. Calculation
agent cities are defined in the calcAgentCityCode domain.

Recovery
Rate

Enter the recovery rate (e.g. "40" for 40%). The recovery rate is the actual recovery which will be
applied on the trade.
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"Fee" Properties

Property Description

Upfront
Fee

Displays the upfront fee based on the spread or percentage entered.

Fee information is automatically attached to the trade and can be viewed by right-clicking in the trade
and clicking Trade Details > Trade Fees or Alt + F.

The ISDA model can be used to calculate the upfront fee if the ISDA module has been configured and a
discount curve has been added to the pricer configuration.

6.2 CDS Index Trade
To capture CDS Index trades, a user enters details for the trade.

Properties
Pricing Details - Index Details - Fee Details

CDS Index trade

You can set the default RECOVERY_RATE from the Calypso Navigator using Configuration > Credit Derivatives >
Standard Recovery for the "CDSIndexDefinition" type.

Pricing Properties
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Property Description

Buy/Sell Enter Buy for buying credit protection or Sell for selling credit protection.

Notional Enter the trade notional.

"Product: Info" Properties

Property Description

Underlying Displays the product details for the selected index. To select an index, double-click this field and begin
typing any portion of the index name to show all available indexes that include the entered text. Click
the preferred index from the list to populate the Underlying field.

Price Details

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Sample pricing parameters

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Trader Price Displays the unit amount of trader premium based on the selected Price Format.

Customer Price Displays the unit amount of customer premium based on the selected Price Format.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.
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Properties Description

Sales Premium Displays the Sales Fee in premium currency.

Sales Fee This property is only enabled if you have selected a Sales Person. Enter the sales fee.

Please refer to Capturing Sales Margins documentation for setup details.

You can also display:

• Sales Fee Date - Enter the date of the sales fee.

• Sales Fee Ccy - Displays the default sales fee currency if any. The default sales fee
currency is set in the Defaults panel under Configuration > User Preferences. You can
select another sales fee currency as needed.

• Sales Fee FX Rate - Enter the FX rate between the premium currency and the sales fee
currency in case they differ. It is automatically populated if a real-time feed is setup. If
the FX rate between the premium currency and the sales currency changes, you can
elect to recompute the premium or the sales fee using the parameter "On Sales Fee FX
Rate change" in the Defaults panel under Configuration > User Preferences.

The MarginFXRate trade keyword stores the rate used in the conversion.

Trader Premium Displays the theoretical premium computed by the pricer. You can modify its value.

The Trader Premium can adjust the Sales Premium or the Customer Premium based on the
configuration under Configuration > User Preferences.

Sale Premium Displays the Sales Fee in premium currency.

Customer Premium Displays the premium amount such that Customer Premium = Sales Premium + Trader
Premium. Displays the customer premium such that:

• Customer Premium = Trader Premium + Sales Premium (Sell)

• Customer Premium = Trader Premium - Sales Premium (Buy)

The customer premium is the actual fee that will be paid/received.

Index Properties

Property Description

Issuer Select an Issuer by clicking the cell and entering a name or by using the search box.

Seniority Select the rating of the reference obligation.

Settlement
Matrix

Displays default settlement instructions.

Upfront Fee
Type

Select Spread or Upfront Fee Percentage.

If Spread is selected, enter the spread in basis points in the "Spread" cell.

If Upfront Fee Percentage is selected, enter a fee as a percentage in the "Upfront Fee Percentage" cell.
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Property Description

City The city of the Calc Agent. This is auto populated when selecting the Settlement Matrix. Calculation
agent cities are defined in the calcAgentCityCode domain.

Recovery
Rate

Enter the recovery rate (e.g. "40" for 40%). The recovery rate is the actual recovery which will be
applied on the trade.

Fee Details

Property Description

Upfront
Fee

This is the upfront fee to account for the following (it is computed using the ISDA model):

1. Difference in current spread and inception spread.

2. Accrual. The upfront fee will be calculated for CDS Indices with "Price" as the quote type via Calypso,
regardless of ISDA Server set up.

Fee information is automatically attached to the trade and can be viewed by right-clicking in the trade
and clicking Trade Details > Trade Fees or Alt + F.

6.3 CDS Index Option Trade
To capture CDS Index Option trades, a user enters details for the trade.

Properties
Option Details - Settlement Details - Premium Details - Index Details

CDS Index Option trade

Option Properties
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Property Description

Expiry Date Enter the date for the option to expire.

Strike Enter the spot rate.

Volatility Enter the volatility.

Price Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Sample pricing parameters

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Trader Premium Displays the theoretical premium computed by the pricer. You can modify its value.

The Trader Premium can adjust the Sales Premium or the Customer Premium based on the
configuration under Configuration > User Preferences.

See Premium Triangulation for details.

Trader Price Displays the unit amount of trader premium based on the selected Price Format.

Customer Premium Displays the premium amount such that Customer Premium = Sales Premium + Trader
Premium. Displays the customer premium such that:

• Customer Premium = Trader Premium + Sales Premium (Sell)

• Customer Premium = Trader Premium - Sales Premium (Buy)
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Properties Description

The customer premium is the actual fee that will be paid/received.

Customer Price Displays the unit amount of customer premium based on the selected Price Format.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.

Sales Premium Displays the Sales Fee in premium currency.

Sales Fee This property is only enabled if you have selected a Sales Person. Enter the sales fee.

See Capturing Sales Margins for setup details.

You can also display:

• Sales Fee Date - Enter the date of the sales fee.

• Sales Fee Ccy - Displays the default sales fee currency if any. The default sales fee
currency is set in the Defaults panel under Configuration > User Preferences. You can
select another sales fee currency as needed.

• Sales Fee FX Rate - Enter the FX rate between the premium currency and the sales fee
currency in case they differ. It is automatically populated if a real-time feed is setup. If
the FX rate between the premium currency and the sales currency changes, you can
elect to recompute the premium or the sales fee using the parameter "On Sales Fee FX
Rate change" in the Defaults panel under Configuration > User Preferences.

The MarginFXRate trade keyword stores the rate used in the conversion.

"Product: Info" Properties

Property Description

Underlying Displays the product details for the selected index. To select an index, double-click this field and begin
typing any portion of the index name to show all available indexes that include the entered text. Click
the preferred index from the list to populate the Underlying field.

Settlement Properties

Property Description

Settlement Select Cash or Physical.

Settlement Lag Enter the number of days between the delivery date and the expiration date.

Expiration Time Zone Enter the expiration time zone.

Expiration Time Enter the expiration time.

Premium Properties
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Property Description

Premium Date Enter the payment date for the option's premium fee.

Customer Price Displays the customer price such that:

- Customer Price = Trader Price + Sales Price (Sell)

- Customer Price = Trader Price - Sales Price (Buy)

Customer Premium Enter the customer premium.

Index Properties

Property Description

End Date Displays the maturity date for the index.

Issuer Select an index name.

CDS Indices are defined from the Calypso Navigator using Configuration > Credit Derivatives > CDS
Index Definition.

City Select the city of the calculation agent. Calculation agent cities are defined in the calcAgentCityCode
domain.

Current
Notional

Displays the current notional value.

Clean
Price

Displays the clean price.

Trade
Date
Factor

Displays original factor (the factor on the trade date of the index).

Current
Factor

Displays current factor (the factor as of Val date of the index).

Trade
Date
Notional

displays the notional on the trade date.

Funded When funded, there is a notional exchange.

If a credit event occurs, we have two flows on the settlement date which offset each other: Seller Pays (1
- Recovery) * Notional, and receives Notional. The net cashflow is Recovery Rate * Notional. If no credit
event occurs, the Notional is returned to the Seller of Protection at the maturity of the deal. The
settlement is cash only.

6.4 CDS Index Tranche Trade
To capture CDS Index Tranche trades, a user enters details for the trade.
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Properties
Pricing Details - Issuer Details - Fee Details - Tranche Details

CDS Index Tranche trade

Pricing Properties

Property Description

Buy/Sell Direction of the trade from the book’s perspective.

Notional Enter the notional.

The Notional follows the Bond market convention i.e. Buy Index means a positive notional. The factor is
displayed in the Current Factor field - the factor is the total number of non-defaulted issuers / total
number of original issuers.
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Price Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Sample pricing parameters

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Trader Price Displays the unit amount of trader premium based on the selected Price Format.

Customer Price Displays the unit amount of customer premium based on the selected Price Format.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.

Sales Premium Displays the Sales Fee in premium currency.

Sales Fee This property is only enabled if you have selected a Sales Person. Enter the sales fee.

See Capturing Sales Margins for setup details.

You can also display:

• Sales Fee Date - Enter the date of the sales fee.

• Sales Fee Ccy - Displays the default sales fee currency if any. The default sales fee
currency is set in the Defaults panel under Configuration > User Preferences. You can
select another sales fee currency as needed.

• Sales Fee FX Rate - Enter the FX rate between the premium currency and the sales fee
currency in case they differ. It is automatically populated if a real-time feed is setup. If
the FX rate between the premium currency and the sales currency changes, you can
elect to recompute the premium or the sales fee using the parameter "On Sales Fee FX
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Properties Description

Rate change" in the Defaults panel under Configuration > User Preferences.

The MarginFXRate trade keyword stores the rate used in the conversion.

"Product: Info" Properties

Property Description

Underlying Displays the product details for the selected index. To select an index, double-click this field and begin
typing any portion of the index name to show all available indexes that include the entered text. Click
the preferred index from the list to populate the Underlying field.

Issuer Properties

Property Description

End Date Displays the maturity date for the index.

Issuer Select an index tranche.

CDS index tranches are defined from the Calypso Navigator using Configuration > Credit Derivatives
> CDS Index Definition.

Standard
Fixed
Coupon

When selected, the "Spread" property becomes a drop-down listing standard SNAC coupon values.
These values can be defined using the domain CreditDefaultSwapCoupon.SNAC.

For details on using domains, see "Defining Domain Data" in Calypso Getting Started documentation.

When the checkbox is cleared, the "Spread" property becomes a text field that allows the user to enter
any value for the spread.

Spread Enter the spread in basis points.

City Select the city of the calculation agent. Calculation agent cities are defined in the calcAgentCityCode
domain.

Recovery
Rate

Enter the recovery rate.

Fee Properties

Property Description

Upfront Fee Displays the upfront fee.

Fee information is automatically attached to the trade and can be viewed by right-clicking in the trade
and clicking Trade Details > Trade Fees or Alt + F.

Current Displays the current notional.
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Property Description

Notional

Clean Price Enter the clean price.

Trade Date
Factor

Displays the current factor on the trade date.

Current
Factor

Total number of non-defaulted issuers / total number of original issuers. Total number of non-defaul-
ted issuers / total number of original issuers.

Trade Date
Notional

Displays the notional on the trade date.

Funded When checked, the subtype of the CDS is FUNDED, otherwise it is UNFUNDED.

When a credit event occurs, if the trade is funded, there is no settlement fee but there is a principal
reduction for the amount of loss.

Tranche Properties

Property Description

Correlation Enter the correlation. If a correlation surface has been configured and mapped, the correlation value
will be taken from there. Entering a value will override a previously configured correlation surface.

Original Attach-
ment Point

Enter the tranche attachment point at trade inception.

Original
Detachment
Point

Enter the tranche detachment point at trade inception.

Trade Date
Attachment
Point

Displays the effective attachment point as of the entered trade date.

Trade Date
Detachment
Point

Displays the effective detachment point as of the entered trade date.

Current Attach-
ment Point

The current attachment point as of the val date.

Current
Detachment
Point

The current detachment point as of the val date.

Tranche Loss Displays the loss amount of the tranche.

Tranche Loss
Percentage

Displays the percentage loss of the tranche.
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Property Description

Portfolio Loss Displays the loss amount on the portfolio.

Portfolio Loss
Percentage

Displays the percentage loss on the portfolio.

Tranche
Recovery

Displays the tranche recovery amount for the trade

Tranche
Recovery Per-
centage

Displays the tranche recovery amount in terms of percentage.

Portfolio
Recovery

Displays the portfolio recovery amount.

Portfolio
Recovery Per-
centage

Displays the portfolio recovery amount in terms of percentage.

Original Attach-
ment Notional

Displays the notional at the original attachment point for the trade.

Original
Detachment
Notional

Displays the notional at the original detachment point of the trade.

6.5 Asset Swap Trade
To capture Asset Swap trades, a user enters details for the trade.

Properties
Trade Details - Settlement Details - Payment Details - Swap Details - Asset Details - Coupon Details
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Asset Swap trade

Trade Properties

Property Description

Notional Enter the notional amount for the reference leg.

Notional Ccy Enter the notional currency type for the reference leg.

Pay/Receive Enter the pay or receive for each leg in the strategy.

Leg Type Displays the type for each leg in the strategy.

Swap Properties

Property Description

Start Date Trade start date.
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Property Description

End Date Trade end date.

Rate Enter the forward rate.

Rate Index
Factor

Enter the index factor as needed for floating rates to multiply the rate value.

Rate Index Select the rate index for floating rates. You can set additional properties:

• Reset Timing - Select "At Start" or "In Arrears".

• Reset Lag - Enter the number of days between the actual reset date and the reset date as
defined by the reset timing, and specify Business or Calendar.

• Reset Holidays - Select the reset calendars.

• Reset Date Roll - Select the reset date roll.

• Manual First Rate - Enter the first reset rate if any.

• Convert Basis - Check the “Convert Basis” checkbox to check whether the reference index and
the trade have the same daycount convention. If not, the rate’s daycount convention is
converted to the trade’s daycount convention.

Please refer to "Convert Basis" in Calypso Product Details documentation for more details.

• Rate Rounding - Select the rate’s rounding method to override the default value from the rate
index.

• Rate Decimals - Enter the number of decimal places to override the default value from the rate
index.

Reset Fre-
quency

Select the reset frequency to sample resets at a frequency different from the payment frequency.
Otherwise, the resets are sampled at the payment frequency.

Stub Type Select the stub period, if applicable, or none. You can also set the following properties:

• Stub First Date - Enter the end date of the first period for SPECIFIC FIRST and SPECIFIC BOTH.

• Stub Last Date - Enter the start date of the last period for SPECIFIC LAST and SPECIFIC BOTH

• Stub Full Coupon Date - Enter the full coupon date for FULL COUPON.

• Stub Tolerance - Enter the number of days of stub tolerance.

• First Stub Interpolation - Select Interpolate to interpolate on the first period, or none otherwise.

• First Stub Tenor 1 - Select the first index tenor for interpolation of the first period.

• First Stub Tenor 2 - Select the second index tenor for interpolation of the first period.

• Last Stub Interpolation - Select Interpolate to interpolate on the last period, or none otherwise.

Please refer to "Interp checkbox" in Calypso Product Details documentation for more details.

• Last Stub Tenor 1 - Select the first index tenor for interpolation of the last period.

• Last Stub Tenor 2 - Select the first index tenor for interpolation of the last period.
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Property Description

• Interpolated Rate Rounding - Select the stub rate’s rounding method.

• Interpolated Rate Decimal - Enter the number of decimal places for interpolated rate rounding.

• Interpolation Style - Select the interpolation style:

Index Based - The DateRoll, the holidays and the daycount are coming from the rate index.

Product Payment - The DateRoll, the holidays and the daycount are coming from the coupon
panel.

Compounding
Type

Select the compounding type, if applicable, or none.

• Flat - Flat compounding - The spread is added after the compounding is computed if any.
Current period interest is calculated using floating rate plus spread. But compound interest is
calculated using floating rate only (and the spread is not added).

• Spread - The interest compounds at the rate value plus spread. Enter the Spread in the
Compounding Spread field.

• SimpleSpr (Swaps only) - This involves compounding the Floating Rate but treating the spread
as simple interest. In other words,the floating rate interest is earned at the end of a period but
not the spread (only the floating rate is added back into the notional). The spread is then
calculated on the notional for the entire calculation period without compounding.

• NoCmp - A cashflow is created at the compounding period without actually compounding the
interest. The daily rate resets for the floating rate are used to calculate the simple interest
everyday and summed to find the total interest for the period.

You can also set:

• User Reset Period Dates - Check to compound trades based on the reset dates rather than the
payment dates.

Bond Properties

Property Description

Underlying Select a Bond product.

Click the Arrow icon to open a "Search Bonds" window.

You can define a search for current assets. Double click the asset to load it to the Pricing Sheet.
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Property Description

Next Coupon Displays the next coupon date.

Clean Price Enter the clean price.

Dirty Price Enter the dirty price. This includes the accrued interest.

Gross Price Displays Clean Price * Inflation Factor when Inflation Bond is selected.

Yield Enter the yield (rate of return).

Guarantor If the selected bond is associated with a legal entity of role Guarantor, it will be displayed here.

Legal entities can be associated with bonds in the Legal Entities panel of the Bond Product Window.

Accrual Displays the amount of interest accrued as of the settlement date.

Fee Properties

Property Description

Upfront
Fee

Displays the Par Adjustment and Accrual fees.

Fee information is automatically attached to the trade and can be viewed by right-clicking in the trade
and clicking Trade Details > Trade Fees or Alt + F.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 146 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 147 / 359

7. Capturing Equity Derivatives Trades
To capture Equity Derivatives trades in the Pricing Sheet, you first need t o define Equity products.

Please refer to Calypso Equity Derivatives Trading for details.

Then select an Equity-related strategy and set the properties as needed.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to Equity trades are described below.

- Equity Reset Properties

- Equity

- Equity Forward

- Equity Swap

- Portfolio Swap

- Equity Structured Options

- Correlation Swap

- Scriptable OTC Products

7.1 Equity Reset Propert ies
You can select an equity reset from the Equity Reset property for equity and equity index underlyings. The fixing
quote should be set for the quote name in the form "EquityReset.<equity name>.<reset name>". If you do not select
an Equity Reset, CLOSE is selected by default. The fixing quote is the spot quote in that case.

For basket underlyings, and / or to enter manual resets, you need to bring up the Supplemental panel to enter Equity
Reset information.

Equity resets are defined in the Equity Definition or Equity Index Definition.
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Supplemental Panel
You can select the Resets panel to display Resets details for the various legs.

You can select an equity reset from the Reset Name field. The fixing quote should be set for the quote name in the
form "EquityReset.<equity name>.<reset name>". If you do not select an equity reset, CLOSE is selected by default.
The fixing quote is the spot quote in that case.

You can also select "Specific Reset" and enter a manual fixing quote in the Value field.

7.2 Equity
To capture equity trades, you must define an equity product in the system before it can be loaded to the Pricing
Sheet.

Key Properties
Trade Direction - Underlying - Quantity - Strike - Trade Dates - Price
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Property Description

Buy/Sell Enter Buy or Sell.

Classification Enter the classification for the trade from a dropdown. This classification is for information
purposes only.

It is stored in the trade keyword "TradeClassification", and available values can be set in
domain "keyword.TradeClassification".

It can be used in filters to filter trades for various processes, and can be viewed in reports
throughout the system.

Underlying Enter the Equity product for the strategy. To enter a product, define one in the system and
click in the cell to bring up the Underlying Product Chooser window.
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Property Description

A user can search Equity products or ADRs.

See Calypso Equity Derivatives documentation for more details.

Quantity Enter the equity product quantity to trade.

Strike Enter the strike.

Strike Ccy Enter the strike currency.

Settlement Date Enter the settlement date. Defaults to the trade date.

Cash Date Enter the cash date.

Negotiated Price Type Enter the type of negotiated price.

Quanto Factor Enter the rate between the underlying currency and the settlement currency. The trade
keyword "EquityFXRate" will be populated accordingly.

7.3 Equity Forward
An Equity Forward can be settled in cash or physical. The cash settlement requires the user to specify a “fixing” to
determine the settlement amount. The fixing is observed on the forward date.

Key Properties
Trade Direction - Product Type - Settlement Date - Fixing - FX Source
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Property Description

Buy/Sell Enter buy or sell.

Quantity Enter the equity product quantity to trade.

Strike Enter the strike. This is the forward price.

Effective
Date

Enter the effective date.

Expiry Date Enter the trade end date.

Underlying Enter the Equity product for the strategy. To enter a product, define one in the system and click in the
cell to bring up the Underlying Product Chooser window.

You can select a basket, and equity or an equity index. If you choose Basket > <create new basket...>,
the Basket window will appear. You can define a basket to use. Transient baskets will appear in italics. If

Product
Type

Displays the product type.
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Property Description

Notional
Ccy

Select the currency of the notional.

Spot Enter the spot.

Settle Type Enter the settle type. Choose CASH, PHYSICAL, FLEXO or QUANTO from a drop down.

Settle Ccy Defaults to the underlying's currency if cash or physical. If QUANTO or FLEXO, choose currency pair.

Settlement
Lag

Enter the date lag.

Flexo FX
Source

If FLEXO is chosen in the Settle Type, displays the FX Reset.

Quanto
Factor

If QUANTO is chosen in the Settle Type, displays the FX Reset.

7.4 Equity Swap
The Equity Swap strategy in the Pricing Sheet defines the performance leg with an equity or equity index and the
funding leg with a floating rate index or a fixed rate.

Key Properties
Underlying - Quantity - Initial Price - Start/End Date - Rate/Rate Index
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Sample Equity Swap trade

Equities and equity indexes selected for the performance leg of the swap are defined in the equity and equity index
product windows.

For equities, see "Equity Product Definition" in the Calypso Equity Derivatives documentation.

For equity indexes, see "Equity Index Product Definition" in the Calypso Equity Derivatives documentation.
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Basic Steps for Capturing an Equity Swap Trade
• Select the underlying equity or equity index in the Underlying property.

• Enter the quantity.

• Enter the initial price.

• Select either Fixed or Float for the Leg Type on the funding leg, and then enter a fixed
rate or the floating rate index details.

• Enter the Start Date and End Date.

• Enter details for the Performance Schedule

• Enter Book, Counterparty, and other essential details for the trade.

Properties Description

Property Description

Book Enter the trading book to which the trade belongs, owned by the processing organization,
and which identifies the initiator's side of the trade.

Books can be selected only after they have been added to Favorites in the Favorite Books
Configuration window. From Calypso Navigator, choose Configuration > Favorites > Books.

Counterparty Enter the legal entity that represents the opposite side of the trade.

Counterparties can be selected only after they have been added to Favorites in the
Configure Favorite Cptys window. From Calypso Navigator, choose Configuration >
Favorites > Counterparties.

Trade Date Date on which the trade is booked. The date initially defaults to the current date.

Start Date Effective date of the trade.

End Date End date of the trade.

Buy/Sell Defaults to Buy.

Pay/Receive Direction for each leg. Selecting one option for a leg sets the option to its opposite for the
other leg.

Underlying Double-click the Underlying field and click the down arrow to open the Underlying Product
Chooser, where you can select either an underlying equity or equity index.

Quantity Enter the number of shares.

Initial Price Enter the initial price. This price will be used to calculate the first payoff. See Notional below.

Notional The funding notional of the trade. The value is "read only" in the Pricing Sheet.

• Notional equals Quantity multiplied by Initial Price when:
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Property Description

The underlying equity's currency equals the settlement currency, or

The underlying equity's currency is different from the contract's settlement currency,
but the FX Conversion Method is Flexo.

• Notional equals Quantity multiplied by Initial Price (Settle Ccy) when the underlying
equity's currency is different from the settlement currency and the FX Conversion
Method is Compo.

Rate When the Leg Type is Fixed, enter a fixed rate. When the Leg Type is Float, you can enter an
index factor in basis points.

Rate Index When Leg Type is Float, select the reference index and make settings for associated
secondary properties under the Rate Index property.

See "Capturing IRD Trades" in the Pricing Sheet documentation for details on Rate Index
properties.

Settle Type / Settle
Ccy

When the settlement currency is different from the underlying currency, you can select the
FX Conversion Method in the Settle Type property. The choices are Local, Quanto, and
Compo.

Price Change % Enter the percentage of performance that the equity leg receives or pays.

Swap Type Currently, the only option available for the Pricing Sheet is TotalReturn.

Leg Type Either Fixed or Float. When Fixed, the Rate Index property is disabled. When Float, asso-
ciated Rate Index properties are enabled.

Performance Sched-
ule

The performance payoff schedule. CUSTOM_SCHEDULE is the only option available in the
Pricing Sheet. Expand the property to make selections for Frequency, Roll On Day, Per-
formance Stub Type, and Period Rule.

Dividend Schedule Select the payment schedule associated with the equity:

• NONE – No dividend payment.

• PERF_SCHEDULE – Dividend will be recognized upon recognition, i.e. in the period
corresponding to the ex-div date of the dividend. The dividend, if any, follows the
performance payoff schedule. If Dividend Pmt Date is after the Trade End Date, Dividend
Pmt Date in the cashflow will be the same as Trade End Date.

• UPON_RECEIPT – The dividend, if any, will be paid / received on the dividend date.

Dividend Ownership
Second Period is currently the only option. Second Period relies on the dividend's ex-div
date and refers to each period from one fixing date to the next fixing date, excluding the first
date and including the last. The initial dividend period, however, will commence on but
exclude the trade date, and the final dividend period will end on and include the final fixing
date.
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Property Description

Adjust Funding
Notional

Select the notional adjustment method:

• On Pay Date – The Notional of the funding leg equals the Fixing of the Prior Leg * Initial
Quantity. The Notional will adjust on the payment date.

• On Fixing Date – The Notional of the funding leg equals the Fixing of the Prior Leg * Initial
Quantity. The Notional will adjust on the fixing date.

Date Calculation
Method

Select the Date Calculation Method:

• Fixing Date -> Payment Date - Funding payment dates are determined by Performance
payment dates. Fixing date lag on Performance leg is non-editable. It is possible to
define a Reset date lag on the Funding leg.

• Payment Date -> Fixing Date - Performance payment dates are determined by Funding
payment dates. It is possible to define a Fixing date lag on the Performance leg.

7.5 Portfol io Swap
A Portfolio Swap is an agreement between counterparties to swap cash flows on fixed dates in the future over a
certain period of time, where one flow is based on the performance of a dynamic basket of equity assets and the
other on a fixed or floating set interest rate whose amount is calculated using a predetermined notional value. The
Portfolio Swap helps standardize the handling of equity swaps.

The underlying specifics of the agreement are defined by the Portfolio Swap Contract. For details on setting up a
Portfolio Swap Contract, see Calypso Portfolio Swap Definition documentation.

Key Properties
Book - Counterparty - Trade Date - Start Date - Contract - Buy/Sell - Underlying - Quantity - Gross Price

Sample Portfolio Swap trade

Basic Steps for Capturing a Portfolio Swap Trade
• Enter a Book and Counterparty.

• Select the Portfolio Swap Contract that will define the trade.

• Enter the Trade Date.

• Specify Buy or Sell as the direction of the trade.

• Select the underlying equity and then enter the quantity.

• Enter a gross price for the equity.
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Properties Description

Property Description

Book Enter the trading book to which the trade belongs, owned by the processing organization,
and which identifies the initiator's side of the trade.

Books can be selected only after they have been added to Favorites in the Favorite Books
Configuration window. From Calypso Navigator, choose Configuration > Favorites > Books.

Counterparty Enter the legal entity that represents the opposite side of the trade.

Counterparties can be selected only after they have been added to Favorites in the
Configure Favorite Cptys window. From Calypso Navigator, choose Configuration >
Favorites > Counterparties.

Trade Date Date on which the trade is booked. The date initially defaults to the current date.

Start Date Effective date of the underlying contract.

Contract Double-click the Contract property field to select a contract. The Portfolio Swap Contracts
window allows you to search for the target contract.

Once the Contract is entered for the trade it can be opened quickly from the Pricing Sheet by
highlighting the contract in the strategy leg, opening the Leg Details tool (click in the
Tools Panel), and clicking in the Contract field.

 Ⓘ [NOTE: The processing organization's Book and the Counterparty selected in the
Pricing Sheet must match the corresponding information in the contract before the
contract is made available in the Portfolio Swap Contracts search window. Additionally,
the Trade Date should be the same as or follow after the contract's Start Date and come
before the End Date. When these requirements are met, a list of available contracts (if
more than one exists) is displayed in the search window.]

End Date End date of the underlying Portfolio Swap Contract. The date is defined in the contract and
"read only" in the Pricing Sheet.

Buy/Sell Direction of the trade from the processing organization's perspective.

Underlying Enter the underlying equity. Double-click the Underlying field and click the down arrow to
open the Underlying Product Chooser.

Quantity Enter the number of shares.

Gross Price Enter the gross initial trade price of the equity.

Initial Price Initial price is a net price calculated by the system and "read only" in the Pricing Sheet. When
the contract specifies Commission Pay Method as either Upfront or Upfront Quantity, the
Initial Price equals the Gross Price. When the Commission Pay Method is Embedded, The
Initial Price is dependent on the direction of the trade.

• Buy: Initial Price equals Gross Price minus Gross Price multiplied by the Commission
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Property Description

(bps).

• Sell: Initial Price equals Gross Price plus Gross Price multiplied by the Commission (bps).

Initial Price (Settle
Ccy)

This field is "read only" on the Pricing Sheet. A value is provided only when the settlement
currency is different from the contract currency and the FX Conversion Method is Compo. It
is defined as the initial price converted into settlement currency using the Initial FX Reset of
the trade.

Commission (bps) The commission fee rate in bps. The value is automatically populated from information on
the Country Grid tab of the contract. When the direction of the trade is Buy, the commission
rate is taken from the Long Commission (bps) field. In the case of a Sell trade, this value
comes from the Short Commission (bps) field. However, this value can be overridden at the
trade level and entered manually in the Pricing Sheet.

When the contract specifies the Commission Pay Method as Embedded, Commission (bps)
is used to calculate the Initial Price. When the Commission Pay Method is either Upfront or
Upfront Quantity, Commission (bps) is used to calculate the commission at the trade level.

Notional The funding notional of the trade. The value is "read only" in the Pricing Sheet.

• Notional equals Quantity multiplied by Initial Price when:

The underlying equity's currency equals the contract's settlement currency, or

The underlying equity's currency is different from the contract's settlement currency,
but the FX Conversion Method is Flexo.

• Notional equals Quantity multiplied by Initial Price (Settle Ccy) when the underlying
equity's currency is different from the contract's settlement currency and the FX
Conversion Method is Compo.

Leg Type Either Fixed or Float. Defined in the Portfolio Swap Contract and "read only" in the Pricing
Sheet.

FX
Conversion Method

The FX conversion method used when the underlying currency is different from the
settlement currency. The method is chosen in the contract, and this is a "read only" field in
the Pricing Sheet.

• Flexo: Pricing and P&L measures are calculated in the underlying equity's currency and
then converted for Back Office settlements.

• Compo: Pricing and P&L measures are calculated by converting each fixing into the
settlement currency using the FX resets.

7.6 Equity Structured Options
Equity Structured Option is a general term that describes an agreement between two parties to exchange one or more
cash flows based on a payout. The payout formula typically refers to underlyings. The strategies listed in this section
are specific instances of the equity structured option, although Calypso also provides a general Equity Option
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strategy, which provides the flexibility to configure any one of a variety of equity option strategies. However, Calypso
recommends utilizing a specific strategy whenever possible.

7.6.1 Equi ty Vani l la
The Equity Vanilla option forms the basis for other specific options that follow. When capturing the latter, begin
configuring the trade as though it were an Equity Vanilla then enter values for properties directly associated with the
specific type of trade.

Key Properties
Underlying - Buy/Sell - Put/Call - Notional - Strike% - Strike - Quantity - Trade Date - Effective Date - Expiry Date -
Settle Type - Exercise Type

Sample Equity Vanilla trade

Basic Steps for Capturing an Equity Vanilla Option
• Select an underlying: equity, equity index, or basket.

• Enter the trade direction - buy or sell - and whether a put or call.

• Enter the strike for the underlying and the quantity. Or, if a notional trade, enter a
notional and strike percentage.

• Enter the Trade Date, an Effective Date for the start of the trade, and an Expiry Date.

• Enter the Settle Type and Exercise Type.

• Enter basic trade properties such as Book and Counterparty.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Properties Description

Property Description

Buy/Sell Enter buy or sell.

Put/Call Enter PUT or CALL.+

Performance Type Automatically switches between Quantity, Notional, or Strike depending on the information
entered in the Quantity, Notional, or Strike fields below. Defaults to Quantity.

Quantity Enter the quantity.

If quantity is entered, then the performance type of the trade is quantity-based. Strike, Price
and other dependent properties will display amounts. If notional is entered, then Quantity is
calculated as Notional / Spot reference.

Strike Enter the strike.

If strike is entered, then the performance type of the trade is strike-based, allowing the user
to set the strike immediately. If strike is entered, then quantity is calculated as
Notional/Strike.

Notional Enter the notional.

If notional is entered, then the performance type of the trade is notional-based. Strike, Price,
and other dependent properties will display % amounts. If quantity is entered, then notional
is calculated as Quantity * Spot reference.

Strike % Enter the strike percentage. If the Strike % is entered, then Strike = Spot Reference * Strike
%.

Underlying Enter the Equity product for the strategy. To enter a product, define one in the system and
click in the cell to bring up the Underlying Product Chooser window.
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Property Description

You can select a basket, and equity or an equity index. If you choose Basket > <create new
basket...>, the Basket window will appear. You can define a basket to use. Transient baskets
will appear in italics.

Trade Date The date on which both parties agree on the terms of the trade.

Effective Date Start date of the trade.

Expiry Date Enter the expiration date.

Expiry Displays Day/number of Weeks/Weeks or Years until expiration.

Product Type Displays the product type.

Notional Ccy Select the currency of the notional.

Exercise Type Enter European, American, or Bermudan for the Exercise Type.

Settle Type Enter the settle type. Choose Cash, Physical, Quanto, Flexo, or Compo from the drop-down
list.

Settle Ccy Displays the settlement currency.

If CASH, then notional currency of underlying is displayed.

If PHYSICAL, then blank.

If QUANTO or FLEXO, then enter a currency.

Spot Fixing price. Displays the closing rate of the underlying.

Spot Reference Uneditable. Displays the fixing price. Spot Rate as effective date.

Price Format Displays price in amount or %.

If Quantity, then currency (e.g., EUR) is displayed. If Notional, then percent (e.g., EUR%) is
displayed.

Delivery Date Enter the delivery date.

Strike Type Enter the strike type. Choose Fixed, Forward Start, Average or Lookback.

• If Forward Start, then Strike = Strike % * Spot Reference.

• If Average/Lookback, then Strike = Strike % * Spot Reference.

Notional FX Reset Displays the FX rate reset for the notional. FX rate resets are defined from the Calypso Nav-
igator using Configuration > Foreign Exchange > FX Rate Definitions.

7.6.2 Equi ty Barr ier
To capture an Equity Barrier, select the Equity Barrier strategy and enable the following properties in the Pricing Sheet
Profiles window along with the relevant Equity Vanilla properties discussed above.
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Property Description

Barrier Dur-
ation

Enter None, FULL, PARTIAL or EXPIRY.

Barrier Type Enter the barrier type: UI, DI, UO, DO, DKI, DKO, KIKO (UI) or KIKO (DI).

Barrier Enter the upper barrier. You can set the barrier levels as a percentage of the spot reference (Barrier
%) when Barrier Monitoring = Closing, and Barrier Duration = FULL.

Barrier 2 Enter the lower barrier. You can set the barrier levels as a percentage of the spot reference (Barrier 2
%) when Barrier Monitoring = Closing, and Barrier Duration = FULL.

Barrier Mon-
itoring

Enter the barrier monitoring type, Continuous or Closing. When Barrier Monitoring = Closing, and Bar-
rier Duration = FULL, you can define an observation schedule in the Supplemental panel.

Barrier Start
Date

Displays the start date.

Barrier End
Date

Displays the end date.

Rebate Displays the rebate amount.

Rebate Ccy Displays the rebate currency type.

Rebate Tim-
ing

Displays the rebate timing.

Performance
Type

Automatically switches between Quantity, Notional, or Strike depending on the information entered in
the Quantity, Notional, or Strike fields below. Defaults to Quantity.

7.6.3 Equi ty Dig i ta l
To capture an Equity Digital, select the Equity Digital strategy and enable the following properties in the Pricing Sheet
Profiles window along with the relevant Equity Vanilla properties discussed above.

Property Description

Trigger Dur-
ation

Enter None, FULL or EXPIRY.

Trigger
Type

Enter OT Up/Down or Above Below.

Payout
Type

Displays the digital type.

Barrier Mon-
itoring

Enter the barrier monitoring type, Continuous or Closing. When Barrier Monitoring = Closing, and Barrier
Duration = FULL, you can define an observation schedule in the Supplemental panel. This applies only
to DOT/DNT options.

Trigger Enter the upper trigger. You can set the trigger levels as a percentage of the spot reference (Trigger %)
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Property Description

when Barrier Monitoring = Closing, and Barrier Duration = FULL.

Trigger 2 Enter the lower trigger. You can set the trigger levels as a percentage of the spot reference (Trigger 2
%) when Barrier Monitoring = Closing, and Barrier Duration = FULL.

Digital
Amount

Enter the payout quantity.

7.6.4 Equi ty Asian/Lookback
To capture an Equity Asian/Lookback, select the Equity Asian or Equity Lookback strategy and enable the following
properties in the Pricing Sheet Profiles window along with the relevant Equity Vanilla properties discussed above.

Property Description

Function Select the averaging function for Asian options. This is done in the Supplemental panel.

• Arithmetic — Arithmetic average options where the average is ∑xn, cannot be valued using a closed
form solution. There are approximations (Turnbull and Wakeman 1991), that are fairly accurate, or Monte
Carlo simulations can be applied.

• Geometric — Geometric average options where the average is ((x1…xn)1/n), have a closed form
solution, but are far less common in practice than arithmetic averages.

Strike % Enter the strike percentage for strip generation.

7.6.5 Equi ty Cl iquet
A Cliquet is a multi-period option with a single payoff at maturity. Select the Equity Cliquet strategy and enable the
properties in the table below along with the relevant Equity Vanilla properties discussed above.

Each period has a return that can be floored and/or capped. The Cliquet schedule can be generated and viewed in the
Supplemental panel.

Property Description

Initial Coupon Enter the Initial Coupon. It is used as a base coupon that period returns are added to.

Participation Enter the percentage of the return to return to the user.

Global Cap The maximum return for the payoff.

Global Floor The minimum return for the payoff.

Local Cap The maximum return for any given reset period.

Local Floor The minimum return for any given reset period.

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



7.6.6 Equi ty Chooser
The Chooser Payoff allows the holder to choose whether to enter into one of two possible options on the Expiration
Date. Each of the possible options has its own Strike, Put/Call and Maturity Date. All options are European. In addition
to Equity Vanilla properties shown above, add the following properties to the Equity Chooser strategy.

Property Description

Compound Settlement Type Enter Cash or Physical.

Compound Put/Call Enter the Put and Call for each leg.

7.6.7 Def in ing an Observat ion Schedule
For Equity Barrier options and Equity Digital options, you can define an observation schedule in the Supplemental
panel when Barrier Monitoring = Closing. Right click the strategy and select Supplemental to access the Supplemental
panel.

'

The start date and end date default to the strategy's details.

Step 1 - Select the frequency, date roll convention, and holidays.

Step 2 - Click Save and Close to generate the schedule.

7.7 Correlat ion Swap
A Correlation Swap is an OTC transaction between two parties to exchange the difference between a “Strike
Correlation” and the “Realized Correlation”.

Key Properties
Notional - Notional Ccy - Buy/Sell - Start Date - Expiry Date - Delivery Date - Underlying - Strike %
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Properties Description

Property Description

Notional Enter the notional.

If notional is entered, then the performance type of the trade is notional-based. Strike, Price, and other
dependent properties will display % amounts. If quantity is entered, then notional is calculated as
Quantity * Spot reference.

Notional
Ccy

Select the currency of the notional.

Buy/Sell Enter buy or sell.

Start Date Enter the start date of the swap.

Expiry Date Enter the expiry date of the swap.

Delivery
Date

Enter the delivery date of the swap.

Underlying Enter the Equity product for the strategy. To enter a product, define one in the system and click in the
cell to bring up the Underlying Product Chooser window.
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Property Description

A user can search Equity products or ADRs.

» See Calypso Equity Derivatives documentation for more details.

Strike % Enter the strike percentage. If the Strike % is entered, then Strike = Spot Reference * Strike %.

7.8 Scriptable OTC Products
In order to capture Scriptable OTC Product trades , you need create custom strategies that use a Pricing Script.

Please refer to the Calypso Pricing Sheet Setup Guide for details on building custom strategies.

All the information regarding the pricing script associated with the trade can be found in the Supplemental panel.

You can right-click a SCOT trade in the Pricing sheet and choose:

• "Supplemental" - To display the pricing script details in the supplemental panels.

• "Export Script Data" - To export the pricing script details to an HTML file. You can also use the scheduled task
EXPORT_SCRIPT_DATA.
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8. Capturing ETF Trades
To capture an ETF trade in the Pricing Sheet, you first need t o define ETF products.

This is described below.

Then select the ETF strategy and set the properties as needed.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Prerequisite
Make sure that you add ETF to the domains "ProductType" and "PositionBasedProduct".

8.1 Defining ETF Products
ETF products are created using the ETF window (menu action am.structure.etf.ETFFundWindow).
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» To view an existing ETF, click . You will be prompted to select an ETF. Modify as needed and click to save
your changes.

» To create a new ETF, click . Enter the fields in the various panels as described below, and click to save the
ETF.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Upon saving, the ETF is given a unique id by the system.

8.1 .1 Sett ings Panel
Select the Settings panel to enter the ETF's details.

Details

Fields Description
Name Enter a name to identify the ETF throughout the system.

ETF Description Enter the ETF description.

Currency Select the ETF's currency.

Asset Class Select the asset class of the ETF.

These values come from the domain UnitizedFund.subtype.

Settlement Days Enter the number of days between the trade date and the settlement date in the form
T+<number of days>.

Expense Ratio % Not currently used.

Units

Fields Description
Unit Size Enter the unit size or ETF divisor.

Outstanding Shares Number of ETF shares as of latest effective date of ETF constituents.

Benchmark
Benchmark Index and Leverage are not currently used.

Pricing Env

Fields Description
Pricing Env Not currently used.
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8.1 .2 ETF Const i tuents Panel
ETF Constituents can be uploaded using a Portfolio Composition File (PCF) or using the Data Uploader, and can also
be copy pasted from an Excel Spreadsheet and Clipboard.

Currently Equity and Equity Index are supported as constituents.

You can also add constituents manually as needed.

NOTE: Theoretical pricing uses constituents with Effective Date <= Value Date.

Sample PCF File

8.2 ETF Trades
You can capture ETF trades using the Pricing Sheet or using the Data Uploader.
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Pricing from Quote
When pricing parameter NPV_FROM_QUOTE=TRUE, price is taken from ETF quote (market price).

Theoretical Pricing
When pricing parameter NPV_FROM_QUOTE=FALSE, price is calculated from constituents quotes (market prices).
The theoretical price is the sum of cash component and weighted price (i.e., Price * Quantity) of each component.

8.3 Posit ions
Liquidation methods FIFO and AvgPrice are both supported with comparator method TradeDate.
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8.4 Sensit iv ity Analysis
When Explode Trades is checked, sensitivities are shown at constituent level using "dummy" child trades.

8.5 Off icial P&L Report
Official P&L Explain by Greeks is supported.

In Intraday, change in quantity of constituents, is not expected. Hence OPL explain by Greeks is correct.

From T-1 to T, the PnL attribution due to rebalancing will be categorized as Unexplained or Residual.
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9. Capturing Fixed Income Trades
To capture a Fixed Income trade in the Pricing Sheet, , you first need t o define Bond products.

Please refer to Calypso Fixed Income Trading for details.

Then select the Bond strategy and set the properties as needed.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to Fixed Income trades are described below.

Contents

- Bond Trade

- Treasury Lock

- Inflation Lock

- Search Bonds Window

9.1 Bond Trade

Properties
Customer Price - Rate - Settlement Date - Next Coupon - Settlement - Notional - Yield - Spot - Underlying
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Sample Bond Trade

"Trade" Properties

Properties Description

Discount Displays the discount.

Margin For floating rate bonds, displays the DISC_MARGIN pricer measure, which calculates the
spread added to current rates to equal the bond yield.

You can enter a discounted margin to solve for the clean price.

Cash Rate Displays the cash rate.

TM Displays the traded margin.

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Notional Enter the Nominal in this field. It will update the Quantity accordingly.

Notional Ccy Displays the nominal currency of the selected bond.

Buy/Sell Select the direction of the trade: Buy or Sell.

Settle Ccy Displays the Proceed currency.
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Properties Description

Quantity Enter the Quantity in this field. It will update the Notional accordingly.

"Product: Rate" Properties

Properties Description

Rate Displays the current coupon rate for the selected bond.

"Date" Properties

Properties Description

Next Coupon Displays the date for the next coupon payment.

Settlement Date Select the settlement date. Defaults to the Trade Date + the number of Settle Days
specified in the Bond Product Definition.

The Settlement Date uses the holiday calendar of the bond product to identify business
days.

If the trade date is changed, user can enter "0D" to update the Settlement Date accordingly.

"Price" Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Trader Price Enter the clean price for the bond.

Customer Price Enter the clean price for the bond.

Sales Price Displays the unit amount of sales premium based on the selected Price Format.

Sales Premium Displays the Sales Fee in premium currency.

Sales Premium for Bond allows you to enter a flat amount rather than enter the Sales Price.
Alternatively, entering the Sales Price will automatically calculate the Sales Premium.

Negotiated Price Type Displays the negotiated price type.

Settlement Amount Displays the settlement amount in the settlement currency.

Settlement Principal Displays the settlement principal.

Settlement Accrual Displays the settlement accrual.
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Properties Description

Current Notional Displays the current nominal.

Clean Price Enter the clean price (value of bond - accrued interest).

Dirty Price Enter the dirty price (value of bond + accrued interest).

Gross Price Displays inflation adjusted price. This value is for Inflation Bonds only.

Yield Enter the yield to maturity based on bond inputs.

Spot Displays the market quote for the bond.

Underlying Displays the Bond Product details for the selected bond product. To select a bond product
double-click in this field to bring up the Search Bonds window. See below.

Product ID Enter the bond product identifier.

Product ID Type Select the product ID type to choose from when entering values in the Product ID field.

A default search type can be configured in Configuration > User Preferences under the
Defaults tab. Select the default search type form the Default Bond Product ID type drop
down.

Setting this in the trade leg specifically will override the value set in the defaults.

9.2 Treasury Lock
A Treasury Lock is a customized agreement that fixes the yield, clean price, or dirty price of a specific treasury bond
on a specific date in the future. On that future date, or lockout date, you can exercise the Treasury Lock by choosing
Processing > Exercise, which populates the trade keywords PriceAtLockout, Final DV01/Duration, and Settlement
Amount once they are available as properties.

Descriptions of these keywords can be found below.

Key Properties
Product ID - Underlying - Lockout Date - Notional - Negotiated Price Type - Lock Yield - Lock Price - Funding Rate -
DV01
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Sample Treasury Lock trade

Basic Steps for Capturing a Treasury Lock Trade
• Choose the underlying bond for the trade in either the Product ID or Underlying field.

• Set the direction of the trade as either Buy or Sell.

• Enter a lockout date.

• Select the Negotiated Price Type: yield, clean price, or dirty price.

• Enter the Lock Yield or Lock-Price, depending on the Negotiated Price Type selection.

• Define the notional value for the trade in conjunction with quantity.

Properties Description

Properties Description

Settlement Date The settlement date defaults to the trade date plus the number of Settle Days specified in
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Properties Description

the bond product's Bond Window.

The settlement date uses the holiday calendar of the bond product to identify business
days.

If you change the trade date, double-click in the Settlement Date field to update the
settlement date accordingly.

Product ID Displays the Product ID for the bond underlying the trade. Double-click the field and enter
the bond name or security code. Once you begin typing, a list of bonds matching the entered
information is populated.

Alternatively, you can search for a bond using the Search Bonds window. See the Underlying
property below.

Underlying Displays the Bond Product details for the selected treasury bond product. To select a bond
product, double-click this field to open the Search Bonds window.

 Ⓘ [NOTE: After selecting a bond, you can open the Bond Window by displaying either
Leg Details or Underlying Details in the Tools Panel, and clicking beside the
Underlying field or Product ID field, respectively. See Calypso Using the Pricing Sheet
documentation for more details on Tools Panel features.]

Buy/Sell Direction of the trade from the book’s perspective. Double-click the Buy label to change to
Sell as applicable.

Lockout Date Enter a lockout date, which defines the end of the lockout period.

Delivery Date The Delivery Date is based on Lockout Date plus Settlement Lag/Holidays. The date is
populated automatically once the Lockout Date is entered, although it can be overridden
manually in the Delivery Date field. See description of the Settle Type property below.

Settle Type The system sets the value to Cash Settle Clean Price, Cash Settle Dirty Price, or Cash Settle
Yield, depending on the Negotiated Price Type.

The following properties can also be set by clicking the Settle Type label:

• Settlement Lag - The number of lag days, months, or years. This is the offset between
the expiration date and the delivery date. The lag will reflect Settle Days value in the
Bond Window. Specify the lag as Business days or Calendar days.

Examples: 3D Calendar, 1M Calendar, 1Y Business, etc.

• Settlement Holidays - The holiday calendar.

Notional Enter the notional amount after the underlying bond is selected. The system autopopulates
the quantity, based on quantity being equal to notional divided by face value.

Negotiated Price Type Select the negotiated price type: Clean Price, Dirty Price, or Yield. This selection determines
the Settle Type.

Lock Yield The yield for the locked period. Enter a value for Lock Yield when the Negotiated Price Type
is set to Yield.
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Properties Description

If the Negotiated Price Type is CleanPrice or DirtyPrice, the Lock Yield field value is a
converted yield.

Lock Price The price for the locked period. Enter a value for Lock Price when the Negotiated Price Type
is set to either CleanPrice or DirtyPrice.

If the Negotiated Price Type is Yield, the Lock Price field value is a converted price.

Rate Displays the fixed coupon rate of the underlying bond.

Quantity The quantity is linked to the Notional value and is calculated by the system once the
Notional has been entered. The Quantity equals the Notional divided by the face value of the
bond.

Clean Price

Yield

Dirty Price

Clean Price: Clean Price is the underlying bond's clean spot price based on the Settlement
Date.

Yield: Yield is the underlying bond's spot rate for yield based on the Settlement Date.

Dirty Price: Dirty Price is calculated as the underlying bond's dirty spot price based on the
Settlement Date.

• The dirty price is clean price plus unit accrual.

• For bonds quoted using Price32, the trade’s price can have two, three, or four digits
after the dash. The first two digits represent the number of thirty-seconds (between 1
and 31).

If the price contains 3 digits, the third digit represents the number of eighths of a thirty
second (or 1/256, between 1 and 7). A bond price entered as "99-022" will be read as
[99 + 2/32 + 2/8(1/32)], or 99.0703125. The third digit can also be +, indicating 4/8 of a
thirty second.

If the price contains 4 digits, the last two digits represent the number of sixteenths of a
thirty second (or 1/512, between 1 and 15). Note that the four-digit logic only applies to
bonds with the tick size 512.

Next Coupon Displays the date of the next coupon retrieved from the coupon schedule.

Settlement Accrual Displays the settlement accrual for the underlying bond.

Funding Rate Funding rate is the repo rate used to compute the forward bond price. It is calculated from
the curve, or it can be entered manually (which overrides the repo rate from the curve).

DV01 The dollar value of a one‐basis point change in the contract forward yield. When left blank,
the system uses the DV01 pricer measure for pricing and settlement.

Trader Price Displays the trader price: either Yield or Price type based on the selected Negotiated Price
Type.

Related Trade Attributes (Keywords)
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Keyword Description

PriceAtLockout Set at the exercise of the trade and captures price or yield on the lockout date.

Final DV01/Duration Set at the exercise of the trade when Settle Type is Cash Settle Yield and captures DV01 on
the lockout date.

Settlement Amount Set at the exercise of the trade and captures the Settlement Amount.

9.3 Inf lat ion Lock
An inflation lock is a customized agreement that fixes the yield or price on a specified inflation bond at a specific date
in the future. On the future date, you can exercise the Inflation Lock using Processing > Exercisewhich also
populates the trade keyword "PriceAtLockout".

 Ⓘ [NOTE: Inflation locks are only supported for the Israeli CPI market]

Properties
Lockout Date - Lock Yield - Lock Price - Duration - Funding Rate

Sample Inflation Lock trade

Properties

Properties Description

Buy/Sell Direction of the trade from the book’s perspective. Double-click the Buy label to change to
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Properties Description

Sell as applicable.

Settle Type Select the settle type: Cash Settle Price, Cash Settle Yield, or Physical Settle.

The following properties can also be set:

• Settlement Lag - A number of lag days, months, or years. This is the offset between the
expiration date and the delivery date. Specify the lag as Business days or Calendar days.

Examples: 3D Calendar, 1M Calendar, 1Y Business, etc.

• Settlement Holidays - The holiday calendar.

Lockout Date Select the lockout date which identifies the end of the lockout period.

Delivery Date Enter the delivery date.

This date is based on Lockout Date + Settlement Lag/Holidays.

Negotiated Price Type Select the negotiated price type: Dirty Price or Yield.

Trader Price Displays the trader price: either Yield or Price type based on the selected Negotiated Price
Type.

Lock Yield The yield for the locked period.

If the Negotiated Price Type is "Dirty Price", then the Lock Yield will convert to Yield after a
dirty price is entered into the Lock Price field.

Lock Price Enter the lock price.

If the Negotiated Price Type is a "Yield", then the Lock Price will convert to Dirty Price after a
yield is entered into the Lock Yield field.

Observation Type Displays how the Lockout Rate is calculated, as a Single Yield or Average Yield.

In the case of an Average Yield, you can reset the yield using the standard reset process.
You can also right-click "Average Yield" and choose "Supplemental" to view the resets.

Fixings Displays the number of daily fixings for averaging the yield.

The following properties can also be viewed:

• Schedule Start Date - The schedule start date.

• Schedule End Date - The schedule end date.

Duration Displays the duration of the underlying bond.

Funding Rate Enter the funding rate.

Settlement Date The settlement date defaults to the trade date + the number of settle days specified in the
bond product.

The settlement date uses the holiday calendar of the bond product to identify business
days.

If you change the trade date, double-click in the Settlement Date field to update the
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Properties Description

settlement date accordingly.

Clean Price

Yield

Dirty Price

Gross Price

Enter the clean price, yield, dirty price, or gross price, and the other fields will be calculated
accordingly.

The dirty price is clean price + unit accrual.

The gross price is the inflation adjusted price.

For bonds quoted using Price32, you can enter the trade’s price with two, three, or four
digits after the dash. The first two digits represent the number of thirty-seconds (between 1
and 31).

If the price contains 3 digits, the third digit represents the number of eighths of a thirty
second (or 1/256, between 1 and 7). A bond price entered as "99-022" will be read as [99 +
2/32 + 2/8(1/32)], or 99.0703125. The third digit can also be +, indicating 4/8 of a thirty
second.

If the price contains 4 digits, the last two digits represent the number of sixteenths of a thirty
second (or 1/512, between 1 and 15). Note that the four-digit logic only applies to bonds with
the tick size 512.

Settle Ccy Displays the settlement currency.

FX Rate Displays the FX rate.

Settlement Accrual Displays the settlement accrual.

Next Coupon Displays the date of the next coupon retrieved from the coupon schedule.

Rate Displays the rate.

Underlying Displays the Bond Product details for the selected inflation bond product. To select a bond
product double-click in this field to bring up the Search Bonds window. See below.

Product Type Displays the bond class.

Product Subtype Displays the bond type.

9.4 Search Bonds Window
The Search Bonds window functions similarly to the Bond Report window. Enter parameters for your search and
select a desired bond product.
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» Enter search parameters.

» Click Find Bonds.

» Double-click the desired bond to load it to the Pricing Sheet.
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10. Capturing FX Trades
To capture an FX trade in the Pricing Sheet, select the FX strategy and set the properties as needed.

 Ⓘ [NOTE: Strategy templates are not currently implemented for FX strategies]

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to FX trades are described below.

Contents

- FX Spot Trade

- FX Forward Trade

- FX Swap Trade

- FX NDF Trade

- FX Forward Start Trade

- FX Window Forward Trade

- FX Averaging Forward Trade

- Simple Transfer Trade

- Split Rates and Routing

10.1 FX Spot Trade

The Pricing Sheet allows for non-standard settlement of spot trades. You may select the product type manually,

regardless of the Settlement Date. A validation is applied based on the setting in the Currency Defaults window,

Currency Pairs panel Max Spot Days column.
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Properties
Ccy Pair - Notional - Ccy1 Amount - Ccy2 Amount - Delivery Date = "Spot Date" (default) - Settle Type = "Physical"

Sample FX Spot trade

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Constants Displays any value used in solving that is entered manually like Strike, etc.

Ccy Pair Displays the default currency pair if any. The default currency pair is set in Configuration >
User Preferences.

You can select another currency pair as needed.
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Properties Description

If a split currency is defined for the selected currency pair (through a triangulation rule), you
can right-click and select Supplemental to enter the split rates as needed. You can also view
the Routing information.

See Split Rates and Routing panel for details.

Notional Ccy Select the currency of the notional.

Buy/Sell Select the direction of the trade: Buy or Sell.

Settle Type Select the Settle Type:

• Physical: Physical settlement.

• Cash: Cash settlement.

• NDF: Settles as a non-deliverable forward.

• NDF-Quanto: A non-deliverable forward that settles in a third currency. It uses reset for
conversion instead of a fixed rate determined at inception. The Settle currency can be
selected either as the primary or secondary and the third currency reset is selected as
per the settle currency.

Location Select the location for commodities.

Allocated Displays "Allocated" if the trade has been allocated using the Allocation process, or
"Unallocated" otherwise.

"Product: Rate" Properties

Properties Description

Strike Enter the spot rate.

Rounding
Any system generated strike (solver, shortcut entry) will respect the currency pair rounding
settings. If the user manually enters a strike, it will only be rounded based on the constraints
of the currency rounding of the amounts that the strike generates.

Example: Ccy1 amount is 10,000.00 and a strike is entered as 1.234567.

• If ccy rounding of Ccy2 is 2dp then Ccy2 amount would be 12345.67. The strike does
not need to be rounded.

• If ccy rounding of Ccy2 is 0dp (JPY for example) then Ccy2 amount would be 12346 and
the strike would need to be rounded to 1.2346.

"Date" Properties

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Properties Description

Trade FX Date Displays the trade date adjusted by the 5pm rule if set.

Trade Date Displays the valuation date set in the Pricing window of the pricing sheet by default.

You can modify as needed.

See Using the Pricing Sheet for details.

Trade Time Displays the valuation time set in the Pricing window of the pricing sheet.

You can modify as needed.

See Using the Pricing Sheet for details.

Delivery Date Enter the delivery date.

You can enter a relative term for the delivery, for example, “1m” for one month.

The Trade Term property will be updated accordingly.

Delivery Displays details on the delivery date.

Trade Term Displays the delivery date as a tenor.

"Price" Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Model Price Displays the theoretical price computed by the pricer.

Trader Price Displays the theoretical price computed by the pricer. You can modify its value.

Customer Price Displays the customer price such that:

• Customer Price = Trader Price + Sales Price (Sell)

• Customer Price = Trader Price - Sales Price (Buy)
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Properties Description

Sales Price Enter the sales price as needed. Default value is Spot Margin + Points Margin.

"FX Trade Data" Properties

Properties Description

Trade FX Spot Enter the Spot Rate of the FX trade.

Spot Margin Enter the Spot Margin. This field is disabled if Sales Person is set to NONE.

Final Spot Displays the Final Spot such that:

• Final Spot = Trade FX Spot - Spot Margin (Buy)

• Final Spot = Trade FX Spot + Spot Margin (Sell)

Location Spread (Precious Metal) The premium over the Loco-London spot price (i.e. Trade FX Spot) of a
specific Physical form of precious metal at a particular location. This spread is always
quoted in USD/oz and is used to adjust the Loco-London spot rate.

You may enter an absolute value or a percentage of the Loco-London Spot for the spread.

The base location for each precious metal is designated in the
PreciousMetalBaseLocation.currency domain value. For example,
PreciousMetalBaseLocation.XAU.

You may also designate the base location from the Currency Definition window for the
metal. (Configuration > Definitions > Currency Definitions).

10.2 FX Forward Trade

Properties
FX Spot properties - Delivery Date = "Forward Date" - Settle Type = "Physical" - Fwd Points - FX Fwd
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Sample FX Forward trade

"FX Trade Data" Properties

Properties Description

Trade Fwd Points FX Forward Rate - Spot Rate.

Points Margin Enter the points to apply on the margin for the trade. This field is disabled if Sales Person is
set to NONE.

Final Points Displays the Final Points such that:

• Final Points = Trade Fwd Points - Points Margin (Buy)

• Final Points = Trade Fwd Points + Points Margin (Sell)

Trade Ccy 1 Rate Calculated from Fwd Rate. Can be manually captured to derive a missing value due to lack
of liquidity in the market.
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Properties Description

Trade Ccy 2 Rate Calculated from Fwd Rate. Can be manually captured to derive a missing value due to lack
of liquidity in the market.

"Product: Style" Properties

Properties Description

Settle Type Select the Settle Type:

• Physical: Physical settlement.

• Cash: Cash settlement.

• Quanto: Enables settlement in a third currency. It uses reset for conversion instead of a
fixed rate determined at inception. The Settle currency can be selected either as the
primary or secondary and the third ccy reset is selected as per the settle ccy.

• NDF: Settlement as a non-deliverable forward.

• NDF-Quanto: The same rules apply as for Quanto but as a non-deliverable forward.

10.3 FX Swap Trade
Sample FX Swap trade.
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"FX Trade Data" Properties

Properties Description

Fwd/Fwd Read-only combined cell for both legs of the Swap describing the forward points calculated
following a change to the FX Swap Interest Rate.

Swap IR Editable interest rate for swaps for both legs. Impacts the forward points.

10.4 FX NDF Trade

Properties
FX Forward properties - Delivery Date = "Forward Date" - Settle Type = "NDF" - Settle Ccy - Settlement Source -
Reset Date
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Sample FX NDF trade

"Product: Style" Properties

Properties Description

Settle Ccy Select the settlement currency. It should be the deliverable currency.

Settle Type Select NDF.

"Product: Rate" Properties

Properties Description

Settlement Source Select an FX Rate Definition to fix the FX rates for cash settled trades. FX Rate Definitions
are configured from the Calypso Navigator using Configuration > Foreign Exchange > FX
Rate Definitions.

Reset Date Displays "Delivery Date - Number of lag days defined in the FX Rate Definition".

It is based on the FX Rate Definition selected in Settlement Source.
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Properties Description

You can modify as needed.

Rate Reset Window
To open the Rate Reset window, right click in the FX NDF deal and select "Supplemental".

10.5 FX Forward Start Trade

Properties
Strategy Name is FXForwardStart (Swap) or FXForwardStart (Forward)
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Sample FX Forward Start trade

"Product" Properties

Properties Description

Product Subtype The type of underlying trade that the FX Forward Start converts to on the reset date.

"Date" Properties

v Description

Reset Effective Date The date on which the FX Forward Start trade is converted to the underlying trade type (i.e.
Swap or Forward).

10.6 FX Flexi Forward Trade

Properties

Flexi Forward Take Up Schedule
To open the Schedule tab, right click in the FX Flexible Forward deal and select "Supplemental".

Double-clicking on the row of a take up opens the FX Forward trade that is generated from the take up.
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10.7 Merchant FX Trade

Properties
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10.8 FX Window Forward Trade

Properties
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Sample Window Forward trade

Window Forward Properties
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Properties Description

Window Forward Type PRIMARY, OFFSET, or RISK. Counterparty trades are of type PRIMARY. Backout from the
sales book is of type OFFSET. Forward desk trade is of type RISK.

Right-clicking on the trade, and choosing "Supplemental" will bring up the Window Forward Actions tab (as well as the
Split Rates and Routing Tab). From here, the TAKEUP action can be applied to the trade. Right click on a row in the
Forward Actions tab to make the UndoTakeUp option appear.

10.9 FX Averaging Forward Trade

Properties
FX Averaging Forward properties - Settle Type = "Cash" or "Quanto". Fixing Start -Fixing End -Fixing Frequency.

Sample FX Averaging Forward Trade

"Fixings" Properties
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Properties Description

Fixing Start The start date for the rate fixing.

Fixing End The end date for the rate fixing.

Fixing Frequency The frequency with which rate fixings are calculated: Daily, Weekly, Monthly, Biweekly (BW),
Bimonthly (BM), Semi-annually (SM).

FX Averaging Schedule
To open the FX Averaging Schedule tab, right click in the FX Averaging Forward deal and select "Supplemental".

To change the weight for the rate of any particular reset date, double-click the cell in the weight column
corresponding to that date, and enter the weight.

To add additional reset dates for a customized schedule, press , and enter the date.

To remove a reset date from the schedule, select the reset and press .

When you are finished, press .

10.10 Simple Transfer Trade

Properties
Buy/Sell - Notional - Notional Currency - Settle Type = "Currency"

Sample Simple Transfer trade

"Product: Style" Properties
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Properties Description

Product Type Displays the product type based on the selected strategy.

Notional Ccy Select the currency of the notional.

Buy/Sell Select the direction of the trade: Buy or Sell.

Settle Type Displays "Currency".

10.11 Spl it Rates and Routing
You can right-click an FX trade and choose “Supplemental” to bring up the Split Rates and Routing panel.

Split Rates for FX Spot, FX Forward, and FX Non-Deliverable Forward
The Split Rates panel only appears if a split currency is defined for the selected currency pair (through a triangulation
rule).

Sample Split Currency

» Enter the rates and points as needed and click Apply to apply the rates to the trade.

Split Rates for FX Swap, and FX Non-Deliverable Swap
The Split Rates panel only appears if a split currency is defined for the selected currency pair (through a triangulation
rule).
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Sample Split Currency

» Enter the rates and points as needed and click Apply to apply the rates to the trade.

Routing

Please refer to FX Deal Station documentation for details on the Routing panel.

10.12 Rol lover / Rol lback History
The rollover and rollback history for any booked FX trade can be viewed by navigating to Processing
> Rollover/Rollback History.
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11. Capturing FX Option Trades
Before capturing FX Option trades in the Pricing Sheet, the following market data items are required:

• Spot rate

• Vol surface

• Two interest curves, or, one interest curve + one FX Fwd curve

To capture an FX Option trade in the Pricing Sheet, select an FX Option strategy and set the properties as needed.
You can also select a strategy template to populate default values.

Sample Strategy and Template selection

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to FX Options are described below.

Contents

- Vanilla Strategies

- Accrual Strategies

- Asian Strategies

- Barrier Strategies

- Compound Strategies

- Digital Strategies

- Forward Starting Strategies
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- Lookback Strategies

- Volatility Forward Strategies

- FX Target Redemption Forwards

- Inverting Quanto and Flexo Settled Strategies

- "Volatility and Variance Swaps Strategies" on page 237

- "Volatility and Variance Options Strategies" on page 240

11.1 Vani l la Strategies
This also applies to Butterfly, Condor, Reversal, Spread, Straddle, and Strangle strategies.

Properties
Product Type - Constants - Ccy Pair - Notional Ccy - Settle Ccy - Quanto Ccy Pair - Quanto Factor - Buy/Sell -
Put/Call - Ccy2 Put/Call - Exercise Type - Settle Type - Location - Allocated - Strike - Strike % itmf - Strike Inverse -
Settlement Source

Sample Vanilla FX Option

"Trade" Properties
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Properties Description

Customer Pay/Rec The values available for this property are “Customer Pays” and “Customer Receives.” The
value is driven by the sign of the Customer Premium: negative populates “Customer
Receives” while positive populates “Customer Pays.”

In the case where multiple options with different directions are open in the same pricing
sheet, the property helps keeping track of pay and receive obligations with customers.

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Constants Displays any value used in solving that is entered manually like Strike, etc.

Ccy Pair Displays the default currency pair if any. The default currency pair is set in Configuration >
User Preferences.

You can select another currency pair as needed.

Notional Ccy Select the currency of the notional. In a Digital or Digital with Barrier, Notional Ccy = Settle
Ccy.

Settle Ccy Select the settlement currency for cash trades and self-quanto trades:

• Primary Currency - Asset-or-Nothing - For a cash settlement, the trade becomes a
quanto trade, and you can enter the quanto factor.

• Secondary Currency - Cash-or-Nothing.

Quanto Ccy Pair Only applies to "Self Quanto" or "Quanto" set as a Settle Type.

Displays the currency pair used in the Quanto. This is Settlement Ccy/Secondary Ccy in the
defined currency pair. The currency pair is defined in the Calypso Navigator under
Configuration > Definitions > Currency Definitions....

Quanto Factor Only applies to "Self Quanto" or "Quanto" set as a Settle Type. Not available with Digital and
Digital with Barrier strategies.

Enter the rate between the quoting currency and the primary currency if the settlement
currency is the primary currency.

You can enter "k" to populate it with the strike rate, "s" for spot rate, or enter a fixed rate.
The trade keyword "QuantoSource" will be populated accordingly.

Flexo FX Source Only applies to the "Flexo" Settle Type.

Choose the FX rate source for Flexo type trades.

Buy/Sell Select the direction of the trade: Buy or Sell.

Put/Call Enter / displays the option direction for the primary currency.
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Properties Description

Ccy2 Put/Call Displays / enter the option direction for the quoting currency.

Exercise Type Select the exercise type:

• European (default value) - The option may only be exercised on the expiry date.

• American - You can exercise the option anytime during the life of the option.

Settle Type Select the settlement type at exercise. The application may automatically select it based on
the product type.

• Physical - For physical settlement (exercise against the underlying product) - A trade on
the underlying product is automatically created. FX points are calculated to the payment
date.

• Physical NDF - For physical settlement into an NDF product. FX points are calculated to
the valdate of the fixing date of the related NDF

• Cash - For cash settlement (exercise against a fee).

• Self Quanto - For cash settlement in primary currency, with a fixed conversion factor
(quanto factor). Only available for Vanilla, Barrier, Barrier with Digital, and Forward Start
strategies.

• Quanto - For the settlement currency in a third currency type, with a fixed conversion
factor (quanto factor). Only available for Vanilla, Barrier, Barrier with Digital, and Forward
Start strategies.

• Flexo - For a settlement currency in a third currency type with a configure FX Rate
source. Only available for Vanilla, Barrier and Forward Start strategies.

Location Select the location for commodities.

Allocated Refers to physical Precious Metal trades. Displays allocated/unallocated metal status. This
field has no connection to the ALLOCATE trade status.

"Product: Rate" Properties

Properties Description

Strike Enter the strike.

The following FX Delta shortcuts are also available. Add the shortcut to the Strike property
field and press Enter.

• You can enter "atm" to solve for an at-the-money forward. This gives the at-the-money
strike for the given currency pair and tenor. The premium in Delta convention and the
Delta-neutral-or-atm-forward convention are taken from the vol surface. This is the
most commonly used shortcut because it produces the "at-the-money" strike whether
it's Delta neutral or ATMF.

• You can enter "atms" to solve for an at-the-money spot. This gives the strike equal to
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Properties Description

the current spot rate.

• You can enter "atmf" to get the strike equal to the current outright forward.

• You can enter "dn" to set the strike to the ATM delta neutral strike generated from the
supplied vol surface and expiry date.

• You can use the strike to solve for a Delta by entering "<delta value>d", for example
"25d".

• When "<delta value>s" is entered (e.g., 10s), this gives the 25-spot-delta strike, with
premium-in-delta coming from the vol surface.

• When "<delta value>f" is entered (e.g., 10f), this gives the 25-forward-delta strike, with
premium-in-delta coming from the vol surface.

• One percentage strike shortcut: "<delta value>%s" gives the strike equal to spot plus
<delta value>%. Also, "-<delta value>%s" gives the strike equal to spot minus <delta
value>%.

Rounding
Any system generated strike (solver, shortcut entry) will respect the currency pair rounding
settings. If the user manually enters a strike, it will only be rounded based on the constraints
of the currency rounding of the amounts that the strike generates.

Example: Ccy1 amount is 10,000.00 and a strike is entered as 1.234567.

• If ccy rounding of Ccy2 is 2dp then Ccy2 amount would be 12345.67. The strike does
not need to be rounded.

• If ccy rounding of Ccy2 is 0dp (JPY for example) then Ccy2 amount would be 12346 and
the strike would need to be rounded to 1.2346.

The shortcut used will not be persisted if the trade is saved. EX: Entering "atms" in this field
will calculate the at-the-money-strike and will appear as "<strike value> [atms] when
pricing. If the trade is saved, the value is saved, but the shortcut used will not be saved.

Strike % itmf Displays the percentage of strike with respect to "in-the-money" forward: [(FX Fwd -
Strike)/ FX Fwd]*100.

Strike Inverse Displays 1/Strike for an inverted trade.

Settlement Source Select an FX Rate Definition to fix the FX rates for cash settled trades. FX Rate Definitions
are configured from the Calypso Navigator using Configuration > Foreign Exchange > FX
Rate Definitions.

Reset Date Only applies to Physical NDF settle type.

Displays "Delivery Date - Number of lag days defined in the FX Rate Definition".

It is based on the FX Rate Definition selected in Settlement Source.

You can modify as needed.
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"Date" Properties

Properties Description

Trade FX Date Displays the trade date adjusted by the 5pm rule if set.

Trade Date Displays the valuation date set in the Pricing window of the pricing sheet by default.

You can modify as needed.

See Using the Pricing Sheet for details.

Trade Time Displays the valuation time set in the Pricing window of the pricing sheet.

You can modify as needed.

See Using the Pricing Sheet for details.

Expiry Date Enter the expiration date.

You can enter a relative term for the option expiration, for example, “1m” for one month.

The Trade Term property will be updated accordingly.

 Ⓘ [NOTE: The expiration date takes into account "local" holiday calendars defined in
the Defaults panel under Configuration > User Preferences]

Expiry Displays expiration date details.

Expiry Cut Displays the default expiry timezone. The default expiry timezone is set in the Defaults panel
under Configuration > User Preferences.

Expiry Delivery Link Select one of four options in the list:

• On - Links the delivery date to the expiration date using the default set for the currency
pair, so that when one is updated, the other one is updated accordingly.

• Off - The delivery date and expiration are independent of each other.

• Equal - The delivery date and expiration date are made to equal each other.

• T+1 - The delivery date follows one day after the expiry date.

Delivery Date Displays the delivery date of the option. You can modify as needed.

Delivery Displays details on the delivery date.

Trade Term Displays the expiry date as a tenor.

First Exercise Date Enter the first date the option can be exercise for American options.

"Price" Properties
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Properties Description

Premium Date Displays the premium payment date. The system uses the spot date by default. You can
change this to a forward date. If you use a forward date, the application adjusts the premium
amount using the discount curve from the selected pricing environment.

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Sample pricing parameters

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Price Format Select the currency and unit amount of the prices.

The unit amount defaults to the price format specified under Configuration > User
Preferences.

You can select:

• Percentage of the primary amount "<primary currency> %" - For example "EUR %".

Premium primary % = (premium amount / primary amount) * 100.

• Pips of the primary amount "<primary currency> Pips" - For example "EUR Pips".

Premium primary pips = (premium amount / quoting amount) * bp factor.

• Percentage of the quoting amount "<quoting currency> %" - For example "USD %".

Premium quoting % = (premium amount / quoting amount) * 100.

• Pips of the quoting amount "<quoting currency> Pips" - For example "USD Pips".

Premium quoting pips = (premium amount / primary amount) * bp factor.
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11.2 Broker Butterf ly and Broker Strangle Strategies
"Broker" strategies are quoted with the same volatility on all legs, giving them different strikes for a given delta. The
behavior of the Volatility and Strike properties is different from standard Butterfly and Strangle strategies.

A single, linked volatility is entered in these strategies.

Sample Broker Strangle trade

A Broker Butterfly is a Broker Straddle with a delta neutral straddle.

11.3 Accrual Strategies
 Ⓘ [NOTE: Quanto pricing for Accrual strategies is not currently supported]

Properties
Vanilla properties - Range Style - Observation Source - Reset Source - Known 1st Range - Reset Effective Date -
Trigger properties
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Sample Accrual FX Option

"Product" Style" Properties

Properties Description

Observation Type For Accrual and Accumulator options, the choices are:

• Cash Accrual

• FX Accrual

• Vanilla Fade In - Each time the spot condition is met on a fixing date, a portion of the
notional is paid. That is, on expiry date the notional is: "n/N" x "notional amount".

• Vanilla Fade Out - Each time the spot condition is met on a fixing date, a portion of the
notional is deducted from the maximum that can be used. That is, on expiry date the
notional is: "notional amount" - ("n/N" x "notional amount").

Where:

• "notional amount" is the notional amount

• n is how many times the spot satisfies the predefined condition (whether it is meant to
be above/below a predetermined trigger, or inside/outside a predetermined range) on
the predefined fixing dates

• N is the number of fixings dates over the life of the option
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Properties Description

Range Style Select Single for single range, or Multiple for multiple ranges.

• For Single range, you can capture the range in the Trigger properties.

• For Multiple range, right-click the trade and choose "Supplemental" to define the
ranges.

See Setting Accrual Details for details.

Known 1st Range Select Yes if the first range is known for a resetting range, or No otherwise.

If Yes, you can specify the first range in Trigger and Trigger2.

"Product: Rate" Properties

Properties Description

Observation Source Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

Then right-click the FX Rate Definition and choose "Supplemental" to define the accrual
details.

See Setting Accrual Details for details.

Reset Source Select "Not resetting" for non-resetting ranges, or select the FX Rate Definition that will be
used to fix the rates. FX Rate Definitions are configured from the Calypso Navigator using
Configuration > Foreign Exchange > FX Rate Definitions.

Then right-click the FX Rate Definition and choose "Supplemental" to define the fixing
schedule.

See Setting Accrual Details for details.

"Date" Properties

Properties Description

Reset Effective Date Enter the date at which the strike will be known.

"Trade" Properties

Properties Description

Breakeven FX Rate Informs the trader or customer from which point the option begins to make profit, or, on the
other side, from which point the option starts to lose money. It gives an indication of how far
the option is from that point compare to market conditions.
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11 .3 .1 Sett ing Accrua l Deta i ls
To define observation schedules, reset schedules, and ranges for Accrual options, right-click the trade and choose
"Supplemental". Define the schedules as needed then click Save and Close to apply the details to the trade.

Observation Schedule

Accrual Configuration (Observation schedule)

The observation source (FX Rate Definition), start date, and end date default to the option's details.

Step 1 - Select the frequency, date roll convention, and holidays.

Select the Accrual Method: Daily or Unweighted (discrete accrual on each observation date).

For Daily, you can include weekends or not, and include holidays or not. If you include weekends and holidays, the
precedent business day's rate will be used.

Step 2 - Click Generate to generate the schedule.

You can click the "Clear All" menu to add / remove observation dates.

Reset Schedule

 Ⓘ [NOTE: The Reset Schedule panel only appears if the ranges are resetting ("Reset Source" property
contains an FX Rate Definition)]
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Accrual Configuration (Reset schedule)

The fixing source (FX Rate Definition) defaults to the option's details.

Step 1 - Set the reset lag (number of days between reset date and effective date), frequency, date roll convention,
holidays, and first and last effective dates.

Step 2 - Click Generate to generate the schedule.

You can click the "Clear All" menu to add / remove observation dates.

Fixed Ranges

Accrual Configuration (Fixed ranges)

For a single range, you can only specify one range, for a multi-range, you can add multiple ranges.

Single Range - Select the range and click Edit.

» Select the range type: IN, OUT, ABOVE, or BELOW.

» Enter the lower value of the range, the upper value of the range, the strike, and a leverage as needed (factor to
increase / decrease the notional).

Multi-Range - Click Add and define the range - The information is the same as for a single range.

» You can check "Allow overlapping ranges" to define ranges that are included in one another. By defining only two
ranges, you can actually define three levels.

» Repeat as needed for other ranges.
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Resetting Ranges

Accrual Configuration (Resetting Ranges)

For a single range, you can only specify one range, for a multi-range, you can add multiple ranges.

Single Range - Select the range and click Edit.

» Select the range type: IN, OUT, ABOVE, or BELOW.

» Enter the lower spread, the upper spread, and a leverage as needed (factor to increase / decrease the notional).

Multi-Range - Click Add and define the range - The information is the same as for a single range.

» You can check "Allow overlapping ranges" to define ranges that are included in one another. By defining only two
ranges, you can actually define three levels.

» Repeat as needed for other ranges.

Summary
The summary panel shows a report of the range observation.

11.4 Asian Strategies
 Ⓘ [NOTE: Quanto pricing for Asian strategies is not currently supported]

Properties
Vanilla properties - Fixings - Observation Source - Observation Type
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Sample Asian FX Option

"Product: Style" Properties

Properties Descripition

Observation Type The choices are:

• Average Rate — The average of the fixings determines the average rate. The settlement
is the difference between the average rate and the strike multiplied by the primary
amount in the trade.

• Average Strike — The average of the fixings determines the average strike. The
settlement is the difference between the spot rate and the average strike multiplied by
the primary amount in the trade.

• Geom Avg Rate — The system calculates the geometric average of all the fixings and
compares it with the strike. The settlement is the difference between the geometric
average rate and the strike multiplied by the primary amount in the trade.
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Properties Descripition

• Geom Average Strike — The system calculates the strike from the geometric average of
all the fixings. The settlement is the difference between the spot rate and the geometric
average strike multiplied by the primary amount in the trade.

• DARO - Double average rate option, the average is computed for both the rate and the
strike.

• Geom DARO - Geometric double average rate option, the geometric average is
computed for both the rate and the strike.

"Product: Rate" Properties

Properties Description

Observation Source Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

Then right-click the FX Rate Definition and choose "Supplemental" to define the fixing
schedule.

See Setting an Asian Observation Schedule for details.

"Date" Properties

Properties Description

Fixings Displays the number of fixings for averaging the rate or strike.

You can also view the following properties:

• Schedule Start Date

• Schedule End Date

• Schedule 2 Start Date

• Schedule 2 End Date

11 .4 .1 Sett ing an Asian Observat ion Schedule
Right-click the FX Rate Definition and choose "Supplemental" to define the fixing schedule. Click Save and Closewhen
you are done.
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Fixing Schedule (Asian options)

The start and end dates default to the option's details.

Step 1 - Select the frequency. For the weekly frequency, you can check the Roll Day checkbox, and select the day
from the adjacent field. For other frequencies, your can check the “Roll On End Date” checkbox to roll on the last day
of the period.

Select holidays as needed.

You can check the Adjusted checkbox to adjust the sample dates for holidays based on the selected holiday
calendars.

You can check the Weighted checkbox to adjust the weights for holidays based on the selected holiday calendars.

Step 2 - Click Generate to generate the schedule.

The FX rates are set from the Calypso Navigator using Trade Lifecycle > Reset > FX Rate Reset. They are saved as
quote values for the quote value name of the FX Rate Definition.
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You can also enter the reset values from the Calypso Navigator usingMarket Data > Market Quotes > Quotes for the
quote value name of the FX Rate Definition.

The quote value name of the FX Rate Definition is of the form “FX.<primary currency>.<quoting currency>.<FX Rate
Definition name>.<FX Rate Definition source>” - For example “FX.EUR.USD.EUR/USD_ECB.ECB”.

You can add and remove dates in the schedule. In this case the "Custom Samples" checkbox will appear checked.

Step 3 - You can modify the weights as needed. The weights are applied to the values when calculating an average
rate value, or an average strike value.

The Current Value field displays the actual value of the average rate based on the averaging type and existing resets.

Step 4 - Click Save and Closewhen you are done.

11.5 Barr ier Strategies
This also applies to Window Barrier strategies.

Properties
Vanilla Strategies properties- Barrier properties

Sample Barrier FX Option

"Barrier" Properties
"Barrier" properties apply to Barrier, Window Barrier, Digital with Barrier FX options.
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Properties Description

Barrier Duration Select the duration type:

• EXPIRY - The barrier is only observed on the expiry date. You can define multiple
volatilities. The VOLATILITY1 and VOLATILITY2 pricing parameters correspond to the
volatilities for the upper and lower barriers. Enter the volatility for the barrier if desired.
Otherwise, the pricer uses the volatility from the surface if you do not specify one in the
pricing parameters. To use the same volatility as the strike, manually enter that value in
the pricing parameters.

• FULL - The barrier is observed throughout the life of the option. The start date of the
observation is the trade date; the end date of the observation is the expiry date.

• PARTIAL - Enter the start and end dates for the observation, which can be less than the
life of the option. Enter values for Barrier/Barrier2 Start and Barrier/Barrier2 End dates.

• MULTI_PERIOD - The barrier is observed over multiple periods. With MULTI_PERIOD
selected, right-click the barrier trade and choose "Supplemental" from the pop-up
menu.

See Configuring Multiple Barriers for details.

Barrier Description Displays the description of the barrier type.

Barrier Type Select the type of barrier:

• UI - Up In

• DI - Down In

• UO - Up Out

• DO - Down Out

• DKI – Up In Down In

• DKO - Up Out Down Out

• KIKO (UI) – KIKO Up In Down Out - Knock into a UI barrier option

• KIKO (DI) - KIKO Up Out Down In - Knock into a DI barrier option

• UIDO (Up In or Down Out) - After Knock_In (Up In) Barrier is Traversed, FXO Vanilla
Option is created. If the knock-out barrier is traversed at any time, then there ceases to
be an option.

• UODI (Up Out or Down In) - After Knock_In (Down In) Barrier is Traversed, FXO Vanilla
Option is created. If the knock-out barrier is traversed at any time, then there ceases to
be an option.

Barrier Strike rate for the single barrier, or upper barrier for a double barrier.

Barrier Start Date For a partial barrier: the start date of the barrier observation.

You can also set the Barrier Start Time.

Barrier End Date For a partial barrier: the end date of the barrier observation.
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Properties Description

You can also set the Barrier End Time.

Barrier2 Strike rate for the lower barrier.

Barrier2 Start Date For a partial double barrier: the start date of the second barrier observation.

You can also enter the Barrier2 Start Date.

Barrier2 End Date For a partial double barrier: the end date of the second barrier observation.

You can also set the Barrier2 End Time.

Rebate Enter a rebate amount if applicable.

You can also set the following properties:

• Rebate Ccy - Select the currency for the rebate.

– Primary Currency — Asset-or-Nothing

– Secondary Currency — Cash-or-Nothing

• Rebate Timing - Select Expiry (rebate at expiration), or INSTANT (rebate when the
barrier is hit).

11 .5 .1 Conf igur ing Mult ip le Barr iers
When the Barrier Duration property is set to MULTI_PERIOD, you can right-click anywhere in a barrier trade and
choose "Supplemental" from the pop-up menu to open the Multiple Barrier Configuration panel.

Right-click in Barrier trade leg

Periods in which an observation occurs in the schedule are referred to as stages. Barriers define the specific window
of observation of each stage and can be manipulated to customize the terms of the observation.

There are two methods for creating multiple stage barriers on the Multiple Barrier Configuration panel. The first is
accomplished on the Barrier Schedule tab and lets you parametrically generate the duration of the stages in the
schedule by frequency, such as weekly or bi-weekly. The second method is accomplished on the Barrier Definition
tab and allows you to manually set the number and duration of the barriers, and apply unique definitions to each.
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Notice that when you select MULTI_PERIOD in the trade leg, property settings such as Barrier , Barrier Type, barrier
start and end dates, and Rebate are shifted to the Multiple Barrier Configuration panel. All barrier types are available
except for KIKO options.

Follow the basic steps below for creating multi-period barriers.

TIP: If you create an observation schedule on the Barrier Schedule tab, you can make refinements and/or add
stages to it on the Barrier Definition tab. To edit a specific barrier, highlight that barrier's row in the schedule
and use the Barrier parameters to make changes.

Barrier Schedule Tab

Example observation schedule generated on the Barrier Schedule tab.

Step 1 - Set Stages and Barriers parameters on the Barrier Schedule tab to generate the observation schedule.

• The Frequency determines the period of time for each stage, such as daily, weekly, bi-weekly, monthly, or
quarterly.

• The [Barriers] Type drop-down list provides the same barrier types as those described in Barrier properties with
the exception of KIKO options.

• For Observation, you can select SPOT or an FX Rate Definition (discrete observation).
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• For the Start/End Time, you can select "Default" to observe the barrier over the whole day, or "Custom" to observe
the barrier within a specific frame of time during the day. In the latter case, you can set the Start Time and the End
Time.

• For the Duration, you can choose "Full" (each observation window has the same length based on the frequency),
"Window at Start" (the observation window starts at the beginning of the stage, and Window Length determines
its duration), "Window at End" (the observation window ends at the End Date of the stage and Window Length
determines its duration), or Custom (each window has a user-defined length with possible offset).

• Set the barrier level. You can also include an increment for defining progressive changes in the level from stage to
stage.

• You can set rebate details for "out" barrier types.

Step 2 - Click Generate to generate the observation schedule. To make further edits, use the Barrier Definition tab. See
details below for this tab.

Step 3 - Click Save and Closewhen you are satisfied with the schedule.

Barrier Definition Tab

Example observation schedule created manually on the Barrier Definition tab.

 Ⓘ [NOTE: When you first open the Multiple Barrier Configuration panel and click the Barrier Definition tab, the
system has generated the first stage including a start and end date based on the present day and Expiry Date, if
one was entered on the Barrier trade leg. To begin manually adding stages, highlight the stage's row in the
schedule, enter the Stage and Barrier parameters, and click Apply to override the autopopulated settings in
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Stage 1. (The Apply button is used for executing edits made to already existing stages.) Alternatively, you can
simply highlight the first stage, delete it, and add a new first stage. See details below.]

Step 1 - Click New to initiate a new stage. Stage and Barrier parameters are reset to default.

Step 2 - Configure Stage parameters.

• The Barrier Type(s) drop-down list provides the same barrier types as those described in Barrier properties with
the exception of KIKO options.

• For the Observation, you can select SPOT or an FX Rate Definition (discrete observation).

• Define the Start Date and End Date for the given stage.

 Ⓘ [NOTE: Start and end dates can be for any period of time provided the stage does not overlap with a
previous or subsequent stage.]

• For the Start/End Time, you can select "Default" to observe the barrier over the whole day, or "Custom" to observe
the barrier within a specific frame of time during the day. In the latter case, you can set the Start Time and the End
Time, which are located under Barrier parameters.

Configure Barrier parameters

• For the Duration, you can choose "Full" (the barrier's observation window shares the same period as the stage),
"Window at Start" (the observation window starts at the beginning of the stage, and Window Length determines
its duration), "Window at End" (the observation window ends at the End Date of the stage and Window Length
determines its duration), or Custom (each window has a user-defined length with possible offset).

 Ⓘ [NOTE: When Custom, Window at Start, or Window at End is selected, the barrier's start and end must fall
within the constraints of the stage's Start Date and End Date. Also, the Window Length parameter must not
exceed the stage's period.]

• Set the Level for the barrier.

• You can set rebate details for "out" barrier types.

•

Step 3 - When you have finished configuring the stage, click Add. The stage is added to the observation schedule. To
add further stages, repeat from Step 1.

Step 4 - If you need to make any changes to an already existing barrier, first highlight the barrier's row in the schedule
and make changes to the parameters. Once the edits are made, click Apply to execute the changes. To delete a stage,
highlight it in the schedule and click Delete.

Step 5 - Click Save and Closewhen you are satisfied with the schedule.
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11.6 Compound Strategies

Properties
Vanilla properties - Compound Term - Compound Expiry Date - Compound Expiry - Compound Delivery Date -
Compound Delivery - Compound Expiry Cut - Compound Put/Call - Compound Strike - Compound Strike Amount

Sample Compound FX Option

"Product: Style" Properties

Properties Description

Compound Put/Call Select the direction of the compound option for the primary currency.

"Product: Rate" Properties

Properties Description

Compound Strike Enter/displays the price of the underlying option as a percentage of the underlying primary
amount.

Compound Strike
Amount

Compound Strike Amount = Compound Strike * Ccy 1 Amount / 100.

You can also enter a compound strike amount and the Compound Strike will be updated
accordingly.
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Properties Description

When exercising the compound option, the compound strike amount will be passed to the
created plain vanilla as PREMIUM fee.

"Date" Properties

Properties Description

Compound Expiry Date Enter the expiry date of the compound option.

Compound Expiry Displays details about the "Compound Expiry Date".

Compound Expiry cut Displays the default expiry timezone for the compound option. The default expiry timezone
is set in the Defaults panel under Configuration > User Preferences.

Compound Term Displays the "Compound Expiry Date" as a tenor.

Compound Delivery
Date

Enter the delivery date of the compound option.

Compound Delivery Displays details about the "Compound Delivery Date".

11.7 Digital Strategies
This also applies to Digital with Barrier strategies.

Properties
Vanilla properties (no strike) - Trigger properties - Observation Source

Sample Digital FX Option
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"Product: Rate" Properties

Properties Description

Observation Source Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

"Trigger" Properties
"Trigger" properties apply to Accrual, Accumulator, Range Accrual, Digital, Window Digital, European Binary FX
options.

Properties Description

Trigger Duration Select the duration type:

• EXPIRY— The trigger is only observed on the expiry date. You can define multiple
volatilities. The VOLATILITY1 and VOLATILITY2 pricing parameters correspond to the
volatilities for the upper and lower triggers. Enter the volatility for the digital if desired.
Otherwise, the pricer uses the volatility from the surface if you do not specify one in the
pricing parameter. To use the same volatility as the strike, manually enter that value in
the pricing parameter(s).

• FULL— The trigger is observed throughout the life of the option. The start date of the
observation is the trade date; the end date of the observation is the expiry date.

• PARTIAL — Enter the start and end dates for the observation, which can be less than
the life of the option. Enter values for Trigger/Trigger2 Start and Trigger/Trigger2 End
dates.

Trigger Description Displays the description of the trigger type.

Trigger Type Select the trigger type.

For Digital options, the choices are:
• OT UP - One Touch Up

• OT DN - One Touch Down

• NT UP - No Touch Up

• NT DN - No Touch Down

• DOT - Double One Touch

• DNT - Double No Touch

• OTNT (UI) - One Touch No Touch UI

• OTNT (DI) - One Touch No Touch DI

For Digital at Expiry, the choices are:
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Properties Description

• ABOVE – Payout occurs if spot rate above the trigger level

• BELOW – Payout occurs if spot rate below the trigger level

• IN – Payout occurs if the spot rate within the two trigger levels

• OUT – Payout occurs if the spot rate outside the two trigger levels

For Digital With Barrier options, the choices are ABOVE or BELOW.
For Accrual options and Accumulator options, the choices are:
• ABOVE - Payout occurs when the spot rate is above the trigger.

• BELOW - Payout occurs when the spot rate is below the trigger.

• IN - Payout occurs when the spot rate is within in the trigger range.

• OUT - Payout occurs when the spot rate is out of the trigger range.

Payout Type Select Instant (payout when the trigger is hit) or Expiry (payout at expiration).

Trigger Digital an European Binary options:
Enter the strike rate for the single trigger, or upper trigger for a double digital.

Accrual and Accumulator options:
Enter the trigger for ABOVE and LOW options, or low trigger for a range.

Trigger Start Date Enter the start date of observation for a partial digital.

Trigger End Date Enter the end date of observation for a partial digital.

Trigger Spread In case of resetting range, enter the upper spread for single range.

Trigger Included Accrual options:
For ABOVE and BELOW accruals, select Yes to monitor the trigger, or No otherwise.

Range Accruals:
Select Yes to monitor the upper value of the range, or No otherwise.

Trigger2 Digital and European Binary options:
Enter the strike rate for the lower trigger.

Accrual options and Accumulator options:
Enter the high trigger for a range.

Trigger2 Start Date Enter the start date of second trigger observation for a double partial digital.

Trigger2 End Date Enter the end date of second trigger observation for a double partial digital.

Trigger2 Spread In case of resetting range, enter the lower spread for single range.

Trigger2 Included Range Accruals:
Select Yes to monitor the lower value of the range, or No otherwise.
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11.8 Forward Start ing Strategies

Properties
Vanilla properties - Reset Source - Reset Effective Date - Formula Strike

Sample Forward Starting FX Option

"Product: Rate" Properties

Properties Description

Strike You can enter the strike as a percentage of the "at-the-money" forward like "102% atmf", as
an "in-the-money" spot like "atms", as a percentage of "out-the-money" like "10%otm", or as
rate +/- pips like "2 pips".

Entry shortcuts can be used for the strike:

"o" for %OTM i.e. entering "10o" displays as 10%OTM.

"f" for atmf i.e. entering "90f" displays as 90%atmf.

"s" for atms i.e. entering "85s" displays 85%atms.

"p" for pips i.e. entering "-10p" displays -10 pips.

An option trade can be inverted (strike inverted). For percentage strikes, the strike is
1/original strike. For pip strikes, the strike is converted to percentage strike, and then
inverted as 1/strike. This is then reconverted to a pip strike to display.

Rounding
Any system generated strike (solver, shortcut entry) will respect the currency pair rounding
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Properties Description

settings. If the user manually enters a strike, it will only be rounded based on the constraints
of the currency rounding of the amounts that the strike generates.

Example: Ccy1 amount is 10,000.00 and a strike is entered as 1.234567.

• If ccy rounding of Ccy2 is 2dp then Ccy2 amount would be 12345.67. The strike does
not need to be rounded.

Formula Strike Displays the formula captured in the Strike property.

"Product: Style" Properties

Properties Description

Reset Source Select the FX Rate Definition that will be used to fix the strike. FX Rate Definitions are
configured from the Calypso Navigator using Configuration > Foreign Exchange > FX Rate
Definitions.

If ccy rounding of Ccy2 is 0dp (JPY for example) then Ccy2 amount would be 12346 and the strike would need to be
rounded to 1.2346.

"Date" Properties

Properties Description

Reset Effective Date Enter the date at which the strike will be known.

11.9 Lookback Strategies

Properties
Vanilla properties - Observation Source - Fixings - Observation Type
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Sample Lookback FX Option

"Product: Style" Properties

Properties Description

Observation Type The choices are:

• Lookback Rate - Enter a strike in the Strike field. Call pays the maximum of the rate
during the option life, minus the strike; put pays the strike minus the minimum rate
during the option life.

• Lookback Strike - No strike price is required; the rate is the rate at expiry. Call pays the
rate at expiry minus the minimum of the rate during the option life; put pays the
maximum rate during the option life, minus the rate at expiry.

"Product: Rate" Properties

Properties Description

Observation Source Select an FX Rate Definition to fix the FX rates. FX Rate Definitions are configured from the
Calypso Navigator using Configuration > Foreign Exchange > FX Rate Definitions.

"Date" Properties

Properties Description

Fixings Displays the number of fixings.

The following properties are also displayed:
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Properties Description

• Schedule Start Date

• Schedule End Date

• Schedule 2 Start Date

• Schedule 2 End Date

11.10 Volat i l i ty Forward Strategies
The Volatility Forward strategy supports both cash and physical settlement. When a physical-delivery Volatility
Forward strategy is exercised, it creates an ATM delta-neutral straddle trade.

Properties
Vanilla properties (no strike) - Agreed Forward Volatility - VF Vol at Trade Expiry - VF Vol at Straddle Expiry - VF
Implied Forward Vol – Vega - VF Straddle Expiry Date - VF Straddle Term - VF Straddle Cut

"Product: Rate" Properties

Properties Description

Vega Displays what the Vega would be in a Vanilla option from the trade date to the number of
days calculated from the difference of the Expiry Date and the Fixing Date of the Volatility
Forward option.

VF Vol at Trade Expiry Displays the volatility at trade expiration (from the market data).

VF Vol at Straddle
Expiry

Displays the volatility at underlying expiration (from the market data).

VF Implied Forward Vol Displays the implied forward volatility.

Agreed Forward
Volatility

Enter the forward volatility agreed to on the trade date. The price that is agreed upon to buy
the ATM straddle. It defaults to the calculated implied forward volatility. However, you can
modify the value.

"Date" Properties

Properties Description

VF Straddle Expiry
Date

Enter the expiration date of the underlying option (straddle).

VF Straddle Term Displays the "VF Straddle Expiry Date" as a tenor.

VF Straddle Cut Select the expiry timezone for the expiration date of the underlying option (straddle). Expiry
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Properties Description

timezones are created from the Calypso Navigator using Configuration > Definitions >
Expiry Time Zone.

11.11 FX Target Redemption Forwards
Target Redemption Forwards (TARF) are options composed of a strip of FX Forwards with a knockout on the entire
structure based on the accrued profit for the structure purchaser.

The FX TARF strategy must be created as a custom strategy using Configuration > Strategy Builder.

11 .11 .1 Def in ing the FX TARF Strategy
Choose Configuration > Strategy Builder an select the strategy "Script > Pricing Script".

» Select the Pricing Script payout corresponding to the FX TARF, and complete the strategy definition as needed.

Please refer to Calypso Pricing Script documentation for information on defining pricing scripts.

» Save the custom strategy and give it a name.

» Make sure that you add the new strategy to the user profile.

11 .11 .2 Using the FX TARF Strategy
Open a Pricing Sheet and select the custom strategy that you have created.
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Each forward uses a fixing source. If the forward is at-the-money at the fixing time, the accrued interest is added to a
counter. When the counter reaches the knockout level, the entire structure knocks out. The final payment may or may
not be paid.

Sample FX TARF trade

"Product" Properties

Properties Description

Ccy Pair Displays the currency pair used in the trade.

Buy/Sell Select the trade direction.

Notional Enter the trade notional.

Notional Ccy Displays the notional currency used in the trade.

Observation Source Select the observation source for FX underlying.

Model Premium Displays the model premium in notional currency.

Underlying The underlying of an FX TARF is a currency pair.

Displayed based on the selected currency pair.

"Product: Accrual" Properties
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Properties Description

Accrual Schedule Displays the accrual schedule dates and methods used. You can enter values for:

• Start Date

• End Date

• Frequency

• Payment Holidays

• Date Roll

• Payment Rule

• Date Rule

• Specify Roll

• Roll Day

• Payment Lag

• Reset Lag

• Reset Holidays

• Bus. Day Lag

• Stub Rule

• Rounding

• Include Start

• Quote Usage

• Manual Schedule - check and click the ... button to manually define a schedule and apply it.

"Product: Type" Properties

Properties Description

Payout Displays the Pricing Script payout selected in the strategy.

CallPut "Call" or "Put". Select the direction of the option from the book's perspective.

Cash Residual Click the checkbox for true, or clear otherwise.

Final Payment
Type

Select "Full", "Exact", or "None".

KOLevel Enter the knock out level.

LeverageRatio Enter the factor to increase/decrease the notional by.

Strike Enter the strike.

Rounding
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Properties Description

Any system generated strike (solver, shortcut entry) will respect the currency pair rounding
settings. If the user manually enters a strike, it will only be rounded based on the constraints of the
currency rounding of the amounts that the strike generates.

Example: Ccy1 amount is 10,000.00 and a strike is entered as 1.234567.

• If ccy rounding of Ccy2 is 2dp then Ccy2 amount would be 12345.67. The strike does not need
to be rounded.

• If ccy rounding of Ccy2 is 0dp (JPY for example) then Ccy2 amount would be 12346 and the
strike would need to be rounded to 1.2346.

11.12 Invert ing Quanto and Flexo Sett led Strategies
A user can invert strategies with a "Quanto" or "Flexo" settle type by selecting the strategy and clicking Tools > Invert
> Selected Strategies. An entire sheet can be inverted by clicking Tools > Invert > Sheet.

Inverting a strategy with a "Quanto" settle type will change the following properties:

• Ccy Attributes

• Put/Call

• Strike/Trigger/Barrier Attributes- Value will invert to 1/<Original Value> or vice versa.

EX: An entered strike of 1.25 will invert to 1/1.25 = .08

• Quanto Ccy Pair/Quanto Factor- The inverted currency and the settle currency. The order of the currencies in the
"Pair Pos Ref" defined in the Currency Default window. To set this, click Configuration > Definitions > Currency
Defaults....

• Trigger Type Attributes

• Barrier Type Attributes

Inverting a strategy with a "Flexo" settle type will change the following properties:

• Ccy Attributes

• Put/Call

• Strike/Trigger/Barrier Attributes- Value will invert to 1/<Original Value> or vice versa.
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EX: An entered strike of 1.25 will invert to 1/1.25 = .08

• Quanto Currency Pair- The inverted currency and the settle currency. The order of the currencies in the "Pair Pos
Ref" defined in the Currency Default window. To set this, click Configuration > Definitions > Currency Defaults....

• Flexo Source - The Flexo Source will be the Settlement Source of the new Quanto Currency Pair.

• Trigger Attributes

• Barrier Attributes

11.13 Volat i l i ty and Variance Swaps Strategies
FX Volatility Swaps and FX Variance Swaps are agreements between counterparties to swap a fixed rate of FX
volatility or variance and a realized rate of FX volatility or variance over a set period of time. This strategy also
provides an optional cap.

The key property in this strategy for determining whether the swap measures variance or volatility is "Swap Type." A
drop-down list in the property field allows users to select between the two settings. Since variance is the
mathematical square of volatility and computed differently, further properties for the Variance Swap also display
Variance Strike and Variance Notional, which are editable fields when enabled. See property descriptions below for
details.

 Ⓘ [NOTE: Selecting the Pricing Model used for the FX Variance/Volatility Swap is integral to market data input
and trade capture. For pricer details specific to this strategy, see "FX Options" in the Calypso Analytics and
Pricing Environment documentation.]

Key Properties
Buy/Sell - Ccy Pair - Notional - Pricing Model - Swap Type - Observation Source - Vol Reference % - Vol Strike % -
Variance Strike
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Sample FX Variation Swap with Swap Type "Variance"

Basic Steps for Capturing FX Variance/Volatility Swap Trades
• Select the trade direction, either buy or sell, and enter a notional value for the trade.

• Select the Ccy Pair and Observation Source.

• Select the Swap Type, either Volatility or Variance, and the Pricing Model.

• Enter a value for Vol Reference %.

• Enter a value for Vol Strike % if a volatility swap, or Variance Strike if a variance swap.

• Enter the Settle Type and Expiry Date.

• Enter other common trade properties, such as Book and Counterparty.
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"Trade" Properties

Properties Description

Swap Type This setting determines whether the swap is for variance or volatility. When Variance is selected, the
Variance Strike, Variance Notional, and Variance Cap properties are enabled.

Expected N Displays the number of fixings expected during the life of the trade.

Use First
Observation

When the checkbox is selected, the trade will use the market fixing rate for the first fixing. When the
checkbox is cleared, the trade uses a supplied rate for its first fixing.

Annualization
Factor

Enter the number of business days in a year to calculate the annualized volatility. Default is 252.

Conditional
Volatility Type

This field allows you to select a condition type to include observations.

• None – No condition.

• Upside – You can set a lower return. The observation must be greater or equal to the lower return
to be included.

• Downside – You can set an upper return. The observation must be lower than the upper return to
be included.

• Corridor – You can set a lower return and an upper return. The observation must be within the
lower and upper return to be included.

Vol Reference
%

The volatility reference is used to compute the vega notional (or volatility exposure). The amount of
volatility exposure in currency units per volatility point. VEGA_NOTIONAL = NOTIONAL / 2 * Volatility
Reference = 100 000 / 2*27 = 1851,85

Vol Strike % Enter the volatility strike for the trade. This is the fixed level against which the payout is computed as
a percentage.

Volatility Cap
%

Enter a cap on the realized volatility.

Variance
Strike

Displays the volatility strike squared. Modifying this field re-computes the Volatility Strike %. Vari-
ance Strike = (Volatility Strike)^2.

Variance
Notional

Displays the notional amount for the variance swap. The payout is linked to this amount. Modify as
needed and it will recompute the volatility notional. Variance Notional = Volatility Notional / (2 * Volat-
ility Strike)^

Variance Cap Enter a cap on the realized variance.

"Style" Properties
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Properties Description

Buy/Sell Choose the direction of the trade.

Settle Type Select a settlement type: Cash, Quanto, or Compo.

Ccy Pair Enter the currency pair used to measure the volatility.

Notional Ccy Currency of the notional

"Product: Rate" Properties

Properties Description

Observation Source Select the FX rate definition used to fix the FX rates.

"Product: Amount" Properties

Properties Description

Notional Enter the notional amount for the trade.

"Date" Properties

Properties Description

Expiry Date Enter the expiration date of the trade.

Delivery Date Enter the delivery date of the trade.

"Price" Properties

Properties Description

Pricing
Model

Select the pricer used to price the trade. It defaults to the pricer set in the pricer configuration.

For pricer details on the FX Variance/Volatility Swap, see "FX Options" in the Calypso Analytics and
Pricing Environment documentation.

11.14 Volat i l i ty and Variance Options Strategies
FX Volatility and Variance Options are used to capture options on swaps that reference realized FX volatility or
variance. They are captured the same way as FX Variance/Volatility Swaps with the addition of the Put/Call property,
but have no provision for a cap or conditions on volatility.
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 Ⓘ [NOTE: Selecting the Pricing Model used for the FX Variance/Volatility Option is integral to market data
input and trade capture. For pricer details specific to this strategy, see "FX Options" in the Calypso Analytics
and Pricing Environment documentation.]

Key Properties
Buy/Sell - Put/Call - Ccy Pair - Notional - Pricing Model - Swap Type - Observation Source - Vol Reference % - Vol
Strike % - Variance Strike

Sample FX Volatility Option with Swap Type "Volatility"

Basic Steps for Capturing FX Variance/Volatility Option Trades
• Select the trade direction, either buy or sell, and whether the trade is a put or call.

• Enter a notional value for the trade.

• Select the Ccy Pair and Observation Source.
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• Select the Swap Type, either Volatility or Variance, and the Pricing Model.

• Enter a value for Vol Reference %.

• Enter a value for Vol Strike % if swap type is volatility, or Variance Strike if swap type is
variance.

• Enter the Settle Type and Expiry Date.

• Enter other common trade properties, such as Book and Counterparty.

"Trade" Properties

Properties Description

Swap Type This setting determines whether the swap is for variance or volatility. When Variance is selected, the
Variance Strike, Variance Notional, and Variance Cap properties are enabled.

Expected N Displays the number of fixings expected during the life of the trade.

Use First
Observation

When the checkbox is selected, the trade will use the market fixing rate for the first fixing. When the
checkbox is cleared, the trade uses a supplied rate for its first fixing.

Annualization
Factor

Enter the number of business days in a year to calculate the annualized volatility. Default is 252.

Vol Reference
%

The volatility reference is used to compute the vega notional (or volatility exposure). The amount of
volatility exposure in currency units per volatility point. VEGA_NOTIONAL = NOTIONAL / 2 * Volatility
Reference = 100 000 / 2*27 = 1851,85

Vol Strike % Enter the volatility strike for the trade. This is the fixed level against which the payout is computed as
a percentage.

Variance
Strike

Displays the volatility strike squared. Modifying this field re-computes the Volatility Strike %. Vari-
ance Strike = (Volatility Strike)^2.

Variance
Notional

Displays the notional amount for the variance swap. The payout is linked to this amount. Modify as
needed and it will recompute the volatility notional. Variance Notional = Volatility Notional / (2 * Volat-
ility Strike)

"Style" Properties

Properties Description

Buy/Sell Choose the direction of the trade.

Put/Call Select whether the trade is a put or call.

Settle Type Select a settlement type: Cash, Quanto, or Compo.

Ccy Pair Enter the currency pair used to measure the volatility.

Notional Ccy Currency of the notional
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"Product: Rate" Properties

Properties Description

Observation Source Select the FX rate definition used to fix the FX rates.

"Product: Amount" Properties

Properties Description

Notional Enter the notional amount for the trade.

"Date" Properties

Properties Description

Expiry Date Enter the expiration date of the trade.

Delivery Date Enter the delivery date of the trade.

"Price" Properties

Properties Description

Pricing
Model

Select the pricer used to price the trade. It defaults to the pricer set in the pricer configuration.

For pricer details on the FX Variance/Volatility Option, see "FX Options" in the Calypso Analytics and
Pricing Environment documentation.
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12. Capturing IRD & Cash Trades
To capture an IRD trade in the Pricing Sheet, select an IRD strategy and set the properties as needed. You can also
select a strategy template to populate default values.

Sample Strategy and Template selection

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to IRD trades are described below.

Contents

- Cap Floor Trades

- Spread Cap Floor Trades

- Setting an Amortization Schedule

- FRA Trades

- Structured Flows Trades

- Applying Reconvention Actions

- Swap Trades

- Capped Swap Trades

- Swaption Trades

- Setting Specific Resets

- Islamic Trades
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12.1 Cap Floor Trades
This also applies to Collar trades and Corridor trades.

Key Properties
Buy/Sell - Option Type - Leg Type - Strike - Rate properties - Payment properties - Start Date - End Date

Sample Cap trade

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Notional Ccy Select the currency of the notional.

Buy/Sell Select the direction of the trade: Buy or Sell.

Amortization The amortization of the notional defaults to Bullet.
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Properties Description

You can also right-click the trade and choose "Supplemental" to specify an amortization
schedule.

See Setting an Amortization Schedule for details.

Option Type Select the option type: Cap, Floor, Collar, Corridor.

If Leg Type is set to Float, Compounding Type is set to SimpleSpr, and Cmp Frequency is set
to DLY, then two additional options appear: Daily Floor, and Daily Cap. These two options
apply the cap or the floor to each day's rate prior to compounding.

Leg Type Displays "Cap", "Floor", "Collar", or "Corridor" based on the selected strategy and Option
Type.

Custom Cashflows Displays "true" if the cashflows have been customized, or "false" otherwise.

"Product: Rate" Properties

Properties Description

Strike Enter the strike.

You can also right-click the trade and choose "Supplemental" to specify a Strike Schedule.

Sample Strike Schedule

» The start and end dates default to the trade's start and end dates.

» You can select a frequency or a date rule to generate the strike schedule.

» Click Generate to generate the schedule. Then double-click a strike cell to enter the
strike for the corresponding date.

You can click the "Clear All" menu to add / remove strike dates.

» Then click Save and Close to apply to the strike schedule to the trade.

Rate Enter the fixed rate for fixed rates, or the spread over the rate value for floating rates as
needed.

You can also right-click the trade and choose "Supplemental" to specify a Rate Schedule.
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Properties Description

You can specify a schedule for the Pay Leg and another schedule for the Rec Leg. For a
fixed rate, it is a fixed rate schedule, and for a floating leg, it is a spread schedule.

Sample Rate Schedule

» The start and end dates default to the trade's start and end dates.

» You can select a frequency or a date rule to generate the rate schedule. Select the
other parameters as needed.

» Click Generate to generate the schedule. Then double-click a rate cell to enter the rate
for the corresponding date.

You can click the "Clear All" menu to add / remove rate dates.

» Then click Save and Close to apply to the rate schedule to the trade.

Rate Index Factor Enter the index factor as needed for floating rates to multiply the rate value.

Rate Index Select the rate index for floating rates.

You can set additional properties:

• Reset Timing - Select "At Start" (reset occurs at the beginning of the period) or "In
Arrears" (reset occurs at then end of the period).

• Reset Lag - Enter the number of days between the actual reset date and the reset date
as defined by the reset timing, and specify Business or Calendar.

The Reset Lag will persist is terms of days. Entering "30D" and saving will be displayed
as "1M" on retrieval. Entering "d" for days, "w" for weeks, "m" for months and "y" for
years as a tenor (EX: 1m b = -1M Business) will be saved as days.

If not tenor is entered, the system will use days by default.

• Reset Holidays - Select the reset calendars.
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Properties Description

• Reset Date Roll - Select the reset date roll.

• Manual First Rate - Enter the first reset rate if any.

• Specify Initial Inflation - Select "None", "Initial Level Date" or "Initial Level".

• Initial Level Date - If selected in "Specify Initial Inflation", enter the initial level date.

• Initial Level - If selected in "Specify Initial Inflation", enter the initial level.

• Convert Basis - Check the “Convert Basis” checkbox to check whether the reference
index and the trade have the same daycount convention. If not, the rate’s daycount
convention is converted to the trade’s daycount convention.

Choose Help > View Help for complete details.

• Rate Rounding - Select the rate’s rounding method to override the default value from
the rate index.

• Rate Decimals - Enter the number of decimal places to override the default value from
the rate index.

Reset Frequency Select the reset frequency to sample resets at a frequency different from the payment
frequency. Otherwise, the resets are sampled at the payment frequency.

• For Weekly, you can set the Reset Day of Week.

• For Monthly, you can set the Reset Day of Month.

When the sampling frequency is more frequent that the payment frequency, you can define
the weight of the resets, and the duration of the sampling period.

Reset Weighting
You can select:

• Equal - Resets within the sampling period are equally weighted.

• Weighted - Resets are weighted according to the number of days for which they apply.
For example, if a reset occurs on a Monday, the weight is 1 day; if it occurs on a Friday,
the weight is 3 days (Friday, Saturday and Sunday).

• Simple - The reset rate is calculated as the mean rate within the sampling period.

• Cutoff Adj. (Only applies to Daily reset) - Calculates weighting up to cutoff date. The
cutoff date is set as a number of days from the last sample period’s end date in Reset
Cutoff Lag.

• Cutoff Weekly (Only applies to weekly reset) - If you specify a reset cutoff, the last
sample period will be “end date – reset cutoff”. Set the cutoff lag in Reset Cutoff Lag.

Reset Duration
You can select:

• Match - Rates are sampled over the entire averaging period.
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Properties Description

• Custom - Rates are sampled over a user-defined period. Define the number of days of
the sampling period in Custom Sample Period.

"Product: Payment" Properties

Properties Description

Compounding Type Select the compounding type, if applicable, or none.

• Flat - Flat compounding - The spread is added after the compounding is computed if
any. Current period interest is calculated using floating rate plus spread. But compound
interest is calculated using floating rate only (and the spread is not added).

• Spread - The interest compounds at the rate value plus spread. Enter the Spread in the
Compounding Spread field.

• SimpleSpr (Swaps only) - This involves compounding the Floating Rate but treating the
spread as simple interest. In other words, the floating rate interest is earned at the end
of a period but not the spread (only the floating rate is added back into the notional).
The spread is then calculated on the notional for the entire calculation period without
compounding.

• NoCmp - A cashflow is created at the compounding period without actually
compounding the interest. The daily rate resets for the floating rate are used to
calculate the simple interest everyday and summed to find the total interest for the
period.

You can also set the following properties:

• Compounding Frequency - Select the compounding frequency. The compounding
frequency must be more frequent than the payment frequency.

When you select a DLY compounding frequency for a rate index that is not setup for
daily compounding, the DailyCompound calculator is used.

• User Reset Period Dates - Check to compound trades based on the reset dates rather
than the payment dates.

• Compounding Stub

• Sample Timing - Select the sample timing: "At Start" or "In Arrears".

• Use Sample Period Shift - When checked, it includes an Observation Shift that allows
shifting the whole Sample Period in addition to the Reset Dates, such that the weights of
any given daily fixing remains the same.

Payment Frequency Select the payment frequency.

Payment Day Count Select the payment daycount.

Payment Date Roll Select the payment date roll, when the payment date falls on a non business day.
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Properties Description

You can also set the following properties:

• Payment Timing - Select "At Start" (payment occurs at the beginning of the period) or
"In Arrears" (payment occurs at the end of the period).

• Payment Interest Calculation

– For payment timing "In Arrears", select EXP for an exponential interest calculation,
or NONE otherwise.

– For payment timing "At Start", select DISC for discounting, or NONE otherwise.

• Payment Accrual - Select the adjustment method of the accrual period:

– ADJUSTED - Adjusts the period’s end date if it falls on a non-business day,
according to the payment date roll convention. Rolling the end date adjusts the
period length, so a rolled date changes the interest amount.

– UNADJUSTED - Does not adjust the period’s end date for non-business days.

– MAT_UNADJUSTED - Adjusts the period’s end date if it falls on a weekend unless
it is the last period (maturity), in which case it is not adjusted. Thus the adjustment
method may affect intermediate interest amounts, but it does not change the
maturity date.

– FRN - Adjusts the period’s end date for non-business days to the next business
day unless the next business day is in the following month, in which case it uses
the preceding business day.

• Payment Holidays - Select the payment calendars to determine business days.

• Payment Lag - Enter the number of days between the interest date and the payment
date, and specify Business or Calendar.

The Payment Lag will persist is terms of days. Entering "30D" and saving will be
displayed as "1M" on retrieval. Entering "d" for days, "w" for weeks, "m" for months and
"y" for years as a tenor (EX: 1m b = -1M Business) will be saved as days.

• Apply Pmt Lag to Principal Flows - Set to True or False. (The Apply Pmt Lag to Principal
Flows Domain value sets the default value for this property to True or False.) Supports
different payment dates for principal and interest cashflows. The property applies to
either Principal cashflows or not based on this property.

• Payment Roll Day - Select a date roll adjustment to adjust the date, or none otherwise.

– DAY - Enter a fixed day of the month to which the date will be rolled. For example,
entering “5” forces the payment date to be on the fifth calendar day of the month.
Entering “31” indicates the last day of the month, even for months with fewer than
31 days - The selection changes to EOM.

– IMM - The payment date is rolled according to the IMM_WED date roll convention
by default. If the date roll convention is IMM_MON, then the payment date is rolled
according to the IMM_MON date roll convention.
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Properties Description

– EOM - The last day of the month, regardless of the number of days in the month.

• Payment Rounding - Select the rounding method.

• Extra Day in First Period - Check to add a day to the first payment period. The system
uses the daycount (nominator+1)/denominator on the first cashflow - For example
ACT+1/360.

• Extra Day in Last Period - Check to add a day to the last payment period. The system
uses the daycount (nominator+1)/denominator on the last cashflow - For example
ACT+1/360.

Exclude First Check the “Exclude First” checkbox to exclude the first caplet from the cashflows.

Stub Type Select the stub period, if applicable, or none.

You can also set the following properties:

• Stub First Date - Enter the end date of the first period for SPECIFIC FIRST and
SPECIFIC BOTH.

• Stub Last Date - Enter the start date of the last period for SPECIFIC LAST and
SPECIFIC BOTH

• Stub Full Coupon Date - Enter the full coupon date for FULL COUPON.

• Stub Tolerance - Enter the number of days of stub tolerance.

• First Stub Interpolation - Select Interpolate to interpolate on the first period, or none
otherwise.

Choose Help > View Help for complete details.

• First Stub Tenor 1 - Select the first index tenor for interpolation of the first period.

• First Stub Tenor 2 - Select the second index tenor for interpolation of the first period.

• Last Stub Interpolation - Select Interpolate to interpolate on the last period, or none
otherwise.

Choose Help > View Help for complete details.

• Last Stub Tenor 1 - Select the first index tenor for interpolation of the last period.

• Last Stub Tenor 2 - Select the first index tenor for interpolation of the last period.

• Interpolated Rate Rounding - Select the stub rate’s rounding method.

• Interpolated Rate Decimal - Enter the number of decimal places for interpolated rate
rounding.

• Interpolation Style - Select the interpolation style:

– Index Based - The DateRoll, the holidays and the daycount are coming from the
rate index.

– Product Payment - The DateRoll, the holidays and the daycount are coming from
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Properties Description

the coupon panel.

Choose Help > View Help for complete details.

"Date" Properties

Properties Description

Trade Date Displays the valuation date set in the Pricing window of the pricing sheet by default.

You can modify as needed.

See Using the Pricing Sheet for details.

Trade Time Displays the valuation time set in the Pricing window of the pricing sheet.

You can modify as needed.

See Using the Pricing Sheet for details.

Settlement Date Enter the settlement date.

Settlement Holiday Enter the settlement holiday calendar.

Start Date Enter the start date.

End Date Enter the end date.

Start Tenor Enter the start tenor.

Maturity Tenor Enter the maturity tenor.

"Price" Properties

Properties Description

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.
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Properties Description

Sales Price Enter the sales price as needed.

Sales Location You can select the location of the sales representative. The sales location is a legal entity of
role SalesLocation. The sales fee is paid to that legal entity if selected.

If the sales location is not selected, the sales fee is paid to the counterparty of the trade if
the domain "DefaultSalesMarginFeeLE" contains the value "UseTradeCptyAsDefault".

Otherwise, it is paid to the "NONE" counterparty.

12.2 Spread Cap Floor Trades
This also applies to Spread Collar trades.

Key Properties
"Product: Rate" Properties

Sample Spread Cap trade

"Product: Rate" Properties

Properties Description

Spread Rate Index Select the spread rate index.

You can set additional properties:

• Spread Reset Lag - Enter the number of days between the actual reset date and the
reset date as defined by the reset timing, and specify Business or Calendar.

The Reset Lag will persist is terms of days. Entering "30D" and saving will be displayed
as "1M" on retrieval. Entering "d" for days, "w" for weeks, "m" for months and "y" for
years as a tenor (EX: 1m b = -1M Business) will be saved as days.

If not tenor is entered, the system will use days by default.

• Spread Reset Holidays - Select the reset calendars.

Spread Rate Index
Factor

Enter the index factor as needed to multiply the rate value.
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12.3 Sett ing an Amortizat ion Schedule
To define an amortization schedule, right-click the trade and choose "Supplemental".

Sample Amortization Schedule

» Select the type of amortization and set the corresponding properties.

Choose Help > View Help for complete details on the amortization types.

» Then click Generate to generate the schedule.

You can click the "Clear All" menu to add / remove amortization dates.

» Click Save and Close to apply the schedule to the trade.

12.4 FRA Trades
An FRA is a forward contract where one party pays a fixed rate and the other party pays an interest rate set on a
specified future date.

Key Properties
Buy/Sell - "Product: Rate" properties - "Product: Payment" properties - Start Date - End Date
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Sample FRA trade

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Notional Ccy Select the currency of the notional.

Buy/Sell Select the direction of the trade: Buy or Sell.

"Product: Rate" Properties

Properties Description

Rate Enter the forward rate.

Rate Index Select the rate index.

You can also set the following properties:

• Reset Lag - Enter the number of business days between the actual reset date and the
payment date.

• Rate Interpolation - Select “Interpolate” to interpolate the fixing rate. The rate is
interpolated using the tenors specified in "Interpolate Tenor 1" and "Interpolate Tenor 2".

• Rate Rounding - Select the rate’s rounding method to override the default value from
the rate index.

• Rate Decimals - Enter the number of decimal places to override the default value from
the rate index.
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"Product: Payment" Properties

Properties Description

Payment Day Count Select the payment daycount.

Payment Date Roll Select the payment date roll, when the payment date falls on a non business day.

You can specify the following additional properties:

• Payment Timing - Select "At Start" (payment occurs at the beginning of the period) or
"In Arrears" (payment occurs at the end of the period).

• Payment Interest Calculation - Select the discounting method:

– FWD_DISC - Discounts the payment / receipt amount from the end date to the
start date using the fixing rate. Only applies when you do not select "In Arrears".

– DUAL_DISC - Discounts the payment / receipt amount from the end date to the
start date using both the fixing rate and the fixed rate. Only applies when you do
not select "In Arrears".

– FIX_RATE_DISC - ProjAmtBeg = ProjAmtEnd/(1+F * daycount/basis))

– RATIO_DISC - ProjAmtBeg = ProjAmtEnd * (1+f * daycount/basis) / (1+F *
daycount/basis)

Where:

- ProjAmtEnd = Amount to settle if “in arrears”

- ProjAmtBeg = Discounted amount to settle in advance

- f = Forward rate projected from curve

- F = Contracted FRA rate

• Payment Begin Date Roll - Select a date roll for the start date.

• Payment Begin Holidays - Select a holiday calendar for the start date.

• Payment End Date Roll - Select a date roll for the end date.

• Payment End Holidays - Select a holiday calendar for the end date.

12.5 Structured Flows Trades

Select a Floating Rate strategy or a Fixed Rate strategy.

Key Properties
Direction Type - Pay/Receive - Payment properties - Rate properties
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Sample Floating Rate trade

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Product Subtype Select the product type as per your need. By default, it is Standard.

Notional Enter the notional amount.

Notional Ccy Select the currency of the notional.

Direction Type Select Interest or Principal.

A "swap leg" should be defined as Receive Interest or Pay Interest.

A "loan" should be defined as Pay Principal, and a "deposit" as Receive Principal.

Pay/Receive Select the direction of the trade leg from the book's perspective.

Rate Index Select the rate index for floating rates.

You can set additional parameters:

• Reset Timing - Select beginning period or end period.

• Reset Lag - Check to define the parameters in the Reset Lag field:
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Properties Description

– Offset - Enter the number of days between the actual reset date and the reset
date as defined by the reset timing.

– Days - Specify business or calendar days.

– Holidays - Select the holidays calendars.

– Roll - Select the reset date roll.

• Manual First Rate

• Convert Basis - Check to check whether the reference index and the trade have the
same daycount convention. If not, the rate’s daycount convention is converted to the
trade’s daycount convention.

• Rate Rounding - Select the rate’s rounding method to override the default value from
the rate index.

• Rate Decimals

• Reset Date Rule - Select the date rule to determine the reset dates of the cashflows.

• Use Sample Period Shift - When checked, the reset lag allows shifting the whole Sample
Period in addition to the Reset Dates, such that the weights of any given daily fixing
remain the same.

If you select an Inflation Index, you can set the Fixed Inflation Rate in percent and the
inflation calculation type.

Rate Enter the rate for fixed rates or the spread for floating rates.

Notional Exchange Select Initial, Final, Amortization or any combination of the three to indicate that the notional
amount will be exchanged, otherwise there is no exchange of notional.

Amortization The amortization of the notional defaults to Bullet.

You can also right-click the trade and choose "Supplemental" to specify an amortization
schedule.

See Setting an Amortization Schedule for details.

Custom Cashflows Displays "true" if the cashflows have been customized, or "false" otherwise.

Collateral Type Select the Collateral Type as needed.

Collateral Types can be defined in the domain "Advance.CollateralType".

You can set additional parameters:

• Partial Collateralized - Check to perform a partial collateralization.

• Prepayment Method - Select the method by which the collateral will be reduced.

– PROPORTIONAL - Whenever principal decreases, the collateral is reduced
according to the proportion specified upfront.

– SEQUENTIAL - Whenever principal decreases, the portion with the lower ranking
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Properties Description

collateral type will be reduced first until it's exhausted.

• Collateralized Precentage - Enter a percentage to be collateralized.

Open Term Check for an open term trade. In this case, you need to select a behavioral maturity and
enter a number of notice days.

"Compounding Type" Properties

Properties Description

Compounding Type Select the compounding type, if applicable, or none.

• Flat - Flat compounding - The spread is added after the compounding is computed if
any. Current period interest is calculated using floating rate plus spread. But compound
interest is calculated using floating rate only (and the spread is not added).

• Spread - The interest compounds at the rate value plus spread. Enter the Spread in the
Compounding Spread field.

• SimpleSpr (Swaps only) - This involves compounding the Floating Rate but treating the
spread as simple interest. In other words, the floating rate interest is earned at the end
of a period but not the spread (only the floating rate is added back into the notional).
The spread is then calculated on the notional for the entire calculation period without
compounding.

• NoCmp - A cashflow is created at the compounding period without actually
compounding the interest. The daily rate resets for the floating rate are used to
calculate the simple interest everyday and summed to find the total interest for the
period.

You can also set the following properties:

• Compounding Frequency - Select the compounding frequency. The compounding
frequency must be more frequent than the payment frequency.

When you select a DLY compounding frequency for a rate index that is not setup for
daily compounding, the DailyCompound calculator is used.

• User Reset Period Dates - Check to compound trades based on the reset dates rather
than the payment dates.

• Compounding Stub

• Sample Timing - Select the sample timing: "At Start" or "In Arrears".

• Compounding cut off lag and holidays

• Partial Period Compounding - Select NCCR for Non-Cumulative Compound Rate (only
applicable to daily compounding trades), or not set for CCR (Cumulative Compound
Rate). The NCCR rate is the daily change in CCR rate.
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Properties Description

The value NCCR can be added to the domain
"PartialPeriodCompRateEnrichmentMethods" if it is not available for selection.

"Product: Payment" Properties
Swap "Product: Payment" properties also apply.

"B2B" Properties

Properties Description

B2B The application automatically checks the B2B checkbox when an internal trade with an
inter-company book is associated with the trade. The B2B configuration can be defined
using Configuration > Automated Operations > Back to Back Trades.

• To use the default B2B configuration, no further action is required. The B2B trade will be
automatically created based on the B2B configuration when the trade is saved.

• To modify the B2B configuration, modify any details below, then check the "User
override" checkbox.

• To turn the B2B feature off, clear the B2B checkbox.

• To turn the B2B feature on (if there is no default B2B configuration defined), check the
B2B checkbox. Set the details below.

SD_FILTER Optional. Enter the name of the Static Data Filter. As in the B2B configuration, you can filter
by an amount, counterparty, legal entity attribute, sales person, or some other parameter.

Transfer Margin Select this checkbox to transfer the sales margin (sales price) to the destination book. Clear
the checkbox to ensure the margin remains in the original trade book.

Transfer Book The book to which the B2B trade is transferred.

Transferred Trade ID The ID of the B2B generated trade.

Transferred Book The book from which the original trade is transferred.

User Override Check to override the default configuration.

Please refer to Calypso Money Market documentation for details on setting up Back to Back trades.

12.6 Applying Reconvention Actions
You can apply reconventions to structured flows. Reconventions are changes made to the current trade that will
affect cashflows, such as a change of notional amount or the maturity date. To perform a reconvention, select the
trade column, choose Processing > Reconvention, and select the reconvention type.
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» In the Parameters area, enter the parameters of the reconvention. They are described below based on the
reconvention type.

» The Original and Replacement areas only apply if you have defined market measures.

» You can add or calculate a reconvention fee as needed in the Reconvention Fee area. See below for details.

» Click Applywhen you are done to apply the reconvention.

Reconvention Action
By default, the AMEND action is applied to the trade when a reconvention is performed or removed.

You can configure the reconvention actions to be applied when adding a reconvention, or deleting a reconvention,
using the following domains:

• Domain for addition is “ReconventionAction.<reconvention type>”.

Example:

The action NOTCHANGE will be applied to the trade when the "Notional Reconvention" is performed.

• Domain for removal is “ReconventionDeleteAction.<reconvention type>”.

Example:

The action DELNOTCHANGE will be applied to the trade when a "Notional Reconvention" is removed.
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 Ⓘ [NOTE: The actions defined in these domains must be added to the Trade workflow for structured flows]

Common Parameters
The following parameters are common to all reconvention types. The other parameters are described below by
reconvention tpye.

• Reconvention Type - Displays the type of reconvention to be performed.

• Reconvention Date Time - Defaults to today's date and time. You can modify as necessary.

• Effective Date - Enter the effective date on which the reconvention is to be applied.

• Is Prescheduled - Check to ignore validations that control reconvention order, or clear otherwise.

• Pricer Measures (Fee calculation) - You can select the pricer measures you want to compute for fee calculation.
Their values are displayed when you click Calculate.

• Breakage Cost as Spread - Check to convert breakage cost on synthetic hedge to spread.

• Contractual - Check to indicate that the reconvention is contractual, or clear otherwise. For information purposes
only.

Hedge Breakage Costs
The hedge breakage cost can be simulated when a reconvention is applied based on FTP (Fund Transfer Pricing)
rules.

Please refer to Calypso Liquidity documentation for information on setting up FTP rules.

Reconvention Fee
You can click Calculate to add a fee based on the selected pricer measures is any.

You can click Add to add a reconvention fee as needed. Enter the fee amount.

You can configure the fee type in the domain “DefaultReconventionFee”. If not set, it defaults to PREPAYMENT_FEE.

Viewing Reconventions
You can view all reconventions applied to the trade in the Events panel.

You can right-click a reconvention and drill down to the trade or to the details of the reconvention. You can also delete
a reconvention.

12.6 .1 Capi ta l ize
You can capitalize the current accrual using the Capitalize reconvention. The current accrual amount as of the
Effective Date is moved to the principal.
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Sample Capitalize reconvention

» Enter the effective date.

12.6 .2 Col latera l Change
You can change the collateral using the Collateral Change reconvention.

Sample Collateral Change reconvention

» Select the Collateral Type, and set additional parameters as needed.

– Partial Collateralized - Check to perform a partial collateralization, then enter a percentage to be
collateralized in the "Collateralized Percentage" field.

– Prepayment Method - Select the method by which the collateral will be reduced.

PROPORTIONAL - Whenever principal decreases, the collateral is reduced according to the proportion
specified upfront.

SEQUENTIAL - Whenever principal decreases, the portion with the lower ranking collateral type will be
reduced first until it's exhausted.
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» Rate (%) or Spread (bps) - Enter a new rate (fixed) or spread (floating) to perform a rerate at the same time.

Enter a sales margin as needed.

» Interest Cleanup - Select "Yes" to perform an interest cleanup at the same time, otherwise select "No".

12.6 .3 Disbursement
You can set a new Disbursement Schedule to override the current Disbursement schedule using the Disbursement
reconvention. For a trade, if no specific disbursement dates are known, this reconvention allows individual
disbursements to happen as lifecycle actions. You can use the Disbursement reconvention anytime until the last day
specified on the original disbursement schedule.

 Ⓘ [NOTE: The disbursements must still add up to the trade notional. If you need to change the trade notional,
use the Notional Change reconvention]

Sample Disbursement reconvention

» Principal Disbursement - Set the schedule parameters as needed. Then click Generate and OK.

12.6 .4 F l ipper
You can change the leg type using the Flipper reconvention.
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Sample Flipper reconvention

If the original trade's leg type is Float, the Flipper reconvention flips the leg type to Fixed. You can then specify the
parameters for a Fixed leg (or vice versa if the original trade is Fixed).

12.6 .5 Interest Cleanup
You can end the current payment period and pay out the interest on an effective date using the Interest Cleanup
reconvention.

Sample Interest Cleanup reconvention

» Enter the new Effective Date on which the interest is to be paid out.
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12.6 .6 Matur i ty Date Change
You can change the maturity date using the Maturity Date Change reconvention.

Sample Maturity Date Change reconvention

» Maturity Date: Select a maturity date.

12.6 .7 Not iona l Change
You can change the principal amount using the Notional Change reconvention.

Sample Notional Change reconvention

» Enter the direction of the notional change: Increase or Decrease.

» Enter the amount of the notional change.
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» Interest Cleanup - Select "Yes" to perform an interest cleanup at the same time as the rerate, select "Partial,
Prepayment Amount only" for a partial interest cleanup, otherwise select "No" for no interest cleanup.

» Check the Scale checkbox to scale the notional change with each amortization payment.

» Check the Contractual checkbox to indicate that the notional change is contractual. You can then enter the
contractual percentage. For information purposes only.

» Fee Calculator - You can select a fee calculator to compute the fee amount when you click Calculate, or select
Manual to enter the fee amount manually.

» Apply Term. Pmt Lag On - This only applies to full notional change - Select the cashflows where the payment lag
should be applied: Principal, Interest, Both, None or not set.

Default is not set, which means that no lag applied to Principal and lag applied to Interest.

» Interest Rate Differential - Enter the percentage of interest rate differential, which is the fee computed based on
the difference between the original trade and replacement trade.

» Prepayment Constraint - This field is only applicable for Advance trades.

» PPS - This field is only applicable for Advance trades.

» Fee Calculation Trade - Set to Replacement or Original based on the selection in the Reconvention Fee area.

– Replacement - The fee is computed based on the NPV of the replacement trade (default).

– Original - The fee is computed based on the NPV of the original trade.

12.6 .8 Payment Frequency
You can change the payment frequency using the Payment Frequency reconvention.
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Sample Payment Frequency reconvention

» Select the Payment Frequency.

» Select the Amortization Frequency.

» Select the Compounding Type. You can expand this field to set additional compounding parameters.

» Select the Stub Rule. You can expand this field to define the stub periods.

» Enter a new rate (fixed) or spread (floating) to perform a rerate at the same time.

Enter a sales margin as needed.

12.6 .9 Payment Hol iday
You can specify a payment holiday using the Payment Holiday reconvention. This allows you to delay the payment of
all subsequent flows to begin again at a later date. For the duration of a payment holiday, no payments will be made.

Sample Payment Holiday reconvention

» Effective Date - Enter the start date of the payment holiday.

» Payment Holiday End Date - Enter the end date of the payment holiday.

12.6 .10 Pr inc ipa l Structure
You can change principal structure on the remainder of the trade using the Principal Structure reconvention.
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Sample Principal Structure reconvention

» Principal Structure - Select the type of amortization type and set the corresponding amortization parameters.
Then click Generate and OK.

If the amortization type requires calculation, the principal amount that was remaining on the Effective Date will be
the starting amount.

» Enter a new rate (fixed) or spread (floating) to perform a rerate at the same time.

If the rerate reconvention uses a hypersurface and the new structure is not Bullet, it triggers the IsAmortizing
trigger and allows the calculation of the measures using the new amortization structure.

Enter a sales margin as needed.

12.6 .11 Rate Index
You can change the index of a floating rate trade using the Rate Index reconvention.
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Sample Rate Index reconvention

» Select a Rate Index. You can then specify its parameters.

12.6 .12 Rerate
You can change the rate on a fixed leg or the spread on a floating leg trade using the Rerate reconvention.
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Sample Rerate reconvention

» Enter a new rate (fixed) or spread (floating).

[NOTE: This will overwrite the market measures if any]

Enter a sales margin as needed.

» Interest Cleanup - Select "Yes" to perform an interest cleanup at the same time as the rerate, otherwise select
"No".

12.7 Swap Trades

Key Properties
Pay/Receive - Call Type - Cap "Product Rate" properties (no strike) - Structured Flows "Product: Payment" properties

Sample Swap trade

"Product: Style" Properties
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Properties Description

Trade Type Select "On Market" or "Off Market":

• Off Market allows the addition of Sales Margin in terms of bp or a dollar amount, which
will be represented as a CA Sales Margin Fee.

• On Market includes the use of an off-market-rate swap, indicated by [om] in the Rate
property. CA Sales Margin Fees can be included as well, resulting in two fee types for
the saved trade.

Product Type Displays the product type based on the selected strategy.

Notional Ccy Select the currency of the notional.

You can select a different currency for each leg.

See Swap Trade - Cross-Currency for details.

Pay/Receive Select the direction of the trade leg from the book's perspective.

Notional Exchange Select Initial, Final, Amortization or any combination of the three to indicate that the notional
amount will be exchanged, otherwise there is no exchange of notional.

Amortization The amortization of the notional defaults to Bullet.

You can also right-click the trade and choose "Supplemental" to specify an amortization
schedule.

See Setting an Amortization Schedule for details.

Leg Type Select the trade leg type: Fixed or Float.

Call Type Select "None".

You can select "Cancellable" for a cancellable swap.

See Cancelable Trades for details.

Custom Cashflows Displays "true" if the cashflows have been customized, or "false" otherwise.

"Product: Rate" Properties

Properties Description

Rate Index Select the Rate Index:

• ISDA Set In Advance: True or False. Setting to true will trigger behavior for daily
compounded and averaging swap trades.

12.7 .1 Braz i l ian Swaps

Key Properties
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Swap Properties - Ccy - "Product: Rate" Properties - "Product: Payment" Properties

Sample Brazil Swap trade

"Product: Rate" Properties

Properties Description

Rate Index Select the rate index, CDI. CDI interest calculation is compounded exponentially.

If a PTAX rate is used, it will have to be configured in the Exotic Type Creator. From the Calypso
Navigator, navigate to Configuration > Product > Exotic Type Creator to define the index and added to
the Exotic Swap Strategy in the Strategy Builder.

Please refer to Calypso Building Custom Strategies documentation for more details

"Product: Payment" Properties

Properties Description

Payment
Frequency

Select the payment frequency.
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Properties Description

(Float Leg)

Payment Day
Count

(Float Leg)

Select BU/252. Interest accrues using this daycount. The daycount fraction is the number of busi-
ness days in the period divided by 252. Business days are set on the trade.

Payment
Interest
Calculation

(Float Leg)

Select the interest calculation.

"Reset Swap" Properties
The Reset Swap properties allow for setting reset trigger conditions such as Cap, Floor, or Collar on the NPV of the
swap or one or more reset dates. If any of the trigger conditions are met, the designated resetting party has the option
to reset the swap.

Properties Description

Reset Barrier Type Select a trigger type for the swap: None, Cap, Floor, Collar.

MTM Barrier Ccy Select the trade currency. When a barrier is set, both the mark to market (MTM) and the barrier
will be converted to the base currency defined by the pricing environment.

MTM Upper Barrier Enter the limit for the MTM upper barrier. This box is enabled when the Reset Barrier Type is set
to either Cap or Collar.

MTM Lower Barrier Enter the limit for the MTM lower barrier. This box is enabled when the Reset Barrier Type is set
to either Floor or Collar.

Reset Dates Select the checkbox to generate a schedule of one or more reset dates.

» Right-click anywhere in the Swap Pay/Rec legs and select Supplemental from the menu.
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Properties Description

This opens the Supplemental panel, which includes the Reset Dates tab.

» Enter a Start Date and End Date to define the duration for trigger reset dates. Then select
the Frequency, Date Roll schedule, Day to Roll On, and Holiday schedule as needed.

» Click Generate to see the schedule of trigger reset dates. If necessary, you can manually
override the dates that are generated.

» Click Clear All to clear all rows generated in the schedule. You can also click the arrow to see
options for adding and deleting extra rows.

» Once the schedule is complete, click Save and Close.

Check Barriers on
Reset Dates Only

Enabled when both barrier and date conditions are specified. When selected, the barriers will
only be monitored on the designated reset dates.

Resetting Party Select Processing Org, Counterparty, or Mutual.

 Ⓘ [NOTE: This setting is for informational purposes only and does not impact trade
behavior.]

"Fwd Start Notional Adjustment" Properties
These properties allow you to define a forward start for either a cross currency swap or non deliverable swap and
adjust the notional of one of the legs based on the FX rate on the forward swap Start Date. On a USD/BRL cross
currency swap, this feature allows participants to hedge a forward USD amount by fixing the USD notional and
updating the BRL notional at the swap’s Start Date. Between the Trade Date and the swap’s Start Date, on which the
BRL notional is fixed, the valuation of the forward starting cross currency swap is based on a projected FX rate.
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Properties Description

Fwd Start Notional Adjustment Select which leg will receive the notional adjustment: Pay, Rec, or None.

FX Reset Select the FX Reset to be used to fix the notional.

FX Reset Lag (Bus) Enter a number to be used for the Reset Lag if a reset lag is desired.

FX Reset Holidays Select the holiday schedule to be used with the Reset Lag.

Calculation Ccy To use an intermediate currency to calculate the FX rate, double-click this field
and enter the calculating currency from the list.

Calculation FX Source Select the FX reset for calculation. The FX reset will auto-populate when select-
ing the currency if the reset already exists in the system.

Calculation FX Reset Lag (Bus) Enter an FX reset lag to override the lag set in the FX reset.

Calculation FX Reset Holidays Select one or more FX reset holiday schedule(s). This field will auto-populate
when entering the currency if an FX reset already exists but can be overridden.

12.7 .2 Inf lat ion Swaps
To enter an Inflation Swap, select the Swap strategy and select an inflation index.

Key Properties
Swap properties - "Product: Rate" Properties
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Sample Inflation Swap trade

"Product: Rate" Properties

Properties Description

Rate Index Select an inflation index. An inflation index can be defined from the Calypso Navigator by navigating to
Configuration > Interest Rates > Rate Index Definition.

Inflation specific fields will only be editable if an inflation index is selected.

Inflation Cal-
culation
Method

Select the calculation method:

• IndexLevel – Index levels are not interpolated between publication dates.

• Interpolated – Daily index levels are interpolated between reference dates. Select the interpolation
method from the Inflation Interpolated Method field.

Inflation Inter-
polated
Method

Only appears for the Interpolated calculation method. The only option is "Weighted".

Specify Ini-
tial Inflation

Select "None", "Initial Level Date" or "Initial Level".

Initial Level
Date

Enter the initial level date.

For a real rate swap, the Initial Level Date uses the Start Date as a base date rather than the Valuation
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Properties Description

Date. The Initial Level Date is therefore relative to the Start Date.

When saving a strategy template for a real rate swap, be sure to select "Relative" for the "Save dates
as?" option. When you use a tenor in the date fields (e.g., 1d, 1w, 1m), new trades using the template
will then populate dates according to the tenor and based on the current date. If you use "0d" for the
Initial Level Date when creating the template, it will be populated with the same date as the Start Date.

Initial Level Enter the initial level.

Inflation Cal-
culation
Type

Select the inflation calculation type:

• InflationIncome - [(Final Level / Initial Level) - 1]

• InflationIndexation – [Final Level / Initial Level]

You can also set the following properties:

• Apply To:

– Select “Interest” to apply the inflation calculation type to the interest. If InflationIncome
calculation type is selected, this is the only option available.

– Select “Interest and Principal” to apply the InflationIndexation calculation type to both the
interest and principal. If selected, the swap leg requires a manual Initial Level to be defined
in the “Specify Initial Inflation” property.

• Use Fixed Rate - When “Use Fixed Rate” is checked, enter a value in the property “Fixed Coupon
Rate”.

Then right-click the Fixed Coupon Rate and choose "Supplemental" to define the fixed coupon
schedule.

• Inflation Factor - Enabled only when Inflation Calculation Type = InflationIndexation. Determines
the rounding method for the Inflation Factor on the Cash Flows panel. Options for this field are
NONE, NEAREST, UP, DOWN.

• Inflation Factor Decimal - Enabled only when Inflation Calculation Type = InflationIndexation.
Determines the rounding precision for the Inflation Factor on the Cash Flows panel. Enter an
integer to specify the precision.

 Ⓘ [NOTE: to add the Inflation Factor column on the Cash Flows panel, in Pricing Sheet point to
Configuration > User Preferences and select the Cash Flows tab. From there you can move the
Inflation Factor column to the Selected Columns field to expose it in cashflows.]

Leg link for Inflation Swaps trades can be configured.

• Fixed Coupon Rate - can be set to "=", "*", "+" or "-"

12.7 .3 Braz i l ian Inf lat ion (PTAX) Swaps
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Key Properties
Swap Properties - Product: Rate Properties

Sample PTAX Inflation Swap trade

"Product: Rate" Properties

Properties Description

Leg Type Select Fixed or Float on one leg, and select PTAX in the other.

To configure this type of leg, create a PTAX exotic structure in Configuration > Product > Exotic Type
Creator and add it to the Exotic Swap strategy in the Pricing Sheet using Configuration > Strategy
Builder.

12.7 .4 Cross-Currency Swaps
Swaps where each leg is expressed in a different currency.

Key Properties
Swap properties - Ccy Pair - Initial FX Spot - Principal Adjustment
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Sample Cross-Currency Swap trade

Properties Description

Ccy Pair Displays the currency pair when each leg is in a different currency.

Initial FX Spot Enter the FX spot trade between the two currencies.

Principal Adjustment If there is notional exchange, you can also specify notional adjustments at every coupon
period based on FX rates.

Select None, Pay (adjustments on the Pay leg), or Rec (adjustments on the rec leg).

You can also set the following properties:

• FX Reset - Select the FX rate reset to determine the FX rates for the adjustments. FX
rate resets are defined from the Calypso Navigator using Configuration > Foreign
Exchange > FX Rate Definitions.

• Adjust First - Check to adjust the first cashflow.
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Properties Description

• FX Reset Use Index Reset Date - Check to set the FX reset date to the index reset date.
It is the payment begin date otherwise.

If "FX Reset Use Index Reset Date" is not checked, you can set the FX Reset Lag and FX
Reset Holidays as needed.

12.7 .5 Cancel lab le Swaps

Key Properties
Swap properties - Call Type = "Cancellable"

Sample Cancellable properties

Properties Description

Call Type Select "Cancellable".

For a Cancellable swap, you can set the following properties:

• Buy/Sell - Select Buy or Sell, the direction of the trade from the book’s perspective.

• Exercise Type - Select European, Bermudan, or American - See below for details.

European
The trade can only be canceled on the expiration date.

» Enter the expiration date in the Expiry Date field. If you enter a non-business day, it will automatically move to the
previous business day.
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» Enter the expiration time in the Expiry Time field, and select the corresponding timezone and holiday calendars.

You can also enter the earliest exercise time and latest exercise time.

» The delivery date defaults to the spot date for the selected currency. You can modify as needed. You can also
enter the number of lag days in the Settlement Lag field and select whether the lag days are business days or
calendar days.

» You can select a fee type in the Fee Type field (Amount or %), and enter the fee amount / percentage in the Fee
field. Select the fee currency from the Fee Currency field.

American
The trade can be canceled between the first exercise date and the expiration date.

» Enter the first exercise date in addition to the European properties.

Bermudan
The trade can be canceled according to a user-defined schedule.

Right-click the trade and choose "Supplemental" to specify the Schedule.

Sample Bermudan Schedule

» The start and end dates default to the trade's start and end dates.

Select a frequency, date roll and holiday calendars to generate the schedule.

Enter a number of lag days to compute the delivery date based on the actual call date. And select Bus if the lag
days are business days, or Cal for calendar days.

» Click Generate to generate the schedule.

You can click the "Clear All" menu to add / remove dates.

You can enter the fees in the schedule in percentage or in amounts. The Fee currency is selected in the trade's
"Fee Currency" property.
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» Then click Save and Close to apply the schedule to the trade.

12.7 .6 Non-del iverab le Swaps

Key Properties
Swap Properties - Currency type: Non-Deliverable - Product: Style properties - Product: Rate properties

"Product: Style" Properties

Properties Description

Settle Type Select for Non-Deliverable FX Reset or Non-Deliverable Fixed FX.

Settle Ccy Select the settlement currency.

Quanto Factor Used when Settle Type = Non-Deliverable (Fixed FX). Displays the current quanto factor.
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Properties Description

Quanto Ccy Pair Used when Settle Type = Non-Deliverable (Fixed FX). Displays the currency pair between
the Notional Ccy and the Settle Ccy.

"Product: Rate" Properties

Properties Description

Flexo FX Source If Settle Type = Non-Deliverable (FX Reset), enter the following values:

Flexo FX Reset Lag - Enter a lag value to override the default reset lag for the selected
Settlement Source.

Flexo FX Reset Holidays - Select a holiday calendar to override the default holiday calendar
for the selected Settlement Source.

Calculation Ccy Select the intermediate currency to convert notional currency to settle currency. Enter:

– Calculation FX Rate

– Calculation FX Source

– Calculation FX Reset Lag

– Calculation FX Reset Holidays

For NDS Swaps in the Pricing Sheet, the Events Viewer panel will display the following columns:

• Currency - Settlement currency

• Currency Native

• Amount - Interest amount in settle currency

• Amount Native Ccy

• Amount Calculation Ccy

• Settle FX Reset

• Settle Reset Date

• Calculation FX Reset

• Calculation Reset Date

• PV Amt - PV Disc in Native Ccy

• PV Amt Settle Ccy

• df - df of native Ccy

• df Settle Ccy
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12.7 .7 Quanto Swaps
A Quanto swap trade uses the Swap strategy. it is a swap where the rate index currency is different from the notional
currency.

You can add the QTO cashflow values to the Events Viewer panel of the Pricing Sheet using Configuration > User
Preferences > Events tab.

Key Properties
Swap Properties - Trade Events = QTO cashflow details

12.7 .8 Real Y ie ld Swaps
To enter a Real Yield Swap, select the Swap strategy and the "RealYield" leg type.

Key Properties
Swap properties - Underlying - Product ID
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Sample Real Yield Swap trade

Properties Description

Underlying Double-click to select the underlying inflation bond.

Product ID Displays the bond product identifier.

You can also override the following bond properties:

• Product Reset Timing - Select the product reset timing: At Start, or In Arrears.

• Product Reset Lag - Enter product reset lag (number of days between the reset date
and the payment date), and specify the reset lag as Business days or Calendar days.

• Product Reset Holidays - Select the product reset holidays.

12.7 .9 F ixed Payment Swap
The Fixed Payment Swap strategy allows for entering a fixed amount on the fixed leg to specify a cashflow amount
that will be exchanged at the end of the period. The floating leg, on the other hand, can have exchanges during the life
of the swap. Instead of entering a notional and rate to calculate the payment amount, a value is entered directly in the
Fixed Amount property.

Key Properties
Swap properties - Fixed Amount

Nasdaq Calypso
Pricing Sheet User Guide / Version 18

December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 286 / 359



December 2024
Revision 4.0 / Approved

Proprietary and Confidential
Page 287 / 359

Cashflows indicate the amount for the fixed leg and have no information for the rate.

12.7 .10 Performance Swap
A Performance Swap trade is a swap where a set of future cash flows are exchanged between two counterparties.
The primary leg can be a single asset only, with a bond or market index underlying. The secondary leg is currently
limited to swaps.

Key Properties
Swap properties - Leg Type, Underlying - Product: Performance Schedule properties - Product: Income Schedule
properties
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Properties Description

Underlying Select the product that underlies the performance swap: A bond or a market index depend-
ing on what you specify under Leg Type.

Leg Type Pricing sheet currently supports Bond and MarketIndex for the primary leg, and swap for the
secondary leg.

Modified Adj Duration Enabled when the primary leg type is "Market Index" and Fixing Type is set to "Spread".
Enter a number.

Fixing Type When the primary leg is set to Bond: Default value is based on the selected Bond Quote
Type.

When the primary leg is set to MarketIndex: Can set to Spread to disable Initial Price and set
Units Based to False. This disables "Modified Adj Duration".

Notional Price Bond asset detail. Select the notional price for the bond.

Use Asset Schedule Bond asset detail that impacts the cashflows, set to true or false.

"Product: Performance Schedule" Properties

Properties Description

Income Payments
Type

Dropdown with options "NONE", "AT_MATURITY", "REF_ASSET_CPN_SCHEDULE",
"CUSTOM_SCHEDULE", and "DATE_RULE".

Pmt Lag This string applies a payment lag to the income payments.

Pmt Holidays Selecting this property opens the Holiday Calendar widget from which payment holidays can
be selected and customized.

Pmt Date Roll Selecting this property opens the Date Roll widget from which payment date rolls can be spe-
cified.

Reinvestment Rate Enter a number to apply a reinvestment rate.

Pmt Frequency Select the frequency of payment from a dropdown menu.

Pmt Roll Day Select the payment roll day from the dropdown.

"Product: Income Payments Type" Properties

Properties Description

Income Payments
Type

Bond only: Dropdown with options None, At Maturity, Upon Receipt, and Custom Schedule.
Defaults to Upon Receipt.
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Properties Description

Pmt Lag This string applies a payment lag to the income payments.

Pmt Holidays Selecting this property opens the Holiday Calendar widget from which payment holidays can
be selected and customized.

Pmt Date Roll Selecting this property opens the Date Roll widget from which payment date rolls can be spe-
cified.

Reinvestment Rate Enter a number to apply a reinvestment rate.

Pmt Frequency Select the frequency of payment from a dropdown menu.

Pmt Roll Day Select the payment roll day from the dropdown.

12.8 Capped Swap Trades
A swap with a cap floor on the floating leg. The trade can be fixed-floating or floating-floating.

Key Properties
Swap properties - Option Type - Strike 2 - Factor - Volatility
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Sample Capped Swap trade

"Product: Style" Properties

Properties Description

Settle Type Select for Non-Deliverable FX Reset or Non-Deliverable Fixed FX.

Settle Ccy Select the settlement currency.

Quanto Factor Used when Settle Type = Non-Deliverable (Fixed FX). Displays the current quanto factor.

Quanto Ccy Pair Used when Settle Type = Non-Deliverable (Fixed FX). Displays the currency pair between
the Notional Ccy and the Settle Ccy.

"Product: Payment" Properties
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Properties Description

Compounding Type Select the compounding type, if applicable, or none.

• Flat - Flat compounding - The spread is added after the compounding is computed if
any. Current period interest is calculated using floating rate plus spread. But compound
interest is calculated using floating rate only (and the spread is not added).

• Spread - The interest compounds at the rate value plus spread. Enter the Spread in the
Compounding Spread field.

• SimpleSpr (Swaps only) - This involves compounding the Floating Rate but treating the
spread as simple interest. In other words, the floating rate interest is earned at the end
of a period but not the spread (only the floating rate is added back into the notional).
The spread is then calculated on the notional for the entire calculation period without
compounding.

• NoCmp - A cashflow is created at the compounding period without actually
compounding the interest. The daily rate resets for the floating rate are used to
calculate the simple interest everyday and summed to find the total interest for the
period.

You can also set the following properties:

• Compounding Frequency - Select the compounding frequency. The compounding
frequency must be more frequent than the payment frequency.

When you select a DLY compounding frequency for a rate index that is not setup for
daily compounding, the DailyCompound calculator is used.

• User Reset Period Dates - Check to compound trades based on the reset dates rather
than the payment dates.

• Compounding Stub

• Sample Timing - Select the sample timing: "At Start" or "In Arrears".

• Use Sample Period Shift - When checked, it includes an Observation Shift that allows
shifting the whole Sample Period in addition to the Reset Dates, such that the weights of
any given daily fixing remains the same.

Factor Enter the factor. Available for the Option Type "Digital Cap", "Digital Floor" or "Digital Collar".

"Product: Rate" Properties

Properties Description

Strike Enter the upper strike.

You can also specify the following property:

• Strike 2 - Captures the lower strike. Available for the Option Type "Collar" or "Digital
Collar".
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Properties Description

You can also right-click the fields and choose "Supplemental" to specify a Strike Schedule.
For "Strike 2", you can specify different schedules for the Upper and Lower Strike.

Option Type Select an option type: None, Cap, Floor, Collar, Digital Cap, Digital Floor, Digital Collar.

Flexo FX Source If Settle Type = Non-Deliverable (FX Reset), enter the following values:

– Flexo FX Reset Lag - Enter a lag value to override the default reset lag for the
selected Settlement Source.

– Flexo FX Reset Holidays - Select a holiday calendar to override the default holiday
calendar for the selected Settlement Source.

Calculation Ccy Select the intermediate currency to convert notional currency to settle currency. Enter:

– Calculation FX Rate

– Calculation FX Source

– Calculation FX Reset Lag

– Calculation FX Reset Holidays

"Market Data" Properties

Properties Description

Volatility Displays the volatility based on the market data associated with the selected pricing envir-
onment. You can modify this value.

12.9 Swaption Trades

Key Properties
Swaption properties - Expiry Date - Delivery Date - Option Type - Exercise Type - Settle Type - Fixed Swap Tenor -
Cash Settle Method
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Sample Swaption trade

"Product: Style" Properties

Properties Description

Option Type Select the option type: Payer, Receiver, or Straddle.

Exercise Type Select the exercise type:

• European (default value) - The option may only be exercised on the expiry date.

You can select a fee type (Amount or %) and enter a fee.

• American - You can exercise the option anytime between the first exercise date and the
expiration date.

You can define a fee schedule. Right-click the trade and choose "Supplemental" to
define the fee schedule.

For American Swaptions in the Pricing Sheet, changing the Delivery Date will not effect
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Properties Description

the underlying Swap Start Date. Shortcuts applied to the Swap Start Date are based on
the Trade Start Date, not the Delivery Date. Changing the Swap End Date triggers the
validation of the Expiry Date. If it is after the new End Date, the dates become equal.

See Defining a Fee Schedule for details.

• Bermudan - You can exercise the option according to a user-defined exercise schedule.

Right-click the trade and choose "Supplemental" to define the exercise schedule. It is
the same as defining a cancelable schedule.

See Cancelable Swaps for details.

Settle Type Select the settlement type at exercise. The application may automatically select it based on
the product type.

• Cash - For cash settlement (exercise against a fee).

• Physical - For physical settlement (exercise against the underlying product) - A trade on
the underlying product is automatically created.

• Cleared Physical Settlement

You can also set the following properties:

• Settlement Lag - Enter a number of lag days, months or years. This is the offset
between the expiration date and the delivery date.

Examples: 3D, 1M, 1Y, etc.

• Settlement Lag Days - Select Business or Calendar.

• Settlement Holidays - Select the holiday calendar.

• Settlement Date Roll - Select the date roll convention.

• Expiration Time Zone - Select the timezone of the expiration times.

• Expiration Time - Enter the expiration time.

• Earliest Exercise Time - Enter the earliest exercise time.

• Latest Exercise Time - Enter the latest exercise time.

• Automatic Exercise - Check to allow automatic exercise.

Swaptions can be automatically exercised using the AUTOMATIC_EXERCISE scheduled
task, provided they are in-the-money.

You can specify a threshold in percentage to trigger the automatic exercise.

Otherwise, choose Processing > Exercise to exercise the option - Help is provided
from that window.

• Partial/Multiple Exercise (European swaptions only) - Check to allow partial exercise.

You can specify the minimum and maximum notional that can be partially exercised.

MidCurve / Select an option from the drop-down list:
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Properties Description

FixedSwapTenor • None - Neither MidCurve nor Fixed Swap Tenor is selected for the Swaption.

• MidCurve - Select for a MidCurve Swaption, which sets the Product Subtype to
MidCurve

• FixedTenor - Select for a Fixed Tenor Swaption, which sets the Product Subtype to FT
European.

This selection disables the Start Date and End Date. You can also add a tenor to the
Fixed Swap Tenor field (see below), press Enter, and the FixedTenor selection is
automatically made.

Pricing for Mid-Curve Swaption
Mid-curve swaption needs to be priced using the pricer PricerSwaptionMidCurve.

In addition to the volatility surface, discount curve and forecast curve, it requires a
correlation matrix between the swaption expiry (Offset Axis), underlying swap start date (1st
Axis = Lag) and underlying swap expiry (2nd Axis = Tenor).

You can set the following parameters at trade level:

• SWAPTION_MIDCURVE_CALCULATOR

– Normal2Normal - Normal marginals + normal effective distributions.

– Lognormal2Normal - Lognormal marginals + normal effective distributions.

– Lognormal2ShiftedLognormal - Lognormal marginals + shifted-lognormal
effective distributions.

• VOLATILITY_LONG_TENOR - Marginal volatility of the long replicating swap. A value of
’1.2’ means 1.2 bp vol for normal marginals, while it is 1.2% for lognormals. Use to
numerically calculate corresponding marginal vega.

• VOLATILITY_SHORT_TENOR - Marginal volatility of the short replicating swap. Use to
numerically calculate corresponding marginal vega.

• USE_ATM_VOLS - Only True is currently supported.

• CORRELATION - Correlation between the replicating swap rates. The correlation is of
the ‘same’ type as the marginals. A value of ‘0.87’ means: 87%. Use to numerically
calculate corresponding CORRELATION_01.

• SHIFTEDLOGNORMAL_SHIFT - Shift of the effective shifted-lognormal distribution. If
missing, a default value of ‘0.0’ is assumed. Ignored unless VOLATILITY is set as well.
Not applicable to Normal2Normal / Lognormal2Normal models.

• VOLATILITY - Effective volatility of the underlying swap. Use to numerically calculate
corresponding vega.
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Properties Description

More details can be found in the Calypso Analytics Library documentation.

Fixed Swap Tenor Enter the fixed tenor of the swap for Fixed Tenor Swaptions.

The swap starts on the option’s delivery date and ends on the option’s delivery date + fixed
tenor.

The system currently only supports the pricing of European Fixed Tenor Swaptions.

"Product: Payment" Properties

Properties Description

Cash Settlement
Method

Only applies to cash settlement.

Select the settlement method to compute the settlement amount.

[NOTE: If you have defined cash settlement defaults (CSD), it will pick up the settlement
method from the CSD defined for the agreement specified in domain
"CashSettleDefaultsAgreements" / rate index / currency - It is ANY by default.

For example, ANY is defined in domain "CashSettleDefaultsAgreements", and you have a
CSD defined for ANY / LIBOR / USD. If the trade is LIBOR / USD and settles in Cash, then the
settlement method from the CSD will be set on the trade by default]

You can set additional properties:

• Valuation Date - Defaults to the Expiration Date.

• Valuation Lag - Enter the number of days between the valuation date and the cash
settle payment date.

• Valuation Holidays - Select the holiday calendar.

• Cash Settle Payment Date - Defaults to the Delivery Date.

• Cash Settle Currency - Select the currency of the settlement amount.

• Rate Source - You can select a rate source or none (empty). Rate sources are defined in
the "RateSource" domain.

If you select none, you have to select a set of reference banks in Rek Bank 1, Ref Bank 2,
Ref Bank 3, Ref Bank 4, Ref Bank 5 - Legal entities of role ReferenceBank.

If you select OTHER_SOURCE, you need to select a rate index in Cash Settle Rate Index.

• Quotation Rate - Select the instance of the quotation rate that you want to use: MID,
BID, or ASK.

• Settle Rate - Displays the settlement rate used to compute the settlement amount for
the cash settlement methods “Par Yield Curve - Adj.” and “Par Yield Curve - Unadj.”.

In the Option Exercise Window, there is a Settlement Rate field. You can get the value
from the pricing environment by clicking Price, or you can enter a value. If you enter a
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Properties Description

rate, it will be displayed here.

• Cash Settle Location - Select the ISDA location.

• MV Applicable CSA - Activated when one of the following settlement types are selected:
Mid-market Valuation, (Indicative Quotations), Mid-market Valuation (Indicative
Quotations) - Alternate Method, or Mid-market Valuation (Calculation Agent
Determination). Select No CSA, Existing CSA, or Reference VM CSA.

• Cash Collateral Currency - Activated when MMV Applicable CSA is set to Reference VM
CSA. Select a currency from a list defined in Domain Values.

• Cash Collateral Interest Rate - Activated when MMV Applicable CSA is set to Reference
VM CSA. Select a Rate Index (Populated via the arte index window from the database).

• Agreed Discount Rate - Activated when one of the following settlement types are
selected: Mid-market Valuation (Indicative Quotations), Mid-market Valuation
(Indicative Quotations) - Alternate Method, or Mid-market Valuation (Calculation Agent
Determination) and MMV Applicable CSA is set to No CSA. Also activated when Cash
Settlement Type is set to Collateralized Cash Price. Also activated when Settlement
type is set to Cleared Physical Settlement. Select a Rate Index (Populated via the rate
index window from the database).

• Mutually Agreed Clearing House - Activated when Cash Settlement type is set to
Collateralized Cash Price. Also activated when Settlement type is set to Collateralized
Cash Price. Enter text (up to 128 characters).

12.9 .1 Def in ing a Fee Schedule
Right-click the trade and choose "Supplemental" to define a fee schedule for American swaptions.

Sample American Fee Schedule

» The start and end dates default to the trade's start and end dates.

Select a frequency, date roll and holiday calendars to generate the fee schedule.

» Click Generate to generate the schedule.
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You can click the "Clear All" menu to add / remove cancellation dates.

You can enter the fees amounts in the fee schedule.

» Then click Save and Close to apply the schedule to the trade.

12.9 .2 Comput ing the Premium Fee
The premium fee is a fee of type PREMIUM. Such a fee needs to be defined in the Calypso Navigator under
Configuration > Fees, Haircuts, & Margins > Fee Definition.

Once you apply the premium fee to the trade, it is displayed in the Trade Events panel.

To compute the premium fee, price the trade, then right-click the trade and choose "Supplemental".

Sample Cashflow Schedule premium fee

There are multiple ways to compute the premium fee.

Cashflow Schedule
This is the default calculation when the trade is priced.

» You can modify the rounding convention from the Rounding field.

» You can modify the fee amount as needed.

– Click “Fixed Premium Amount” and check the “Edit Amount” checkbox to modify the fee amount for each fee
period.
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– Or click “Fixed Premium Percentage” and check the “Edit Amount” checkbox to modify the fee percentage.

» Then click Calc to recalculate the fee, and click Save and Close to save the fees. You can view the generated fees
in the Trade Events panel.

Single Premium Fee

Sample Single Premium fee

» Select “Custom Single” from the Mode field.

» Click Percentage to enter the fee as a percentage of the notional, or Amount to enter a fee amount.

» Select the rounding convention from the Rounding field, and enter the fee date in the Date field.

» Then click Calc to calculate the fee, and click Save and Close to save the fee. You can view the generated fee in
the Trade Events panel.

Custom Schedule
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Sample Custom Schedule premium fee

» Select “Custom Schedule” from the Mode field.

» Click Percentage to enter the fee as a percentage of the notional, or Amount to enter a fee amount. This is the
total amount that will be broken down according to the schedule.

» Select the rounding convention from the Rounding field.

» Check “Amortize Fee Over Schedule” to assign the total premium by percentage or amount to each period, or
uncheck to assign the same amount to each period.

» Enter the criteria to define the custom schedule: From and To dates, frequency, payment calendars, date roll
convention, day count, payment date, and roll day adjustment.

The "Use Cashflow Schedule" checkbox only applies if the trade has stub periods.

When checked, if your trade has stub periods, all the correct dates will have been generated for the trade. Then
you can overlay the settings of frequency, date roll, beg/end, etc. on top of that. Ensure that the frequency is less
than or equal to the frequency of the cashflows. This is similar to the way Bermudan exercise dates generation
works.

» Then click Calc to calculate the fees, and click Save and Close to save the fees. You can view the generated fees in
the Trade Events panel.

Sample PREMIUM fees in Trade Events panel
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12.10 Sett ing Specif ic Resets
You can enter price fixings and rate resets specific to the current trade. The resets defined here are not used by other
trades.

To set specific resets, right-click a trade and choose "Supplemental".

» Enter a reset rate (or reset price, as applicable), and select a reset date, then click Add.

» Click Save and Close to save the specific resets.

The rates will appear in the corresponding cashflows, and the Manual Reset checkbox will appear checked.

12.11 Islamic Trades
You can capture Islamic MM trades and Islamic Swap trades using the Pricing Sheet.
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Islamic trades are standard loan / deposit trades and swap trades with an underlying commodity asset, and
participants (brokers and counterparty). The underlying details are only stored for reference. The brokers need to
accept the underlying details however in order for the trade to be validated.

The INTEREST flows are replaced with PROFIT and COST flows.

12.11 .1 Before you Begin

Execute SQL
You need to add "<calypso home>/client/resources/samples/dbscripts/SchemaData_islamic.xml" to
Execute SQL, in order to populate Islamic static data.

Underlying Names
The names of the commodity underlyings must be defined in the domain "IslamicMM.UnderlyingName" for Islamic MM
trades, and in the domain "IslamicSwapLeg.UnderlyingName" for Islamic Swap trades.

Islamic trades are not actually linked to a commodity product. They are linked to an underlying name for reference.

Islamic MM Workflow Setup
The trades should only be validated once the brokers have accepted the underlying details.

So the trade lifecycle should be as follows:

1. Capture trades - Trades move to status PENDING, and confirmation messages are sent to the brokers.

2. When the trades are accepted by the brokers, the back office operator manually applies the ACCEPT action to the
confirmations, which applies the same action to the trades through the message rule ApplyTradeSameAction.

The trades then follow the standard workflow.

Changes to Trade Workflow

Add the transition PENDING - ACCEPT - ACCEPTED.

Change the transition PENDING - AUTHORIZE - VERIFIED to ACCEPTED - AUTHORIZE - VERIFIED.

Orig Status Action Resulting Status Use STP Product Type Rules Create Task

PENDING ACCEPT ACCEPTED false IslamicMM true

ACCEPTED ACCEPT ACCEPTED false IslamicMM true

ACCEPTED AUTHORIZE VERIFIED false IslamicMM CheckSDI false

Message Workflow
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Orig
Status

Action Resulting
Status

Use
STP

Product
Type

Rules Create
Task

Comment

NONE NEW PENDING false IslamicMM true

PENDING ACCEPT VERIFIED false IslamicMM ApplyTradeSameAction true [action=ACCEPT]

PENDING ACCEPT VERIFIED false IslamicMM ApplyTradeSameAction true [action=ACCEPT]

PENDING CANCEL CANCELED false IslamicMM ApplyTradeSameAction true [action=CANCEL]

VERIFIED CANCEL CANCELED false IslamicMM true

The action defined in the Comment will be applied to the trade.

12.11 .2 Is lamic MM Trades
Select the "Islamic MM" strategy.

Key Properties
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Pay/Receive - Product Name - Contract Type - Broker - Secondary Broker - Underlying - Rate - Rate Index - Cap %

Properties Description

Pay/Receive Select the direction of the trade, either Pay or Receive.

• Deposit indicates that the processing org is borrowing money from the counterparty
(the party that deposits the money). The commodity trades are done with the brokers
and the counterparty.

• Loan indicates that the processing org lends the money to the counterparty. The
commodity trades are done with the brokers.

Product Name Select the product.

• For Pay (Deposit), you can select Isra, Murabaha, or Wakala.

• For Rec (Loan), you can select Tawaruq or Murabaha.

Contract Type Applies to Wakala only.

You can select the contract type for information purposes:

• Restricted Agency

• Unrestricted Agency

Broker Optional for Murabaha trades. Not used for Wakala.

Type in a few letters, and all brokers that start with those letters will appear. You can select
a broker from the list.

A broker is a legal entity of role Broker.

Only favorite brokers can be selected. Favorite brokers are selected from the Calypso
Navigator using Configuration > Favorites > Brokers.

Secondary Broker Optional for Murabaha trades. Not used for Wakala.

Type in a few letters, and all brokers that start with those letters will appear. You can select
a broker from the list.

A secondary broker is a legal entity of role Broker.

Only favorite brokers can be selected. Favorite brokers are selected from the Calypso
Navigator using Configuration > Favorites > Brokers.

Underlying Select the name of the commodity underlying.

Underlying names are defined in the domain "IslamicMM.UnderlyingName".

Not used for Wakala.

Underlying Mode Select the calculation mode:

• Quantity and Price: You will be prompted to enter the quantity and price. The principal is
computed as:

Principal = Underlying Quantity * Underlying Price.
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Properties Description

• Value Only: You will be prompted to enter an asset value. The principal is computed as:

• Principal = Underlying Value

Underlying Quantity Applies for Underlying Mode = Quantity and Price.

Enter the quantity of underlying.

Underlying Price Applies for Underlying Mode = Quantity and Price.

Enter the unit price of underlying.

Value For Underlying Mode = Quantity and Price, displays the asset value.

For Underlying Mode = Value Only, enter the asset value.

Rate Enter the fixed rate for Isra, Murabaha, Tawaruq.

Rate Index Select the rate index for Wakala, and set the rate index parameters as needed.

Cap % Enter the cap rate for Wakala.

12.11 .3 Is lamic Swaps
Islamic Profit Rate swaps allow buying / selling the underlying commodity asset t a certain date. The underlying details
are only stored for reference.

Select the "Islamic Swap" strategy.
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Islamic Swap Properties - Product Name - Product Structure - Broker - Secondary Broker - Underlying

Properties Description

Product Name You can select "Pure Murabaha" or "Waad Based".

Product Structure You can select "Single Sale" or "Double Sale".

For a Single Sale swap, there is only one cashflows per payment period. Both legs must have
the same payment frequency. You need to setup a netting method similar to the Trade
netting method that uses the netting key IslamicTransferType instead of TransferType.
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Properties Description

For a Double Sale swap, the cashflows are generated for each leg independently.

Broker Type in a few letters, and all brokers that start with those letters will appear. You can select
a broker from the list.

A broker is a legal entity of role Broker.

Only favorite brokers can be selected. Favorite brokers are selected from the Calypso
Navigator using Configuration > Favorites > Brokers.

Secondary Broker Type in a few letters, and all brokers that start with those letters will appear. You can select
a broker from the list.

A secondary broker is a legal entity of role Broker.

Only favorite brokers can be selected. Favorite brokers are selected from the Calypso
Navigator using Configuration > Favorites > Brokers.

Underlying Select the name of the commodity underlying.

Underlying names are defined in the domain "IslamicSwapLeg.UnderlyingName".

Underlying Mode Select the calculation mode:

• Quantity and Price: You will be prompted to enter the quantity and price. The principal is
computed as:

Principal = Underlying Quantity * Underlying Price.

• Value Only: You will be prompted to enter an asset value. The principal is computed as:

• Principal = Underlying Value
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Properties Description

Underlying Quantity Applies for Underlying Mode = Quantity and Price.

Enter the quantity of underlying.

Underlying Price Applies for Underlying Mode = Quantity and Price.

Enter the unit price of underlying.

Value For Underlying Mode = Quantity and Price, displays the asset value.

For Underlying Mode = Value Only, enter the asset value.

Exercise Timing Select the exercise timing: "At Start" (exercise occurs at the beginning of the period) or "In
Arrears" (exercise occurs at the end of the period).

Purchase Timing Select the purchase timing: "At Start" (purchase occurs at the beginning of the period) or "In
Arrears" (purchase occurs at the end of the period).

12.11 .4 Sample Message Setup

Islamic MM
You need to setup message templates for each type of pending trade so that a confirmation is to the brokers and/or
counterparty to be accepted:

• Pending loan to Broker 1

• Pending loan to Broker 2

• Pending deposit to Broker 1

• Pending deposit to Broker 2

• Pending deposit to CounterParty

You can distinguish the types of trades using static data filters as needed.

Sample pending confirmation sent to the broker:
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 Ⓘ [NOTE: These are just sample values - You need to use the appropriate message type and template]

Once the trades are VERIFIED, an official confirmation can be sent to the counterparty.

Sample verified confirmation sent to the counterparty:

 Ⓘ [NOTE: These are just sample values - You need to use the appropriate message type and template]

For Wakala, you can use the following templates:
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• IslamicMMWakalaWakilOffer.html

• IslamicMMWakalaWakilOfferArabic.html

To use the Arabic template, set the language to Arabic, and the environment property FORMATTER_CHARSET=UTF-
8.

Islamic Swap
You can use the following templates:

• IslamicSwapAssetSaleConfirmation.html

• IslamicSwapConfirmation.html

• IslamicSwapExerciseNotice.html

• IslamicSwapAssetSaleConfirmationArabic.html

• IslamicSwapConfirmationArabic.html

• IslamicSwapExerciseNoticeArabic.html

To use the Arabic template, set the language to Arabic, and the environment property FORMATTER_CHARSET=UTF-
8.

Sample confirmation:
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Sample exercise notice (not needed for Pure Murabaha Islamic swaps):

Sample asset sale confirmation (not needed for Pure Murabaha Islamic swaps):
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13. Capturing Listed Derivatives
Strategies
To capture a listed derivatives trade in the Pricing Sheet, you first need to define listed derivatives contracts and
products.

See Listed Derivatives for details.

Please refer to Calypso Listed Derivatives documentation for details.

Then select a listed derivatives strategy and set the properties as needed.

There are two types of exchange traded strategies (based on the user preference "Default Listed Product Strategy":
Specific or Generic.

• For Specific, you can capture listed derivatives trades using specific strategies based on the type of the listed
derivatives: Future Bond, Future MM, Future Option Bond, etc.

• For Generic, you can capture listed derivatives trades using the strategies Future (for Future trades) or Option (for
Future Option and ETO trades). It is mandatory to select Generic for ETD Clearing.

 Ⓘ [NOTE: Strategy templates are not currently implemented for listed strategies]

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Properties specific to listed derivatives strategies are described below.

Contents

- ETO FX, Equity and Equity Index Trades

- Bond, MM, FX, Equity, Equity Index and Commodity Future Trades

- Bond, MM, FX, Equity, Equity Index and Commodity Future Option Trades

- Listed FRA Trades
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- Future Structured Flows

- "Future Swap Trades" on page 329

- "Future Forward Start FX Trades" on page 331

- Brazilian FRC Trades

- Generic Future and Generic Option

13.1 ETO FX, Equity and Equity Index Trades
Prior to capturing ETO FX trades, you need to specify ETO equity contracts from the Calypso Navigator using
Configuration > Listed Derivatives > Option Contracts, and generate the ETO FX, Equity and Equity Index products.

Properties
Exchange - Contract - Contract Date - Strike - Quantity - Buy/Sell - Put/Call

Sample ETO FX trade

An ETO product is uniquely identified by an exchange, a contract, a contract date, and a strike.

» Select an exchange, a contract, a contract date, and a strike to select an ETO product.
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 Ⓘ [NOTE: So-called "Flex" option products - bespoke products allowed by some exchanges for trading and
clearing by the clearinghouse, and which sometimes have multiple expiration dates - are referenced by a day,
month, and year in the Contract Date field. To achieve the correct date format used in the quote you can use a
combination of the Date Format field and the DateFormat attribute in the Exchange Traded Option Contract
Window to populate the correct date in the Contract Date property. See "Exchange Traded Option Contract" in
the Calypso Equity Derivatives documentation for details.]

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Ccy Pair Displays the currency pair of the contract.

Notional Ccy Select the currency of the notional.

Settle Ccy Select the settlement currency.

Buy/Sell Select the direction of the trade: Buy or Sell.

Put/Call Enter / displays the option direction for the primary currency.

Settle Type Displays the settlement type of the contract: Cash or Physical.

Contract ID Type

Contract ID

You can select a security code of the ETO product, and the corresponding value will be
displayed in the Contract ID field.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays the contract size.

Quantity Enter the traded quantity.

Contract Select the contract.

Contract Date Select the expiration date.

"Product: Rate" Properties

Properties Description

Strike Select the strike.

"Date" Properties

Properties Description

Trade Date Displays the valuation date set in the Pricing window of the pricing sheet by default.
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Properties Description

You can modify as needed.

See Using the Pricing Sheet for details.

Trade Time Displays the valuation time set in the Pricing window of the pricing sheet.

You can modify as needed.

See Using the Pricing Sheet for details.

Expiry Date Displays the expiration date.

Expiry Displays expiration date details.

Delivery Date Displays the delivery date.

Delivery Displays delivery date details.

"Price" Properties

Properties Description

Premium Date Displays the premium payment date. The system uses the spot date by default. You can
change this to a forward date. If you use a forward date, the application adjusts the premium
amount using the discount curve from the selected pricing environment.

Pricing Model Select the pricer used to price the trade. It defaults to the pricer set in the pricer
configuration.

You can also specify pricing parameters associated with the selected pricing model.

Pricer Override The Pricer Override allows overriding the default pricer coming from the pricer configuration
in a persistent fashion. This trade will always be priced using the new pricer.

You can select a pricer-override key provided you have created override keys in the Pricer
Configuration.

Market Data Item Over-
ride

The Market Data Item Override allows overriding the default market data coming from the
pricer configuration in a persistent fashion. This trade will always be priced using the new
market data.

You can select a market data-override key provided you have created override keys in the
Pricer Configuration.

Model Premium Displays the theoretical premium computed by the pricer.

Trader Premium Displays the theoretical premium computed by the pricer. You can modify its value.

Trader Price Displays the unit amount of trader premium.

Customer Premium Displays the premium amount such that Customer Premium = Trader Premium.

The premium is the actual fee that will be paid/received.
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Properties Description

Customer Price Displays the unit amount of customer premium.

Modified Strike Displays the strike.

13.2 Bond, MM, FX, Equity, Equity Index and Commodity Future
Trades
Prior to capturing Futures trades, you need to specify Future contracts from the Calypso Navigator using
Configuration > Listed Derivatives > Future Contracts, and generate the Future products.

Properties
Exchange - Contract - Contract Date - Strike - Quantity - Buy/Sell

Sample Bond Future trade

A Future product is uniquely identified by an exchange, a contract, and a contract date.

» Select an exchange, a contract, and a contract date to select a Future product.

» The trade counterparty must be a clearer, a legal entity of role Clearer.
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"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Ccy Pair Displays the currency pair of the contract.

Notional Ccy Select the currency of the notional.

Settle Ccy Select the settlement currency.

Buy/Sell Select the direction of the trade: Buy or Sell.

Settle Type Displays the settlement type of the contract: Cash or Physical.

Contract ID Type

Contract ID

You can select a security code of the Future product, and the corresponding value will be
displayed in the Contract ID field.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays the contract size.

Quantity Enter the traded quantity.

Contract Select the contract.

Contract Date Select the expiration date.

Once you have entered a trade, you can type the following shortcuts into the Contract Date
to duplicate the trade for additional contracts.

• +ny - For example "+2y" - To add trades for all available contracts over the next n years.

• +nyq - For example "+2yq" - To add trades for all quarterly contracts over the next n
years.

• +nq - For example "+2q" - To add trades for the next n quarterly contracts.

• +ns - For example "+2s" - To add trades for the next n contracts.

Cheapest to Deliver Bond futures only.

Displays the cheapest bond to deliver.

"Product: Rate" Properties

Properties Description

Strike Enter the traded price.

"Product: Payment" Properties
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Properties Description

Factor Bond futures only.

Displays the cheapest to deliver factor.

13.3 Bond, MM, FX, Equity, Equity Index, Commodity Future
Option Trades
Prior to capturing Futures Option trades, you need to specify Future Option contracts from the Calypso Navigator
using Configuration > Listed Derivatives > Future Option Contracts, and generate the Future Option products.

 Ⓘ [NOTE: So-called "Flex" option products - bespoke products allowed by some exchanges for trading and
clearing by the clearinghouse, and which sometimes have multiple expiration dates - are referenced by a day,
month, and year in the Contract Date field. To achieve the correct date format used in the quote you can use a
combination of the Date Format field and the DateFormat attribute in the Future Option Contract Specification
Window to populate the correct date in the Contract Date property. See "Defining Future Option Contracts" in
the Calypso Futures documentation for details.]

Properties
Exchange - Contract - Contract Date - Strike - Quantity - Buy/Sell - Put/Call
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Sample MM Future Option trade

A Future Option product is uniquely identified by an exchange, a contract, a contract date, and a strike.

» Select an exchange, a contract, a contract date , and a strike to select a Future Option product.

» The trade counterparty must be a clearer, a legal entity of role Clearer.

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the selected strategy.

Ccy Pair Displays the currency pair of the contract.

Notional Ccy Select the currency of the notional.

Settle Ccy Select the settlement currency.

Buy/Sell Select the direction of the trade: Buy or Sell.

Put/Call Enter / displays the option direction for the primary currency.

Exercise Type Displays the exercise type of the contract.
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Properties Description

Settle Type Displays the settlement type of the contract: Cash or Physical.

Contract ID Type

Contract ID

You can select a security code of the Future product, and the corresponding value will be
displayed in the Contract ID field.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays the contract size.

Quantity Enter the traded quantity.

Contract Select the contract.

Contract Underlying Displays the expiration date of the underlying future contract.

Contract Date Select the expiration date.

Once you have entered a trade, you can type the following shortcuts into the Contract Date
to duplicate the trade for additional contracts.

• +ny - For example "+2y" - To add trades for all available contracts over the next n years.

• +nyq - For example "+2yq" - To add trades for all quarterly contracts over the next n
years.

• +nq - For example "+2q" - To add trades for the next n quarterly contracts.

• +ns - For example "+2s" - To add trades for the next n contracts.

"Product: Rate" Properties

Properties Description

Strike Select the strike.

13.4 Listed FRA Trades
The Listed FRA possesses features of both a future and an OTC trade. As opposed to a plain FRA, the Listed FRA uses
a standardized contract to capture the details of the agreement and facilitate clearing of the product by an exchange.
The sections that follow describe how to define the contract and then capture the trade in the Pricing Sheet.

13.4 .1 Def in ing L isted FRA Contracts
The future contract for the Listed FRA bases the trade on quantity of contracts, where the trade's notional equals
quantity times the contract size specified in the contract. To open the contract from Calypso Navigator, point to
Configuration > Listed Derivatives > Listed FRA Contracts (menu action
refdata.ListedIRContractDefinitionWindow).
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» To create a new contract, make settings in the Contract Summary, Details and Underlying fields described below
and click Save.

» To load an existing contract, select an available contract from the Contract field's drop-down list at the top of the
contract window.

» To use an existing contract as the basis for a new one, make preferred changes to the contract and click Save
Contract As New. This preserves the existing contract and creates another.

» To delete a contract, select it in the Contract field and click Delete.
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» To view the schedule of essential dates and associated quotes to be used for a particular Listed FRA contract,
enter a From Date in the top central portion of the contract window and click Show.

 Ⓘ [NOTE: The schedule of dates is a tabular representation of key dates derived from date rule and lag
settings defined in the contract. The schedule is provided so that parties to the agreement can verify and
validate important dates included in the life of the trade. See Details Tab properties below.]

Contract Summary

Properties Description

Exchange Select the exchange where the FRA is listed.

Currency Select the currency for the contract.

Name Provide a unique name for the contract.

Type ListedFRA is populated by default.

Details Tab

Properties Description

Quote Type Select Yield for the Listed FRA.

Quote Decimals Define the decimal precision at the contract level. The system uses this decimal precision in
the Price field in the trade window and in quote rounding when calculating the NPV.

Contract Size Enter the Contract Size specified by the exchange.

No. of Futures in Con-
tract

Enter the total number of future products traded in the contract.

Settle Type Settlement type for the Listed FRA is "Cash".

Holidays Select a holiday calendar.

Last Trading Time Enter the time of day that trading will end on the last trading day. Use twenty-four hour time
notation (for example 16:30 is four-thirty in the afternoon).

Last Trade Date
Schedule

Expiration Settlement
Date Schedule

Select a date rule to generate the dates for each schedule. Date specifications are provided
by the exchange.
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Properties Description

Periodic Settlement
Date Schedule

» To select a date rule, click the down arrow in the date property's Value field, select and
highlight a date rule from the list, and click OK.

» You can click Open Rule to view the selected date rule in the Date Rules window.

» You can sort the rules by ID or by Name by clicking the corresponding header.

Date rules are defined and created in the Date Rules window. To open the window from
Calypso Navigator, point to Configuration > Definitions > Date Schedule Definitions > Date
Rules - Help is available from that window.

Expiration Fix Date Lag
(to Final Settlement)

Enter the lag to be used for the expiration fixing date.

Periodic Settlement
Discount Reset Fixing
Lag

Enter the lag to be used for periodic settlement discount reset fixing.

Periodic Settlement
Payment Lag

Enter the lag for periodic settlement payment.

Periodic Settlement
Discount Rate

Select the Rate Index to be used as the Discount Rate on the monthly settlement.

Tenors Lists the available tenors configured in the system for the Rate Index that is used to determ-
ine the Discount Rate. Select the tenors that are valid for use interpolating the correct Dis-
count Rate.

Underlying Tab
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Properties Description

Start/End Date Select the date rule that corresponds to the start and end of interest periods specified by
the exchange. For example, the start and end dates based on IMM date rules (the third Wed-
nesday of each month ending the quarter) would fall on the third Wednesday of a month end-
ing any given quarter and the third Wednesday of the month ending the next quarter,
respectively (e.g., March 16th, 2016 to June 15th, 2016).

Rate Index Select the Rate Index to be used as underlying for the trade.

DayCount Select the Daycount convention.

13.4 .2 Captur ing a L isted FRA Trade
This section covers the key properties that need to be entered to capture a trade.

Basic Steps for Capturing a Listed FRA Trade
• Make sure a contract has been defined.

• Specify the Exchange, Contract, and Contract Date properties in the Pricing Sheet -
this will load information from the contract and populate other related properties.

• Select an option for Buy/Sell, specify the Quantity of the trade, and add a value for
Rate.

• Define other basic properties such as Book and Counterparty.

Key Properties
Exchange - Contract - Contract Date - Buy/Sell - Quantity - Rate
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"Product: Style" Properties

Properties Description

Exchange The Exchange where the contract is listed. OMX is currently the only exchange used for the
Listed FRA product.

Contract Select the contract name.

Contract Date Select a date from those provided by the Date Rules definitions included in the Listed FRA
contract.

Buy/Sell Select the direction of the trade: Buy or Sell.

Quantity Enter the number of Listed FRA contracts to be traded.
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Properties Description

Product Type Displays the product type based on the selected strategy.

Trade Date Determines which contracts can be traded by making available those contracts that are
effective on or after the Trade Date.

Notional Calculates a total value that is equal to Quantity multiplied by Contract Size.

Notional Ccy Displays the contract currency.

Underlying Displays the contract name and refers to the interest periods, rate index and day count spe-
cified by the contract.

Settle Type Settlement type is Cash for the Listed FRA.

Contract Size Displays the size of the contract as defined in the Listed FRA Contract.

"Product: Rate" Properties

Properties Description

Rate Enter the price of the trade in yield (the strike price as a rate).

Rate Index Displays the rate index defined in the Listed FRA contract.

"Date" Properties

Properties Description

Expiry Date The day on which the contract's final settlement interest is fixed. Defined by Date Rules
included in the Listed FRA contract and populated automatically once a contract is chosen
in the Pricing Sheet.

Start Date The start of the interest period specified by the exchange. Defined by Date Rules included in
the Listed FRA contract and populated automatically once a contract is chosen in the Pricing
Sheet.

End Date The end of the interest period specified by the exchange. Defined by Date Rules included in
the Listed FRA contract and populated automatically once a contract is chosen in the Pricing
Sheet.

Settlement Date Expiration settlement, which coincides with the Start Date. Defined by Date Rules included
in the Listed FRA contract and populated automatically once a contract is chosen in the Pri-
cing Sheet.

Events Panel Columns
Two additional columns are included in the Events Panel for the Listed FRA.

• Periodic Settlement: the unadjusted monthly settlement amount based on the EOM ListedFRA fixing.
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• Discount Rate: The linearly interpolated Discount Rate based on the relevant rate index tenor quotes for the
number of days to final settlement.

For details on using the Events Panel, see "Viewing Trade Cash Flows" on page 39.

For details on configuring columns for the Events Panel, see "Events Panel" in Pricing Sheet Setup Guide
documentation.

13.5 Future Structured Flows
Future Structured Flows are exotic legs.

Properties
Product: Info = Exchange, Contract, Contract Date - Product: Price = Strike, Notional

» Select an exchange, a contract, a contract date , and a strike to select a Future Option product.

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the strategy.

Ccy Pair Displays the currency pair of the contract.

Notional Displays the notional based on the quantity.

Notional Ccy Select the currency of the notional.

Settle Ccy Select the settlement currency.

Buy/Sell Select the direction of the trade: Buy or Sell.

Expiry Date Displays the expiration date from the future contract

Delivery Date Displays the delivery date from the future contract.

Settle Type Displays the settlement type of the contract: Cash or Physical.

Strike Enter the strike.

Contract ID Type

Contract ID

You can select a security code of the Future product, and the corresponding value will be
displayed in the Contract ID field.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays the contract size.

Quantity Enter the traded quantity.

Contract Select the contract.

Contract Date Select the expiration date.
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Properties Description

Once you have entered a trade, you can type the following shortcuts into the Contract Date
to duplicate the trade for additional contracts.

• +ny - For example "+2y" - To add trades for all available contracts over the next n years.

• +nyq - For example "+2yq" - To add trades for all quarterly contracts over the next n
years.

• +nq - For example "+2q" - To add trades for the next n quarterly contracts.

• +ns - For example "+2s" - To add trades for the next n contracts.

13.6 Future Swap Trades
Swap Futures combine the economic exposure of an interest rate swap with the benefits of a standardized futures
contract. To book and price a trade, the Future Swap strategy requires a futures contract that uses the contract Type
Swap or SwapPerpetual.

For details on defining a futures contract, see "Defining Future Contracts" in Setup Requirements for Futures in
Calypso Asset Classes documentation.

Basic Steps for Capturing a Future Swap Trade
• Make sure a contract has been defined.

• Specify the Exchange, then the Contract, and Contract Date properties in the Pricing
Sheet - this will load information from the contract and populate other related
properties.

• Define other basic properties such as Book and Counterparty.

Key Properties
Exchange - Contract - Contract Date
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Description of Key Properties

Properties Description

Exchange Select the exchange where the contract is listed.

Contract Select the futures contract name.

Contract Date Select a date from those provided by the Date Rules definitions or enter a manual date
schedule. Contract Date is not used for the product FutureSwapPerpetual.

Quantity Enter the number of futures and the Notional will be calculated accordingly. Or enter the
Notional and the Quantity will be calculated accordingly.

Product Type Displays the product type based on the contract.
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Properties Description

Notional Calculates a total value that is equal to Quantity multiplied by Contract Size.

Underlying Displays product, maturity, and leg details of the underlying swap.

Contract Size The face value of the underlying product represented by one future.

13.7 Future Forward Start FX Trades
The Future Forward Start FX strategy (Forward Points on US Dollar Futures, or FRP) involves the trading of the first
available maturity date of US Dollar Contract (basis month) and adding or subtracting a number of points from the FX
spot rate, represented by the Central Bank of Brazil's PTAX rate (the FX rate is released on the same day for
settlement in two business days). At the end of a trading session, forward point transactions are transformed into a
trade in the US Dollar Futures Contract for the basis month. In the Pricing Sheet this generates a "Child" trade (the
underlying DOL Future) and expires the initial "Parent" trade (the FRP product).

The basis month is the first US Dollar Futures Contract month, up to the second business day that precedes the
expiration date, meaning that the contract is valid and can be traded up to 2 business days prior to the contract
expiration date. After that, the basis month will be the second month, which will be the basis month up to the second
business day that precedes the expiration date, and so on.

 Ⓘ [NOTE: The FRP strategy does not create a new future contract. It is only an alternative way to trade the
vanilla US Dollar Futures Contract. All cash transfers will be calculated for the US Dollar Futures Contracts.
There is no daily variation margin payment until the contract becomes a US Dollar Future Contract.]

 Ⓘ [NOTE: Until the actual PTAX fixing, the spot rate is an estimated rate - the estimated spot rate can also be
derived from the Casado.]

13.7 .1 Before You Begin
Certain requirements need to be met, and considerations taken, before you can begin capturing Future Forward Start
FX trades in the Pricing Sheet. This section covers these requirements and considerations.

 Ⓘ [NOTE: In addition to standard Calypso servers, users need to run the Position Keeping Server and the
Liquidation Engine (required for all Futures) before managing these trades.]

Trade Domain Values
» Under the domain "domainName", add the following values:

– FutureForwardStart.subtype

– FutureForwardStart.underlyingType

– FutureForwardStartKeywordsToCopy

 Ⓘ [NOTE: See Parent/Child Trade Keywords below for keyword considerations.
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» Once the new domain "FutureForwardStart.subtype" has been added, add the value "FutureFX" to it.

» Also, add the domain value "UNDO" to the "TradeRejectAction" domain.

For details on working with domain data, see "Defining Domain Data" in the Getting Started documentation.

Parent/Child Trade Keywords
• The linking keyword on the parent Future Forward Start trade is "FutureForwardStartChildTradeId" and is only

populated when the underlying child trade (FutureFX) is created. The parent will also include the keyword
"FutureForwardStartFixingRate".

• The child trade is created when the forward start reset is fixed.

• The keyword on the child trade that links back to the parent Future Forward Start trade is
"FutureForwardStartParentTradeID". The child trade will also have keywords "FutureForwardStartFixingRate" and
"FutureForwardStartParentTradeDate".

• The keywords listed under the domain "FutureForwardStartKeywordsToCopy" will be copied over from the parent
Future Forward Start trade to the new child underlying trade when the future forward start reset is fixed.

Currency Pair Attributes
For the currency pair USD/BRL, make the following settings for currency pair attributes.

• DeriveFromQuote = Casado (The FX Spot FX.USD.BRL quote is derived from the "Casado" front DOL Future.)

• Exchange.ContractName = BMF.DOL

• FutureRolloverSpotDays = 2

 Ⓘ [NOTE: The front FX future contract for any valuation date in month N, except the last 2 business days of
month N, is the future contract for delivery on the 1st business day of month N+1. The front FX future contract
for a valuation date on the last 2 business days of month N, is the future contract for delivery on the 1st
business day of month N+2.]
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For details on working with default currency pairs, see "Defining Currencies and Currency Pairs" in the Getting
Started documentation.

Date Rule Setup for Attributes
» First, add the value FRP_DATE_RULE_FILTER to the "FutureContractAttributes" domain.

» Second, set up a date rule for the attribute added above. In Navigator point to Configuration > Definitions > Date
Schedule Definitions > Date Rules to open the Date Rules window.

For this step, any date rule that adds one business day to the reset date can be used. Also be sure to select a Holiday
calendar. The following example illustrates just one way to set up a date rule that meets the requirement.

Example Date Rule for attribute configuration

For details on setting up date rules, see "Defining Date Rules" in the Getting Started documentation.
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Future Contract Attributes Preconfiguration
» Add the following values to the "FutureContractAttributes" domain:

– DeriveFromCurrentFutureQuote

– IS_NEXT_DAY_CASH_SETTLE

» Add the following values to the "domainName" domain:

– FutureContractAttributes.DeriveFromCurrentFutureQuote

– FutureContractAttributes.IS_NEXT_DAY_CASH_SETTLE

» Once these domains are available, add values "Yes" and "No" to them.

» If the attribute "FutureQuoteMultiplier" doesn't already exist under the domain "FutureContractAttributes", add it
as a value.

For details on working with domain data, see "Defining Domain Data" in the Getting Started documentation.

Pricing Sheet Preconfiguration
» In Pricing Sheet Profiles, add the Future Forward Start FX strategy to the Menu so that it becomes available in the

list of leg strategies.

For details on Configuring Profiles in the Pricing Sheet, see "Configuring Profiles" in Pricing Sheet Setup Guide
documentation.

Rate Index Definition
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Prior configuration of a rate index for a 1-day interbank deposit rate for currency BRL is required.

Example rate index definition

For details on configuring rate indices, see "Defining Rate Indices" in the Getting Started documentation.

Rate Reset Definitions
Following the market conventions for FRP, it is necessary to create two FX Rate Resets. The first (e.g., FRP0) should
have the "Reset Days" parameter set as 0 (zero) and the second (e.g., FRP1) should have the parameter set as 1.

For details on configuring FX rate resets, see "Defining FX Rate Fixings" in the Getting Started documentation.

13.7 .2 Def in ing Future Contracts
Defining the future contract in Calypso creates the US Dollar Future Contract for the Future Forward Start FX strategy.
For detailed information needed to define the contract, refer to specifications provided by the exchange.

To open the Future Contract from Calypso Navigator, point to Configuration > Listed Derivatives > Future Contracts.

For further details on defining the future contract, see "Defining Future Contracts" in the Futures and Future Options
Trading documentation.
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Details Tab

Properties Description

Exchange Select the legal entity configured for the exchange. ("BMF" in the example above)

Currency Select "BRL" for the currency.

Name Enter a unique name for the future contract.

Type Select "FX".

Quote Type Select "Price".

Attributes » To open contract attributes, click Select and then in the Value column. The Attributes
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Properties Description

window opens.

» Make settings for the following attributes.

– DeriveFromCurrentFutureQuote: When "Yes", the rollover quote is created over
this future.

– FutureQuoteMultiplier: Enter the value 1000. The value entered in this field allows
the system to accommodate quotes expressed in one format so that they can be
interpreted and used in another. For example, if live market data provides a quote
in the format 3,620 and the attribute is set to 1000, the system can convert this to
3.620 so that it can be used in functions such as curve generation without causing
calculation errors.

– IS_NEXT_DAY_CASH_SETTLE: When "Yes", cash is settled on the following
business day. Applicable for Brazilian futures. (Determined by BM&F rules and
regulations, positions outstanding at the end of each session are settled
according to the day's settlement price.)

– FRP_DATE_RULE_FILTER: Add the Date Rule that was created in Date Rule Setup
for Attributes section above.

 Ⓘ [NOTE: You can add new attributes directly from the Attributes window by
selecting Domain Setup at the top. However, for those attributes that require lower level
values (such as "Yes" or "No"), you will need to add new attributes as described in the
Future Contract Attributes Preconfiguration section above.]

Future Name Month Select "Expiry Date".

Tick Type Select "Fixed".

Date Format Select "Monthly".

Expiration Date Sched-
ule

Enter "@Begin of Month" for the date rule.

Last Trade Date Sched-
ule

Enter "@Begin of Month" for the date rule.

First Delivery Date
Schedule

Enter "@Begin of Month" for the date rule.
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Underlying Tab

Properties Description

Curr Pair Select "USD/BRL".

Product Select "FX/USD/BRL" for the product.

Underlying Currency Select "BRL".

Index Select the rate index previously configured for a 1-day interbank deposit rate for currency
BRL.

Tenor Select "1D" for the tenor.

Holidays Select "SPO" for the holiday schedule.

13.7 .3 Captur ing Future Forward Start FX Trades
This section covers the key properties that need to be entered to capture a trade.

Basic Steps for Capturing a Future Forward Start FX Trade
• Make sure a future contract has been defined.

• Specify the Ccy Pair, Exchange, Contract, Contract Date, and Reset Source properties
in the Pricing Sheet - this will load information from the contract and populate other
related properties.

• Select an option for Buy/Sell and specify the Quantity of the trade.

• Define other basic properties such as Book, Counterparty, Broker, etc.

Key Properties
Ccy Pair - Exchange - Contract - Contract Date - Buy/Sell - Quantity - Reset Source
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"Product: Style" Properties

Properties Description

Exchange Select the exchange where the trade is listed.

Contract Select the underlying futures contract.

Contract Date Select the underlying futures contract date from the list. These are generated from the
contract.

Ccy Pair Enter USD/BRL.
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Properties Description

Buy/Sell Select the direction of the trade: Buy or Sell.

Quantity Enter the number of future contracts to be traded.

Contract Size Automatically populated and based on information defined in the underlying future contact.

Notional Calculated automatically from contract size and quantity. (contract size * quantity =
notional)

Notional Ccy Automatically populated as USD.

"Product: Rate" Properties

Properties Description

Reset Source Select the reset source for fixing.

You can also configure a custom strategy to have a default reset source populated when
opening a new strategy.

For details on customizing strategies, see "Building Custom Strategies" in Pricing Sheet
Setup Guide documentation.

FX Reset Rate Displays the reset rate from the FX Quote window. Typically, this is the last reset value.

"Date" Properties

Properties Description

Reset Effective Date This date is based on the selected reset source and is populated automatically.

"Market Data" Properties

Properties Description

Points Enter the number of points being traded.

FX Spot Automatically populated with the market spot rate from the Market Data panel. It can be
manually overridden.

FX Fwd Automatically populated with the calculated outright forward rate based on the spot and
interest rates for each currency in the pair.

Ccy 1 Rate

Ccy 2 Rate

Automatically populated with the respective currency's interest rate derived from the spe-
cified curve.

"Keyword" Properties
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Properties Description

@Strategy Identifies whether the trade is to be used for hedging.

13.8 Brazi l ian FRC Trades
Prior to capturing Brazilian DDI Futures trades, you need to specify Future contracts from the Calypso Navigator using
Configuration > Listed Derivatives > Future Contracts and generate the Future products. The DDI Future can be
traded as a standard future trade or as an FRC trade.

An FRC future is a future with two legs.

Properties
Product: Info = Exchange, Contract, Contract Date - Product: Price = Strike, Notional

» Select an exchange, a contract, a contract date , and a strike to select a Future Option product.

"Product: Style" Properties

Properties Description

Product Type Displays the product type based on the FRC strategy.

Ccy Pair Displays the currency pair of the contract.

Notional Displays the notional based on the quantity.

Notional Ccy Select the currency of the notional.

Settle Ccy Select the settlement currency.

Buy/Sell Select the direction of the trade: Buy or Sell.

Expiry Date Displays the expiration date from the future contract

Delivery Date Displays the delivery date from the future contract.

Settle Type Displays the settlement type of the contract: Cash or Physical.

Strike Enter the strike.

Contract ID Type

Contract ID

You can select a security code of the Future product, and the corresponding value will be
displayed in the Contract ID field.

Exchange Select the Exchange where the contract is quoted.

Contract Size Displays the contract size.

Quantity Enter the traded quantity.

Contract Select the contract.

Contract Date Select the expiration date.
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Properties Description

Once you have entered a trade, you can type the following shortcuts into the Contract Date
to duplicate the trade for additional contracts.

• +ny - For example "+2y" - To add trades for all available contracts over the next n years.

• +nyq - For example "+2yq" - To add trades for all quarterly contracts over the next n
years.

• +nq - For example "+2q" - To add trades for the next n quarterly contracts.

• +ns - For example "+2s" - To add trades for the next n contracts.

13.9 Generic Future and Generic Option
Select the strategy Future or Option for ETD Clearing.

Please refer to the Calypso ETD Clearing Installation and Setup Guide for complete setup details.

Properties
Exchange - Contract - Contract Date - Strike - Quantity - Buy/Sell - Put/Call - Product ID Type - Product ID

» Select an exchange, a contract, a contract date , and a strike to select a product.

» You can also select a Product ID Type, and enter a Product ID to select the corresponding product.
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14. Capturing Structured Product Trades
To book Structured Product Trades in pricing sheet, you need to create strategy using Strategy Builder. While
creating strategy, you need to tick ‘Save as Structured Product’ option to create multilegged strategy to save as a
single trade id. If the strategy is saved as Structured Product, it will create single trade. Currently only Equity Options
are supported as sub type of structured product in pricing sheet.

For Structured Product trades on Pricing Sheet, when detailed data is checked for saved trade then leg wise pricer
measure value will be populated. if it's unchecked then consolidated value of all legs will be populated in last leg of
Structured Product on Pricing Sheet.

Strategy created for booking Structured Product Trade:

Sample trade saved as structured product is shown below:
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15. Solving
The pricing sheet offers two types of solving capabilities:

• Solving shortcuts

• Advanced solving

15.1 Solving Shortcuts
Solving shortcuts are available for the Strike field, to solve for strike in order to obtain at-the-money trades, or a target
delta.

A shortcut can be applied to a single trade, to a set of selected trades in a strategy, or to all the trades in a strategy.

15.1 .1 S ing le Trade Shortcuts

On a single trade, you can enter any of the following in the Strike field, then click .

• atm or atmf: To solve for an at the money forward trade.

• atms: To solve for an at the money spot trade.

• #d: To solve for target delta (25d, 10d, 0d, etc.).

• #% itmf: To solve for a percentage of the in-the-money forward (102% itmf).

Scenario 1 - Single Trade - Solve for Strike to get 25% Delta
Enter "25d" in the Strike field, then click .
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Scenario 1 - Solving Shortcut (Single trade - Solve for strike with target 25% Delta)

The strike shortcut is stored in the property "Solve Strike Shortcut".

15.1 .2 Out-of-the-box Strateg ies Shortcuts

For out-of-the-box strategies, the following solving shortcuts are predefined. Enter the strike, then click .

Strategy Strike Expected Results
Straddle “0d” or “atm” Vanilla

Buy

PUT

S

Vanilla

Buy

CALL

S

Strangle “25d” or "#d"

(# can be any number)

Vanilla

Buy

PUT

S1 (-25d)

Vanilla

Buy

CALL

S2 (25d)

Butterfly “25d” or "#d"

(# can be any number)

Vanilla

Buy

PUT

S1 (-25d)

Vanilla

Buy

CALL

S2 (25d)

Vanilla

Buy

PUT

S3 (atm)

Vanilla

Buy

CALL

S3 (atm)

Risk reversal (collar) “25d” or "#d"

(# can be any number)

Vanilla

Buy

PUT

S1 (-25d)

Vanilla

Sell

CALL

S2 (-25d)

Scenario 2- Out-of-the-box Strategy - Solve for Strike to get 0% Delta over Strategy
Enter "0d" in the Strike field of the first trade, then click .

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



Scenario 2 - Solving Shortcut (Out-of-the-box Strategy- Solve for strike with target 0% Delta)

DELTA_PCT is null over the strategy.

15.1 .3 Mul t ip le Trades Shortcuts
Now, if you have multiple trades in a strategy, you can still apply a solving shortcut to a single trade, or to a set of
selected trades, or to all the trades at once.

To do so, select a set of trades, enter any of the following in the Totals column of the Strike field.

• atm or atmf: To solve for an at the money forward trade.

• atms: To solve for an at the money spot trade.

• #d: To solve for delta (25d, 10d, 0d, etc.).

• #% itmf: To solve for a percentage of the in-the-money forward (102% itmf).

Scenario 3 - Multiple Trades - Solve for at-the-money Forward
Enter "atm" in the Totals column of the Strike field, then click .
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Scenario 3 - Solving Shortcut (Multiple trades- Solve for at-the-money forward)

15.2 Advanced Solving
To enable the advanced solving capability, set the Solve property to "Solve".

Advanced solving can be applied to a single trade, to selected trades in Solve mode in a strategy, or to all trades in
Solve mode in a strategy.

All the properties you can solve for are outlined in orange.

 Ⓘ [NOTE: In case you have trades with different types of strategies, only the common properties will be
available for solving. For example, if you have a Vanilla trade and a Barrier trade, you will not be able to solve for
Barrier for the whole strategy, whereas if you only have Barrier trades, you will be able to solve for Barrier]

The pricer measures can be set as targets.

Pricing sheet (Solve mode)

 Ⓘ [NOTE: Even though the Customer Premium is not outlined in orange, it is possible to solve for a target
customer premium - You can select the Target "Customer Premium" in the Solver window]

Nasdaq Calypso
Pricing Sheet User Guide / Version 18



» Price the trades before getting started.

15.2 .1 Advanced Solv ing - Sing le Trade
Double-click the property you want to solve for, Strike in this example. The background turns orange.

Pricing sheet (Solve mode - Select property to solve for)

Then double-click the pricer measure that you want to set as target, DELTA_PCT in this example. The solving
information is displayed in the Solver window.

Pricing sheet (Solve)

» Enter the Target Value, and click Solve.

You can also enter the target value directly in the pricer measure, and it sets the Target Value in the Solver
window.

A solution is computed and displayed - The Solver window shows the solved value (Strike in this example), and
the new pricer measure computed with the solved value (DELTA_PCT in this example).

At this point, you can:

– Try another solution by changing the target value and clicking Solve again.

– Tune the solver parameters: Upper Boundary and Lower Boundary.

– Exit the solver without any change if none of the solutions are satisfying.

– Apply the solution to the trade.
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Pricing sheet (Solving results)

» To apply the solution to the trade, click Apply.

The solved properties are updated accordingly.

Pricing sheet (Apply solving)

Solving details are stored in the solving properties:

You can also click Show Trials to view the solver trials.
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Pricing sheet (Solve - Trials details)

» You can right-click the graph and a popup menu appears with a number of options, including the ability to zoom in
and out on the various axes.

Scenario 4 - Solve for Barrier with Target DELTA
Double-click the Barrier property to solve for barrier, and select the DELTA pricer measure.
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Scenario 4 - Solve for Barrier with Target DELTA

» Enter the target DELTA in "Target Value", and click Solve.

The solving results are displayed. You can exit without any change, or apply the results to the trades.

» Then click Apply.

Scenario 4 - Solving results

15.2 .2 Advanced Solv ing - Mult ip le Trades
You can select a set of trades, or solve all the trades in solving mode. Make sure to price the trades.

Double-click the property you want to solve for, Strike in this example. The background turns orange.
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Pricing Sheet (Solve mode - Multiple trades - Select property to solve for)

Then, select the Totals column of the pricer measure that you want to set as target, PV in this example.

Pricing Sheet (Solve)

» Enter the target value (0 for example), and click Solve.

A solution is computed and displayed - The Solver dialog shows the solved value (Strike in this example), and the
new pricer measure computed with the solved value (PV in this example).

At this point, you can:

– Try another solution by changing the target value and clicking Solve again.

– Exit the solver without any change if none of the solutions are satisfying.

– Apply the solution to the trade.

Pricing sheet (Solving results)

» To apply the solution to the trades, click Apply.
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The solved properties are updated accordingly.

Pricing sheet (Apply solving results)

When solving for multiple trades, you can select the distribution method over the trades:

Pricing sheet (Solve - Distribution)

• "Don't use Distribution" - Default selection - The solver will find the solution common to all selected trades that
gives the target value - The same solved value is applied to all trades.

• For the other distribution methods, the targeted value is split by trade according to the selected method, then the
solving process is applied trade by trade to determine the solution that will make the target pricer measure equal
to the split amount.

– "Divide evenly" - The target value is divided by the number of selected trades (target value / number of
trades).

– "Weight by Notional" - The target value is proportional to the notional of the trade with respect to the total
notional amount of the selected trades (target value * trade notional / total notional).

– "Weight by Factor (%)" - You will be prompted to enter a factor for each leg - The target value is proportional
to the user-defined factors (target value * factor %).

– "Weight by Expiry" - The target value is proportional to the number of days to expiration of the trade with
respect to the total number of days to expiration of the selected trades (target value * trade number of days
to expiration / total number of days to expiration).

– "Strategy" - The target value is applied to each selected strategy. For example, you have selected 2
straddles (4 trades) - The target value is applied to each straddle independently.
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 Ⓘ [NOTE: It does not make sense to select a distribution method for a null target value]

Scenario 5 - Multiple Trades - Solve for Strike to get 0% DELTA
Double-click the Strike property to solve for strike, and select the Totals column for the DELTA pricer measure.

Scenario 5 - Solve for 0% DELTA

» Enter the target delta in "Target Value", and click Solve.

The solving results are displayed. You can exit without any change, or apply the results to the trades.

» Then click Apply.

Scenario 5 - Solving results

Scenario 6 - Multiple Trades - Solve for Strike to get 0 PV with Notional Distribution
In this scenario, the trader wants to solve for strike to obtain a 0 PV weighted by notional.

Double-click the Strike field to solve for strike, and select the Totals column for the PV pricer measure.
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Scenario 6 - Solve for 0 PV

» Enter the target PV in "Target Value", and click Solve.

The solving results are displayed. You can exit without any change, or apply the results to the trades.

» Then click Apply.

Scenario 6 - Solving results

The PV of the trade in Price mode has not changed, and is distributed by notional over the trades in Solve mode.

Scenario 7 - Multiple Trades - Solve for Target Customer Premium with Constant Sales Premium
In this scenario, the trader wants to obtain a target customer premium by keeping the sales premium constant.

Double-click the Strike field to solve for strike, and select the target Total Customer Premium in the Solver window.
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Scenario 7 - Solve for target premium

» Select the distribution method as needed.

» Enter the target premium in "Target Value", and click Solve.

The solving results are displayed. You can exit without any change, or apply the results to the trades.

» Then click Apply.

Scenario 7 - Solving results

Scenario 8 - Multiple Trades - Solving with Linked Properties
In this example, Strike (second trade) = Strike (first trade) + 5 pips.

Scenario 8 - Linked strikes
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Please refer to "Strategy Attributes" in Calypso Building Custom Strategies documentation for details on defining
property links.

Now, the user want to solve for Strike to get a 0 PV on the whole strategy.

In this case, since the second trade is linked to the first trade, you only need to set the first trade in Solve mode.

Scenario 8 - Solve with Linked Properties

» Enter the target PV in "Target Value", and click Solve.

» Then click Apply.

Scenario 8 - Solving results - Strike (second trade) = Strike (first trade) + 5 pips
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