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1. Fees, Haircuts, and Sales Margins
Overview
The Calypso system allows computing various types of fees, haircuts, and sales margins:

• Contract fees - Contract fees are associated with trades upon trade capture - They are also referred to as Trade
fees - They can be manually entered, or automatically generated.

Contract fees require a fee type definition configured from the Calypso Navigator using Configuration > Fees,
Haircuts, & Margin Calls > Fee Definition.

See Defining Fees for details.

See Defining Automatic Contract Fees for details on generating automatic fees.

See Capturing Fees for details on entering fees manually.

• Invoice fees - Invoice fees can be generated on trades, transfers, messages and accounts on a periodic basis -
They are also referred to as Billing fees.

See Defining Invoice Fees for details on generating invoice fees.

• Withholding Tax fees - Withholding tax fees are automatically generated on interest cashflows.

See Defining Withholding Tax Fees for details.

• Haircut fees - Haircut fees are computed based on haircut rules for Collateral management and repo-based
trades.

See Defining Haircut Rules for details.

The actual haircut fee capture is described in Calypso Collateral Management documentation, and Calypso
Security Finance documentation.

• Sales Margins - Sales margins are associated with trades in the Pricing Sheet and the FX Deal Station, based on
Sales Margins Configurations - They can also be set at trade capture.

See Defining Sales Margins for details.

Viewing Fees
• Contract (trade) fees can be viewed in the Fee Report.

See Trade Fees Report for details.

• Invoice (billing) fees can be viewed in the Billing Report.

See Billing Fees Report for details.

• Contract fees and invoice fees can be viewed in the Consolidated Fee Report.

See Consolidated Fees Report for details.
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2. Defining Fees
The Fee Definition window allows defining fee types. Fee types can be selected in trades and be associated with fee
amounts. Fee amounts can be calculated automatically according to a fee grid, or can be entered at the time of the
trade.

Open the Fee Definition window from the Calypso Navigator using Configuration > Fees, Haircuts, & Margin Calls >
Fee Definition (menu action trading.FeeDefinitionWindow).

When you open the Fee Definition window, all existing fee types are loaded by default.

2.1 Creating a Fee Type
» Click New to create a new fee type, and enter a type in the Type field. Then enter information into the fields as

applicable. The fields are described below.

» Click Save to save your changes.

Nasdaq Calypso
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Fields Details

Fields Description
Type Enter the type of the fee, for example, COMMISSION, BROKERAGE, etc.

It will identify the fee throughout the system.

Role Select the role of the receiver/payer of the fee.

PnL Category Click ... to select the P&L bucket to which the fee will be added in the Official P&L report.

The possible values are:

• MTM, Accrual, Accretion, MV, Other - The fee will be added to the corresponding P&L
bucket in the Official P&L report.

• ExcludePnL - The fee is not included in the Official P&L report.

If one of these P&L buckets is not available for selection, it indicates that the corresponding
domain is not available. The values come from the domains in the form "<P&L
bucket>FeeType".

A fee should have only one PnL category.

Include If the Pricing checkbox is checked, the corresponding fee amount will be included in the
pricing of the trade, provided the pricing parameter INCLUDE_FEES is set to true.

If Pricing is unchecked, the corresponding fee amount will not be included in the pricing of
the trade, regardless of the value of the pricing parameter INCLUDE_FEES.

Comments Enter a free form fee description.

Fee Offset By default, Fee Date = Trade Date + Spot Days (from Fee currency).

However, you can enter a number of days lag to compute the fee date. By default, the days
are business days. You can double-click the Bus label to change to Cal as needed. Business
days are computed using the product’s holiday calendar.

In case a fee offset is defined, Fee Date = Trade Date + Spot Days (from Fee currency) + Fee
Offset.

Assigning different lags to different products with the same fee type can be done through
the Fee Grid, provided the fee definition uses the FeeGrid calculator.

See Defining Automatic Contract Fees for details.

Products Click ... to select the product types to which this fee applies, or ALL.

Default Calculator Select the calculation method of the fee. The following methods are provided out-of-the-
box:

• NONE - The fee amount is manually entered in the trade.

• Actualize, ActualizeAlternate, ActualizeComplete, ActualizeLinear, Linear - Not
supported.

• AnnualPercentage - The fee amount is nominal * (fee percentage * daycount/365). The
fee percentage is entered in the trade.
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Fields Description
• BaseQuoting - Only applies to FX Option trades. The fee amount is the quoting currency

amount * fee bps, expressed in Base currency. The fee bps is entered in the trade.

• BPNominalRepo - Only applies to Repo trades. The fee amount is ((basis points * repo
nominal)/10,000) * (repo duration / daycount). The basis points are entered in the trade.
The repo duration is the number of calendar days between the start and end dates.

• BPPrincipalRepo - Only applies to Repo trades. The fee amount is ((basis points * repo
principal)/10,000) * (repo duration / daycount). The basis points are entered in the trade.
The repo duration is the number of calendar days between the start and end dates.

• Brokerage - Used to compute broker fees. Refer to Calypso FX documentation for
details.

• CFD - Only applies to CFD trades. The fee amount is calculated using the CFD financial
grid and country grid. Refer to Calypso CFD documentation for details.

• Commodity - Only applies to Commodity trades. Refer to Calypso Commodities
documentation for details.

• CustomerTransfer - Only applies to Customer Transfer trades. This is the base method
for calculating REMITTANCE, CABLE, CORRESPONDANCE, and LIFTING fees.

• EquityLinkedSwapPercentage - To be used for Equity Linked Swaps instead of
Percentage when the settlement currency is different from the underlying currency. The
fee is in settlement currency.

• FeeConfig - The fee amount is calculated based on a fee configuration (fee
configurations are defined from the Calypso Navigator using Configuration > Fees,
Haircuts, & Margin Calls > Fee Set Up, Fee Config panel). Fee configurations allow
defining fee schedules. It is used in the context of automatic fees and invoice fees.

See Defining Contract Fee Schedules for details on defining fee schedules for
contract fees.

See Defining Invoice Fee Schedules for details on defining fee schedules for invoice
fees.

• FeeGrid – The fee amount is calculated based on a fee grid (fee grids are defined from
the Calypso Navigator using Configuration > Fees, Haircuts, & Margin Calls > Fee Set
Up, Fee Grid panel).

See Defining Automatic Contract Fees for details.

• FeePercentage – The fee amount is related fee amount * percentage. This is used to
calculate fees on fees.

For example, you want to calculate FEEB as a percentage of FEEA - Define FEEB with
the FeeGrid calculator. In the fee grid, select the FeePercentage calculator, and set the
attribute RELATED_FEE to FEEA.

[NOTE: RELATED_FEE can contain a comma-separated list of fee types]

Nasdaq Calypso
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Fields Description
• ISDARisklessAccrual, ISDARiskyAccrual - Not supported.

• MarginPts* - All MarginPts fees apply to sales margins.

See Defining Sales Margins for details.

• NoticeWithdrawalPenalty - Used for Customer Transfer penalty fee. Refer to Calypso
Client Custody documentation for details.

• PctBase - Only applies to FX Option trades. The fee amount is base currency amount *
fee percentage, expressed in base currency. The fee percentage is entered in the trade.

• PctQuoting - Only applies to FX Option trades. The fee amount is quoting currency
amount * fee percentage, expressed in quoting currency. The fee percentage is entered
in the trade.

• Percentage - The fee amount is nominal * fee percentage. The fee percentage is
entered in the trade.

• PhysicalSettlementPct - To be used for Commodities instead of SettlementPct to set the
fee date to the Physical Settle Date.

• PortfolioSwapCommission - Used internally by Portfolio Swap trades to compute upfront
commissions based on the rates specified in the Portfolio Swap Contracts.

• PrincipalPct - Same as Percentage for repos but takes into account principal changes.

• Quantity - The fee amount is trade quantity * fee unit. The fee unit is entered in the
trade.

• QuotingBase - Only applies to FX Option trades. The fee amount is base currency
amount * fee bps, expressed in quoting currency. The fee bps is entered in the trade.

• SettlementPct - The fee amount is settlement amount * fee percentage. The fee
percentage is entered in the trade.

• TransferSettleDate - Sets the fee settlement date to Booking Date + Settle Lag.

You can create custom fee calculators and register them in the feeCalculator domain. Refer
to the Calypso Developer’s Guide for details.

Preferences Check or clear the following checkboxes as needed.

Accounting
If checked, the corresponding fee amount will generate an accounting event, provided
accounting generation is enabled on your system.

In addition, in the accounting configuration, you should have the following:

• The accounting event type for the fee should be the same as the fee type. For example,
if you have a fee definition named PREMIUM, you should have an accounting event type
named PREMIUM as well.

You can also configure the following accounting event types:
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Fields Description
– <FEE TYPE> - To book the fee amount with an Effective Date equal to the Fee

Date. It will not be generated if the Fee is after a Termination Date or if the Fee has
already been settled when coming from a Partial Termination or Novation (if the
Fee has been propagated and is already settled).

– <FEE TYPE>_AM - To book the accrual fee amount between the start and end
dates.

– <FEE TYPE>_INC - To book the fee amount with an Effective Date equal to the
Trade Date or to the Transfer Trade Date.

– <FEE TYPE>_ACCRUAL_YIELD - To book the accrual fee amount calculated using
constant yield.

– <FEE TYPE>_ACCRUAL_SETTLE - To book the accrual fee amount between the
settlement date and the end date.

– <FEE TYPE>_ACCRUALREC - To book the Accrued Fee Amount on the Maturity
Date / Termination Date.

– <FEE TYPE>_PREMDISC_YIELD - To book the amortized fee amount based on a
constant yield between the start and end dates.

If the fee calculator is FeeABSContractualYield. If the Input is 0, set keyword.YIELD
to null. Otherwise take the input and set it in the keyword.YIELD. The scheduled
task FEE_YIELD_COMPUTATION allows computing and updating the Fee Yield.

– <FEE TYPE>_REAL - To book the fee amount on the end date.

– <FEE TYPE>_REC - To book the fee amount on the maturity date, exercise date or
termination date based on the event.

– <FEE TYPE>_START - To book the fee amount with an Effective Date equal to the
Fee Start Date.

– <FEE TYPE>_TA – To book <FEE TYPE> – ACCRUAL_BS on Trade Settle Date. For
example, UPFONT_FEE – ACCRUAL_BS.

– <FEE TYPE>_TERMREC - To book (Fee Amount - Accrued Fee Amount) on the
Maturity Date or Termination Date.

• The “Fee Related Event” checkbox must be checked for these accounting event types.

Allocation
Economic Based Fees can be defined with the Allocation flag. These are fees that are
calculated based on the valuation of the parent trade, such as the premium of an option. This
type of fee would require recalculation if any allocated attribute is changed.

The fee attaches to the parent trade, and when the trade is allocated, the fee is allocated to
the children trades in the same proportions as the parent trade's notional. The fees roll back
up to the parent trade and are re-allocated in the case of an amendment to the parent.

Nasdaq Calypso
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Fields Description

Transfer
If checked, the corresponding fee amount will have its own transfer (generated by the
transfer engine), to represent the payment or receipt of the fee.

Otherwise, the fee amount can be added to the settlement amount (see “Settlement
Amount”).

Therefore, when Transfer is checked, “ Settlement Amount” should be unchecked, otherwise
the fee will be counted twice.

Note: Fees with Transfer unchecked are not represented in Forward Ladder.

Settlement Amount
If checked, the fee amount will be included in the settlement amount, therefore no specific
transfer will be generated for the fee.

Including the fee amount in the settlement amount has many important impacts on the
system:

• The fee will not appear in the cashflows, as it will be part of the settlement amount itself.

• The fee currency must be the same as either the trade currency or the settlement
currency of the trade.

• The trade will be incorporated into the position with a price that includes the fee amount.

Note that currently, only bond, money market, future and equity trades use this checkbox. If
you want to add the fee amount to the settlement amount, without any impact on the
position, you should uncheck "Settlement Amount", and check “Transfer” instead with Trade
Netting for these trades.

Otherwise, the fee amount can have its own transfer (see “Transfer”).

Therefore, when “Settlement Amount” is checked, “Transfer” should be unchecked,
otherwise the fee will be counted twice.

2.2 Defining Fee Propert ies
Double-click a value cell to specify the value of the corresponding property, then press Enter.

To create new properties, click . You will be prompted to enter a property name. They are stored in the domain
"feeDefinitionAttributes".

Fee Dates
You can use the following Fee Definition properties to set the default date per date type: FeeStartDate / FeeEndDate /
FeeDate with the values Trade Date / Settle Date / Maturity Date. When any or all of the FeeDate, FeeStartDate,
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FeeEndDate properties are specified with a trade, settle, or maturity date, the corresponding date property fields will
be automatically populated on the trade's Fee panel when the defined fee type is selected.

 Ⓘ [NOTE: The Pricing Sheet also supports this default date feature in the Trade Fees Details window for fee
types CA_SALES_MARGIN and UPFRONT_FEE.]

Alternate Fee Dates
Alternatively, you can create a domain “FeeDefinition.<fee type>” with:

Value = <date type>

Comment = < default date>

The date type can be: FeeStartDate / FeeEndDate / FeeDate

The default date can be: Trade Date / Settle Date / Maturity Date

The Fee Definition properties have priority over the domain definition. When FeeStartDate, FeeEndDate, FeeDate are
defined as described above, they override the “spot days” logic.

Fee Dates by Product Type
Fee Definition attributes can be defined in the domain “feeDefinitionAttributes” by product type as <fee
date>.<product type or product group>. For example, FeeEndDate.FRA.

The values for the attributes can be defined in the domains “feeDefinitionAttributes.<attribute name>”. For example,
“feeDefinitionAttributes.FeeEndDate.FRA” may contain the following values:

Maturity Date

Settle Date

Trade Date

If a given fee date is defined at the product type level (attribute <fee date>.<product type or product group>), it takes
priority over the fee date defined at the fee type level (attribute <fee date>).

Nasdaq Calypso
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2.3 Defining ETD Propert ies
The ETD panel will appear if ETD Clearing is enabled on your system.

Please refer to Calypso ETD Clearing documentation for details.

2.4 Defining Fee Pricer Measures
The following fee pricer measures can be created from the Calypso Navigator using Configuration > System > Add
Pricer Measure:

• <FEE TYPE> - Fee amount attached to the trade.

• <FEE TYPE>_ACCRUAL_SETTLE - Fee accrual calculated between the settlement date and the end date.

• <FEE TYPE>_ACCRUAL_YIELD - Fee accrual calculated using constant yield.

• <FEE TYPE>_AM - Fee accrual (amortized fee).

• <FEE TYPE>_AM_DC_<DAYCOUNT> - Amortized fee using specified daycount.

• <FEE TYPE>_CASH - Fee P&L.

• <FEE TYPE>_CASH_YIELD - Fee P&L based on yield amortization.

• <FEE TYPE>_NPV - Fee NPV.

• <FEE TYPE>_PREMDISC_YIELD - Fee yield-based amortization.

• <FEE TYPE>_REC - Fee amount on the Termination Trade Date or on the end date of the Fee.

• <FEE TYPE>_REMAIN - <FEE TYPE> - <FEE TYPE>_AM (remaining fee to amortize).

• <FEE TYPE>_REMAIN_DC_<DAYCOUNT> - Remaining fee to amortize using specified daycount.

• <FEE TYPE>_TA – <FEE TYPE> – ACCRUAL_BS on Trade Settle Date. For example, UPFONT_FEE – ACCRUAL_BS.

• <FEE TYPE>_UNREALIZED_JAS - < FEE TYPE >_NPV - <FEE TYPE>_AM

• <FEE TYPE>_EXCLUDED_<all of the above> - Combines all the fees attached to a trade into one pricer measure,
except for <FEE TYPE>.

Example: You have a trade with PREMIUM, COMMISSION, and ADJUST fees. Pricer measure PREMIUM_EXLUDED
will combine COMMISSION and ADJUST fees.

• FEES_ALL_<all of the above> - Combines all the fees attached to a trade into one pricer measure.

You can then use these pricer measures for any trade.

Example:
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The class is tk.pricer.PricerMeasureGenericFee, and the ID should be an ID not already in use.

Yield Based Amortization
<FEE TYPE>_AM is calculated using straight-line amortization by default.

When pricing parameter FEE_AM_DISCOUNT = true, <FEE TYPE>_AM is calculated using yield based amortization
based on trade keyword FeeDiscountRate.

This only applies to fees with fee attribute UseFeeDiscountRate = true.

The trade keyword FeeDiscountRate can be set by the workflow rule SetFeeDiscountRateFromAFR based on the AFR
rate index. You need to define the pricing environment and the rate index quote name in the rule parameters as:

PricingEnv=<pricingenvironment>,RateIndex=<rate index quote name>.

Example:

PricingEnv=default,RateIndex=MM.USD.AFR.1M.ISR

It requires the definition of the AFR rate index with a 1M tenor and ISR source.

If you want to select a different index quote name based on the contract duration, you can define the quote name as:

<contract duration>=<rate index quote name> instead

Example:

PricingEnv=default,0-3Y=MM.USD.AFR.1M.ISR,3-9Y=MM.USD.AFRMD.1M.ISR

It requires the definition of each AFR rate index with a 1M tenor and ISR source.

2.5 Specifying Round Turn Fees
Round turn fees can be setup on Future and Future Option trades. They are computed by the ROUND_TURN_FEES
scheduled task when the trades are liquidated, expired, or exercised.

Refer to Calypso Futures documentation for details.

Nasdaq Calypso
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2.6 Amortiz ing Fees Based on Effective Yield Methodology

2.6.1 Pr icer Measures
Add the following pricer measures from the Calypso Navigator using Configuration > System > Add Pricer Measure.

To calculate the UPFRONT_FEE amortization based on a constant yield, define the additional pricing measure with the
format“<FEE TYPE>_PREMDISC_YIELD” and attach the class name tk.pricer.PricerMeasureGenericFee.

For example, UPFRONT_FEE_PREMDISC_YIELD.

In addition to the pricer measure linked to constant yield amortization, you can also see the ACCRUAL calculated
using the constant yield (UPFRONT_FEE_ACCRUAL_YIELD) and the ACCRUAL calculated between the settle date and
end date (UPFRONT_FEE_ACCRUAL_SETTLE_DATE) using the same logic.

2.6.2 Bond Templates
Define Bond Templates named <ProductType>-Currency in the Bond Definition window.

For money market products, you need to define a “reference” bond template named <product type>-<currency>. For
example, for your Cash trades (product type = CASH) in EUR, you should refer to the Bond Template "cash-eur" as
shown below.

The "reference" bond template is used to store the information to convert yield/price and price type, which are
missing on a money market trade to correctly perform the constant yield based on the contract rate/cashflows and
initial settlement amount.

2.6.3 Pr ic ing Parameters
Set pricing parameters HYBRID_AMORTIZATION and FORECAST_FROM_CURVE:

• HYBRID_AMORTIZATION = true

• FORECAST_FROM_CURVE = false
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2.6.4 Account ing Events
To define the related accounting event, from the Calypso Navigator, navigate to Configuration > Accounting >
Eventsand add the <FEE TYPE>_PREMDISC_YIELD accounting event. For example, UPFRONT_FEE_PREMDISC_
YIELD, and attach the pericer measures UPFRONT_FEE_PREMDISC_YIELD to that event. The Triggering events for
this Accounting Event should be TRADE_VALUATION, CANCELED_TRADE, TERMINATED_TRADE and MATURED_
TRADE.

Note that you can use the same logic to define the related accounting events for UPFRONT_FEE_ACCRUAL_YIELD
and UPFRONT_FEE_ACCRUAL_SETTLE_DATE.

2.7 Modifying a Fee Type
» Select a fee type, and make changes as applicable.

» Then click Save to save your changes.

2.8 Delet ing a Fee Type
» Select a fee type, and click Delete.
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3. Defining Automatic Contract Fees
Fee types associated with the FeeGrid calculator can be automatically generated on a trade if:

Option 1 (Recommended option for clearing fees, when Fees are known at the inception of the trade) - You set the
action on which you want to generate automatic fees using the domain “AutomaticFeesTradeEnricher.TradeAction”.
The default value is NEW.

Option 2 (Recommended option when the fee generation requires trade keywords for example) - The AutomaticFees
rule is set on a workflow transition in the trade workflow, for example PRICING - EXECUTE - PENDING, and PENDING -
AMEND - PENDING for the fee recalculation in case of trade amendment.

The fee amount will be automatically calculated based on the fee grid.

Fee grids are created from the Calypso Navigator using Configuration > Fees, Haircuts, & Margin Calls > Fee Setup
(menu action refdata.FeeSetUpWindow), Fee Grid panel.

By default, you can define fees for the ProcessingOrg role and for the trade counterparty role (CounterParty, or
another role if you change it in the trade). The role must be the same in the Fee Definition and the Fee Grid.

For example, the fee type FEE has a fee definition and a fee grid for the role Agent. The fee will only be calculated if
the role of the trade counterparty is changed to Agent on the trade, and an agent is selected as trade counterparty.

However, you can setup an automatic fee for any role, provided you add a trade keyword of specified role, and
populate the trade keyword on the trade.

In the previous example, you can keep the trade counterparty role as "CounterParty", and add a trade keyword
"Agent" that contains an Agent legal entity. In this case, the corresponding "Agent" fee will be generated.

The product type can be a group of products. From the Calypso Navigator, navigate to Configuration > Product >
Group (menu action refdata.ProductGroupWindow) for information on creating groups of products. Note that the
environment property USE_PRODUCT_GROUP should be set to true in order to allow specifying fee grids by product
group.

3.1 Setup Example
The fee type COMMISSION is defined for the counterparty role with the FeeGrid calculator.

See Defining Fees for details on the Fee Definition window.
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Sample fee type with FeeGrid calculator

The fee grid can be defined as shown below.

Nasdaq Calypso
Fees, Haircuts and Sales Margins / Version 18



Sample fee grid

» The fee will be calculated based on the selected amount and calculator.

See Defining Fees for a description of the various calculators.

Note that the description is mandatory.

By default, the direction of the fee will be “received” by the selected legal entity (“paid” by the processing
organization). To make the fee “paid” by the legal entity (“received” by the processing organization), you need to
enter a negative amount in the fee grid.

» You can click Attributes to set attributes for the fee grid.

See Fee Grid Attributes for details.

» The minimum amount and maximum amount can be specified if:

– The currency selection field (Ccy field) is different from ANY - In that case these amounts will be expressed
in the selected currency.

Nasdaq Calypso
Fees, Haircuts and Sales Margins / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 20 / 114



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 21 / 114

– The currency selection field is set to ANY, and the FeeCurrency attribute is set to a specific currency - In
that case these amounts will be expressed in the FeeCurrency.

If you want to specify a fee schedule instead of a flat fee, or use a more complex calculator, select the FeeConfig
calculator, and configure a fee grid.

See Defining Contract Fee Schedules for details on defining fee schedules for contract fees.

» The fee date defaults to "trade date + spot days (from the fee currency) + fee offset (from the fee definition)".

You can define a date lag and date roll between the trade date and the fee date in the fee grid - It overrides the
setting of the fee definition if any. It can be used in particular in the context of terminations.

In case a lag is specified in the fee grid, Fee Date = Trade Date + Spot Days (from Fee currency) + Lag (from Fee
Grid).

Refer to Calypso Termination documentation for details.

You can also force the fee date by setting the fee grid attribute TRADE_DATE_TYPE - See details below.

You can also use the Fee Definition properties FeeStartDate / FeeEndDate / FeeDate (if set, they override the
"spot days" logic).

» Round turn setup is described in Calypso Futures documentation.

» Withholding tax setup is described under Defining Withholding Tax Fees.

» If the Authorization mode is enabled, an authorized user must approve your entry.

3.2 Fee Grid Attr ibutes
The following attributes can be set out-of-the-box.

AdjustmentRelatedFees
Used in the computation of a trade overall minimum fee.

Let's say you have a trade for which three types of fees are computed (COMMISSION, EXCHANGE_FEE, CLEARING_
FEE) and you want to ensure an overall minimum fee for the trade, taking into account all three fees.

You can select one of the fees as the “main” fee, COMMISSION for example, configure a fee formula that contains the
other fee amounts using the variable RelatedFeesAmount, and set the fees to be taken into account in the fee grid
attribute AdjustmentRelatedFees of the “main” fee.

Example:

The formula for the COMMISSION fee is: Max(3.10*Quantity + RelatedFeesAmount, 3.50*Quantity) –
RelatedFeesAmount

• The commission is 3.10*Quantity

• The overall minimum fee is 3.50*Quantity

• Attribute AdjustmentRelatedFees = EXCHANGE_FEE, CLEARING_FEE

• RelatedFeesAmount is the sum of EXCHANGE_FEE and CLEARING_FEE
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The COMMISSION fee will be adjusted to reflect the overall minimum fee if applicable.

ApplyFeeOffset
Only applies to related fees - See below.

DefaultLegalEntity
Short name of the legal entity that will receive/pay the fee, if different from the trade counterparty. This can be used
to pay/receive a fee to/from a specific legal entity.

FeeCurrency
You can use this attribute to set the fee currency to a specific currency. Otherwise, the fee currency defaults to the
trade currency.

FeeSettleCurrency
You can use this attribute to set the fee settlement currency to a specific currency. Otherwise, the fee settlement
currency defaults to the fee currency.

In this case, you can also set the following attributes:

• FeeSettleCurrrency.PrincingEnv or FeeSettleCurrency.FXRateName

FeeSettleCurrrency.PrincingEnv – Pricing environment to retrieve the FX quote. The User Defaults pricing
environment is used if not set.

FeeSettleCurrency.FXRateName – FX Reset used to retrieve the FX quote. If empty FX.<original ccy>.<fee settle
ccy> is used.

• FeeSettleCurrency.FixingDate = TradeDate or FeeDate - It allows defining the fixing date used to retrieve the FX
quote. If empty, FeeDate is used.

FEE_PAYREC
Only applies to related fees - See below.

RELATED_FEE
This is used to compute fees on fees using the FeePercentage calculator.

Say you want to calculate FEEB as a percentage of FEEA - Define FEEB with the FeeGrid calculator. In the fee grid,
select the FeePercentage calculator, and set the attribute RELATED_FEE=FEEA.

 Ⓘ [NOTE: RELATED_FEE can contain a comma-separated list of fee types]
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You can also generate the fee on fee based on the direction of the related fee by setting the fee grid attribute FEE_
PAYREC to REC or PAY (on the fee on fee, FEEB in this example). Otherwise, the fee is generated for each related fee.

In order to apply the Lag Days of the Fee Definition to the fee on fee, you need to set the fee grid attribute
ApplyFeeOffset = true (on the fee on fee, FEEB in this example).

You can use the fee grid attribute RelatedFeeCheckRole to control the legal entity to be used by the fee on fee.

• When true (default value), the fee on fee uses the role of its definition. The legal entity is taken from the trade
keyword of selected role.

• When false, the fee on fee is generated on the same legal entity and role as the related fee.

RelatedFeeCheckRole
Only applies to related fees - See above.

TRADE_DATE_TYPE
You can use this attribute to force the fee date:

• TRADE_DATE_TYPE = CLEARED DATE: The system sets the fee date to the date stored in the trade keyword
CCPClearedDate.

• TRADE_DATE_TYPE = TRADE DATE: The system sets the fee date to the trade date.

• TRADE_DATE_TYPE = ALTERNATE DATE: The system sets the fee date to the trade’s alternate date for FX trades.

• TRADE_DATE_TYPE = DATE RULE: The fee date is set using the Date Rule defined in the attribute DateRuleName.

DateRuleName
Date Rule used to set the fee date when attribute TRADE_DATE_TYPE = DATE RULE.

WHT_USE_CALCULATOR
If set to true, the calculator specified on the Fee grid must be used to compute the withholding task, instead of the
hard-coded calculator.

This fee calculator must implement the interface com.calypso.tk.bo.WHTFeeCalculator.

A specific fee calculator has been implemented to handle rounding conventions different than the Ccy decimals.

See Defining Withholding Tax Fees for details.

ZeroAmount
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The fee grid attribute ZeroAmount should be set to false to prevent the generation of fees with a 0 amount. If true, the
system will generate a fee with a 0 amount if a valid fee grid exists.
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4. Defining Contract Fee Schedules
The Fee Set Up window allows defining fee schedules for the FeeConfig calculator in the context of automatic
contract fees. When the FeeConfig calculator is set on the Fee Grid, the fee schedule defined in the Fee Config panel
is used to compute the fee.

4.1 Fee Schedule Definit ion
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Setup (menu action
refdata.FeeSetUpWindow) to open the Fee Set Up window, Fee Config panel.

Sample contract fee schedule

In this example, if the trade notional is below 1,000,000, the fee rate is 1.2% - If the notional is 1,000,000 or above (and
below 10,000,000), the fee rate is 0.8%.

» Enter a configuration name and set the fee parameters as needed. They are described below.

» Then click Add to add an entry to the fee schedule. It brings up the Formula Definition dialog. It is described
below.

» Click to save the configuration. The configuration will be used when the FeeConfig calculator is set on a Fee
Grid, based on the selected filters.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

You can also click to bring up the Browse panel for loading existing configurations.
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References
These parameters are used to specify the fee.

Fields Description
Config ID ID of the configuration given by the system upon saving.

Name Enter a configuration name.

Config Type Select "Trade Fee" to generate contract fees.

Rule Type Select the reference amount unit:

• Avg Price (unit amount).

• Volume (trade amount).

Scale By Select the reference amount of the fee schedule:

• For Avg Price, you can select Price.

• For Volume, you can select Quantity, MarketValue (Trade Quantity * Trade Price), Notional,
Premium, or MADVQuantity (Monthly Average Daily Volume).

The fee rate used to compute the fee at trade capture depends on the trade's price / quantity / notional
/ premium. A fixed rebate may be applied at the end of the billing period to adjust the fee as needed.

See Contract Rebate Process for details.

Range by
Tenor

Check to set the fee range by tenor, or clear to set the fee range by number of days.

Range by
ResidualMat

Check to set the fee range by residual maturity, or clear to set the fee range by product maturity.

Tiered Check to indicate that the reference amount is distributed over the range, rather than applied to the
absolute range.

For example, you have the following range:

• 0 to 1,000 - Fee rate is 10%

• 1,000 to 5,000 - Fee rate is 5%

• 5,000 and up - Fee rate is 2%

The reference amount is 7,000.

• For the non-tiered method, the fee rate is 2% (5,000 and up range).

• For the tiered method, the fee rate is 10% for the first 1,000 - Then 5% for the next 4,000 - Then 2%
for the remaining 2,000.

Event Type Select Trade.

The fee is computed on trade events.

Fee
Currency

You can select a fee currency, or leave empty for ANY.
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Fields Description
Day Count Select a daycount as needed.

Effective
From

Enter the effective start date of the configuration.

Effective To Enter the effective end date of the configuration (optional).

Description Enter a free form description as needed.

Rebate
Check the Rebate checkbox to compute a fixed rebate on the contract fees, or a global rebate amount over a group of
trades.

See Contract Rebate Process for details.

Fields Description
Rebate Type Select Fixed for a fixed rebate, or Default for a global rebate amount over a group of trades.

Rebate % For the Fixed rebate type, enter the rebate percentage.

Rebate Period For the Default rebate type, select the rebate period:

Trade - The rebate is computed at the end of the trade.

Daily - The rebate is computed daily.

Filtering
These parameters are used to determine the conditions of application of the fee. You can use pre-defined filtering
criteria, or a filter template.

Pre-defined criteria:
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Fields Description
Processing
Org

Select a processing organization as needed, or ALL.

Legal Entity Select a legal entity of specified role, or ALL.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Exchange Select one or multiple exchanges (legal entity of role MarketPlace), or leave empty for ALL.

Product Type Select one or multiple product types, or leave empty for ALL.
Product groups are identified as "G. <group name>" and are created using Configuration > Product >
Group.

Security ID Enter one or multiple product IDs (separated by commas), or leave empty for ALL.

Book Select one or multiple books, or leave empty for ALL.

Book Attr Select one or multiple book attribute / attribute value, or leave empty for ALL.

Currency Select one or multiple currencies, or leave empty for ALL.

Account ID Only applies to account management fees.

Fee Date Only applies to account management fees.

SD Filter Select a static data filter as needed, or leave empty.

Attributes Click to add attribute criteria as needed.

Filter template:
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» To add a new filter template, choose > Filter category > Add. You will be prompted to enter a filter category
name. Enter a name and click OK.

» Then choose > Filter fields template. You will be prompted to select a filter category previously created, and
to select the filter criteria you want to use.

Fields Description
Filter Category Select a filter template previously created.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Filter Template Criteria Select the values for the filter criteria defined in the filter template.

In this example, the filter template contains the filter criteria Book and Strategy attribute.

Formula Definition
Click Add to bring up the Formula Definition dialog.
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Sample formula

» Enter the parameters to define the ranges of the fee schedule. They are described below.

» You can type in the formula, or double-click variables and operators to add them to the formula. Only the
displayed variables and operators can be used in the formula.

» Click OK when you are done.

Fields Description
Min
Amount

Max
Amount

Enter the minimum and maximum amounts of the range. It refers to the reference amount defined by the
Rule Type and Scale By parameters: Quantity, Notional, or Price.

No value is considered as 0 for the minimum amount, and infinite for the maximum amount.

The minimum amount is inclusive.

The maximum amount is non inclusive.

Nasdaq Calypso
Fees, Haircuts and Sales Margins / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 30 / 114



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 31 / 114

Fields Description
Min Tenor

Max Tenor

Min Days

Max Days

You can also select a minimum tenor and a maximum tenor to scale the fee rates by product maturity
("Range by ResidualMat" is not checked), or by residual maturity ("Range by ResidualMat" is checked).

 Ⓘ [NOTE: For products without maturity date, the fee rates are scaled by settlement date
instead]

The minimum tenor is non-inclusive.

The maximum tenor is inclusive.

When the "End Date" falls on a non-business day, its is rolled to the following business day. So in this
situation the minimum tenor becomes inclusive and the maximum tenor becomes non-inclusive.

If "Range by Tenor" is not checked, you can enter a number of days instead of selecting a tenor.

Calc Unit Enter a calculation unit when defining a fee expressed as an amount per unit.

For example 2 per million of notional: Calc Unit = 1000000 and Formula = 2*UnitNotional.

Variables You can use the following variables in the formula depending on the selected reference amount:

Quantity

Price

ContractSize

FaceValue

Duration

UnitNotional

Notional

NotionalInFeeCurrency (uses the trade keywords <fee>.FeeCCY, <fee>.FeeLeg and <fee>.FXRate to
compute the trade notional in Fee currency)

Markup - The Markup allows setting a markup percentage per legal entity. You can define the legal entity
attribute "Client Markup" and set a markup percentage on the attribute. For example, Client Markup = 120
for 120%. The Markup variable in the formula will be multiplied by 120%.

Premium

RelatedFeesAmount (see Fee Grid Attribute AdjustmentRelatedFees for details on using this variable)

MADVQuantity (Monthly Average Daily Volume)

TradeAccrual (trade Accrual field)

LegalEntityWHT (WHT rate from legal entity attribute LegalEntityTaxRate_<COUNTRY>)

WHTRate (WHT rate from Withholding Tax Configuration).
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Fields Description
Operators You can use the following operators in the formula: Subtract (-), Multiply (*), Add (+), Divide (/), Exponent

(^), Absolute Value, Max, Min, Round, Round Up, Round Down.

 Ⓘ [NOTE: If the fee is always paid, the formula should be defined as an absolute value]

Functions You can select a function in Functions area and click Add to add it to the formula.

Currently, only the DayCountFactor function is available, you will be prompted to select the start date,
end date and daycount.

4.2 Contract Rebate Process
The rebate of contract fees is computed as soon as contract fees are generated but are settled periodically. The
billing function is therefore used to generate contract rebate fees.

The billing function requires the setup of a billing grid and a billing rule. Then based on this setup, the Billing engine
creates billing trades for the rebate fees.

4.2.1 Def in ing a Bi l l ing Gr id
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Set Up, and select the
Billing Grid panel to define a billing grid as shown below.
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Sample billing grid for contract fee rebate

» Select the "Trade" event type, the same role as the role defined for the fee configuration, and the calculator:
"TradeFeeRebate" or "TradeFeeConfigRebate" - See below for calculator details.

» You can check "Use Multiple Calculators" to generate a fee for each applicable calculator. Otherwise, a fee is
generated only for the first applicable calculator.

» Click Add to add the calculator to the billing grid - It will bring up a dialog, just click Apply.

» Then click Save to save the billing grid.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

TradeFeeRebate
This calculator allows computing a fixed rebate based on the rebate percentage specified in the Fee Config.

TradeFeeConfigRebate
This calculator allows computing a rebate (if applicable) over a group of trades that share the same billing criteria. The
rebate will be the sum of the individual trade fees minus the fee amount for the group of trades (in the case where it
falls in a different fee bracket).
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Example:

The fee range is defined as:

Trade Qty 0-100 - Fee Formula= Qty*5

Trade Qty 100-200 - Fee Formula= Qty*2

You have the following trades:

Trade1 Qty=70 => Fee=70*5=350

Trade2 Qty=80 => Fee=80*5=400

Total Fee Amount=350+400=750

Now, if grouping these trades to compute the fee globally, the fee amount is: Fee=100*5+50*2=600

Therefore there is a rebate of Rebate = 750-600 = 150

4.2.2 Def in ing a Bi l l ing Rule
A billing rule must be defined to set the rebate currency and rebate settlement date.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Billing Rule to define
a billing rule.
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Sample billing rule for contract fee rebate

» Enter the following fields:

– Select a legal entity, or double-click the Legal Entity label to set the legal entity to ALL.

– Select the same role as in the billing grid.

– Select the billing currency - This is the settlement currency of the fee.

– Select the billing date rule to determine the billing frequency.

– Select the settlement date rule to determine the settlement frequency of the fee.

– Input Date Type - Select the reference date to load the trades, messages, transfers:

TradeDate - Trade date

SettleDate - Trade value date

FeeDate - Fee date (Fee Value Date defined in the Billing Grid)

EnteredDate - Trade entered date

– Open the "Defaults Trade Billing Values" panel, and select the transfer type of the billing trade as needed. If
not set, the transfer type is set to INTEREST. Note that transfer types are defined in the domain “flowType”.

 Ⓘ [NOTE: If the attribute EntryType is set, and the Default Transfer Type is not set, the transfer type defaults
to the EntryType]
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» You also need to define the following attributes:

– BillingOnly - Set to True so that it is only used for billing trades.

– EntryType - Set to "CONTRACT REBATE".

– XferByBook - Set to True to create a transfer by trading book (using the book of the original trade on which
the contract fee was computed).

» Save the billing rule.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

4.2.3 Generat ing the Bi l l ing Fees
Make sure the Billing engine subscribes to PSEventTrade events using the Engine Manager in Web Admin.

The Billing engine can be started from the Engine Manager as well.

The Billing engine creates a billing fee to book the rebate amount in the original fee currency.

You can set the book attribute "Rebate Book" on the book of the original billing trade to book the rebate fee in the
rebate book. If this book attribute is not set, the rebate fee is booked in the same book as the original billing trade.

See Example of Broker Fees with Rebate for a full example.

For the TradeFeeRebate calculator, you need to run the scheduled task EOD_REBATE_FEE to convert the fee into the
rebate currency if applicable, and settle the rebate fee. The rebate fee is converted using the FX rate of the last day of
the billing.

For the TradeFeeConfigRebate, you need to run the scheduled task EOD_REBATE_FEE to compute the global rebate
amount.
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Sample EOD_REBATE_FEE scheduled task setup

You need to set the following attributes:

• Contract Fee = True.

• Process - Not used.

• APPLY ACTION - It is possible to specify the action to be applied in the scheduled task. For example, the billing
trade could stay in PENDING status during the billing period and move to VERIFIED status once the conversion is
done. This could be achieved by setting the action to AUTHORIZE for example.

• LegalEntity - You can enter a legal entity ID as needed.

4.3 Example of Broker Fees with Rebate
This example uses the volume rule on the quantity amount. The volume rule is triggered by trade events and can be
used for contract or invoice fees.

The fee rate used to compute the fee at trade capture depends on the trade quantity.

Fee Definition
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Sample contract fee definition for automatic fee

» Calculator set to FeeGrid.

Fee Grid
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Sample automatic contract fee grid based on fee schedule

» Calculator set to FeeConfig

Fee configuration with Rebate
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Sample contract fee schedule configuration

Billing Grid for Rebate Process

Sample billing grid for contract rebate process
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» Select the calculator "TradeFeeRebate".

Fee Billing Rule for Rebate Process

Sample contract fee rebate billing rule

Equity Trade and associated Fees
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4.4 Contract Fees - Accounting Events

4.4.1 Account ing of Contract Fee
Make sure that the Accounting checkbox is checked in the fee definition.
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Sample contract fee definition

Then from the Calypso Navigator, navigate to Configuration > Accounting > Events to create an accounting event
that has the same name as the fee type - COMMISSION in this example.

Make sure that "Fee Related Event" is checked.

Sample fee accounting event

Nasdaq Calypso
Fees, Haircuts and Sales Margins / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 44 / 114



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 45 / 114

4.4.2 Account ing of Rebates
From the Calypso Navigator, navigate to Configuration > Accounting > Events to create an accounting event to book
the rebate amount in original fee currency with effective date = rebate settle date.

The posting is booked on the original trading book.

Sample rebate accounting event in fee currency

Then create a second accounting event to book the rebate amount in settlement currency with effective date =
rebate settle date.

The posting is booked on the original trading book.
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Sample rebate accounting event in settlement currency

CST postings: For the billing trade, it is necessary to book CST postings on the underlying transfers in order to book
the correct fee amount on each original trading book.

To do so, you need to configure a CST event type (with property UNNET) as shown below.

Sample CST accounting event

The postings will be generated from the underlying transfers, provided the engine filter PaymentOnlyEventFilter is not
set on the Accounting engine in Web Admin.
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5. Capturing Trade Fees
The Fees panel of a Trade window allows entering fees for the trade. It also shows contract fees that have been
automatically computed based on a Fee Grid.

See Defining Fees for details on defining fee types.

See Defining Automatic Contract Fees for details on setting up automatic fees.

Sample fee capture

A number of fee types are provided out-of-the-box.

» Select a fee type from the Type field, or click ... next to the Type field to create a new fee type. The Fee Definition
window will appear.

– Select PAY or REC next to the fee type as applicable. This indicates whether the processing org pays or
receives the fee to / from the recipient.

– Select the payment currency of the fee from the field next to the Amount field.

– Enter the payment date of the fee in the Fee Date field.

The fee date defaults to trade date + spot days (from the fee currency) + fee offset (from the fee definition).

For automatic fees, the fee date can be overridden by the attributes of the fee grid.

See Defining Automatic Contract Fees for details on setting up automatic fees.

– Select the role of the fee recipient from the Role field, and click ... next to the Legal Entity field to select the
fee recipient. You will be prompted to select a legal entity of specified role.
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If the fee LE role is the same as the trade counterparty LE role, when you click Add in the Fees panel, the fee
legal entity will default to the trade counterparty, you do not need to select the fee legal entity.

Enter the other fields as applicable. The fee entry depends on the selected method as described below.

» Click Add to add a fee row, or click Generate to amortize the fee over a given period.

When amortizing a fee, you will be prompted to enter a start date, an end date, and an amortization frequency.

Note that the amortization frequency should be at least the coupon frequency.

Click Apply to generate fee rows as applicable.

The PV column represents the fee present value. It will only be populated if the trade is priced, and if FEES_NPV is
added to the pricer measures. Note that this currently only applies to interest rate derivatives and credit derivatives.

 Ⓘ [NOTE: When the Broker Fee is removed from a trade, the user is prompted to remove the Broker field as
well]

Fields Details

Fields Description
Amount Enter the fee amount for a flat fee only (method NONE). Otherwise the amount will be

calculated as described below.

Method Select a fee calculation method, and enter an input (fee rate for example) as needed. Then
click Calc to calculate the fee. Note that the NONE method does not require calculation.

When defining a fee type, you can select a default fee calculator. Refer to the Calypso
Developer’s Guide for information on adding custom fee calculators.

You can click ? for information on a given method.

Start Date

End Date

The Start Date and End Date will be set to the Fee Date unless you choose to amortize the
fee over a given period.

Known Date Allows you to enter a fee for a given date when you choose to amortize the fee over a given
period.

Enter a fee with a known date and click Add. A fee row will be added for that date. The
known date must be between the start and end date.

Description Enter a comment as applicable.

Automatic Fees Computation
Provided you have configured automatic fees, you can click Automatic Fees to generate the fees before saving the
trade.

They will be generated upon saving otherwise.
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See Defining Automatic Contract Fees for information on defining automatic fees.

Automatic Fees Override
When viewing automatic fees, you can override the fee amount.

» Select an automatic fee and enter the modified amount in the Amount field. Then click Modify. The "Manual
Amount" column will appear checked.

» To prevent the fee from being automatically recomputed upon saving the trade, clear the Override column.

» Save the trade.

Configuring Fee Columns
You can configure the display of the fee columns using Back Office > Configure Fee Columns.
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6. Defining Invoice Fees
The system allows generating invoice fees relating to various transactions such as trades, payments, and messages.

The Billing engine subscribes to trade events, message events, and transfer events to generate invoice fees (billing
trades) based on billing grids and fee billing rules.

Before you Begin
You can set a default book for billing trades in the legal entity attribute "FUNDING BOOK" of the legal entity that pays /
receives the fee (broker, counterparty, agent, etc.).

The fee types for billing fees are created in the Fee Definition.

Example:

Billing Trade Workflow
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Billing trades follow the standard trade workflow. However, make sure that the AMEND action is available, as new
billing fees will be added to the same trade during the billing period, and the billing trade will therefore be amended.
Also, it is recommended to move the billing trade to a status that can no longer be amended at the end of he billing
period.

6.1 Defining Bi l l ing Grids
The billing grid allows automating the fee calculation for trades, messages, and transfers.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts & Margin Calls > Fee Set Up (menu action
refdata.FeeSetUpWindow), and select the Billing Grid panel.

Sample billing grid for invoice fee

» Enter the fee application criteria as needed and select the event type for which the fee will be generated:
Message, Trade, or Transfer.

Enter the validity dates of the grid - They apply to the selected "Fee Value Date" of the related object.

See Note on "Fee Value Date" for details.

Fill in the Description field to describe the grid. This field is mandatory.
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You can check "Use Multiple Calculators" to generate a fee for each applicable calculator. Otherwise, a fee is
generated only for the first applicable calculator.

The event types Account and MaintenanceTrade apply to account management fees.

Refer to Cash Management documentation for details on account management fees.

» Select a calculator (Default, FeeConfig, FTT), and click Add to define the calculator.

– For the Default calculator, the fee will be computed based on the amount defined here.

Enter a description and an amount. The amount can be signed: "-" means the PO pays the fees, "+" means
the PO receives the fee.

You can check "use Time Period" to select a date rule to generate the fee.

Then click Apply.

– For the FeeConfig calculator, the fee will be computed based on a fee schedule defined in the Fee Config
panel.

See Defining Invoice Fee Schedules for details on defining fee schedules for invoice fees.

You can check the "Split by book" checkbox to allocate the fees to the original books, and click Apply.

– FTT allows computing the Financial Transaction Tax on the physical settlement of securities.

See Computing the Financial Transaction Tax for full setup details.

» Save the billing grid.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Nasdaq Calypso
Fees, Haircuts and Sales Margins / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 52 / 114



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 53 / 114

Note on “Fee Value Date”
The “Fee Value Date” determines which date on the billing event should be used to select the Billing Grid and the
Billing Rule.

By default, it can be set to the following values based on the type of event:

• Messages: CurrentDate (Today), CustomDate (if the Fee Value Date of the billing event has been customized),
MessageCreationDate, or MessageSettleDate – You can add more types of dates to the domain
“billingMessage.feeValueDates”.

• Trades: CurrentDate, CustomDate, TradeDate, or TradeSettleDate – You can add more types of dates to the
domain “billingTrade.feeValueDates”.

• Transfers: CurrentDate, CustomDate, TransferValueDate, or TransferSettleDate – You can add more types of
dates to the domain “billingTransfer.feeValueDates”.

6.2 Defining Fee Bi l l ing Rules
The billing rule allows defining the billing frequency, and a billing threshold if needed.

Define the Billing rules from the Calypso Navigator using Configuration > Fees, Haircuts & Margin Calls > Fee Billing
Rule (menu action refdata.FeeBillingRuleWindow).

Sample billing rule for invoice fee

» Enter the following fields:

– Select a legal entity, or double-click the Legal Entity label to set the legal entity to ALL.
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– Select the same role as in the billing grid.

– Select the billing currency or ANY.

– Select the billing date rule to determine the billing frequency.

– Select the settlement date rule to determine the settlement frequency of the fee.

– Input Date Type - Select the reference date to load the trades, messages, transfers:

TradeDate - Trade date

SettleDate - Trade value date

FeeDate - Fee date (Fee Value Date defined in the Billing Grid)

EnteredDate - Trade entered date

– Open the "Defaults Trade Billing Values" panel, and select the transfer type of the billing trade as needed. If
not set, the transfer type is set to INTEREST. Note that transfer types are defined in the domain “flowType”.

 Ⓘ [NOTE: If the attribute EntryType is set, and the Default Transfer Type is not set, the transfer type defaults
to the EntryType]

» You also need to define the following attributes - This only applies if you have selected the FeeConfig calculator
in the Billing Grid.

– BillingAggregation - When set to true, the system does not create the billing fees. It creates billing fee
details that can be aggregated into a single billing fee using the scheduled task EOD_BILLING_
AGGREGATION.

See Aggregating Billing Fees for details.

– BillingOnly - Set to True so that it is only used for billing trades.

– EntryType - Set to the fee type ,"BROKERINVFEE" for example.

– XferByBook - Set to True to create a transfer by book.

You can click Domain to add an attribute if it is not available.

» Save the billing rule.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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6.3 Generat ing Invoice Fees
The Billing engine is used to create the billing fees.

6.3.1 Conf igur ing the Bi l l ing Engine
The Billing engine is configured in the Engine Manager of Web Admin: event subscription and engine parameters.

You may need to add this engine if it is not available for configuration: Create a new engine called BillingEngine, with
class name com.calypso.engine.billing.BillingEngine.

The Billing engine must subscribe to the following events: PSEventTrade, PSEventMessage, PSEventTransfer.

The behavior of the Billing engine may be modified with the following engine parameters.

If a parameter is not available for setup, you can register it in the domain "engineParam".

Parameters Description
IGNORE_ACTION Comma-separated list of trade actions to be ignored by the engine.

MAX_BATCH_EVENT Maximum number of persistent events loaded at one time by an engine in batch mode. The
engine will load events in MAX_BATCH_EVENT chunks until all events are processed.
Persistent events received after MAX_QUEUE_SIZE is reached will be processed in batch
mode.

Allows controlling engine memory usage, therefore improving the performance.

MAX_QUEUE_SIZE Maximum number of events buffered on an engine event queue.

When this number is exceeded, real time events are discarded and the engine restarts
based on the restart timer (TIMEOUT_RESTART), in order to process the unprocessed
persistent events using batch mode. This parameter can be useful for controlling the
engine’s memory usage. If not set, the default value for this parameter is no limit on queue
size.

Allows controlling engine memory usage, therefore improving the performance.

PricingEnv Pricing environment used by the engine. If not set, the default Pricing Environment of the
user running the engine will be used.

TIMEOUT_RESTART Number of seconds to wait before an engine restarts after MAX_QUEUE_SIZE has been
reached. The default value is 3600 seconds (1 hour).

6.3.2 Start ing the Bi l l ing Engine
The Billing engine can be started from the Engine Manager in Web Admin.

Please refer to Calypso Web Admin documentation for complete details.
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In order to update the same billing trade for a given counterparty, account ID and billing rule ID, you need to provide
the account ID in a trade keyword. The trade keyword that holds the account ID information must be defined in the
domain “BillingAccountTradeKeyword”.

6.3.3 Aggregat ing Bi l l ing Fees
When the Fee Billing Rule attribute "BillingAggregation=true" the billing fees are not created directly. The system
publishes a PSEventTrade, processed by the Billing engine, when a trade is booked. If valid Billing Grid, Fee Config
(optional) and Billing Rule are found, the system creates billing fee details. Billing fee details can then be aggregated
into a single billing entry (creation of a new billing trade, or update of an existing one) using the scheduled task EOD_
BILLING_AGGREGATION.

You can set the following attributes:

• APPLY ACTION - It is possible to specify the action to be applied by the scheduled task. It is AMEND by default.

• LegalEntity - Enter the Legal Entity short name to reduce the scope of the Scheduled Task or leave blank.

6.3.4 Bi l l ing Fees for Trade Events
When a trade is booked, the system publishes a PSEventTrade which is processed by the Billing engine. If valid Billing
Grid, Fee Config (optional) and Billing Rule are found, the system creates a billing entry (creation of a new billing trade,
or update of an existing one). This billing entry is linked to the original trade.
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6.3.5 Bi l l ing Fees for Transfer events
When a transfer is created by the transfer engine, the system publishes a PSEventTransfer which is processed by the
Billing engine. If valid Billing Grid, Fee Config (optional) and Billing Rule are found, the system creates a billing entry
(creation of a new billing trade, or update of an existing one) linked to this transfer. This billing entry is linked to the
original transfer (and trade if known).

6.3.6 Bi l l ing Fees for Message Events
When a message is created by the message engine, the system publishes a PSEventMessage which is precessed by
the Billing engine. If valid Billing Grid, Fee Config (optional) and Billing Rule are found, the system creates a billing
entry (creation of a new billing trade, or update of an existing one) linked to this message. This billing entry is linked to
the original message (and transfer or trade if known).

6.3.7 Example
For example, the processing organization, receives $2,000 each time it generates a message for the agent.

The Billing engine subscribes to message events and generates a Billing trade. The system generates one trade per
billing period. So, every new message will create an update of this Billing trade.

From the Calypso Navigator, navigate to Processing > Accounting Operations > Billing > Trade > Open (menu
action trading.TradeBillingWindow). It opens the Trade Selector. Click Show Trades to view all billing trades.
Double-click a trade to view its details.

Sample billing fee trade

» Select the Billing Fees panel to see the details of each fee:
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You can select a row and click Billing Event to open the corresponding event report - Message report in this case.

You can click Billing Grid to see the detail of the grid used for this calculation.

Billing Fee Override

Sample billing fee override

» Check the "Manual amount" column and enter the modified amount in the "Converted Amount" column.

» To prevent the fee from being automatically recomputed upon saving the trade, clear the Override column.

» Save the trade.
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7. Defining Invoice Fee Schedules
The Fee Set Up window allows defining fee schedules for the FeeConfig calculator in the context of billing fees. When
the FeeConfig calculator is set on the Billing Grid, the fee schedule defined in the Fee Config panel will be used to
compute the billing fee.

7.1 Fee Schedule Definit ion
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Set Up (menu action
refdata.FeeSetUpWindow) to open the Fee Set Up window, Fee Config panel.

Sample invoice fee schedule

In this example, if the number of trades for a given broker is below 20, the fee rate will be 10, and if the number of
trades is 20 or above (and below 50), the fee rate will be 8.

» Enter a configuration name and set the fee parameters as needed. They are described below.

» Then click Add to add an entry to the fee schedule. It brings up the Formula Definition dialog. It is described
below.

» Click to save the configuration. The configuration will be used when the FeeConfig calculator is set on a Billing
Grid, based on the selected filters.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

You can also click to bring up the Browse panel for loading existing configurations.
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References
These parameters are used to compute the fee.

Fields Description
Config ID ID of the configuration given by the system upon saving.

Name Enter a configuration name.

Config Type Select "Billing Fee" to generate invoice fees.

Rule Type Select the reference amount unit:

• Avg Price (unit amount).

• Transactional (number of transactions).

• Volume (trade amount).

 Ⓘ [NOTE: The Maintenance and Safekeeping rules only apply to account management fees and
are generated by the ACCOUNT_BILLING scheduled task on inventory positions - Please refer to
Calypso Cash Management documentation "Generating Account Fees" for details]

Scale By Select the reference amount of the fee schedule:

• For Avg Price, you can select Price.

• For Transactional, you can select Count.

• For Volume, you can select Quantity, ConvQuantity (Trade Quantity converted to the fee
currency), MarketValue (Trade Quantity * Trade Price), Notional, ConvNotional (Trade Notional
converted to the fee currency), or MADVQuantity (Monthly Average Daily Volume).

The fee rate used to compute the fee at fee creation depends on the event's reference amount
(notional, quantity, etc.). At the end of the billing period, a rebate can be applied to adjust the fee rate
based on all the events of the period.

See Invoice Rebate and Conversion Process for details.

Range by
Tenor

Check to set the fee range by tenor, or clear to set the fee range by number of days.

Range by
ResidualMat

Check to set the fee range by residual maturity, or clear to set the fee range by product.
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Fields Description
Tiered Check to indicate that the reference amount is distributed over the range, rather than applied to the

absolute range.

For example, you have the following range:

• 0 to 1,000 - Fee rate is 10%

• 1,000 to 5,000 - Fee rate is 5%

• 5,000 and up - Fee rate is 2%

The reference amount is 7,000.

• For the non-tiered method, the fee rate is 2% (5,000 and up range).

• For the tiered method, the fee rate is 10% for the first 1,000 - Then 5% for the next 4,000 - Then 2%
for the remaining 2,000.

Event Type Select the event type:

• For Avg Price and Volume, you can only select Trade - The fee is computed on trade events.

• For Transactional, you can select Message, Trade or Transfer - The fee is computed on message
events, transfers events, or trade events.

Refer to Cash Management documentation for details on account management fees.

Fee
Currency

You can select a fee currency, or leave empty for ANY.

Conversion Check if you want to convert the fee using the FX rate at the end of the billing cycle. It is converted
using the fee date FX rate otherwise.

For computing the converted fee at the end of the billing cycle, you need to run the scheduled task
EOD_REBATE_FEE.

See Invoice Rebate and Conversion Process for details.

Select the pricing environment for loading the FX rates. If not set, the pricing environment defined in
the Billing engine will be used.

Day Count Select a daycount as needed.

Effective
From

Enter the effective start date of the configuration.

Effective To Enter the effective end date of the configuration (optional).

Description Enter a free form description as needed.

Rebate
Check the Rebate checkbox to compute a rebate on the invoice fees.

See Invoice Rebate and Conversion Process for details.
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Fields Description
Rebate
Type

Select the Rebate type:

• Default - At the end of the billing period, a rebate is applied to adjust the fee rate based on all the
events of the period (Trade period), or for each billing entry (Daily period).

Rebate Period - Select the rebate period: Trade or Daily.

Add Fee Amount By Range - To compute a billing fee by range as needed - You can select:

– No - No billing fee by range.

– Yes, on the fly - Billing fee by range is computed by the billing engine each time a new billing fee
is attached/removed to the Billing trade. Event type is FeeConfigRange.

– Yes, on rebate - Billing fee by range is computed by EOD_REBATE_FEE scheduled task. Event
type is FeeConfigRange.

Range Amount Type - To define the amount type of the billing fee by range - It is set to RANGE by
default. You can set to another value as needed.

• Discount - A discount rebate is applied based on the total fee amount of the billing period (Trade
period) or for each billing entry (Daily period), and the discount schedule.

Select the rebate period: Trade or Daily.

Click Add to add a discount entry.

Enter a minimum fee and a maximum fee and enter the discount percentage.

• CapFloor - At the end of the billing period (Trade period) or for each billing entry (Daily period), a
rebate is applied if the fee is not within the minimum and maximum amounts.

Select the rebate period, the currency, the cap amount, and the floor amount.
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Fields Description

The FX rate used to convert the cap or floor amount into the settlement currency is the one available
on the end date of the billing trade.

Billing Fee by Range
Fee billing entries are generated for each range in addition to fee billing entries for each event when Add Fee Amount
By Range = "Yes, on the fly" or "Yes, on rebate".

The transfer attribute AccountHolderAccountId is set to the GL Account of the DDA transfer for DDA transfers of
Customer Transfer trades.

The Account ID of the billing trade is set to the GL Account of the external transfer by default. If domain
"BillingEvent.TransferMessageAccountSelector" contains Value = AccountHolderAccount, it is fetched from the
“AccountHolderAccount” transfer attribute instead.

If billing account attribute LastBillingInvoiceNumber is set, the trade keyword InvoiceNumber is set to
LastBillingInvoiceNumber + 1.

You can use the trade workflow rule UpdateAccountBillingInvoiceNumber to update the account attribute
LastBillingInvoiceNumber from the trade keyword InvoiceNumber. It should be used on a transition where the result
status is VERIFIED.

Filtering
These parameters are used to determine the conditions of application of the fee. You can use pre-defined filtering
criteria, or a filter template.

Pre-defined criteria:
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Fields Description
Processing
Org

Select a processing organization as needed, or ALL.

Legal Entity Select a legal entity of specified role, or ALL.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Exchange Select one or multiple exchanges (legal entity of role MarketPlace), or leave empty for ALL.

Product Type Select one or multiple product types, or leave empty for ALL.
Product groups are identified as "G. <group name>" and are created using Configuration > Product >
Group.

Security ID Enter one or multiple product IDs (separated by commas), or leave empty for ALL.

Book Select one or multiple books, or leave empty for ALL.

Book Attr Select one or multiple book attribute / attribute value, or leave empty for ALL.

Currency Select one or multiple currencies, or leave empty for ALL.

Account ID Only applies to account management fees.

Fee Date Only applies to account management fees.

SD Filter Select a static data filter as needed, or leave empty.

Attributes Click to add attribute criteria as needed.

Filter template:
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» To add a new filter template, choose > Filter category > Add. You will be prompted to enter a filter category
name. Enter a name and click OK.

» Then choose > Filter fields template. You will be prompted to select a filter category previously created, and
to select the filter criteria you want to use.

Fields Description
Filter Category Select a filter template previously created.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Filter Template Criteria Select the values for the filter criteria defined in the filter template.

In this example, the filter template contains the filter criteria Book and Strategy attribute.

Formula Definition
Click Add to bring up the Formula Definition dialog.
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Sample formula

» Enter the parameters to define the ranges of the fee schedule. They are described below.

» You can type in the formula, or double-click variables and operators to add them to the formula. Only the
displayed variables and operators can be used in the formula.

» Click OK OK when you are done.

Fields Description
Min
Amount

Max
Amount

Enter the minimum and maximum amounts of the range. It refers to the reference amount defined by the
Rule Type and Scale By parameters: Count, Quantity, Notional, or Price.

No value is considered as 0 for the minimum amount, and infinite for the maximum amount.

The minimum amount is inclusive.

The maximum amount is non inclusive.
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Fields Description
Min Tenor

Max Tenor

Min Days

Max Days

You can also select a minimum tenor and a maximum tenor to scale the fee rates by product maturity
("Range by ResidualMat" is not checked), or by residual maturity ("Range by ResidualMat" is checked).

 Ⓘ [NOTE: For products without maturity date, the fee rates are scaled by settlement date
instead]

The minimum tenor is non-inclusive.

The maximum tenor is inclusive.

When the "End Date" falls on a non-business day, its is rolled to the following business day. So in this
situation the minimum tenor becomes inclusive and the maximum tenor becomes non-inclusive.

If "Range by Tenor" is not checked, you can enter a number of days instead of selecting a tenor.

Calc Unit Enter a calculation unit when defining a fee expressed as an amount per unit.

For example 2 per million of notional: Calc Unit = 1000000 and Formula = 2*UnitNotional.

Variables You can use the following variables in the formula depending on the selected reference amount:

Quantity

ConvQuantity (Trade Quantity converted to fee currency)

MarketValue (Trade Quantity * Trade Price)

Notional

ConvNotional (Trade Notional converted to fee currency)

MADVQuantity (Monthly Average Daily Volume)

TradeAccrual (trade Accrual field)

LegalEntityWHT (WHT rate from legal entity attribute LegalEntityTaxRate_<COUNTRY>)

WHTRate (WHT rate from Withholding Tax Configuration).

Operators You can use the following operators in the formula: Subtract (-), Multiply (*), Add (+), Divide (/), Exponent
(^), Absolute Value, Max, Min, Round, Round Up, Round Down.

 Ⓘ [NOTE: If the fee is always paid, the formula should be defined as an absolute value]

Functions You can select a function in Functions area and click Add to add it to the formula.

Currently, only the DayCountFactor function is available, you will be prompted to select the start date,
end date and daycount.
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7.2 Invoice Rebate and Conversion Process
Rebate entries and conversion entries are generated using the scheduled task EOD_REBATE_FEE.

The rebate process adjusts the fee rate / amount at the end of the billing period based on the selected rebate type.

• Default - The fee rate is adjusted based on all the events of the billing period

• Discount - A discount is applied based on the total fee amount and the discount schedule

• CapFloor - The fee amount is adjusted if it is not within the minimum and maximum fee amount

The conversion process converts the fee using the FX rate at the end of the billing cycle.

The scheduled task EOD_REBATE_FEE must be run daily. It retrieves the billing trades for which the end date falls on
the scheduled task valuation date.

The system creates new billing entries of type REBATE to book the difference between the billing fee amount
originally computed and the billing fee amount computed at the end of the period, once the actual fee rate or FX rate
is known, or the discount or cap floor is applied. There is one REBATE billing entry per trading book.

You can set the book attribute "Rebate Book" on the book of the original billing trade to book the rebate fee in the
rebate book. If this book attribute is not set, the rebate fee is booked in the same book as the original billing trade.

Sample EOD_REBATE_FEE scheduled task setup

You need to set the following attributes:
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• Contract Fee = False.

• Process - Select "Amount Recalc" to compute rebates, or "Conversion" to convert the fee using the FX rate at the
end of the billing period.

• APPLY ACTION - It is possible to specify the action to be applied in the scheduled task. For example, the billing
trade could stay in PENDING status during the billing period and move to VERIFIED status once the rebate is
computed, if any. This could be achieved by setting the action to AUTHORIZE for example.

• LegalEntity - You can enter a legal entity ID as needed.

7.3 Example of Transactional Fee for Messages
Define a generic billing grid valid for any agent with the FeeConfig calculator.

Sample invoice billing grid

Make sure that the fee billing type is defined within Fee Definition.
For example, CUSTODIAN FEE.
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Define the fee config with financial conditions specific to the agent.

Each message will be charged 2 USD. The final fee amount will depend on the number of messages sent at the end of
the period (Scale By = Count).

Sample invoice fee schedule configuration

Define a billing rule with the settlement ccy (AUD in this example, meaning all fees will have to be converted from USD
to AUD).
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Sample contract fee rebate billing rule

FX.AUD.USD (10/17/2011)=1.52

FX.AUD.USD (10/24/2011)=1.51

FX.AUD.USD (10/28/2011)=1.50

The following billing trade is created:
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Run the scheduled task EOD_REBATE_FEE on the end date of the billing period to compute the rebate. The rebate
amount is computed globally but is then allocated by original trading book.

FX rate on 10/31/2011 is 1.05
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7.4 Invoice Accounting Events

7.4.1 Trade Capture
The accounting event NOM_NET_EB is used to book the entry amount, on entry date, using the original trading book.
The amount booked is the theoretical fee amount.

Sample NOM_NET_EB accounting event

To book the converted amount, it is possible to use the accounting event FXNOM_NET_EB.
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Sample FXNOM_NET_EB accounting event

7.4.2 End of B i l l ing Per iod
The rebate amount if any, is booked using the accounting event REBATE_EB on settle date of the billing trade, using
the original trading book.

 Ⓘ [NOTE: Rebate amounts can only be computed if you are using a Fee Config]

Sample REBATE_EB accounting event
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7.4.3 Sett lement
The CST UNNET accounting event can be used to book the settlement amount per original trading book.

Sample CST accounting event
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8. Computing the Financial Transaction
Tax
The Financial Transaction Tax (FTT) is calculated on the physical settlement of securities when:

• Underlying security transfer going to SETTLED (delivery / receipt of securities)

• Underlying security transfer going to CANCELED

The FTT calculation is performed separately on each group of sales and purchases that satisfy the following criteria:

• Real settlement date

• Processing Organization

• Security

• GL Account of security transfer

• Custodian

The FTT is calculated as follows:

FTT Amount = roundup(Basis * Buy Average Price;2) * Fee Rate

Where:

Basis = max(0, sum(nominal_purchased) – sum(nominal_sold))

The FTT is computed by the scheduled task EOD_FTT_FEE using the billing calculator FTT.

8.1 Setup Requirements

Step 1 - Define a billing grid with the FTT calculator.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts & Margin Calls > Fee Set Up, and select the
Billing Grid panel (menu action refdata.FeeSetUpWindow).
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» Select the event type "Transfer", and any application criteria as needed.

Any eligibility criteria for the security should be defined in a static data filter.

» Select the calculator FTT and click Add.

You will be prompted to define the calculation parameters.

Click Apply when you are done.

» Save the billing grid.
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Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Step 2 - Define a fee billing rule to drive the calculation period and settlement dates.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts & Margin Calls > Fee Billing Rule (menu
action refdata.FeeBillingRuleWindow).

It is possible to settle the tax to a third party using the fee billing rule attributes THIRDPARTY and THIRDPARTY ROLE.

The scheduled task EOD_FTT_FEE must be run daily to compute the tax amount based on the daily traded quantity
and average price.

8.2 Computing the FTT
The FTT is computed by the scheduled task EOD_FTT_FEE based on the daily traded quantity and average price.
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» Select a processing org and a trade filter as needed.

» Select the action to be applied, and a legal entity.

Run the scheduled task daily.

For each underlying security SETTLED transfer, the system will create an entry in the billing trade to store the
corresponding trade quantity and price. There's a billing trade per account, period and security.
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9. Trade Fees Report
The Fee Report displays fee details associated with the trades entered in the system.

From the Calypso Navigator, navigate to Reports > Fees & Settlements > Fee Report to access the Fee Report.

Sample fee report

 Ⓘ [NOTE: The columns of this picture have been configured. Sort columns, subheadings and subtotals have
to be explicitly specified. See Help > Menu Items for details]

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» Specify search criteria as applicable and click to load the corresponding fees.

The dates can be specified either as specific dates or using a rule. To use a rule, check the Rule checkbox. The
Period, -/+, and Tenor fields should appear.

The period can be "Month" or "Year". If Tenor is 0, then the start and end dates of the current month or year are
automatically displayed.

-1 means the previous month/year, etc.
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+1 means the next month/year, etc.

Check the Display Signed Amount checkbox to display the following:

– If REC Fee, then display Positive amount.

– If PAY Fee, then display Negative amount.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

NOTE: For the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Fee Repor t Resu l t s
You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.
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10. Billing Fee Report
The Billing Fee Report allows viewing billing trades created by the Billing engine for invoice fees.

See Defining Invoice Fees for information on generating invoice fees.

From the Calypso Navigator, navigate to Reports > Fees & Settlement > Billing Fee Report to access the Billing Fee
Report.

Sample Billing fee report

» Enter search criteria as needed and click to load the corresponding billing trades.

You can configure the display using the Data and View menus - Choose Help > Menu Items for complete details.

For transaction fees, you can display information on the related transactions using the columns under Trade >
Linked Object.

For account management fees, you can display information on the accounts using the columns under Trade >
Account.

» You can uncheck the menu item View > Criteria to hide the search criteria (this menu item operates as a
checkbox).

» Check “Billing Fees” to view billing fees, and/or check “Billing Details” to view billing details related to billing fees
aggregation. See “Defining Invoice Fee” for details on aggregating billing fees.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.
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» You can click to print the report results.

NOTE: For the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Bi l l i ng Fee Resu l t s
The Billing Fee report does not allow opening the corresponding Billing trade but you can use the Trade Browser to
display billing trades for the Billing product type.
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11. Consolidated Fees Report
The Consolidated Fee Report displays fee details for trade fees and billing fees.

See Fee Overview for details on capturing fees.

From the Calypso Navigator, navigate to Reports > Fees & Settlements > Consolidated Fee Report to access the
Consolidated Fee Report.

Sample consolidated fee report

 Ⓘ [NOTE: The columns of this picture have been configured. Sort columns, subheadings and subtotals have
to be explicitly specified. See Help > Menu Items for details]

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.
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» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» Specify search criteria as applicable and click to load the corresponding fees.

» You can check the "Billing Details" checkbox to select multiple event types.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

NOTE: For the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Conso l ida ted Fee Repor t Resu l t s
You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.

Report Columns

Columns Trade Fee Description Billing Fee Description

Fee Amount Trade fee amount. Billing fee amount.

Billing Fee No Yes

Billing Ccy Fee settlement ccy. Fee settlement ccy (coming from the
billing rule).

Billing Rule N/A ID of the billing rule.

Billing TradeId N/A Id of the billing trade.

Book Trading book of the corresponding trade. Book of the billing trade.

Fee Condig Id ID of the Fee Config used to compute the trade
fee, if any.

ID of the Fee Config used to compute
the trade fee, if any.

Fee Converted Amount Fee amount converted in billing currency. Fee amount converted in billing
currency.

Fee Currency Currency of the trade fee. Currency of the billing fee.

Fee Date Trade fee date. Settlement date.

Fee Type Trade fee type. Billing entry type.

FX Rate FX rate used to convert the fee in case fee
currency is different from fee settlement
currency.

FX rate used to convert the fee in case
fee currency is different from billing
currency.
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Columns Trade Fee Description Billing Fee Description

Fee Grid Id ID of the Fee Grid used to compute the trade fee,
if any.

ID of the Billing Grid used to compute
the trade fee.

Fee Legal Entity Short name of the legal entity that pays / receives
the fee.

Short name of the legal entity that pays /
receives the fee.

Fee Role Role of the legal entity that pays / received the
fee.

Role of the legal entity that pays /
received the fee.

Billing Fee Event Type Set to Trade. Event type selected in the billing grid.

Manual Amount Checked, if the fee amount has been modified
manually, or unchecked otherwise.

Checked, if the fee amount has been
modified manually, or unchecked
otherwise.
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12. Defining Withholding Tax Fees
Withholding tax fees can be applied automatically to interest cashflows. This section describes the setup and
generation of withholding tax fees for INTEREST cashflows on Money Market trades and Sec Finance trades.

 Ⓘ [NOTE: The Withholding Tax setup for corporate actions on bonds is described in the Calypso Fixed
Income documentation and is a different process]

12.1 Before you Begin
The following settings are required to generate Withholding Tax fees.

Environment Property
The withholding tax process is enabled if the environment property WITHHOLDINGTAX is set to true.

Counterparty
You can identify multiple categories of withholding taxes using the legal entity attribute WHT-Category, and use it in a
static data filter in the fee grid definition.

Flow Type
You need to add WITHHOLDINGTAX to the domain "flowType". A cashflow of type WITHHOLDINGTAX will be
generated based on the fee grid criteria.

 Ⓘ [NOTE: The flow type must be the same as the fee type]

Authorizing Withholding Tax Attributes
In order for the Authorization mode to apply to withholding tax attributes, you need to add “WithholdingTaxAttribute”
to the domain “classAuthMode”.

12.2 Fee Definit ion
Define a fee type WITHHOLDINGTAX for the role Counterparty as shown below. You can define multiple fees with
different names.
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» Check only Transfer and Accounting.

» Select the FeeGrid calculator.

12.2 .1 Withhold ing Tax Attr ibutes
You can define a number of withholding tax attributes with a validity period. Multiple fee grids can be defined based
on the values of these attributes (through the use of static data filters). Changes to these attributes will be reflected in
the WHT calculation.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Withholding Tax
Attributes (menu action refdata.WithholdingTaxAttributeWindow) to define withholding tax attributes.
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12.2 .2 Tax Regist rat ion
In order to register Cash trades with the tax office (Japanese and Indonesian requirements), the event type action
“Tax Registration” has been added to cash trades. Choose Cash > Tax Registration in the Trade Cash window to
apply the “Tax Registration” action. The static data filter element “Is Tax Registered” allows applying different fee
grids whether the trade is registered or not.

12.2 .3 Fee Gr id Def in i t ion
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Set Up, and select the
Fee Grid panel to define a fee grid for the counterparty.
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» Check the “WithHolding Tax” checkbox.

» Select the WITHHOLDINGTAX fee type.

» You can set the fee grid attribute DefaultLegalEntity to a legal entity short name to pay the tax to a given legal
entity. Otherwise, the tax will be paid to the counterparty.

» You can set a static data filter on the legal entity attribute WHT-Category, the flow type INTEREST, and the
direction.

For example:

– CPTY_ATTRIBUTE.WHT-Category = 1
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– Buy/Sell = Buy

– Xfer Type = INTEREST

» You can set static data filters based on the withholding tax attributes using the static data filter elements: PO_
WHT_BOOK_ATTRIBUTE, PO_WHT_LE_ATTRIBUTE, CPTY_WHT_ACCOUNT_ATTRIBUTE, and CPTY_WHT_LE_
ATTRIBUTE.

 Ⓘ [NOTE: These static data filter elements only apply to CASH interest cashflows, not SECURITY cashflows]

» You can set static data filters based on the “Is Tax Registered” static data filter element to apply different fee
grids whether the trade is registered or not.

» If the Authorization mode is enabled, an authorized user must approve your entry.

Rounding by Unit
A specific fee calculator has been implemented to handle rounding conventions different than the Ccy decimals:
WHTRoundToUnit. In order to use this fee calculator, you must configure the WITHHOLDINGTAX fee with:

• Feed Grid attribute WHT_USE_CALCULATOR = true

• Fee Grid Calculator = WHTRoundToUnit (you may need to add it to the domain “feeCalculator”)

Truncating by Unit
A specific fee calculator has been implemented to allow truncating the tax amount: WHTTruncateToUnit. In order to
use this fee calculator, you must configure the WITHHOLDINGTAX fee with:

• Feed Grid attribute WHT_USE_CALCULATOR = true

• Fee Grid Calculator = WHTTruncateToUnit (you may need to add it to the domain “feeCalculator”)

12.3 Nett ing
INTEREST and WITHHOLDINGTAX transfers should be netted.

12.4 Pricer Measures
The WITHHOLDINGTAX pricer measures can be created from the Calypso Navigator using Configuration > System >
Add Pricer Measure. The class is tk.pricer.PricerMeasureWithholdingTax, and the ID should be an ID not already
in use.

12.5 Accounting
The accounting event WITHHOLDINGTAX is triggered by VERIFIED_TRADE, CANCELED_TRADE, TERMINATED_
TRADE, and RATE_RESET.
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If you have defined multiple fees, define multiple accounting events with "Fee Related Event" checked, in the form:

"<CAPITALIZE_INT_TAX>_<Name of WHT Tax Fee>”.

For example: CAPITALIZE_INT_TAX_WHT if the fee is defined as “WHT”.
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13. Defining Haircut Rules
The Haircut window allows defining haircut rules to apply haircut percentages based on security maturities.

A haircut rule can be associated with a collateral upon trade capture. The haircut amount is added / subtracted to /
from the collateral value.

The following trades and processes support haircut rules: repos, security loans, and margin calls.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Haircut Rule for defining
haircut rules.

13.1 Sample Haircut Rule

In this sample rule, the market values of the collaterals will be increased or decreased by the following percentages:

• Maturity ≤ 5Y, Haircut is 3%
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• Maturity > 5Y and ≤ 10Y, Haircut is 5%

• Maturity > 10Y and ≤ 30Y, Haircut is 8%

• Maturity >30Y and ≤ 50Y, Haircut is 10%

• Collaterals with no expiration, Haircut is 12%

Note that in this example, the haircut percentage is applied based on the remaining maturity of the collaterals as of
the trade date.

13.2 Sample Haircut Rule Using a Stat ic Data Fi l ter Tree

When defining a haircut rule using a static data filter tree instead of a standard static data filter, the tree is displayed in
an exploded view in the Definition panel where each row represents a node of the tree. Initially, every row is displayed
in red. You need to click on each row and define its haircut points as described in Definition Panel. Once the haircut
points are defined for the node, the row turns white. The haircut rule can only be saved when all of the rows are white.

Please refer to Calypso Trading Environment documentation for details on defining a static data filter tree.

13.3 Stat ic Data Fi l ter Attr ibutes
You can enable filtering based on the pledger (processing org or counterparty, depending on the direction).

Add "LegalEntity" to the domain sdFilterCriterion.Factory to create the Legal Entity static data filter attributes.
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13.4 Creating a Haircut Rule

13.4 .1 Tota l Ha i rcut Calcu lat ion
Click New to create a new haircut rule, and enter a name in the Name field. Enter a description in the Description field
as needed.

Select a Total Haircut Calculation type:

• ADDITION: Total Haircut = Definition Haircut + Cross Currency Haircut + Wrong Way Risk Haircut + Additional
Haircut_1 + Additional Haircut_2...

• MULTIPLICATION: Total Haircut = 1 - (1- Definition Haircut) * (1 - Cross Currency Haircut) * (1 - Wrong Way Risk
Haircut) * (1 - Additional Haircut_1) * (1 - Additional Haircut_2)...

• HIGHEST: The system looks across all the panels of the haircut rule and applies the one which corresponds to the
highest haircut value.

• LOWEST: The system looks across all the panels of the haircut rule applies the one which corresponds to the
lowest value.

• AVERAGE: The system looks across all the panels of the haircut rule and calculates an average haircut.

Note: If more than one 'Additional Haircut' is defined, each is considered individually.

Enter a description in the Total Haircut Calculation Description field as needed.

Example 1:
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Example 2: 
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13.4 .2 Tota l F loor Hai rcut
The Total Floor Haircut applies to the total haircut and is the haircut used if the total haircut is lower than this floor. It is
a non-mandatory, editable field that can contain values between 0 and 100 %.

Example 3: 

Total Floor Haircut is 8%
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13.4 .3 Valuat ion Hai rcut Subtype
Choose a Valuation Haircut Subtype: 

– STANDARD: Only one haircut applies regardless of how many static data filters are accepted. (Default
behavior)

– HIGHEST: The system looks for all accepted static data filters and applies the one which corresponds to the
highest haircut value.

– LOWEST: The system looks for all accepted static data filters and applies the one which corresponds to the
lowest value.

– AVERAGE: The system looks for all accepted static data filters and calculates an average haircut.

– ADDITION: The system looks for the accepted static data filters and adds the related haircuts.

For example: German bonds 5%, Pharmaceutical bonds 10%
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If the Valuation Haircut Subtype is ADDITION and a German bond issued by a pharmaceutical firm is being
processed, a 15% haircut is required, not 5% or 10% depending on which rule is applied first (which would be
the result if the rules were listed in the Definition tab and not in Additional Haircuts).

 Ⓘ [NOTE: The order is important in the Definition panel as only ONE definition haircut will apply when using
STANDARD Valuation Haircut Subtype. - The first applicable rule / filter in the list will be used]

13.4 .4 Tenor Matur i ty Date Inc lus ive
Select the Tenor Maturity Date Inclusive checkbox to make the lower limit of the haircut tenor inclusive and the upper
limit tenor exclusive. Otherwise, if un-checked, the lower limit tenor is exclusive and the upper limit tenor is inclusive.

13.5 Panel Descript ions
Enter haircuts on the various panels as needed. Each panel is described below.

Click Save when you are done.

Note: If the Authorization mode is enabled, an authorized user must approve your entry.

13.5 .1 Def in i t ion Panel
The Definition panel allows defining base haircut rules to apply haircut percentages based on security maturities.

» Click to add a rule definition to the Haircut Configuration. You can choose to create the definition from either a
static data filter or from a quote set.

» To define a rule using a static data filter, select "Haircut rule" from the Rule Type drop down, then click ... next to
the Filter field. Select a filter as needed. The securities filter is a static data filter to filter the collaterals to which
the rule applies (bonds, equities, or currencies). For a haircut rule that applies to a cash collateral, in the static
data filter used in the haircut rule, select a product currency and designate the Product Type as Cash.

In the Haircut Points area, add a tenor by entering an integer and selecting D, W, M, or Y, then click . You can
select OPEN to define a haircut for collaterals with no expiration.

The tenor is added to the table below. Enter a haircut percentage.

You can check "Original Maturity" to apply the haircut percentage based on the original maturity of the collateral.
Otherwise, it is applied based on the remaining maturity as of the trade date.
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» To use a quote set, select "Haircut from quote" from the Rule Type drop down. A definition using a quote set rule
handles a security (it can't handle cash) if the quote set has a quote on that day for that security in the CLOSE
column.

If a haircut from quote is either defined at the legal agreement or the margin call contract level, the applicable
haircut quote is picked up to value the inventory of type “Balance * Haircut”.

The haircut quotes must be defined with the quote type “Haircut”.

13.5 .2 Cross Currency Panel
The Cross Currency panel allows defining haircut add-on amounts to be applied based on currency pairs.

» Click to add a cross currency haircut. Complete the fields in the popup window as needed, then click Apply.

– Liability Currency: The currency of the contract.

– Collateral Currency: The currency of the collateral. You can select a currency here or select ANY, SAME, or
CROSS. If SAME is selected, the Liability and Collateral currencies must be the same for the haircut add-on
to be applied. If CROSS is selected, the Collateral Currency must be different from the Liability Currency for
the haircut add-on to be applied.

If ANY is selected for both the Liability Currency and the Collateral Currency, the haircut is applied anywhere
the Liability and Collateral currency are different.

– Collateral Type: The type of collateral, either Cash, Security, or ANY.
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– Filter: Click ... next to the Filter field and select a filter as needed.

» The currency pair is added to the table below. Enter a haircut add-on.

 Ⓘ [NOTE: The order is important in the Cross Currency panel as only ONE cross currency haircut will apply -
The first applicable filter in the list will be used]

13.5 .3 Wrong Way Risk Panel
The Wrong Way Risk panel allows applying an additional haircut in the case of wrong way risk. This type of risk occurs
when the legal entity pledges as collateral a security issued by itself or by a closely related party. Wrong way risk can
also arise if the legal entity country is the same as the country of issuance of the security.

Note that wrong way risk haircut is only applicable when receiving collateral.

» Click to add a wrong way risk haircut.

» Select "Haircut rule" from the Rule Type drop down, then click ... next to the Filter field. Select a filter as needed.
The static data filters added in this panel must have at least one Wrong Way Risk attribute.

 See Wrong Way Risk Setup for details on Wrong Way Risk attributes.

» Add a tenor by entering an integer and selecting D, W, M, or Y, then click . You can select OPEN to define a
haircut for collaterals with no expiration.

The tenor is added to the table below. Enter a haircut percentage.

You can check "Original Maturity" to apply the haircut percentage based on the original maturity of the collateral.
Otherwise, it is applied based on the remaining maturity as of the trade date.

 Ⓘ [NOTE: The order is important in the Wrong Way Risk panel as only ONE wrong way risk haircut will apply -
The first applicable filter in the list will be used]

Wrong Way Risk Setup
Before you can create a wrong way risk haircut rule, some configuration is required.

» Add "WrongWayRisk" to the domain sdFilterCriterion.Factory to create the wrong way risk static data filter
attributes.
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» Create wrong way risk static data filters. These static data filter attributes return true or false.

– Wrong Way Risk.Issuer: Compares the counterparty of the trade to the issuer of the security.

– Wrong Way Risk.Industry: Compares the legal entity attribute INDUSTRY of the counterparty and the
product issuer.

– Wrong Way Risk.Country: Compares the counterparty country (on the Legal Entity window) to the country of
issuance of the security (on the product definition window).

– Wrong Way Risk.Group: Checks whether the counterparty of the trade and the issuer of the security are part
of the same Wrong Way Risk Group. These groups are described in the next step.

» Create Wrong Way Risk Groups to group together legal entities that have a close link.

Add a menu item for the Wrong Way Risk Group window (menu action refdata.WrongWayRiskGroupWindow).

Click to add a new group. You will be prompted to enter a name.

Select the legal entities to be grouped together, then click Save All.

If the Authorization mode is enabled on your system, you can enforce authorization for Wrong Way Risk Groups
by adding "WrongWayRiskGroup" to the domain classAuthMode.

In order to view audits related to Wrong Way Risk Groups, add "WrongWayRiskGroup" to the domain
classAuditMode.

13.5 .4 Addi t iona l Ha i rcuts Panel
The Additional Haircuts panel allows defining additional haircuts based on other haircut rules. The restriction is that
these haircut rules can only have the base haircut rule defined on the Definition panel - They cannot have haircut rules
defined on the Cross Currency, Wrong Way Risk, or Additional Haircuts panels.

As opposed to the other panels, more than one additional haircut can be applied.
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» Click to add an additional haircut. You will be prompted to select a rule name.

13.5 .5 Att r ibutes Panel
The Attributes panel allows adding custom haircut rule attributes.

» Select SetUp > Domain to add haircut rule attributes. Or you can add them directly in the Domain Values window
using the HaircutRuleAttributes domain.

» Select SetUp > Favorites to add haircut rule attributes to your list of favorites. Or you can add them directly in the
Domain Values window using the HaircutRuleAttributes.favorites domain.

» Click to toggle between loading all haircut rule attributes, or only those on your favorites list.

» Enter values for the haircut rule attributes as needed. By default, the values are free text fields. You can create a
drop down menu of choices by creating a domain for each haircut rule attribute as needed in the form
HaircutRuleAttributes.<attribute name> with the possible values.

13.6 Modifying a Haircut Rule
» Click to load an existing rule. You will be prompted to select a rule name. Select a rule definition and modify as

needed.

» Click Save to save your changes.

13.7 Delet ing a Haircut Rule
» Click to load an existing rule. You will be prompted to select a rule name.

» Select a rule definition, and click . You will be prompted to confirm that you want to delete the rule.

13.8 Simulat ing a Haircut Rule
» Click to load an existing rule. You will be prompted to select a rule name.

» Click Simulate to test the haircut rule. (Menu action reporting.ReportWindow$HaircutRuleSimulate.)
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13.9 Haircut Menu
The menu items of the Haircut menu are described below.

Menu Items Description
Load To load an existing rule. You will be prompted to select a rule name.

Pending Authorization To display any haircut pending authorization. This only applies if the Authorization mode is
enabled.

New To create a new rule.

See Creating a Haircut Rule.

Save To save the rule currently loaded, or to save a new rule.

Save As New To save the rule currently loaded as a new rule. You will be prompted to enter a rule name.

Delete To delete a given haircut rule for all securities filters.

See Deleting a Haircut Rule.

Simulate To test the haircut rule.

See Simulating a Haircut Rule.
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14. Defining Sales Margins
Sales margins can be automatically added to trades in the Pricing Sheet and the FX Deal Station based on Sales
Margin Configurations.

14.1 Configuring Sales Margins
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts & Margin Calls > Sales Margin
Configuration to configure Sales Margins. Menu action refdata.SalesMarginConfigurationWindow.

» Enter the fields described below as needed, and click Save.

The default sales margin can be configured based on the following fields:
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Fields Description

Processing Org The processing organization assigned to the trade. (Required field)

Counterparty /
Margin Group

Select either a trading Counterparty or a Margin Group.

See Configuring Margin Groups for more information. (Required field)

Product Select the product to which the sales margin applies. (Required field)

Product Subtype Select a product subtype related to the specified product if desired.

Product Code /
Trade Keyword

Select either a product code associated with the product or a trade keyword.

Attribute Value Enter a trade attribute or keyword for the product depending on the selection of the Product
Code/Trade Keyword field.

Currency / Pair Choose currencies or currency pairs depending on the product selected. (required field)

Channel Type This is the platform for the trade. This is set in the salesMarginChannelType domain.

<= Tenor Enter a tenor for which the margin is valid for trades with a value date up until or equal to the
tenor date.

<= Amoun-
t/Quantity

The specified margin is valid for trades up to or equal to this amount or quantity. For FX swaps,
this is the near leg notional amount.

Buy / Sell Specify whether the trade has to be a buy or sell, or either.

Principal / Agent This is required for bonds, displayed on Pricing Sheet only.

Margin Price
Format

Depending on the product selected, then choose the format of the margin price.

• Points

• Basis Points/Yield - For interest rate products. The margin is calculated off of the interest rate
or yield.

• Basis Points/Price - For some interest rate products, such as bonds, the margin is calculated
off of the price.

• Percentage

• Flat Amount

Margin / Margin
Breakdown

Amount of margin.

Margin Breakdown can be selected when the Product is FX Forward, FX Swap or FX NDF. When
selected, Margin Breakdown adjust Margin entry to dual entry for Spot Margin and Points Margin.

If a trade is entered in FOWS Quick Trade Entry or Deal Station Quick Deal Entry that fulfills the
parameters designed in the Sames Margin Configuration, the designated margin for spot and/or
points will populate the QTE or QDE fields automatically.

Clean / Dirty /
Gross

Select the Clean Price, Dirty Price or Gross Price. Required for bonds, displayed on Pricing Sheet
only.
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Fields Description

Rounding Method Select the rounding method to be used for the margin.

Effective From Enter the date from which the margin rule is valid.

Effective To Enter the expiration date of the margin rule.

14.2 Configuring Margin Groups
A margin group allows you to include many counterparties in one group for the purpose of assigning sales margins. A
margin group is defined through a domain value and added as an attribute in the Legal Entity window.

Assign the margin group name to the domain salesMarginGroup.

Then add the attribute type and value to the desired counterparty in the Legal Entity Attributes window.
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14.3 Applying a Default Sales Margin
The sales margin can be applied in FX Deal Station and the Pricing Sheet using either a Points or Percentage format.

Below are example for how to apply default sales margins in the FX Deal Station and the Pricing Sheet.

14.3 .1 Sa les Marg in in FX Deal Stat ion
Sample Sales Margin Configuration
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In the FX Deal Station, when you enter a trade that fulfills the parameters designated in the Sales Margin
configuration, the margin amount will automatically populate in the Margin field.

You can override the margin amount.

After the trade is saved, the fee amount is displayed in the Results panel.
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You are also able to see the fees in the Fee Details window. This window can be displayed by selecting Trade > Fee
Details from the Title Bar drop-down menu.

For the FX Deal Station, only the FAR_MARGIN and SPOT_MARGIN fee types are supported. You can configure the
calculators used for these fee types in the Fee Definition window.

The calculators provide variations to the default calculation:

If Fee ccy = Trade Quote Ccy, then Fee Amount = [input value] * Quantity (that is, Trade Base Amount).

If Fee ccy <> Trade Base Ccy, then Fee Amount = [input value] * Quantity (that is, Trade Basis Amount = Trade Base
Amount converted using the Trade Spot Price).

The supported calculators are:
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• MarginPtsNoDiscounting - Computes the amount as the above computed margin basis amount and sets the
margin date as the trade settle date.

• MarginPtsNoDiscountingBookBase - Converts the above computed margin basis amount to the book base
currency and sets the margin amount as the same.

The margin date is set as the trade settle date.

Equivalent to the sales user creating a forward for the basis amount against the base currency.

• MarginPtsSpotDiscounted - Computes the margin as the spot discounted amount of the above computed margin
basis amount.

The margin date is set as the spot date of the trade currency pair.

• MarginPtsSpotDiscountedBookBase - Computes the margin as the spot discounted amount of the above
computed margin basis amount against the base currency.

The margin date is set as the spot date of the trade currency pair.

Equivalent to the sales user selling the spot risk against the base currency for the margin basis amount.

The margin basis amount is first discounted to spot of the currency pair and then converted to the base.

• MarginPtsTodayDiscounted - This calculator computes the margin as the today discounted amount of the above
computed margin basis amount.

The margin date is the spot date of the trade currency pair.

• MarginPtsTodayDiscountedBookBase - Computes the margin as the today discounted amount of the above
computed margin basis amount against the base currency.

The margin date is set as today.

Equivalent to the sales user doing a trade today against the margin basis amount currency/base currency pair for
the discounted margin basis amount.

 Ⓘ [NOTE: The calculators used for FAR_MARGIN and SPOT_MARGIN must be the same]

14.3 .2 Sales Marg in in Pr ic ing Sheet
Sample Sales Margin Configuration
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In the Pricing Sheet, when you enter a trade that fulfills the parameters designated in the Sales Margin configuration,
the margin amount will automatically populate in the Sales Fee field.
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You can override the margin amount.

After the trade is saved, the fee amount is displayed in the Trade Fees Details window. This window can be selected
by right clicking in the trade leg (or legs) and selecting Trade Details > Trade Fees. You can also click Ctrl + F.
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The fee type depends on the product types: FXOPT_MARGIN for FX options, SPOT_MARGIN and FAR_MARGIN for FX,
and CA_SALES_MARGIN for all other product types.

14.4 Viewing Sales Margins
For sales margin fee reporting, you can use the Fee report window which is accessed through the Calypso Navigator
under Reports > Fees & Settlements > Fee Report.

See Trade Fees Report for details.

You can also use the Sales Margin analysis which configured in the Analysis Designer.

Please refer to Sales Margin Analysis documentation for details.
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