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Document History

Revision Published Summary of Changes

1.0 February 2024 First revision for version 18.

The following windows allow setting rates and fixing prices:
l The Rate Reset window allows resetting floating rates.
l The FX Rate Reset window allows fixing FX rates for FX NDF trades and FX trades that
have central rate fixings.

l The Price Fixing window allows fixing prices for commodity resets and equity
derivatives trades.
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1. Rate Reset
The Rate Reset window allows resetting floating rates. This is a two-step process:

• You first review and enter the reset rates

• Then you apply the rates to the corresponding flows

You can also use the RATE_RESET scheduled task.

1.1 Resett ing a Rate
From the Calypso Navigator, navigate to Trade Lifecycle > Reset > Rate Reset (menu action
reporting.RateResetFrame).

When you open the Rate Reset window, the Trade Resets panel is selected by default. It allows setting rates for
trades that require rate reset.

To set reset rates rate indices regardless of whether it is used in a trade or not, select the All Resets panel.

See Resetting All Rates for details.

» Enter selection criteria and click Load to load trades that require rate reset during the selected period. You would
typically load the trades that require rate reset today.

Note that when the first reset is set on a trade, the corresponding cashflow will not appear in the Rate Reset
window.

"Use Diary" option - See "Using the Diary Engine" below for details.
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The following indicators apply to flows displayed in the Trade Flows panel:

– “Warn If Publishing Zero” – Check to get a warning upon publishing rates set to 0. Uncheck otherwise.

– “ShowManual Reset Only” – Check to display only flows that were reset manually in the trade windows
(customized cashflow). In order to display manual resets, you also need to check “Include Manual Resets”.
Uncheck otherwise.

– "Use Fallback Rates" - Set to true to use fallback rates on the Fallback Observation Date for Libor trades that
will not be migrated by the Libor cessation date - It only applies if the rate index is defined with
IndexCalculator = FallbackISDA. Please refer to Calypso Getting Started documentation for complete details
on setting up the rate index for fallback pricing and resetting.

The checkboxes ShowManual Reset Only, Include Manual Resets, and Use Diary should be unchecked
when Use Fallback Rates is checked. When Use Fallback Rates is checked, the All Resets tab is disabled.

– “Include Manual Resets” – Check to display flows that were reset manually in the trade windows
(customized cashflow) in addition to flows that need reset. Uncheck otherwise.

– “Show Only New Resets” – Check to display only flows that have not yet been reset.

– “Hide Pure Reset Sample” – Check to only display simple flows and not compounded flows. Uncheck
otherwise.

» Click Show to display the rates that need to be reset.

If the rates are already populated, they will appear. You can click Refresh Rates to get the latest rates.

To subscribe to a source feed, click Subscribe. The rates will be populated accordingly.

Or you can enter the rates directly.

» Click Save to save the rates.

The rates can be viewed in the trades’ cashflows.

Using the Diary Engine
The Diary engine allows recording trade lifecycle events such as rate resets for all the trades in the system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

1.2 Applying a Reset Rate
Select the Trade Flows panel and click Show to display the actual flows that need reset.
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 Ⓘ [NOTE: Trade flows highlighted in gray, correspond to customized trade flows]

» Click Calc to apply the rates to the flows. The rate amount will be calculated.

For a specific reset, or a manual reset, the rate is retrieved from the trade.

» Click Publish to update the corresponding transfers.

The system publishes RATE_RESET events. The Transfer engine subscribes to these events to modify the
corresponding transfers (make sure that the step PENDING - AMEND - PENDING is configured in the transfer
workflow). The Message engine subscribes to these events to generate Rate Reset notices (provided message
configurations are defined). The Accounting engine subscribe to these events to generate rate reset postings.

You can also select a set of flows and click Publish Selections.

When the environment property CHECK_SAME_USER_RATE_RESET_PUBLISH is set to true, a user is not allowed
to publish a rate that he or she has saved. Another user must publish the rates.

[NOTE: The Save button and action are used for terminating conditional trades only. This applies to flexible and
chooser cap floors once they reach their number of uses – See Resetting Flexible and Chooser Cap Floors for
details]

1.3 Resett ing Flexible and Chooser Cap Floors

1 .3 .1 F lex ib le Cap Floor
When resetting a flexible cap floor, you will notice that the Exercise box is checked by default, and you should keep it
this way. As long as the number of uses is not reached, the Terminable column indicates “No”.

Nasdaq Calypso
Rate Reset and Price Fixing / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 6 / 22



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 7 / 22

» Publish the rates, then select an action (AMEND, UPDATE, or a custom action) and click Save. The number of uses
will be updated on the trade.

After the number of uses has been reached, the Terminable column will indicate “Yes”.

» After you have published the rates, select an action (AMEND, UPDATE, or a custom action) and click Save to
terminate the cap floor. The trade will move to status TERMINATED and the termination keywords will be
populated.

1 .3 .2 Chooser Cap Floor
When resetting a chooser cap floor, you can decide if you want to use the cap floor or not. As long as the number of
uses is not reached, the Terminable column indicates “No”.

» Publish the rates. If you want to exercise the cap floor, check the Exercise checkbox, select an action (AMEND,
UPDATE, or a custom action) and click Save. The number of uses will be updated on the trade.

After the number of uses has been reached, the Terminable column will indicate “Yes”.

» Publish the rates. If you want to exercise the cap floor, check the Exercise checkbox, select an action (AMEND,
UPDATE, or a custom action) and click Save. The trade will move to status TERMINATED and the termination
keywords will be populated.
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1.4 Resett ing al l Rates
To reset or review all rates defined in the system, regardless of whether they are used in trades or not, select the All
Resets panel.

» Select a rate index from the Index field, and click Show. You can enter the rate for every day within the selected
period.

» You can also click Show All to display all rate indices defined in the system.

1.5 Uti l i t ies Menu
The menu items of the Utilities menu are described below.

Menu Items Description
Configure Columns To open the Configure Columns window that allows you to select what columns you want to

display, and to specify the order in which you want to display the columns.

Configure Sort To open the Selector window that allows you to select sort columns and the sort order. Only
columns that have been selected for display can be used for sorting.

Sort To sort according to the selected sort configuration.

Export to HTML To export the panel currently selected to an HTML file.

Export to Excel To export the panel currently selected to an Excel file.
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Menu Items Description
Print To print the panel currently selected.

Print Landscape To print the panel currently selected.

Ensure Postings
Loaded

This menu item operates as a checkbox.

Check to ensure that all postings for the selected trades are pre-loaded in the Data Server
so that the accounting matching process is faster. This only applies if you generate postings
for RATE_RESET events.

Close To close the Rate Reset window.

Secondary Market
Processing

This menu item operates as a checkbox.

Check to enable processing for secondary market products. Rate reset is done by position
rather than by trade. A PSEventCARateReset is generated per position. The flows in the
Trade Flows panel correspond to positions.

Otherwise, secondary market products will be reset trade by trade.
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2. Rate Reset Report
This document describes how to use the Rate Reset report. The Rate Reset report displays upcoming resets for a
single day or over a period.

From the Calypso Navigator, navigate to Reports > Rate Reset Reports > Rate Reset to bring up the report.

 Ⓘ [NOTE: The columns can be configured. Sort columns, subheadings and subtotals have to be explicitly
specified. See Help > Menu Itemsfor details]

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Specify search criteria as applicable and click to load the corresponding trades that need to be reset.

[NOTE: The Start and End dates are mandatory]

– "Use Diary" option - See "Using the Diary Engine" below for details.

– “Show Only New Reset” – Check to display only flows that have not yet been reset.
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– “Hide Pure Reset Sample” – Check to only display simple flows and not compounded flows. Uncheck
otherwise.

– “Highlight Overdue Resets” – Check to highlight flows for which the reset is overdue.

– “ShowManual Reset” – Check to display only flows that were reset manually in the trade windows
(customized cashflow). In order to display manual resets, you also need to check “Include Manual Reset”.
Uncheck otherwise.

– “Include Manual Reset” – Check to display flows that were reset manually in the trade windows (customized
cashflow) in addition to flows that need reset. Uncheck otherwise.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Us ing the Dia ry Eng ine
The Diary engine allows recording trade lifecycle events such as rate resets for all the trades in the system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

Rate Rese t Repor t Resu l t s
The information displayed in this report matches the data displayed in the Rate Reset Window for the same date.

You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.
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3. Rate Reset Overdue Report
This document describes how to use the Rate Reset Overdue report. The Rate Reset Overdue report displays reset
rates that have not been set for a single day or over a period.

From the Calypso Navigator, navigate to Reports > Rate Reset Reports > Rate Reset Overdue to bring up the report.

 Ⓘ [NOTE: The columns can be configured. Sort columns, subheadings and subtotals have to be explicitly
specified. See Help > Menu Itemsfor details]

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Specify search criteria as applicable and click to load the corresponding trades that need to be reset.

[NOTE: The Start and End dates are mandatory]

– "Use Diary" option - See "Using the Diary Engine" below for details.
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– “Show Only New Reset” – Check to display only flows that have not yet been reset.

– “Hide Pure Reset Sample” – Check to only display simple flows and not compounded flows. Uncheck
otherwise.

– “Highlight Overdue Resets” – Check to highlight flows for which the reset is overdue.

– “ShowManual Reset” – Check to display only flows that were reset manually in the trade windows
(customized cashflow). In order to display manual resets, you also need to check “Include Manual Reset”.
Uncheck otherwise.

– “Include Manual Reset” – Check to display flows that were reset manually in the trade windows (customized
cashflow) in addition to flows that need reset. Uncheck otherwise.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Us ing the Dia ry Eng ine
The Diary engine allows recording trade lifecycle events such as rate resets for all the trades in the system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

Rate Rese t Overdue Repor t Resu l t s
You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.
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4. Rate Reset Validation Report
This document describes how to use the Rate Reset Validation report. The Validation Report displays information
related to rate reset that have been entered and authorized through the Rate Reset process.

From the Calypso Navigator, navigate to Reports > Rate Reset Reports > Rate Reset Validation to bring up the
report.

 Ⓘ [NOTE: The columns can be configured. Sort columns, subheadings and subtotals have to be explicitly
specified. See Help > Menu Itemsfor details]

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Specify search criteria as applicable and click to load the corresponding trades that have been reset.

[NOTE: The Start and End dates are mandatory]

– "Use Diary" option - See "Using the Diary Engine" below for details.
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– “Show Only New Reset” – Check to display only flows that have not yet been reset.

– “Hide Pure Reset Sample” – Check to only display simple flows and not compounded flows. Uncheck
otherwise.

– “Highlight Overdue Resets” – Check to highlight flows for which the reset is overdue.

– “ShowManual Reset” – Check to display only flows that were reset manually in the trade windows
(customized cashflow). In order to display manual resets, you also need to check “Include Manual Reset”.
Uncheck otherwise.

– “Include Manual Reset” – Check to display flows that were reset manually in the trade windows (customized
cashflow) in addition to flows that need reset. Uncheck otherwise.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Us ing the Dia ry Eng ine
The Diary engine allows recording trade lifecycle events such as rate resets for all the trades in the system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

Rate Rese t Va l ida t ion Repor t Resu l t s
You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.
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5. FX Rate Reset
The FX Rate Reset window allows fixing FX rates for FX NDF trades and FX trades that have central rate fixings. This is
a two-step process:

l You first review and enter the FX rates
l Then you apply the rates to the corresponding flows

You can also use the FX_RATE_RESET scheduled task.

You can run the FX Rate Reset report to display FX reset requirements for today - From the Calypso Navigator,
navigate to Reports > Rate Reset Reports > Rate Resets > FX Rate Reset Report (menu action
reporting.ReportWindow$FXRateReset).

5.1 Setup Requirements

5.1 .1 Workf low
Configure RATERESET as a workflow Action, if not already configured. To do this, add RATERESET to the tradeAction
domain value.

Be sure that the task PENDING - AMEND - PENDING is configured in the transfer workflow.

5.1 .2 Events
Make sure that the following engines subscribe to PSEventFXRateReset: Accounting engine, Diary engine, Message
engine, Position engine, and Transfer engine.

5.2 Sett ing FX Rates
From the Calypso Navigator, navigate to Trade Lifecycle > Reset > FX Rate Reset to reset today’s FX rates.
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» Select a pricing environment and a trade filter.

» Click Load Resets to display the FX rates that need to be fixed today.

"Use Diary" option - See "Using the Diary Engine" below for details.

The FX Rate Fixings panel displays the rates that require resetting.

» Enter the rates.

» Click Save Resets.

The rates can be viewed in the trades' cashflows.

Forward Starting FX Options
If the calculated strike for Fwd Starting FX options is manually amended, the trade keyword "FXResetInput" is set to
"Manual".

Using the Diary Engine
The Diary engine allows recording expected trade lifecycle events such as FX rate resets for all the trades in the
system.

Nasdaq Calypso
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If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

5.3 Applying FX Rates
Select the Trade Flow Fixings panel.

» Select the trades you want to reset, and click Calculate to compute the settlement amount.

The application automatically checks the "Need Save" and "Need Publish" checkboxes.

» You can select an action to apply to the trades, it is AMEND by default.

You can set the default action in domain "fxRateResetAction" - FXRESET for example.

You can click Set All to apply the action to all trades.

» Click Publish to update the corresponding transfers.

The system publishes FX_RATE_RESET events. The Transfer engine subscribes to these events to modify the
corresponding transfers (make sure that the step PENDING - AMEND - PENDING is configured in the transfer
workflow). The Message engine subscribes to these events to generate FX Rate Reset notices (provided
message configurations are defined). The Accounting engine subscribe to these events to generate rate reset
postings.

You can also select a set of flows and click Publish Selections.

When the environment property CHECK_SAME_USER_RATE_RESET_PUBLISH is set to true, a user is not allowed
to publish a rate that he or she has saved. Another user must publish the rates.

» Click Save Trades to amend the trades.

You can view the updated transfers in the BO Browser.
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6. FX Rate Reset Report
This document describes how to use the Rate Reset report. The FX Rate Reset Report displays FX reset requirements
for a single day or over a period.

From the Calypso Navigator, navigate to Reports > Rate Reset Reports > FX Rate Reset Report to bring up the
report.

 Ⓘ [NOTE: The columns can be configured. Sort columns, subheadings and subtotals have to be explicitly
specified. See Help > Menu Itemsfor details]

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Specify search criteria as applicable and click to load the corresponding trades that need to be reset.

[NOTE: The Start and End dates are mandatory]

– "Use Diary" option - See "Using the Diary Engine" below for details.

– “Show Only New Reset” – Check to display only flows that have not yet been reset.

Nasdaq Calypso
Rate Reset and Price Fixing / Version 18



– “Hide Pure Reset Sample” – Check to only display simple flows and not compounded flows. Uncheck
otherwise.

– “Highlight Overdue Resets” – Check to highlight flows for which the reset is overdue.

– “ShowManual Reset” – Check to display only flows that were reset manually in the trade windows
(customized cashflow). In order to display manual resets, you also need to check “Include Manual Reset”.
Uncheck otherwise.

– “Include Manual Reset” – Check to display flows that were reset manually in the trade windows (customized
cashflow) in addition to flows that need reset. Uncheck otherwise.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Using the Diary Engine
The Diary engine allows recording trade lifecycle events such as rate resets for all the trades in the system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

FX Rate Rese t Repor t Resu l t s
The information displayed in this report matches the data displayed in the FX Rate Reset Window for the same date.

You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. See Help > Menu Items for details.
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7. Price Fixing
Use the price fixing process to fix prices and apply them to the cashflows. This applies to commodity resets, and
equity derivatives trades.

Note that you can also set the FX quotes required in the price fixing of cross-currency trades, and the price fixing of
precious metal trades.

From the Calypso Navigator, navigate to Trade Lifecycle > Reset > Price Fixing (menu action
reporting.PriceFixingFrame).

The Price Fixing Window contains two panels. The Prices panel gives you a summary of all the Prices in the system for
your chosen period. The Trade Flows panel shows you only the cashflows for which saved trades require Prices within
your specified period.

To work in the spreadsheet tables, click any row to highlight it, and double-click any cell to edit it. Rows that you have
edited but not saved will be shown in blue-green. Rows that you have saved will be shown in yellow.

• Prices Panel — Set the criteria in the top of the window and click Load. The Prices panel displays all of the prices
and FX quotes that require setting, according to the criteria that you specified. You can get the price from a feed
or enter it manually.

"Use Diary" option - See "Using the Diary Engine" below for details.

Select the feed from the drop-down menu and click Subscribe.

Enter the price in the Quote field. Click Save to save the price to the quote set.

• Trade Flows— Calculate and apply the amount for the cashflows.

Click Show to display the flows requiring resetting.

Nasdaq Calypso
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Click Calc to calculate the amount of the cashflows.

Click Publish to apply the prices to the cashflows. This also generates payments and advices for approval in the
Task Station.

Click Publish Selections to apply the prices to the selected flows only.

Using the Diary Engine
The Diary engine allows recording expected trade lifecycle events such as price fixings for all the trades in the
system.

If the Diary engine is configured to subscribe to trade events, the "Use Diary" checkbox is checked by default. In that
case, the system only loads trades that have diary entries, for optimization purposes. This requires the Diary engine to
be running.

Refer to Calypso Trade Diary documentation for details on running the Diary engine.

You can clear the checkbox if you do not want to use the Diary engine.

 Ⓘ [NOTE: You may also set up and run the PRICE_FIXING scheduled task]
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