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This document describes how to get started with the Calypso system using the Calypso
Navigator that provides access to all areas of the system. It also provides overviews of the
various areas of the system: running modes, reporting, and back office.
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1. Logging In
In the login window for the Calypso Navigator, select the name of your Environment from the Env field. The
Environment contains your default user login information: username, password, database connection, environment
properties, etc.

Login window

» The next time you log in, you will probably want to use the same Environment. You can click Set As Default Env to
make it your default Environment.

» Once the correct User and Password appear in the window, click OK to log in.

 Ⓘ [Important NOTE: If you modify the Environment, you need to deploy the changes to your application
servers. Please refer to the Calypso Installation Guide for details]
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2. Calypso Navigator
Once you have logged in into the Calypso Navigator, you can navigate to the various applications of the system.

The default settings are shown below. These default settings can be configured to suit individual users.

You can search for applications using the search icon , and the list of corresponding menu items will be displayed
for selection.

From this window, you can access all areas of the system:

• User Menu – You can add custom menu items to this menu. Choose User Menu > Configure to add menu items.

• Configuration – Access to data configuration functions. Minimum data requirements to operate the system are
described in this document. All other configuration data are described in their respective user guides: messages,
settlements, accounting, etc.

• Market Data – Access to market data configuration functions. Market data requirements to price trades are
described in their respective asset class user guides: interest rate derivatives, credit derivatives, FX, fixed
income, etc.

• Pricing – Access to pricing sheets.

• Trade – Access to individual trade worksheets. Trades are described in their respective asset class user guides.

• Position & Risk – Access to position reports, and risk reports. Position reports are described in their respective
asset class user guides. Risk reports are described in the risk analyses user guide and scenario analyses user
guide.

The Risk favorite button brings up the risk analysis configuration window that allows defining a set of risk
analyses with the risk factors to analyze.

TheWorkstation favorite button brings up the Calypso Workstation that allows viewing risk analyses results.

• Reports – Access to data reports. They are described in their respective user guides: messages, settlements,
accounting, etc.

See Reporting Overview for general information.
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• Deal Management – Access to trade review tools. They are described in their respective asset class user guides.

• Trade Lifecycle – Access to trade enrichment tools. They are described in their respective asset class user
guides.

• Processing – Access to back office tools. They are described in their respective user guides: messages,
settlements, accounting, etc.

The Taskstation favorite button brings up the Task Station that allows monitoring the back office activity.

See Back Office Overview for general information.

• Utilities – Provides access to utility functions.

Please refer to Calypso Utilities Menu documentation for details.

• Help – Provides access to Help functions.

See Help Menu for details.

In particular, Help > Search Documentation allows accessing all documents.

All these menus can be configured to suit the user activity, except for the Utilities menu. But you can set access
permissions so that the user will not have access to the Utilities menu.

You can open multiple windows at once, all windows being started are shown in the "window management panel":

Performance Improvement
A number of report attributes can be pre-loaded with the Calypso Navigator. The report types need to be added to
domain "MEPreload". Report types can be found in domain "REPORT.Types".

By default the attributes of the following reports are pre-loaded: BOCashPosition, BOSecurityPosition, BOBrowser.

Defining Menu Items and Favorites
Menu items and favorites are defined using Main Entry Customizer.
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See Main Entry Customizer for details.

You can click to display / hide the menu items.

You can click to display / hide the favorites.

You can click to display / hide the list of open windows.

You can click to select the layout of the Calypso Navigator.

When you choose > Preferences, you can choose additional settings, and re-arrange favorites using drag and
drop.

Viewing Log Information

Click to view log information.

Minimizing the Window and Exiting

Click to minimize the Calypso Navigator.

Click to exit.
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3. Help Menu
The menu items of the Help menu are described below.

 Ⓘ [NOTE: Accessing the Help menu from the Calypso Navigator requires the setup of the environment
property HELP_LOCATION]

Menu Items Description

About Displays the Calypso Data Server name; Access Permission, Authorization, and Workflow
settings; JVM information; and host system information.

You can click More Info to view the More Info window. Tabs on More Info window list version
information for Calypso applications and the Classpath.

Search
Documentation

Launches the Calypso Documentation Portal.

Release Notes Not used.

Class Library Not used.

Domain Values Opens the Documentation Portal to the page listing Domain Values available throughout the
system.

Shortcuts Opens the Documentation Portal to the page listing keyboard shortcuts available throughout the
system.

Day-Count
Conventions

Opens the Documentation Portal to the Daycount conventions page. Daycounts are used
throughout the system for calculating the number of days in a period.

Date Roll
Conventions

Opens the Documentation Portal to the Date Roll conventions page. Date Rolls are used
throughout the system to roll dates that fall on business dates.

Quotes Types Opens the Documentation Portal to the page describing the quotes types methods used
throughout the system.

Rounding
Methods

Opens the Documentation Portal to the page describing the rounding methods used throughout
the system.

Message
Template
Keywords

Opens the Documentation Portal to the page describing the keywords used in message
templates.

Report Template
Keywords

Opens the Documentation Portal to the page listing keywords used in report templates.
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4. Configuring the Calypso Navigator
From the Calypso Navigator, navigate to Utilities > Main Entry Customizer to configure the Calypso Navigator.

Main Entry Customizer window

» Select the Menu Bar panel to configure the menus, or the Favorites panel to configure favorite applications.

 Ⓘ [NOTE: The Utilities menu cannot be customized - If necessary, the Utilities menu can be hidden for a
given group of users using the access permission restriction HideUtilitiesMenu]

» Select a user from the list of users.

» Click Load to load the configuration for that user. If no configuration has been saved, click Defaults to load the
default configuration so that you can modify it as applicable.

See Default Configuration below for details on the default configuration.

The selected configuration will appear in the Menu Bar and Favorites panels.

On the Menu Bar panel, double-click menu levels to navigate the menu hierarchy.

Right-click any menu level to display the popup menu shown below.

When adding a menu item, you need to give it a name, and set the Action to the class name.
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Example: trading.TradeGenericOptionWindow

On the Favorites panel, right-click anywhere to display the menu shown below.

When adding a favorite application, you need to give it a name, and set the Action to the class name.

– Select a color and an icon for the favorite to distinguish the tile as it appears among other favorites below
the Navigator menu items.

– You can also apply a shortcut key to any favorite so that the application can be opened quickly from the
keyboard. Add any letter A through Z in the "Key" field to assign a letter to the shortcut. Press "Alt" plus the
letter to open the application. The shortcut does not accept numerals or other key combinations.

– Once the favorite appears in Navigator, you can right-click the tile to open a menu that provides options for
editing, adding, duplicating, and rearranging favorites.
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» You can click Clear to clear all modifications to the menu. It will bring back the original menu, including the User
Menu. Then make sure to save before exiting.

» Click Save to save the current configuration for the selected user.

» You can click Duplicate to copy the current configuration to another user. You will be prompted to select another
user.

» Click Close to close the Main Entry Customizer window.

» Click Duplicate for Group to copy the current configuration to another group. You will be prompted to select
another group.

» Click Merge Default (by Drag & Drop) to merge the default configuration with the current configuration. The default
configuration will appear in a separate window. Select a menu item or menu level from the default configuration,
and drag and drop it to a menu level in the current configuration (hold the mouse button pressed down and
release where desired).

 Ⓘ [NOTE: You need to close and restart the Calypso Navigator in order for the configuration to take effect]

Default Configuration
To load another configuration than the default one, you need to have the environment property MAINENTRY_
CUSTOMIZER_SHOW_DB_FLAG set to true. In this case, a DB checkbox will appear in Main Entry Customizer as
shown below.

» Clear the DB checkbox and click Load. You will be prompted to select a resource file.

» Then check the DB checkbox and click Save. The selected file will be set as the new default configuration.

 Ⓘ [NOTE: The DB checkbox does not apply to favorites, only menu items - To load favorites from another
environment, please use the Configuration Management Tool (CM Tool)]

Any application which implements com.calypso.apps.main.LauncherInterface can be added to the Calypso
Navigator via the Main Entry Customizer. Furthermore, by implementing the method setArgs(), any string appended to
the action will be passed as an argument.

For example, if the action is defined as “util.MyApplication my params”, an instance of the class
calypsox.util.MyApplicationwill be created and the method setArgs(“my params”)will be called.
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5. Setting User Locale and Timezone
This topic describes the configuration of the locale and timezone, and provides date and time considerations.

5.1 Configurat ion
From the Calypso Navigator, navigate to Configuration > Definition > Locale Configuration to set your locale and
timezone for the current session.

Locale Configuration window

» Select a locale and a timezone as needed, then click Apply.

Locale
The locale defaults to the locale specified in your User Defaults if specified, or in your Environment otherwise. You can
set the locale in this window for the current session only. When you exit the Calypso Navigator, the locale will be reset
to the locale specified your User Defaults if specified, or in your Environment otherwise. Therefore, if you need to
change your locale permanently, please do so in the User Defaults or Environment (the locale specified in the User
Defaults for a given user takes precedence over the locale specified in the Environment).

Timezone
The timezone defaults to the timezone specified in your User Defaults. You can set a timezone in this window for the
current session only. When you exit the Calypso Navigator, the timezone will be reset to the timezone specified in the
User Defaults. Therefore, if you need to change your timezone permanently, please do so in the User Defaults.

All dates and times are displayed in the selected timezone for the current user.

However, all dates and times are saved to the database in the reference timezone. The reference timezone is set at
implementation time in the database table calypso_info. It is GMT by default.
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calypso_info database table

 Ⓘ [NOTE: Once the reference timezone is set, it cannot be changed]

5.2 Date and Time Considerat ions
Some date fields are displayed as a date (for example the Settlement date is displayed as DD/MM/yyyy), while others
are displayed as a date and time (for example the Trade Date is displayed as MMM DD, yyyy HH:MM AM/PM).

The choice of format is not arbitrary, it depends on the need to refer to a specific time and timezone:

• A date is used when the time and timezone are not relevant. For example: Settlement Date, Maturity Date.

A date simply represents a Julian date.

• A date and time is used when time and timezone are important such as for recording the exact time of day that a
trade was executed, or a record updated.

For example, if an AUD/USD FX Option expires on Wednesday at 10:00 am in Sydney, a trader in New York should
be able to see that the same trade expires on Tuesday at 8:00 pm in New York.

A date and time uses the Java Calendar to be able to order objects in strict chronological order regardless of the
timezone.

Valuation Datetime, Update Datetime, Undo Datetime
Strict chronological requirements of the system (such as audit and kick-off/cut-off processing) are driven by date and
time fields set by the Data Server. This allows the Data Server to retrieve a trade as of a specific date and time
(reconstructed from the audit trail for example) so that it can perform analysis and batch processing as of specific
times without having to block users from entering new trades or updating existing trades.

• Records in the database are timestamped with an Update Datetime which is used to audit changes.

• Risk analyses and scheduled tasks can specify an Undo Datetime, a point in time that trades will be rolled-back to
for the purposes of processing. The trade may have been amended since then but will be recreated as it was at
the Undo Datetime for this specific request.

• The Valuation Datetime specifies the point in time that a processing is deemed to be occurring. For example, if
Valuation Datetime is 5:00 pm, then only the trades entered before 5:00 pm will be processed, and the process
will use market data as of the Valuation Datetime.

Using the Portfolio Manager as an example, we have the following settings:
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Valuation Datetime = 14:23:52

Undo Datetime = 13:00:00

We can see from the audit trail on this trade that the trade will be included in the process because it existed before
14:23:52, but it will be rolled back to version 0 because it was amended at 13:17:19, and we want to consider all trades
as of 13:00:00.

The "undo" feature is driven by the audit trail and timestamp generated by the Data Server, so the date and time of
the user has no impact.

User versus Data Server Date and Time
The date and time of the user is used to display dates and times, and it may be different from the date and time of the
Data Server.

From the Calypso Navigator, you can navigate to Utilities > Check Server Time to check their respective date and
time.
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To avoid any confusion (like capturing back-dated trades inadvertently), you can enforce a limit to the difference
between the Server Time and the Client Time using the environment property MAX_DIFF_TIME. It is set in ms, and
defaults to 3600000 (1 hour).

If the difference is more than MAX_DIFF_TIME, the Client application will not start.
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6. Defining Domain Data
Domain data are the most basic data required for operating the system, such as typed lists that will be available for
selection from the various windows.

Some domain data are user-defined (like custom attribute values), while others are dictated by the system (like legal
entity roles).

From the Calypso Navigator, navigate to Configuration > System > Domain Values (menu action
refdata.DomainValueWindow) for defining domain data.

You can find a description of out-of-the-box domains under Help > Domain Values.

6.1 Searching Domains
All domains are loaded by default when you open the window.

» Scroll through the list of domains on the left-hand side to find a domain.

Double-click a domain to display its values.

» You can also type in a few characters in the search field and click the up or down arrows to search forward or
backward. The first domain that contains the specified characters will be selected. Click the up or down arrows
again to search the next domain as needed.
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You can check the Value checkbox to search domain values rather than domain names.

6.2 Adding Domain Values
» Select a domain from the left-hand side.

» On the right-hand side, enter a domain value in the Value field, and a description in the Comment field as
applicable.

Then click Add. Repeat as needed to add multiple values.

» At the top, click Save to save the domain currently selected, or Save All to save all domains.

You can also click Add & Save to add the value and save the current domain at the same time.

» Click Reload to make the new values available.

Sample Usage

Sample Bond Product definition
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6.3 Sett ing Domain Constraints
Setting domain constraints requires the access permission function CreateDomainConstraints.

» Click Constraints Setup to invoke the Domain Constraints window for setting character limits on the domain values
of a given domain.

Click Add to add a constraint. Then select a domain from the Domain Value field, and enter a minimum length and
a maximum length.

Click Save. The constraint ensures that the values entered for that domain are within the specified range of
characters.

In the example above, when you select the "bondStatus" domain and add the value AUTHORIZED, an error
message will popup indicating that the value violates the constraint because it is more than 8 characters long.

6.4 Adding Domains
Domains are registered in the "domainName" domain.

To add a new domain, add the name of the domain you wish to create as a value to the "domainName" domain.

» Select the "domainName" domain and enter the name of the domain you wish to create in the Value field.

» Then click Save to save the domain currently selected, or Save All to save all domains.

» Click Reload to make the new domain available for selection, "ThisDomain" in this example.

Select the new domain, and add values as applicable.
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6.5 Authorizat ion in Domain Values
Calypso has enabled authorization for Domain Values to prevent unapproved or unauthorized modifications to
existing values or additions. It allows user to enable / disable the authorization in Domain Values. By default
authorization in Domain Values is disabled.

To enable authorization in Domain Values, follow the below steps:

» Enable data authorization (by setting CALYPSO_DATA_AUTHORIZATION_ENABLED to true). The user should be
able to add or save domain values without an authorization prompt.

» Now, open the Domain Values window and add DomainValues class in classAuthMode to enable authorization of
Domain Values.

» So, now whenever you add a Domain Value in the Domain Value window and click on Save, Save All or Add & Save.
A pop-up will be generated stating "Authorization Required".
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» After adding the Domain value, if you click on the Reload button, the newly added Domain Value will disappear
because the changes are not yet approved.

» Now, open the authorization window, click on Refresh button.

» To view the details of the added Domain Values double-click on the row. You can accept / reject the change
accordingly. Once accepted, reload the Domain Values window, the newly added domain value will be shown and
if rejected the domain value will not be added.

Similar steps will be followed to Removethe Domain Value for the user.
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7. Domain Values List
This document describes the domains provided out-of-the-box.

Domains Description
<product type>.Pricer Pricers for the selected <product type>.

You can create a custom pricer, register it in this domain, and define it in the
Pricer Config.

Refer to the Calypso Developer's Guide for details about creating a custom
pricer.

<product type>.subtype Product subtypes for the selected <product type>.

Out-of-the-box subtypes for each product are described in the
corresponding Asset Class user guide.

You can add subtypes as needed.

In the Pricer Config, you can assign different market data and pricers by
product subtype.

<product type>.extendedType Extended types for the selected <product type>.

Out-of-the-box extended types for each product are described in the
corresponding Asset Class user guide.

You can add extended types as needed.

In the Pricer Config, you can assign different market data and pricers by
extended type.

absMktDataUsage Usage codes for assigned ABS Market Data Items.

absMktDataUsage.DEFAULT Stores the types of curves that can be used with the DEFAULT usage. The
CurveDefault is registered in this domain out-of-the-box.

absMktDataUsage.DELINQUENCY Stores the types of curves that can be used with the DELINQUENCY usage.
The CurveDelinquency is registered in this domain out-of-the-box.

absMktDataUsage.PREPAY Stores the types of curves the can be used with the PREPAY usage. The
CurvePrepay is registered in this domain out-of-the-box.

absMktDataUsage.REC Stores the types of curves that can be used with the REC usage. The
CurveRecovery is registered in this domain out-of-the-box.

accBookClassification Accounting book classification. Add values to this domain that you can select
in the Accounting Book application to specify the intent of the accounting
book (examples include Trading, AmotizedCost, and AmortizedValue).

accCurType Accounting currency conversion rules for types of currency in the accounting
system.
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• EURO – Specifies that posting is in Euros.

• TRADE – Specifies that posting is in the trade currency.

accEventClass Accounting event classes used by the Accounting engine. Categorizes the
posting records. You can add values to this domain.

Please refer to Calypso Accounting Postings documentation for details.

accEventProperty Labels to be placed on an Accounting Event Config, indicating classification
for Transfer Accounting. You can add properties to this domain.

Please refer to Calypso Accounting Postings documentation for details.

accEventType Accounting event types contain a definition for the permitted types of
accounting entries.

Refer to Calypso Accounting Events documentation for a description of the
accounting events.

You can add custom accounting events to the accEventType domain. Define
custom accounting events in a custom AccountHandler class.

Refer to the Calypso Developer's Guide for details.

accountActiveStatus In Accounts Definition, you can add status for classifying active accounts.

AccountCalculationType Types of account position calculations. Calypso includes Interest.

accountClosedStatus In Accounts Definition, you can add statuses for classifying closed accounts.

AccountHolderRole Used in acc_account to indicate the role of a CallAccount.

accountPendingStatus In Accounts Definition, you can add statuses for classifying pending account.

accountProperty In Accounts Definition, you can add properties that contain information about
the account.

AccountSettleMethod Used in acc_account to indicate the SettleMethod of the sdi linked to a
CallAccount.

accountStatus In Accounts Definition, you can add statuses for classifying SETTLE
accounts.

accountSuspendedStatus In Accounts Definition, you can add statuses for classifying suspended
accounts.

accountType Used in acc_account and acc_rule_config to indicate the type of a GL
account or custodian account.

Please refer to Calypso Accounting Postings documentation for details.

accRuleType Labels to be placed on an accounting rule, indicating classification.

Please refer to Calypso Accounting Postings documentation for details.

addressMethod The Sender engine uses DocumentSender objects to send message
documents to a given address method or gateway. The addressMethod
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domain stores the address methods.

Refer to the Calypso Developer’s Guide for details about creating custom
DocumentSender objects.

Define the address method for a legal entity by clicking Contact in the Legal
Entity window.

AllocationSupported Used in the new allocation framework. Contains a list of products for which
the Allocation menu will be displayed in the trade worksheet under Back
Office > Allocate.

AmendGroup You can amend workflow of message for checking advice messages. You
have the value as workflowRuleMessage.

analysisParameter Analysis parameters defined when running risk analysis reports.

You can create custom parameters when creating a custom analysis.
Register the custom parameter names in the analysisParameter domain.

Refer to the Calypso Developer’s Guide for details.

applicationName You can assign access permissions in the Access Window > Group Access
panel for applications that a group of users may run. The default value is _
ALL_.

You can add engine and application names in the applicationName domain in
order to assign the access permission to run it.

asianOptionType Types of Asian options that you can trade in the FX Option trade window.

Calypso out-of-the-box includes the following types of Asian options:

• AVERAGE RATE – Average rate on the sample dates.

• AVERAGE STRIKE – Average strike on the sample dates.

• GEOM AVERAGE RATE – Geometric average rate on the sample dates.

• GEOM AVERAGE STRIKE – Geometric average strike on the sample
dates.

• MAXIMUM – Maximum on the sample dates.

• MINIMUM – Minimum on the sample dates.

AssetSwapPrincipalStructures The schedule principal structures that you can select from the Asset Swap
trade window. The default value is Schedule.

You can create custom principal schedules, and register them in the
AssetSwapPrincipalStructures domain.

Refer to the Calypso Developer’s Guide for details.

assetSwapRedemptionFeeType Stores the redemption fee type for asset swaps. REDEMPTION_FEE is
defined out-of-the-box.
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assetSwapUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

attributeType Components of automatic account names for GL accounting.

auditReportRestrictable Controls what can be seen in the Audit Report. If the same classes are
assigned to this domain and in the audit report restriction in group access for
your user, then you will not be able to see them.

autoExercise Add the names of secondary market products that are options. Use this
domain with the AUTOMATIC_EXERCISE scheduled task to automatically
exercise the options that are in-the-money.

averageType Methods for averaging rate resets, including the following: OIS, SIMPLE,
UNWEIGHTED, WEIGHTED.

BalanceInitDate Balance initialization date. Add dates that populate the InitDate attribute
drop-down list in the BALANCE scheduled task.

BankingPriority Swift message support for field 113 <banking priority> in Swift Block 3 / User
Header (at least for payment.selector).

In the BankingPriority domain, add a value for each message type (for
example MT103), and set the banking priority in the comment (for example
NNNN).

barrier_type Option barrier type, including the following: DOWN_AND_IN, DOWN_AND_
OUT, UP_AND_IN, and UP_AND_OUT.

BBAShiftDateRoll Stores the date rules used for shift date roll.

billingCalculators Names of the billing calculators.

billingEvents Events to which the Billing engine subscribes.

Bo_position_snapshot Stores the snapshot date of the INVENTORY_SNAPSHOT scheduled task
with the types of position and the dates (in the comment field).

BondAssetBacked.collateralType Collateral type for the Asset Backed Bond. You can select the collateral type
when defining the Bond product in the Bond Window > ABS panel.

Calypso out-of-the-box includes the following collateral types: Auto Loans,
Commercial Home Equity Loans, Credit Card, Mortgages, Residential Home
Equity Loans, and Student Loans.

You can add collateral types to the BondAssetBacked.collateralType domain.

BondAssetBacked.poolFactorType The pool factor types, which are how the principal is paid down, in the Asset
Back Bond. You can select the pool factor type when defining the Bond
product in the Bond Window > ABS panel.

Out-of-the-box, the system includes the following pool types: Fixed
Schedule, Variable, and Variable Schedule.

 Refer to the Calypso Fixed Income User Guide for a description of the pool
factor types.
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bondStatus Populates the Bond Status drop-down menu on the bond product window for

bonds imported from Bloomberg. You can select one of the following values:

• PENDING (default value)

– Create request from Bloomberg: Amend the bond – Do not create a
specific task.

– Update request from Bloomberg: Amend the bond – Do not create
a specific task.

• VERIFIED

– Create request from Bloomberg: Do not amend the bond – Create a
task of type EX_BLOOMBERG_EXCEPTION with the following
message “Could not update bond id <bond_id> from a create
request: status is VERIFIED”.

– Update request from Bloomberg: Amend the bond – Do not create
a specific task.

• NOUPDATE

– Create request from Bloomberg: Do not amend the bond – Create a
task of type EX_BLOOMBERG_EXCEPTION with the following
message “Could not update bond id <bond_id> from a create
request: status is NOUPDATE”.

– Update request from Bloomberg: Do not amend the bond – Create
a task of type EX_BLOOMBERG_EXCPETION with the following
message “Could not update bond id <bond_id> from an update
request: status is NOUPDATE”.

bondType Type of bonds.

Out-of-the-box, the system includes the following types: Bond,
BondAssetBacked, BondBrady, BondCLN, BondConvertible, BondFRN,
BondMMDiscount, BondMMDiscountAUD, BondMMInterest, BondRevolver.

bookAttribute.BookBundle Add names of book bundles to this domain. See the Book Attributes Dialog
window, which you can open from the Book Window. Add books to a book
bundle by defining the attribute on the book.

You can assign access permissions by book bundle to a group of users.
Users who have permissions to a book bundle have permissions to all of the
books in the bundle.

bookingType GL accounting posting conventions, including the following: Incremental,
N/A, and Reversal.

BOPositionFilter Used for filtering BO inventory position. You can select a custom filter in the
Inventory Position report.
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Calypso includes the filter SecurityFilter, which only shows security positions
that are held at multiple agents. In order to use this filter, compile
calypsox.apps.reporting.SecurityFilter.

You can create custom filters. Create a class named
apps.reporting.<Name>Filter that implements the interface
com.calypso.apps.reporting.BOPositionFilter. Register the class
name in the BOPositionFilter domain.

bundleType Bundle types. You can add types to this domain.

Cache.class Cache class implementations.

Cache.eviction Cache eviction implementations.

calcAgentCityCode Add a list of cities for the calculation agent. Users can select a city in the
Credit Default Swap trade window > Details panel.

calendarIsoCodes Stores calender ISO codes.

calibratibleModels Domain for the calibration module.

calibrations Domain for the calibration module.

calibrators Domain for the calibration module.

CallAccountType Types of Call Accounts.

CapitalizePremiumFeeType For physically exercised swaptions, stores the Fee Type used to capture the
premium on an option trade that is copied to the underlying trade. The
default value of this domain is “PREMIUM”.

CashSettleDefaultsAgreements Add names of cash settle default agreements to this domain. The agreement
names can be selected in the Cash Settle Info Window that opens from the
trade worksheet (for example, in the Swap worksheet choose Swap > Cash
Settle Info).

cashSettleEvent Event types for Cash Settlement of Products. Calypso includes Default,
which is the default Cash Settlement event type.

cashSettleFeeType Specify the credit event fee type for the settlement payment from CDS
Index, CDS Index Tranche, CDS Nth Loss, and CDS Nth Default trades.

ccdsUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsAbsindexUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsAbsindexTrancheUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsabsUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsAdditionalProvisions Values from this domain can be selected for inclusion in the CDS Settlement
Matrix, or non-market-standard CDS.

You can add or remove values from this domain when new versions of the
settlement matrix are published.
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cdsIndexTrancheUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsIndexUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

cdsPmtLagType Values that you add to this domain appear in a drop-down menu in the Credit
Default Swap trade window > Details panel as options that you can select for
the payment lag description.

cdsSettleTiming Specify methods for when the settlement will occur.

Certificate.Underlying List of underlying products that you can select when setting up a certificate
in the Warrant/Certificate Window.

Certificate.UnderlyingEditable Add Certificate underlying product types that are not managed in Calypso in
this domain. Users can enter a description for products defined in this
domain.

cfdProductType Types of products that you can select in the CFD Product Window. Calypso
includes the following products in this domain: BondConvertible and Equity.

CheckUnauthorizedSDI Types of workflows to check for unauthorized SDIs for a legal entity.

city City codes for holiday calendars.

classAuditMode Classes in this domain are auditable, meaning that the database stores any
changes to the corresponding data, and the system applies versions so that
you can view and compare different versions of the data. Remove a class
from the classAuditMode domain to make it not auditable.

Refer to the Calypso Security User Guide for details on the Audit
functionality.

Refer to the Calypso Developer’s Guide for details on making a class
auditable.

classAuthMode Classes in this domain require authorization. When a user makes any
changes to the corresponding data, an authorization user must authorize the
change. Remove a class from the classAuthMode domain to disable
authorization for that class.

Choose from the following values to enable or disable authorization for
Liquidity Limits:

• LiqLimitCcyBucket

• LiqLimitCcyClassificationLevel

• LiqLimitCcyClassificationLevelBucket

Refer to the Calypso Security User Guide for details the Authorization
functionality.

Refer to the Calypso Developer’s Guide for details on making a class
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authorizable.

classNotAuth Lists the values to disable authorization of the given class for the given
processing organization.

CollateralAttribute Collateral attributes are similar to trade keywords except that they are set at
the collateral object level, so for a multi-collateral repo trade, the same
attribute can have a different value per each piece of collateral.

Related Domains:

MirrorCollateralAttribute

PropagateCollateralAttribute

commodity.ForwardPriceMethods Types of forward pricing methods used for commodities.

These can be selected in the Commodity Reset Definition.

CommodityAveragingPolicy Add custom policy names that you can select for averaging the rates used in
fixing in the Commodity Swap 2 and Commodity OTC Option 2. The policy
names appear in the Avg Method menu.

For a custom Averaging Policy, the code should reside in
tk/product/commodities and be compiled. For reference, please check:
calypsox/tk/product/commodities/AveragingPolicySample

Add your custom policy name to the CommodityAveragingPolicy domain. If
the custom policy involves a foreign currency, add the policy name to the
CommodityFXAveragingPolicy domain.

CommodityAveragingRoundingPolicy Add custom policy names that you can select for the averaging rounding
policy in the Commodity Swap 2 and Commodity OTC Option 2. The policy
names appear in the Round After menu.

For a custom Averaging Rounding Policy, the code should reside in
tk/product/commodities and be compiled. For reference, please check:
calypsox/tk/product/commodities/AveragingRoundingPolicySamp
le

Add your custom policy name to the CommodityAveragingRoundingPolicy
domain. If the policy involves a foreign currency, add it to the
CommodityFXAveragingRoundingPolicy domain.

CommodityCumulativeDaily

FwdPointKeywords

(one word)

Stores the derivative daily fwd point keywords for daily points. If unit for
CurveUnderlying doesn't match any of predefined daily keywords, an error
message for that particular curve underlying is being displayed.

CommodityCumulativeMonthly

FwdPointKeywords

(one word)

Stores the derivative monthly fwd point keywords for monthly points. If unit
for CurveUnderlying doesn't match any of predefined monthly keywords, an
error message for that particular curve underlying is being displayed.
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CommodityElectricityQuoteTypes Add Commodity Electricity quote types. The quotes can be used in the

Commodity Electricity Hyper Surface. Following are examples of the quote
format:

• OFF = Off Peak Quote

• ON = On Peak Quote

• BL = Base Load (24 hours) Quote

• 1D = Today +1

• 2D = Today +2

• 1M = Next Calendar month

• 2M = The month after that

• 1Y = Next Year (Jan 1 - Dec 31)

• 2Y = The year after that

• BOD = Balance of the Day (today)

• BOM = Balance of the Month (starting tomorrow)

• BOY = Balance of the Year (starting tomorrow)

CommodityFixingDatePolicy Stores the fixing date policies that you can select for fixing dates during the
swaplet or optionlet period in the Commodity Swap 2 and Commodity OTC
Option 2, respectively.

For the custom Fixing Date Policy, the code should reside in
tk/product/commodities/schedulegeneration/fixing and be
compiled. Add the custom fixing date policy name to the
CommodityFixingDatePolicy domain.

CommodityFXAveragingPolicy Add custom policy names that you can select for averaging the rates used in
fixing in the Commodity Swap 2 and Commodity OTC Option 2. The policy
names appear in the Avg Method menu.

For a custom Averaging Policy, the code should reside in
tk/product/commodities and be compiled. For reference, please check:
calypsox/tk/product/commodities/AveragingPolicySample

Add your custom policy name to the CommodityAveragingPolicy domain. If
the custom policy involves a foreign currency, add the policy name to the
CommodityFXAveragingPolicy domain.

CommodityFXAveraging

RoundingPolicy

(one word)

Add custom policy names that you can select for the averaging rounding
policy in the Commodity Swap 2 and Commodity OTC Option 2. The policy
names appear in the Round After menu.

For a custom Averaging Rounding Policy, the code should reside in
tk/product/commodities and be compiled.
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Add your custom policy name to the CommodityAveragingRoundingPolicy
domain. If the policy involves a foreign currency, add it to the
CommodityFXAveragingRoundingPolicy domain.

CommodityLocation Add names of the physical locations where the commodities are delivered.
You select the location when setting-up the Commodity product.

commodityMktDataUsage Extend the list of usage types to associate with a commodity curve in the
Pricer Configuration > Commodity panel.

CommodityName Add names of commodity products. You select a commodity name when
setting up the commodity product.

CommodityPaymentFrequency Add names of custom payment frequency policies that you can select in the
Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

Bullet

Add names of custom bullet payment frequency policies that you can select
in the Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

Contract

Add names of custom contract payment frequency policies that you can
select in the Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

Daily

Add names of custom daily payment frequency policies that you can select in
the Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

Periodic

Add names of custom periodic payment frequency policies that you can
select in the Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

PeriodicIRConvention

Add names of custom periodic IR convention payment frequency policies
that you can select in the Commodity Swap 2 and Commodity OTC Option 2.

CommodityPaymentFrequency.

Whole

Add names of custom whole payment frequency policies that you can select
in the Commodity Swap 2 and Commodity OTC Option 2.

CommodityReset Screen name for Commodity Reset.

CommodityResetSource Screen name for Commodity Reset Source.

CommoditySettleMethod Settle method for Commodity transfers. For example, COMMODITY is for
commodity certificate transfers.

CommoditySource Add names of the exchanges where the commodities trade. You select the
source in the Commodity product.

CommodityType The default product type is Commodity. The commodity type can be
selected in the commodity product definition.

Additional commodity product types are available out-of-the-box: Electricity,
Storage Based, Vintage Based. They are associated with additional attributes
that you can set that are used in pricing, and the market data that is required
for the pricing of those commodities.
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CommodityUnit Units in which the exchange quotes the commodities. You can select the unit

in the Commodity or Commodity Index product, and also in the trade. You
can set up the conversion factor from one type of unit to the other. See
Configuration > Commodities > Commodity Conversion.

CommodOptVolTypeDelta Extend the list of delta values that you can select when creating underlyings
for the commodity option volatility surface.

ComputeCouponPerQty Sec code for added rounding conventions when calculating interest on
Russian and Brazilian bonds.

contactType Contact person or department types for advices. Define the contact type for
a legal entity by clicking Contact in the Legal Entity window.

Calypso demonstration data includes the following contact types:
Accounting, Back-Office, Default, Documentation, Operation, Payments, and
Settlement. You can add types to the contactType domain.

contractDateGen Add the names of custom date generators that you can select when defining
future contracts in the Future Contract Window.

Refer to the Calypso Developer’s Guide for details about how to create a
custom date generator for a future contract.

corporateActionType Add links for models and subtypes in the corporateActionType domain using
<ModelName>.<SubType> as the format. In the Corporate Action window >
Create panel, when you select the Model name, the application only displays
the Sub Types linked to that model. For example, if you add
ACQUISITION.OPA and ACQUISITION.OPE in the corporateActionType
domain, when you select the ACQUISITION Model, Sub Type displays OPA
and OPE.

CorrelationMatrix.gen Add custom correlation matrix generators to this domain. A correlation matrix
generation class contains the algorithm for deriving a non-simple correlation
matrix. Calypso out-of-the-box includes the FXIndex generator.

To create a custom generator, create a class named
tk.marketdata.CorrelationMatrixGenerator<Name> that extends
com.calypso.tk.marketdata.CorrelationMatrixGenerator.

Refer to the Calypso Class Library for details. Register the custom
generator name in the CorrelationMatrix.gen domain.

The com.calypso.tk.marketdata.CorrelationMatrix class invokes
the generator.

CorrelationSurface.gen Names of the generation algorithms (generators) for derived Basket
Correlations. Calypso out-of-the-box includes the BaseCorrelation
generator.

You can create custom Correlation Surface generators. Create a class
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named tk.marketdata.CorrelationSurfaceGenerator<Name>which
extends the abstract base class
com.calypso.tk.marketdata.CorrelationSurfaceGenerator.
Register the custom generator name in the CorrelationSurface.gen domain.

The com.calypso.tk.marketdata.CorrelationSurface class invokes
the generator.

CorrelationSurface.gensimple Names of the generators for simple Basket Correlations. Calypso out-of-the-
box includes the BespokeCorrelation and BespokeCorrelationMoneyness
generators.

You can create custom generators and register them in the
CorrelationSurface.gensimple domain.

correlationType This domain contains the correlation types that you can select for each axis
when creating a Correlation Matrix.

You can create custom correlation types and register them in the
correlationType domain.

Refer to the Calypso Developer’s Guide for details about how to create a
custom correlation type.

CovarianceMatrix.gen Add custom covariance matrix generators to this domain. Calypso out-of-
the-box includes the MFMDefault and Rebonato generators.

To create a custom generator, create a class named
tk.marketdata.CovarianceMatrixGenerator<Name> that extends
com.calypso.tk.marketdata.CovarianceMatrixGenerator.

 Refer to the Calypso Class Library for details. Register the custom
generator name in the CovarianceMatrix.gen domain.

The com.calypso.tk.marketdata.CovarianceMatrix class invokes the
generator.

creditDefaultSwapUpfrontFeeType No longer used. Use tradeUpfrontFeeType instead.

creditEventProtocolType Stores the names of ISDA credit event protocol types.

creditEventType Credit event types that you can select in the Credit Event Window. You can
add event types to this domain.

creditMktDataUsage Used in the Pricer Configuration Window > Credit panel. Specifies how the
system can use a market data item. The following usage types are available:

• CORR_SKEW – Use the market data item as a correlation skew.

• C_VOL – Use the market data item as a call volatility surface.

• PREPAY – Use the market data item as a prepay curve.

• PROB – Use the market data item as a probability curve.
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• P_VOL – Use the market data item as a put volatility surface.

• REC – Use the market data item as a recovery curve.

• RISKY_DIS – Use the market data item as a risky curve.

• VOL – Use the market data item as a volatility surface.

creditMktDataUsage.

CORR_SKEW

Specifies the application name CorrelationSurface for the usage.

creditMktDataUsage.C_VOL Specifies the application name VolatilitySurface3D for the usage.

creditMktDataUsage.PREPAY Specifies the application name CurvePrepay for the usage.

creditMktDataUsage.PROB Specifies the application name CurveProbability for the usage.

creditMktDataUsage.P_VOL Specifies the application name VolatilitySurface3D for the usage.

creditMktDataUsage.REC Specifies the application name CurveRecovery for the usage.

creditMktDataUsage.RISKY_DIS Specifies the application name CurveRisky for the usage.

creditMktDataUsage.VOL Specifies the application name VolatilitySurface3D for the usage.

creditRatingSource Specifies the default credit rating agency.

In the Pricer Configuration, you can now associate credit curves by credit
rating: agency and LE attributes.

Set the default credit rating agency in the domain creditRatingSource.

Set the credit rating attributes order in the domain
PCCreditRatingLEAttributesOrder.

Example: RED_REGION, RED_SECTOR

If the issuer’s specific curve does not exist, the generic curve will be used,
based on Legal Entity attributes: Rating agency (Moody's, S&P, Internal),
Rating (AAA, AA, A), Sector (ANY, Auto, Financial), Region (North America,
Asia, ANY).

creditRatingType The credit rating type, which you can select in the Credit Rating and Credit
Rating Feed Address windows. You can add types to the creditRatingType
domain.

creSentStatus Statuses for the Account Enrichment Report and the Manual CRE window.

CstQEQtSpreadRule No longer used.

currency Add currency International Organization for Standardization (ISO) symbols to
this domain. Define how a currency is quoted and how it is traded against
other currencies in the Currency Default window.

currencyDefaultAttribute Define custom attributes on currencies for selection and reporting purposes.

currencyGroup Groups of currencies, grouped for risk analysis and accounting purposes.
You can add new groups to this domain.
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currencyPairAttribute Define custom attributes on currency pairs for selection and reporting

purposes.

CurveBasis.gen Names of the generation algorithms (generators) for Basis Curves.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom Basis Curve generators and register them in the
CurveBasis.gen domain.

 Refer to the Calypso Developer’s Guide for details.

CurveCDSBasisAdjustment.gen Names of the generation algorithms (generators) for CDS Basis Adjustment
curves.

You can create custom generators and register them in the
CurveCDSBasisAdjustment.gen domain.

Refer to the Calypso Developer’s Guide for details.

CurveCommodity.gen Names of the generation algorithms (generators) for Commodity Curves.
Calypso out-of-the-box includes the Commodity generator.

You can create custom generators and register them in the
CurveCommodity.gen domain.

Refer to the Calypso Developer’s Guide for details.

CurveCommoditySpread.gen Names of the generation algorithms (generators) for Commodity Spread
Curves. Calypso out-of-the-box includes the Commodity generator.

You can create custom generators and register them in the
CurveCommoditySpread.gen domain.

Refer to the Calypso Developer’s Guide for details.

CurveFX.gen Names of the generators for FX Curves. Calypso out-of-the-box includes the
following generators: FXCrossRate, FXForward, and FXPoints.

 Refer to Calypso FX and Money Market Analytics for details.

You can create custom FX Curve generators and register them in the
CurveFX.gen domain. Create a class named
tk.marketdata.CurveGeneratorFX<name> that extends the abstract
base class com.calypso.tk.marketdata.CurveGeneratorFX.

Refer to the Calypso Developer’s Guide for details.

CurveInflation.gen Names of the generators for Inflation Curves. Calypso out-of-the-box
includes the Inflation generator.

You can create custom generators and register them in the
CurveInflation.gen domain.

Refer to the Calypso Developer’s Guide for details.
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Domains Description
CurveInflation.gensimple Names of the generators for simple Inflation Curves. Calypso out-of-the-box

includes the Inflation generator.

You can create custom simple Inflation Curve generators and register them in
the CurveInflation.gensimple domain.

CurveInflationBasis.gen Names of the generators for Inflation Basis Curves. Calypso out-of-the-box
includes the InflationBasis generator.

You can create custom generators and register them in the
CurveInflationBasis.gen domain.

Refer to the Calypso Developer’s Guide for details.

CurvePrepay.PrepaymentModel Prepayment curves are used for pricing ABS bonds in the context of the Intex
integration. Add names of models that you can select when building the
curves in the Prepayment Curve window.

CurveProbability.gen Names of the generators for Probability Curves. Calypso out-of-the-box
includes the Probability and ProbabilityIndex generators.

Refer to Calypso Credit Derivatives Analytics and Calypso Credit
Derivatives User Guide for details.

You can create custom Probability Curve generators and register them in the
CurveProbability.gen domain. Create a class named
tk.marketdata.CurveGeneratorProbability<Name> that extends the
abstract base class
com.calypso.tk.marketdata.CurveGeneratorProbabilityBase.

Refer to the Calypso Developer’s Guide for details.

CurveProbability.gensimple Names of the generators for simple Probability Curves. Calypso out-of-the-
box includes the CreditGrades generator.

You can create custom simple Probability Curve generators and register
them in the CurveProbability.gensimple domain.

CurveProbability.Selector Lists curves by pricing environment. Calypso includes
PricingEnvCurveProbabilitySelector.

CurveRecovery.gen Names of the generators for Recovery Curves.

Calypso does not contain a generator for the Recovery Curve as it is a simple
curve; you manually enter the recovery rates.

Refer to Calypso Credit Derivatives Analytics for details.

You can create a custom generator to use with your own pricer and register it
in the CurveRecovery.gen domain. Create a class named
tk.marketdata.CurveGeneratorRecovery<Name> that extends the
abstract base class
com.calypso.tk.marketdata.CurveGeneratorRecovery.
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Refer to the Calypso Developer’s Guide for details.

CurveRepo.gen Names of the generators for Repo Curves.

Calypso does not contain a generator for the Repo Curve as it is a simple
curve. Enter Repo Curves as basis point spreads over the discount curve.

Refer to Calypso Curves documentation for details.

CurveRisky.gen Names of the generators for Risky Curves.

You can create a custom generator to use with your own pricer and register it
in the CurveRisky.gen domain. Create a class named
tk.marketdata.CurveGeneratorRisky<Name> that extends the abstract
base class com.calypso.tk.marketdata.CurveGeneratorRiskyBase.

Refer to Calypso Credit Derivatives Analytics and Calypso Developer’s
Guide for details.

CurveSeasonality.adj Add names of custom seasonality adjustment types for Seasonality Curves.

CurveSeasonality.interpolator Add names of custom curve seasonality interpolators.

CurveVolatility.gen Names of the generators for Volatility Curves.

You can create a custom generator and register it in the CurveVolatility.gen
domain. Create a class named
tk.marketdata.CurveGeneratorVol<Name> that extends the abstract
base class com.calypso.tk.marketdata.CurveGeneratorVol.

Refer to the Calypso Developer’s Guide for details.

CurveZero.gen Names of the interest curve generators for Zero Curves. Calypso out-of-the-
box includes the following generators: BootStrap, BootStrapForwards, and
BootStrapStandard.

You can create a custom generator and register it in the CurveZero.gen
domain.

Refer to the Calypso Developer’s Guide for details.

CurveZero.gensimple Names of the generators for simple Zero Curves, meaning curves that are not
derived from underlying instruments. The default value is none.

You can create a customer generator and register it in the
CurveZero.gensimple domain.

Refer to the Calypso Developer’s Guide for details.

CurveZeroFXDerived.gen Names of the generators for FX Derived Zero Curves. Calypso includes the
FXDerived generator.

Refer to Calypso FX and Money Market Analytics and the Calypso FX
Trading System User Guide for details.

CurveZeroPreciousMetal.gen Names of the generators for precious metal zero curves. Calypso out-of-the-
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Domains Description
box includes the PreciousMetal generator.

You can create a custom generator and register it in the
CurveZeroPreciousMetal.gen domain.

Refer to the Calypso Developer’s Guide for details.

curveZeroType Used in the Curve window to select the type of Zero Curve. If you extend
com.calypso.tk.marketdata.CurveGeneratorZero, you can add new
curve types to the curveZeroType domain.

CustomCalibrationFrameConfig Add names of custom calibration frame configurations.

CustomCalibrationMeasureConfig Add names of custom calibration measure configurations.

customCriterion You can add a custom panel in the trade filter that contains your custom
attributes.

Refer to the Calypso Developer’s Guide for details. Register the names of
the custom attributes in the customCriterion domain.

CustomCurveUnderlying You can add a custom underlying instrument panel to the Curve Underlying
Window and register the instrument name in the CustomCurveUnderlying
domain.

Refer to the Calypso Developer’s Guide for details.

customerCallType In the Customer Station, you select a category for the type of call received
from a customer. Add the categories to the customerCallType domain.

customProductWindow You can create custom product windows and add them to the Configuration
> Product. Register the class name in the customProductWindow domain.

Refer to the Calypso Developer’s Guide for details.

customScenarioRule You can create custom scenario rules and register them in the
customScenarioRule domain.

Refer to the Calypso Developer’s Guide for details.

CustomSDISelector Refer to the Calypso Settlements User Guide for the methodology used by
Calypso for selecting settlement and delivery instructions (SDIs) for trades.

You can create a custom SDI selector and register it in the
CustomSDISelector domain.

Refer to the Calypso Developer’s Guide for details.

CustomStaticDataFilter Stores names of custom static data filter attributes.

CustomVolSurfaceUnderlying You can create a custom volatility surface underlying instrument and add a
panel in the Volatility Surface Underlying Window. Register the instrument in
the CustomVolSurfaceUnderlying domain.

Refer to the Calypso Developer's Guide for details.

DateRuleReportTemplate Use with reports that use the report framework. Add the names of date rules
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Domains Description
to the domain, and then the date rules appear in the date tenor drop-down
menus in the report. You can select date rules for use in the date period.

dayChangeRule Stores day change rules.

DBRelationCategory Categories for database relation tables. Used for consistency checks.

defaultCapGainTerminationFeeType Stores the default capital gains termination fee type. The default value is
CAPGAIN_TERM_FEE.

defaultFXVolSurfUndQtGen Remove excludeFeedSource from this domain and add includeFeedSource
to include the feed source in the quote name. Thus, you can use quotes from
multiple sources for the same instrument.

defaultIntTerminationFeeType Stores the default interest termination fee type. The default value is INT_
TERM_FEE.

defaultMgmtTerminationFeeType Stores the default management termination fee type. The default value is
MGMT_TERM_FEE.

defaultTerminationFeeType Set the default fee type for the Termination Window. The default value is
TERMINATION_FEE.

DefaultTradeRole For each front-office trade window, you can define the default role for the
counterparty. If you do not set a default role, then the window uses
CounterParty as the default role.

You can set the default role in the trade worksheet by choosing Utilities >
Set Default Role. Also, you can enter the default role directly in the
DefaultTradeRole domain in the Domain Values application. Use the following
format: <FullClassName>.<RoleName>. For example, to set Clearer as the
default counterparty role in the Futures Trade Window, enter the following in
the DefaultTradeRole domain:
com.calypso.apps.trading.TradeFutureWindow.Clearer.

delayedSettleFeeType Add the name of the fee definition for the delayed settlement fee that is
calculated in the Bank Debt trade worksheet.

deliverableCharacteristics In the Credit Default Swap trade window, you can select the Deliverable
Characteristics in the Physical panel. You can extend this domain.

DeliverableType In the OTC Equity Option Vanilla Window when the EQUITY_DERIVATIVES_X
environment property is set to true, the window displays a Deliverables panel
from which you can select the Deliverable Type. Calypso out-of-the-box
includes the CASH EXERCISE and PHYSICAL EXERCISE types. You can
extend this domain.

deliveryType The delivery type for actions that involve a movement of a loan against a
movement of collateral. Calypso out-of-the-box includes the following
delivery types:

• DAP – Delivery Against Payment
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Domains Description
• DFP – Delivery Free of Payment

disableReportTableFiltering The column filtering (right-click on column heading) is now enabled by
default for all reports except those in the domain
disableReportTableFiltering.

DispatcherParamsCalypso Stores the names of the parameters to configure in the Dispatcher Config
Window for Calypso grids.

DispatcherParamsDatasynapse Stores the names of the parameters to configure in the Dispatcher Config
Window for Datasynapse grids.

DispatcherType Add types of dispatchers that you can select in Configuration > System >
Dispatcher.

Extend the class com.calypso.tk.distproc.DistAnalysisCalypso.

disruptionFallbacks Add the names of the default disruption fallbacks for commodity
confirmations. You can view these keywords from the Commodity product
trade worksheet. Choose <ProductName> > Commodity Confirm
Keywords. The application automatically selects the default disruption
fallbacks.

disruptionFallbacksAll Add the names of all of the possible disruption fallbacks for commodity
confirmations. You can view these keywords from the Commodity product
trade worksheet. Choose <ProductName> > Commodity Confirm
Keywords. The application automatically selects the default disruption
fallbacks that you define in the disruptionFallbacks domain. You can select
additional disruption fallbacks.

DividendType You can include names of new dividend types. The present dividend types
supported are:

• Final – The last dividend in a corporation’s financial year.

• Interim – Dividends that are not final dividends.

• Regular – An established dividend rate fixed by a corporation upon its
stock and usually paid quarterly or semiannually.

• Special – A dividend that is not paid regularly each year. The term may
differ by corporation.

domainName Add new domains in the domainName domain.

dsInit No longer used as of version 10.0.

Refer to the Calypso Developer’s Guide for information on registering
custom services.

eco_pl_column No longer used.

EnableExoticBaskets Add the Value ‘true’ to this domain to enable the prototype of basket
structures in eXSP.
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The “Add Basket Variable” icon appears in the Structured Dialog, Variable
panel, which allows defining basket variables. The Components field allows
creating baskets of quotable variables.

engineEventPoolPolicies Maps the name of the class, as entered into the comment field of
engineEventPoolPolicyAliases, to a textual description.

engineEventPoolPolicyAliases Add names of policies for handling events being dispatched to engine
threads. The domain value contains the policy name; the domain comment
contains the class name.

Select the policy name in the EVENT_POOL_POLICY engine parameter.

To create a new policy, create a class named
tk.util.<PolicyName>SequencePolicy that extends the abstract base
class com.calypso.tk.util.AbstractSequencePolicy. Add the policy
name to the engineEventPoolPolicyAliases domain and enter the class name
in the comment field.

engineName Names of the real-time engines that subscribe to certain types of events in
the system, carry out processes, and publish the processing results.

Engines and their parameters are defined in the Engine Manager of Web
Admin.

Please refer to Calypso Web Admin documentation for details.

You can also refer to the Calypso List of Servers and Engines for the list of
supported engines.

You can create custom engines and register them in the engineName
domain.

Refer to the Calypso Developer’s Guide for details.

engineParam Names of the engine parameters that you can set in the Engine Manager
fromWeb Admin.

You can also include the parameters of custom-created engines.

Refer to the Calypso Developer’s Guide for details.

equity_index_source Names of sources that publish the equity index.

equityIndexType Types of equity indices.

equityStatus Populates the Equity Status drop-down menu on the equity product window
for equities imported from Bloomberg.

ERS_RESULTS_GROUPS Supported grouping types for storing data at group level when running the
ERS_ANALYSIS scheduled task. Also supported grouping types for ssched-
uled task ERS_GROUP_RESULTS to save group level results for historical
data. You can add additional grouping types.

etoContractDateGen You can create a custom date generator for Exchange Traded Option (ETO)
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Domains Description
contracts, which you can select in the Exchange Traded Option Contract
Window to generate the ETO products.

Create a class named tk.product.ETODateGenerator<Name> that
implements the interface com.calypso.tk.product.ETODateGenerator.
Register the generator name in the etoContractDateGen domain.

ETOUnderlyingType Types of ETO underlying instruments. Calypso includes the following: Equity,
EquityIndex, and FX.

eventClass Names of the event classes that engines can subscribe to in Calypso.

Engines and their parameters are defined in the Engine Manager of Web
Admin.

Please refer to Calypso Web Admin documentation for details.

You can create custom event classes for custom objects, and register the
custom event classes in the eventClass domain.

Refer to the Calypso Developer’s Guide for details.

eventFilter Names of the event filters that can be defined for engines. They filter the
events received by the engine for processing. This can decrease the number
of unnecessary events sent to the engine, thus improving performance.

Engines and their parameters are defined in the Engine Manager of Web
Admin.

Please refer to Calypso Web Admin documentation for details.

You can create custom event filters and register them in the eventFilter
domain.

Refer to the Calypso Developer’s Guide for details.

eventType Types of events that can occur in Calypso.

exceptionType BOException names. Back Office engines generate these exceptions when
there is an exception in processing a trade or corporate action.

You can view and resolve tasks in the Task Station created by the exception
events. In the Task Station user configuration, select the Exception event
types to include in the configuration. These are the event types defined in
the eventType domain, which uses the format EX_<BOExceptionName>. For
example, the exceptionType RATE_RESET has the eventType EX_RATE_
RESET.

Refer to theWorkflow User Guide for configuration information and
descriptions of the exceptions.

Custom workflow rules can generate BOException tasks.

Refer to the Calypso Developer’s Guide for details.
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Register new BOException names in the exceptionType domain, and add EX_
<BOExceptionName> to the eventType domain.

exchange Deprecated domain. Define exchanges as legal entities with the MarketPlace
role.

ExerciseDoInterestCleanUp Default value is True. This causes the interest cleanup checkbox to be
checked in all exercise windows. False leaves this box unchecked in all exer-
cise windows.

ExerciseMode The delivery type in option trades. Calypso includes the following types:
Cash, Cash or Physical, and Physical.

ExerciseType Contains the exercise types for options: American, Bermuda, and European.

ExoticFunction Stores the names to register the custom exotic functions.

eXSPSystemVariables Stores all system variables. The default values are
AccumulatedCouponIncludingCurrentSVar, AccumulatedCouponSVar,
CalculatedNotionalSVar, CalculatedRateSVar, CouponPeriodSVar,
CurrentNotionalSVar, DaysSVar, InitialNotionalSVar, PreviousNotionalSVar,
and PreviousRateSVar.

ExternalMessageField.Amounts The MessageMatcher interface can use amounts stored in this domain in
matching external messages.

ExternalMessageField.Dates The MessageMatcher interface can use dates stored in this domain in
matching external messages.

ExternalMessageField.Fields The MessageMatcher interface can use fields stored in this domain in
matching external messages.

ExternalMessageField.Instructions The MessageMatcher interface can use instructions stored in this domain in
matching external messages.

ExternalMessageField.MessageMapp
er

The MessageMatcher interface can use message types stored in this domain
in matching external messages.

ExternalMessageField.References The MessageMatcher interface can use references stored in this domain in
matching external messages.

ExternalMessageField.Roles The MessageMatcher interface can use roles stored in this domain in
matching external messages.

FASEffMethodPro In the Hedge Strategy Window, lists the methods that can be used to
measure expected and on-going hedge effectiveness.

FASEffMethodRetro In the Hedge Strategy Window, lists the methods that can be used to
measure whether a hedge relationship has been highly effective during a
past period.

FASHedgedRisk Types of risk that the user can select to hedge in the Hedge Strategy
Window.
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FASObjectiveCode List of objective codes to select from the O/S Code drop-down menu in the

Hedge Strategy Window. These codes are specific to each organization and
refer to internally recognized documentation codes, for example, 100 might
refer to “Interest Rate Risk Reduction”.

FASObjectiveDesc Use this domain instead of the FASObjectiveCode domain if you prefer to
use a descriptive list of the objectives instead of a list of codes in the Hedge
Strategy Window. The O/S Desc drop-down menu in the Hedge Strategy
Window displays the descriptive list of objectives.

FeeBillingRuleAttributes Specifies a list of attributes that you can define in the fee billing rule window.

• DefaultBook – Specify a default book for the fee billing trades.

feeCalculator Fee calculators calculate fees on trades. You can select the fee calculator in
the fee definition. When you set up a fee grid, you can select the FeeGrid
default calculator. You can also select the fee calculator in the Fees panel in
the trade worksheet.

Calypso out-of-the-box includes a number of fee calculators. The help file in
the fee definition window describes the out-of-the-box fee calculators and
their equations.

You can create custom fee calculators and register them in the feeCalculator
domain.

 Refer to the Calypso Developer’s Guide for details.

feed Names of the real-time feeds. Feed configs that you define in the Feed
Config Window.

feedType Names of the feed handlers, which are connections between Calypso and
real-time feed sources. You can select the feed type when defining the feed
config in the FeedConfig Window. Calypso out-of-the-box includes the
following feed handlers: Bloomberg, Composite, Random, Remote, and
Reuters.

You can create custom feed handlers to connect to real-time feed sources
and register them in the feedType domain.

Refer to the Calypso Developer’s Guide for details.

feeGridAttribute Stores names of attributes that you can set on fee grids.

Refer to Calypso Fees documentation for details.

feeInPositionEngine Lists the fee types that need to be included in the Cash position.

FillUpHeapAnalysisServers The names of the analysis servers for which we would like to fill up the heap.
The default heap is 100000. If you choose a value smaller than 100000, it will
cause a longer full Garbage Collector, whereas if you choose a value larger
than 100000, it will cause a shorter full Garbage Collector.
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FillUpHeapAnalysisServersThreshold The names of the analysis servers for which we are filling up the heap. It only

applies if the analysis server is also defined in the FillUpHeapAnalysisServers
domain. In the comment, you can specify the percentage of heap to be filled.
For e.g. 0.7 for 70%.

Once the heap is full, the Garbage Collector can be triggered using a profiler
like VisualVM.

flowType Types of cashflows.

formatType Format types for advices and payment messages.

frequency Custom frequencies.

function Access permission functions that you can assign to a group of users in the
Access Window.

 Refer to the Access Permissions Functions online help for a list of functions
and descriptions. In the Access Window > Group Access panel, click Function
Help to open the help file.

You can create classes that check custom access permissions. Register the
name in the function domain. The name is the S_MODIFY_FUNCTION string
in the <Name>CheckAccess class. See
calypsox.apps.util.BondAssetBackedCheckAccessfor an example.

Refer to the Calypso Developer’s Guide for details.

FundAttributes Stores the name of the attributes that you can define in the Fund Window.

FutureContractAttributes Names of custom attributes that you can define or modify on the future
contract definition.

FutureContractAttributes.

IsDefaultDeliverableFutureContract

Stores values for the IsDefaultDeliverableFutureContract contract attribute.

FutureContractAttributes.PeakSetting Stores values for the PeakSetting attribute.

FutureLiffeModel Future Options on exchanges which the user lists under the FutureLiffeModel
domain will be treated as variation margined premium options. Premium will
not be paid up front, rather the option will just be margined on a daily basis
based on the option settlement value.

FutureOptionContractAttributes Names of custom attributes that you can define or modify on the future
option contract definition.

futureOptUnderType The type of future options that you can select in the Future Option Contract
Window.

You can create custom future option types and register them in the
futureOptUnderType domain.

futureUnderType The type of futures that you can select in the Future Contract Window.

Nasdaq Calypso
Getting Started User Guide / Version 18

April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 48 / 253



April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 49 / 253

Domains Description
You can create custom future types and register them in the
futureUnderType domain.

FwdLadderPVDisplayCcy Enter the display currency for the PV_XXX column in the Calypso Workstation
Forward Ladder analysis. The default value is USD, so the analysis displays
the PV_USD column by default.

FX.keywords Add trade keywords for FX trades to this domain. FX trades will use this
product-specific domain instead of the default tradeKeyword domain.

fx_rate_option Contains the names of FX Rate Definitions, which you can select to reset FX
rates.

fx_rate_source Contains the sources for the FX rates resets, for example, the name of the
index.

FXForward.keywords Add trade keywords for FX Forward trades to this domain. FX Forward trades
will use this product-specific domain instead of the default tradeKeyword
domain.

FXKeywordsToRemoveOnCopyNew When starting a new trade entry by clicking on "Copy New" from an existing
trade in the FOWS quick trade entry panel, keywords specified in this domain
value can be removed for the new trade.

FXNDF.keywords Add trade keywords for FX NDF trades to this domain. FX NDF trades will use
this product-specific domain instead of the default tradeKeyword domain.

FXOption.keywords Add trade keywords for FX Option trades to this domain. FX Option trades will
use this product-specific domain instead of the default tradeKeyword
domain.

FXOption.optionSubType Contains a list of FX Option types and subtypes.

FXOptionBarrier.ExercisableStatuses In the Barrier Monitor, FX Option Barrier and Digital trades that are in the
status(es) defined in this domain appear in the Untriggered Barriers panel.
Calypso includes the VERIFIED status. You can extend this list according to
your workflow.

FXOptionBarrier.ExercisedStatuses In the Barrier Monitor, FX Option Barrier and Digital trades that are in the
statuses defined in this domain appear in the Triggered Barriers panel.
Calypso includes the EXERCISED, EXPIRED, KNOCKED_IN, and KNOCKED_
OUT statuses. You can change or extend this list according to your workflow.

FXOptionBarrier.OptionList Contains a list of FX Option Barrier types.

FXOptionForward.keywords Add trade keywords for FX Option Forward trades to this domain. FX Option
Forward trades will use this product-specific domain instead of the default
tradeKeyword domain.

FXOptSlidePricerMeasure Names of pricer measures that you can select to use in the FX Option Spot
Slide and FX Option Volatility Slide.

FXOptVolSurfUndSource Add names of the sources for the FX Option volatility surface underlying
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quotes. The source name is appended to the quote name.

FXOrder.keywords Add trade keywords for FX Order trades to this domain. FX Order trades will
use this product-specific domain instead of the default tradeKeyword
domain.

FXSpotReserve.keywords Add trade keywords for FX Spot Reserve trades to this domain. FX Spot
Reserve trade will use this product-specific domain instead of the default
tradeKeyword domain.

FXSwap.keywords Add trade keywords for FX Swap trades to this domain. FX Swap trades will
use this product-specific domain instead of the default tradeKeyword
domain.

FXTTM.keywords Add trade keywords for FX TTM trades to this domain. FX TTM trades will use
this product-specific domain instead of the default tradeKeyword domain.

FXVolSurface.gensimple Simple FX volatility surface generators.

Add the names of your custom simple FX Volatility Surface generators.

Refer to the Calypso Developer’s Guide for details about creating custom
generators.

FXVolSurfaceGenerator Derived FX volatility surface generators.

Add the names of your custom derived FX Volatility Surface generators.

Refer to the Calypso Developer’s Guide for details about creating custom
generators.

gateway Gateway systems for advice production. You select the gateway in the
Message Configuration Setup Window.

You can create custom document sender classes to send message
documents and register them in the gateway domain.

Refer to the Calypso Developer’s Guide for details.

genericCommentType Add comment types that you can select in the Add Generic Comment /
Edit Generic Comment windows.

genericCusip Domain used in allocations process for Triparty and GCF.

generic<object>Comment Add predefined <object> comments that you can select in the Add
Generic Comment / Edit Generic Comment windows. You can also enter
free form comments.

genericObjectClass Contains the names of objects to which you can add comments using
the Add Generic Comment / Edit Generic Comment windows. Calypso
out-of-the-box includes the LegalEntity, Message, Posting, Product,
SDI, Trade, and Transfer objects.

You can extend the list of objects by creating a custom class that

Nasdaq Calypso
Getting Started User Guide / Version 18

April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 50 / 253



April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 51 / 253

enables generic comments for specified objects. Register the object
names in the genericObjectClass domain.

Refer to the Calypso Developer’s Guide for details.

GenericOption Generic Option types that you can select when capturing a trade in the
Generic Option trade worksheet.

hedgeStrategyType Contains the names of hedge strategies that you can select in the Hedge
Strategy Window.

hyperSpaceContainers Stores the names of hypersurface space containers.

hyperSpaceInterpolators Add the names of custom hypersurface interpolators.

hyperSurfaceGenerators Add the names of custom hypersurface generators.

hyperSurfaceSubTypes Add the names of custom hypersurface subtypes.

IgnoreAdviceMessages Applications defined in this domain do not generate warning messages,
so the user does not have to make the extra mouse clicks during the
trade capture. Enter the full class name for the application. Use commas
to separate multiple applications.

For example, enter the class name
com.calypso.apps.trading.CollateralDialogFrontBond. When
capturing the trade, the application does not generate warning
messages when the user enters values that cause the dirty price to
exceed a certain threshold or the Face value of the bond is 1.

incomingStatus Add the external status names for incoming messages to this domain.
You can map the external status to a Calypso workflow configuration in
the Mapping Status Config Window.

IncomingSwiftTrade Stores the names of incoming SWIFT message types that will be handled
by the SwiftTradeMatcher.

incomingType For incoming SWIFT messages, allows creating a custom message. The
message type should be entered as the domain value and the message
stored in the domain value comment.

IndHierarchyWinDefSpecialTemplate Default template for the primary Industry Hierarchy Window Industry
Hierarchy Report.

IndHierarchyWinDefTemplate Default template for the primary Industry Hierarchy Window Industry
Hierarchy Report.

interfaceRule Rules for exporting accounting postings to the main GL system. You can
select the rule in the Accounts Definition window.

Refer to the Calypso Accounting User Guide for details.

interpolator Contains the names of curve interpolators.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom curve interpolators and register them in the
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interpolator domain.

Refer to the Calypso Developer’s Guide for details.

interpolator3D Contains the names of volatility surface interpolators.

Refer to Calypso Interest Rate Derivatives Analytics and Calypso Class
Library for details.

You can create custom volatility surface interpolators and register them
in the interpolator3D domain.

Refer to the Calypso Developer’s Guide for details.

interpolatorInflation Contains the names of inflation curve interpolators.

You can create a custom inflation curve interpolator and register it in the
interpolatorInflation curve domain.

Refer to the Calypso Developer’s Guide for details.

InventoryAggregations Use to define additional aggregation criteria for the Inventory engine to
generate multiple positions.

Use the netting configuration to define the keys; include the
isAggregation key.

Add the netting configuration name to the InventoryAggregations
domain.

The aggregated positions can be viewed in the BOPostionReport.

InventoryInitDate No longer used as of version 14.1.

isAmortStartDateDirect Controls the logic for the first amortization period when a parameterized
amortization type is used.

• When false (default), it will assume the first amortization occurs in
the first coupon period where Pmt End Date >= Amort Start Date +
Amort Tenor.

• When true, it will assume the first amortization occurs in the first
coupon period where the Pmt End Date > Amort Start Date.

isApplyPmtLagtoPrincipalFlows Enables separation of Principal and Interest cashflows.

• When true (default) a payment lag is applied to the principal flows
when a payment delay is specified in the Date Rules tab of the
Product Detail window.

• When false, the payment lag is set to 0 while generating Principal
Flows (including Principal Flow generated through customization or
amortization). The payment lag is also ignored while generating
Principal Adjusted Flows.

ISDA.Locations Name of the International Swaps and Derivatives Association (ISDA)
locations used in cash settlement.
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isdaCDSAgreement ISDA Agreements for Credit Default Swaps. You can select the year in
the trade window in the Details panel.

isdaSetInAdvance True or False. Affects the default behavior for swap trades with daily
compounding or simple averaging, and with Reset Timing set to BEG_
PER. Utilizes the ISDA 2021 convention for sample or observation period
generation. Setting to True causes the default value of ISDA Set-In-
Advance field in the Index and Resets tab of the Product Details window
to True by default.

issuerRegion Stores the issuer regions that you can select in the Master Confirmation
Window when setting up Credit Derivatives confirmations for DTCC.

You can extend this list.

issuerSector Stores the issuer sectors that you can select in the Master Confirmation
Window when setting up Credit Derivatives confirmations for DTCC.

You can extend this list.

issueSector Stores the issue sectors that you can select in the Master Confirmation
Window when setting up Credit Derivatives confirmations for DTCC.

You can extend this list.

keyword.26T List of transaction types to which the trade's payment relates. The
SWIFT message requires that the code be set in the trade keyword. The
codes are from the European Central Bank (ECB) document Harmonized
Code List for Balance of Payments Collection Systems.

keyword.Desk Add names of desks to populate in the Desk field in the Missing Trade
Adjustment window.

keyword.PM_Allocation SWIFT precious metal codes for MT601 Tag 26C. Creates a drop-down
menu of values that you can select. You can extend this list.

keyword.PM_Availability SWIFT precious metal codes for MT601 Tag 26C. Creates a drop-down
menu of values that you can select. You can extend this list.

keyword.PM_Delivery Details SWIFT precious metal codes for MT601 Tag 26C. Creates a drop-down
menu of values that you can select. You can extend this list.

keyword.PM_Denomination SWIFT precious metal codes for MT601 Tag 26C. Creates a drop-down
menu of values that you can select. You can extend this list.

keyword.PM_Type SWIFT precious metal codes for MT601 Tag 26C. Creates a drop-down
menu of values that you can select. You can extend this list.

Related Domain:

PM_Form

keyword.STP You can set on the trade whether it can be processed automatically
using straight-through-processing (STP=YES), or if a Task Station user
needs to process the trade (STP=NO). Use this keyword with the
CheckSTPKeyword workflow rule in the workflow configuration.
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keyword.Strategy You can set the strategy keyword on a trade to include the
trade/position in a strategy creation by using Configuration > Asset
Management > Strategy.

keyword.terminationReason Stores termination reasons for use in the Termination Window and Static
Data Filter.

keyword.TradeClassification Add values in this domain to populate the Trade Classification field in the
Bond Front Trade window and the Equity Trade window. The
TradeClassification keyword stores this value.

keywords2CopyUponAllocate  Please refer to Calypso Trade Keywords documentation.

keywords2CopyUponExercise  Please refer to Calypso Trade Keywords documentation.

keywords2CopyUponExpiry  Please refer to Calypso Trade Keywords documentation.

keywords2CopyUponRolloverAndRollback  Please refer to Calypso Trade Keywords documentation.

keywords2CopyUponSpotReserveSetVal  Please refer to Calypso Trade Keywords documentation.

keywords2CopyUponTransfer  Please refer to Calypso Trade Keywords documentation.

kickoffDateCalculator Contains the names of the KickOff CutOff date time calculators that you
can select in the KickOff CutOff configuration to use with the workflow.

You can create custom calculators and register them in the
kickoffDateCalculator domain.

Refer to the Calypso Developer’s Guide for details.

laAdditionalField Add fields to legal agreements.

laAdditionalField.ISDA_SUBTYPE Contains the names of the ISDA agreements that you can select from the
Legal Agreement Window.

LadderPL_LinearProducts When this domain is empty, the Spot Slide for Ladder P&L is priced at
each value as defined in the parameters.

You may add product types to this domain (e.g., FXForward, FX,
SimpleTransfer, Equity), for which only the MIN,MAX, and baseline points
are calculated during the INIT_LADDERLIVEPL scheduled task.
Interpolation is then performed in FOWS between these points to
determine the remaining points of the Spot Slide.

 Ⓘ [Note: This domain is to be used only with linear products.]

language Languages for advices. You can extend this list.

leAttributeType Contains the names of attributes that you can set on a legal entity. For
example, you could store bank or industry codes. You can use them for
reporting and accounting purposes. Also, you could create an attribute
and store information that references the legal entity in an external
system.

You can extend this list.
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You can also create a drop-down menu of values to select for the
attribute. Add the attribute name to the leAttributeType domain. Then
add a domain named leAttributeType.<attribute_name> to domainName.
Finally, add values to the created domain to populate the drop-down
menu.

leAttributeType.CLS Select whether or not the legal entity is CLS eligible.

leAttributeType.FX_MARGIN Set FX_MARGIN to NO so that trades with that legal entity in the FX
Trading System are exempt from margin. Create a margin fee
configuration using a static data filter.

leAttributeType.INDUSTRY Add the names of industries that you can select for an issuer.

leAttributeType.RED_JURISDICTION Populated by Markit upload.

leAttributeType.RED_REGION Populated by Markit upload.

leAttributeType.RED_SECTOR Populated by Markit upload.

leAttributeType.RED_TYPE Populated by Markit upload.

leAttributeType.STP You can set on the legal entity whether to allow STP or not. Use this
attribute with the CheckSTPCounterparty workflow trade rule and
CheckSTPCounterparty workflow message rule.

legalAgreementStatus Status of the legal agreement. Select to include the appropriate legal
wording into the confirmation statements.

legalAgreementType Types of legal agreements. You can extend this list.

LegalEntitySelector Add names of LegalEntitySelector to load criteria in the legal entity
selector.

limit.products Add the names of products to which you want to apply credit limit
checking. Causes the trade window for the product to display a Limits
menu.

To check limits in the Pricing Sheet, add the value "PricingSheet".

limitKeyword Add keywords that you can apply to nodes in the limit configuration. You
can use the keywords as filter criteria in the Limit Report and Limit
Details Report.

limitType The types of limits that you can set in the limit configuration.

liquidationKeyword Add trade keywords that are used in Liquidation. Calypso includes
Custodian, Long/Short, and Strategy.

liquidationMethod Contains the liquidation methods used by the Liquidation engine and the
Position engine.

Refer to the Calypso Positions User Guide for details.

You can create custom liquidation methods and register them in the
liquidationMethod domain.

Refer to the Calypso Developer’s Guide for details.
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loanType Type of loans that you can select in the loan product window.

lossAmortType CDS Nth Loss amortization types. Calypso includes Junior and None.

• Junior – Calculate portfolio/tranche losses based on the notionals of
defaulted entities.

• None – Calculate portfolio/tranche losses based on “actual losses”.
Depends on the termination payment type.

– Par minus recovery: notional minus actual recovery

– Fixed amount/percentage (fixed recovery): specified amount

– Initial minus recovery: (notional * reference price) minus actual
recovery

mandatoryMessageRule Add workflow message rules that the system should check at every
transition in the workflow.

mandatoryTradeRule Add workflow trade rules that the system should check at every
transition in the workflow.

mandatoryTransferRule Add workflow transfer rules that the system should check at every
transition in the workflow.

markAdjustmentReasonOTC Stores a list of reasons that you can select for making PL mark
adjustments for trades in the Mark Adjustment window and for creating
PL marks for missing trades in the Missing Trade Adjustment window.

markAdjustmentReasonPosition Stores a list of reasons that you can select for making PL mark
adjustments for positions in the Mark Adjustment window and for
creating PL marks for missing positions in the Missing Trade Adjustment
window.

marketDataType Types of market data. Includes curves, surfaces, and correlation
matrices.

You can create custom curves and surfaces and register them in the
marketDataType domain.

Refer to the Calypso Developer’s Guide for details.

marketDataUsage Usage codes for assigning market data items in the Pricer Configuration
Window > Product Specific panel. You can extend this list.

Calypso out-of-the-box includes the following usages:

• ADJUST_FX – Indicates item is a curve that is used for adjusting
Value Spot FX rates to Value Today rates.

• CMS_CAP_VOL – Cap vol surface for CMS index.

• CMS_SWAPTION_VOL – Swaption vol surface for CMS index.

• CORRELATION – Indicates item is correlation matrix.

• CORR_SKEW – Indicates item is a correlation skew.
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• DIS – Indicates item is used for discounting future cash flows.

• DIVIDEND – Indicates item is a dividend curve.

• FOR – Indicates item is used for forecasting.

• INFLATION – Indicates item is an inflation curve.

• PREPAY – Indicates item is a prepay curve

• PRIME_SPREAD_CURVE – Indicates item is a prime spread curve.

• PROB – Indicates item is probability curve.

• REC – Indicates item is recovery curve.

• RISKY_DIS – Indicates item is credit spread curve.

• SVOL – Indicates item is volatility surface.

• VOL – Indicates item is a volatility curve.

marketDisruptionEvents Add the names of the default market disruption events for commodity
confirmations. You can view these keywords from the Commodity
product trade worksheet. Choose ProductName > Commodity Confirm
Keywords. The application automatically selects the market disruption
events.

marketDisruptionEventsAll Add the names of all of the possible market disruption events for
commodity confirmations. You can view these keywords from the
Commodity product trade worksheet. Choose ProductName >
Commodity Confirm Keywords. The application automatically selects
the default events that you define in the marketDisruptionEvents
domain. You can select additional events.

marketIndexType Stores the types that you can select when creating an index in the
Market Index Window.

marketType Select the market type from the following: Primary, Re-Issue, Secondary,
and When-Issued.

masterConfirmAdditionalField Stores the attributes that you can select in the Master Confirmation
Window when setting up Credit Derivatives confirmations for DTCC. Use
these attributes when setting up static data filters.

You can extend this list.

masterConfirmationType Stores the types of confirmations that you can select in the Master
Confirmation Window when setting up Credit Derivatives confirmations
for DTCC.

You can extend this list.

MatchingContext The rules that you can select in the Matching Configuration Window for
SWIFT message matching.

You can create a custom matching context. Create a class named
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tk.refdata.<ContextType>MatchingContext that extends
com.calypso.tk.refdata.MatchingContext. Register the context
type in the MatchingContext domain.

Refer to the Calypso Class Library for details.

MatchingContext.Amounts Types of amounts that are used as criteria in the message matching
process. Calypso out-of-the-box includes the following amount types:
MONEY_AMOUNT, NOMINAL_AMOUNT, RETURNED_AMOUNT, REPO_
RATE, and TRADE_PRICE.

You can add new amount types to the MatchingContext.Amounts
domain. They need to be implemented in the
com.calypso.tk.util.swiftparser.MessageMatcher interface to
be used in the matching process.

Refer to the Calypso Class Library for details.

MatchingContext.Dates Types of dates that the Matching Message engine uses as criteria in the
message matching process. Calypso out-of-the-box includes the
following date types: MATURITY_DATE, SETTLE_DATE, and TRADE_
DATE.

You can add new date types to the MatchingContext.Dates domain.
They need to be implemented in the
com.calypso.tk.util.swiftparser.MessageMatcher interface to
be used in the matching process.

Refer to the Calypso Class Library for details.

MatchingContext.Fields Types of fields that the Matching Message engine uses as criteria in the
message matching process. Calypso out-of-the-box includes the
CURRENCY and TRADE_TYPE fields.

Refer to the Calypso Class Library for a complete list.

You can add new field types to the MatchingContext.Fields domain.
They need to be implemented in the
com.calypso.tk.util.swiftparser.MessageMatcher interface to
be used in the matching process.

MatchingContext.References Type of references that the Matching Message engine uses as criteria in
the message matching process. Calypso out-of-the-box includes the
following reference types: AGENT, CNTP, CLEARER, and PO.

You can add new reference types to the MatchingContext.References
domain. They need to be implemented in the
com.calypso.tk.util.swiftparser.MessageMatcher interface to be used in the
matching process.

Refer to the Calypso Class Library for details.

MatchingContext.Roles Types of roles that the Matching Message engine uses as criteria in the
message matching process. Calypso out-of-the-box includes the
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following role types: CNTP, AGENT, and PSET.

You can add new role types to the MatchingContext.Roles domain. They
need to be implemented in the
com.calypso.tk.util.swiftparser.MessageMatcher interface to
be used in the matching process.

Refer to the Calypso Class Library for details.

MCCTimeStatus No longer used.

measuresForAdjustment Stores a list of measures that you can adjust in the P&L Mark Adjustment
window.

MESSAGE.Templates Contains a list of templates for messages documents, such as
confirmation statements and trade tickets. You can select the template
in the message configuration in the Message Configuration Window.

Calypso includes a standard set of templates that you can use out-of-
the-box. You can also modify the templates or create your own
templates. Register new templates in this domain.

Refer to the Calypso Message Templates User Guide for details, or
choose Help > Message Template Keywords.

messageAction Actions that back-office users can apply to advice message tasks in the
Task Station.

Refer to the Calypso Messages User Guide for descriptions of the
actions.

MessageAttributeCopier Contains a list of attributes that need to be copied while copying
messages.

messageGrouping Add types of message groups to process multiple messages in a single
global message.

Refer to the Calypso Message Groups User Guide for details.

messageStatus Lifecycle status of a trade advice document. You can extend the list of
statuses.

Refer to the Calypso Workflow User Guide for details.

messageType Types of advices and payment messages.

Refer to the Calypso Messages User Guide for descriptions of the
messages.

MirrorCollateralAttribute The system does not automatically copy the custom collateral attributes
that you set manually on a repo's securities to the mirror trades. Add
attributes to the MirrorCollateralAttribute domain so that the system
copies them to the mirror trades.

MirrorKeywords The system does not automatically copy the custom keywords that you
set manually on a trade to the mirror trades. Add keywords to the
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MirrorKeywords domain so that the system copies them to the mirror
trades.

mktDataInstance Codes that indicate the type of market action a quote or curve
represents. Calypso includes the following: CLOSE, LAST, and OPEN.

mmkt_type Money market loan and deposit types.

MsgAttributes Attributes that attach to BOMessages and contain additional information
about the message. You can extend this list.

MsgAttributes.NackReason Used in rejection messages sent by SWIFT to Calypso. Contains the
Reject code reasons as provided within the tag 405 of the message.

multiObligValMethodChoice Credit Derivatives multiple obligation references with multiple valuation
dates: Average Blended Highest and Average Blended Market.

multipleValMethodChoice Credit Derivatives multiple day valuation methods: Average Highest,
Average Market, and Highest.

MutationType No longer used.

negociatedPriceType Types of negotiated prices, which you can select when trading equities.

nettingHandler Stores the names of netting methods that can be selected in the netting
configuration.

To create a custom netting method, create a class named
tk.bo.<MethodName>NettingHandler that extends
tk.bo.DefaultNettingHandler. Register the method name in the
nettingHandler domain.

nettingType Levels at which payments can be netted. You can extend this list.

Refer to the Calypso Settlements User Guide for details.

newEventTypeTradeAction Stores the list of trade action on which the Message engine generates
confirm message only for new event type action.

novationTransfereeRole Used when novating a Credit Derivatives trade in the Termination
Window. Contains the possible roles for the transferee, that is, the party
who is taking over the rights, liabilities, duties, and obligations from the
transferor. Calypso includes the ProcessingOrg and CounterParty roles.

obligationCharacteristics Names of the characteristics that you can select in Credit Default Swap
trades. You can extend this list.

obligationType Obligation Category that you can select in Credit Default Swap trades.

obligValMethodChoice Credit Derivatives multiple reference obligations with a single valuation
date: Blended Highest and Blended Market.

ObservableDataType Add the types of data that are observed.

Refer to the Calypso Equity Derivatives User Guide for details.

ObservableDomainType Add the product types for which you want to create observable data.
Define observable data for equities underlying Equity Linked Swap (ELS)

Nasdaq Calypso
Getting Started User Guide / Version 18

April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 60 / 253



April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 61 / 253

trades.

Refer to the Calypso Equity Derivatives User Guide for details.

ObservableRule In Equity Linked Swap (ELS) trades, the type of quote used to perform
price fixing. Calypso includes the following quote types: ASK, BID,
CLOSE, LAST HOUR AVG, MAX INTRADAY, and OPEN. You can extend
this list.

ObservableSrcType The source type for the observable data. The source type is MarketPlace
for ELS trades. You can extend this list.

OneFactorModelSurface.gensimple Names of the generators for simple One Factor Model surfaces. Calypso
out-of-the-box includes the OFMDefault generator.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom generators and register them in the
OneFactorModelSurface.gensimple domain.

Refer to the Calypso Developer’s Guide for details.

OneFactorModelSurfaceGenerator Names of the generators for derived One Factor Model surfaces.
Calypso out-of-the-box includes the OFMCapsSwaptions generator.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom generators and register them in the
OneFactorModelSurfaceGenerator domain. Create a class named
tk.marketdata. VolSurfaceGenOFM<Name> that extends
com.calypso.tk.marketdata. VolSurfaceGenOFM.

Refer to the Calypso Class Library for details.

optContractDateGen Add the names of custom date generators that you can select when
defining future option contracts in the Future Option Contract Window.

Refer to the Calypso Developer’s Guide for details about how to create
a custom date generator for a future option contract.

OptionType Type of option.

OrderAttributes Stores the names of attributes that you can define in the Order Window.
OtcProductCode.Location Allows various interfaces to always utilize the correct MiFID product

code framework by specifying whether the MiFID product code is stored
as a trade keyword or product/sec code. This ensures compatibility with
all interfaces (e.g., Data Uploader), even when the newMiFID codes are
backported to different versions of Calypso.

When the domain name “OtcProductCode.Location” is assigned the
value ProductSecCode, MiFID codes will be stored as product/Sec
Codes. When the domain name is not assigned a value (blank), the codes
will be stored as Trade Keywords.

The following relationship shows how the codes are expressed in the
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system as either Trade Keywords or Sec Codes, respectively:

• InstrumentISIN <> ISIN

• InstrumentCFI <> CFI

• InstrumentFullName <> FullName

PathType The possible path types in Vanilla OTC Equity Options. When the
EQUITY_DERIVATIVES_X environment property is set to true, then you
can select the path type in the Product panel.

PayoffType When the EQUITY_DERIVATIVES_X environment property is set to true,
then you can select the pay off type in the Product panel. You can
extend this list.

payoutFormula Specifies the names of payout formulas. Calypso includes the Barrier,
Binary, CappedSwap, and RangeFloater formulas.

You can create a custom payout formula and register the formula name
in the payoutFormula domain.

Refer to the Calypso Developer’s Guide for details.

PCCreditRatingLEAttributesOrder To define the order of credit rating attributes in the Pricer Configuration
Window > Credit panel.

Example: RED_REGION,RED_SECTOR

PerformanceSwap.PrimaryLegConfig Types that you can select for the primary leg of the performance swap.

PerformanceSwap.SecondaryLegConfig Types that you can select for the secondary leg of the performance
swap.

PhysicalCommodityType Stores types for physical commodities that you can select when setting
up the commodity product. The type determines the attributes used in
pricing.

PM_Form SWIFT precious metal codes. You can enter a free-format value.

PositionBasedProducts List of products that return true in their implementation of
isPositionBased. This list is used internally for excluding the trades
whose products are position based from trade filters with that criteria.

This list is not to be modified, and should include at most all products
that are position based products. Including products which return false
from their isPositionBased implementations will result in incorrect
behavior when loaded through trade filters with the property
setIncludePositionBased to false.

Not including all position based products in this list will only result in
lower performance and higher memory requirements when loading trade
filters with the property setIncludePositionBased to false.

postingStatus The status of the posting in its lifecycle. You can add statuses to the list.

postingType Labels to be placed on an accounting posting, indicating whether it is a
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normal posting or a reversal.

PreciousMetalBaseLocation.XAU Base location for the precious metal currency as defined in the currency
definition.

PreciousMetalLocations.XAU Trading locations for the precious metal currency as defined in the
currency definition. A spread can be added to these locations.

principalStructure Types of amortizing structures.

You can create custom structures and register them in the
principalStructure domain.

Refer to the Calypso Developer’s Guide for details.

Probability.gen Names of the generators for Probability curves. Calypso includes the
Probability generator.

You can create custom generators and register them in the
Probability.gen domain.

Refer to the Calypso Developer’s Guide for details.

prodAggr Names of product aggregation configurations that you can use in risk
analyses.

productClass Financial product classes; market in which an instrument is traded.
Calypso includes the following classes: Commodity, Equity, FX, and
FixedIncome.

productFamily Financial product families used in back office processing. You can
extend this list.

productGroup Names of product groups that you can use in message configuration.

productInterface Product Interfaces used in defining Report Framework columns. Add
new interfaces to this domain.

productInterfaceReportStyle Lists all product interfaces having a report style.

productType Product types, which are the product class names.

You can create custom products and register the class name in the
productType domain.

Refer to the Calypso Developer’s Guide for details.

ProductUseTermFrame As of v13.0, the default Termination window is TermFrame. It is displayed
by default for all the product types that use the default Termination
window.

For all the product types that were using an extension of
TerminationWindow, they can also use TermFrame, provided they now
use the <product type>TermPanel API, and they are added to this
domain.

Out-of-the-box, the following product types use the <product
type>TermPanel API: Cash, CreditDefaultSwap, EquityLinkedSwap,
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PerformanceSwap, Repo, SecLending.

Please contact Calypso Product Support for details.

productTypeReportStyle Lists all product types having a report style.

PropagateBlockTradeChangesAction You can configure the action that is applied to the child trade when edits
to the block trade are propagated. From the Calypso Navigator, navigate
to Configuration > System > Domain Values and set the action in the
PropagateBlockTradeChangesAction domain. The default value for this
domain is AMEND, so you should set this domain to a different action so
that the propagation of edits can be distinguished from direct
amendment of the child trade.

Example:
Set the domain PropagateBlockTradeChangesAction to PROPAGATE.
Set the trade workflow rule NotAllocationChild on action AMEND.

PropagateCollateralAttribute The list of attributes to be copied from the repo's securities into the
transfer attributes. The PropagateCollateralAttribute transfer workflow
rule is also required.

The collateral attributes that you want to propagate must also be added
to the domain "XferAttributes”.

PropagateTradeKeyword The list of keywords to be copied from the trade into the transfer
attributes. The PropagateTradeKeyword transfer workflow rule is also
required.

The trade keywords that you want to propagate must also be added to
the domain "XferAttributes”.

PropertyTemplateType Templates for various market sectors of Commodity Certificates.

QEQtSpreadRule No longer used.

QEQtValRule No longer used.

quoteGroup Binding groups of quotes within a quote set for finer grained access
permission. For example, add a value of BondUST* to the qutoeGroup
domain. You can assign read/write access permissions for BondUST
quotes.

quoteName Stores special quote names that the system generates. For example,
stores special bond-related quotes that have a different quote name
every day because the index factor changes.

quoteType Format of quotes.

rate_index Names of the rate indices that you can use to reset rates.

rate_index_source Quoting sources for the indices. You can extend this list.

rate_index_type Rate index type. Calypso includes Inflation and Interest. You can extend
this list.

rateIndexAttributes Names of attributes that store additional information about the rate
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definition. You can extend this list.

RateSource Used in the Cash Settlement application in Interest Rate Derivatives.

Refer to the Calypso Cash Settlement User Guide for details. You can
extend this list.

ratingAgency Rating agency names that you can select in the Credit Rating window.
You can extend this list.

ReconcileInventoryComment Comments that you can select in the Reconcile Inventory window in the
reconciliation results. You can extend this list.

ReferencePriceFixingMode When the EQUITY_DERIVATIVES_X environment property is set to true,
you can select the Observable Variable fixing mode in the Product panel.
Calypso includes the following values: Asian, Lookback, and Spot.

ReferenceRates.<FX Product Type> Within the Domain Value, configure Reference Rate field names for each
Trade Type. These field names will be displayed in the Calypso trade
entry screens. (e.g. for RefernceRates.FXForward, the values could be
Allin, Points, and Spot.)

Reference Rate support for FX products include product types FX Spot,
FX Forwards, FX Swap, FX NDF, FX NDF Swap, FX Window Forward, FX
Average Rate Forward, FX Flexi Forward, FX Merchant FX, FX Strip and
FX Forward Start.

remittanceType Remittance method for the Customer Transfer. Calypso includes the
following types: DemandDraft, MailTransfer, and TelegraphicTransfer.
You can extend this list.

Repo.DispatchInterestMethod Contains the interest dispatching calculation methods for GSCC Repo
Substitutions.

You can create a custom method. Create a class named
tk.bo.BORepo<name>DispatchInterestHandler that implements
com.calypso.tk.bo.BORepoDispatchInterestHandler. Register
the custom name in the Repo.DispatchInterestMethod domain.

RemoveGroup You can remove workflow of message for checking advice messages.
You have the value as workflowRuleMessage.

REPORT.Functions Contains the names of the aggregation functions that you can use with
the report framework. Calypso out-of-the-box includes the following
functions: Average, Count, Maximum, Minimum, and Sum.

In the report, you can specify the aggregation functions under Subtotals
> Configure Functions, or Totals > Configure Functions. Note that you
first need to specify subtotals and totals.

You can add custom aggregation functions. Create a class named
tk.report.function.<function_name> that implements
com.calypso.tk.report.function.ReportFunction. It will be
invoked from
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com.calypso.tk.report.function.FunctionFactory. Register
the custom function name in the REPORT.Functions domain.

REPORT.Templates The default HTML template for reports is default.html located under
<calypso
home>/client/resources/com/calypso/templates/report.

You can create an HTML template using a number of keywords, and
register the template name in this domain. Choose Help > Report
Template Keywords to view the list of Report Template Keywords.

REPORT.Times Use for setting the valuation time for reports. Enter the type of report for
the Value, and enter the valuation time in the Comment. For example,
value=Trade comment=11:59:00 PM.

REPORT.Types Types of reports.

You can create custom reports and register the report names in the
REPORT.Types domain.

Refer to the Calypso Developer’s Guide for details.

restriction Add names of restrictions that you can assign in the Access Window.

retroActivity Rules indicating a period of allowable retroactivity for postings from a
particular type of accounting event.

Refer to the Calypso Accounting Postings User Guide for details.

reversalRule For a particular accounting rule, indicates when to post reversals.

Refer to the Calypso Accounting Postings User Guide for details.

riskAlternateCurveInterpolateAs For reports that use the alternate interpolator feature (e.g. Scenario,
sensitivity, multi-sensitivity): This domain controls what replaces
Interpolate As in the curves.

A value must be defined for this domain value when using an alternate
interpolator.

riskAnalysis Types of valuation and risk reports.

You can create custom risk analysis reports and register them in the
riskAnalysis domain.

Refer to the Calypso Developer’s Guide for details.

riskPresenter Names of analyses that can be viewed through the Risk Presentation
Service.

roDSFunction Functions that the read-only Data Server executes.

Refer to the Calypso Installation Guide for details.

role Roles for Legal Entities. You can extend this list.

salesPerson Enter the names of sales people. On the trade you can select the sales
person to track the sales margin.
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scenarioMarketDataFilters Add custom extentions of ScenarioMarketData.

scenarioRule Contains the names of custom scenario rules.

ScenarioViewerClassNames Add the class names of scenario viewers in this domain. You can select
the viewer in the Scenario Editor from a dialog window.

You can create custom scenario report viewers and register the class
names in the ScenarioViewerClassNames domain.

Refer to the Calypso Developer’s Guide for details.

scheduledTask Names of the scheduled tasks that automate processing and report
generation in the system.

Refer to the online help file available in the Scheduled Task window
and the Calypso Scheduled Tasks User Guide for details about the
scheduled tasks that Calypso provides out-of-the-box.

You can create custom scheduled tasks and register them in the
scheduledTask domain.

Refer to the Calypso Developer’s Guide for details.

sdiAttribute SDI attributes allow recording additional information that can be used by
the message formatting tools. You can extend this list.

sdiCompareKeys SDI compare keys allow override the default SDI matching keys. You can
extend the list.

sdiStatus Keyword applied to a TradeTransferRule or a BOTransfer to indicate
whether and how settlement instructions were assigned.

• Assigned – Settlement instructions were assigned by a user in the
Calypso applications.

• Default – The system automatically assigned the default settlement
instructions.

• GSTPA – Manual SDI for GSTPA support.

• Manual – Manual SDI.

• TBA – No instructions have been assigned.

• Xfer Assigned – Settlement instructions were uniquely assigned to
this transfer.

secondaryCreditEventBased List of credit event based products.

securityCode A product code can be a unique identifier such as the ISIN code, or a
user-defined code for classification purposes. The product code can be
used throughout the system for searching products, and grouping
products for settlement and delivery instructions for example. You can
add new product codes to the securityCode domain.

Refer to the Calypso Fixed Income User Guide for details.
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securityCode.DebtSeniority Seniority that you can select in credit ratings.

securityCode.DesignatedPriority Priorities that you can select for the CDS Loan.

SecurityLending.autoMarkType Mark Type for Auto Marking Procedure in Security Lending.

SecurityLending.loanType Loan Types in Security Lending.

settlementMethod Settlement methods that you can select in the settlement and delivery
instruction (SDI).

settlementType Settlement types for bond calls and redemptions.

SimpleAvgPreventCutoffPeriodCollapse For swap and structured flows trades: When this domain value is set to
true, when averaging frequency is set to DLY and a cutoff lag is applied,
the cutoff period is not collapsed into a single period. Instead, the daily
periods are retained and the cutoff rate is applied to those daily periods.
This slightly changes the daily average rate that is calculated.

SimpleMM.ApplyOneDayInterest Used in Russian intraday repos, and repos of maturity type INTRADAY.
Configure a list of principal currencies or ANY to enable adding one day
on interest calculation.

sortMethod Sorting for position conventions that you can select in the liquidation
configuration.

You can create custom sort methods and register them in the
sortMethod domain.

Refer to the Calypso Developer’s Guide for details.

splitReason Add reasons for splitting transfers, which you can select when manually
splitting a transfer.

SpotDateCalculator Stores spot date calculators that you can select when setting up a rate
index in the Rate Index Attributes Window.

SpotDateCalculatorForSource Stores the source for the spot date calculators.

StatementNumbering In Account Definitions you can add rules to generate statement
numbers.

StatementType Add types of account statements that can be generated.

StrategyType Option strategies in the OTC Equity Option Vanilla trade window >
Product panel. You can select the strategy when you set the EQUITY_
DERIVATIVES_X environment property to true. You can extend this list.

StrikeFixingMode Type of strike fixing in the OTC Equity Option Vanilla trade window >
Product panel. You can select the strike fixing when you set the EQUITY_
DERIVATIVES_X environment property to true. You can extend this list.

swaptionCashSettleFeeType The fee type to be used for the cash settlement fee when exercising a
cash settled swaption.

Default behavior if not set is CASH_SETTLE_FEE.

SWIFT.Templates Names of the SWIFT message templates. Calypso includes a standard
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set of templates out-of-the-box.

You can create custom message templates. Register the template
names in this domain.

Refer to the Calypso Messages Templates User Guide for details.

SwiftMessage.Action For the message type ACK_MSG. The HandleAckNack workflow rule
applies the right action on the outgoing message, depending on the
ReturnedStatus msg attribute. By default ACK for an ACK, and NACK for
a NACK. The action can be customized by defining the comment of the
values ACK and NACK within the domain SwiftMessage.Action.

systemKeyword The domain "systemKeyword" is no longer used, and is replaced by the
class com.calypso.tk.core.SystemKeyword.

Refer to the SystemKeyword class in the Calypso Class Library for a
list of the system keywords. For backward compatibility, if the domain
"systemKeyword" contains custom keywords, then the system adds the
keywords to the list of system keywords.

You cannot edit the value of system keywords in the Keyword Window,
nor can you remove system keywords.

systemLimitKeyword System keywords that can be applied to limits.

Related Domains:

limitKeyword

systemKeyword

systemProperty Add global settings properties with name as "value" and value as
"comment".

taskPriorities Defines the priorities of the task. Calypso includes “1.LOW”, “2.NORMAL”,
and “3.HIGH”.

templateLinkRegion In Credit Derivatives issuer to template linking, Region and Type are
retrieved by default from the issuer attributes RED_REGION and RED_
TYPE. However, you can specify the name of the issuer attributes to be
considered in the domains templateLinkRegion and templateLinkType.

templateLinkType In Credit Derivatives issuer to template linking, Region and Type are
retrieved by default from the issuer attributes RED_REGION and RED_
TYPE. However, you can specify the name of the issuer attributes to be
considered in the domains templateLinkRegion and templateLinkType.

tenor Add custom tenors to this domain.

You can create custom tenor calculators that add tenors to the tenor
domain.

Refer to the Calypso Developer’s Guide for details.

terminationAgreement The type of early termination agreement in an Equity Linked Swap. You
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can extend this list.

• BILATERAL – Both parties have the right to terminate the agreement
early.

• CP – The counterparty, only, has the right to terminate the
agreement early.

• PO – The processing organization, only, has the right to terminate
the agreement early.

terminationAssignee List of termination assignees. You can extend this list.

terminationAssignor List of termination assignors. You can extend this list.

terminationPmtType Termination payment types. You can extend this list.

terminationReason List of termination reasons. You can extend this list.

tickerKeyword You can add keywords to tickers in the Credit Market Data/Credit Curve
Blotter. Choose Configure > Tickers.

Refer to the Calypso Credit Derivatives User Guide for details.

tickSize Denominators for the fractional portion of a price quote. You can extend
this list.

TPAcessPermCategory No longer used.

tradeAction Actions that the system automatically applies to trades; actions that
back-office users can apply to trades in the Task Station.

Refer to the Calypso Workflow User Guide for descriptions of the
actions.

tradeCancelStatus Lists the workflow status codes that identify canceled trades, and return
zero for all pricer measures.

TradeCFDExePortfolio Execution portfolios in Contract for Difference (CFD) trades. You can
extend this list.

tradeExerciseAction Actions that you can apply to exercise options in the Option Exercise
Window.

tradeExpiryAction Add actions in this domain that you can apply to options in the Option
Exercise Window to expire them worthless. Calypso includes EXPIRE and
CANCEL by default.

When you select one of these actions in the Option Exercise Window and
click Set Selected or Set All, the application clears the Create Underlying
checkbox.

tradeKeyword Contains keywords that attach to trades and contain additional
information about the trade. Some keyword values are generated by the
system while others you can define. You can extend the list of keywords.

Instead of using the tradeKeyword domain, you can create domains by
product type using the format <product_type>.keywords. An example is
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FX.keywords. Add the domain to domainName. Products that do not
have a specific keyword domain defined use the tradeKeyword domain.

You can create a drop-down menu for trade keywords so that users can
select a value for the keyword.

• If you are using the tradeKeyword domain, add the keyword to the
tradeKeyword domain. Then add a domain named
keyword.<keyword_name> to domainName. Finally, add the values
for the drop-down menu to the created domain. For example, add
the keyword Branch to the tradeKeyword domain, create a domain
named keyword.Branch, and add the values London, New York, and
Tokyo to the keyword.Branch domain.

• If you are using a <product_type>.keywords domain, add the
keyword to the <product_type>.keywords domain. Then add a
domain named keyword.<product_type>.<keyword_name> to
domainName. Finally, add the values for the drop-down menu to the
created domain. For example, add the keyword Branch to the
FX.keywords domain, create a domain named keyword.FX.Branch,
and add the values London, New York, and Tokyo to the
keyword.FX.Branch domain.

You can view and set trade keywords in the Keyword Window, and view
keywords in the blotter.

Additionally, you can create a custom trade dialog window for your
custom trade keywords.

Refer to the Calypso Developer’s Guide for details.

Related Domains:

keywords2CopyUponAllocate

keywords2CopyUponExercise

keywords2CopyUponExpiry

keywords2CopyUponRolloverAndRollback

keywords2CopyUponSpotReserveSetVal

keywords2CopyUponTransfer

MirrorKeywords

PropagateTradeKeyword

systemKeyword

tradeTmplKeywords

TradeLevelOverride.MdiKeys Lists all the market data item override keys defined in the system.

TradeLevelOverride.PricerKeys Lists all the pricer override keys defined in the system.
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TradeLevelOverride.Products Lists all the products that support trade level override functionality.

tradeNoteType Trade note types. You can add your own note types by extending this
list.

trader Names of traders. You can select the trader name in the User Defaults
configuration, or in the Trade Details. You can extend the list of trader
names.

TradeRejectAction Stores the names of actions that will perform an undo. The Reject trade
workflow rule is also required. A special message type should be set up
on the terminated trade status.

tradeStatus Lifecycle status of a trade. Select a trade status for the original status
and resulting status in a workflow transition.

When setting up the workflow, you can add custom trade statuses in the
tradeStatus domain.

Refer to the Calypso Workflow User Guide for more information about
trade statuses.

tradeTerminationAction Lists the actions that are used from Termination window only, if the
domain is empty then TERMINATE is considered as "in".

tradeTmplKeywords Add keywords to the tradeTmplKeywords domain that you want to store
and use with a trade template. Note that you also need to add the
keywords to the tradeKeyword domain if not already present.

tradeTransferAction Used in the Trade Transfer Window. Contains the actions that you can
apply when transferring a trade from one book to another book, or when
transferring a trade from one counterparty to another counterparty. You
can add actions to this domain.

tradeUpfrontFeeType Upfront fee type for all CRD products. UPFRONT_FEE is defined out-of-
the-box.

trancheFamily Lists all the standard tranche families supported in the market. You can
increase the list.

transferAction Actions that the system automatically applies to transfers; actions that
back-office users can apply to payment and transfer tasks in the Task
Station.

 Refer to the Calypso Workflow User Guide for descriptions of the
actions.

transferReport.condition Stores queries on date comparisons for use in the Transfer Report.

You can add custom conditions to the transferReport.condition domain.
Enter a name for the query in the domain Value, and enter the actual SQL
query in the Comment.

transferStatus Lifecycle status of a transfer or payment. Select a transfer status for the
original status and resulting status in a workflow transition.
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When setting up the workflow, you can add custom transfer statuses in
the transferStatus domain.

Refer to the Calypso Workflow User Guide for more information about
trade statuses.

unavailabilityReason Stores reasons that you can select when making a security position
unavailable by creating an unavailability transfer.

Use_Pmt_Hols_for_Curve_Gen In the Rate Index Definition > Rate Index Attributes Window, set this
attribute to one of the following:

• true – Use payment holidays from the rate index to generate swap
start and end dates.

• false – Use the Rate Index's Reset Holidays to generate the dates.

Use_Pmt_Hols_for_Fwd_End_Dt In the Rate Index Definition > Rate Index Attributes Window, set this
attribute to one of the following:

• true – The system uses the reset holiday(s) and payment holidays(s)
when calculating the forward end date.

• false (default value) – The system uses the reset holiday(s) only
when calculating the forward end date.

UseColumbianDevaluationConcepts True or False. Unlocks Devaluation, Devaluation Spread, and Client
Devaluation fields for use in USD/COP FX trades in the Quick Trade Entry
window and Pricing Sheet. Default is False.

UseQuantity For Repo and Security Lending trades, set this domain value to "true" to
enable the Quantity field in the trade window regardless of quote type
set on the collateral. Set to "false" to disable the field in all instances.

useNextEvent Use with the Transfer engine and the XFER_NEXT_EVENT parameter set
to true. Add product family names to the useNextEvent domain to use
the NextEvent logic. The system generates all transfers for products not
listed in the useNextEvent domain.

userAccessPermAttributes Add permission attributes related to a specific user.

You can create attributes related to the maximum number of objects that
can be loaded in a report. User the format Max.<ObjectName>.

Define the attribute values in the Access Window > Users panel >
Permission Attributes.

userAttributes Add attributes to specify in the User Defaults profile.

UserTypes Types of users that you can select in the User Defaults profile. You can
extend this list.

valMethodChoice Credit Derivatives valuation method.

volatilityType Volatility type that you can select in the volatility surface.

You can create custom volatility types and register them in the
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volatilityType domain.

Refer to the Calypso Developer’s Guide for details.

VolSurface.gensimple Names of simple volatility surface generators. You define the surface
points.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom volatility surface generation algorithms and
register them in the VolSurface.gensimple domain.

 Refer to the Calypso Developer’s Guide for details.

volSurfaceGenerator Names of volatility surface generators. The surface points are derived
from the underlying instruments.

Refer to Calypso Interest Rate Derivatives Analytics for details.

You can create custom volatility surface generation algorithms and
register them in the volSurfaceGenerator domain.

Refer to the Calypso Developer’s Guide for details.

volSurfaceGenerator.commodity Add custom generators for COMMODITY volatility surfaces.

volSurfaceType Volatility surface types.

volUsages Contains the names of volatility usages, so that you can assign multiple
volatility surfaces with different usages for the same Currency, Vol Type,
Index, Tenor, Product Type, Subtype, and Put/Call in the Pricer Config >
Surfaces panel. Calypso includes the VOL usage. This usage is assigned
to all of the surfaces by default.

You can extend this domain by adding usages such as ATM and OTM.

Warrant.Deliverable Add Warrant underlying products to this domain so that you can select a
delivery type. If the underlying product is not defined in this domain, then
the delivery type is automatically set to Cash.

Warrant.Delivery The delivery type in case of exercise/assignment of the Warrant product.

Warrant.Status Possible statuses for Warrant products.

Warrant.Type Class of product to set up in the Warrant/Certificate Window. Calypso
includes Warrant and Certificate.

Warrant.Underlying List of underlying products that you can select when setting up a warrant
in the Warrant/Certificate Window.

Warrant.UnderlyingEditable Add Warrant underlying product types that are not managed in Calypso
in this domain. Users can enter a description for products defined in this
domain.

WHTAccountAttribute Names of withholding account attributes.

WHTBookAttribute Names of withholding book attributes.

WHTLEAttribute Names of withholding legal entity attributes.
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workflowRuleMessage Workflow rules to check advice messages.

You can create custom workflow rules and register them in the
workflowRuleMessage domain.

Refer to the Calypso Developer’s Guide for details.

workflowRuleTrade Workflow rules to check trades.

You can create custom workflow rules and register them in the
workflowRuleTrade domain.

Refer to the Calypso Developer’s Guide for details.

workflowRuleTransfer Workflow rules to check payments and transfers.

You can create custom workflow rules and register them in the
workflowRuleTransfer domain.

Refer to the Calypso Developer’s Guide for details.

workflowType Types of workflows. Calypso includes some workflow out-of-the-box
like Message, Trade, Transfer, etc.

You can create custom workflows for entities. Add the entity name in the
workflowType domain. You can also create custom workflow rules for
entities. Create a new domain named workflowRule<EntityName> and
add the rule names to the domain.

Refer to the Calypso Developer’s Guide for details.

worldTime You can use this domain to customize the world times displayed under
Configuration > Market Data > Utilities > World Time.

By default, six cities are displayed there. If you want to change the
display, you need to define six cities in this domain, and it will override
the default display.

The value should be a valid city code, and the comment should be a valid
timezone.

XferAttributes Attributes associated with transfers. You can view the attributes in the
BO Browser, Task Station, and Transfer Report. You can extend this list
as needed.

XferProfileType Add names of transfer profile types, to apply billing rules to any fees in
the system.

XferWorkflowType Add names of workflow profile types, to apply workflow rules to any fees
in the system.

yieldMethod Method for calculating the bond's dirty price.
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8. Defining Countries
From the Calypso Navigator, navigate to Configuration > Definitions > Countries (menu action
refdata.CountryWindow) to define countries.

Countries are mostly used when creating legal entities.

Country window

» All existing countries are loaded by default.

You can filter the list of countries using the Filter tab, as needed.

You can select a list of countries and/or enter an active date.

You can click to configure the column display.

» Countries are identified by their name throughout the system.

» You can specify user-defined attributes for selection and reporting purposes.

» You can export / import countries to XML files using the XML menu.

8.1 Creating a Country

» Click to create a new country. You will be prompted to select an ISO code.

Only the ISO codes specified in the Java locale are available for selection.

To add an ISO code which is not in the Java locale, you can add it to the domain “additionalCountryISOCode”.
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» Then click the panel and enter information into the fields as applicable. The fields are described
below.

» Click to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Details

Details panel

Fields Description
ISO Code The ISO code is associated with a country when you create it.

Name Enter the name that will identify the country throughout the system.

Time zone Select a time zone from the drop-down box.

Currencies Select currencies from the drop-down box.

Default Holidays Select holiday calendars from the drop-down box.

Effective From

Effective To

Enter active dates to cover the timeframe of the project.

Enabled Check / uncheck to enable / disable the country.

This setting is only used in conjunction with the CheckValidCountry transfer rule and
CheckValidCountry message rule to prevent payments from being authorized when the
country of the counterparty’s agent is disabled, or to prevent messages being sent when the
country of the receiver is disabled.

This rule can be placed on the transition PENDING - AUTHORIZE - VERIFIED in the transfer
workflow.
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Fields Description
This rule can be placed on the transition PENDING - AUTHORIZE - TO_BE_SENT in the
message workflow.

Attributes Click Attributes to define country attributes.

See Defining Country Attributes for details.

Sample Usage

Sample legal entity

8.2 Modifying a Country
» Select a country from the list, then click Details from the right-hand side.

Make changes as applicable.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

 Ⓘ [NOTE: If you modify a country, it will impact currencies, legal entities and related data, and products]

8.3 Delet ing a Country
» Select a country from the list, then click Delete.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

 Ⓘ [NOTE: If you delete a country, it will impact currencies, legal entities and related data, and products]

8.4 Defining Country Attr ibutes
Country attributes can be used for selection and reporting purposes.

» Select a country from the list, then click the Attributes field. The Attributes Window will appear.
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Sample country attributes

Click Domain to add or delete attributes.

Then click Save to save your changes.

» Then double-click the Value cells to set values for the corresponding attributes.

Click Apply.

 Ⓘ [NOTE: If you want to specify a list of possible values for a given attribute, create the domain
“CountryAttributes.<attribute name>”, and add the values to that domain - the name is case sensitive]

8.5 Defining an Address Format
The address format is used in Swift messages.

» Select a country from the list, then click Address Format. The Mail Address Formatter dialog will appear.

Sample address format
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Select items and click Add Item as needed.

You can add separators between the items. Select a separator and click Add Separator.

Then click Validate to save the address format.

» Then click Save in the Country window to save your changes.

8.6 Displaying Pending Authorizat ions
» Select a country from the list, then click Pending Authorization to display any country pending authorization. This

only applies if the Authorization mode is enabled.
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9. Defining Currencies and Currency
Pairs
From the Calypso Navigator, navigate to Configuration > Definitions > Currency Defaults (menu action
refdata.CurrencyDefaultJFrame) to define currencies and currency pairs.

Currencies

» A currency is identified by a currency code throughout the system. Select the Currency Default panel to define
currencies and their associated static data.

» You can specify user-defined attributes for selection and reporting purposes.

Currency Pairs
Select the Currency Pairs panel to define currency pairs and their associated static data.

Nasdaq Calypso
Getting Started User Guide / Version 18



» You can specify user-defined attributes for selection and reporting purposes.

9.1 Creating a Currency
Select the Currency Defaults panel to define a currency and its associated static data.

» Click ... next to the Currency field to add a currency code to the Ccy list. Once the currency code has been
created, select it from the Ccy list on the left hand-side of the window.

The selected currency code will appear in the Currencyfield. Enter the other fields as described below.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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Fields Details

Fields Description
Currency Displays the currency code when you select it from the Ccy list. The currency code will

identify the currency throughout the system.

You can click ... to add or remove currencies from the Ccy list.

ISO Code Enter the standard ISO abbreviation for the currency (International Organization for
Standardization).

Used in Swift messages in the environment property USE_CCY_ISO_CODE is set to true
(payment messages and MT940/MT950 messages).

Country Select the country of the currency.

This information is used to calculate country risk, as well as positions and limits by country.

Spot Days Enter the number of business days between the trade date and settlement (or start) date.

Holidays Click ... to select holiday calendars that apply to this currency for calculating business days.

Rounding Select the rounding convention: NEAREST, UP, or DOWN.

Rounding conventions are described under Help > Rounding Methods.

Decimals Enter the number of decimals used to display amounts according to the rounding
convention.

Rate Decimals Enter the default number of decimals used to display rates expressed in this currency.

However, if you set Rate Decimals to -1 here, the Rate Decimals specified in User Defaults
will be used instead. See Configuration > User Access Control > User Defaults (menu
action refdata.UserDefaultsWindow).

Day Count Select the default daycount convention for financial instruments expressed in this currency.

Def. Index Select the default reference index for financial instruments expressed in this currency (for
example, Swap USD will be derived by default with LIBOR).

Tenor Select the default tenor for the default reference index.

Group Click ... to select groups of currencies to which this currency belongs, such as CLS, EMU or
ILLIQUID.

The groups of currencies are user-defined. You can click Add to add currency groups to the
currencyGroup domain.

Currency groups are used by the CheckSTPCurrency workflow rule.

Location Select the timezone for the currency.

Warning Threshold Applies to repo trading only.

Enter a nominal amount that will trigger a warning when entering a repo trade.

External Reference Enter an external reference code for the currency as applicable.
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Fields Description
This is for information purposes only.

Settlement Cutoff Time Enter the settlement cutoff time for evaluating today FX Spot trades. A trade entered after
this time requires that you enter a mandatory comment in order to save the trade.

Select the timezone that corresponds to the cutoff time from the adjacent field.

The keyword AfterSettlementCutoffTime attaches to the trade.

Trading Cutoff Time This field is used to determine the first available trade date for a currency and currency pair
in eDealing.

The first available date for a currency is:
l Current business date (uses holidays defined in Currency Defaults), if the current time

is not greater than the cutoff time
l Business day following the current date/time (uses holidays defined in Currency

Defaults), if the current time is greater than the cutoff time

The first available date for a currency pair is the greater of the first available date of each
currency in the currency pair. If this date falls on a holiday for any of the two currencies, then
the next business day at the currency pair level is chosen.

Select the timezone that corresponds to the cutoff time in the adjacent field.

Precious Metal Check the Precious Metal box to indicate that the currency is a precious metal, XAU gold for
example.

You can also define the locations where the precious metal trades, as the spot price differs
between locations. Set the base location by selecting a user defined location from the drop-
down menu. This will be the default location in the trade entry window.

Click Locations to add location names.
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Fields Description

Enter the location name in the text field, click >> to add it to the list, and click Save.

Select the base location from the drop-down menu.

When you save the currency, the system creates Loco-Spread quotes in the quote set.

The system creates both allocated and unallocated quotes for the locations. However, the
base location does not have an unallocated quote, as the spread is zero.

• Allocated – When a client requires the precious metal to be physically segregated, with a
list of bar weights and assays (purity tests). Each bar has an identification code against
which its details are recorded and the client holds full title of this bar. It is merely held in
custody.

• Unallocated – when specific bars are not set aside and the client retains a general
entitlement to the metal. It is at its most convenient in this form, as it can be credited and
debited electronically between parties.

When you use the FX Spot, FX Forward, or FX Swap trade windows to capture precious
metal trades, you can set the location details in the Location panel.
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Fields Description
Select the location from the drop-down menu. The application automatically uses the
unallocated spread from the quote set. Select Allocated to use the allocated spread.

Non Deliverable Check the Non Deliverable box to specify that the currency is a non-deliverable currency in
FX trading.

Then you will be able to save a trade with that currency as an FX NDF trade.

 Ⓘ [NOTE: The Non Deliverable setting in User Defaults takes precedence over the
comparable setting in Currency Defaults]

Description Enter any description or comment if desired.

9.2 Defining Currency Attr ibutes
Currency attributes can be used for selection and reporting purposes.

Load a currency then click Attributes.

» Click ... to add attributes.

Then double-click a Value cell to set a value for the corresponding attribute.

» Click Apply.

» Then click Save to save your changes.
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 Ⓘ Note:Added a new domain ‘SubunitConversionFactor’ as an Out of the Box attribute to provide support for
currency with more than 100 sub-units.

9.3 Precious Metal Currency Information
An additional tab appears in the Currency Definition window when you are defining a precious metal called Precious
Metal Information. This tab allows you to define various forms for each precious metal.
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To define a new form, click , enter the name of the form and click OK. A new row will then be created, allowing you
to enter the information to define the new physical form of the precious metal.

Fields Description

Name The name for the physical form.

Description A description of the physical form.

Conversion Factor The factor required to convert one unit of this form to troy ounces.

Unit The unit of the form.

Fineness Percentage of the precious metal in the defined form. This is only for description purposes.

When you have entered the details for the precious metal physical form, click the Save Physical Forms button to save
the data.

» For every currency with which you trade a precious metal, other than USD, you must set the
DefaultCurrencyPairSplitSolveTarget attribute (accessed by clicking the Attribute button in the Currency Pairs tab)
to CrossPair. With this setting, the system will solve for the forward points of the cross pair in an FX trade.
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» A Triangulation rule should be set up so that all of your trades with a precious metal and a currency other than
USD are triangulated through USD. This is done through the Triangulation Currency Rule Manager.

See Triangulation Currency Rule Manager for details.

9.4 Chinese Yuan (CNY) Currency Information
The Chinese Yuan is a highly regulated currency. The People's Bank of China (PBOC) publishes the FX quote for CNY
and it produces the MID rate for USD/CNY. PBOC regulates the trading of USD/CNY spot rate and restricts the spread
to be greater than 0% and less than or equal to 1%. These rates are input manually.

Calypso validates the USD/CNY quote at two levels, in the Quote window and upon trade entry.

Step 1 – Define a rate reset in the FX Rate Definition window for USD/CNY and set the quote side to MID. To display
the FX Rate Definition window, navigate to Configuration > Foreign Exchange > FX Rate Definitions.
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Step 2 – In the Currency Definition window (Configuration > Definitions > Currency Defaults), select USD/CNY and
enter a Regulatory Tolerance of 1 and the Regulatory Validation Source as PBOC.
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Step 3 – Open the Quote window (Market Data > Market Quotes > Quotes). Enter the PBOC BID/ASK rates. These are
the same rate, which is the MID rate published by the PBOC. Then, save and close the Quote window. Re-open the
Quote window and enter the Spot BID / ASK rates. When you click Save, the validation is performed. These steps must
be completed in this order.
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Step 4 – The remaining steps are required for trade window validation.

Display the Book window for the book that you would like to use for the USD/CNY trade. Identify the legal entity
associated with the book (Configuration > Books & Bundles > Trading Book).
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Step 5 – Open the Legal Entity window for this legal entity and click the Attributes button. Enter the Attribute Type
RegulatoryRateQuoteSource and set the value to the Quote Set Type used in Step 3, then save.
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Step 6 – In the Workflow window, add the rule CheckFXSpotRateTolerance to each NEW and AMEND action.

If during either validation, the spread is >0% and <=1%, the quote or trade will be saved. If the rate is out of the
required range, an error message appears like that below.
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• The computation for validation is:

(HIGHEST ASK - LOWEST BID)/ TODAY'S PBOCMID RATE.

• The Highest Ask and Lowest Bid are dynamic based on the latest data from the trades done throughout the day.
The first validation check is based on the initial static FX rates manually input in the morning in the Quote window.
Dynamic implies that if a trade is done which is still in the 1% range but the quote is lower than the BID rate on the
quote window or higher than the ASK rate, these then become the Highest Ask and the Lowest Bid for the next
trade validation check.

• Each time the trade is amended, or goes through a trade life cycle action, it must comply with the above validation
check.

9.5 Modifying a Currency
 Ⓘ [NOTE: If you modify a currency, it will impact the whole system]

Select the Currency Defaults panel to modify a currency.

» Select a currency from the Ccy list on the left to show its defaults.

Make changes as applicable.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

9.6 Delet ing a Currency
 Ⓘ [NOTE: If you delete a currency, it will impact the whole system]

Select the Currency Defaults panel to delete a currency.

» Select a currency from the Ccy list on the left, and click Delete.

You cannot delete a currency in use.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

9.7 Displaying Currency Pending Modif icat ions
Select the Currency Defaults panel.
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» Select a currency from the Ccy list on the left, and click Show Pending Modifications to display any currency
pending authorization. This only applies if the Authorization mode is enabled.

9.8 Creating a Currency Pair
Currency pairs are used for quoting FX rates and trading FX products. You can set quoting conventions for currency
pairs. If you enter a trade using a currency pair that does not have default values defined, then the system uses the
system default values.

However, you can define your own default values for the point factor and quote rounding. Set the environment
properties CCY_PR_DEFAULT_PT_FACTOR and CCY_PR_DEFAULT_QT_ROUNDING respectively.

To add a currency pair:

» Select a currency from the Ccy list on the left, and select the Currency Pairs panel.

» Then click Add Row. The selected currency will be considered as the secondary currency.

» Select a primary currency, then enter the fields described below.

» Click Save Currency Pairs to save the currency pairs currently displayed. Note that if you select another currency
from the Ccy list on the left, without saving, you will loose your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Details

Fields Description
Primary/ Secondary The secondary currency is the currency selected from the Ccy list on the left. Select the

primary currency.

For the EUR/USD currency pair, 1 EUR = x USD. Therefore in the quote set, you will enter a
quotation for the product FX [EUR/USD]. If you enter 2, it would mean: 1 EUR = 2 USD.

Pair Pos Ref You can define two currency pairs CCY1/CCY2 and CCY2/CCY1 but there is a single FX
Position, combining the trades in both currency pairs. Check Pair Pos Ref only for the
currency pair used to represent the FX Position.

 Ⓘ [NOTE: The FX Volatility Surface uses the pair position reference. For example, if
USD/JPY is the pair position reference, the surface is always saved as USD/JPY. It
saves a surface set up as JPY/USD as USD/JPY]

At the user level, you can set the opposite currency pair as the position reference currency
pair. Set the PosRefCurPairs user attribute in the User Defaults.

Example:
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Fields Description

The Pos Ccy Pair attribute can be added on a trade report style that displays the currency
pair as per the Pair Pos Ref attribute. This attribute is directly linked to the Currency Pair
trade attribute. The implementation is as follows: 

• If the existing Currency Pair attribute does not return a currency pair value, Pos Ccy Pair
does not return a currency pair value.

• If the existing Currency Pair attribute returns a Pair Pos Ref value (such as EUR/USD),
Pos Ccy Pair returns the same value (EUR/USD).

• If the existing Currency Pair attribute returns an inverse pair value (such as USD/EUR),
Pos Ccy Pair returns the Pair Pos Ref value (EUR/USD).

Display Factor This number allows you to specify how you would like the FX rate for the currency pair to be
displayed.

For example, for the currency pair JPYCHF the FX Rate in the Deal Station would be
displayed as 0.0110; if you set a Display Factor to 100, the FX rate would be displayed as 1.11,
which is 0.0110 * 100.

The Display Factor is used for the specified currency-pair when displaying the FX market
rate, trade/dealt rate and holding cost.

Point Factor Format of forward points (difference between Spot FX Rate and Forward FX Rate) displayed
in FX Forward and FX Swap trade windows.

If point factor = 10000, and you enter 25 forward points, then the actual difference between
Spot FX Rate and Forward FX Rate is 0.0025.

Point Rounding Round the forward points to this number of decimal places.

If you enter 10.12345 for the points, and the Point Rounding is 1, then the point value
displayed should be 10.1.

Quote Rounding Used for FX Rate Display purposes only. Mainly used to display Cross Rate calculated by
triangulate method.

See Setting Up Cross Currency Pairs for details.
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Fields Description
Big Fig Rounding You can set the big figure for each currency pair. Enter which figure after the decimal point is

the big figure. The next two figures display as the significant figures in the quotes window.
Following are examples.

• If you set the USD/JPY Big Fig Rounding to 0, then the first and second figures are the
significant figures.

• If you set the EUR/USD Big Fig Rounding to 2, then the third and fourth figures are the
significant figures.

Spot Days The Spot Days field applies spot days at the currency pair level. To apply the spot days at
currency level, set the currency pair Spot Days as “-1” and specify spot days at the currency
level.

When counting days for spot date calculation, the system uses both currencies holidays and
counts only days that are business days for both currencies. Intermediate non-weekend soft
holidays, if any specified in domain “FXCcyPairSoftHolidays”, are counted.

The log category “CcyPairDateCalcs” can be used to get information on spot date
calculations.

BBA Convention
The FX convention follows the BBA convention for the most part, except for the NYC
Memorial Day - See below.

Recommended Setup
• All holidays by default are considered "hard". The only exception is USD, thus we

recommend that NYC be added to the domain FXCcyPairSoftHolidays.

• Depending on the Bank, a certain desk will consider "cross pairs" as going through a
"cross currency". This "cross currency" will then cause the spot date calculation to
further consider another currency's holiday into account. A good example is EUR/JPY. If
a bank considers this a "cross via USD", you need to include NYC as a third calendar to
the EUR/JPY currency pair (the same applies to all currency pairs that you consider
crossing via USD).

However, if you have specified NYC as a soft holiday, then even in the third holiday
context, that holiday will be considered soft. This is OK for all NYC holidays, except for
Memorial Day which is treated by the markets as a hard holiday (due to the fact that it
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Fields Description
coincides with a London holiday and thus obeys the BBA convention). To handle this
case, you should create a NYC_MEMORIAL calendar that only contains Memorial Day.

You have two choices:

– Choice 1 – If you want NYC_MEMORIAL to be considered as a hard holiday in all
cases, then just add NYC_MEMORIAL to the holiday calendars of the USD
currency. Since it is not in domain FXCcyPairSoftHolidays, it will be considered as
a hard holiday.

– Choice 2 – If you want NYC_MEMORIAL to be considered as a hard holiday only in
the case of cross currency pairs, then add NYC_MEMORIAL as a third calendar to
all the currency pairs where you have added NYC as a third calendar.

• The Currency Pair attribute SpotDateCalcByCcySpotDays can be added to trigger a
currency pair value date calculation where Calypso will calculate the individual currency
spot days for the underlyings and use the higher date for the pair. This attribute is
recommended to only be set for currency pairs where the underlying currencies have
different spot days, such as EUR=2 and CAD=1.

• For the purpose of calculation of spot days, Sunday is considered a weekend day when
using a soft calendar only if it is the second business day.

Max Spot Days Maximum number of days allowed between the trade date and the settlement date of FX
trades to determine spot FX trades. The max spot date is calculated at currency pair level.

Example: If Max Spot Days = 5, the user can enter a spot FX trade for any trade with "settlement
date = trade date" up to "settlement date = trade date + 5 days".

 Ⓘ [NOTE: It is not currently possible to add forward points to product type FX]

3rd Holidays Check if you want to take into account holiday calendars in addition to the holiday calendars
of each currency, or clear otherwise.

3rd Calendar You can select holiday calendars in addition to the holiday calendars of each currency.

Active From Enter the date from which the secondary currency belongs to a Currency family. Applies to
the EURO zone.

Active to Enter the date from which the secondary currency will no longer belong to a Currency
Family.

Ccy Family You can select a currency family to which the secondary currency belongs to during the
"Active From" and "Active To" date range.

When a currency family is selected, if the settlement date of a trade falls between the
"Active From" and "Active To" date range, the trade cashflows are converted to the currency
family.

You can enter a fixed conversion rate using the fields Fixed and Fixed Rate. The market's
FX rate is used otherwise.
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Fields Description
Family Rounding Not used.

Fixed Only applies if a currency family is selected.

Check to define a fixed rate, or clear otherwise.

Fixed Rate Only applies if a currency family is selected.

Enter a fixed FX rate if Fixed is checked.

Risky Ccy Used in FX and FX Options.

Primary or Secondary. Default is Secondary.

Indicates which currency of the two should be considered as riskier by the system.

The Risky Ccy should be set based on the following order:

• If the pair contains the base currency, then the other currency should be the Risky Ccy.

• If the pair contains USD, then the other currency should be the Risky Ccy.

• If the pair contains exactly one non-deliverable currency, then the non-deliverable
currency should be the Risky Ccy.

• If Pair Pos Ref is true then the Risky Ccy should be the secondary currency; otherwise it
should be the primary currency.

Delta Display Ccy Set the default display currency for Delta and Gamma measures in the risk reports and
Pricing Sheet: primary or secondary currency. The default value is the secondary currency.

The Delta Display Ccy should be primary currency if Pair Pos Ref is true; otherwise it should
be secondary currency.

PL Display Ccy Set the default display currency for NPV and Vega measures in the risk reports and Pricing
Sheet: primary or secondary currency. The default value is the secondary currency.

The PL Display Ccy should generally be the secondary currency, unless the secondary
currency is non-deliverable, in which case it should be the primary currency. If both
currencies are non-deliverable, it should be the secondary currency.

9.9 Sett ing Up Cross Currency Pairs
The system uses a currency triangulation rule set for calculating cross currency trades. This rule set must be manually
set up in the Triangulation Currency Manager window, accessible via Configuration > Definitions > Triangulation Ccy
Rule. If this rule set is not set up, currency triangulation will not work.

See Triangulation Currency Rule Manager for details.

9.10 Defining Currency Pair Attr ibutes
Currency pair attributes can be used for selection and reporting purposes.

Nasdaq Calypso
Getting Started User Guide / Version 18

April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 100 / 253



April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 101 / 253

Select a currency pair, then click Attributes. The Attributes dialog will appear.

» Click ... to add attributes.

Then double-click the Value cell to set a value for the corresponding attribute.

» Click Apply.

» Then click Save Currency Pairs to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

9.11 Modifying a Currency Pair
 Ⓘ [NOTE: If you modify a currency pair, it will impact trades and pricing]

Select the Currency Pairs panel to modify a currency pair.

» Select a currency from the Ccy list on the left to show the currency pairs for which the selected currency is a
secondary currency. Then select a currency pair and changes as applicable.

» Click Save Currency Pairs to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

9.12 Delet ing a Currency Pair
 Ⓘ [NOTE: A currency pair in use cannot be deleted]

Select the Currency Pairs to delete a currency pair.

» Select a currency from the Ccy list on the left to show the currency pairs for which the selected currency is a
secondary currency.

Then select a currency pair and click Remove Currency Pairs.

You cannot delete a currency pair in use.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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9.13 Displaying Currency Pair Pending Modif icat ions
Select the Currency Pairs panel.

» Select a currency from the Ccy list on the left to show the currency pairs for which the selected currency is a
secondary currency.

Then select a currency pair and click Show Pending Modifications to display any currency pair pending
authorization. This only applies if the Authorization mode is enabled.

9.14 Note on Environment Propert ies
The following environment properties apply to currencies:

• CCY_PR_DEFAULT_PT_FACTOR

• CCY_PR_DEFAULT_QT_ROUNDING
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10. Triangulation Currency Rule Manager
Currency triangulation can be configured for any currency pair designated in the system. Multi-level triangulation is
also possible. For example, to get EUR/JPY via AUD, we can get EUR/AUD via USD and AUD/JPY via CAD. This type of
triangulation is transparent in the FX Deal Station trade window.

Also note that when a triangulation currency is set for a certain currency pair, the system will always triangulate, even
if a direct quote is available.

 Ⓘ [NOTE: A triangulation currency rule set must be established for any cross currency trades to save
properly]

10.1 Triangulat ion Currency Pair Set Up
From the Calypso Navigator, navigate to Configuration > Definitions > Triangulation Ccy Rule Set Manager to
display the Triangulation Currency Rule Set Manager window.

Nasdaq Calypso
Getting Started User Guide / Version 18



Triangulation Currency Rule Setup

Step 1 – Click to create a new triangulation currency rule set.

Step 2 – Enter a name for the rule set.

Step 3 – Click to add a new rule to the selected triangulation currency rule set.

Step 4 – Double-click in each cell to select a Primary Currency, Quoting Currency and a Split Currency for each rule in
the rule set.

Some examples are:

• All Currencies|All Currencies|EUR is a typical default setting. In this case, any currency pair not specified in the
rule set would use EUR.

• EUR|JPY|AUD, EUR and JPY will always split via AUD even if a EUR|JPY direct quote is available.

Step 5 – Click Save to save the Triangulation Currency Rule set and rules contained in the set.

10.2 Adding a Triangulat ion Rule to the Pricing Parameters
After you have created a new triangulation rule set, it needs to be added to the pricing parameters. To do this, go to
the Edit Pricing Parameter Set window (Market Data > Pricing Environment > Pricing Parameter Set).
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Pricing Parameters Window

Step 1 – Click Load to load the existing Pricing Parameter sets.

Step 2 – Select TRIANGULATION_CCY_RULESET_NAME from the Pricing Param Name drop-down box.
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Step 3 – Enter the name of the Triangulation Currency Rule Set that you would like to use.

Note that only one triangulation rule set can be used at any time. Therefore, even if you have created more than one
rule set, you may only designate the one you would like to use in this window.

Step 4 – Click Save to save the pricing parameter set.

 Ⓘ [NOTE: When first setting up the Triangulation Currency configuration, you also need to remove the old
pricing parameter for Triangulation Currency. Locate that parameter name, TRIANGULATION_CCY, and click
Remove]
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11. Defining Holiday Calendars
Holiday calendars are used throughout the system for determining business days. They can be attached to
currencies, legal entities, products, user defaults, etc.

From the Calypso Navigator, navigate to Configuration > Definitions > Holiday Calendars (menu action
refdata.HolidayFrame) for defining holiday calendars.

• A holiday calendar is identified by its code throughout the system.

11.1 Creating a Hol iday Calendar
Select the Codes label and click New.

» Enter the fields described below, and click Add.

» You can click Compare to Current to display any modification.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Details

Fields Description
Name The name identifies the calendar throughout the system.
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Fields Description
Non Business Days Check the boxes corresponding to the non-business days of the week. Sat and Sun are

checked by default.

Currency Select the default currency associated with the calendar.

Iso Code Select the ISO code as needed. Calendar ISO codes are stored in the domain
calendarIsoCodes.

The calendar ISO code will populate tag22B of the generated swift message based on the
holiday calendar set on the trade’s currency.

Description Enter a user-defined comment if desired.

Generic Dates Click Set to select rules that define recurring non-business days. Rules are defined in the
Rules panel.

See Defining Holiday Rules for details.

Once the rules are selected, you need to generate the actual non-business days that apply
to this calendar.

Click Generate to generate the non-business days corresponding to the selected rules.

» Select a rule, enter years in the fields From Year and To Year then click Generate.

» Click Add All to add all the generated dates to the non-business days, or select a few
dates and click Add Selected.

You can paste in specific dates defined in an Excel spreadsheet by right-clicking and
choosing “Paste from Clipboard”.

The dates are added to the specific dates.
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Fields Description
The generated holiday calendar can be viewed from Utilities > Calendar.

Specific Dates Adding Specific Dates as Holidays
Enter a date that is a non-business day. When you hit [Enter], the date is added to the
specific dates. You can specify a comment.

Adding Working Days
You can add working days that are exceptions to a rule.

For example, you have selected all Saturdays to be holidays but a specific Saturday is a
working day. You can add it here.

Enter a date that is a working day and check the "Working Day" checkbox. When you hit
[Enter], the date is added to the specific dates. You can specify a comment.

Sample Usage

Sample Legal Entity definition

11.2 Defining Hol iday Rules
Select the Rules label, and click New.
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» Enter a name and select a type, and enter the fields described below based on the selected type. Then click Add.

» You can click Compare to Current to display any modification.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

» You can enter years in the fields From Year and To Year fields and click Generate to test the dates generated by
the rule.

» The Usage area shows the holiday calendars that use the selected rule.

EASTER
The EASTER type allows determining Easter Sunday.

» Enter the offset that represents the number of days after Easter for the actual holiday (usually 1 day, as the
holiday is on Monday).
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FIXED
Select FIXED to setup a holiday that occurs on a fixed date.

» Enter the fields described below as applicable.

Fields Description
Month Month of holiday.

Day Day of holiday.

Saturday Roll Enter a positive or negative number of rolling days when the holiday falls on a Saturday.

For example, you can set it to -1 so that if the holiday falls on a Saturday, it will roll to Friday.

Sunday Roll Enter a positive or negative number of rolling days when the holiday falls on a Sunday.

For example, you can set it to 1 so that if the holiday falls on a Sunday, it will roll to Monday.

FLOAT
Select FLOAT to define a holiday that occurs on a floating date, such as the last Monday of August.

» Enter the fields described below as applicable.

Fields Descriptionn
Month Select the month of the holiday.

WeekDay Select the day of the holiday in the week.

Rank Select the rank of the day in the month (NONE, FIRST, SECOND, THIRD, FOURTH, LAST).
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AED-SATURDAY-NBD
The rule type “AED-SATURDAY-NBD” counts Saturdays as a holiday as of May 29, 2015. This type is used for AED
EIBOR fixings.

11.3 Modifying a Hol iday Calendar or a Hol iday Rule
 Ⓘ [NOTE: If you modify a holiday calendar, it will impact the whole system]

» Select a calendar under the Codes label, or a rule under the Rules and make changes as applicable. Then click
Update.

» You can click Compare to Current to display any modification.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

When a calendar is modified, the exception EX_HOLIDAYS_CHANGES is generated.

You can apply the action “ReProcess Transfers” to this exception – It brings up the Process Trades window with all the
trades impacted by this change. You can select the trades from there and have the Transfer engine reprocess the
corresponding transfers.

You can also use "Investigate > Show Trade Diary" to view the impacted trades before processing the exception.

 Ⓘ [IMPORTANT NOTE: The “ReProcess Transfers” action looks for impacted trades in the Trade Diary,
therefore this functionality only works if the Diary engine is running – Also, the “ReProcess Transfers” action
only modifies future transfers, with respect to Today - If you modify a calendar that impacts past transfers, they
will not be reprocessed]

11.4 Delet ing a Hol iday Calendar or a Hol iday Rule
 Ⓘ [NOTE: If you delete a holiday calendar, it will impact the whole system]

» Select a calendar under the Codes label, or a rule under the Rules and click Remove.

» You can click Compare to Current to display any modification.

» Click Save to save your changes.
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Note that if the Authorization mode is enabled, an authorized user must approve your entry.

11.5 Displaying Pending Modif icat ions
» Click Pending Modifs to display any pending modification.

This only applies if the Authorization mode is enabled.
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12. Defining Legal Entities
A legal entity represents an organization that plays a role in a trade.

Your organization is identified with the role ProcessingOrg, while the other side of a trade is identified with the role
CounterParty. Other roles are also available for legal entities related to a trade such as agents for payments, issuers,
market places, etc.

The roles of a legal entity control what type of activity the legal entity can carry out within the system.

Legal entities can be organized in a hierarchical manner to match actual business units within an organization.

From the Calypso Navigator, navigate to Configuration > Legal Data > Entities (menu action
refdata.BOLegalEntityWindow) for defining legal entities.

Legal Entity window

» Legal entities are identified by their short name throughout the system.

» You can specify user-defined attributes for selection and reporting purposes.

» You must define contacts for message generation and payment generation. Refer to the Calypso Messages User
Guide and to the Calypso Settlements User Guide for details.
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12.1 Creating a Legal Entity
» Click New to create a new legal entity, and enter information into the fields as applicable. The fields are described

below. A legal entity is identified throughout the system by its short name.

» Click Save to save your changes.

You can also click Save As to save the legal entity as a new legal entity. You will be prompted to enter a new short
name.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

See Sample Legal Entities for examples of legal entities usage.

You can use the Legal Entity Report to view existing Legal Entities.

See Legal Entity Report for details.

Fields Details

Fields Description
Short name Enter the short name that will identify the legal entity throughout the system.

Full Name Enter the full name of the Legal Entity.

Parent Click ... to select the parent of the Legal Entity if any. Used when the Legal Entity is the
subsidiary of another Legal Entity for example. This allows creating a hierarchy of legal
entities.

Note that the parent legal entity must have already been saved (any legal entity can be a
parent).

Legal entities in the hierarchy inherit configuration information from the parent organization
such as settlements instructions.

Country Select the country of the Legal Entity.

Inactive As From Enter the date from which the Legal Entity is disabled, i.e. you can no longer trade with it.

It can be used for example in case of a merger between two existing Legal Entities. You
create a third one (the new Legal Entity resulting from the merger) and deactivate the old
Legal Entities.

User Displays the name of the user who created the Legal Entity.

Entered date Displays the date and time when the Legal Entity was created.

External Ref Enter an external reference for the Legal Entity, optional.

It can be used for selection and reporting purposes.

Holidays Click ... to select the holiday calendar that applies to this Legal Entity.

Financial / Non
Financial

Click Financial or Non Financial.
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Fields Description
This is mostly for information purposes. However, for swift messages, if you have selected
the Payment template we generate MT202 messages for financial recipients, and MT103
messages for non financial recipients.

Status Select the status of the Legal Entity:

• Enabled – Available for trading.

• Disabled – Unavailable for trading, i.e. you cannot select it from the trade window.

• Pending – Available for trading but you will receive a warning when saving the trade.

Access permission functions can be used to allow the creation of legal entities with a
specific status.

Role(s) Click ... to select the roles of a Legal Entity. The roles control what type of activity the legal
entity can carry out within the system, and constitute therefore sensitive information.

You can click Add to add more roles to the list. Note that user-defined roles are used for
information purposes only, unless custom processes have been implemented.

Calypso-provided roles:

• Agent – A legal entity that receives or sends cash or securities: nostro, custodian,
clearing house, etc. Used in SDI specification.

• Broker – A legal entity that receives fees. Used in trade windows.

• BuySide – A legal entity that is NOT a calc agent. Used in CDS Trades.

• Calculation Agent – A calculation agent for a debt issue. Used in the Issuance Trade
window, in Bond Product (Domiciliation module), and can be used also as valuation
agent in Margin Call Contracts.

• CCP (Central Clearing Counterparty) – A legal entity that enables members to settle
cross-border trades.

• Clearer – A clearing house for futures and options.

• Counterparty – A participant in a trade: internal and external trading partners.

• Fund – A hedge fund.

• Guarantor – A referee in the event of a disagreement about a trade's rate reset or other
payment detail, for IRD trades. The calculation agent will be designated in a legal
agreement such as an ISDA agreement.

• IPA – An issue-paying agent for debt issuance. Used in the Issuance Trade window and
in the Bond Product window.

• Investor – Used for information purposes only.

• Issuer – The issuer of a debt issue. Used for bond products and CRD trades.

• Lead Manager – A legal entity that has primary responsibility for organizing a given bond
or credit issuance.
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Fields Description
• Market Place – A market place, either physical or electronic, that brings together buyers

and sellers of securities.

• Matching System – A legal entity that provides centralized real-time trade, settlement
and confirmation matching facilities.

• Processing Org – A legal entity that identifies your organization.

• Provider – A legal entity involved in a CFD contract.

• Reference Bank – A financial organization authorized to provide quotes. Used in cash
settlement definition.

• Sales Location – A legal entity that is used for location of sales margins.

• Subsidiary – A legal entity that is controlled or fully owned by another legal entity. Used
in trading windows.

• Syndicate Manager – A managing underwriter or lead manager of a syndicate created for
underwriting a new issue.

• Triparty Agent – An intermediary for sellers/lenders and buyers/borrowers of repos and
sec lending trades. Used in MT569 processing.

• Trustee – A trustee for a debt issue. Used in the Issuance Trade window and in Bond
Product (Domiciliation module).

Disabled Role(s) This area only appears if domain "LegalEntity.ShowDisabledRoles" contains Value = true.

Roles that have been disabled are shown here in red.

Roles can be disabled usingMain Entry > Configuration > Legal Data > Disabled Roles
(menu action refdata.RoleDisabledWindow).

» Select a legal entity, a role and a processing org, and click Save to disable the selected
role for the selected legal entity.
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Fields Description
Comment Enter a comment if desired.

LE Id Unique id number given by the system when the legal entity is saved.

Sample Legal Entities
• Processing Organization – A processing organization represents an entity within your organization. It must be

defined with the role ProcessingOrg.

A processing organization owns trading books that hold the activity of your organization.

Sample book definition

All the back office configuration is based on the processing organization.

• Counterparty – A counterparty represents the other side of a trade. It must be defined with the role CounterParty.

Sample trade

• Internal Counterparty – An internal counterparty represents an entity on the other side of a trade that is also part
of your organization. An internal counterparty must be defined with both roles ProcessingOrg and CounterParty.
Setting an internal counterparty on a trade allows capturing an internal trade.

• Agent – An agent is an entity that holds a settlement account. It is used to specify the settlement instructions of
your processing organizations, and the settlement instructions of your counterparties. It must be defined with the
role Agent.
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Sample settlement instruction definition

• Customer – A customer is an entity for which your organization is the custodian. Refer to the Calypso Client
Custody Management User Guide for complete details.

12.2 Modifying a Legal Entity
» Click Load to load an existing legal entity from the Legal Entity Chooser window. Type in the beginning of the

name and hit Enter. All the names that start with the fragment you typed will appear in the list at the right. The
search is case insensitive.

» You can click Update Short Name to modify the short name of the legal entity. You will be prompted to enter a new
short name.

Note that the new short name will be reflected everywhere the legal entity is used. You need to update
integration procedures however, if any.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

12.3 Delet ing a Legal Entity
» Click Delete to delete a legal entity. You can only delete a legal entity that is not in use.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

 Ⓘ [NOTE: A legal entity in use cannot be deleted, however it can be disabled - You can modify a legal entity
short name, it may impact integration procedures however if any - A role in use cannot be removed from a legal
entity - If you modify or delete a contact, it will impact SDIs and messages based on that contact, you will need
to reprocess the trades - If you modify or delete legal entity attributes, it will impact filters and reports based on
these attributes]

12.4 Specifying Legal Entity Attr ibutes
Legal entity attributes can be used for selection and reporting purposes. They are entirely user-defined.

» Load a legal entity then click Attributes to specify legal entity attributes as applicable.

You can also set legal entity attributes using Configuration > Legal Data > Attributes (menu action
refdata.BOLegalEntityAttributeWindow).
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Sample legal entity attributes

Select a role and a processing organization to which the attribute applies, then select an attribute type. You can
also search the attributes using the Search field.

You can click next to the Attribute Type field to create a new attribute.

Enter the attribute value in the Value field, and click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

 Ⓘ [NOTE: If you want to specify a list of possible values for a given attribute, create the domain
“leAttributeType.<attribute name>”, and add the values to that domain - The name is case sensitive]

» You can also select an attribute group to group the attributes for filtering purposes. Click next to the Attribute
Group field to add attribute groups.

» You can set constraints on legal entity attributes using Configuration > Legal Data > Attribute Code (menu action
refdata.LEAttributeCodeWindow).

Note however that these constraints are not enforced by Calypso. They can be enforced using custom validation
routines. Refer to the Calypso Developer’s Guide for information on implementing custom validation routines.
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Legal Entity Attribute Code window

Select an attribute and a type. You can click ... to create a new attribute.

– The Unique checkbox can be used to check that the attribute value is unique. The user would not be able to
enter the same value for two legal entities.

– The Searchable checkbox can be used to search legal entities.

– The Mandatory checkbox can be used to make the attribute mandatory. The user would be prompted to
enter a value upon saving a legal entity.

Then click Save.

Access Permissions
To set access permissions per legal entity attribute, set the comment of the attribute to "allowAccessPermission" in
domain "leAttributeType".

Example:

Sample access permission on legal entity attribute

It creates the access functions AddModifyLEAttribute#ACCOUNTING and RemoveLEAttribute#ACCOUNTING. You
can then grant read/write access or read-only access to these functions in Access Permissions.

It also creates the access function AuthorizeLEAttribute#ACCOUNTING.
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12.5 Specifying Contact Information
Contacts represent departments or individuals within an organization. Contact information such as addresses,
member ids, etc. is used for back office operations (generation of messages and payments).

» Load a legal entity then click Contact to associate contact personnel with the legal entity. At least one contact
must be defined for message and payment generation.

You can also choose Configuration > Legal Data > Contact Personnel (menu action
refdata.BOLEContactWindow). Help is available from that window.

12.6 Specifying Legal Agreements
Legal agreements provide default values for various types of trades.

» Load a legal entity then click Legal Agreement to specify legal agreements as applicable.

You can also set legal agreements using Configuration > Legal Data > Agreements (menu action
refdata.BOLegalAgreementWindow). Help is available from that window.

12.7 Specifying Rating Information
Rating information is used for evaluating credit risk, and for reporting purposes.

» Load a legal entity then click Rating to set the legal entity rating.

You can also set rating information usingMarket Data > Credit Curves > Credit Ratings (menu action
refdata.CreditRatingWindow).

Refer to the Calypso Credit Derivatives User Guide for details.

12.8 Specifying SDIs
SDIs (settlement and delivery instructions) are used for payment generation.

» Load a legal entity then click SDI’s to specify the SDIs associated with the legal entity.

You can also set SDIs using Configuration > Settlements > Settlement Instructions (menu action
refdata.BOSettlDeliveryWindow). Help is available from that window.

12.9 Specifying Nett ing Methods
Netting methods allow associating a netting type with a counterparty / processing organization pair in order to
perform automatic netting.

» Load a legal entity then click Netting Methods to specify the netting methods associated with the legal entity.
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You can also set netting methods using Configuration > Settlements > Netting Method (menu action
refdata.NettingMethodWindow).

Refer to the Calypso Settlements User Guide for details.

12.10 Specifying Custom Data
» Load a legal entity then click Custom to open a custom legal entity window for entering custom data.

Refer to the Calypso Developer’s Guide for information on implementing a custom legal entity window.

12.11 Specifying Registrat ion Information
Registration information allows specifying registration details with a given settlement place or other external entities.
It can be used for selection and reporting purposes.

» Load a legal entity then click Registration to specify registration information for the legal entity.

You can also specify registration details using Configuration > Legal Data > Registration Details (menu action
refdata.BOLERegistrationWindow).

» Enter registration information as applicable and click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

12.12 Specifying Legal Entity Relat ions
You can specify relations to restrict the interaction between processing organizations and other legal entities for a
given role. When you enter a trade, if no relation is defined between the processing org and the counterparty, you will
not be able to save the trade.

You can also specify relations between two legal entities in the context of customer transfers, for a given PO or for all
POs.

» Load a legal entity then click Relation to specify legal entity relations.

You can also specify relations using Configuration > Legal Data > Relation (menu action
refdata.LERelationWindow).
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Default legal entity relations

By default, all processing organizations can interact will all legal entities at the trade level.

» To restrict relations between POs and legal entities, select the default entry (ALL, ALL, ALL, NONE, ALL), and click
Delete to delete it. Then set restrictions as applicable.

Select a processing org or ALL, click ... to select a legal entity, and select a role.

Then click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

» To restrict relations between legal entities, select the default entry (ALL, ALL, ALL, ALL, ALL), and click Delete to
delete it. Then set restrictions as applicable.

Select a processing org or ALL, and check "Multi Legal Entity".

Sample relation restriction

Click ... to select a legal entity, and select a role.

Then click ... to select another legal entity, and select a role.

Then click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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 Ⓘ [NOTE: You can disable the check for legal entity relations in the Legal Entity Selector by setting the
access permission function DisableCheckLERelation]

Segregation of Legal Entity Roles by Processing Organization
Using legal entity relationships, you can segregate legal entity roles across the system by processing org.

This only applies if the environment property LEGAL_ENTITY_SEGREGATION = True.

In this case, roles are classified between “common” roles and “dedicated” roles. A “common” role can be viewed
across all POs (like Issuer and MarketPlace), whereas a “dedicated” role can only be viewed for certain POs.

“Common” roles are defined in the domain “CommonLERole”. All other roles are considered “dedicated”.

• When a user creates a legal entity of “common” role, the system will create a legal entity relationship with
specified role, and PO=ALL.

This requires the access permissions AddModifyLECommonRole and RemoveLECommonRole.

All users will be able to see this role for this legal entity.

• When a user creates a legal entity of “dedicated” role, the system will create a legal entity relationship with
specified role for the POs to which the user is restricted.

This requires the access permissions AddModifyLEDedicatedRole and RemoveLEDedicatedRole.

Only users associated with this PO will be able to see this role for this legal entity.

In addition, when LEGAL_ENTITY_SEGREGATION = True, audit and authorization are segregated by processing
organization.

For the objects not associated with a processing organization, you can add them to the domains "storePOForAudit"
and "storePOForAuth".

For objects added to the domain "storePOForAudit", the processing organization is saved on the audit records.

For objects added to the domain "storePOForAuth", the processing organization is saved on the authorization
records.

The processing organization saved on the records is the PO associated with the user if any. If the user is associated
with multiple POs, then the parent PO is saved on the records if any.

12.13 Specifying Sett lement Tolerance
Settlement tolerance is used when matching incoming payment messages with Calypso transfers. Additional setup is
required in order to import incoming payment messages. Refer to the Calypso Cash Management User Guide for
complete details.
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12.14 Specifying Sett lement Accounts
» Load a legal entity then click Account to define settlement accounts associated with the legal entity.

For example, you can specify settlement accounts associated with the processing organization.

You can also specify accounts using Configuration > Accounting > Accounts (menu action
refdata.AccountFrame). Help is available from that window.

12.15 Specifying Reference Obl igat ions
If a legal entity has the role Issuer, you can define the reference obligations to be used in Credit Derivatives trading.

» Load a legal entity then click Ref Obl to define the reference obligations associated with the legal entity.

Refer to the Calypso Credit Derivatives User Guide for details.

12.16 Displaying Pending Authorizat ions
» Click Show Auth to display any legal entity pending authorization. This only applies if the Authorization mode is

enabled.

12.17 Uti l i t ies Menu
The menu items of the Utilities menu are described below.

Menu Items Description
Search by Method Allows you to search for a Legal Entity by an address method and its address code. For

example, to find a legal entity by its SWIFT code, choose SWIFT and enter the code.

Search by Selector Allows you to find a legal entity using various criteria, including legal entity attributes. The
Legal Entity ID is then displayed on the Legal Entity Window.

Message Configuration Opens the Message Rule window to display any message rule defined for this legal entity.

Update Market Data Allows updating the market data associated with a legal entity in the case where you have
changed the short name.

Update Static Data Allows updating the various static data associated with a legal entity in the case where you
have changed the short name.

CLS Setup Check Checks if a legal entity is associated with a CLS agreement and if the corresponding SDIs
are valid.

Close Closes the window.
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12.18 Sett ing EOD Dates and Times
You can set EOD dates and times per processing organization using Configuration > Legal Data > EOD (menu action
refdata.LegalEntityEODTimeWindow).

Legal Entity EOD Time window

» Click ... to select a processing organization. Enter a date and enter an EOD time in hours and minutes.

» Then click Save.

When the system needs the EOD time, it uses the EOD time in the following order:

• The specific EOD time defined by book and date, if any.

• The specific EOD time defined by processing organization and date, if any.

• The default EOD time defined by book.

The Start of Day Time is set by the scheduled task ROLL_ACCENGINEDAY for processing organizations that have the
legal entity attribute ACC_USE_BUSINESS set to Yes.

You can view start of day times using the CloseBusinessDay report (menu action
reporting.ReportWindow$CloseBusinessDay).
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Close Business Day report
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13. Defining Legal Entity Contacts
Contacts represent departments or individuals within an organization. Contact information such as addresses,
member ids, etc. is used for back office operations (generation of messages and payments).

You need to specify contacts on sender legal entities, and on receiver legal entities.

From the Calypso Navigator, navigate to Configuration > Legal Data > Contact Personnel to define contacts.

13.1 Creating a Contact
» Click New to create a contact, and enter the fields described below.

The contact is identified by the contact type throughout the system. If the same physical person has multiple
roles in an organization, you can create multiple contact entries for the same person by changing the contact
type.

Note that you can create only one contact for a given combination of Legal Entity, Role, Product, Contact Type,
and Processing Org.

» Then click Save to save your changes.

You can also click Save As New to save the legal entity as a new legal entity. You will be prompted to enter a new
short name.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Details

Fields Description
Legal Entity Click ... to select the legal entity to which the contact belongs.

Role Select a legal entity role, or ALL.

Product Click ... to select a product type, or ALL.

The product type can be a group of products. See Configuration > Product > Group (menu
action refdata.ProductGroupWindow) for information on creating groups of products.
Note that the environment property USE_PRODUCT_GROUP should be set to true in order to
allow specifying contacts by product group.

Contact Type Select a contact type or ALL.

You can click ... to add contact types.

Processing Org Select the processing organization or ALL.

You can double-click the Processing Org label to set it to ALL.

Effective From

Effective To

Enter the validity period of the contact (optional).

NOTE: When using the Effective From and Effective To dates for "expiring" old contacts and
using the new one, please make sure that the contact type is the same as the contact type in
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Fields Description
the Message Set-up window, otherwise INVALID messages will be created.

Static Data Filter Click ... to select a static data filter to restrict the usage of the contact (optional).

The static data filter is used for contact selection during the generation of messages but
does not apply to contact selection when processing incoming messages.

Contact Id Unique id number given by the system when the contact is saved.

Trade Keyword You can enter a trade keyword value for the trade keyword defined in the domain
“leContactTradeKeyword”. This allows an additional criteria to determine the LE Contact.
This is optional.

Last Name

First Name

Enter the last name and first of a physical person if applicable.

Title Enter the title of a person / department if applicable.

Address

City

State

Zip Code

Enter the mailing address of the contact. It can be used when generating messages and
payments.

The Address field may contain multiple lines.

Address Type Select the type of address (like Home, Office, etc.). Address types are defined in the domain
"AddressType".

Country Select the contact’s country.

Phone

Telex

Fax

E-Mail

Enter the information that you will need for message and payment generation. This
information can also be specified by clicking ... next to the Codes field.

You can also specify additional information there.

These codes are defined in the domain "addressMethod". You can select the code that
appears by default be setting Comment = default in the "addressMethod" field for the code
of your choice.
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Fields Description
» Double-click a cell to enter the corresponding value. Then click Apply.

» You can click ... to create new codes.

 Ⓘ [NOTE: If you want to specify a list of possible values for a given code, create the
domain “addressMethod.<code>”, and add the values to that domain - The name is
case sensitive]

Non Connected BIC
If you set the code NON_CONNECTED_BIC = true, the BIC code specified in the Swift field
corresponds to a non connected BIC code (passive participant), and follows specific
constraints in Swift messages.

Swift You can enter the SWIFT BIC code manually, or click ... to select a SWIFT BIC code from the
BIC directory. It can be imported using the scheduled task SWIFT_BIC_IMPORT.

If you enter the SWIFT BIC code manually, and the environment property CHECK_BIC_DATA
is set to true, the system will check that the code is valid.

External Ref Enter an external reference as needed.

Comment Enter a comment if desired.

Access Permissions
To set access permissions per contact, set the comment of the attribute to "allowAccessPermission" in domain
"contactType".

Example:

Sample access permission on contact type

It creates the access functions CreateLEContact#Confirmation and RemoveLEContact#Confirmation. You can then
grant read/write access or read-only access to these functions in Access Permissions.

It also creates the access function AuthorizeLegalContact#Confirmation.

13.2 Modifying a Contact
» Click Load to load the contacts for a given legal entity. You will be prompted to select a legal entity.

You can modify the fields as applicable.

» Then click Save to save your changes.
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Note that if the Authorization mode is enabled, an authorized user must approve your entry.

13.3 Loading Val id Contacts
You can set the "Valid On" date at the bottom of the screen to only load contacts valid on or after that date - Based on
the Effective From and Effective To dates.

13.4 Val idat ing a Contact
When you modify a contact, you can check if the contact is used and needs to be modified in existing messages.

» Click Load to load the contacts for a given legal entity. You will be prompted to select a legal entity.

» Then click Validate Contact to check if the contact needs to be updated in existing messages. You will be
prompted to select a message status to be checked.

A message report will display messages for which the contact needs to be modified.

You can choose Process > Update Messages to apply the action UPDATE on the selected messages.

If the contact was modified, the action UPDATE will set the status of the message to INVALID. You will have to
create new valid contacts and apply action FIX to verify the messages manually.

If the modification on the contact was minor, the action UPDATE will set the current address code and contact
type on the message. The message will remain in its original status with the necessary updates.

The following workflow transitions need to be added in the message workflow:

– <STATUS> - UPDATE - <STATUS> (workflow rule ApplyDefaultContact)

– <STATUS> - UPDATE - INVALID (workflow rule CheckCorrectContact)

13.5 Delet ing a Contact
» Click Load to load the contacts for a given legal entity. You will be prompted to select a legal entity.

» Then select a contact and click Delete. If the contact is used in configuration data, you will not be able to delete it.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

13.6 Displaying Pending Authorizat ions
» Click Show Auth to display any contact pending authorization. This only applies if the Authorization mode is

enabled.

13.7 Uti l i t ies Menu
The menu items of the Utilities menu are described below.
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Menu Items Description
Search Allows you to find a contact using various criteria, including codes.

Search by Method Allows you to search for a contact by code. For example, to find a contact by its SWIFT code,
choose SWIFT and enter the code value.

Exit Closes the window.
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1. Legal Entity Report
This document describes how to use the Legal Entity report.

The Legal Entity report allows displaying legal entities created in the system.

Enter the menu item reporting.ReportWindow$LegalEntity to create the report.

» Select the Criteria Type (including legal entity attributes) and Criteria Operator, then click Add Criteria to add it to
the criteria list below.

» Click to load the corresponding legal entities.

» Choose Report > Save As Template to save the search criteria as a template. You will be prompted to enter a
template name and specify whether the template is public or private.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» You can click to print the report results.
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2. Legal Entities Anonymization
This topic shows how to anonymize legal entities for the General Data Protection Regulation (GDPR).

The anonymization function allows meeting GDPR’s “right to erasure” obligations by providing the following features:

• Anonymizing personal data

The anonymization function allows deactivating legal entities, contact information and legal entity attributes.
When personal data is anonymized, users can no longer apply actions to related trades, transfers or messages.
The messages related to an anonymized contacts cannot be accessed.

• Cleaning up database tables containing personal data

Audit information related to personal data is anonymized in the database tables.

• Providing audit for anonymized data

Log entries are kept for anonymized data. These entries provide the ENTITY_ID, CLASS_NAME, ANONYMIZING_
DATE, ANONYMIZING_USER_NAME, and APPROVER_USER_NAME.

• 4-eye principle/authorization of personal data anonymization

Once data is anonymized, it cannot be reversed. It is recommended to use authorization for additional control.

Recommendations
Before the anonymization process, it is important to determine data that needs to be archived (moved to the HIST
tables) and those requiring deletion. Personal data should only be anonymized if the data is no longer essential for
performing daily activities. To easily identify legal entities in the system, it is recommended to set the legal entity
status to deactivated and/or set an inactive date. Deactivation and inactivity information should come from the
compliance department.

Archiving and purging is a requirement for anonymizing legal entities with the role counterparty. To maintain database
integrity, existing trades related to a legal entity will be blocked during anonymization. Legal entity contacts and
attributes can however be anonymized without archiving/purging related trades.

The recommended archival/purging process is to first move trades into an expired or matured status, and archive the
trades based on the bank’s criteria. Archiving data is beneficial for reducing database size and improving
performance.

A condition for archiving trades, via the scheduled task ARCHIVE_TRADE, is that there is no related entry in the liq_
position or trade_open_qty table. These tables, liq_position or trade_open_qty, are archived using the ARCHIVE_
POSITION scheduled task.

For more information related to the archiving/purging process visit the Calypso Archiving documentation.

Nasdaq Calypso
Getting Started User Guide / Version 18



Nasdaq Calypso
Getting Started User Guide / Version 18

April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 136 / 253



April 2025
Revision 5.0 / Approved

Proprietary and Confidential
Page 137 / 253

2.1 Setup Requirements

2.1 .1 Report Types
After installation, the following values should be available in the "REPORT.Types" domain:

• LEAttributesAnonymizing

• LEContactAnonymizing

• LegalEntityAnonymizing

2.1 .2 Anonymized Fie lds Conf igurat ion
The fields to be anonymized in a legal entity or LE contact need to be defined in the domains
"leContactAnonymizedFields" and "legalEntityAnonymizedFields" as needed.

Examples for domain "leContactAnonymizedFields":

• firstName

• lastName

• email or addressMethod.EMAIL

• comment

• fax or addressMethod.FAX

• telex or addressMethod.TELEX

• phone

• zipCode

• state

• city

• address or addressMethod.MAIL

• addressMethod.SWIFT

• addressMethod.XXX for any address method defined in the addressMethod domain values

• externalRef

Examples for domain "legalEntityAnonymizedFields":

• shortName

• fullName

• parent
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• comment

• externalRef

No configuration is required for LE attributes - You can select the attributes to be anonymized in the tool - See below
for details.

2.1 .3 Access Permiss ions
You need the following access permissions:

• ModifyLegalEntity - Permission to modify legal entities of any status, or ModifyLegalEntityDisabled,
ModifyLegalEntityEnabled, ModifyLegalEntityPending if you are using those instead.

• ModifyLEContact - Permission to modify LE contacts

• AddModifyLEAttribute - Permission to create and modify LE attributes

• AuthorizeLegalEntityAnonymity - For accepting legal entity anonymizations

• AuthorizeLEContactAnonymity - For accepting LE contact anonymizations

• AuthorizeLEAttributeAnonymity - For accepting LE attribute anonymizations

To create an authorization task for anonymizing, you need to add the following domain values and run the system in
Authorization mode (highly recommended for this tool):

Domain exceptionType, Value = ANONYMIZING_AUTH

Domain eventType, Value = EX_ANONYMIZING_AUTH

2.2 Legal Entity Anonymization
Bring up the report for menu action reporting.ReportWindow$LegalEntityAnonymizing.
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» Enter at least one search criteria and click . The search criteria are defined below.

» To anonymize the legal entities, check the Select checkbox and click Anomymize Selection.

The legal entities become deactivated and you can no longer apply actions to related trades, transfers or
messages.

Audit information related to personal data is anonymized in the database tables.

 Ⓘ [NOTE: To prevent loss of essential information legal entities can only be anonymized if the related
positions are closed and trades are no longer available in the system, that is, trades have been archived and
purged]

In Authorization mode, an authorization task EX_ANONYMIZING_AUTH is published to the Task Station and it must be
approved for the anonymization to take effect.

 Ⓘ [NOTE: The anonymization cannot be undone]

Fields Description

Legal Entity Select one or multiple legal entities to be anonymized.

Status Select the status of the legal entities.

Inactive As Enter the number of days that the legal entities have been inactive (based on legal entity Inactive As
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Fields Description

From From field).

Country Select the country of the legal entities.

Anonymized
Data

Clear to load legal entities that are not yet anonymized, or check to view legal entities that have
been anonymized.

After legal entity anonymization, the legal entity name is replaced by a code.

Example of legal entity in a legal agreement before and after anonymization:

Associated SDIs are anonymized if the legal entity is a Beneficiary, Agent, Intermediary or Intermediary 2.

The SDI attributes are anonymized as well if the legal entity is a Beneficiary.
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The Effective To date is set to the anonymization date.

Associated accounts are anonymized with their account attributes.

The Active To date is set to the anonymization date.

2.3 LE Contact Anonymization
Bring up the report for menu action reporting.ReportWindow$LEContactAnonymizing.
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» Enter at least one search criteria and click . The search criteria are defined below.

» To anonymize the LE contacts, check the Select checkbox and click Anomymize Selection.

You can no longer view messages associated with these LE contacts.

Audit information related to personal data is anonymized in the database tables.

In Authorization mode, an authorization task EX_ANONYMIZING_AUTH is published to the Task Station and it must be
approved for the anonymization to take effect.

 Ⓘ [NOTE: The anonymization cannot be undone]

Fields Description

Legal Entity Select one or multiple legal entities, which LE contacts should be anonymized.

Status Select the status of the legal entities.

Inactive As
From

Enter the number of days that the legal entities have been inactive (based on legal entity Inactive As
From field).

Country Select the country of the legal entities.

Contact Type Select the contact type.

Effective Date Enter the contact effective date.
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Fields Description

Anonymized
Data

Clear to load LE contacts that are not yet anonymized, or check to view LE contacts that have been
anonymized.

After LE contact anonymization, the contact information is replaced with a code and the effective date is set to the
anonymization date.

For new trades, only SDIs with effective LE contacts are used.

For existing trades, users cannot view messages related to anonymized LE contacts.
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2.4 LE Attr ibute Anonymization
Bring up the report for menu action reporting.ReportWindow$LEAttributesAnonymizing.

» Enter at least one search criteria and click . The search criteria are defined below.

» To anonymize the LE attributes, check the Select checkbox and click Anomymize Selection.

Audit information related to personal data is anonymized in the database tables.

 Ⓘ [NOTE: LE attributes are expected to be anonymized along with the relevant LE contact, as such, LE
contact anonymization impacts also influence LE attributes]

In Authorization mode, an authorization task EX_ANONYMIZING_AUTH is published to the Task Station and it must be
approved for the anonymization to take effect.

 Ⓘ [NOTE: The anonymization cannot be undone]

Fields Description

Legal Entity Select one or multiple legal entities, which LE attributes should be anonymized.

Status Select the status of the legal entities.
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Fields Description

Inactive As
From

Enter the number of days that the legal entities have been inactive (based on legal entity Inactive As
From field).

Country Select the country of the legal entities.

Attribute Type Select the attribute type.

Anonymized
Data

Clear to load LE attributes that are not yet anonymized, or check to view LE attributes that have
been anonymized.

After LE attribute anonymization, the attributes value is replaced with a code.

2.5 Anonymization Audit
Bring up the report for menu action reporting.ReportWindow$AnonymizingAudit to view audit information
related to anonymization.
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» Enter search criteria and click . The search criteria are defined below.

Fields Description

Requester Select a user who anonymized the data.

Approver Select a user who approved the anonymization (only applies in Authorization mode).

Entity Type Select the type of data.

From / To Select the anonymization date range as needed.
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14. Defining Legal Agreements
You can define legal agreements between two parties for OTC derivatives. Legal agreements can be referred to in the
messages generated by the system.

Legal agreements can also be associated with break clauses in trades (Cash Settlement Info).

From the Calypso Navigator, navigate to Configuration > Legal Data > Agreements to define legal agreements.

You can browse legal agreements using Reports > Cross-Asset Reports > Legal Agreement Report.

14.1 Defining a Legal Agreement
The Global panel is selected by default.

» Click New and enter the Global panel fields described below as needed.

» Select the Legal Agreement panel and enter the fields described below as needed.

» Then click Save to save your changes.
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You can also click Save As New to save the legal agreement as a new legal agreement provided you change some
criteria as follows: for a given combination of processing org and counterparty, you can setup multiple non-
master agreements per product type, and ONE master agreement per product type.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Global Panel Fields Details

Fields Description
Processing Org Select a processing organization.

Legal Entity Click ... to select the counterparty of the agreement.

Product Family Select a product family, or ALL.

Product Type Select product type(s), or product subtype(s) defined as "<product type>.<product
subtype>", or ALL.

Example: Selection by product type would be "SecLending", and selection by product subtype
would be "SecLending.Sec Vs Cash".

For a given combination of processing org and counterparty, you can setup multiple non-
master agreements per product type, and ONE master agreement per product type.

The product type can also be a group of products. See Configuration > Product > Group
(menu action refdata.ProductGroupWindow) for information on creating groups of
products. Note that the environment property USE_PRODUCT_GROUP should be set to true
in order to allow specifying legal agreements by product group. Product groups can also be
created by product subtype.

Currency Click ... to select the currencies for which the agreement applies, or ANY.

When you select the agreement type CLS, the currencies default to the CLS currencies
(currencies that belong to the CLS group in the Currency definition).

You can use the static data filter element "Legal Agreement#<LE agreement type>#Check
Currency" to check the currency of the legal agreement.

Date Enter the effective date of the agreement.

PO Children

ALL

Click ... next to the PO Children field to select the children of the processing org for which
the agreement applies.

You can also check the ALL checkbox next to the PO Children field to apply the agreement
to all the children of the processing org.

LE Children

ALL

Click ... next to the LE Children field to select the children of the counterparty for which the
agreement applies.
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Fields Description

You can also check the ALL checkbox next to the LE Children field to apply the agreement to
all the children of the counterparty.

Legal Agreement Panel Fields Details

Fields Description
Agreement Select the type of agreement. It can be used in messages, and as search and selection

criteria.

Click ... to add new types of agreement as applicable.

The TripartyRepo agreement type is specific to triparty repos. Such an agreement type must
be specified between the processing org, counterparty and agent.

Refer to the Calypso Triparty Services Guide for complete details.

Is Master Check the “Is Master” checkbox for the master agreement between two parties. This applies
when multiple agreements are specified between two parties.

 Ⓘ [NOTE: When using the static data filter element "Legal Agreement Type", only
master agreements are taken into account - To create a static data filter that takes into
account non-master agreements, you can use the static data filter element "Legal
Agreement#<type>#Type"]

Id Number Id number automatically given by the system when the agreement is saved.

Documents Allows attaching documents.

 See Attaching Documents for details.

Is Trilateral Check the “Is Trilateral” checkbox to define a Triparty agreement, and select the type
TripartyRepo. The third-party is specified in the Guarantor field - See below.

Ref Number Enter a reference number as applicable.
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Fields Description
Is Triparty Substitution Used in the triparty repo allocation process.

If checked, and depending on the repo trade maturity type:

• OPEN and callable – The pledge trades will be OPEN with Notice Days = Notice Days of
parent triparty repo.

• TERM and callable – The pledge trades will be OPEN with Notice Days = Notice Days of
parent triparty repo.

• TERM and not callable – The pledge trades will be OPEN with Notice Days = 0.

• INTRADAY – The pledge trades will be TERM with 1D duration.

If not checked, and depending on the repo trade maturity type:

• OPEN and callable – The pledge trades will be OPEN with Notice Days = Notice Days of
parent triparty repo.

• TERM and callable – The pledge trades will be TERM with End Date = End Date of parent
triparty repo, and with Notice Days = Notice Days of parent triparty repo.

• TERM and not callable – The pledge trades will be TERM with End Date = End Date of
parent triparty repo, and with Notice Days = 0.

• INTRADAY – The pledge trades will be TERM with 1D duration.

Status Select the status of the agreement. It can be used in messages, and as search and selection
criteria.

In the out-of-the-box confirmations, a reference to the legal agreement will be mentioned
for SIGNED legal agreements.

You can click ... to add new status codes as applicable. They are defined in the domain
"legalAgreementStatus".

Guarantor Click ... to select a legal entity of role Guarantor.

You can double-click the Guarantor label as applicable to change the role. In that case, you
will be able to select a legal entity of the selected role.

For TripartyRepo agreements, change the role to Agent and select the agent.

Special Clause Enter a free form special clause as applicable.

Additional Info Click the second ... button to set values for the additional information.

The Additional Info section allows specifying custom attributes for a legal agreement. You
can select an attribute, and its value will be displayed in the adjacent field.

You can click ... next to the Additional Info field to add attributes.

If you want to specify a list of possible values for a given attribute, create the domain
“laAdditionalField.<attribute name>”, and add the values to that domain - The name is case
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Fields Description
sensitive.

The attribute CrystalizationDays can be used to define the number of crystallization days for
the EONIA rate index on security finance trades paying interest at maturity.

The attribute TERMINATION_APPENDIX_MID can be used to drive default values on break
clauses (cash settlement info):

• Quotation Rate

– If TERMINATION_APPENDIX_MID = Yes, it is set to MID.

– If TERMINATION_APPENDIX_MID = No, it is set to BID / ASK.

– Otherwise, it is not set.

• Exercise Party Pays

– If TERMINATION_APPENDIX_MID = Yes or not set, it is set to false (unchecked).

– If TERMINATION_APPENDIX_MID = No, it is set to true (checked).

14.2 Attaching Documents
From the Legal Agreement panel, you can attach actual documents to the legal agreement for information purposes.

Select the Legal Agreement panel, load a legal agreement and click Documents to attach documents.

» Enter a description for the document and click Add. You will be prompted to select a document. Select a
document as needed.

Once a document is added, you can double-click the document to display it.

» Then click Close.

Then click Save in the Legal Agreement window to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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14.3 Adding El igibi l i ty Rules
The Eligibility Rule panel only applies to legal agreements for repo trades. It allows adding eligibility rules to a legal
agreement and specifying whether they are blocking or not on each direction independently. Eligibility rules allow
specifying which securities are acceptable as collateral. Security eligibility checking will take place when the legal
agreement is selected on a repo trade, even if this occurs after having booked the security.

Before adding an eligibility rule to a legal agreement, you need to define eligibility rules. From the Calypso Navigator,
navigate to Configuration > Legal Data > Eligibility Rules (menu action refdata.EligibilityRuleWindow).

In order to specify eligible securities, you must have set up static data filters / static data filter trees which cover all
the eligible securities you would like to use.

» Click New to create a new eligibility rule, and enter a name in the Name field.
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» In the Collateral Giver area, click to select a static data filter to be used as an eligibility filter for collaterals in
the give direction.

Add additional eligibility filters as necessary. You can delete a filter by selecting it and clicking .

To be eligible, a security must belong to at least one of these filters.

» Repeat as needed in the Collateral Taker area to specify eligibility filters for collaterals in the receive direction.

You can click Copy to duplicate the list from the Collateral Giver area.

» Click Savewhen you are done.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Now you can add eligibility rules to a legal agreement in the Legal Agreement window.

» Select the Eligibility Rule panel.

» Select an eligibility rule from the Name drop-down. The eligibility filters that are defined on the rule are populated
in the Collateral Giver and Collateral Taker areas. Note that they are only displayed here for information purposes
and are not editable from this window. To edit the eligibility filters you must do so from the Eligibility Rule window.

» Check the Blocking checkbox if desired in the Collateral Giver and / or Collateral Taker areas.

If checked, repo trades with ineligible securities will not be able to be saved.

If not checked, repo trades with ineligible securities will alert the user upon saving, but can be saved.

» Then click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Viewing Security Eligibility in Trade Windows
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When a legal agreement is selected on a repo trade, the "Sec. Eligibility" field is displayed in the Collateral details area.
It will appear as checked if the selected security is eligible to the selected legal agreement.

When more than one security has been added to a repo trade, a list of securities is displayed. You can add a column
which will display whether or not the securities are eligible to the selected legal agreement.

» Right-click in the column headings and select Configure > Configure Columns.

» Add the "Sec. Eligibility" column. It will appear as checked for those securities which are eligible.

14.4 Adding Haircut Rules
The Haircut Rule panel allows entering haircut details which will be used as default values when the legal agreement is
selected on repo trades.
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» Select the Haircut Rule panel.

» In the Collateral Giver area, enter the haircut details to be used as default values for collaterals in the give
direction.

– Select the base amount to compute the haircut: DirtyPrice or CleanPrice. The haircut amount will be added /
subtracted to / from the collateral value.

– Select Regular or Inverse to indicate the type of haircut computation: Regular [amount * (1+haircut)], or
inverse [amount / (1-haircut)]. The haircut value is not an absolute value. The sign of value is important.
Enter a negative value for a discount and a positive value for a premium.

– Select Give or Receive to indicate the direction of the haircut from the processing organization’s
perspective.

– Enter the number of decimals permitted for haircuts entered for this counterparty.

– Enter the haircut percentage, expressed in basis points (enter 0 for no haircut), or select a haircut rule.

Haircut rules are defined in Calypso Navigator > Configuration > Fees, Haircuts, & Margin Calls > Haircut
Rule.

» Repeat as needed in the Collateral Taker area to enter haircut default values for collaterals in the receive
direction.

» Then click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

14.5 Adding Pricing Parameters
From the Pricing panel, you can specify pricing parameters to be used when this legal agreement is selected on a repo
or security lending trade. These parameters are used for calculating the MARGIN_CALL pricer measure. By setting
them at the legal agreement level, it allows margin call exposures to be calculated differently from one counterparty to
another.
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» Select the Pricing panel and enter values for the pricing parameters described below as needed. Those that are
not needed can be left blank.

» Then click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Some of these pricing parameters are also able to be set on margin call contracts, as indicated in the table below. For
a trade using both a legal agreement and a margin call contract, the pricing parameters that are actively defined (not
left blank) on the legal agreement will take priority. For parameters left blank on the legal agreement, the values
defined in the margin call contract, if any, will be used. For parameters undefined in both the legal agreement and
margin call contract, the values from the pricing environment, if any, will be used.

Pricing Parameters Description

MC_INCLUDES_END_DATE_
EXPOSURE

True or false. If set to true, MARGIN_CALL is calculated at trade end date, but
disregarded (returns 0 value) if set to false.

Margin call contract corresponding field: "Include End Date Exposure" on the Details
panel

MC_EXCLUDE_TRADE_
HAIRCUT

True or false. If set to false, MARGIN_CALL calculation includes the trade haircut to
price the collateral value.

Margin call contract corresponding field: "Exclude Trade Haircut" on the Parties
panel

MC_EXCLUDE_INTEREST True or false. If set to false, MARGIN_CALL calculation includes accrued interest to
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Pricing Parameters Description

trade liability.

Margin call contract corresponding field: "EXCLUDE_REPO_INTEREST" and
"EXCLUDE_SECLENDING_INTEREST" on the Additional Info panel

MC_SEC_QUOTE_OFFSET 0 or 1. Determines which day’s quote to use in the collateral value calculation.

When set to 0, uses the val date quote.

When set to 1, uses the (val date - 1) quote.

Margin call contract corresponding field: "Quote Offset Days" in the Dates & Times
panel

MC_INCLUDE_EXDIV_
COUPON

If set to true, the MARGIN_CALL pricer measure includes any pending coupon due
amount from the earlier record date to the payment date.

Margin call contract corresponding field: "INCLUDE_EXDIV_COUPON" on the
Additional Info panel

14.6 Viewing Exist ing Legal Agreements
You can browse legal agreements using Reports > Cross-Asset Reports > Legal Agreement Report.

Security finance trade defaulting definitions are also displayed in this report. Either the 'Trade Defaulting' column or
the 'Legal Agreement' column will be checked to indicate which it is.

 Refer to Calypso Security Lending Trading and Calypso Repo Trading documentation for details on security finance
trade defaulting.

» You can double-click a legal agreement to load its configuration window.
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14.7 Modifying a Legal Agreement
The left-hand side of the window allows searching and browsing existing legal agreements.

» In the Search panel, you can enter search criteria and click to load the corresponding legal agreements. You
can also navigate the existing legal agreements in the Navigate panel.

They will appear at the bottom of the window - Double-click a legal agreement to show its details. Then modify
the fields as needed.

It is possible to set the maximum number of agreements to be displayed in the User attribute
“Max.LegalAgreement”.

» Then click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

14.8 Associat ing a Legal Agreement with a Margin Cal l Con-
f igurat ion
» Load a legal agreement and click Margin Call Agreement to create a margin call configuration. A margin call

configuration is used to calculate margin calls between two parties.

 Refer to Calypso Collateral Management documentation for details.

14.9 Displaying Pending Authorizat ions
» Click Show Pending Authorizations to see any legal agreements pending authorization. This only applies if the

Authorization mode is enabled.
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14.10 Delet ing a Legal Agreement
» Load a legal agreement and click Delete to delete it.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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15. Defining Trading Books
A trading book is a collection of trades that represent a business activity within your organization.

A trading book may be associated with an accounting book that holds the postings for the trades in the book. You may
create accounting books using Configuration > Accounting > Accounting Books (menu action
refdata.AccountingBookFrame).

It is also possible to define dynamic collections of trades for reporting purposes, using different types of filters.

From the Calypso Navigator, navigate to Configuration > Books & Bundles > Trading Book (menu action
refdata.BookWindow) to define trading books.

Book window

» A book is identified by its name throughout the system, and belongs to a processing organization. A processing
organization may own multiple books.

» You can specify user-defined attributes for selection and reporting purposes.
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15.1 Creating a Book
» Click New to create a new book, and enter information into the fields as applicable. The fields are described

below.

» Click Save to save your changes.

You can also click SaveAsNew to save the book as a new book provided you enter a new book name in the Name
field.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Note that if the Access Permissions mode is enabled, you need to define book access permissions.

Fields Details

Fields Description
Book Id Id number automatically given by the system when the book is saved.

Name Enter the name that will identify the book throughout the system.

Activity Free field that can be used for creating book hierarchies.

Accounting Link Select an accounting book. It has to be previously defined using Configuration >
Accounting > Accounting Books (menu action refdata.AccountingBookFrame). The
accounting book defines the accounting scheme of the book, and holds the postings.
Multiple books can feed the same accounting book.

You can select NONE if you do not have an accounting book at this point.

You can associate additional accounting books with the book using the book attribute
"Additional Accounting Links". See below for details.

Legal Entity Click ... to select the owner of the book. The owner is a legal entity of role ProcessingOrg.

Location Select a timezone that represents the geographical location of the book.

You can double-click the Location label to retrieve your default timezone.

End of Day Enter the end of day time of the selected timezone.

 Ⓘ [NOTE: Trade Valuation uses the Location and End of Day settings to determine
when a trade actually belongs to the book]

You can click ... to define specific EOD times for specific days.
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Fields Description

» Enter a date and a time. Then click the right arrow and click Apply.

You can also define specific EOD times for specific processing organizations and specific
dates using Configuration > Legal Data > Legal Entity EOD (menu action
refdata.LegalEntityEODTimeWindow).

When the system needs the EOD time, it uses the EOD time in the following order:

• The specific EOD time defined by book and date, if any.

• The specific EOD time defined by processing organization and date, if any.

• The default EOD time defined by book.

When a user books a trade after the EOD time of the book, the effective date of the posting
is adjusted based on the calendar date instead of the business date. To adjust the posting
based on the business date, set the legal entity attribute ACC_TD_CHECK_HOLIDAY= true
on the processing org. The system uses the book holiday calendar by default, or the
processing org holiday calendar if not set.

Base Currency Select a base currency. This currency can be used to convert all amounts of a book into a
single currency.

 Ⓘ [NOTE: Accounting valuation may value trades in trade currency, base currency, or
a user-defined currency - See "Specifying Book Valuation Currencies" for details]

Holidays Click ... to select holiday calendars.

Comment You can enter a user-defined comment for information purposes.

Attributes Book attributes can be used for selection and reporting purposes.

Double-click a value cell to specify the value of the corresponding attribute then hit enter.

To create new attributes, click ... next to the Attributes label.
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Fields Description

» Enter an attribute name in the Book Attribute field, then click the right arrow.

You can select the attribute and specify its value in the adjacent field. Then click Add.

The checkbox "Selected attribute is the P&L Methodology Driver" applies to P&L
methodologies. Only one attribute can have this checkbox checked. It is the Desk
attribute by default. Once chosen, it cannot be modified.

Refer to Calypso Official P&L documentation for details on P&L methodologies.

» Finally, click Apply to save your changes.

 Ⓘ [NOTE: If you want to specify a list of possible values for a given attribute, create a
domain named “bookAttribute.<attribute name>”, and add the values to that domain,
for example "bookAttribute.Domiciliation" - The name is case sensitive]

Out-of-the-box Attributes
• AccAdjustmentDays, AccDateRule, and AccReversalRule – If these attributes are set on

the book, they override the settings defined at the Accounting Rule level.

 Refer to the Calypso Accounting User Guide for details.

• Additional Accounting Links - Comma-separated list of additional accounting books.

• BookBundle – A group of books. All books that have the same BookBundle value belong
to the same group. The accounting books cannot have the same GAAP accounting
standard.

If you associate additional accounting books with the book, you need to specify the
default GAAP in the domain "GAAP.default" for pricing purposes.

• CollateralHolding – Set to true to make the book available for selection in margin call
contracts and margin call collaterals.

• CTC Compounding, CTC Consolidator, CTC Offset, and CTC Role – Attributes for cost to
carry computations.

 Refer to the Calypso Position Management User Guide for details.
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Fields Description
• DayChangeRule – Set to FX to use the 5pm New York rule to determine the close of

business to compute the trade date and time and spot date and time, otherwise the
book's timezone is used.

When set to FX, if a trade is entered today after 5pm (New York time), the trade date is
rolled 1 day forward, and the spot date is computed from the new trade date using NYC
holidays.

• Desk, and ProfitCenter – For information and reporting purposes.

• Domiciliation – Select "Offshore" or "Onshore" to determine if the currency used is non-
deliverable and must be paired with another currency for discounting. You can select a
discounting currency in the Pricer Configuration.

• Drawn MM Book – Select the book where the corporate actions on drawn bonds are
generated. Applies to Danish Mortgage Bonds.

 Refer to Calypso Fixed Income documentation for details.

• EODWeek – Set to true to compute pricer measures over the weekend taking the
holidays into account. Note that at the end of the month, the system only accrues to the
last day of the month (whether this is a business day or not).

You can use the scheduled task PROP_RATE_1BUSDAY to propagate the latest available
quotes to the quotes missing over the weekend.

• FloatingBondAccretion – Used to specify the yield behavior of BondAssetBacked
products.

 Refer to Calypso Fixed Income documentation for details.

• DisableEOM – This is false by default (behavior described in EODWeek). You can set to
true to disable the EOM boundary, and compute pricer measure over the weekend even
if EOM occurs over the weekend.

• LiquidationTime – You can set a liquidation time to override the EOD time in the form
HHMM.

• Market Index – Set to true to allow associating the book with a market index.

 Refer to the Calypso Asset Management User Guide for details.

• VALUATION_TIMES, and VALUATION_TIMEZONES – Times and timezones for the
position snapshots.

 Refer to the Calypso Position Management Documentation for details.

Book Usage
A book is typically used in a trade to identify the business activity to which the trade belongs.
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Sample trade

Favorite Books
The books available for selection throughout the system are set in Configuration > Favorites > Books.

Favorite books can be further refined within each trade window.

» Click ... next to the Book field.

» Select favorite books for a given product and click OK. These books will be available for selection in the Book
field.

15.2 Modifying a Book
 Ⓘ [NOTES: You can modify a book name, it may impact integration procedures however if any - If you modify
the EOD date and time, it will impact trade liquidation - If you modify the accounting book, it will impact
postings, you will need to reprocess the trades - If you modify or delete book attributes, it will impact filters,
book hierarchies, and reports based on these attributes - The Legal Entity can only be modified if the book is
not associated with any trade or any live Call Account]

» Click Load to load all existing books, and select the book you want to modify.

» Click Save to save your changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

15.3 Delet ing a Book
 Ⓘ [NOTE: A book in use cannot be deleted]

» Load a book then click Delete. You can only delete a book that is not in use.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

15.4 Displaying Pending Authorizat ions
» Load a book then click Show Pending Authorizations to display any book pending authorization. This only applies if

the Authorization mode is enabled.
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15.5 View Menu
The menu items of the View menu are described below.

Menu Items Description
Configure
Columns

Use this menu item to configure the list of books. In particular, you can add book attributes to the
display, they are identified by “BOOK_ATTR.<attribute_name”.

15.6 Specifying Book Valuation Currencies
By default, the valuation currency is the base currency of the book, and the reference pricer measure for calculating
the NPV is the NPV pricing measure. However, using Configuration > Books & Bundles > Book Valuation Currency
(menu action refdata.BookValCcyWindow), you can specify a valuation currency and a reference pricing measure
per book and per product type.

This is used for accounting valuation by the Portfolio Manager and the following scheduled tasks: EOD_POSITION_
VALUATION, EOD_TRADE_FUNDING, EOD_TRADE_VALUATION, and EOD_TRADE_VAL_DB.

You can specify the valuation currency as non-deliverable by setting the domiciliation attribute. See above.

Authorizing Book Valuation Currencies
In order for the Authorization mode to apply to book valuation currencies, you need to add “BookValCcy” to the
domain “classAuthMode”.
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16. Defining Book Hierarchies
Books can be organized in book hierarchies for reporting purposes. Book hierarchies allow defining aggregation levels
of books, based on book criteria.

From the Calypso Navigator, navigate to Configuration > Books & Bundles > Book Hierarchy (menu action
refdata.BookHierarchyWindow) for defining book hierarchies.

Book Hierarchy window

» Book hierarchies are identified by a name throughout the system.

» Book hierarchies do not constitute a parent / child relationship between books. They represent levels of
aggregation. A book can belong to multiple book hierarchies.

» You can view existing book hierarchies when you click Load.

Contents

- Creating a Book Hierarchy

- Modifying a Book Hierarchy
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- Deleting a Book Hierarchy

- Using Book Hierarchies

16.1 Creating a Book Hierarchy
You build a book hierarchy from top to bottom by adding layers of nodes made up of book criteria. For example, you
can have a book hierarchy that collects books by owner, base currency, and profit center attribute.

» Click New to create a new book hierarchy, and select the root node.

You can change the name of the root node in the Node field, and click Update for the change to take effect.

» Select a book criterion from the Criterion field. Then you can click Add All to add all the possible values of the
selected criterion to the book hierarchy, or select individual values and click Add to add them to the book
hierarchy.

Repeat for subsequent nodes in the hierarchy as applicable.

When you select a node, you can change the name of the node in the Node field, and click Update for the change
to take effect.

Sample book hierarchy

» Click Save to save your changes. You will be prompted to enter a book hierarchy name. A book hierarchy will be
identified by its name throughout the system.

You can also click Save As to save the book hierarchy as a new book hierarchy. You will be prompted to enter a
new book hierarchy name.

16.2 Modifying a Book Hierarchy
 Ⓘ [NOTE: If you modify book hierarchies, it will impact reports]

» Click Load to load an existing book hierarchy.

Modify as applicable.

» Click Save to save your changes.

16.3 Delet ing a Book Hierarchy
» Click Delete. You will be prompted to select a book hierarchy.
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16.4 Using Book Hierarchies
In most reports, you can add the Book Hierarchy panel by choosing View> Show Frame > Book Hierarchy. It allows
selecting a book hierarchy, and grouping the report results based on the criteria of the book hierarchy upon loading.

 Ⓘ [NOTE: The Book Hierarchy panel only appears if book hierarchies are defined]

Sample report with Book Hierarchy panel

The book hierarchy appears as a tree on the left-hand side of the report.

You can then drill-down the book hierarchy to view the report results based on the criteria of the book hierarchy.
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17. Defining Rate Indices
The Rate Index window allows defining rate indices. This is a two step process:

• You first define the characteristics of the rate index in the Rate Definition panel, and save the rate index.

• Then you define tenors for the rate index in the Tenors panel.

You can only use a rate index throughout the system once both steps have been completed. It will be identified by its
currency, index name, tenor, and source.

The actual rate values are set using Trade Lifecycle > Reset > Rate Reset, or using the RATE_RESET scheduled task.

17.1 Defining a Rate Index
From the Calypso Navigator, navigate to Configuration > Interest Rates > Rate Index Definitions.

The Rate Definition panel is selected by default. It is used to define rate indices and set default market conventions.

» Click New to create a new rate index, and enter the fields described below as applicable.

» You can click Average to specify averaging details if applicable.

See Specifying Average Rate Details for details.

» You can click Attributes to specify rate index attributes if applicable.

See Specifying Rate Index Attributes for details.

» Then click Save to save your changes.

You can also click Save As New to save the rate index as a new rate index, provided you select a new index name
or currency.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

» Once the rate index is saved, click Load to make it available for selection. Then select the Tenors panel to specify
tenors for the rate index.

See Specifying Tenors for details.

» To load an existing rate index definition, click Load and select the rate index from the list of rate indices.
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Rate Index window – Rate Definition

The characteristics of the rate index will appear in the upper area of the table. You can modify the fields as
needed, then click Save to save the changes.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Details

Fields Description
Index Select an index name.

If the desired index name does not appear, click Add to add it to the "rate_index" domain.

 Ⓘ [NOTE: The index name cannot contain spaces]

Currency Select the currency of the index.

Day Count Select the default daycount convention to determine the number of days in an interest
period.

Daycount conventions are described under Help > Day-Count Conventions.

Sources Click ... to select quoting sources for the index as applicable.

If the desired quote source name does not appear, click Add to add it to the "rate_index_
source" domain.

Nasdaq Calypso
Getting Started User Guide / Version 18



Fields Description
Date Roll Select the default date roll convention to roll non-business days.

Date roll conventions are described under Help > Date Roll Conventions.

Time Zone Select the time zone in which the rate is published.

Hour Enter the time at which the rate is published in the selected time zone.

Period Rule Select the default interest period generation rule.

• ADJUSTED – You pay the exact day of the interest period.

• UNADJUSTED – You do not pay the exact day if the end of period is not a business day.

• MAT_UNADJUSTED – Same as ADJUSTED except for the maturity flow which is
unadjusted (for derivatives).

• FRN – Enforce start and end date at the end of the month even if the roll date is the 15
(for derivatives).

Publish Freq Select the frequency at which the rate is published.

For the weekly frequency, you can select the day of the week the rate is published from the
Day field.

When Inflation is selected for Index Type, the quarterly frequency also allows you to select
the month of the year.

For Interest indices, you can select NON and select a publication date rule instead for
complex frequencies. See Publish Date Rule below.

For Inflation indices, select a publication frequency and then enter a reference day and a
publication lag.

The reference day is the day of the month when the inflation is effective, and the publication
lag is the time lag between the effective date of an inflation level and its actual publication.

 Ⓘ [NOTE: Publication Freq and Reference Day settings also have an impact on dates
for interpolated points in the Inflation Curve window. See "Inflation Curve" in the
Analytics and Pricing Environment documentation for details]

You can click Publications and generate the dates to make any modification if needed.
Otherwise the reference day and publication lag are used to determine the publication
dates, and the reference day and publishing frequency are used to determine the reference
dates.
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Fields Description

» Enter a "From" and "To" date, and click Generate. You can modify the reference dates or
publication dates as needed.

» Click Savewhen you are done.

 Ⓘ [NOTE: The system does not support end-of-month reference days 29, 30, and 31.
This restriction also pertains to the Publications Dates window described above when
modifying the Reference Date fields]

Default Source Select the default quoting source from the list of sources defined for that index.

Publish Date Rule Only applies to Interest indices.

Instead of selecting a publication frequency, you can click ... to select a date rule to generate
the publication dates based on complex frequencies. Date rules are created using
Configuration > Definitions > Date Schedule Definitions > Date Rule.

Pay Hol Click ... to select default payment holiday calendars.

Used to set the default payment dates for interest rate trades.

Reset Hol Only applies to Interest indices.

Click ... to select default reset holiday calendars.

Used to set the default reset dates for interest rate trades.

Publication Hol Only applies to Inflation indices.

Click ... to select default publication holiday calendars.

Pay Days Enter the number of days between the period end date, and the actual payment date, if paid
in arrears. Entering 2 indicates that the payment date occurs 2 days after the period end
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Fields Description
date.

Or enter the number of days between the period start date, and the actual payment date, if
NOT paid in arrears.

Reset Days Only applies to Interest indices.

Enter the number of days between the actual reset date and the payment period end date, if
reset is in arrears. Entering 2 indicates that the reset occurs 2 days before the payment
period end date.

Or enter the number of days between the actual reset date and the payment period start
date, if reset is NOT in arrears.

Index Lag Only applies to Inflation indices.

Enter the number of days (D), weeks (W), months (M), or years (Y), between the actual
publication date and the period end date, if paid in arrears. Entering 3M indicates that the
publication occurs 3 months before the period end date.

Or enter the number of days (D), weeks (W), months (M), or years (Y), between the actual
publication date and the period start date, if NOT paid in arrears.

Pay Bus Lag Check to indicate that the Pay Days lag is measured in business days, or uncheck for
calendar days.

Pay in Arrears Check to indicate that the interest is paid at the end of each coupon period, or uncheck if the
interest is paid at the beginning of the period.

Reset Bus Lag Check to indicate that the Reset Days lag / Index Lag is measured in business days, or
uncheck for calendar days.

Reset in Arrears Check to indicate that the index resets / is published at the end of each coupon period, or
uncheck if the index resets /is published at the beginning of the period.

Compound Freq Only applies to Interest indices.

Select a compounding frequency if applicable, or NON.

Calc Mtd Only applies to Inflation indices.

Select the calculation method:

• IndexLevel – Index levels are not interpolated between publication dates. The same
index level is used throughout the period.

• Interpolated – Index levels are interpolated between publication dates. Select the
interpolation method from the Interp Mtd field.

 Ⓘ [NOTE: The "Calc Mtd" setting also has an impact on dates for interpolated points
in the Inflation Curve window. See "Inflation Curve" in the Analytics and Pricing
Environment documentation for details]
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Fields Description
Interp Mtd Only applies to Interpolated Inflation indices.

The only option is "Weighted". Index levels are interpolated using the following formula.

For example, to calculate an interpolated May 12thCPI index level, which has a 3 month lag:

 Ⓘ [NOTE: The Daycount set on the Rate Index Definition is used by the interpolation
formula when calculating dd and DiM. For example, if 30/360 is set as the Daycount,
DiM will always use 30]

Index Type Select Bond, Interest, Inflation, Notional Factor, or Swap.

Bond Index Type
The Bond type should be used for CMS/CMT bond indices.

Set the bond default in the rate index attribute CMT_BOND_NAME.

Inflation Index Type
For inflation-based rate indices. A full setup example of the inflation index is described in the
Inflation Swap documentation.

Interest Index Type
Standard rate index.

Notional Factor Index Type
The Notional Factor type should be used for SELIC bond indices.

In the rate index attribute UNDERLYING_RATE_INDEX, specify the index to be used in case
the notional factor quote is unavailable and one needs to be projected.
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Fields Description

Swap Index Type
The Swap type should be used for CMS swap indices. When you select Swap, click Swap to
specify the most liquid swap.

» Enter the various fields to define the swap, and click Apply. The coupon frequency, rate
index name, and rate index tenor are retrieved from the swap.

Rate Rounding Select the rounding method for the rates.

Rounding methods are described under Help > Rate Rounding.

 Ⓘ [NOTE: When you select NONE,  there is no rounding of the rate – All decimals are
retained]

No Automatic
Interpolation

This checkbox is not related to the interpolation method of Inflation indices.

When checked, there is no automatic interpolation applied to stub periods, otherwise stub
periods are automatically interpolated.

Quote Type Select the quote type for the rate.

Comment Enter a free form comment.

Formula Click ... to open the Formula Helper window that allows defining a rate index using a formula
combining other indices.

You can also enter the formula directly in the Formula field, and click Parse to check the
syntax. The parser recognizes any “common-formatted” algebraic expression. It also has
some predefined useful functions, like Gaussian curves, min, max, etc. For more information,
refer to the Javadoc for the com/calypso/tk/util/parser/ExprFunction class.

Sample Usage
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A rate index is typically selected by currency, index name, tenor and source.

Sample swap trade

17.2 Specifying Rate Index Attr ibutes
You can set user-defined attributes, or out-of-the-box attributes.

Rate Index attributes

» Double-click a Value cell to enter a value for the corresponding attribute. Out-of-the-box attributes are described
below.

Note that the attribute names and their values are case sensitive.

If you want to create a list of available values for a given attribute, you need to create a domain named
“RateIndex.<attribute name>”, and add the available values to that domain.

» You can click ... to add attributes if they are not available.

» Click Applywhen you are done to return to the Rate Index window.

» Then click Save to save the changes to the rate index.

Attributes Details
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Attributes Description
Advance Used for overnight rate indices in Advance trades.

It should be set to VRC to identify such rate indices, so that the trades can be
identified as VRC.

BRL_CONVENTION

BRL_SUBTYPE

Not used.

CheckBusDayOnResetLag Enter the name of the holiday calendar that was set up for AED EIBOR rate
resets. This holiday calendar uses the rule type AED-SATURDAY-NBD.

See "Defining Holiday Calendars" on page 107 for details.

CMT_BOND_COUPON Not used.

CMT_BOND_NAME Bond default name for CMS/CMT bonds.

Coupn_Frq Not used.

CTCHolidayReset Holiday calendars for Cost To Carry computation of Cash Positions.

DailyIndexCalculator Set to DailyCompound to allow daily compounding (recommended setting).

See Note on Daily Compounding for details.

Note that you should set DailyIndexCalculator OR IndexCalculator, not both.
IndexCalculator takes precedence over DailyIndexCalculator.

Other calculators are available out-of-the-box:

• TBillDailyCompound

• LiborDailyDecompound

Discontinued_Tenors Allows users to hide selected tenors for newly created Swaps, Swaptions, and
Structured Products. You can enter a comma-separated list of tenors. No
spaces are needed.

 Ⓘ [NOTE: Previously saved trades using discontinued tenors will still
have the tenors available and selected]

Excl_intrp_tnr_list A list of comma-separated tenors to be excluded from being used within stub
interpolation (on the Stub Periods tab of the Product Details window). You can
use the scheduled task ADJUST_STUB_TENORS to recalculate stub periods on
existing trades.

FallbackCalculatorAsOfDate For use in conjunction with the Index Calculator: FallbackISDA for LIBOR trades.
This is the date on which the new Index Calculator is set on the LIBOR Rate
Index. When Val Date is before the FallBackCalculatorAsOfDate, the
Fallback ISDA Index Calculator logic is not applied.

FixedTenorRFRRollMethod For use with the ESTRAVG rate index. Set to MOD_PRECED to make use of the
FixedTenorCompoundedRFR Index Calculator.

FWD_CRYS Set to true to crystallize the last known rate for averaging rates, MRO rate for
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Attributes Description
example.

Default is false.

FWD_DAILY Used for EONIA index calculator only.

Set to true to compute the final interest using estimated future daily resets, or
false to compute the final interest using the final estimated reset only.

IA_CMP_INT_RATES_ADJ Set to true to force each compound index to be adjusted via an "InArrears"
adjustment, the total compounded interest amount just paid at the payment
date.

Default is false.

Index Convention Used for Colombian indices.

Please refer to Calypso Fixed Income documentation for details.

Index Type Used for Colombian indices.

Please refer to Calypso Fixed Income documentation for details.

IndexCalculator Used for specific rate indices:

• For a bond, swap, cap / floor inflation index, set to InflationIndexKerkhof -
Sample setup in Inflation Swaps documentation.

• For an Australian bond CPI inflation index, set to AUDCPI (it calculates the
historical “p” and “k” factors and payment amounts).

You can also set to PayOffBasedInflation. For AUD CPI bonds, it uses the
AUDCPI calculator and for the other AUD CPI products, it uses the
InflationIndexKerkhof calculator. This way, you only need to define one rate
index for all AUD CPI products.

• For a South African bond CPI inflation index, set to ZARCPI (it uses -3 and -
4 months for interpolation while the regular CPI calculator uses -3 and -2
months for interpolation).

• For IGPM Pro Rata BRL swaps, set to InflationIndexBRL - Sample setup in
Brazilian Swaps documentation.

• For a Brazilian NTN-B or NTN-C bond, set to BrazilInflationIndex.

• For a bond TEC10, set to TEC10.

• For a CMS swap index, set to SwapRate - Sample setup in CMS Swaps
documentation.

• For a CMT swap index, set to CMT.

• For an overnight index, set to OISNew - Sample setup in OIS Swaps
documentation.

See Note on Daily Compounding for details of overnight indices.
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Attributes Description
• For a French compounded index, set to T4M, TAG, TAM, TEC10, TME, THE,

TMO, THO as applicable.

• For a Japanese STPR index, set to STPR.

• For an LTPR index, set to LongTermPrime.

• For a crystallized EONIA, set to EONIA.

• For an ECB repo, set to MROIndex - The MRO index is averaging weekly,
see below for averaging details.

• For a Peruvian overnight index in Peruvian sol (PEN), set to TNA.

• For the ICP rate index in Chilean Peso (CLP currency), set to TNA - Sample
setup in Chilean Swaps documentation.

• For the ICP rate index in Chilean UF (CLF currency), set to TRA - Sample
setup in Chilean Swaps documentation.

• For a SOFRAVG index, set to FixedTenorCompoundingRFR. For a
SOFRINDEX index, set to CompoundingRFR.

See Recommended SOFRAVG Setup, and Recommended
SOFRINDEX Setup for details.

• For swaps using the ISDA Fallback Protocol for the transition from LIBOR to
a risk free rate such as SOFR, set to FallbackISDA.

See Specifying Libor Fallback for complete details.

• For the reference rate of columbian repos, set to DailyBanrep.

 Ⓘ [NOTE: DailyBanrep can only be used to repos]

IsPrime Set to true to identify a prime rate so that the COF-PRIME spread is displayed
for Advances.

NO_AVG_FORECAST Set to true to take the reset from the forecast curve only on reset date since the
forecast curve is supposed to have already averaged rates.

Default is false.

Nominal Index The underlying overnight rate index that the compounded rate index is
referencing.

E.g. For a SOFRAVG rate index that references an already-established
SOFR rate index defined with the Index Name SOFR, set to SOFR.

In the case of LIBOR fallback trades, this is the name of the RFR rate index that
is replacing libor.

OISMethod Default is empty.

It can be set to OIS for the OISNew calculator to use the compounding
calculation of the OIS calculator.
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Attributes Description
See Note on Daily Compounding for details.

OPTIMIZE_AVG_RESET Set to true to optimize average deals when performing MTM and revaluation.

Default is false.

RESET_TIMING Only applies to Repo and SecLending trades.

Allows specifying the default reset timing on a given index. The only possible
values are END_PER or BEG_PER.

RATE_INDEX_CODE.<source> ISDA code.

The attribute is in the form “RATE_INDEX_CODE.<source>”, for example “RATE_
INDEX_CODE.T350” = EUR-EURIBOR-TELERATE.

If the attribute is specified, its value will be used in messages, otherwise the
index will be identified as “<currency>-<index name>-<index source>”, for
example EUR-EURIBOR-T350.
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Attributes Description
ROUND_FINAL_DAILY_RATE_DEC

ORIGINAL_RATE_DEC

ORIGINAL_RATE_ROUNDING_
METHOD

DAILY_RATE_DEC

DAILY_RATE_ROUNDING_
METHOD

FINAL_RATE_DEC

FINAL_RATE_ROUNDING_
METHOD

OIS swaps
When DailyCompound calculator is used, you can specify how to round the rate.

ROUND_FINAL_DAILY_RATE_DEC – Rounds the accumulated rate for the trade.
Only applies to multiplicative spreads.

Rate = Round(Daily Rate * Accumulated Rate)

– Specify the number of decimals in ROUND_FINAL_DAILY_RATE_DEC.

ORIGINAL_RATE_DEC – Rounding applied to the saved rate in the quote set.

– Specify the number of decimals in ORIGINAL_RATE_DEC.

– Specify the rounding method in ORIGINAL_RATE_ROUNDING_
METHOD: UP, DOWN, or NEAREST.

DAILY_RATE_DEC – Rounds the daily published rate after applying the period.

Rate = Round(Rate)

– Specify the number of decimals in DAILY_RATE_ROUNDING_
METHOD.

– Specify the rounding method in DAILY_RATE_ROUNDING_METHOD:
UP, DOWN, or NEAREST.

FINAL_RATE_DEC – Rounds the product of the accumulated rate and
accumulated spread.

Rate = Round(Accumulated Rate * Accumulated Spread)

– Specify the number of decimals in FINAL_RATE_DEC.

– Specify the rounding method in FINAL_RATE_ROUNDING_METHOD:
UP, DOWN, or NEAREST.

Inflation products
When InflationIndex calculator is used, and when Calc Mtd = Interpolated, you
can specify how to round the interpolated CPI value.

– Specify the number of decimals in FINAL_RATE_DEC.

– Specify the rounding method in FINAL_RATE_ROUNDING_METHOD:
UP, DOWN, or NEAREST.
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Attributes Description
ROUND_FINAL_RATE

ROUND_FINAL_RATE_ISDA

Applies to rounding of rate indices with index factor and spread.

Here is the list of possibilities using both attributes.

ROUND_FINAL_RATE = True, ROUND_FINAL_RATE_ISDA = True

Rate = No rounding

Final Rate = Round(Rate * Index Factor) + Spread

ROUND_FINAL_RATE = False, ROUND_FINAL_RATE_ISDA = True/False

Rate = Round(Rate)

Final Rate = Round(Rate) * Index Factor + Spread

ROUND_FINAL_RATE = True, ROUND_FINAL_RATE_ISDA = False

Rate = No rounding

Final Rate = Round(Rate * Index Factor + Spread)

RateLookback True or false. Default is false.

Set to true to allow rate lookback. You can set the number of days in
RateLookbackDays.

RateLookbackDays Number of days to look back for missing quotes if today’s quote is not available.

ResetsPerTenor True or false. Default is false.

To be used when the rate index tenor is greater than 1 year, and the payment
frequency is less than the rate index tenor. When it is set to true, the cashflow
generator uses the rate index tenor to generate reset dates instead of the
payment frequency.

RoundingMethod For the EONIA rate index, it must be set to SICOVAM.

Note that on the bond, rounding for accrual digital = rounding for coupon rate
decimal = 6/DOWN.

Standard_SwapCurveUnderlying_
Id

No longer used as of patch 903. Select the Index Type “Swap” instead.

UMR_Index_Mapping Used for multiple rate indices like SIFMA and MUNIPSA. Can have the value of
label2 in the CRIF file. If the existing hardcoded mappings do not map to any
label2, this rate index attribure is used to map the index to label2. Used in
MARGIN_INPUT scheduled task.

UNDERLYING_RATE_INDEX Only applies to Notional Factor indices.

Specify the index to be used in case the notional factor quote is unavailable and
one needs to be projected.
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Attributes Description
Use Inflation Ref Date Only applies to Inflation indices that are defined as Index Level but use a

forecast curve whose points are reference (settle) dates instead of inflation
date (actual dates on which inflation is set).

In this case, it should be set to true.

USE_ARREAR_ADJ Default is true. In-arrear convexity adjustments are applied when Reset Timing
= END_PER. It is based on the correlation between the payment frequency and
the index frequency.

Set to false to ignore in-arrear convexity adjustments.

USE_CURVE_FRQ Set to true to use the frequency of the curve definition to retrieve forward rates,
or false otherwise.

It should be set to true for the CDI rate index.

USE_INDEX_FREQUENCY The Rate Index attribute USE_INDEX_FREQUENCY allows users to set a default
compounding frequency as part of a Rate Index Definition given market stand-
ard conventions. So, if a Rate Index is always quoted as annual rates, you would
set the Compound Frequency to PA and set this attribute to true. Then the for-
ward rates returned by the curve will always use this frequency instead of apply-
ing the default logic (which usually assumes frequency is the same as the
compound freq on the trade).

Use_Pmt_Hols_for_Curve_Gen Set to true to use payment holidays from the rate index to generate swap start
and end date.

Default is false.

Use_Pmt_Hols_for_Fwd_End_Dt Set to true to roll Forward End Date using both Rate Index Defaults Reset and
Pay Hol, else just Reset Hol is used.

Default is false.

VariationIndex Specify an index for daily projection rates for Brazilian NTN-B or NTN-C bonds.

Note on Daily Compounding
There are different ways of setting a rate for daily compounding: DailyIndexCalculator = DailyCompound OR
IndexCalculator = OISNew OR IndexCalculator = OIS.

With OISNew, USE_ARREAR_ADJ is set to true to calculate convexity adjustments. For OIS, it is hard-coded to false.

The main difference between DailyCompound and OIS / OISNew is the following:

• With DailyCompound, you set the compound frequency on the trade.

• With OIS / OISNew, the compound frequency is hard-coded to DLY (Daily). You cannot select the DLY
compounding frequency on the trade but the index calculator takes care of it. The compounding frequency on the
rate index must be set to NON.

Note that if you have IndexCalculator = OISNew and OISMethod=OIS, it is the same as IndexCalculator = OIS.
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 Ⓘ [NOTE: DailyIndexCalculator, IndexCalculator, USE_ARREAR_ADJ, and OISMethod are all rate index
attributes]

Summary of differences between daily compounding calculators:

Features IndexCalculator =
EONIA

IndexCalculator =
OIS

IndexCalculator =
OISNew

DailyIndexCalculator
= DailyCompound

DailyIndexCalculator
= DailyCompound2

USE_ARREAR_
ADJ

No convexity
adjustment.

No convexity
adjustment.

Can be set to true
or false.

No convexity
adjustment.

No convexity
adjustment.
Compounding
frequency selected
on the trade.

Control over
trade
compounding
frequency

No - DLY
compounding is
hard-coded.

No - DLY
compounding is
hard-coded.

Compounding
frequency on rate
index must be set
to NON.

No - DLY
compounding is
hard-coded.

Compounding
frequency on rate
index must be set
to NON.

Compounding
frequency selected
on the trade.

No convexity
adjustment.
Compounding
frequency selected
on the trade.

Control over
trade Reset
Lag

No - It comes
from the Rate
Index.

No - It comes
from the Rate
Index.

No - It comes
from the Rate
Index.

No - It comes from
the Rate Index.

Can be overridden at
the trade level.

Control over
Reset Holidays

No - It comes
from the Rate
Index.

No - It comes
from the Rate
Index. Also in
finding the final
rate in a period it
rolls to the next
date (it ignores
the Period Rule of
the Rate Index).

No - It comes
from the Rate
Index. Also in
finding the final
rate in a period it
rolls to the next
date (it ignores
the Period Rule of
the Rate Index).

Ignores Date Roll
"NO_CHANGE".

No - It comes from
the Rate Index.

The Period Rule of
the Rate Index is
respected.

Respects Date Roll
"NO_CHANGE".

Can be overridden at
the trade level.

Rounding Defaults to Rate
Index rounding -
Can be
overridden on the
trade.

Ignores Rate
Index rounding -
Can be set on the
trade.

Defaults to Rate
Index rounding -
Can be
overridden on the
trade.

 See
DailyCompound
rounding attributes.

Can be overridden at
the trade level.
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Features IndexCalculator =
EONIA

IndexCalculator =
OIS

IndexCalculator =
OISNew

DailyIndexCalculator
= DailyCompound

DailyIndexCalculator
= DailyCompound2

Reset timing:
Beginning or
End

Hard-coded to
End.

Hard-coded to
End.

Hard-coded to
End.

Hard-coded to End. Can be overridden at
the trade level, plus
new feature allows
user to change
sample timing from
beginning to end.

Compounding
Flat

Not used. Not used. Can be selected
on the trade.

Can be selected on
the trade.

Can be selected on
the trade.

Compounding
Spread

Not used. Not used. Not used. Can be selected on
the trade.

Can be selected on
the trade.

Compounding
NoComp

Not used. Not used. Not used. Can be selected on
the trade.

Can be selected on
the trade.

Compounding
Simple

Not used. Not used. Not used. Can be selected on
the trade.

Can be selected on
the trade.

Compounding
as in OIS
calculator

No. Yes. Yes with
OISMethod = OIS

No. No.

Sample Dates
Display, with
spread

No. Yes. Yes. Yes. Configurable
Columns in the
Viewer at the trade
level.

Sample Dates
Display, no
spread

No. Yes. Yes. Yes - Configurable
Columns in the
Viewer at the trade
level.

Configurable
Columns in the
Viewer at the trade
level.

 Ⓘ [NOTE: If you select the DLY compounding frequency on a trade for a rate index that is not setup for daily
compounding, the DailyCompound calculator will be used by default]

17.3 Specifying Average Rate Detai ls
The settings in the Average Rate Details window are used to set the default values for average rate IRD trades, and as
parameters for average rate curve underlying instruments. This window also allows defining index rates based on
other index rates.
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Average rate details

» Enter the fields described below as applicable, and click Apply to return to the Rate Index window.

» Then click Save to save the changes to the rate index.

Fields Details

Fields Description
Method Select the averaging method:

• Equal – Resets within the averaging period will be equally weighted.

• Weighted – Resets will be weighted by the number of days for which each rate applies.
For example, if a reset occurred on a Monday, the weight would be 1 day; if a reset
occurred on a Friday, the weight would be 3 days, taking into account Friday, Saturday
and Sunday.

• Simple – Mean rate within the averaging period.

Frequency Select the averaging period.

For a weekly averaging, you can select the day of the week when the averaging period starts
from the Week Day field.

Start Offset Enter the number of days prior to the payment date to specify the beginning of the
averaging period.

In the example below, the index is based on the standard EONIA but the reset date will be 7
days prior to the coupon date.
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Fields Description

CutOff Days Only applies to daily averaging.

Enter the number of days prior to the payment date for the rate reset cutoff, usually “1”.

The Bus label indicates that the cutoff is a number of business days. Double-click the Bus
label to change to Cal as applicable for indicating that the cutoff is a number of calendar
days.

Period Rule Select Match or Custom. Match indicates that the rates are sampled over the entire
averaging period. Custom indicates that the averaging period is a custom averaging period
implemented via the toolkit.

Rounding Unit Enter the number of decimal places for rounding.

Unadjust Sample Date Only applies to weighted averages.

Check to not adjust sample dates according to holidays, or uncheck to adjust sample dates
according to holidays.

Underlying Rate Index Select the underlying index which is the basis for the average calculation, or is the basis of
the rate index.

Note that if an index is based on another index, when you enter the quotes of the underlying
index, the quotes of the index are automatically calculated.

You can also use an underlying rate index to crystallize the value of a rate index. For
example, if you specify a rate index with underlying rate index EONIA, and set the
IndexCalculator attribute to EONIA, the quote of the EONIA will be crystallized on the rate
index.

Example: French T4M
The French T4M is a weighted monthly average of the EONIA:
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Fields Description

Similarly:

• The French TME is a monthly average of the THE.

• The French TMO is a monthly average of the THO.

• The French TAG is a capitalization of the T4M for the last twelve months, etc.

Example: MRO Index
The MRO index averages weekly.

It uses a specific index calculator. You can also set the attribute FWD_CRYS to true to
crystallize the last known rate.
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17.4 Specifying Libor Fal lback
For trades that will not be migrated by the Libor cessation date, you can use the Libor fallback method for pricing and
resetting the trades.

You need to set the following attributes on the Libor rate index.

• IndexCalculator = FallbackISDA

• FallbackCalculatorAsOfDate - <date on which the FallbackISDA calculator is effective - If you price a Libor trade
on Val Date < FallbackCalculatorAsOfDate, the fallback logic is not applied.

• NominalIndex - <RFR index replacing Libor>

• NominalIndexSource - <RFR index source if different from Libor>

To capture LIBOR Fallback Data at the Rate Index Tenor Level, click Fallback Data.

• Cessation Effective Date - This date is used by the calculator to determine whether or not the fallback logic
applies to a given Libor cashflow. If Cashflow Reset Date >= Cessation Effective Date, then fallback pricing and
resetting applies.

• RFR Adjusted Spread - This spread is used by the calculator to calculate an all-in forward rate (added to the
compounded forward rate looked up from the RFR curve). This spread is eventually expected to be a fixed static
value. Given that USD LIBOR will be live until 2023, the system will also support storing the value as a Quote until
such time it becomes fixed.
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17.5 Rebasing an Inf lat ion Index
You can click Rebase to rebase the index level as needed.

» Step 1 – Enter an effective date and a rebase factor in percentage.

» Step 2 – Click Save.

17.6 Specifying Tenors
Select the Tenors panel to define each available quoted index in the system. A rate index is defined by the
combination of currency, index name, tenor and source. A tenor must be associated with an index before the index
can be used in the system.
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Rate Index window – Tenors

» To add a tenor to an index, select a currency, an index, a tenor and a source.

You can also select a date roll convention and a daycount convention, if different from the default rate index
definition.

You can check the “Follow end-end maturity convention” checkbox, to correct the end date of the index in
accordance with the BBA definition. This applies to BBA Libor indices.

Follow end-end maturity convention is for Fwd End. If Fwd Begin is the last business day of the month, Fwd End
will be the last bus day. If Fwd Begin is not the last business day, Fwd End will not be the last business day at fwd
end period.

“Where a deposit is made on the final business day of a particular calendar month, the maturity of the deposit
shall be on the final business day of the month in which it matures (not the corresponding date in the month of
maturity). Or in other words, in line with market convention, BBA LIBOR rates are dealt on an end-end basis. For
instance a one month deposit for value 28th February would mature on 31st March, not the 28th of March.”

» You can also click Save Multiple Tenors to add multiple tenors at a time. You will be prompted to select tenors.

» Then click Save.

17.7 Modifying a Rate Index
» Select a rate index, and modify the fields as applicable.

» Then click Save to save your changes.

You can also click Save As New to save the rate index as a new rate index, provided you select a new index name
or currency.

17.8 Delet ing a Rate Index
» To delete a rate index, you first need to delete all the tenors (provided they are not used), and then delete the

rate index definition.

17.9 Showing Pending Modif icat ions
» Select a rate index and click Show Pending Modifications to show any rate index pending authorization.

Note that this only applies if the Authorization mode is enabled. The Authorization checkbox will appear checked
if the Authorization mode is enabled. Refer to the Calypso Security User Guide for details.
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17.10 Recommended FEDFUNDS Setup

Sample FEDFUNDS index

Attributes

Average Rate Details
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17.11 Recommended SOFR Setup

Sample SOFR index
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Attributes

It is recommend to use the DailyCompound2 index calculator, which allows for more customization at the
Product/Trade level (i.e. ability to define different Reset Lag Days per product, etc.).

Please note that when DailyCompound2 is used, Reset Timing must explicitly be set to END_PER (Reset In Arrears).
Using BEG_PER will result in a calculated rate at the start of the coupon (referencing an observation period prior to the
coupon start). Please consider this setting on curve underlyings as well as trades.

RateLookbackDays can be configured to a larger number if FRNs referencing SOFR use longer settle lags (for
example, if there is a T+8 settled FRN, this attribute should be set to 9 to ensure forward dated accruals properly use
the last published SOFR rate). In any case, pricing always uses the most recent rate.

Average Rate Details

It is recommended that the “Rounding Unit” be left blank. When the calculated weighted average rate is known, it
follows the rounding specified above.

Tenors
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Only the 1D tenor is currently available in the market.

17.12 Recommended SOFRAVG Setup
By referencing a fixed tenor compounded index, coupons can be calculated off of a single reset observed at the
beginning or end of each coupon.
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Sample SOFRAVG Rate Definition

Attributes
IndexCalculator is set to FixedTenorCompoundedRFR, and NominalIndex is set to SOFR.
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Tenors
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SOFRAVG uses 30, 90, and 180 calendar day tenors.

 Ⓘ [NOTE: Compounding and Averaging are not supported for this index, so nothing need be configured in the
Average Rate Details window]
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17.13 Recommended SOFRINDEX Setup
By referencing the compounded index, coupons can be calculated off of two resets observed at the beginning and
end of each coupon.

Sample SOFRINDEX Rate Definition

Attributes
IndexCalculator is set to CompoundedRFR and NominalIndex is set to SOFR.

 Ⓘ [NOTE: For the CompoundedRFR index calculator, bonds use the rate lookback specified in the nominal
index attribute RateLookbackDays, while other products only allow a 1-day tolerance]
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Tenors
At minimum, a single 0D tenor should be configured for this index.

17.14 Recommended ESTRAVG Setup
To ensure that the FixedTenorCompoundedRFR Index Calculator functions properly for this index, set
FixedTenorRFRRollMethod to MOD_PRECED.
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Tenors
ESTRAVG publishes 1W, 1M, 3M, 6M, and 12M tenors.

17.15 Recommended MXN TIIE Rate Index Setup

The aim of this MXN TIIE Rate Index enhancement is to be able to price projected TIIE cashflows where fallback is
applied according to the calculation methodology. While this is actually a change in methodology in the way that TIIE
rates will be calculated and not technically a fallback rate.

Detailed Specifications

17 .15 .1 Rate Index Conf igurat ion

The MXN TIIE Rate Index can be set up as follows:
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Due to the conventions of MXN TIIE, the tenors should be set up as Weekly tenors (other than 1D). The 4W tenor is the
most liquid tenor.

17.15.1.1 New Index Calculator

A new Index Calculator has been added to hold the fallback pricing logic for MXN TIIE: FallbackTIIE.
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This allows users to achieve backdated pricing where the Val Date can be set to a date < FallbackCalculatorAsOfDate
and no fallback pricing will be applied (as if the IndexCalculator is not set).

 Ⓘ Note: The FallbackTIIE calculator makes use of the 1D tenor of the same Rate Index. Therefore, there is no
need to specify a NominalIndex.

17.15.1.2 Fallback Data

The existing Fallback Data UI will be used to hold the fallback spread to be applied for each tenor as well as the date
on which a MXN TIIE cashflow would be considered as “Fallback Applied” (i.e. Reset Date >= Cessation Effective
Date).
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17 .15 .2 Cashf lows

The fallback pricing and resetting logic for MXN TIIE is much more simple than ISDA fallbacks. Therefore, the only
fallback related cashflow column that is relevant to MXN TIIE cashflows is:

• Fallback Applied

• Fwd Beg: If Fallback Applied = true, display the Fwd Beg of the 1D rate used for pricing

• Fwd End: If Fallback Applied = true, display the Fwd End of the 1D rate used for pricing

 Ⓘ Note: The Reset Date never changes for MXN TIIE cashflows where Fallback is applied .

17 .15 .3 Pr ic ing

17.15.3.1 Fallback Forecast Curve

The MXN TIIE fallback solution will support a fallback forecast curve that will be configured via the Product Specific
tab of Pricer Config. The curve mapped for this purpose should be the MXN TIIE 1D curve and it will be used to retrieve
the projected TIIE 1D rate needed to calculate the projected TIIE fallback rate.
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As per the current FB_FOR implementation, this mapping is not required and if this curve mapping is not found, the
fallback cashflows will continue to be priced using the existing MXN TIIE forecast curve

17.15.3.2 Forward Rate Calculation

For TIIE cashflows where “Fallback Applied” = true, the “Fwd Rate” cashflow column should show the projected TIIE
fallback rate calculated as follows:

Where,

TF = The MXN TIIE 1D rate for Reset Date – 1 MEX* bus day. This should be looked up on the FB_FOR curve. (*or
whatever Reset Holiday Calendar is saved for MXN TIIE Rate Index. Any trade level override of the Reset Holidays
should be ignored).

N = the number of days implied in the Rate Index Tenor (example: 28D or 4W = 28).

Adjustment = the RFR Adjusted Spread saved for the MNX TIIE tenor in Fallback Data.

The TIIE 1D rate look up on the FB_FOR curve should follow the standard forward period looks up where the Fwd Beg
and Fwd End 1D period should always fall on a good business day.
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There are two specific use cases that must be covered where the MXN TIIE 1D quote must be used instead of looking
up the projected rate from the FB_FOR curve:

• Where the Val Date = Reset Date – 1 MEX bus day (i.e. the Date for which the 1D rate is needed for formula above),
and the MXN TIIE 1D quote is available for today. In this case, it is still possible to project the MXN TIIE 1D rate from
the curve, but the quote, if available, should be used instead to calculated the projected TIIE fallback rate . A new
Pricing Parameter has been implemented (available only at the global PE level – not transiently on the trade
window) called RESET_TIIE1D_FROM_CURVE.

If RESET_TIIE1D_FROM_CURVE = false (default value if not defined), if a quote for TIIE !D is found on Val Date =
Reset Date – 1, use it. If not found, forecast from curve.

If RESET_TIIE1D_FROM_CURVE = true, on Val Date = Reset Date -1, always forecast from curve, even if a quote is
found.

• Where the Val Date = Reset Date and the MXN TIIE fallback rate is not yet saved to the Quote Set (or RESET_
FROM_CURVE = true). In this case, the TIIE 1D rate cannot be projected from the curve and a TIIE 1D quote must
be retrieved from the Quote Set for Reset Date – 1 MEX bus day. Once the rate is retrieved, the same formula
above would be applied .

On Val Date = Reset Date, if TIIE Fallback Rate (i.e. 4W tenor quote) is found AND RESET_FROM_CURVE <> true,
use the quote.

On Val Date = Reset Date, if (TIIE Fallback Rate (i.e. 4W tenor quote) is NOT found OR RESET_FROM_CURVE =
true) AND if TIIE 1D rate for Reset Date -1 is NOT found, throw missing quote error for TIIE 1D quote

On Val Date = Reset Date, doing Check Market Data should show the TIIE Fallback Rate quote (i.e. 4W tenor
quote actually used on the cashflow)
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18. Defining FX Rate Fixings
The FX Rate Definitions window allows defining where, when, and how FX rates will be fixed (or reset) for a given
currency pair.

The actual FX rates values are fixed using Trade Lifecycle > Reset > FX Rate Reset, or using the FX_RATE_RESET
scheduled task.

From the Calypso Navigator, navigate to Configuration > Foreign Exchange > FX Rate Definitions.

» To create an FX rate definition, click New, complete the details described in the table below, and click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry. Click Show Pending
Authorizations to display any definitions pending authorization.

» To view an existing definition, select the definition in the table.

Fields Details

Fields Description
Name Select a name for the fx rate definition. To add a new name to the drop-down menu, click ...
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Fields Description
to add a name to the "fx_rate_option" domain.

 Ⓘ [NOTE: You can add multiple rate sources for a rate index. Just add the source to
the name so each rate definition has a unique name. For example, create rate
definitions named AUD/USD Reuters and AUD/USD Telerate]

Id When you save the definition, the system assigns it a unique id, and displays it in this field.

Prim Currency

Sec Currency

Select the primary and secondary currencies in the currency pair.

Time

Time Zone

Enter the time at which the rate is published in the selected time zone.

Select the time zone in which the rate is published.

Default Source Select the default quoting source from the list of... to add a source to the "fx_rate_source"
domain.

Date Roll Select the default date roll convention to roll non-business days.

Date roll conventions are described under Help > Date Roll Conventions.

Quote Side Select which quote to use: MID, BID, or ASK.

Reset Days Enter the number of days for the reset lag.

Quote Type Select Multiply to use the quoting convention that 1 unit of primary currency = x units of the
secondary currency.

Reset Hol Click ... to select default reset holiday calendars.

Unscheduled Hol Click ... to select an unscheduled holiday calendar for a Non-Deliverable Swap trade.

Unscheduled Holiday is defined by ISDA as "a day not considered a business day, and one of
which the market was not aware (by way of public announcement or other publicly available
information) until a time later than 9:00 a.m. local time in the Principal Financial Center(s) of
the Reference Currency two Business Days prior to the Scheduled Valuation Date". The
holiday could be due to unforeseen events or unexpected occurrences that alter normal
business days.

• To make the Unscheduled Holiday available for selection in the FX Rate Definition
Window, a new holiday calendar is required.

For details on adding new holiday calendars, see "Defining Holiday Calendars" in the
Calypso Getting Started documentation.

• For the Non-Deliverable Swap trade, you can populate the unscheduled holiday
calendar by double-clicking the red label next to the FX Reset and adding it to the "Hol"
field in the FX Reset pop-up window.
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Fields Description

• To set a maximum number of days for the unscheduled holiday, go to the Currency Pairs
tab of the Currency Default window and add a number of days to the Currency Pair
Attribute "Deferred Period".

By default the maximum is set to 14 days (even though the field will appear empty
before adding a value).

See "Defining Currencies and Currency Pairs" in Calypso Getting Started
documentation for details.

Details Enter a description of the rate definition to be used in confirmations.

Preferred Select to indicate that the definition is the default one if more than one definition exists for
the currency pair.

Manually Reset Select if no publicized rate is available and reference banks or similar will have to be used to
calculate a rate.

Reset Bus Lag Select to indicate that the Reset Days lag is measured in business days, or uncheck for
calendar days.

Spot Alternative Select to enable the BRL Dirty Cupom Curve to pick up the PTAX rate for use as a base
instead of the FX spot rate. For a given currency pair, only one FX reset can be designated as
"Spot Alternative."

The curve window uses the generator parameter "Use FX Reset" on the Quotes tab to
determine whether the curve picks up the FX spot or takes the PTAX rate as the spot
alternative.
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19. Defining Expiry Timezones
You can define expiry timezones using Configuration > Definitions > Expiry Time Zone (menu action
tradingPadNew.fxOpt.FXOptExpTZConfigPanel).

FX Options can expire at different times during the 24 trading day based on the expiration cut. You can assign a
weight to each cut based on holidays and busy days. The multipliers must total 1.0.

Step 1 – Enter the expiration cut details in the input fields:

• Name – Enter the name for the cut. It will be identified through the system with that name, in particular in the
Pricing Sheet.

• Time Zone – Select the local time zone that relates to the cut.

• Exp Time – Enter the option expiration time.

• Multiplier – Enter the holiday / busy day weight to apply to the cut. It is used in the calculation of trading days.

Each Date Cut for an arbitrary period into the future can be given a weight to reflect expected activity. Date Cuts
that fall on holidays or weekends can be given little weight, while Date Cuts that include scheduled market
moving events, such as government reports, can be given higher trading weights.

The number of trading days between two Date Cuts dc1 and dc2 (where dc1 < dc2) is defined as ,

where is the weight for the Date Cut dc.

• Vol Date Cut – Check to use the cut in the volatility surface generation.– It will be available for selection in the
parameters of the surface generator.

Step 2 – Click Save to create the expiration cut. The application adds the cut to the table.
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20. Defining Date Rules
Date rules are used throughout the system to generate a schedule of dates based on complex frequencies.

From the Calypso Navigator, navigate to Configuration > Definitions > Date Schedule Definitions > Date Rules
(menu action refdata.DateRuleWindow) for defining date rules.

Date Rule window

» Date rules are identified by a name throughout the system. Once a date rule is defined, you can enter from and to
dates, and click Generate to check that the dates correspond to the dates you want to obtain.

The general process for generating dates is the following:
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– The system generates default dates based on the selected type and selected months (for example every
first day of the month).

– Then you can add business days or calendar days (depending on the Bus/Cal radio buttons) to the default
generated dates (see Add Days below).

– Finally, you can have an additional check that the new date is a business date (see Check Holiday below). If
is falls on a holiday, the date will be rolled according to the date roll convention.

» You can implement custom date generators. Refer to the Calypso Developer’s Guide for details. Once a custom
generator is implemented, to define the date rule, you must select the CUSTOM type, then save it as the name of
your custom generator. So for example, if you have created a custom generator named
DateGeneratorMyDateRule, you must save the date rule as MyDateRule.

20.1 Creating a Date Rule
Click New to define a date rule, and enter the fields described below.

Then click Save As New to save your changes. You will be prompted to enter a rule name. The new date rule will be
added to the list.

Date Rule Fields Details

Fields Description
Name The name identifies the date rule throughout the system.

Type Select the type of date rule that you want to create.

• ADD_PERIOD – This rule is used to add a number of days / weeks / months / years to a
reference date, and repeating the frequency on the generated date to generate the
following date.

For example, the rule is defined as "Add 2 Months". If you generate the dates between
03/12/2012 and 07/12/2012, you will obtain "03/12/2012 + 2 months = 05/12/2012" and
"05/12/2012 + 2 months = 07/12/2012".

– For "Days", you can specify whether the days are business days or calendar days.

– For "Months", "Weeks", and "Years", the generated date follows the "Check
Holidays" logic described below.

– When the date roll is set to END_MONTH, the date is always rolled to the end of
the month even if the generated date is a business day.

• ADD_TERM – This rule is used to generate a date from a term. The term is added to
today's date, and a single date is generated. The tenor is entered as a number of days,
weeks, months, or years.

– For "Days", you can specify whether the days are business days or calendar days.

– For "Months", "Weeks", and "Years", the generated date follows the "Check
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Fields Description
Holidays" logic described below.

• BEG_MONTH – This rule is used to generate the first day of the month. You can select
the months for which you want to generate the date. It can be modified with the Add
Days field.

• BEG_YEAR – This rule is used to generate the first day of the year. It can be modified
with the Add Days field.

• CUSTOM – This rule is used to define a custom date generator (refer to the Calypso
Developer’s Guide for details on implementing a custom date generator). Once a custom
generator is implemented, to define the date rule, you must select the CUSTOM type,
then save it as the name of your custom generator. So for example, if you have created a
custom generator named DateGeneratorMyDateRule, you must save the date rule with
the name "MyDateRule".

Calypso provides some Out-of-the-Box Custom Date Generators as described below.

• DAILY – This rule is use to generate every day.

• DAY_FIXED – This rule is used to generate a fixed day in a month. You can set the day in
the Day field, and check individual months. If you do not select any month, a date will be
generated for every month.

• DAY_MONTH_FIXED – This rule is used to generate a fixed day in a given month. You can
set the day in the Day field, and select the month from the Month field.

• DIFFERENCE – This rule is used to generate the difference between two date rules. You
can select the rules to be compared from the Rules field.

• END_MONTH – This rule is used to generate the last day of the month. You can select
the months for which you want to generate the date. It can be modified with the Add
Days field.

• END_YEAR – This rule is used to generate the last day of the year. Can be modified with
the Add Days and Add Relative Months fields.

• IMM – This rule is used to generate dates for future and listed option contracts.

• INTERSECTION – This rule is used to generate the first possible date in the future or past
that matches ALL selected rules. You can select a list of rules.

• RELATIVE – This rule is used to adjust an existing rule. You can select the rule to be
adjusted from the Relative field.

• RULE_SEQUENCE – This rule is used to apply multiple date rules in sequence to form one
aggregated date rule. You first select a date rule, then you indicate the duration of this
date rule in number of dates or as a term (like number of months). The last date rule will
be applied indefinitely.
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Fields Description

In this example, the dates from "@Begin of Month" are generated for 1 month, then two
dates are generated from "@Daily Date Rule", then the dates from "@25th Calendar Day
of Month" are generated for 1 year (or until the end of the period).

Generated Dates: For 1 month, the beginning of the month: Jan 1, 2009 and Feb 1, 2009
- Then 2 days: Feb 2, 2009 and Feb 3, 2009 - Then the 25th of the month for the rest of
the period: Feb 25, 2009, Mar 25, 2009, Apr 25th, 2009, etc.

• UNION – This rule is used to generate the first possible date in the future or past that
matches one of the selected rules. You can select a list of rules.

• WEEKDAY_CBOT – This rule is used to generate dates for future and listed option
contracts.

• WEEKDAY_FIXED – This rule is used to generate a fixed day in a week. You can select
the day from the WeekDay field.

• WEEKLY – This rule is used to generate a day in a week according to a rank (for example,
every third Tuesday). You can select the day from the WeekDay field, and the rank from
the Rank field.

Day Enter the day in the month for DAY_FIXED or DAY_MONTH_FIXED.

Add Days Enter a number of days to be added to the default calculated dates.

For example, if you enter 2 for BEG_MONTH, the rule will add 2 days to the first day of the
month.

Select the radio button Bus or Cal to specify whether to add business days or calendar days.
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Fields Description
You can check the Bus Days checkbox to indicate that, before adding the specified number
of days, if the date falls on a holiday, the system uses the specified Date Roll to roll to the
following business day. Then the specified number of days are added.

Month Select the month for DAY_MONTH_FIXED.

Individual Months You can check individual months to which the rule applies. You can also click Select All to
apply the rules to all months.

Click UnSelect All to clear all months.

Add Relative Months

Relative Type

Add Relative Months - The Add Relative Months field uses the value in the field to add that
number of months to the individual months already selected. These months are added
relative to selected months and are not static. Relative months depend on the date on which
the date schedule is in use (the current day's date, aka, the anchor date) and therefore
change over time accordingly.

Relative Type - The Relative Type settings create further conditions for the way the anchor
date and relative months affect the schedule of dates. Refer to the example below to see
how they differ in use.

The From Date in the following example refers to the date generated by the Next & Previous
button used in testing the date rule. See "Testing a Date Rule" on page 218. This date
provides the point of reference described as the anchor date mentioned above.

For the example, the date rule Type is set to BEG_MONTH; selected individual months are
Mar, Jun, Sep, and Dec; the Add Relative Months value is 3. January 1st has been made the
anchor date to simplify explanation.

• Nearest – The 3 relative months are added as follows:

– If From Date is before January 1st, the system adds Jan, Feb and Apr.

– If From Date is on or after January 1st, the system adds Feb, Apr and May.
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Fields Description
• Nearest-Relative – Similar to Nearest, except that in the case where the From Date is on

or after January 1st, the system only adds Feb and Apr.

• Fixed – The selected individual months are taken into account in the span of relative
months, so only 2 months are added as follows:

– If From Date is before January 1st, the system adds Jan and Feb.

– If From Date is on or after January 1st, the system adds Feb and Apr.

• Relative – The 3 relative months are added as follows:

– If From Date is on or before January 1st, the system adds Jan, Feb and Apr.

– If From Date is after January 1st, the system adds Feb, Apr and May.

• Absolute – If we put 2 in the field Add Relative Months, the system will add Feb (Dec+2),
May (Mar+2), Aug (June+2) and Nov (Sep+2).

 Ⓘ [NOTE: Relative Types "Relative" and "Absolute" will both include the From Date
(anchor date) in the schedule. Relative Types "Fixed," "Nearest," and "Nearest-
Relative," on the other hand, roll to the next date in the sequence and do not include the
From Date. When testing the date rule schedule, this becomes apparent after clicking
the Next & Previous button, which shows results for the Next Date. For details on testing
results for the date rule, see "Testing a Date Rule" on the next page.]

WeekDay Select the day in the week for IMM, WEEKDAY_FIXED, or WEEKLY.

Rank Select the rank of the weekday in the month for IMM, or in the week for WEEKLY: NONE,
FIRST, SECOND, THIRD, FOURTH, LAST.

Date Roll Select the date roll convention to roll the dates when "Bus Days" is checked, or when "Check
Holidays" is checked.

Date Roll conventions are described under Help > Date Roll Conventions.

Bus

Cal

This only applies if you have populated "Add Days" to indicate whether to add business days
or calendar days.

Bus Days This only applies if you have populated "Add Days".

You can check the Bus Days checkbox to indicate that, before adding the specified number
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Fields Description
of days, if the date falls on a holiday, the system uses the specified Date Roll to roll to the
following business day. Then the specified number of days are added.

Holidays Click... to select holiday calendars to determine holidays when "Add Days" is populated. See
"Add Days" for details.

Check Holiday This only applies if you have populated "Add Days".

You can check "Check Holiday" when you want to check for holidays (after the calendar
days have been added if any).

If you check "Check Holiday" the system will make sure that the new date is a business date.
It is falls on a holiday, it will be rolled according to the date roll convention.

Relative Only appears when the RELATIVE type has been selected.

Click ... to select a relative date rule. The new date rule is based on the relative date rule,
with any specified adjustments.

For example, on the IMM futures market, trading dates are calculated from delivery dates. As
the delivery date in most cases is defined as the 3rd Wednesday of Delivery Month and the
last Trading date is 2 business days before Delivery date, you can define a trading rule
based on the delivery date with Add days = equals –2 Bus.

Rules Only appears when the DIFFERENCE, UNION or INTERSECTION types have been selected.

Click ... to select the date rules part of the difference, union or intersection.

Description Enter a user-defined comment as needed.

From Date

To Date

In order to verify that the date rule definition is valid, you may generate all dates matching
your rule between the From Date and the To Date fields.

See Testing a Date Rule for details.

Sample Usage
Typically, a date rule will be required to generate a schedule.

Sample swap details

20.2 Testing a Date Rule
» Select an existing date rule, and enter from and to dates.

» Then click Generate. The dates generated by the date rule will appear.
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Sample date rule test

You can also click Next & Previous to view the next and the previous dates that the system would generate.

20.3 Modifying a Date Rule
» Select an existing date rule, and modify it as applicable.

» Then click Save to save your changes.

20.4 Delet ing a Date Rule
» Click Delete. You will be prompted to select a date rule.

Note that if the date rule is in use, you will not be able to delete it.

20.5 Out-of-the-Box Custom Date Generators
To define the date rule, you must select the CUSTOM type, and then save it as the name of the custom generator, as
in the example below.
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Sample custom date generator

Calypso provides the following custom date generators out-of-the-box.

Generator / Date Rule Name Description
Aluminum Daily from cash to 3 months (first prompt date two working days from

cash). Then every Wednesday from 3 months to 6 months. Then every
third Wednesday from 7 months out to 27 months forward.

Define the holidays in the date rule.

CBOT_WHEAT_OPTION_EXPIRY Pre-generated list of option expiry dates through 2040 for CBOTWheat
standard option contracts.

CBOT_WHEAT_SERIAL_OPTION_EXPIRY Pre-generated list of option expiry dates through 2040 for CBOTWheat
serial option contracts.

CMEFeederCattle Pre-generated list of last trading dates for CME Feeder Cattle Futures
Contract.

CME_USDA_LASTTRADEDATE Pre-generated list of last trading dates for CME USDA.

COMEX_JUNE_DEC_OPTION_EXPIRY Expiration occurs on the fourth business day prior to the first day of June
and December. If the expiration falls on a Friday or immediately prior to an
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Generator / Date Rule Name Description
Exchange holiday, expiration will occur on the previous business day.

Pre-generated list of option expiry dates through 2040.

COMEX_MONTHLY_OPTION_EXPIRY Expiration occurs on the fourth business day prior to the first day of each
month. If the expiration falls on a Friday or immediately prior to an
Exchange holiday, expiration will occur on the previous business day.

Pre-generated list of option expiry dates through 2040.

COMEX_GOLD_MID_OPTION_EXPIRY Expiration occurs on the fourth business day prior to the first day of
February, April, June, August, October, and December. If the expiration
falls on a Friday or immediately prior to an Exchange holiday, expiration will
occur on the previous business day.

Pre-generated list of option expiry dates through 2040.

COMEX_SILVER_MID_OPTION_EXPIRY Expiration occurs on the fourth business day prior to the first day of March,
May, July, September, and December. If the expiration falls on a Friday or
immediately prior to an Exchange holiday, expiration will occur on the
previous business day.

Pre-generated list of option expiry dates through 2040.

ICE_ECX_LTD Pre-generated list of last trading dates for the ICE Futures CFI Futures
Contract.

ICE_LTD Pre-generated list of last trading dates for the ICE Brent Crude futures
contract.

ICE_LTD_FUTURE_OPTIONS Pre-generated list of last trading dates for the ICE Brent Futures Options.

IMMCombined Generates the expiry dates on CME Quarter and Serial Eurodollar Future
Option contracts.

IMMNZD Generates expiration dates on NZD 90D Bank Bill Futures. The expiration
dates fall on the first Wednesday after the 9th day of March, June, Septem-
ber, December. If the expiration date falls on an exchange holiday (spe-
cified by the selected holidays calendar configured on the Date Rule), the
date is rolled using the FOLLOWING roll method to the next good business
day.

 Ⓘ [NOTE: The four COMEX rules can be used together in a RULE_SEQUENCE to generate the expiration dates
for COMEX Precious Metal Option Expirations. Following is an example]
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Generated Dates:

11/20/2008

12/23/2008

01/27/2009

02/24/2009

03/26/2009

04/27/2009

05/26/2009

07/28/2009

09/24/2009

11/23/2009

01/26/2010

03/25/2010

05/25/2010

07/27/2010

11/23/2010

05/25/2011

11/22/2011

05/24/2012

11/27/2012

02/25/2013

04/25/2013

06/25/2013

08/27/2013

Sample RULE_SEQUENCE

20.6 Custom Date Rule Tenor Shortcut Window
The Custom Date Rule Tenor Shortcut window allows you to assign a shortcut key to a pre-existing date rule so that a
custom date rule based tenor can be used to quickly populate compatible date fields using the date rule.

From the Calypso Navigator, point to Configuration > Definitions > Custom Tenors (menu action
refdata.CustomTenorShortcutWindow) and open the window to begin creating a custom date rule tenor shortcut.
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Example of Tenor Shortcut window with saved shortcut keys associated with date rules.

20.6.1 Access Permiss ions
The following access permission functions are specific to the Custom Date Rule Tenor Shortcut window.

ViewCustomDateRuleTenors
Provides permission to open/view the Custom Date Rule Tenor Shortcuts window.

RemoveCustomDateRuleTenors
Provides permission to delete existing custom tenor configurations.

AddModifyCustomDateRuleTenors
Provides permission to create new or modify existing custom tenor configurations.

For details on assigning Access Permissions, see "Access Permissions" in Calypso User Security documentation.

20.6.2 Creat ing a Shortcut
» Click New to clear Shortcut Character and Date Rule fields and prepare for adding a new shortcut.
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» In the Shortcut Character field, enter any letter a through z that is not already used by the system for shortcuts.

Exceptions are y, m, w, d, b, and i, which are used as shortcuts for year, month, week, day, business days, and
IMM tenors.

» Click ... beside the Date Rule field to open the Select DateRule window, where you can select a date rule from all
of those available in the system. Use the "Search text" field to filter date rules by text that begins the name of the
date rule.

After highlighting a date rule in the list, click OK to close the Select DateRule window and populate the Date Rule
field.

» You can click Open Date Rule to open the Date Rule window for the rule that is populated in the Date Rule field.

» Click Save to save the shortcut. It then appears in the table of shortcuts and associated date rules in the bottom
portion of the window.

» You can select a row in this table and click Delete to remove the shortcut.

 Ⓘ [NOTE: Manual date rules and rules that generate only one date are not supported.]

20.6.3 Using Custom Date Rule Tenor Shortcuts
The Custom Date Rule Tenor Shortcuts rely on an anchor date as a starting point for generating a date based on the
date rule schedule. When using a shortcut for populating a Start Date, the shortcut uses the Valuation Date as the
anchor. When using a shortcut for the End Date, the Start Date is the anchor.

To apply a shortcut, enter an integer in the date field followed by the letter associated with the date rule.
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Then press Enter. The shortcut key applies the date rule and the integer determines how far out the date is and
populates the date field accordingly.

The Custom Date Rule Tenor Shortcut feature is available in the following products and fields.

• Swap Trade Window – Start Date, End Date

• FRA Trade Window – Start Date, End Date

• Swaption Trade Window – Underlying Swap Start Date, Underlying Swap End Date

• Pricing Sheet strategies: Swap, FRA, Cap, Fixed Rate, Floating Rate – Start Date, End Date

• Front Office Workstation components: Swap Pricer, Line Swap Pricer – Start Date, End Date
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21. Defining Manual Date Schedules
Manual Date Schedules are used to handle complex date schedules for generating futures and future options
products. Manual date schedules can be based off date rules and modified, or can be created from scratch.

From the Calypso navigator, navigate to Configuration > Definitions > Date Schedule Definitions > Manual Date
Schedule (menu action refdata.ManualDateScheduleWindow) for defining manual date schedules.

21.1 Defining a Manual Date Schedule off a Date Rule

Manual Date Schedule off Date Rule

Step 1 – Click to create a new manual schedule.

Step 2 – Enter a name and a description for the manual schedule. The name will be used throughout the system to
identify the manual schedule.

Step 3 – Select a date rule, and enter a start and end dates. Date rules are created using Configuration > Definitions >
Date Schedule Definitions > Date Rule.
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Click Generate to generate the corresponding dates. They are displayed in the "Dates" area.

You can then customize the dates in the "Dates" area:

» Enter comments as needed.

» Click to add custom dates.

Step 4 – Click Save to save the manual schedule.

21.2 Defining a Custom Manual Schedule

RandomManual Date Schedule

Step 1 – Click to create a new manual schedule.

Step 2 – Enter a name and a description for the manual schedule. The name will be used throughout the system to
identify the manual schedule.

Step 3 – Click to add custom dates, and enter comments as needed.

Step 4 – Click Save to save the manual schedule.
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22. Defining Market Indices
This document describes how to create a market index using the Market Index window.

A market index can also be selected as the reference asset in a Performance Swap trade.

Refer to Calypso Performance Swap documentation for details.

From the Calypso Navigator, navigate to Configuration > Product > Market Index to create a market index.

» Click to open the product chooser, then select a market index to display its details in the upper portion of the
window. You can modify its definition as applicable, the fields are described below.

» To create a new market index, click and enter the fields as applicable. The fields are described below.

» Then click to save your changes. You will be prompted to enter a market index name.

You can also click to save the market index as a new market index. You will be prompted to enter a new
market index name.

» You can click to display the Market Index Definition Importer in order to import an index.
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» You can click to display the Market Index Constituents Importer in order to import constituents.

» You can click to rename the market index.

 Ⓘ [NOTE: The Custom Data button is no longer active as of Version 13.0]

Definition Panel Details

Fields Description
Name This name identifies the market index throughout the system, and appears in the quote

name.

When you save the market index, you will be prompted to enter the name for the index.

Product ID A unique identifier that is assigned by the application when you save a newMarket Index.

MarketIndex Type An informational subtype. The sub-type is only for filtering. A list of choices is contained in
the domain "MarketIndex.subtype".

Currency Select the currency in which the index is quoted.

BB_CALC_TYP The Security Codes that identify the ADR Product. Available codes designated in the
Product Code window as ALL.

Country Select the country of the Market Index.

Exchange Select the market place where the index trades. The market place is a legal entity with the
MarketPlace role.

Spot Days Displays the market place spot days entered in the SpotDays Legal Entity Attribute. The spot
days and the holidays attached to the MarketPlace defined in the Legal Entity are used to
compute the Settle Date.

Issuer Select the issuer of the index. The issuer is a legal entity with the Issuer role.

Provider Select the provider of the index as needed. The provider is a legal entity with the Provider
role.

Publish Select a legal entity with the role of Provider. This entity is needed to manage cash in a
market index. If this field is left blank, imported market indices will not be able to handle
cash.

Frequency Select the publishing schedule frequency.

Day Some schedules have for specific publishing days. Day of the week, month, etc.

Holiday Select the holiday calendars to determine the non-business days for the index.

Hour Enter the hour of the day when publishing occurs.

Minute Enter the minute when publishing occurs.

TimeZone Select the time zone for the publish time.

Date Rule Select a Expected Dividend date rule, if any.
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Fields Description
Date rules are created using Configuration > Definitions > Date Schedule Definitions >
Date Rules.

Maturity Payment Lag Enter the payment lag for the final cashflow, if any.

External Reference Enter an External Reference ID as applicable.

Comment Enter a free-text description as applicable.

Constituents Panel Details

» Click to add a new set of constituents to the Market Index. You will be prompted to set the Effective Date for
this Constituent set.

Set the divisor as needed. It is used in the computation of the basket level (number of assets in a basket).

» Then click to add a new constituent.

» Select the Weight Type (Quantity or Weight).

For Weight, you can click Apply equal weights to make the weights/quantities/ equal for all constituents.

» You can click to export the constituents to Excel.

» You can click to paste a list from the clipboard.

Fields Description
Asset Click to select an underlying product.

You can double-click the Products label in the Product Chooser window to view the list of
available products.

Quotable For an FX asset, you can select the fixing in the Quotable field.

Asset Ccy Displays the selected product's currency.

Size/Weight Enter the quantity / weight of the product within the index.

FX Pair Displays the currency pair between the product's currency and the index currency (set in the
Definition panel).
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Fields Description
Quanto/Compo

FX Reset

Fixed FX Rate

Only applies if the product's currency is different from the index currency.

» Select QUANTO to set a fixed FX rate between the product's currency and the index
currency. Enter the fixed rate in the Fixed FX Rate field.

» Select COMPO to retrieve the FX rate between the product's currency and the index
currency from an FX Rate Definition. Select the FX Rate Definition from the FX Reset
field.

22.1 Import ing a Market Index
Click to display the Market Index Definition Importer in order to import an index. The import window is described
below.

Fields Description

Definitions File Select the file that contains the Market Index Definitions.

Provider Select the legal entity of the of the Provider. If this field is left blank, the paid cash for the imported
market indices cannot be handled.

Product Codes Select the product codes that are in the Definitions File.

Comment Click in this field to add a comment. A default comment is provided if none is entered.
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Fields Description

Import
Constituents

Select this if you wish to also import constituents. When this check box is selected, the window
expands to display the fields required for this process.

Constituents
File

Select the file that contains the market index constituents to be imported.

Market Index
Product Code

Select the product codes for the market indices in the file.

Constituents
Product Code

Select the product codes for the constituents in the file.

Import Missing
Bonds

Clicking this option creates missing bonds that are encountered during the import. The columns
needed in the bond file are:

Notional Amount, Level 0, Ticker, Issuer, Final Maturity, First Settlement Date, Interest Accrual Date,
first Coupon Date, Day Count Method, Coupon Frequency and Coupon.

Bonds File Select the file that contains the bond definitions for the importing of missing bonds.

22.2 Import ing Constituents
You may click to display the Market Index Constituents Importer in order to import constituents only. This window
contains the same fields that appear when you select the Import Constituents checkbox in the Market Index Definition
Importer window.
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23. Defining Baskets
This document describes how to create baskets of assets. The ability to create a hybrid basket of assets is possible
by adding assets and mapping them to quote names.

Baskets can be created on-the-fly (transient). Use the Basket window to create these baskets.

From the Calypso Navigator, navigate to Configuration > Basket to open the Basket window (menu action
product.BasketWindow).

23.1 Creating a Basket

Basket window

» To create a new basket, click to clear the window.

» Enter the basket details:

– Basket name.

– Description (free form).

– Select a currency.

– The start date defaults to today but you can change it as needed.

– Divisor used in the computation of the basket level (number of assets in a basket).

Nasdaq Calypso
Getting Started User Guide / Version 18



» To add a component, click  in the Components area, and select the weight type of the basket: Quantity or
Weight (percentage).

A row is added to the Components area. You can right-click the Components area to change the column
configuration.

– Click ... in the Asset field to select a product.

You can double-click the Products label in the Product Chooser window to view the list of available
products.

For an FX asset, you can select the fixing in the Quotable field.

If the currency of the selected product is different from the currency of the basket, you can define the
conversion scheme between the currencies - See Multi-Currency Details below.

– Enter the quantity or weight of the component. You can also click Apply equal weights to apply equal weights
to all components.

Repeat as needed to add more components.

» Click  to save the basket. For a keyboard shortcut, type CTRL + S.

NOTE:When saving weighted baskets, an integrity check is performed to make sure component amounts add up
to 100%. If the components do not add up to 100%, you receive the message shown below.

OR

Create an on-the-fly (transient) basket. Name the basket and click to add it to the transient basket drop-down.
If any asset information is missing, the user will be prompted to add it.

A transient basket must be named and saved in order to load into a trading window or a Pricing Sheet.

» To delete a basket, click .

Multi-Currency Details

Fields Description

FX Pair Displays Product currency / Basket currency.

Quanto/Compo Select whether the basket level is computed based on a fixed rate (Quanto) or an FX Rate
definition (Compo).

FX Reset If you have selected Compo, select an FX Rate Definition to convert the product amount into
the basket amount.
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Fields Description

Fixed FX Rate If you have selected Quanto, enter the FX rate to convert the product amount into the
basket amount.

23.2 Modifying a Basket
You may load existing baskets in the window to view or edit them.

» To load an existing basket, click . For a keyboard shortcut, type Ctrl +O. You will be prompted to select a
basket.

» Modify as necessary.

» Click to save your changes.

23.3 Import ing a Basket from Excel
The import process for product baskets is tied to the Excel application. To import, the following steps must be taken:

» Select cells in Excel.
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» Copy the data to the clipboard.

» Click in the Basket Window.

The basket will be imported into the Basket window.

NOTE: If the Basket window is unable to interpret certain properties from the clipboard, it will leave the
corresponding cell(s) blank in the Basket window.

23.4 Export ing a Basket to Excel
The export process for baskets is tied to the Excel application.

» Click to export the currently loaded basket to Excel.

The file should automatically display itself in Excel.

NOTE: If the file you are trying to export is in a different format than specified by the file extension, you may need
to verify that the file is not corrupted.

23.5 Import ing Baskets Between Calypso Environments
You can import baskets from an XML file, as well as export baskets to an XML file. These functions are especially
useful when working on projects that span multiple Calypso environments.
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To Export to an XML file

» Click .

» Select a file to export.

After the export is executed, you will have the option to display the file. The screen will be displayed as shown
below.

To Import from an XML file

» Click to import a basket to the Calypso environment.

» Select the file and it will appear in the Basket window.

23.6 Analyzing a Basket
Select the Analysis panel to compute the basket level.

Note that you need quotes and market data on the valuation date for each product in the basket.

» Enter a valuation date and click Price. It computes the basket level.

where
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• D = Divisor

• wi = Quantity of the ith component

• Li = Spot Level of the ith component

• FXi = The FX Rate to translate the ith component to the basket currency - Fixed Quanto rate if Quanto, or
prevailing FX rate from FX Rate Definition if Compo

To view product definitions and other product information, select a product and click Product Info. The panel will
appear as shown below.
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24. Defining Product Codes
Product codes are defined for association with the various securities and OTC derivatives products in the system. A
product code can be a unique identifier (as with securities), one used for OTC products, or a user-defined code for
classification purposes.

The product code can be used throughout the system for searching products and grouping products for settlement
and delivery instructions, for example.

From the Calypso Navigator, navigate to Configuration > Product > Code (menu action
product.ProductCodeWindow) for specifying product codes in the Product Code Window as shown below.

 Ⓘ [NOTE: The actual values for the product codes are specified in either a security's product definition
window or directly in the trade window's trade details for an OTC product. In other words, product codes for
securities are specified at the product level, while product codes for OTC products are specified at the trade
level.]

» Click Load to load the existing product codes. You can select a product code name from the Name field and edit
its definition as applicable. The fields are described below.
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» Click New to create a new product code and enter its definition. The fields are described below.

» Click Save to save your changes.

Fields Description

Name Name of the product code currently selected. Click ... to create a new product code name.
The Add Domain Window will appear as shown below.

» Enter a product code name and use the green arrow to move the new name to the list of
domain values to the right. Click OK to save the name.

» In the Product Code Window, select the new name from the Name drop-down list and
enter other criteria described below to complete its definition.

Type Select a product code type:

• String – alphanumeric

• int (integer) – figures

• double – amount

• Boolean – yes/no, true/false

Unique (Securities
Only)

Select this checkbox to require product code values to be unique. Doing so prevents the
user from entering the same value for two different products. If a value is entered for a
second separate product, the system will provide a warning when trying to save the product
definition.
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Fields Description

The "Unique" parameter only applies to securities and is not valid with OTC products.

Searchable Select this checkbox if you want to allow searching for products in the system by product
code. The following are a few examples of interfaces that accommodate product codes in
the search function.

• Trade Browser - codes are specified in the Sec Code drop-down list. Also, once a code
is defined, you can configure columns and have the code appear in the report.

• Trade Blotter - when creating a search template in Ad Hoc Search, under the Sec Code
criteria you can select codes as part of the search when loading trades.

• Trade Filter - on the Product Criteria tab, you can click ... beside the Sec Code field to
select which codes will be used as part of the filter.

 Ⓘ [NOTE: Product codes that can be associated with OTC products, such as ISIN and
CFI codes, utilize the same Sec Code system search framework as do codes associated
with securities. Therefore, codes defined for OTCs are also compatible with the Sec
Code fields used to facilitate product code searching as described in the interfaces
above.]

Mandatory (Securities
Only)

Select this checkbox if you want the product code value to be mandatory. You will be
prompted to enter a value for the code upon saving the product definition if the value is not
set. In this last case, the system will provide a warning and the definition will not be saved.

The Mandatory parameter only applies to securities and is not valid with OTC products.

OTC Select this checkbox when the code will be used for an OTC product. When selected the
code is made available in the trade window, Pricing Sheet, or Deal Station for any OTC
product. It can be accessed by clicking Product Code on the Details panel for trade window
or Deal Station, or by using the Product Code property field in Pricing Sheet. Please note
that OTC product codes are not supported for FX Spot trades.
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Fields Description

For more information on the Details panel, please refer to Calypso Front Office Tools
documentation.

Product “All” is selected by default. Click ... to specify a list of product types for which this product
code is valid.

Setting Product Codes
You can set product codes on products or trades using the workflow rule SetInternalAttribute based on Product Code
configurations (menu action refdata.ProductCodeConfigurationWindow).

You need to add the workflow rule SetInternalAttribute to an action of the Trade workflow, and define the product
codes to set in the Product Code Configuration window based on static data filters.

Example:

You can select Product to set product codes on the product or Trade to set product code on the trade. The static data
filter should only contain product and trade criteria.

In the example above, the following product codes are set on the product:

Cache by Product Code
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You can improve product search by product code using a product code cache, by adding the product code to be
cached to the domain “productSecCodeCached”.

For example, if you add ISIN to the domain “productSecCodeCached”, an ISIN cache is created and it improves the
product search by ISIN code.
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25. Running Mode Overview
When configuring the Data Server, your administrator will choose the running mode regarding access permissions and
authorization.

25.1 Access Permissions
When running in access permissions mode, you will need access permissions at the Function level and at the Data
level, in order to carry out any activity.

Access permissions are granted to user groups. Part of this process is to define users and user groups. Note that
Calypso enables the Access Permissions mode by default during the installation process.

Please refer to Calypso Access Permissions and Calypso Security documentation for details.

25.2 Authorizat ion
When running in authorization mode, any static data modification will have to be authorized by another user. You can
choose what type of data should be authorized. Note that the Authorization Mode is disabled by default.

Please refer to Calypso Authorization documentation for details.
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26. Back Office Overview
The Calypso workflow allows carrying out any back office activity by automating back office operations using
straight-through processing (STP), provided a number of conditions are satisfied. The idea is that the user will only
intervene in the case of an exception (an error or a special case).

The workflow defines the lifecycle of an object: trade workflow, message workflow, transfer workflow, etc. Workflows
are configured by processing organization and product type. A workflow is composed of tasks that promote an object
from a given status to another status through a given action. The task can use STP with conditions, or can be manual.

The way it works is that a number of engines are running in the background, and they are reacting to the various
events that occur on the system. For example, a trade is saved, a quote is saved, a payment is settled, etc. Based on
these events and the configuration of the workflow, new events will be generated: a confirmation, a payment, a
posting, a position, etc.

The workflow in itself is managed by the Data Server and does not require any engine to be running. However, if you
are setting workflow tasks with kick-off timers and cut-off alerts, you need to run the Task engine.

The following back office engines are available:

• Generation of Messages – Message engine

• Sending of Messages – Sender engine

• Import of incoming messages and matching – Import Message engine, Matching engines

• Generation of transfers, payments, and netted payments – Transfer engine

• Generation of accounting postings – Accounting engine

• Generation of CREs (Account Enrichment events) – CRE engine

• Sending of CREs – CRE Sender engine

• Generation of inventory positions – Inventory engine

• Generation of management fees – Billing engine

• Generation of P&L positions – Liquidation engine, Position engine

• Processing of scheduled tasks – Calypso Scheduler
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All of these processes are described below.

Contents
- Trade Workflow

- Message Generation

- Transfer Generation

- Posting Generation

- CRE Generation

- Cash Management

- P&L Positions

- Scheduled Tasks

26.1 Trade Workflow
The trade workflow allows defining the lifecycle of a trade.

Sample Trade Workflow
The basic action of creating a trade is represented by the transition NONE - NEW - <any status>.

The trade workflow is configured by processing organization, and product type.
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At any point of a workflow, a message can be generated and the message workflow takes care of it: a message can be
sent, acknowledged, matched, etc.

The trade lifecycle functions of the trade workflow are described in the user guides per asset class.

26.2 Message Generat ion
The messages functionality is two-fold:

• Generation of messages and associated physical/soft documents

• Processing of incoming messages

A message identifies any document or payment that you send/receive to/from an organization (including contacts
within your organization) to alert them about an event that has occurred on a trade, payment, position, etc.

The generation of messages is a two-step process:

1. The message engine generates messages based on message configurations and contact information. A message
follows its own workflow, and is associated with a physical document generated according to a template. The
physical document at this point, is just a preview. It has to be processed by the sender engine in order to be actually
saved to the database, and sent to the recipients.

2. The physical documents can then be saved to the database and sent to a number of recipients using the sender
engine based on message sender configurations.
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Part of this process is to define document templates. Defining document templates is described under Help >
Message Template Keywords.

A number of document templates are provided out-of-the-box under <calypso
home>/client/resources/com/calypso/templates. They can be customized or you can create your own
templates. Document templates are registered in the “MESSAGE.Templates” domain. Templates contain free-form
text as well as template keywords to retrieve information from trades, messages and transfers.

Sample Message Workflow
You will not be able to generate messages without a message workflow. The basic action of creating a message is
represented by the transition NONE - NEW - <any status>.

The message workflow is configured by processing organization, product type, and message type.

Refer to the Calypso Messages documentation for complete details.

Message Grouping
To generate grouped messages, the general process is the following:

» Define message grouping keys using the Message Grouping window.

» Set message grouping keys on a message configuration using the Message Setup-Up window.

» Run the MESSAGE_GROUPING scheduled task to generate the actual grouped messages.

We currently support the generation of the following grouped messages:
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• MT604 / MULTIPLE Precious Metal Transfer / Delivery Order, and MT605 / MULTIPLE Precious Metal Notice to
Receiver.

MT692 that allows canceling only one single Transaction of a Multiple Message (MT692 will be produced to
cancel one transaction which is part of an initial GLOBAL/MULTIPLE Delivery Order Message MT604 or MT605).

• MT203 that allows grouping of MT202 / MT103 - MT205 that allows grouping of MT202 / MT103

Note that the grouping of MT202 only works for underlying MT202 XML templates.

• MT102 that allows grouping of MT103.

• MT101 that allows grouping of individual MT101 - Refer to the Calypso Corporate Cash Management User Guide.

Refer to Calypso Message Grouping documentation for complete details.

Reconciling Incoming Messages
Reconciling incoming messages can be done manually through the task station (using the ACKED, NACKED, MATCH,
MISMATCH actions, etc.), or using various processes depending on where the messages are coming from.

Refer to Calypso Message Matching documentation for information of out-of-the-box processes and complete
details.

26.3 Transfer Generat ion
Expected transfers are generated by the transfer engine for any movement of cash or security attached to a trade
provided the trades are associated with valid settlement and delivery instructions (SDIs).

Once a transfer is generated, it follows its own workflow for the actual settlement, cancellations, amendments, etc.

Netting
Transfers can be netted based on user-defined nettings keys (netting configuration) and netting criteria (netting
method), or can be manually netted using the Pair Off Manager.

When transfers satisfy the specified criteria, they are netted according to the netting key until the user actually
applies the EXECUTE action to the netted transfer. Subsequent transfers are netted into a new netted transfer until it
is executed in turn. Note that for netting by trade id, you do not need to apply the EXECUTE action, the transfer is
automatically executed when all underlying transfers are known.

The transfer engine processes automatic netted transfers in real-time.

Settlement
Transfers can be settled once they are verified. Transfers are verified when they are known (no reset or completed
reset). Netted transfers are verified when all underlying transfers are known, and they have been executed.
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Sample Transfer Workflow
You will not be able to generate transfers without a transfer workflow. The basic action of creating a transfer is
represented by the transition NONE - NEW - <any status>. A standard transfer workflow is provided out-of-the-box.
You should review the transfer workflow and modify as needed. The various actions of the standard workflow are
described later in this document.

The transfer workflow is configured by processing organization, product type, and transfer type.

At any point of the transfer workflow, a payment message can be generated and the message workflow takes care of
it.

Refer to Calypso Settlements documentation for complete details.

26.4 Posting Generat ion
The accounting engine generates postings based on accounting rules. An accounting rule specifies for a given event
which accounts will be debited and credited. A set of accounting rules is associated to a book through an accounting
book. Part of this process is to define accounting books and accounts.

Refer to the Calypso Accounting documentation for complete details.
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26.5 CRE Generat ion
CREs (Compte Rendu d’Evenement) or Account Enrichment events allow Banks who do not want to have their
debit/credit postings in their Back-Office system, send accounting events to external systems. These events do not
hold details about what accounts are debited or credited.

CREs are generated by the CRE engine.

The CRE Sender engine actually sends the CREs using the CreSenderFormater interface, and updates their status.
The CreSenderFormatter has to be implemented to produce the output of a CRE.

Refer to the Calypso Developer’s Guide for details.

Note that you can also use the CRE_SENDER scheduled task, which sends the CREs using the CreSenderFormater
interface, and updates their status. The CRE Sender engine is a real-time process, while the CRE_SENDER scheduled
task is a batch process.

Refer to Calypso CRE documentation for complete details.

26.6 Cash Management
The cash management capability is based on SETTLE accounts. A SETTLE account is associated with the agent that
settles the trades of a processing organization.

Inventory positions are calculated by the Inventory engine based on transfers of cash and securities into SETTLE
accounts. They can be monitored through the Inventory Position report which computes funding requirements over a
user-defined period.

Account statement events are generated by the scheduled task ACCOUNT_STATEMENT based on inventory
positions, and account statement configurations. The Message engine subscribes to account statements events and
generates account statement messages based on statement message configurations.

Account interest trades (interest bearing trades) are generated by the ACCOUNT_INTEREST scheduled task based
on inventory positions and interest bearing rules.

Account billing events are generated by the scheduled task ACCOUNT_BILLING based on inventory positions and
account billing configurations. The Billing engine subscribes to account billing events to generate account
management fees (billing trades) based on billing grids and fee billing rules.

Billing trades and interest bearing trades are generated on the funding book of the processing organization.

Inventory Position Flow
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26.7 P&L Posit ions
The Liquidation Engine creates positions for products that are position-based.

The Liquidation Engine generates the Economic Position. The position for each security shows the amount of your
holding and the associated realized and unrealized P&L. The positions are computed by default by book and product,
but you can also compute positions based on any other aggregation criteria below book and product, as defined in the
Liquidation configuration.

Trades are taken into account in positions based on the End of Day Valuation Date/Time and Time Zone of the books.
Alternatively, you can define when the liquidation should occur in the LiquidationTime book attribute. Use the format
HHMM. For example, if you set LiquidationTime to 2030, the Liquidation engine liquidates positions at 8:30 PM. If you
do not set this attribute, then the liquidation occurs at the book EOD.

The Position Engine uses less data than the Liquidation Engine, thus improving performance when running position
reports. It does not liquidate the positions.

The Position Engine aggregates positions by product, book, and settle date. You can also create positions using
additional aggregation criteria, for example, by currency pair. Additionally, you can create a position history by
setting-up settle position buckets to value positions at different times during the day.

Refer to Calypso Positions Management documentation for complete details.
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26.8 Scheduled Tasks
Scheduled tasks are batch jobs for automating EOD processing: reports, trade activity, valuation, etc. They are
executed by the Calypso Scheduler, and can also be executed on-the-fly.

The Calypso Scheduler is started in the background by your administrator.

The results of scheduled task executions are displayed in the Report panel of the Scheduled Task window, and also
logged into the Task Station. Custom exception handlers can be implemented for failed scheduled tasks to restart the
scheduled task or to fix the error.

Refer to Calypso Scheduled Tasks documentation for complete details.
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