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1. Fixed Income Overview
Reference Data Specific to Fixed Income Trading
• Issuers

• Bond Defaults

• Bond Benchmarks

• Bond Products

• Bond Spreads

• Bond Report

• Bond Browser

Bond products can be imported from Bloomberg - Refer to Calypso Bloomberg Integration Documentation for details.

ABS Bonds can also be imported from Intex - Refer to Calypso Structured Financing Documentation for details.

Market Data Requirements
Generally, you will need the following market data (Help is available from all market data windows):

• Discount and Forecast curves - See Market Data > Interest Rate Curves > Zero Yield Curve.

• Probability curves - See Market Data > Credit Curves > Probability Curve.

• Repo curves - See Market Data > Interest Rate Curves > Repo Curve.

• Quotes - See Market Data > Market Quotes > Quotes.

Market data can be imported from Reuters - Refer to Calypso Reuters Integration Documentation for details.

ABS Bonds can be priced using the Intex pricer - Refer to Calypso Intex Integration Documentation for details.

Callable Bonds can be priced using the Kalotay pricer - Refer Calypso Kalotay Integration Documentation for details.

Trade Capture
All types of trades are described below.

Trade Lifecycle
The following trade lifecycle actions can be applied to Fixed Income trades (Help is available from all trade lifecycle
windows):

• Allocation - See Back Office > Allocate in the trade window.

Nasdaq Calypso
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• Corporate Action - See Trade Lifecycle > Corporate Action > Corporate Action.

• Domiciliation

• Positions - Refer to Calypso Positions Management Documentation for details.

• Rate reset - See Trade Lifecycle > Reset > Rate Reset.

• Termination and partial termination - See Back Office > Terminate in the trade window, or Trade Lifecycle >
Termination > Terminate.
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2. Defining Issuers
From the Calypso Navigator, navigate to Configuration > Legal Data > Legal Entities (menu action
refdata.BOLegalEntityWindow) to define issuer data.

» Click Load to load existing legal entities, or click New to create a new legal entity.

Issuers are identified by their short name and have the role Issuer.

» You can choose Help > Legal Entities for complete details.

You can also import issuer data from Bloomberg - Refer to the Calypso Bloomberg Integration Documentation for
details.
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3. Defining Bond Defaults
Bond Defaults represent templates dedicated to help you when you create a new Bond Product. It allows the users to
display fields in the Bond definition. The explanation of the fields is given below.

You can create Bonds Defaults using Configuration > Fixed Income > Default from the Calypso Navigator.

Note that you can also specify bond templates from the Bond Product window.

The following fields should be carefully set up, as they will have an impact on accrual and payment computation. All
the other values are explained in the next section concerning Bond definition.

See Bond Product Definition for details.

Contents

- Fields Details

- Sample Bond UST Setup

3.1 Fields Detai ls

Bond Default

Fields Description
Face Value Used to compute the coupon payment and accrual.

Coupon Rounding Used to round the coupon payment amount. The number of decimals you need to set may
depend on the Face Value amount.

Accrual Rounding Used to round the accrual. The value to set up depends on the Face Value specified. If you
set up an accrual rounding of 5, accrual will be computed with a 5 decimals precision. You
may choose to modify the value based on the market practice on each bond.

3.2 Sample Bond UST Setup
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3.2 .1 Issue Panel

3 .2 .2 Coupon Deta i l Panel

Nasdaq Calypso
Fixed Income Trading / Version 18



3.2 .3 Rounding Rule Panel
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4. Defining Bond Benchmarks
When you define a bond, you can associate any bond or bond future as a benchmark, and quote the bond as a spread
over the benchmark bond or bond future. However, you might also want to modify the benchmark over the life of the
bond.

In order to do so, you can specifically identify a given bond or bond future as a benchmark as of a given date.

From the Calypso Navigator, navigate to Configuration > Fixed Income > Benchmark Management to specify
benchmarks as shown below.

» Click to add a benchmark. The Add Assignment window will appear.

Enter a benchmark name, select a tenor, click Select to select a bond or bond future, and enter an effective date
and time. Then click Add.

» You can select a benchmark and click to modify it as applicable, in particular if you want to add a new
benchmark effective at a given date.

Nasdaq Calypso
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Click Add to add a new benchmark.

» You can also click to display the details of the underlying bond or bond future.

» Click Apply to save your changes.

» Select a benchmark and click to display which bonds are using it.

» Click OK to close the window.

Benchmark Association
You can associate a benchmark with a bond from the Benchmark Association panel. This configuration, if any,
overrides the benchmark in the bond product definition.
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» Click to add an association. The Add Assignment window will appear.

Click ... to select a bond or bond future, select a benchmark name, and enter an effective date and timezone.
Then click Add.

» You can select an association and click to modify it as applicable.

Make modifications as necessary and click Change.

» You can also click to display the details of the underlying bond or bond future.

» Click Apply to save your changes.

» Click OK to close the window.

Nasdaq Calypso
Fixed Income Trading / Version 18



5. Defining Bond Products
Prior to trading a bond, you need to create the Bond product.

From the Calypso Navigator, navigate to Configuration > Fixed Income > Bond Product Definition to open the Bond
window.

When you open the Bond window, the Bond panel is selected by default.

You can view existing bonds using the Bond Report.

Contents

- Defining a Bond

- Specifying the Coupon

- Specifying Market Conventions

- Specifying Special Characteristics

- Generating the Cashflows

- Specifying Primary Market Information

- Specifying Product Codes by Legal Entity

- Specifying a Call Schedule

- Loading Credit Events

- Loading Impairment Events

- Defining a Bond Ticket Template

Defining Specific Bond and Product Types

- Argentine Bonds

- Asset Backed Bonds

- BondMMInterest Products

- Brady Bonds

- Brazilian Bonds

- Chilean Bonds

- Chinese Bonds

- CMTB Bonds

- Colombian Bonds

- Convertible Bonds

- Credit Linked Notes

- Danish Mortgage Bonds

- Floating Rate Notes

- Inflation Bonds

- Islamic Bonds

- Lottery Winner Redemptions

- Mexican CETES Bonds

- Payment-In-Kind Bonds

- Re-Issue Bonds

- Revolver Bonds

- Risky Bonds

- Russian Bonds

- Taiwanese Bonds

- US Treasury Floating Rate Notes
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- When-Issue Bonds

5.1 Defining a Bond
Select the Bond panel to define a bond.

Bond Product Definition Window

5.1 .1 Loading an Exist ing Bond
You can load an existing bond into the Bond Product window using one of the following methods:

Nasdaq Calypso
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» Select a security code from the Security Code list, and enter the actual code value in the adjacent field.

Then click Load to load the corresponding bond.

» You can also click Load at the bottom of the window to open the Product Chooser window.

Then enter the fields described below.

5.1 .2 Creat ing a New Bond
You can create a new bond using one of the following methods.

» If you have specified bond defaults, select a bond default next to the Name field. It will populate the
corresponding fields in the Bond window. You can click ... to create new bond defaults.

» If you have specified bond templates, click Templates and choose “Load Template”. It will populate the
corresponding fields in the Bond window.

» Otherwise, click New and enter the fields in the Bond panel and in the other panels as applicable. The fields are
described below.

5.1 .3 Manipu lat ing Bond Templates
You can save the current bond as a bond template, or load an existing bond template to create a new bond.

» Click Templates to manipulate bond templates.

You can convert all bond defaults to bond templates, load a bond template, remove a bond template, and save
the current bond as a bond template.

5.1 .4 Modi fy ing a Bond Name
» Click Update Name to modify the bond’s name. You will be prompted to enter a new name.

5.1 .5 Sett ing Custom Data
» Click Set Custom Data to specify custom data as applicable. It invokes a class named

apps.product.BondCustomDataWindow that implements
com.calypso.apps.product.CustomDataWindow, provided it is implemented and compiled. Refer to the
Calypso Developer’s Guide for details.

5.1 .6 Sav ing a Bond
» Click Save to save your changes. You will be prompted to enter a bond name.

– When a bond is saved, you can save the quote type. By default the proposed quote type is the one specified
in the Market panel.
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– You will also be prompted to generate the corporate actions for the bond. You can then apply the corporate
actions using Trade Lifecycle > Corporate Action > Corporate Action – Apply panel, or the scheduled task
CORPORATE_ACTION.

» You can also click Save As New to save the bond as a new bond. You will be prompted to enter a new bond name.

5.1 .7 Sett ing Credi t Data
» Click Issue Credit Ratings to set credit data at the bond level (they can also be set at the issuer level). The Product

Credit Rating report will appear.

– Select an agency, a rating type, a value, and a date range then choose ProductCreditRating > Add New
Rating (F5) to add the rating value.

– You can also use this report to display existing rating values.

 Ⓘ [NOTE: Access permissions are needed to add, modify or delete a credit rating in the Product Credit Report
Rating window. Functions must be configured in the function domain]

5.1 .8 Pr int ing a Bond Ticket
» Click Print to print a bond ticket using the default template.

– The default template can be customized as described under Defining a Bond Ticket Template.

Fields Description
Name Name given by the user when the bond is saved.

Product Id Unique id given by the system when the bond is saved.

Bond Class Select a bond class. The following bond classes are available out-of-the-box:

• Bond – Vanilla bonds with a long term maturity. May be fixed or floating rate; may be
bullet, amortizing or sinking.

• BondAssetBacked – Any security that pays down based on a factor (for example, Asset
Backed and Mortgage Backed Securities).

See Specifying Asset Backed Bonds for details.

• BondBrady – Brady bonds. Allows interest capitalization.

See Specifying Brady Bonds for details.

• BondConvertible – Convertible bonds.

See Specifying Convertible Bonds for details.

• BondCLN – Credit linked notes.

See Specifying Credit Linked Notes for details.
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Fields Description
• BondDanishMortgage – Danish mortgage bonds.

See Specifying Danish Mortgage Bonds for details.

• BondFRN (Floating Rates Notes) – Floating rate notes.

See Specifying Floating Rate Notes for details.

• BondMMDiscount – Discounted money market instruments with a short-term maturity
(for example, TBills). The coupon frequency must be set to NON.

• BondMMDiscountAUD – Australian discounted money market instruments with a short-
term maturity.

• Bond MMDiscountWithAI – Chinese Money Market instruments that are issued under par
and pay interest at maturity.

See Specifying Chinese Bonds for details.

• BondMMInterest – Money Market instruments with short-term or mid-term maturity (for
example, CDs, CPs, BMTN, and TNotes).

See Specifying BondMMInterest Products for details.

• BondRevolver – Revolver bond.

See Specifying Revolver Bonds for details.

 Ⓘ [NOTE: MBSArm and MBSFixedRate are not currently supported]

Bond classes are defined in the productType domain.

For information on creating a new Bond class, refer to the Calypso Developer’s Guide.

Bond Type Select a bond type. For each bond class, there is a list of bond types in the <bond
class>.subtype domain, for example Bond.subtype.

The bond type will be used for pricer / curve selection to compute the Yield-to-Price
formula.

You can create bond types as applicable for reporting purposes.

For the “Azeri” bond type, all frequency tenors will be treated as day-based. E.g. Quarterly
will be treated as exact 90D and semi-annual will be treated as exact 180D.

 Ⓘ [NOTE: Domain names are case-sensitive]

Security Type You can select a security type provided security types are defined in domain <Bond
Class>.extendedType, for example Bond.extendedType.

The security type can be used for pricer / curve selection, and reporting purposes.

 Ⓘ [NOTE: Domain names are case-sensitive]

Issue Date Enter the issue date.
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Fields Description
Dated Date Enter the accrual calculation start date.

Bonds with a Dated Date > Issue Date
PricerBondGeneric can compute bonds with a Dated Date > Issue Date. For example, on a
Spanish Government bond defined with Issue Date = 07/15/2000 and Dated Date
09/01/2002, it is possible to input trades between the issue date and the dated date in order
to obtain the settlement amount, i.e. without any accruals calculation.

Similarly, a bond with Dated Date < Issue Date may be purchased on its issue date with
accrued interest.

Maturity Date You can enter the maturity date, or select a maturity offset. If you select a maturity offset,
the maturity date will be calculated as dated date + maturity offset.

Date can be left blank for perpetual bonds. You need to set the stub end date however to
determine how far to generate the cashflows.

 Ⓘ [NOTE: The maturity date for a perpetual bond defaults to +60,000 days after the
val date. This behavior can be overridden at the API level]

Issuer Click ... to select the issuer. The issuer is a legal entity of role Issuer.

Country Defaults to the country of the issuer. Modify as applicable.

Issue Price Enter the issue price.

Issue Price Base
You can specify a different base to use for Issue Price and Redemption Price using the
product code "Issue Price Base". If left blank, the default is base 100.

Example: Taiwanese bills are entered in base 10,000.

Issue Yield Used in defining Chilean Bond products. Enter the Tasa Efectiva Real Anual (TERA) rate for
the bond.

Currency Select the issue currency.

Redem. Price Enter the redemption price.

Issue Price Base
You can specify a different base to use for Issue Price and Redemption Price using the
product code "Issue Price Base". If left blank, the default is base 100.

Example: Taiwanese bills are entered in base 10,000.

Redem. Curr. Redemption currency. Defaults to the issue currency.
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Fields Description
Select another currency as applicable.

When the redemption currency differs from the issue currency, you can enter the
redemption FX rate in the Market panel.

See Specifying Market Conventions for details.

Total issued Enter the total face amount of the issue (original par amount used for generating the
cashflows).

The amount issued does not necessarily need to be correct but an amount greater than the
face amount needs to be populated.

Face Value Enter the face value.

Code Displays the default code selected in Configuration > User Access Control > User Defaults,
and its associated value in the adjacent field.

Click Codes to enter the actual code values.

» Double-click the Value field corresponding to a code and enter its value.

» Then click Apply.

You can create product codes using Configuration > Product > Code.

You can add security codes to the domain securityCode.ReprocessTrades that require
checking if trades need to be reprocessed if the security codes are modified.

You can update security codes in bulk using the Bond report.

See Bond Report for details.

Comment Enter a free comment as applicable.

Min. Purchase Amt Enter a minimum amount required to trade that bond as needed.

Bond Status Only applies to Bloomberg static data integration.

Shows the status of the integration. You can change it as applicable.

It is available in the Bond report for filtering bonds and as a column “Bond Status”, and as a
static data filter element.

5.2 Specifying the Coupon
Select the Coupon panel to specify the coupon.

5.2 .1 Speci fy ing a F ixed Rate
The Fixed Rate label is displayed by default.
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» Enter the fields described below as applicable.

Fields Description
Rate Enter the fixed rate.

Ccy Select the coupon currency.

Daycount Enter the coupon daycount.

Daycount conventions are described under Help > Day-Count Conventions.

Quoting Ccy In the case of an All-In Price Quote, set the quoting currency to be the same as the coupon
currency. Otherwise, set it to match the bond currency. If you set the quoting currency to
match the coupon currency, it assumes the quote includes the FX rate conversion and
inflation adjustment.

5.2 .2 Speci fy ing a F loat ing Rate
Double-click the Fixed Rate label to switch to Floating Rate.

» Enter the fields described below as applicable.

Fields Description
Ccy Select the coupon currency.

Daycount Enter the coupon daycount.

Daycount conventions are described under Help > Day-Count Conventions.

Quoting
Ccy

In the case of an All-In Price Quote, set the quoting currency to be the same as the coupon currency.
Otherwise, set it to match the bond currency. If you set the quoting currency to match the coupon
currency, it assumes the quote includes the FX rate conversion and inflation adjustment.

Spread Enter a spread value in basis points over the floating rate.

Note that this field can be customized to apply a change in spread to the remaining cashflows, in the case
of auctioned bonds for example, where the spread changes on the auction date.

» Double-click the Spread label to switch to Var. Spread.

» Then click ... in order to specify a spread schedule. You can specify a spread schedule using a
coupon date rule, or using a start date, an end date and a frequency.

Nasdaq Calypso
Fixed Income Trading / Version 18



Fields Description
– Click Generate to generate the schedule.

– Enter spread values in the spread schedule as applicable.

– Finally, click Apply to save the spread schedule.

Index Select the currency, rate index, tenor and source that identify the floating rate. Rate indices are specified
using Configuration > Interest Rates > Rate Index Definitions.

Note that you can choose an index with a currency different from the coupon currency, in the case where
the security is not yet re-denominated but the index is in EUR for example.

Current
Coupon

Used by Colombian DTF and IBR-linked bonds.

 See Specifying Colombian Bonds for details.

Effective
Spread

Used by Colombian DTF-linked bonds.

 See Specifying Colombian Bonds for details.

Reset
Days

Defaults to the reset lag specified in the Rate Index definition. Modify as applicable.

This is the number of days lag for the floating rate’s fixing.

Rate Index
Factor

Enter a factor to apply to the floating rate as applicable.

Reset Bus
Lag

Check the “Reset Bus Lag” checkbox to specify the reset lag as business days, or as calendar days
otherwise.

Reset In
Arrear

Check the “Reset In Arrear” checkbox to indicate that the floating rate is known at the end of the interest
period, or clear this box otherwise.

Different
Rates Per
Coupon

Check “Different Resets Per Coupon” to generate the reset dates based on the coupon payment
frequency, or clear it to generate the reset dates based on the index tenor.

Apply
Reset
Dates
Beginning
At First
Coupon

When checked, resets will be produced starting from the issue date. Otherwise resets are produced
starting at the maturity date.

Reset
Holidays

Click ... to select reset holiday calendars.

Reset
Dec.

Enter the number of decimal places and select the rounding method from the adjacent field. Used for
CCT bonds for example.

Average
Resets

You can check the "Average Resets" checkbox at the bottom of the window to sample resets at a
frequency different from the payment frequency. Otherwise, the resets are sampled at the payment
frequency.
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Fields Description

Select the sampling frequency. For "WK", you can select the day of the week.

When the sampling frequency is more frequent than the payment frequency, you can define the weight of
the resets by double-clicking the label next to the reset frequency.

• Equal – Resets within the sampling period are equally weighted.

• Weighted – Resets are weighted according to the number of days for which they apply. For example,
if a reset occurs on a Monday, the weight is 1 day; if it occurs on a Friday, the weight is 3 days (Friday,
Saturday and Sunday).

• Simple – The reset rate is calculated as the mean rate within the sampling period.

• Cutoff Adj. – Calculates weighting up to cutoff date. The cutoff date is set as a number of days from
the last sample period’s end date, entered in the field "Cut-Off Lag".

• Cutoff Weekly – If you specify a reset cutoff in the field "Cut-Off Lag", the last sample period will be
“end date - reset cutoff”.

Sample
Period
Shift

Only applicable with daily compounding or daily averaging.

When checked, the sample weights will be shifted as per the shifted dates of the period. The shifting of
observation dates will be visible in the Reset Samples window on the generated cashflows under the
"Observation Start Date" and "Observation End Date" columns.

Last
Coupon
Only

Only applicable with daily compounding or daily averaging.

When checked, the cutoff lag will only be applied to the last interest period.

CutOffLag
Holidays

You can specify an independent holiday calendar for cutoff lag using business days.

Average
Days

Only displayed for Argentine flipper bonds with the "ARS" yield method.

 See Specifying Argentine Bonds for details.

5.2 .3 Speci fy ing a Var iab le Rate
Double-click the Fixed Rate label to switch to Variable.
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» Click ... to display the Coupon Schedule dialog.

– Select a coupon date rule, or enter a start date, an end date and select a frequency. Then click Generate to
generate the corresponding coupon schedule.

– Enter coupon rates (as absolute values) in the coupon schedule as applicable. The coupon rate will apply up
to the specified period end date.

– Then click Apply.

» Enter the fields described below as applicable.

Fields Description
Ccy Select the coupon currency.

Daycount Enter the coupon daycount.

Daycount conventions are described under Help > Day-Count Conventions.

Quoting Ccy In the case of an All-In Price Quote, set the quoting currency to be the same as the coupon
currency. Otherwise, set it to match the bond currency. If you set the quoting currency to
match the coupon currency, it assumes the quote includes the FX rate conversion and
inflation adjustment.

5.2 .4 Speci fy ing an Exot ic Rate
Double-click the Fixed Rate label to switch to Exotic.

» Click Structure Window to display the Structured Dialog. Help is available from that window. When the formula is
applied, it is displayed in the formula area.

You can also select an exotic structure type if you have defined any. See Configuration > Product > Structure
Type Creator for details.

» Enter the fields described below as applicable.

Fields Description
Ccy Select the coupon currency.

Daycount Enter the coupon daycount.

Daycount conventions are described under Help > Day-Count Conventions.

Quoting Ccy In the case of an All-In Price Quote, set the quoting currency to be the same as the coupon
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Fields Description
currency. Otherwise, set it to match the bond currency. If you set the quoting currency to
match the coupon currency, it assumes the quote includes the FX rate conversion and
inflation adjustment.

Acc Daycount Enter the accrual daycount.

Daycount conventions are described under Help > Day-Count Conventions.

5.2 .5 Speci fy ing Payment Character ist ics

» Enter the fields described below as applicable.

Fields Description
Holidays Click ... to select payment holiday calendars.

Note that if you save a bond without a holiday calendar, a warning message will appear.

Roll Day Enter the day of the calendar month to be used as each coupon period’s end date day. If this
is set to zero, then the maturity date day of the month will automatically be used by default.
So, for example, if the issue date is 7/10/04, the maturity date is 7/20/34, the coupon
frequency is SA (semi-annual), and a value of 16 is entered in this field, the coupon payment
dates will be 7/16 and 1/16 (there will be ‘stub’ periods at both the beginning and the end).

Payment Lag

BUS

Enter the number of days lag between the coupon date and the actual payment date, as
applicable.

Check the "BUS" checkbox to specify the payment lag as business days, or as calendar days
otherwise.

If the payment lag entered exceeds 30 days, the payment day will be calculated with a lag of
1 month for each 30 days, and then the remaining number of days added to the coupon
period end date.

Example: A payment lag of 44 for a security with coupon period end date on the 12th day of the
month would pay on the 26th of the following month.

Example: A payment lag of 54 for a security with coupon period end date on the 12th day of the
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Fields Description
month would pay on the date which is 24 days after the 12th day of the following month.

Payment Rule Select the payment rule. The following payment rules are available:

• ADJUSTED – The coupon payment period is calculated to the actual payment date.

• UNADJUSTED – The coupon payment period is NOT adjusted if the coupon period end
date falls on a non-business day (and therefore rolls to a different date).

• MAT_UNADJUSTED – Same as ADJUSTED except for the maturity flow which is
UNADJUSTED (for derivatives).

• FRN – Sets the start and end date at the end of the month, even if the date roll is the 15th
(for derivatives).

Date Roll Payment date roll convention if the coupon period end date is not a business day.

Date roll conventions are described under Help > Date Roll Conventions.

Maturity Roll When checked, the maturity principal payment Pmt Dt is used to calculate the price. If not
checked, the maturity principal payment Pmt End is used to calculate the price.

Frequency Select the payment frequency. The standard list is: DLY (Daily), WK (Weekly), BIWK(Bi-
Weekly), LUN (Lunar), MTH (Monthly), BIM (Bi-Monthly), QTR (Quarterly), SA (Semi-
Annually), PA (Annually), ZC (Zero Coupon, End of period).

You can check "Use Date Rule" instead to generate the coupon based on a date rule.

Pre-Paid Allows you to specify BondMMInterest products for which the coupon is paid at the
beginning of the period. The calculation of the Coupon amount is exactly the same as the
classic BondMMInterest except that it is paid by the Issuer at the beginning instead of the
end of the period.

The FX Reset Date for Dual Currency Bonds will be calculated based on the checkbox
selection. When checked, the FX reset date will be calculated using the coupon begin date.
If unchecked, the reset date is calculated using the coupon end date.

See Specifying BondMMInterest Products for details.

Compound Freq Select the reset frequency. By default it is the same as the payment frequency.

The weekly frequency "WK(R)" works as follows. For a 3M bond paying MONTHLY
compounding WEEKLY, this method splits the 90 days into 3 periods of 30 days each, and
then splits the 30 day periods into periods of 7 days thus leaving stubs on each coupon
period.

Acc Daycount Daycount used for the accrual calculation. By default, it corresponds to the coupon
daycount and can be modified.

Daycount conventions are described under Help > Day-Count Conventions.

Use In Stubs Check the “Use in Stubs” checkbox to apply the accrual daycount to stub periods.

Method Select the interest calculation method:

• NoCmp – The coupon amount to be paid is the sum of the individual reset interest
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Fields Description
amounts.

• Flat – The reset interest amounts will compound to calculate the coupon to be paid. Note
that this method cannot be used when the payment frequency is greater than the reset
frequency.

• Spread – The interest compounds at the rate value plus spread. Only applies to floating
rates.

On the CashFlow panel, right-click an INTEREST cashflow and choose “Interest History” to
see its details.

Use Date Rule Check to select a date rule for the coupon generation rather than the frequency.

Cut-Off Lag Only appears if Compounding Freq = DLY.

The number of days of cutoff lag to be applied every coupon period.

You can specify business or calendar days by double-clicking the adjacent label.

Stub Start

Stub End

Interp

Stub Start contains the security’s first coupon period end date. If the security’s first coupon
period end date is standard, it is not necessary to enter this date here (although it may still
be entered).

Stub End contains the security’s penultimate coupon period end date. As with Stub Start, it is
not necessary to enter this date if the date is standard. It must be set for perpetual bonds to
determine how far out to generate the cashflows.

If you have a period shorter or longer than the classic periods, you put either the first
coupon’s date or the last coupon’s date.

When the bond does not have the same Daycount and Accrual Daycount, and a long stub
period is detected, then the Accrual Daycount is set on the Coupon, and a
CouponPeriodSchedule is created for this Coupon, with two coupon periods having the
following characteristics:

• First Period

– Start Date = Coupon Start Date

– End Date = Coupon End Date - one Period (depends on the Coupon Frequency)

– dayCount = Accrual Daycount

• Second Period

– Start Date = Coupon End Date - one Period (depends on the Coupon Frequency)

– End Date = Coupon End Date

– dayCount = Bond Daycount

Periods can be seen when you right-click a cashflow in the CashFlow panel of the Bond, and
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Fields Description
choose "Show Paydown Periods" from the popup menu.

Interp checkbox
Only applies to floating bonds.

Whenever there is a stub on a floating rate, the system automatically calculates the best
index tenor for the stub period (provided “No Auto Interp” is unchecked on the rate index
definition). If the length of a stub period matches exactly one of the index tenors, there is no
interpolation required. If the length of a stub period is between two index tenors, the system
defaults the stub index to interpolate between the two index tenors.

You can customize these tenors using the "Interp" checkbox and the adjacent tenor fields. If
no interpolation is required, select the same tenor in both boxes.

Interp Rounding The field "Interpolated Rates" is used to determine the rounding, and support rounding for
BondFRN Interpolated Rate in Stub. By default, the Interpolated Rates should be set to
match the rounding set in the rate index.

The drop-down can be set from: Nearest, Up, or Down.

Average Resets See "Average Resets" in Specifying a Floating Rate.

5.3 Specifying Market Conventions
Select the Market panel to specify market conventions.

» Enter the fields described below as applicable.

Fields Description
Settle Days Number of days between the trade date and the settlement date. This field is used in the

trade window to initialize the settlement date.

Accruals Days Currently not used.

It should be equal to the Settle Days.

Ex-Dividend

BUS

Number of days used to define the ex-dividend date. The following number of days can be
specified:

• A positive number – The ex-dividend date will be coupon date - number of days.

• “-1” (Ireland bond) – The system initializes the ex dividend dates as following: Coupon
date - 21 days to get to the week of dividend period and then select the Wednesday of
that week (so it will vary from -21 to -27...).
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Fields Description
• “-2” (South Africa bond) – The ex-dividend date of a coupon is set to one calendar

month before the end date of the coupon.

If the coupon date = end of month then the ex-dividend date will also be set at end of
month dates. Otherwise, it will follow the calendar month.

• “-3” (Denmark bond) – The system initializes the ex dividend dates as following: Coupon
date - 30 days.

Check the "BUS" checkbox to specify the number of days as business days, or as calendar
days otherwise.

You can specify an ex-dividend schedule instead which will ignore the ex-dividend days and
be used to determine the ex-dividend date.

» Click next to the "BUS" checkbox.

» Right-click within the Ex-Dividend schedule popup to add a row.

» Double-click the row and select a date. Add as many rows and dates as needed.

Include ExDate When checked, positive accrual will be computed while valuing on ex-div date and accrual
measures will be impacted.

Record Days Enter the number of record days prior to the coupon payment date. The record date in the
cashflows will be displayed as payment end date - record days.

Redeem Days Enter the number of redemption record days as needed. In the cashflows, redemption
record date = maturity date - redeem days.

If "BUS" is checked, business days will be used to determine the record date, otherwise
calendar days will be used.

Accrual Dig. Number of decimals for the accrual, when expressed in percentage.

You can select the rounding method from the adjacent field: NEAREST, DOWN or UP.
Rounding methods are described under Help > Rounding Methods.

Price Dec. Number of decimal places for the price. If you do not specify the number of decimals, the
system will take the value of the environment property BOND_PRICE_DECIMAL.

You can select the rounding method from the adjacent field: NEAREST, DOWN or UP.
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Fields Description
Rounding methods are described under Help > Rounding Methods.

Yield Dec. Number of decimal places for the yield. If you do not specify the number of decimals, the
system will take the value of the environment property BOND_YIELD_DECIMAL.

You can select the rounding method from the adjacent field: NEAREST, DOWN or UP.
Rounding methods are described under Help > Rounding Methods.

You can specify lower and upper initial yield limits using the MIN_YIELD and MAX_YIELD
pricing parameters.

Nominal Dec. Number of decimal places for the nominal.

Coupon Rate Dec. Number of decimal places for the coupon rate.

You can select the rounding method from the adjacent field: NONE, SAME AS ACCRUAL,
NEAREST, DOWN or UP.

• NONE – No rounding.

• SAME AS ACCRUAL – Rounding is the same as accrual rounding. The Coupon Rate digit
field is disabled.

The other rounding methods are described under Help > Rounding Methods.

Capitalization Dec. Number of decimal places for the capitalization factor of PIK (“Payment In Kind”) bonds, such
as Brady bonds.

You can select the rounding method from the adjacent field: NEAREST, DOWN or UP.

Discount Margin Dec. Number of decimal places for the discount margin.

You can select the rounding method from the adjacent field: NEAREST, DOWN or UP.

Announce Date Date of announcement for a new issue (for Issuance through an issue syndicate, like
Corporate Bonds).

Auction Date Date of auction for a new issue (for Issuance through an auction, like Government Bonds
such as OAT).

Default Date Only applies to Brady bonds.

Enter the date at which the bond has defaulted.

When a bond has defaulted, all cashflows are set to 0, except for the guaranteed cashflows
specified in the Brady schedule.

Withholding Tax Click ... next to the Withholding Tax field to bring up the Withholding Tax Config window.

See Withholding Tax Configuration for details.

Apply Withholding Tax Check to apply the withholding tax to the cashflows, or uncheck otherwise.

If you set the environment property SEC_WITHHOLDINGTAX=true, the withholding tax will
be automatically withdrawn from the coupons, and reclaim fees will be automatically
generated.

See Withholding Tax Generation for setup details.
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Fields Description
When Issue Bond Check to identify a “When-Issue” bond.

See Specifying When-Issue Bonds for details.

Rounding Rule You can add rounding rules as needed.

» Right-click in the Rounding Rule area and select Insert Row.

» Select a rounding rule. The following rounding rules are available:

– Accrual Amount: Rounds the accrual.

– Accrual Rate: For daily compounding or averaging coupons, rounds the final
accrual rate (the calculated daily averaged or compounded rate that will then be
applied to the Notional * Period to calculate Accrual Amount). Also controls the
visible decimals in the Accrual Rate field of the Bond Trade window.

– CA Interest Amount: Rounds the INTEREST of corporate actions.

– Cashflow Amount: Rounds the cashflows, including prepayment cashflows. This
also affects the prices based on the cashflows.

– Daily Interest: Only used by PricerBondUSTFRN. The rounding is applied to each
calendar day.

– Day Count: Rounds the daycount fraction used for the price yield calculation (i.e.
discounting).

– Discount: Rounds the discount.

– Discount Factor: Rounds the discount factor.

– Discounted Cashflow: Rounds the cashflows after they have been discounted.
This also affects the prices based on the discounted cashflows.

– Discounted Cashflow By Facevalue: Rounds the PV Disc.

– Inflation Unadjusted Price: Rounds the price before it is adjusted by the notional
factor.

– Mortgage Payment Rate: Rounds the constant payment rate which is calculated
for each period on bonds that have a Sinking or Amortizing principal of type
Mortgage, used by Chilean bonds Letra Hipotecaria.

– PRECIO: Rounds the PRECIO pricer measure, used by Chilean bonds.

– Pre FX Settlement Amount: Rounds the VALOR amount before it is adjusted by the
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Fields Description
FX rate in the VALOR_MERCADO pricer measure, used by Chilean bonds.

– Principal Amount: Rounds the principal amount to override Currency Default
rounding settings.

– Settlement Amount: Rounds the settlement amount of a trade. In addition, several
other pricer measures are rounded by this amount, including PV, NPV,
SETTLEMENT_VALUE, and CA_COST.

Note that you will also need to set the security code SETTLEMENT_ROUNDING_
CONVENTION to total.

» Enter the number of decimal places.

» Select the rounding method. Rounding methods are described under Help > Rounding
Methods.

» Repeat as needed.

Tick Size Tick size of the quote.

For Repo trades: For securities with tick size other than 100: You can convert Clean Price to
decimal format when Dirty Price or Yield are specified on trade screen. For this, you need to
set the security product code SECFINANCE_QUOTE_BASE =100.

Yield Method Method applied to convert the price to yield and the yield to price.

• ARS – Yield method for Argentine dual-currency bonds.

• BankOfCanada – Yield method for Canadian government bonds.

• CPR – Yield method for asset backed bonds with a CPR (Conditional Prepayment Rate)
prepayment type. The prepayment type and quote are specified in the ABS panel.

• Exp_ACT360 – Exponential method using the ACT/360 daycount convention for
computing the year fraction, irrespective of the bond's daycount.

• Exp_ACT365 – Exponential method using the ACT/365 daycount convention for
computing the year fraction, irrespective of the bond's daycount.

• Exp_NL365 – Exponential method using the NL/365 daycount convention to not
consider leap year for discounting.

• Exponential – Exponential method using the bond's daycount.

• ISMA – ISMA methodology.

• MM_ACT30 – Money market yield method for monthly yield-quoted bonds using the
ACT/30 daycount. Currently only supported for zero coupon bonds.

• MM_ACT360 – Money market yield method using the ACT/360 daycount convention.

• MM_ACT365 – Money market yield method using the ACT/365 daycount convention.

• MXN – Yield method for Mexican bonds.

• Norwegian – Yield method for Norwegian bonds. Uses a yield discounting daycount
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Fields Description
similar to ACTB/ACTB, except that the first fractional period is calculated on an ACT/365
basis rather than ACT/ACT.

• PSA – Yield method for asset backed bonds with a PSA (Public Securities Association)
prepayment type. The prepayment type and quote are specified in the ABS panel.

• ThaiBMA – Yield method for Thai bonds. Uses the 30Thai/360 daycount convention,
which has special handling for the last day of February.

• USSTREET – Yield method for asset backed bonds. The prepayment type and quote are
specified in the ABS panel.

• USSTREET_Lag – Yield method similar to USSTREET except that in the case of payment
lag, the lag days are factored into the discounting.

 Refer to the Calypso Bond Analytics Guide for more details on these yield methods.

Quote Type Quote type: AOAS (Agency Option Adjusted Spread – Used for European callable bonds),
Clean Price, Dirty Price, Discount, Future, Gross Price, Gross Unitary Price, Price, Price32,
Price64, Spread, Unitary Price, Yield, Yield To Best, Yield To Custom, Yield To Maturity, Yield
To Next, or Yield To Worst.

The quote type is automatically displayed in the trade window.

For the Spread quote type, you should select a benchmark. See benchmark fields below.

For the Yield To Custom quote type, you must have Effective Call = Custom, and a Call Date
set in the Call Schedule panel.

Refer to Calypso Zero Curve documentation for complete details on Agency Option
Adjusted Spread (AOAS) pricing for bonds.

Inflation Protected Only applies to Mexican BPA inflation protected bonds (floating rate bond with yield method
= MXN).

When checked, specify an FX index in the Coupon FX Reset field, and an FX Roll convention.

The rate will be calculated as: Max(Index Rate, FX Index Rate Change)

where FX Index Rate Change = (FX End Period / FX Beginning Period - 1) * 360 / Days in
Period

Fixed Coupon Rate

Coupon FX Reset

Only appear if the currency of the coupon is different from the currency of the bond.

You can enter a fixed FX rate in the Fixed Coupon Rate field, or select an FX Reset from the
Coupon FX Reset field.

FX Roll Only applies to dual currency bonds.

When rolled days will be included in interest calculation, select a date roll convention to
determine how to roll the dates for the FX.
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Fields Description
Note that when using FX Roll, the FX reset date will be computed from the unadjusted
coupon period.

Fixed Redemption Rate

Redem FX Reset

When the redemption currency is different from the issue currency, you can set the FX rate
as follows.

• Option 1 – Set a fixed FX rate: Check "Fixed Redemption Rate" and enter the FX rate in
the adjacent field.

• Option 2 – Retrieve the FX rate from an FX Rate Definition on redemption date: Clear the
"Fixed Redemption Rate" checkbox, and select an FX Rate Definition from the Redem FX
Reset field.

FX Rate Definitions are defined under Configuration > Foreign Exchange > FX Rate
Definitions. The FX rates are reset using Trade Lifecycle > Reset > FX Rate Reset.

Issue Paying Agent Name of the Issue Paying Agent for a new issue. The agent should be previously created as
a Legal Entity with the role IPA.

The Issue Paying Agent will be used for issuance trades.

Calculator Agent Name of the calculator agent for a new issue. The agent should be previously created as a
Legal Entity with the role Calculator Agent.

Trustee Name of the trustee of the issue. The trustee should be previously created as a Legal Entity
with the role Trustee. It is used in the Domiciliation process.

See Domiciliation Process for details.

Commission Paid Automatically checked when the domiciliation commission has been paid.

See Domiciliation Process for details.

Benchmark Name Click the Benchmark Name radio button, if the bond is quoted in spread over a benchmark
bond or bond future that will change over the life of the bond.

» Select a benchmark from the adjacent field.

» The selected benchmark will only be effective as of its effective date. Benchmarks are
defined using Configuration > Fixed Income > Bond Benchmarks.

Note that the Quote Type should be set to Spread in that case.

Benchmark Sec Click the Benchmark Sec radio button, if the bond is quoted in spread over a benchmark
bond that will remain the same over the life of the bond.

» Click ... to select the benchmark bond.

» Click Remove to unselect the benchmark bond.

Note that the Quote Type should be set to Spread in that case.

Future Contract Click the Future Contract radio button, if the bond is quoted in spread over a benchmark
bond future that will remain the same over the life of the bond.

» Select an exchange, a currency and a future contract.

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 40 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 41 / 250

Fields Description
Note that the future contract will be rolled to the next one for pricing, if the pricing occurs
within the number of days specified in the Benchmark panel of the Future contract before
the last trading day.

Yield Curve Click the Yield Curve radio button, if the bond is quoted in spread using a yield curve. Yield
curves are defined using Market Data > Interest Rate Curves > Par Yield Curve from the
Calypso Navigator.

5.4 Specifying Special Characterist ics
Select the Special panel to specify special characteristics.

5.4.1 Speci fy ing Amort izat ion Character ist ics

Bullet
The Bullet label is displayed by default. The entire principal is repaid on the security at maturity.

Amortizing
Some of the principal will be repaid prior to the maturity date. A preset schedule defines the exact repayment dates,
and the amount to be repaid on each date (for example, if "Equal" is specified for the Amortizing type, then the par
amount will be repaid in equal installments, the final installment being on the security maturity date).

Although the par amount is entered as an original par amount (the concept of paydowns does not apply to this type of
security), it does reflect the "current" original par amount.

Double-click the Bullet label to switch to Amortizing.

» Select the amortization type from the Type field. The following types of amortization are available:

– Annuity: The amount of each payment (interest + principal) remains constant over the life of the bond. The
interest payments will be larger at the start and decrease over time, while the principal repayments will be
smaller at the start and increase over time.

– Equal: The principal is amortized in equal payments for each interest period.

– Step down: The principal will decrease or increase (as desired) by a specified amount. Enter the step down
amount in the Amount field.
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– Mortgage: The principal is amortized using the fixed rate and period length of each interest period. You can
specify the rounding convention for the constant payment rate in the "Mortgage Payment Rate" rounding
rule on the Market panel. The last payment rate is calculated as:

Amortizationn = Notionaln-1

Paymentn = Amorizationn + Interestn
– Schedule: The principal is amortized according to a user-defined schedule. Click ... to define the schedule.

In the Principal Schedule window you can select from the drop down whether you want to enter amounts in
terms of Quantity, Notional, or Notional Percent, which is the percent remaining of the notional value.

– Custom: The principal is amortized according to the coupon schedule by user-defined amounts specified in
the CashFlows panel.

Amortizing Example
Take a Security issued on 10/15/94 and maturing on 10/15/24.

The Security is set up as "Amortizing", with Amortizing Type "Equal", and payment frequency SA (semi-annual).

Total amount issued is 600,000,000.

Principal-related cashflows will be:

10/15/94 (600,000,000)

4/15/95 10,000,000

10/15/95 10,000,000

4/15/96 10,000,000

etc., until the maturity date.

If a Buy trade is entered for 40,000,000 settling on 11/20/94:

• The par amount will be quoted as 40,000,000

• The trade will be entered with a par amount of 40,000,000

• The trade principal cashflows will be:

11/20/94 (40,000,000 * price)

4/15/95 666,666.67

10/15/95 666,666.67

4/15/96 666,666.67

etc., until the maturity date (note that there are 60 repayments between the trade settlement date and the
security maturity date).

If a Buy trade is entered for 40,000,000 settling on 11/20/04:

• The par amount will be quoted as 40,000,000

• The trade will be entered with a par amount of 40,000,000
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• The trade principal cashflows will be:

11/20/04 (40,000,000 * price)

4/15/05 1,000,000.00

10/15/05 1,000,000.00

4/15/06 1,000,000.00

etc., until the maturity date (note that there are 40 repayments between the trade settlement date and the
security maturity date).

Sinking
As with the "Amortizing" Bond, some of the principal will be repaid prior to the maturity date. A preset schedule
defines the exact repayment dates and the amount to be repaid on each date (for example, if "Equal" is specified for
the Sinking type, then the par amount will be repaid in equal installments, the final installment being on the security
maturity date).

The Sinking Bond behaves almost identically to a BondAssetBacked security, in that there is an original par and a
current par, and the current par is "paid down". The difference is that the current par is paid down on a
BondAssetBacked as a result of a factor being entered, whereas the current par is paid down on a Sinking Bond as a
result of a scheduled paydown taking place. Within Calypso, the scheduled paydown is tracked internally at the
security level by the automatic creation of an internal factor.

As with a BondAssetBacked, the original par amount is quoted for trades in a Sinking Bond (the current par is
determined by using the internal factor).

The price for a Sinking Bond relates to the current par (i.e. the calculation of the principal amount is original par *
factor * price).

Unlike BondAssetBacked securities, there is no delay between the paydown effective date and the setting of the
paydown amount (caused by the delay in publication of the factor) – This is ALL scheduled in advance for a Sinking
Bond.

With a Sinking Bond, the market usually quotes the "original par", so these trades should be entered in Calypso in the
same way as for MBS (i.e. enter original par).

With Calypso’s bond trade window, the "Nominal" field on the top left of the screen is the par (original) nominal. For
any bonds that have variable notionals (amortizing, sinking, Brady, ABS, MBS, etc.), the "Current Nominal" field shows
the current nominal (that is, the current principal bought/sold on the settlement date).

It is not currently possible to enter the "Current Nominal".

Double-click the Bullet label to switch to Sinking.

» Select the sinking type from the Type field. The following types of sinking are available:

– Annuity: The face value will decrease at the fixed rate for each interest period.

– Equal: The face value will decrease in equal amounts for each interest period.
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– Step down: The face value will decrease according to a specified amount. Enter the step down amount in
the Amount field.

– Mortgage: The face value will decrease at the fixed rate for each interest period. You can specify the
rounding convention for the constant payment rate in the "Mortgage Payment Rate" rounding rule on the
Market panel. The last payment rate is calculated as:

Amortizationn = Notionaln-1

Paymentn = Amorizationn + Interestn
– Schedule: The face value will decrease according to a user-defined schedule. Click ... to define the

schedule. In the Principal Schedule window you can select from the drop down whether you want to enter
amounts in terms of Quantity, Notional, or Notional Percent, which is the percent remaining of the notional
value.

– Custom: The face value will decrease according to the coupon schedule by user-defined amounts specified
in the CashFlows panel.

Sinking Example
Take a security issued on 3/15/04 and maturing on 3/15/34, with a Sinking schedule of "equal" payments. The
coupon is SA (semi-annual).

We buy 10 million par at price of 100 on the issue date.

Our principal cashflows will be:

3/15/04 (10,000,000)

9/15/04 166,666.67

3/15/05 166,666.67

9/15/05 166,666.67

etc. until the last principal cashflow: 3/15/34 166,666.67

Original par and current par will be as follows:

Date Original Par Current Par
3/15/04 - 9/14/04 10,000,000 10,000,000.00
9/15/04 - 3/14/05 10,000,000 9,833,333.33
3/15/05 - 9/14/05 10,000,000 9,666,666.67
9/15/05 - 3/14/06 10,000,000 9,500,000.00

5.4.2 Speci fy ing F loater Character ist ics
This applies to floating bonds only to set caps and floors on the floating rate.
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Simple
The Simple label is displayed by default, indicating that the floating rate is dependent on the floating index rate only.

Floater
» Double-click the Simple label to change to Floater.

Select the type of limit you want to set from the Type field. The following types are available:

– Cap: Enter a cap in the Cap field, in percentage. If you enter for example 5%, this means that if the rate on
the coupon date is higher than 5%, the coupon rate will be 5% (the value of the cap). If the rate is less than
5% the rate value is used to calculate the coupon amount.

– Floor: Enter a floor in the Floor field, in percentage. If you enter for example 2%, this means that if the rate on
the coupon date is less than 2%, the coupon rate will be 2%. If the rate is higher, the rate value is used to
calculate the coupon. Negative floor rates are not supported and if set to a negative value, floor=0 will be
applied.

– Collar: Enter a cap and floor in the Cap and Floor fields.

– Straddle: Not currently supported.

– Range: Not currently supported.

5.4.3 Speci fy ing Reconvent ion Character ist ics

No Reconvention
The “No Reconvention” label is displayed by default, indicating that the daycount convention will apply over the life of
the bond.

Reconventioned
» Double-click the “No Reconvention” label to switch to Reconventioned so that you can specify a new daycount

convention as of a given reconvention date.

Enter the reconvention date in the Date field.

Select the new daycount convention from the DayCount field.
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5.4.4 Speci fy ing F l ipper Character ist ics

No Flipper
The “No Flipper” label is displayed by default, indicating that the coupon type will apply over the life of the bond. If the
bond has a fixed coupon, it will remain fixed, or if the bond has a floating coupon it will remain floating.

Flipper
» Double-click the “No Flipper” label to switch to Flipper.

» Enter the flipper date in the Date field.
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» Click ... next to the Details field to specify the new coupon. The coupon will flip to this coupon as of the flipper
date.

» Enter the details related to Reset, Compounding and Average Resets while creating a Bond Flipper at the left side
of the window.

» Click on the Add button The details will now be displayed in the 'Flipper History' section at the right side of the
window.
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» Click on the Apply button - the flipper window will close.

» Save the bond.

» Reopen to verify that the details have been added.

• Floating to fixed: Specify the fixed rate and click Apply. You can select a different coupon frequency as applicable,
or select NO CHANGE if the coupon frequency does not change.

• Fixed to floating or variable to floating: Specify the floating rate and click Apply. You can select a different coupon
frequency as applicable, or select NO CHANGE if the coupon frequency does not change. You can also modify the
fields described below as applicable.

• Support has been provided for Flipper bond to RFR rate index for Fixed to Floating and Floating to Floating. You
can change the leg type using the Flipper reconvention. A sample flipper reconvention is shown above.

• If the original trade's leg type is Fixed, the Flipper reconvention flips the leg type to Float. You can then specify the
parameters for a Float leg.

• The new Flipper related properties are added to Report Framework:

– For Flipper Type [Fixed to Floating | Floating to Floating | Floating to Fixed]

– Flipper Rate Index: if "…to Floating"

– Flipper Rate Index Tenor: if "…to Floating"

– Flipper Rate Index Spread: if "…to Floating"

– Flipper Coupon: if "…to Fixed"

• Currently only the flipper date is available for selection in criteria.

• Users are request to add only 1 line in the Flipper window.
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• The system can handle max of 2 lines of flipper details. This is allowed only when the old flipper data is a Non-RFR
index and the security has later on changed the flipper details to have an RFR index.

 Ⓘ Note - On Config Workbench, if you export a Flipper Bond prior to upgrading to 17 June MR, you will not be
able to import it after upgrade. You first need to upgrade to 17 June MR and export / import Flippers Bonds after
upgrade.

Fields Description
Spread Enter a spread value in basis points over the floating rate.

Rate Index Select the rate index, tenor and source that identify the floating rate. Rate indices are
specified using Configuration > Interest Rates > Rate Index Definitions.

Rate Index Factor Enter a factor to apply to the floating rate as applicable.

Apply Reset Dates
Beginning At First
Coupon

When checked, the reset dates will be produced starting from the first coupon from the
flipper date onward. Otherwise resets are produced started at the maturity date.

Reset Days Defaults to the reset lag specified in the Rate Index definition. Modify as applicable.

This is the number of days lag for the floating rate’s fixing.

Reset Bus Lag Check the “Reset Bus Lag” checkbox to specify the reset lag as business days, or as
calendar days otherwise.

Reset In Arrear Check the “Reset In Arrear” checkbox to indicate that the floating rate is known at the end of
the interest period, or clear this box otherwise.

Reset Holidays Click ... to select reset holiday calendars.

Compounding This includes Compound Frequency, Compound Method, Sample Period Shift, Cut-Off Lag,
Cut-Off Bus Lag, Cut-Off Lag Holidays, Last Coupon Only.

Average Resets This includes Averaging Frequency, Averaging Method, Sample Period Shift, Cut-Off Lag,
Cut-Off Bus Lag, Last Coupon Only.

Cut-Off Lag Holidays Drop-down widget for Holidays.

5.4.5 Speci fy ing Addi t iona l Character ist ics
» Enter the fields described below as applicable.

Fields Description
Payment-In-Kind Check the "Payment-In-Kind" checkbox for specifying payment-in-kind bonds.

See Specifying Payment-In-Kind Bonds for details.

Trades Flat Check the “Trade Flat” checkbox for handling distressed bonds.

You will be prompted to enter a distress date in the As Of field.
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Fields Description
The bond does not receive any coupon as of the distress date.

Notional Indexed Check the “Notional Indexed” checkbox to specify an inflation bond.

See Specifying Inflation Bonds for details.

Active From / Active To Range of dates when the product can be used in the system.

Assimilation Date Input the date of the assimilation as applicable (bonds merger, for example process of
French Government Bonds, with new issues’ slices).

A corporate action can be generated on the assimilation date using the selected assimilation
product. See the Assimilation Prd field below.

Target Name Double-click the Target Name label to select the ISIN code of the assimilation product.

Assimilation Prd Click ... to select the actual assimilation product.

 Ⓘ [NOTE: In the case of issuance assimilation, the assimilation product is set by the
scheduled task ISSUANCE_CONSOLIDATION - See Capturing Bond Trades for details]

Link to Basket Only applies to Bond, BondFRN and BondAssetBacked.

When checked, the bond is eligible to belong to a basket. You can select the basket from the
adjacent field. Note that this is for information purposes only.

You can click Show Basket to view the basket, and New Basket to create a new basket. Help is
available from that window.

Lockout Check the "Lockout" checkbox to specify lockout details for a UST FRN.

 See Specifying US Treasury Floating Rate Notes for details.

5.5 Generat ing the Cashflows
Select the CashFlows panel to generate the cashflows.

5.5.1 Manipu lat ing Cashf lows

Generating Cashflows
» Select a valuation date from the Val Date field and select a pricing environment from the Pricing Env field.

Then click Generate. The cashflows are displayed.
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Note that if you have customized the cashflows, you should not click Generate if you have not locked the columns
that contain modified values, because those columns will be overridden. You should instead right-click any cell
and choose 'Recalc' from the popup menu.

See also the “Customize Flows” checkbox below.

» Select the type of cashflows you want to display from the Display field: all cashflows, interest cashflows only, or
principal cashflows only.

» Check the “Forecast Unknown Flows” checkbox to forecast floating flows.

For AusCPI bonds, it is possible to display the “p-Factor” and “K-Factor” columns provided “Forecast Unknown
Flows” is checked.

Editing Cashflows
» Check the “Customize Flows” checkbox to modify the cashflows as applicable. A star will appear next to the label

of the CashFlows panel.

– To modify a value, double-click a cell and modify its value as applicable.

A column that contains modified values will show a star to the right of the column heading.

Note that if you don’t want modified values to be overridden when the cashflows are generated, you need to
lock the corresponding columns. Right-click a modified value and choose “Lock Column” or “Lock All
Modified Columns” from the popup menu.

A locked column will show a star to the left of the column heading.

– The Manual Amt column is automatically checked when the Pmt Amt is manually modified. It indicates that
changing parameters that would normally be used in the calculation (fixed rate, interest start and end dates)
will have no affect since the payment amount has been manually set.

– Note that when you customize any column of the bond flows, even if the Daycount column has not been
customized, the accrual will be computed using the coupon daycount. If the bond flows are not customized,
then the coupon amount will be computed via the coupon daycount and the accrual will be computed via the
accrual daycount.

5.5.2 CashFlow Menu
» Right-click any cell in the cashflows to display the Cash Flow Menu.

– The menu items of the Cash Flow menu are described below.

Menu Items Description
Copy Ctl-C

Paste Ctl-V

Allows copying and pasting into values.

Select a cell, type Ctrl+C, then select another cell and type Ctrl+V. The content of the first
cell will be pasted into the second cell.

Add Right-click a row and choose Add. The selected row will be split between two rows. The first
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Menu Items Description
one will be one day long, and the second one will fill the remaining term of the original period.
You can edit the periods as applicable.

Remove Right-click a row and choose Remove. The selected row will be removed.

Scheduler Only applies to the Notional, Spread, and Rate columns.

Opens the Scheduler dialog.

Sample Values Not applicable to bonds.

For averaging and compounding bonds, please use the Bond Trade window instead to verify
sample rates as the Bond window uses curves as of the current date, and not as of the
valuation date.

Check Resets Checks the reset rates.

Configure Columns Allows selecting and organizing the displayed columns.

Rename Columns Allows customizing the column names.

Save Configure
Columns

Allows saving the column configuration.

Lock Column Right-click a modified value and choose “Lock Column” so that the value will not be
overridden when the cashflows are generated.

A locked column will show a star to the left of the column heading.

Note that cashflows columns which are locked but not modified will cause the
corresponding fields to be outlined in blue in the trade worksheet.

Lock All Modified
Columns

Allows locking all columns that contain modified values.

Unlock Column Right-click a locked column and choose “Unlock Column” to unlock it.

Unlock All Columns Allows unlocking all locked columns.

Show Paydown Periods Applies to Asset Backed bonds with variable pool factors changes occurring more frequently
than coupon payments.

Right-click a row and choose “Show Paydown Periods” to show any paydown.

This also applies to bonds with long stub periods, when the bond daycount and the accrual
daycount are different.

Interest History Applies to floating compounding bonds.

Right-click a row and choose “Interest History”. The Interest History window will be
displayed.

The columns are the following:

• Start Date – Starting date of the reset period. If it is the first reset period of the cashflow,
this date is the same as the Pmt Begin date.

• End Date – Ending date of the reset period.
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Menu Items Description
• Days – Number of days included in the reset period.

• Period – Ratio of number of days in the reset period by the daycount.

• Rate – Rate used for interest calculation, populated into the quote.

• Accrual – Total amount of accrual for that period.

• Total – Sum of the accruals. Equal to the Accrual for the first period and then cumulated
for the next periods.

• Reset Date – Date at which the rate is selected. Date initialized according to the setup of
the floating rate definition in the Coupon panel.

• Base Interest – Accrued interest amount.

• Compound Interest – Compounded interest on that period.

Show External Flows External cashflows are defaulted to Calypso-generated cashflows unless they have been
imported from Bloomberg.

You can paste cashflows copied from an Excel spreadsheet into the external cashflows.
External cashflows are only saved once they have been modified.

Right-click any cashflow to invoke a popup menu for additional capabilities.

Recalc When cashflows have been customized, choose Recalc to display the cashflows without
overriding unlocked columns.

Generate To generate the cashflows.

Note that if you have customized the cashflows, you should not choose Generate if you
have not locked the columns that contain modified values, because those columns will be
overridden. You should instead choose Recalc.

Export to Excel Allows exporting the cashflows to an Excel spreadsheet.

Export to HTML Allows exporting the cashflows to an HTML page.

5.6 Specifying Primary Market Information
Select the Primary Market panel to specify issuance information. Issuance trades can be entered using Trade > Fixed
Income > Issuance.

» Select a role from the Role field. It should be Lead_Manager or Syndicate_Member.

» Click ... next to the Legal Entity field to select a legal entity for that role.

» Enter a percentage in the % field. This is the percentage of the issue that the selected legal entity should
purchase.

» Then click Add. Repeat as needed for other members of the issuance.
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5.7 Specifying Product Codes by Legal Entity
Select the Legal Entities panel to specify product codes by legal entity.

You can use this panel to specify for example domiciliation codes, or specific product codes by market place.

» Click Insert to insert a row.

» Then select a role, a legal entity, a product code, and enter a product code value. Repeat as needed.

5.8 Specifying a Cal l Schedule
Select the Call Schedule – Calls/Redemptions panel to specify a call schedule for callable bonds and perpetual bonds.
The schedule is used by the Corporate Action process to perform early redemptions as applicable.

» Select the effective call method as applicable.

All pricer measures are computed based on the effective call.

The system computes the effective call by first looking at the pricing parameter EFFECTIVE_CALL_METHOD to
see what the effective method should be (Worst, Best, Next, Maturity, or Custom). If it is not specified in the
pricing parameter, it uses the effective call method defined here.

– Worst: The call that would occur on the worst option, where worst is defined as the yield to that date. When
the val date is past the last call date, the yield is equal to yield-to-maturity.

– Best: The call that would occur on the best option, where best is defined as the yield to that date. When the
val date is past the last call date, the yield is equal to yield-to-maturity.

– Next: The call that would occur after the current val date. When the val date is past the last call date, the
yield is equal to yield-to-maturity.

– Maturity: The bond is not callable.

– Custom: The call that would occur if you called on the entered call date, but using the redemption price from
the call that occurs after that date. If the val date is past the custom date, then the yield behaves as yield-
to-worst.

Note that you must have Effective Call = Custom and a call date set here in order for the Yield To Custom
quote type, the YIELD_TO_CUSTOM pricer measure, and the bond trade "Custom" Yield price to work.

» Select the redemption type as applicable: “Full and Partial” or “Full”.

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 54 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 55 / 250

When you select “Full and Partial”, you can perform partial redemptions. In the redemption row, you can define the
amount of redemption, and the outstanding notional amount will be recomputed accordingly. In order for the
corporate action process to generate the corresponding corporate action, you need to set the “Exercised?”
column to Yes.

You can also check “Interest Clean Up” to perform interest cleanup on the redemption date.

» To generate the call schedule, click . It brings up the Schedule Settings dialog.

Enter the fields as needed and click Generate. The fields of the call schedule are described below.

The Notice days allow determining the notification date. Check “Business day” if the notice days are business
days.

» You can also click to add a redemption row. Enter the fields described below as applicable.

» You can right-click a row to bring up the Redemption menu. It allows configuring the columns and saving the
column configuration.

Fields Description
Option Type Choose between CALL and PUT.

Exercise Type Select European, American, or Bermudan.

For European Callable bonds, you need to set the quote type to AOAS, and the effective call
method to Maturity to price using AOAS curves.

Refer to Calypso Zero Curve documentation for complete details on Agency Option
Adjusted Spread (AOAS) pricing for bonds.

Redemption Date Enter the redemption date for European callable bonds.

First Exercise Date Enter the first exercise date for American and Bermudan callable bonds.

Notif date Enter the redemption notification date.
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Fields Description
Price Enter the redemption price.

Exercised? Choose Yes to allow the generation of corporate actions for partial redemptions.

For callable flipper bonds, when flipper date > stub end date and Exercise flag of Bond Call
Schedule is checked, the cashflows ignore the flipper date and the stub end date is set to
the exercise date. When flipper date > stub end date and Exercise flag is not checked, an
error is generated. The Exercise flag must be set manually.

Redemption Amount

Prior Notional

Outstanding Notional

Only applies to redemption type “Full and Partial”.

Enter the amount of notional that is redeemed. It will re-compute the outstanding notional
accordingly.

Note that to perform a partial redemption, you need to set the “Exercised?” column to Yes.

Interest Clean Up Check to perform interest cleanup on the redemption date.

5.9 Loading Credit Events
Select the Credit Events panel to load credit events that apply to the selected product.

Credit events are created using Trade Lifecycle > Corporate Action > Credit Events.

» Click Load to load credit events that apply to the selected bond.

5.10 Loading Impairment Events
Select the Impairment Events panel to load impairment events that apply to the selected product.

Impairment events are created using Trade Lifecycle > Corporate Action > Corporate Action in the context of asset
impairment for the JGAAP and USGAAP accounting requirements.

A full example is given in the Calypso Positions Management User Guide.

» Click Load to load impairment events that apply to the selected bond.

5.11 Defining a Bond Ticket Template
You can create a bond ticket template under $CALYPSO_HOME/custom/resources/<custom
package>/templates/BondDealTicket.html. If this template is not found, the system will use the default
template provided by Calypso.

Refer to the Calypso Developer’s Guide for information on creating custom code and custom packages.
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5.11 .1 T icket Generat ion Rules
BondDealTicket.html contains rules to fetch the actual HTML templates that you want to use based on any bond
criteria.

You can copy resources/calypsox/BondDealTicket.html to $CALYPSO_HOME/custom/resources/<custom
package>/templates and edit it as applicable.

For example,
<!--calypso>
if ( |BOND_SUBTYPE| == "UST" )

include "BondDealTicket_Tmpl1.html";
else if ( |BOND_SUBTYPE|== "When-Issued" )

include "BondDealTicket_Tmpl2.html";
else

include "BondDealTicket_Tmpl1.html";
</calypso-->

Then BondDealTicket_Tmpl1.html and BondDealTicket_Tmpl2.html for example contain the actual ticket
templates.

So, only BondDealTicket.html is a mandatory file name, then any file name can be used to define the ticket
templates. Also BondDealTicket.html is NOT the actual HTML template but just a placeholder to define what ticket
templates will be used.

Note that BondDealTicket.html and the ticket templates must be located in the same directory, i.e. $CALYPSO_
HOME/custom/resources/<custom package>/templates.

5.11 .2 HTML Ticket Templates
The actual ticket templates are created as standard Calypso message templates using bond-related keywords.

You have two samples under resources/calypsox/BondDealTicket_Tmpl1.html and
resources/calypsox/BondDealTicket_Tmpl1.html.

For information on creating HTML templates, see Help > Message Template Keywords. The keywords specific to
bond tickets are described in the Bond section.

5.12 Specifying Argentine Bonds
Argentine floating rate bonds include the following:

• BonacS4

• LedesmaC3

• TarshopC17

5.12 .1 Y ie ld Method
The yield method "ARS" has specific calculations for Argentine bonds.
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 Refer to the Calypso Bond Analytics Guide for details.

5.12 .2 Average Days
The "Average Resets" field "Average Days" is only displayed for Argentine flipper bonds with the "ARS" yield method.

For these bonds, the averaging ignores unknown rates and averages only the known rates.

When Average Days = 1, RateCurrent = rate on Val Date or last known rate before

When Average Days = N where N is an integer > 1, RateCurrent = average of N business days, with the last day of the
range being Val Date - 2 business days

 See Average Resets for details on using this field.

5.12 .3 Sample Days
For Argentine bonds, it is a special case that the samples should go to Coupon End Date. This behavior is controlled
by the index attribute IncludeExtraSampleDay.

5.12 .4 Mult ip le Quote Sources
In Argentina, a bond can be traded in multiple markets, generating different quotes for the same bond.

 See Multi Quote Mapping for details.

5.13 Specifying Asset Backed Bonds
Asset Backed Securities are securities which "pay down" based on a factor.

You can select the ABS (Asset Backed Securities) panel, provided the bond class is BondAssetBacked.

ABS bonds can be imported from Intex – Refer to the Calypso Intex Integration User Guide for details.
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» Select the bond type as applicable. The following bond types are available:

– ABS: ARM bonds are supported through the Structured Finance module – Refer to the Calypso Structured
Finance User Guide for details on ARM bonds.

– AUDMBS: For AUD MBS bonds. It allows saving "<quote name>.TM" quotes required by
PricerBondAssetBackedAUD.

– IO (Interest Only): An interest only security is essentially a stream of cashflows that represent interest on
outstanding principal. Note that factors need to be captured for these securities, even though no principal
paydowns apply.

– PO (Principal Only): PO securities only receive principal repayments. Principal only securities are similar to
zero coupon bonds since they are priced at a discount to par, but (unlike zero coupon bonds) they are
typically priced with a dollar price (clean price).

– Pass Through: A security which “passes through” payments of interest and principal on the underlying loans
to the investor shortly after receipt from borrowers.

– Principal + Interest: A mix of IO and PO.

– Stripped: Stripped paydown ABS securities are created by separating the interest and principal payments
from the pool of assets in order to create two new securities: PO securities and IO securities. Some
paydown ABS securities may also be partially stripped so that each investor class receives some interest
and some principal.

» In the Special panel, you can only choose the Bullet amortization type for an ABS bond. The logic of scheduled
payment is built into the pricer.

» Then select the ABS panel to define the details of the ABS. The ABS panel is described below.

» Once the ABS panel is defined, select the CashFlows panel to generate the cashflows.

5.13.1 Coupon Panel
By default, the "Compound Freq" and "Method" fields in the Coupon panel are hidden for BondAssetBacked products.

You can enable them by adding the domain BondAssetBacked.showCompounding with the value "true".

When using a floating rate index with the FixedTenorCompoundedRFR index calculator to support fixed tenor deals,
for example US 30 Day Average SOFR, the "Compound Freq" and "Method" fields are not available.
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5.13.2 ABS Panel
If the principal percentage on the ABS panel is less than 100, then the system automatically reduces the principal
percentage by that amount, regardless of the type. If that rate is set to 100, the system does not reduce the principal
percentage.

If the bond is set up as a zero coupon bond (frequency = ZC, rate = 0, and compounding frequency = NON), then no
interest payments are made, turning the bond into a principal only bond. Note that factor schedule changes still apply
and cause principal paydowns. Also note that you need to set the ABS type to VARIABLE, since there is no schedule of
coupons for the fixed or variable schedule to mimic.

If the ABS is set to Interest Only and your principal percentage is not less than 100, a warning is issued. If the ABS is
set to Principal Only and the bond is not set up as a zero coupon bond, a warning is issued. These warnings however,
do not prevent from saving the bond.

» Enter the ABS details as applicable. The fields are described below.

» Click Add/Edit in the Factor Schedule section to add a factor. The Factor Entry dialog will be displayed.

– Enter an effective date: The first date should be the issue date with a factor of 1.

– Enter a factor: The value should be decreasing between 1 and 0. The factor may be > 1.
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An empty factor is an indication that the factor is not yet known, hence it will not be factored into the
cashflows.

If the factor has not changed since the security issuance, it should be set to 1 (it should not be empty) so
that if there is a coupon change, the coupon change will be applied.

– Enter a coupon rate that will be used to calculate the interest of the next period.

– Enter the weighted average coupon, weighted average maturity, and weighted average loan age.

– Enter shortfall and recovery amounts if any, for interest, principal and writedown.

» If you modify past factors, you will be prompted to check the trades that could be impacted (i.e. trades settling in
the blackout period). The list of impacted trades will appear in the Process Trades window so that you can re-
process the trades to take into account the modified factors.

ABS Identification

Fields Description
Series Enter the series.

Class Enter the class in the series.

Groups Enter the group of collaterals supporting the ABS.

Collateral Select a collateral type from the Collateral field. You can add collaterals to the
BondAssetBacked.collateralType domain.

Principal Payments

Fields Description
Schedule Type Select the type of factor structure. The following types are available:

• Fixed Schedule – The structure of the paydown is fixed in advance, and is exactly the
same as the coupon schedule in terms of dates with the factors known in advance. This
is essentially the same as a sinking fund security.

• Variable Schedule – The schedule of the paydown is exactly the same as the coupon
schedule in terms of dates, but the amount is not known until the factor is fixed at the
start of each period.

• Variable – The bond pays down on a user-defined basis, usually, but not necessarily, on
the coupon date of the bond. Factors and coupons can change at any time. The
payment dates can be defined using the Payment Lag field, because they can differ
from the coupon dates.

Note that for an ABS using the prepayment type PSA or CPR, the schedule type should be
either Fixed Schedule or Variable Schedule.

Factor Delay Days Enter the number of days between the factor’s effective date and the factor’s known date.

Business Day Check the “Business Day” checkbox to indicate that the specified delay corresponds to
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Fields Description
business days, or calendar days otherwise.

Principal Fraction Enter the percentage of principal that will be received at the early redemption date as
applicable.

Payment Lag Applies to the Variable type of factor only.

Enter the number of days between the application of the paydown and its payment.

If the payment lag entered exceeds 30 days, the payment day will be calculated with a lag of
1 month for each 30 days, and then the remaining number of days added to the coupon
period end date.

Example: A payment lag of 44 for a security with coupon period end date on the 12th day of the
month would pay on the 26th of the following month.

Example: A payment lag of 54 for a security with coupon period end date on the 12th day of the
month would pay on the date which is 24 days after the 12th day of the following month.

Business Day Applies to the Variable type of factor only.

Check the “Business Day” checkbox to indicate that the specified payment lag corresponds
to business days, or calendar days otherwise.

Early Redemption Date Enter an early redemption date only when known. Entry of a zero factor will automatically set
this field to the Effective Date of the zero factor.

Date Roll Applies to the Variable type of pool factor only.

Select the date roll convention to apply if the payment date falls on a non business day.

Quotes

Fields Description
Prepayment Type Enter the value for the Bloomberg code MTG_PREPAY_TYP: PSA, CPR, etc.

Speed Assumption Displays the quotes of the selected prepayment type. Click Edit to enter the quote.

Weighted Average Life Displays the weighted average life of the issue as it is published by external data feed. Click
Edit to enter the WAL. This is used for calculating premium accrual, discount accrual and
amortization values.

A WAL of 4.5 must be interpreted as 4.5 years, not 4 years and 5 months.

Double-click the “Weighted Average Life” label to bring up the Quote window showing all of
the WAL quotes for the bond between the issue date and today.

5.13.3 CashFlows Panel
You can display the pool factor at coupon date. Right-click any cell and choose “Configure Columns” from the popup
menu to configure the display columns.
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» Right-click an Interest cashflow and choose “Show Paydown Periods” to display the details of the paydowns of
the period.

This only applies for variable pool factors changes occurring more frequently than coupon payments.

Also the following columns are specific to asset backed bonds.

Columns Description
Scheduled Payment Value of the Scheduled Payment (Interest + Principal) only populated for PSA bonds.

Scheduled Interest Value of the Scheduled Interest (based on the Outstanding Principal).

Scheduled Principal Value of the Scheduled Principal Payment (= Scheduled Payment - Scheduled
Interest).

CPR Prepay annual rate %.

Estimate Principal PrePayment Scheduled Principal * CPR.

Estimate Total Payment Scheduled Payment + Estimate Principal PrePayment.

Estimate Pool Factor Pool Factor included Principal PrePayment Estimation.

Estimate Face Value Face Value included Principal PrePayment Estimation.

 Ⓘ [NOTE: For Asset Backed bonds, the Bond Trade window should be used for verifying rates and cashflows]

5.13.4 Externa l Cashf lows
Asset Backed Securities require forecasts to try to predict the future cashflows (principal and interest) based on
prepayment models. The external cashflows feature allows importing cashflows from Bloomberg based on a variety of
forecast models.

 Ⓘ [NOTE: Special license requirements may be required for some models]

To enable external cashflows, follow the steps below.

» Add the value “true” to the BondAssetBacked.USE_EXTERNAL_FLOWS_FOR_PRICING domain.

» Add the values “BAM”, “CPY”, “CPJ”, “CPR” and any other desired prepayment model to the ABS.PrepayTypes
domain.

» Add the values “BAM”, “CPY”, “CPJ”, “CPR” and any other desired prepayment model to
Bloomberg.PrepaymentType domain.
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Once this is enabled, all bond definitions imported from Bloomberg will use the cashflows (forecasted and historical)
as specified from Bloomberg based on the chosen prepayment model. Trade cashflows will use the same cashflows
defined in the bond definition.

Please refer to the Calypso Bloomberg Data License Integration Guide for more details on importing ABS bonds from
Bloomberg.

5.13.5 Specia l D iscount ing for 30/360 Daycount
For ABS bonds settling on the 31st day of the month and with 30/360 daycount convention, you need to set the
domain BondAssetBacked.DC30_360_SpecialDiscountingFor31 with value "true" in order to calculate the yield based
on discounting to the 1st of the next month.

5.13.6 REPROCESS_AFFECTED_TRADES Scheduled Task
The REPROCESS_AFFECTED_TRADES scheduled task checks if there are any pool factor changes to the bonds within
1 business day. If there is, it reprocesses the trades related to the modified bonds (pool factors only).

You need to add REPROCESS_AFFECTED_TRADES to the scheduledTask domain.

You can set a static data filter to filter trades, and select the trade action to be applied. It applies the AMEND action by
default.

Whatever workflow action is used should include the workflow rule CheckBondCalculations.

5.14 Specifying BondMMInterest Products
Instruments with short or mid-term maturities will be entered in the system as BondMMInterest products.

Coupon Panel
» If the coupon is paid at the beginning of the period, check the "Pre-Paid" checkbox and select the discounting

method from the adjacent field. The default is NONE.

5.15 Specifying Brady Bonds
You can select the Brady Schedule panel provided the bond class is BondBrady.

» Select the Special panel to specify the amortization type.

» Select the Brady Schedule panel to specify the principal and interest guarantee schedules.

» Then select the CashFlows panel to specify the pay-in-kind rate.
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5.15.1 Specia l Panel
Brady Bonds are amortizing or sinking bonds.

» Double-click the Bullet label to switch to Amortizing. You can double-click one more time to change to Sinking as
applicable. Then, you can select the bond amortization type or sinking type.

See Specifying Amortization Characteristics.

5.15.2 Brady Schedule Panel
» Click Add in the Principal Guarantee section. Then enter a guarantee period start date and end date, and a

percentage of outstanding principal guaranteed for the given period.

» Click Add in the Rolling Interest Guarantee section. Then enter a guarantee period start date and end date, and a
percentage of interest and a number of coupons guaranteed for the given period.

5.15.3 CashFlows Panel
You can display the pay-in-kind rate (Capitalization Rate). Right-click any cell and choose “Configure Columns” from
the popup menu to configure the display columns.

» Check the “Customize Flows” checkbox, and enter the pay-in-kind rate in the Capitalization Rate field as
applicable. The pay-in-kind rate is the coupon cap that accrues on the outstanding principal.

– Setting the capitalization rate will compute the capitalization factor, which will in turn compute the face
value, notional amount, and amortization amount.

– The payment amount is computed as Rate - Capitalization Rate.

5.16 Specifying Brazi l ian Bonds
Brazilian bonds are Brazilian government bond products issued by Tesouro Nacional. These bonds have a specific
pricer associated with calculation, and each has its own sub-type.

• LTN – Letra do Tesouro Nacional, zero coupon national treasury bill.

• LFT – Letra Financeiras do Tesouro, zero coupon financial treasury bill indexed to the SELIC rate.

• NTN-F – Nota do Tesouro Nacional Serie F, fixed coupon national treasury note (series F), carries a 10% coupon
paid semi-annually.

• NTN-B – Nota do Tesouro Nacional Serie B, fixed coupon national treasury note (series B), indexed to the IPCA
inflation index and carries a 6% coupon paid semi-annually.

• NTN-C – Nota do Tesouro Nacional Serie C, fixed coupon national treasury note (series C), indexed to the IGPM
inflation index and carries a 6% coupon (except for NTN-C 2031 with a 12% coupon) paid semi-annually.
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» Select 'Bond' for the Bond Class.

» Select a Brazilian product for the Bond Type as appropriate: LTN, LFT, NTN-F, NTN-B, or NTN-C.

» Enter all necessary details.

» Save and name your bond.

5.16.1 Daycount
Brazilian bonds typically use the daycount BU/252 with EXP. BU/252 requires that the holidays you want to exclude
be set in the environment property BU252_HOLIDAYS.

5.16.2 Yie ld Method
Brazilian bonds typically use the yield method Exponential.
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5.16.3 Quote Types
Two quote types support the pricing of Brazilian fixed income products.

l UnitaryPrice = Price + accrued interest (non-inflation bonds)
l GrossUnitaryPrice = UnitaryPrice + inflation price (inflation bonds)

5.16.4 Cashf lows
For the Brazilian sub-types, cashflows are automatically calculated using the daycount convention: Daycount Fraction
= Number of Months in Period / 12

5.16.5 Pr ic ing
These bonds use the pricer PricerBondBrazilian. In addition to specific pricing logic, this pricer is also designed to use
the following Pricer Configuration parameters.

Model Parameters panel:

• BOND_FROM_QUOTE – Set to false if you wish to price from curves. In this case, the discount curve will contain
implicitly or explicitly both the zero curve and the market spread over the zero curve.

• COMPUTE_NOTIONAL_FACTOR – Set to true to enable the projection of notional factors for T+n trades.

• ZD_PRICING – When set to true, pricer measures will perform the ZD_PRICING discounting using the curve
specified in the DI_CURVE parameter in the Product Specific panel. In addition, CA_COST will be discounted by
PricerBondBrazilian.

Product Specific panel:

• DI_CURVE – It should be set for each of the Brazilian product types. This represents the risk-free curve, and will be
used for ZD_PRICING.

Pricer
Measures

Description

NOTIONAL_
FACTOR01

The PV unadjusted by the Notional Factor. It represents the sensitivity to a change in the Notional
Factor. It should only be used on bonds that are notional indexed.

QUOTE_
TYPE_PRICE

Displays the price based on the appropriate formatting for the bond quote type. For example, if the
quote type is UnitaryPrice or GrossUnitaryPrice, the QUOTE_TYPE_PRICE will be based on the face
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Pricer
Measures

Description

value like those quote types.

5.16.6 LFT
For an LFT bond, you can only select a Notional Factor index.

This index type uses the attribute UNDERLYING_RATE_INDEX in scenarios where the Notional Factor quote is
unavailable and one needs to be projected.

In order to properly use the Notional Factor index for LFT, you need to set the Model Parameter COMPUTE_
NOTIONAL_FACTOR to true.

Reprocessing LFTs on Settle Day
When an LFT trade is settled in the future, it is based on a projected Notional Factor. It is market practice for the price
and settlement of the LFT trade to be updated on the settle day, when the Notional Factor is known.
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The scheduled task REPROCESS_SETTLING_TRADES can be used to recompute the Notional Factor, price, and
settlement for LFT bonds. The trade filter can be configured to specify which trades should be reprocessed, for
example only the LFT bond sub-type and trades settling on the Val Date.

5.16.7 NTN-B and NTN-C
NTN-B bonds are indexed to the IPCA inflation index. NTN-C bonds are indexed to the IGPM inflation index. They use
the following attributes:

• IndexCalculator – Set to BrazilInflationIndex.

• VariationIndex – Select an index for daily projection rates.

The index is typically published monthly, which is compounded by the variation index to get a value for each day.

Rate = Index Quote * (1 + Variation Index Quote / 100) ^ (Days from Last Reset to Valuation Day / Days from Last Reset
to Next Reset)

5.16.8 Sample Trade
In the Bond Trade window, for the quote types UnitaryPrice and GrossUnitaryPrice, the quantity appears by default in
place of the nominal. You can however double-click the Quantity label to switch to Nominal.

If the bond definition is associated with a legal entity of role MarketPlace in the Legal Entities panel, the MarketPlace
field in the Details panel of the Bond Trade window will be automatically populated.
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5.17 Specifying Chi lean Bonds
Chilean bonds are products issued by Chilean entities or government. These bonds have a specific yield method and
pricer associated with calculation. Bonds are denominated in pesos (CLP), though some bonds are denominated in
UF.

UF is a non-deliverable currency with a daily spot rate that is known up to the 9th of the following month. For front and
middle office purposes, it is treated as a currency, but as an index in the back office. You cannot select this currency
type when creating a bond.

» Select 'Bond' for the Bond Class.

» Select a Chilean product for the Bond Type as appropriate: PDBC, BCP, BCU, BTP, or BTU. They are described
below.

» Select Chile as the issuer and the country.

» Select CLP as the currency.
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» Specify the Issue Yield (see below).

» Save.

Note that on the Coupon panel, CAMARA is set as the default index when specifying a floating rate.

5.17 .1 Chi lean Types and Pr icer Measures
The following bond types and pricer measures are specified for the 'PricerBondChilean' valuation routine. Specify
them in the Results panel of the Market Data window. Calypso supports the following types of Chilean bonds:

• PDBC (Pagares Descontables del Banco Central) – Peso denominated, short term discount issue.

• BCP – Peso denominated bullet bond, semi-annual coupon.

• BCU – UF denominated bullet bond, semi-annual coupon.

• BTP – Peso denominated Treasury bond.

• BTU – UF denominated Treasury bond.

• Bonos de Reconocimiento – Bonos de Reconocimiento does not have a designated Bond Type.

 See Bonos de Reconocimiento for details on these bonds.

Pricer
Measures

Description

VALOR_
PAR

K(1+yt)ACT/365

• K is the outstanding notional on the pay date prior to valuation date

• yt is the TERA (Yield Issue) as a decimal value

• ACT is the number of days between the previous pay date and the valuation date

You can use a different daycount by specifying it in the security code VALOR_PAR_DAYCOUNT.
Otherwise ACT/365 is used.

Bonos de Reconocimiento
Bonos de Reconocimiento use a different formula for VALOR_PAR.

 See Bonos de Reconocimiento for details.

PRECIO 100Pd / ValorPar

• Pd is the dirty price of the bond

VALOR_ Actual Price for Chilean bonds.
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Pricer
Measures

Description

ACTUAL 100 * (ValorPar / Precio)

VALOR Value of the trade (NPV) for Chilean bonds.

(Trade Nominal * ValorActual) / 100

VALOR_
MERCADO

Market value of a Chilean bond, displayed in CLP. If the bond is denominated in CLP, then identical
calculation as VALOR. If the bond is issued in CLF or UF, then calculated as:

Round(VALOR) * FX Rate

The rounding precision can be set in the “Pre FX Settlement Amount” rounding rule in the bond
definition Market panel.

Note that this rounding is not applied to the VALOR pricer measure itself.

5.17 .2 TERA
Chilean bonds have a special Issue Yield, TERA. This value is entered in the bond product definition.

» Enter the Issue Yield for the bond.

Example issue yield:

Chilean daycount conventions can be added on the Market panel in the Yield Method drop down. Chilean bonds
should use Exp_ACT360 or Exp_ACT365 as a yield method. These yield methods use the ACT/360 or ACT/365
daycount conventions irrespective of the bond’s daycount. Amortizing bonds will have the 1 day payment lag
suppressed when computing the yield.
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5.17 .3 Bonos de Reconocimiento
Bonos de Reconocimiento (Recognition Bonus) is a representative document of a worker's contributions into Chile's
old pension system.

Setup
Use the following setup for Bonos de Reconocimiento:

• Yield Method = Exp_ACT365

• Sec code COMPLETE_YEAR_MONTH_DAYCOUNT= true

• Check "Notional Indexed" and specify the IPC index

See Specifying Inflation Bonds for details.

• Pricer = PricerBondChilean

VALOR_PAR
Bonos de Reconocimiento use a different formula for VALOR_PAR.

Where

• IPC1 is the last Consumer Price Index known

• IPC2 is the Consumer Price Index for the previous month of the issuing date of the Bonos de Reconocimiento

• R is the coupon rate, which you should set to 4%

• AC is the number of complete years (round down) from issuing date to valuation date, always an integer

• M is the number of complete months (round down) that remain in the fraction of the year after calculating the
variable AC, always an integer

Payment
Bonos de Reconocimiento have a single payment at maturity. The payment calculation compounds annually for full
years and a monthly portion for the remainder. In Calypso, this can be broken up into a coupon and principal
component.

Where

• IPC1 is the last Consumer Price Index known

• IPC2 is the Consumer Price Index for the previous month of the issuing date of the Bonos de Reconocimiento

• R is the coupon rate, which you should set to 4%

• ac is the number of complete years (round down) from issuing date to maturity date, always an integer
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• m is the number of complete months (round down) that remain in the fraction of the year after calculating the
variable ac, always an integer

To calculate ac and m:

1. If the month for the maturity date is greater than or equal to the month of the issuing date:

ac = year of val date - year of issuing date

m = month of val date - month of issuing date

2. Else, if the month for the maturity date is less than the month of the issuing date:

ac = year of val date - year of issuing date - 1

m = month of val date + 12 - month of issuing date - 1

5.18 Specifying Chinese Bonds
Chinese Discount Notes are issued under par and pay accrued interest at maturity. The notes are issued at a short
period and a special daycount has been modified to accommodate coupons in a leap year.

Chinese Discount Notes (defined as BondMMDiscountWithAI in Calypso) trade on clean price and accrued interest is
explicitly stated in the settlement calculation.

» Select 'BondMMDiscountWithAI' for the Bond Class.

» Select 'Discount' for the Bond Type.

» Enter all necessary details.

» Save and name your bond.

5.18.1 Pr ic ing
These bonds are priced using PricerBondMMDiscount.

For explanatory purposes, original issue discount (OID) is used to calculate NPV.
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– OID = 100 - Issue Price

– OID_FRACTION = OID / 100

– OID_VALUE = OID_FRACTION * Nominal

– Days in Period = Maturity Date - Issue Date

Pricer
Measures

Description

ACCRUAL Accrued interest from issue to value plus 1 day.

• (OID_FRACTION / Days in Period) * Accrual days

ACCRUAL_
BO

If FIRST_ACCRUAL is set to 'true' in the pricing parameter, accrued interest is from issue to valuation
plus 1 day.

• (OID_VALUE / Days in Period) * Accrual days

If FIRST_ACCRUAL is set to 'false' or null, Accrual days is the same except without the extra day
added.

ACCRUAL_
FIRST

Calculated the same as ACCRUAL_BO, but will be subject to the FIRST_ACCRUAL pricing parameter.

ACCRUAL_
SETTLE_DAY

If FIRST_ACCRUAL is set to 'true' in the pricing parameter, accrued interest is from trade settlement to
valuation plus 1 day.

• (OID_VALUE / Days in Period) * Accrual days

If FIRST_ACCRUAL is set to 'false' or null, Accrual days is the same except without the extra day
added.

PREM_DISC Chinese notes accrete to the final value of the issue price rather than par because of implicit accrued
interest.

• [(Nominal * (Trade Price - Issue Price) / 100) / (Maturity Date - Settle Date)] * (Value Date - Settle
Date + 1)

PREM_DISC_
YIELD

Yield amortizes or accretes to issue price rather than par. If trade price is lower than issue price, yield
calculates down to issue price at maturity. If price is higher, yield calculates up.

NPV The change in market value plus the accrued interest. Accrued interest is derived from the original
issue discount.

• [Nominal * (Market Price - Trade Price) / 100] + [OID_VALUE / Days in Period] * (Value Date -
Settle Date)

NPV_NET Equal to the change in market value without accrued interest, accretion or amortization.

• Nominal * (Market Price - Trade Price) / 100

NPV_DISC Equal to the change in the market value with either accretion of the discount subtracted or the
amortization of the premium added.
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Pricer
Measures

Description

• NPV_NET - PREM_DISC

or

• NPV_NET - PREM_DISC_YIELD

5.18.2 Chinese Discount Note Account ing Events
The following accounting events allow generating the proper postings for Chinese discount notes.

Accounting Event Trigger Event Pricer Measure

COUPON_CLIP LIQUIDATED_POSITION from REDEMPTION corporate action. ACCRUAL_
FIRST

ACCRUAL_INC_REAL LIQUIDATED_POSITION from REDEMPTION corporate action. ACCRUAL_
SETTLE_DATE

PREM_DISC_YIELD_REAL LIQUIDATED_POSITION from REDEMPTION corporate action. PREM_DISC_
YIELD

REALIZED_CLEAN_PL LIQUIDATED_POSITION from REDEMPTION corporate action. Redemption
nominal * (Issue
price - trade
price)

ACCRUAL_REAL LIQUIDATED_POSITION from buy/sells. ACCRUAL_
SETTLE_DATE

ACCRUAL TRADE_VALUATION ACCRUAL_
SETTLE_DATE

PREM_DISC_YIELD TRADE_VALUATION PREM_DISC_
YIELD

MTM_DISC_YIELD TRADE_VALUATION NPV_DISC

See Capturing BondMMInterest and BondMMDiscount Trades for additional details.

5.19 Specifying CMTB Bonds
CMTB bonds can be used only as curve underlying instruments.

They do not have a maturity date. The coupon is fixed and the quote type is Yield.
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In the Curve Underlying window, you can assign specific tenors to these bonds (or benchmark of these bonds).

When used in a curve, the maturity date is calculated from the curve date by applying the specified tenor.

These are synthetic bonds that cannot be opened from the curve.

5.20 Specifying Colombian Bonds

5.20.1 Pr ic ing
The Colombian bonds described below use PricerBondColombian to handle the various rate conversions and
rounding requirements.

 Refer to the Calypso Bond Analytics Guide for details.
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5.20.2 Exponent ia l Interest Cashf low
Some Colombian bonds require that the interest cashflow be based on an exponential formula. This is specified on the
Coupon panel.

5.20.3 Loca l Corporate Bonds
Colombian non-government floating rate securities linked to the DTF, IBR, or IPC indices have various characteristics
relating to the use of nominal and effective rates when issuing securities.

Current Coupon and Effective Spread
The Current Coupon and Effective Spread fields on the bond definition Coupon panel are only used by specific
Colombian bonds.

• Current Coupon – Only used by Colombian DTF and IBR-linked bonds, where from the settlement date to the next
coupon date, the cashflows are calculated using either the "previous" rate or "current" rate.

– Previous rate: Rate valid on coupon start date.

– Current rate: Rate calculated using latest DTF rate on valuation date.

Whether "previous" or "current" rate is used is determined at the time of issuance for a given bond. For future
coupons, the "current" rate is always used.

• Effective Spread – Only used by Colombian DTF-linked bonds, where both the DTF rate and the spread are
quoted in effective terms, however, the coupon rate must be in nominal terms.

Check "Effective Spread" to convert from an effective rate to a nominal rate.

Yield Method
Colombian local corporate bonds linked to the DTF, IBR, and IPC indices use the Exp_ACT365 yield method.
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Rate Index Attributes
The following Rate Index Attributes are required to specify the Index Type and Index Convention.

5.20.4 Bonos Pensiona les
Colombian pension bonds, or Bonos Pensionales, are linked to the IPC inflation index.

IPC_RATE Index
The IPC_RATE index is used to store the percentage change of IPC_INDEX in the quotes.

The IPC_RATE rate index should be configured as a regular index as shown with Quote Type = Yield.

The IPC_RATE is applicable for one month rather than a year. This rate represents a month-on-month inflation rate.
The quotes are published daily by the price vendor. This quote is saved daily in the quote set. The quote will be
updated on the 5th of every month (or previous business day if the 5th is a holiday), so the quote will be same for the
rest of the month.
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IPC_INDEX Index
The IPC_INDEX rate index should be configured as a regular monthly inflation type rate index as shown with Quote
Type = Price and Calc Mtd = Interpolated.

The monthly IPC_INDEX quotes store the monthly Colombia CPI quotes.

Rate rounding will be used while calculating the IPC_INDEX from the IPC_RATE. By default it is 5 for inflation rate
index.
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Index Calculator
Bonos Pensionales use the InflationIndexIPC index calculator to forecast by projecting the IPC rates with known IPC
values.

InflationLevelCalculator Scheduled Task
The scheduled task InflationLevelCalculator should be run daily. When a new IPC_RATE quote is published, the new
quote will be used to convert the IPC Real to IPC_INDEX.

Refer to Calypso Scheduled Tasks documentation for details.

Yield Method
Bonos Pensionales use the Exp_NL365 yield method.
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5.20.5 UVR Bond Forwards
Only one specific type of Colombian UVR bond forward is supported in Calypso, where the bond currency is UVR and
the redemption currency and coupon currency are COP. The bond forward settlement currency can never be UVR.
This type of cross currency bond is only supported for UVR bond forwards; cross currency bonds are otherwise not
supported for bond forwards.

The UVR to COP FX forward rate is calculated using an FX curve. On the exercise date, the UVR to COP conversion is
done using that date's spot price between UVR and COP. No FX reset is needed. Upon exercise, the known date is set
to the fixing date.

Pricer
Unlike Colombian bond trades which use PricerBondColombian, Colombian UVR bond forward trades use
PricerBondForward.

In the bond definition Bond panel, set the UVR product code to TRUE so PricerBondForward can identify the bond as a
UVR bond forward.

 Refer to the Calypso Bond Analytics Guide for details on bond forward pricing calculations.

Trade Capture
Bond forward trades can be captured using the Bond Forward Trade window.

See Capturing Bond Forward Trades for details.

5.21 Specifying Convert ible Bonds
You can select the Convertible panel, provided the bond class is BondConvertible.

Select the Convertible panel to define the convertible features, and the Conversion Schedule panel to define the
conversion schedule.

You can enter the price in monetary units in trade screens for convertible bonds quoted in Price.

5.21 .1 Convert ib le Panel
» Enter the Convertible Details. The fields are described below.
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» Click Add to add a conversion price reset row. Then enter the fields as applicable. The fields are described below.

Convertible Details

Fields Description
Target Product Click ... to select the target equity. The bond will be converted to the selected equity.

Target Code Select the target code from the Target Code field.

Issue Strike Enter the equity price on conversion date.

Start Enter the start date of the conversion process.

End Enter the end date of the conversion process.

Conversion Price Reset Schedule

Fields Description
Type Choose between DOWN or UP to define the type of option.

Date Enter the option date.

Cap Enter the cap value (for a DOWN option).

Floor Enter the floor value (for an UP option).

Multiplier Enter the multiplier (bond / equity) that will apply if the cap or the floor is reached. It will
override the multiplier specified in the Conversion Schedule panel.

Price Set? Check the “Price Set?” checkbox if the option is exercised. In that case, enter the new equity
price in the Historical Price field.

Historical Price Enter the new equity price if the option is exercised.

5.21 .2 Convers ion Schedule Panel
The Effective Call and Redemption Type fields do not apply to convertible bonds.

» Click to generate the schedule. It brings up the Schedule Settings dialog.
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Enter the fields as needed and click Generate. The fields of the conversion schedule are described below.

» You can also click to add a conversion row based on the information specified in the Convertible panel. The
fields are described below.

Fields Description
Redemption Date Enter the effective conversion date.

Option Type Select the option type.

Percentage Enter the percentage of securities that is converted.

Type Select mandatory or optional. If mandatory, this means that the conversion will definitely
occur and that the bond will no longer exist after the effective conversion date.

There is no processing based on that field. It is for information purposes only.

Settlement Select the type of exercise: Physical.

 Ⓘ [NOTE: Cash settlement is not currently supported]

Price Enter the exercise price.

Bond Unit Enter the unit of bond that will be converted.

Target Unit Enter the unit of equity after the conversion.

Exercised? Select Yes or No to indicate if the conversion has been exercised (Yes/No).

The system generates the Convertible Corporate Action only if it is flagged as "Exercised".

At Maturity, the system does not generate the REDEMPTION Corporate Action if it is flagged
as "Exercised".

5.22 Specifying Credit Linked Notes
A Credit Linked Note (CNL) is a debt instrument bundled with an imbedded credit derivative. In exchange for a higher
yield on the note, investors accept exposure to a specified credit event. For example, a note might provide for
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principal repayment to be reduced below par in the event that a reference asset defaults prior to the maturity of the
note.

A Credit Linked Note is a bond whose coupon and principal payments depend on a credit event. Unlike a corporate
bond, where the credit event is on the issuer, a CLN can have a credit event in any reference name.

In a simple case, an investor will buy a CLN (Reference name Ford) from an Issuer (Citigroup) and receive a coupon of
Libor + x. He will lose the remaining coupons and the principal amount if there is a credit event on Ford or Citigroup.
With Risk Aggregation, the exposure is reported as the exposure for the CDS, not the issuer of CLN.

5.22.1 Types of CLN
• Principal-protected notes – The principal is guaranteed by the issuer. The coupons are risky and they disappear if

there is a default on a reference credit.

• Boosted coupon notes – The coupons are guaranteed by the issuer, but the principal payment is linked to the
default event of a reference credit.

• Reduced coupon notes – Principal repayment is the face amount. If the reference credit event occurs, the
termination payment is enhanced by the loss in the event of default of a reference asset.

• Credit Sensitive notes – The coupon changes with the credit rating of the reference entity. If the reference entity
is downgraded, the coupon steps up. If the credit goes below a certain level, the investor can put the bond to the
issuer.

• Index Linked notes – The coupon and redemption is linked to an index. As an example, the coupon can be zero
and the principal can be linked to the level of the iBoxx credit derivative index.

• Counterparty-funded structures or SPV-funded structures.

• Reference Pool – Static or managed.

• Settlement – Cash or physical.

5.22.2 Bond CLN Product
The Bond CLN product is a bond of class BondCLN.

Select the CLN panel and enter the fields described below, then click Save to save the bond.

Fields Description
Reference Entity Type Select the reference entity type: Single Name, Portfolio (Nth Loss), or Portfolio (Nth Default).

A CLN is composed of the following: Risky Bond + CDS (Single Name or Nth Loss Basket) +
Risk Free Bond (Charged asset).

The pricers used are: PricerBondCorporate, PricerCreditDefaultSwap,
PricerNthDefaultBasket and PricerBond to value the individual sub components.

A single name is valued as a Single Name CDS + Risky Bond + Risk Free Bond.

If there are multiple names, these are valued as Nth Loss basket using the same valuation
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Fields Description
model used to value the CDS NthDefault.

Single Name

» Click ... to select the issuer and select the seniority. The issuer’s industry and rating are
displayed.

» In the Credit Events panel, click Select Credit Events to select the credit events to which
the CLN is sensitive.

Portfolio (Nth Loss)

» Click ... to select a basket, or click New to create a new basket. It brings up the
Reference Entity Basket window. Help is available from that window.

In the Loss panel, the Tranche Notional is set to the Total Issued of the bond. Enter the
from and to percentages of the tranche to calculate the size of the basket.

» In the Credit Events panel, click Select Credit Events to select the credit events to which
the CLN is sensitive.

You can also right-click an item of the basket and select Set Credit Events.

Portfolio (Nth Default)
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Fields Description

» Click ... to select a basket, or click New to create a new basket. It brings up the
Reference Entity Basket window. Help is available from that window.

In the Default panel, the Tranche Notional is set to the Total Issued of the bond. Enter
the number of defaults to calculate the size of the basket.

» In the Credit Events panel, click Select Credit Events to select the credit events to which
the CLN is sensitive.

You can also right-click an item and select Set Credit Events.

Protection Type Select the protection type: Coupon Protected, Principal Protected or None.

When credit events are applied, the processing is based on the type of protection.

• For None, the Maturity date of the Bond is set to the Credit Event date. The Payment
Amount is set to the Recovery value specified in the credit event. For example, for a CLN
maturing in June,05 if a credit event happens today with Recovery rate of 40%, the
Maturity date is set to today and the Principal redemptions as 40% * Original Amount.

• For Coupon Protected, the coupons remain the same and reduce the Principal to the
Recovery Amount (same as Termination Amount in CDS).

• For Principal Protected, the coupons are set to 0. The Principal is unaffected.

5.22.3 CLN Trades
It is recommended to capture trades for Credit Linked Notes using a BondCLN product in the Bond Trade window.

5.23 Specifying Danish Mortgage Bonds
Danish mortgage banks publish a range of data for bond investors in order to obtain a more effective pricing of
callable mortgage bonds with focus on debtor’s prepayment behavior in callable bonds, hence for Danish Mortgage
Bonds, you can define a drawing schedule in the system.

Nasdaq Calypso
Fixed Income Trading / Version 18



Negative interest rates on Danish Mortgage Bonds imply that the investor has to pay the issuer interest, however this
is not physically done. Therefore the custodian compensates the issuer for the loss of cash with redemption of the
security. The negative interest redemption is handled through the use of a PINK rate on the drawing schedule, and the
PINK corporate action.

Danish Mortgage Bonds are defined with the bond class BondDanishMortgage, and the bond type "Standard". The
drawing schedule must be defined in the Danish Mortgage panel. The actual drawing is performed using the
Corporate Action process.

» Click to add an entry to the drawing schedule – You can add as many entries as needed.

For the first entry:

• PCAL Amount = PCAL Rate * Issue Amount

• PINK Amount = PINK Rate * Issue Amount

• Remaining Amount = Issue Amount - PCAL Amount - PINK Amount

Subsequent entries are computed based on the previous entry's Remaining Amount, rather than the Issue Amount.

The PCAL drawing rate creates CA products of type REDEMPTION.DRAWING.

The PINK rate allows a redemption of principal without a cash payment to offset the value of negative coupon
payments, if any. It creates CA products of type REDEMPTION.PINK.

5.23.1 Legacy Danish Bonds
When saving the bond, you are prompted to create a drawn bond automatically or not (bond with bond class
BondDanishMortgage and sub-type "Drawn").

• If you choose Yes, the Drawn Bond Id will be automatically populated in the drawing schedule.

• If you choose No, you can manually update the drawn bond Id.

The cashflow schedule is then updated with the information of the drawing.

You can also use the scheduled task BOND_DRAWING to generate the Drawn Bonds on drawing date, prior to
generating the corporate actions.

The Drawn Bond is created with the same characteristics as the master bond.
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The following security codes are set:

• ISIN: Same as master bond (provided it is not defined as "Unique")

• FromBondProduct: Id of master bond

• DMB Serie: Maturity date

Additional security codes can be propagated to the Drawn Bond provided they are not defined as "Unique" – They
have to be added to domain BondDanishMortgage.SecCodes.

A Drawn Bond is created for each entry in the drawing schedule

On the Drawn Bond, the Danish Mortgage panel provides information about the master bond.

At drawing date, the position on the master bond is amortized by the prepaid amount, and a drawn position is
generated on the Drawn bond. Both bonds can be traded.

5.23.2 TARGET2 Compl iant Danish Bonds
In order to enable this feature, set the environment property UseNewDMBRedemption=true.

There is no creation of a "drawn" bond.

In this case, two corporate actions are generated for Danish Mortgage Bonds on the same payment date:
REDEMPTION/DRAWING in order to amortize the bond by the drawn amount, and CASH/INTEREST in order to
generate the coupon amount.

The corporate actions should be applied by payment date so that they can be created together.

The Record Days on the bond should be set to 1, so that on the CA the Record Date is one day before the Payment
date.
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5.24 Specifying Floating Rate Notes

5.24.1 Pr inc ip les
• Some floating rate bonds, indexed on a particular floating rate, may pay interest coupons at different periods than

the reset frequency they are referring to calculate full coupon. The reset frequency can be greater than the
payment frequency, allowing the system to calculate the full coupon based on the different reset rates.

• Also, the payment of the coupon can be more frequent than the rate at which it has been calculated. In that case,
the payment cashflows will refer to the same rate.

• All these reset and payment frequencies will be defined in the coupon panel of the bond product and used by the
system to generate the appropriate cashflow schedule.

Note that the cashflow schedule will display only payment flows. If one coupon payment is composed of several
resets, a utility tool “Interest History” has been set up to show the internal periods used to calculate the coupon.

• The internal periods are not customizable, resulting from the frequency method configured in the coupon
definition. Only the payment periods can be modified in the cashflow schedule, updating consequently the
internal periods.

• Lastly, in the option that the reset frequency is greater than the payment frequency, a compounding method can
be applied to the coupon amount calculation.

Floating rate notes can be defined as Bond or BondFRN. BondFRN should be reserved for actual FRNs (short term
floating rate notes) and not for all floating rate bonds.

5.24.2 Coupon Panel
In the Coupon panel, select Floating Rate, and configure the following.

» The compound frequency specifies the frequency of reset. By default, field is the same as the payment
frequency.

» The method is the Interest calculation method:

– NoCmp means that the coupon amount to be paid is the sum of the individual reset interest amounts.

– Flat means that the reset interest amounts will compound to calculate the coupon to be paid. Note that this
method is not used when the payment frequency is greater than the reset frequency.

5.24.3 CashFlows Panel
In the CashFlows panel, generate the cashflows.

You can see the details of an interest cashflow by choosing “Interest History” from the Cash Flow menu. This will
display the individual periods with the respective reset rates based on the dates configured in the floating rates
definition of the Coupon panel.

The columns are described below.
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Columns Description
Start Date Starting date of the reset period. If it is the first reset period of the cashflow, this date is the

same as the Pmt Begin date.

End Date Ending date of the reset period.

Days Number of days included in the reset period.

Period Ratio of number of days in the reset period by the daycount.

Rate Rate used for interest calculation, populated into the quote.

Accrual Total amount of accruals for that period.

Total Sum of the accruals. Equal to the Accrual for the first period and then cumulated for the next
periods.

Reset Date Date at which the rate is selected. Date initialized according to the set up of the floating rate
definition in the coupon panel.

Base Interest Is the accrual interest amount.

Compound Interest Show only the compounded interest on that period.

Field that remains blank when the method = NoComp.

5.24.4 DISC_MARGIN Pr icer Measure
DISC_MARGIN calculates the discount margin of a floating rate bond, which is the spread added to current rates to
equal the bond yield. Ref: Stigum and Robinson, “Money Market and Bond Calculations” (1996), Ch. 17. For the
average rate needed for that formula, the Calypso implementation uses the index rate as of the valuation date.

5.24.5 FRN Pr ic ing
The following algorithms can be used to price FRN bonds:

• PricerBondGeneric – Standard bond pricing. When solving for the dirty price from a yield to maturity, all future
coupons are taken into account.

• PricerBondFRN – When solving for the dirty price from a yield to maturity, we assume that the bond matures on
the next coupon date when computing the dirty price from the yield.

• PricerBondFRNMargin – It handles PV01 calculation based on discount margin instead of yield. So PV01 is
essentially an analysis in the effect of a one basis point shift in the discount margin.

This affects PV01 only when the pricing parameter BOND_FROM_QUOTE is set to true, also the pricing parameter
FORECAST_FROM_CURVE must be set to false.

Note that you also need to make sure that the Compound Frequency is set on the reference index, even if it is set
to NON because by default it is not set.

• PricerBondFRNAUD – Pricing for BondFRN product with sub-type AUDFRN. It uses the AFMA formula to calculate
the dirty price, given a cash rate, swap rate, and a trading margin.
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Note that the sub-type must be set to AUDFRN in order for the trading margin quotes ("<bond quote name>.TM")
to be saved.

CASH_RATE_01 pricer measure is available for FRN AUD Bonds (BondAUDFRN / PricerBondFRNAUD) for reporting to
represent the Cash_Rate sensitivity. The SWAP_RATE and CASH_RATE are derived from the forecast curve and not
the discount curve.

CASH_RATE_01 is the sensitivity to a 1 bp increase of the CASH_RATE.

CASH_RATE_01 = PV_AFMA (〖Cash_Rate〗+1bp)-PV_AFMA (〖Cash_Rate〗)

5.25 Specifying Inf lat ion Bonds
Follow the steps below to define inflation bonds.

5.25.1 Creat ion of the Rate Index
Make sure that the CPI value (or RPI, TIPS, etc.) is available in the rate_index domain.

Then specify the CPI rate index (or RPI rate index, etc.) using Configuration > Interest Rates > Rate Index Definitions.

» Enter the fields described below.

– Set the index type to Inflation.

– Set the quote type to Price.

– Select a publication frequency, enter a reference day and a publication lag.

The reference day is the day of the month when the inflation is effective, and the publication lag is the time
lag between the effective date of an inflation level and its actual publication.

You can click Publications and generate the dates to make any modification if needed. Otherwise the
reference day and publication lag are used to determine the publication dates.

 Ⓘ [NOTE: The system does not support end-of-month reference days 29, 30, and 31. This restriction also
pertains to the Publications Dates window when modifying the Reference Date fields]

– Click Attributes, and set the IndexCalculator to InflationIndex.

If the IndexCalculator attribute does not appear, click ... to add it.

» Save.

» Select the Tenors panel and add tenors as needed. Then save the rate index.

You can click Rebase in the Rate Index Definition window to rebase the index level as needed.
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» Enter an effective date and a rebase factor in percentage, then click Add.

» Click Save.

5.25.2 Creat ion of the Inf lat ion Bond
You can create a bond sub-type IndexedInflation in the Bond.subtype domain as applicable. This is optional.

For RPI indexed bonds, select the Gilt sub-type.

Select the Market panel.

» For English (issued in or after July 2005), French, American, and South African inflation bonds, the quote type
must be defined as CleanPrice. For English indexed bonds issued before July 2005, the quote type must be
defined as GrossPrice.

Select the Special panel.

» Check the “Notional Indexed” checkbox.

» Select a reference index from the Index field. Only reference indices of type Inflation can be selected.

» Check the “Guaranteed Notional” checkbox to indicate that the notional redemption is guaranteed at maturity.

» Select an Inflation Floor option as needed:

– NONE: Default.

– Guaranteed Principal: Inflation indexation on final principal payment is floored.

– Guaranteed Principal and Coupons: Inflation indexation on all coupon payments, and final principal payment
is floored.

» Enter the index date in the “Index date” field.

» Enter the rate index value on the issue date in the "Idx Value" field.
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» Enter a number of decimal places in the "Rounding" field and select the rounding method from the adjacent field.
If you do not set these values, the default behavior is to round NEAREST to 5 decimals.

» Check the "Round Gross Price Before Adjustment" checkbox as applicable. This will round the prices before the
inflation adjustment and not after.

Peruvian inflation bonds generally use this convention.

5.25.3 Rounding the Corporate Act ions
To specify rounding on the associated corporate actions, follow the steps below.

» Add the value “ROUND_CA_AMOUNT” to the rateIndexAttributes and domainName domains.

» Add the values “true” and “false” to the ROUND_CA_AMOUNT domain.

» In the rate index defaults, click Attributes and set the ROUND_CA_AMOUNT attribute to True.

» In the Coupon panel of the Bond product, set the Coupon Digits field to the number of decimal places that you
want.

5.25.4 Index Overr ide Panel
You can customize index values on an inflation bond. Fields will default to values set in Rate Index Defaults for the
selected index.

Select the Special panel in the Bond Product Definition window.

» Click the "Override Index Attribute" checkbox to activate the feature.

Fields Description

Index Lag Reset lag for the index, Select a numerical value along with day, month, etc. from a drop down menu.

Calc
Method

Indexlevel – Create a single rate index and save quotes.

or

Interpolated – Create a single forecast curve for obtaining inflations prices to calculate bond payouts
based on a product definition.

Interp 'Weighted'.
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Fields Description

Method

5.25.5 Pr ic ing
TIPS should use PricerBondUST. Set USE_REAL_YIELD in the pricing parameter set if you would like to use
PricerBondGeneric for valuation. Otherwise, defaults to False.

5.26 Specifying Islamic Bonds
Islamic bonds are identified with the following security codes:

• Sukuk=True

• IslamicContract=Musharaka, Mudaraba, or Ijara.

You need to add <calypso home>/client/resources/samples/dbscripts/SchemaData_islamic.xml to
ExecuteSQL in order to populate Islamic static data.

The only difference from standard bonds is the corporate action process, where INTEREST corporate actions are
replaced with DISTRIBUTION corporate actions.

5.27 Specifying Lottery Winner Redemptions
Select the Call Schedule – Lottery Winner Redemptions panel to specify lottery redemptions for bonds redeemed by
lottery.

There is no processing based on these redemptions. This is for information purposes only.

The Effective Call and Redemption Type fields do not apply to lottery redemptions.

» Click to add a redemption row. Enter the notional that will be redeemed and the redemption price.
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5.28 Specifying Mexican CETES Bonds
Mexican CETES (Mexican Government T-bills) can be captured as BondMMDiscount with the Quote Type “Yield”, and
the Yield Method “MXN”.

BondMMDiscount and BondMMInterest use the pricing parameter MMKT_FROM_QUOTE.

The pricer measure YIELD_BEY uses the Stigum formula.
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5.28.1 Zero Coupon Risky Bond
To address the case when Principal Recovery must be considered in the PRICE calculations (when INCL_RECOVERY_
PRINCIPAL is true) and there have been no Coupon flows (and hence no prior principal recovery adjustments), in this
case the final Principal payment is adjusted for the Recovery amount. The Recovery Amount is included in the 'Credit
Principal' Column of the Last Principal flow, the 'Probable PV' Column and the 'PRICE' pricer measure reflects this
adjustment.

Setup
• Product Code – Create product code IS_RISKY of type "string". On the bond level the value of this code must be

set to "YES".

Nasdaq Calypso
Fixed Income Trading / Version 18



• Pricer Configuration – Select the Model Parameters panel. For PricerBondGeneric add Pricing Param Name: INCL_
RECOVERY_PRINCIPAL to true.

• Probability Curve – Create the probability curve and add it in the Credit panel of the Pricer Configuration window.

5.29 Specifying Moroccan Bonds
The Moroccan bond market is one of the most important components of the Moroccan financial market. Support for
Moroccan Bonds (new yield method and day count logic) is provided impacting yield method computations for the
Moroccan bonds when configured with Yield method = 'Moroccan'.

5.29.1 Day Count
Created a new Day Count that is to be used with bonds with maturity longer than one year.

l Name: Moroccan/ACTB

This day count will not appear in the daycount drop-down field in the bond definition, but it is embedded in the pricer
pricerBondMoroccan.

First Cash-Flow is First Long Coupon Period
A = Stub Start – virtual regular start date

M= Stub Start – Dated Date

Coupon=Notional*period interest*(Stub Start-Dated Date)/A

Accrual=Notional*period interest*(Settle Date-Dated Date)/A

Subsequent Cash-Flows
All subsequent cash-flows are generated based on a Day Count fraction like ACTB/ACTB.

5.29.2 Yie ld Method
Uses the new daycount Moroccan/ACTB.

Notation
y = Yield to maturity

A = Stub Start - virtual regular start date
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Maturity > 364 Days
If the time to maturity (maturity date – spot date) is <= 364, the Moroccan yield uses the following discount formula:

1/(1+y*(maturity date – spot date)/360)

If the spot date is in a First Long coupon period, the Moroccan yield uses the following discount formula:

1/(1+y)^((Spot Date-Dated Date)/A +i-1)

i >= 1. Here, i represents the number of periods.

5.29.3 Conf igurat ion
l Configure your bond using ACTB/ACTB as the default daycount, the pricer overrides the default daycoount
l Use the new yield method Moroccan
l Quote type: yield
l Only supports pricing from quotes.
l Must use the pricer BondMoroccan

5.30 Specifying Payment-In-Kind Bonds
Payment-in-kind bonds pay a predetermined coupon rate as of a predetermined date: Full coupon rate - PIK rate, i.e a
predetermined portion of the payment is capitalized back to the principal. Specific rules in the bond definition will
outline how the rates are repaid. The PIK start date and rate can be entered on the Special panel of the bond window.

The PIK definition can be added to any payment schedule.

5.30.1 P IK Bond Example
PIK dates and rates are tied to a predefined bond, so the definition of the bond product will be necessary.

1. Set up the bond in the bond window.
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2. Set up the bond coupon rate.

3. Navigate to the Special panel.
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In the Special panel of the bond window:

» Specify payment-in-kind by checking the "Payment-In-Kind" checkbox.

» You can specify a single payment-in-kind date and rate, or you can specify a PIK schedule.

– For a single PIK date and rate, select NO_SCHEDULE from the drop down and specify the PIK date and rate
in the adjacent fields.

Example: Of the specified 4% bond coupon rate, 1% will be capitalized to the principal beginning 4/12/2012, paying on a
bullet schedule.

– For a PIK schedule, select PIK_SCHEDULE from the drop down and click ... to define a PIK schedule.

The PIK schedule is based on the coupon dates, and the generated dates cannot be edited. Enter a PIK rate
for each period.

» Save.

In the CashFlows panel of the bond definition window, generate cashflows and set the columns to display PIK
capitalization rate, capitalization factor, etc. by right-clicking on the flows data and selecting Configure Columns. A
window will be displayed and allow customize of data to view.

The Capitalization rate and factor can be viewed against existing cashflow data.
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5.30.2 Payment- In-K ind Account ing Events

Accounting Event Description

ACCRUAL_BS The component of the bought interest related to cash interest, i.e. coupon rate on the bond
less any PIK interest.

ACCRUAL_BS_PIK The bought interest that is related to the PIK interest.

ACCRUAL_PIK Represents accrual of PIK interest.

ACCRUAL_REAL_PIK For use in buy/sell trading in a PIK security. Liquidation results from accrued interest being
realized.

ACCRUAL_INC_
REAL_PIK

Coupon payment occurrence for an non-liquidated security.

5.31 Specifying Re-Issue Bonds
From time to time, securities may be re-issued. This is normal in the case of Treasury Bills, where the 12-month issue
is usually re-issued when it is getting close to 6 months to maturity – the re-issue will be for a 6-month T-bill. T-bills
are often re-issued again when they are 3 months to maturity. Coupon securities can also be re-issued at one or more
points during their life.
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When a security is re-issued, the re-issue is traded as a separate security (having all the same attributes as the
original security, but with a separate CUSIP) during the period from the re-issue announcement up to the date when
the "regular" settlement date for the original security is the same as the re-issue date. At that time, the two securities
are merged, and all trades in the re-issued security are modified to specify the original security.

 Ⓘ [NOTE: Currently, Calypso assumes that this merge (often referred to as "assimilation") will take place at
start of the business day PRIOR to the re-issue security's Issue date]

The characteristics of the re-issuance security are always identical to the original security, except for the issue date
(and dated date) and CUSIP.

First, here is a typical configuration for a 12 month Tbill.
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Suppose that this security is to be re-issued on 12/07/09. A NEW security must be created for the re-issuance.

Here is the setup for the re-issuance security:
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Note the new CUSIP.

» Set the Issue Date and Dated Date to re-issuance date.

In the Market panel, set the Announce Date to the re-issuance announcement date.
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In the Special, panel, set the Assimilation Date to the re-issuance date.

 Ⓘ [NOTE: The assimilation will actually take place at start of business ONE DAY PRIOR to the specified
Assimilation Date]
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» Select the security into which this re-issuance security will eventually be merged from the Assimilation Prd field.

Upon saving, the re-issuance security will have the value ‘Re-Issue’ in the Product Code field "When-Issued".

5.32 Specifying Revolver Bonds
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5.32.1 Bond Panel
» The face value and total issue amount are set to 0. The drawns will generate cash transfers.

5.32.2 Revolver Panel
Select the Revolver panel to define the drawns.

» Enter the maximum principal amount, investor’s commitment amount (trade amount), and fee rate.

» Then click Add to add a drawn row: date, drawn amount, and rate.

The rate on each drawn is the rate used to calculate the interest on the drawn amount. The bonds’s coupon rate
is only used when there is no drawn during a coupon period.

The drawns generate cash transfers through corporate actions. Note that the environment property USE_NEW_CA_
LOGIC should be set to true. The corporate actions are automatically generated from revolver characteristics using
the Generate panel in the Corporate Action window. Then they must be applied to the positions from the Apply panel.
Note that two corporate action (CA) trades will be created: a CA trade between the book and the processing org to
update the PL, and a CA trade between the book and the agent (nostro/custodian) to reflect the cashflows.

 Ⓘ [NOTE: You need settlements instructions for the agent – The following engines need to be running:
Transfer engine, Inventory engine, and Liquidation engine. You can check engine status from the Engine
Manager of Web Admin: event subscription and engine parameters. Refer to Calypso Web Admin
documentation for complete details]

5.32.3 Pr icer Measures
The following pricer measures are specific to revolver bonds:

• ACCRUAL_DRAWN – The value of the drawn part of the coupon on val date.

• ACCRUAL_UNDRAWN – The value of the undrawn part of the coupon on val date.
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• FACILITY_AMOUNT – Investor’s capital commitment (must be added using Configuration > System > Add Pricer
Measure with the class tk.pricer.PricerMeasureBondRevolver).

• DRAWN_AMOUNT – Total drawn amount available at value date (must be added using Configuration > System >
Add Pricer Measure with the class tk.pricer.PricerMeasureBondRevolver).

• UNDRAWN_AMOUNT – Total undrawn amount available at value date (must be added using Configuration >
System > Add Pricer Measure with the class tk.pricer.PricerMeasureBondRevolver).

Also, the following pricer measures are calculated differently for revolver bonds:

• ACCRUAL_FIRST = ACCRUAL_DRAWN + ACCRUAL_UNDRAWN (with or without an additional day based on
pricing parameter ACCRUAL_FIRST)

• ACCRUAL = ACCRUAL_DRAWN + ACCRUAL_UNDRAWN

The following pricing parameters must be set to true: BOND_FROM_QUOTE and BV_ALTERNATE.

5.33 Specifying Risky Bonds
Risky bonds are usually any corporate bonds set up as a benchmark over a reference bond, and quoted in spread. You
can price risky bonds off credit curves. The default probability implied by the CDS spreads is taken into account for
this.

In the Bond panel, click Codes and select the bond’s seniority in the DebtSeniority code.

In the Market panel, set up the bond as a benchmark over another bond.
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When capturing a trade on this bond, the probability curve for the bond’s issuer will be loaded from the pricing
environment if any.

The following pricer measures can be computed for a risky bond:

• Z_SPREAD – The static spread over the Zero curve which makes the Theoretical Price equal to the Market Price
(Price from Quotes). In the above example, if 117.515 bp are added to the Zero curve, the Theoretical price
100.59306 will become 98.027.

• PV01_CREDIT – The spread sensitivity. The spread is increased by 1bp and the change in NPV is calculated.

If BOND_FROM_QUOTE = Yes. The spread quote is bumped by 1bp, and the difference in NPV is the PV01_
CREDIT.

If BOND_FROM_QUOTE = No. The discount curve is shifted 1bp and the difference in NPV is the PV01_CREDIT.

For a fixed rate bond, the PV01 will be the same as PV01_CREDIT. For a floating rate bond, the PV01 will be close
to 0 (no interest rate sensitivity for a FRN).

• Theoretical Price – The Price using the curve.

• Notional Equivalent – This is defined as Notional * Modified Duration / Modified Duration (Benchmark). The
modified duration of benchmark is set up using the Global Parameters.

• Default Exposure – This is relevant for Risky Bonds (Corporate Bonds) and CDS. It measures the amount of money
we lose in case of default. A positive number indicates a Loss and a negative number indicates a profit. The
definition of Default Exposure is for Bonds: NPV (Market Value), and for CDS: NPV (Market Value) + Notional.

• CDS_SPREAD – This used to calculate the CDS level if the Bond is to be hedged with a CDS. If the bond uses a
probability curve generated from CDS spreads, it calculates the break-even spread for the (hypothetical) CDS
underlying the curve with the same maturity date as the bond. The CDS is priced using the probability curve in the
PricerConfig associated with that CDS, which is usually (but not forced to be) the same as the probability curve of
this bond.

5.34 Specifying Russian Bonds
Russian bonds use specific rounding rules for calculating accrued interest. Two methods, "Pro-Rata" and "MICEX", are
used with PricerBondGeneric to calculate this requirement properly.

The "Pro-Rata" method for calculating is accrued interest is:

1. CPN_Rate/100 * Face_Amt * Factor * Num_Total_Period_Days/365(or 366) = CPN_Amt_Full_Period

2. Round CPN_Amt_Full_Period to 2 decimals to produce RD_CPN_Amt_Full_Period

3. RD_CPN_Amt_Full_Period * Num_Days_Accrual/Num_Days_in_Full_Period = Raw_Accrual

4. Round Raw_Accrual to 2 decimals to produce RD_Accrual

5. RD_Accrual * Quantity = Accrued Interest

6. Round Accrued Interest to 2 decimals to produce the final result.

The "MICEX" method for calculating the accrued interest is:

1. CPN_Rate/100 * Face_Amt * Factor * Num_Days_Accrual /365(or 366) = Raw_Accrual

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 112 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 113 / 250

2. Round Raw_Accrual to 2 decimals to produce RD_Accrual

3. RD_Accrual * Quantity = Accrued Interest

4. Round Accrued Interest to 2 decimals to produce the final result.

Either method is set on the bond product using the security code "ComputeCouponPerQty". When the sec code is set
to false or left blank, the special coupon per face rounding for Russian bonds will not be applied to the coupon amount
of the accrued interest.

For correct calculation with the appropriate rounding and precision, set the Coupon Rate Decimals to 2 and NEAREST
on the Market panel of the bond product. Accrual digits should be set to 2 more than the number of digits in the total
issued amount of the bond or any lager number.

Sample Russian Bond definition
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» Select 'Bond' for the Bond Class.

» Select 'Generic' for the Bond Type.

» Select 'ComputeCouponPerQty' in the Code drop down.

» Enter 'Pro-Rata' or 'MICEX' for the Code value OR

Click the Code... button and enter the value for 'ComputeCouponPerQty' in the Code Window, then click Apply.

Russian Inflation Bond Accrued Interest
PricerBondRussian is used for Russian inflation bonds. It has a specific calculation method for accrued interest.

 Refer to the Calypso Bond Analytics Guide for details.

5.35 Specifying Taiwanese Bonds
Some Taiwanese TCB bills are set to mature on non-business days, in which case the principal payment rolls forward
to the next business day. These bills must be priced using the principal payment date, not the maturity date. A
dedicated pricer and security code allow for this calculation.

Taiwanese money market bond trades can be captured using the Bond (Custom) Trade window.

See Capturing Taiwanese Money Market Bond Trades for details.

5.35.1 Secur i ty Codes
In the bond definition Bond panel, you can set several product codes that are specific to Taiwanese bonds.

BOND_CATEGORY
Set the BOND_CATEGORY product code to "TCB" to identify the bond as a TCB bond.

Issue Price Base
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You can specify a different base to use for Issue Price and Redemption Price using the product code "Issue Price
Base". If left blank, the default is base 100.

Example: Taiwanese bills are entered in base 10,000.

TAIWAN
You can set the product code TAIWAN to true to enable the "Dirty Price (<base>)" field in the Bond (Custom) Trade
window.

The "Dirty Price (<base>)" field displays the Dirty Price in the base specified in the Issue Price Base product code.

Example: If Issue Price Base = 10,000, the field will display "Dirty Price (10K)". If Issue Price Base = 100,000, the field will
display "Dirty Price (100K)".

Disabling Round-trip Pricing
For Taiwanese bonds, if desired, you can set the product code DisableRoundtripPricing to TRUE to disable the Dirty
Price field and prevent round-trip pricing.

 Ⓘ [NOTE: DisableRoundtripPricing was designed for the Taiwanese market and it is not recommended for use
on other bonds]

5.35.2 Pr icer
Ensure that the pricer PricerBondTCB is used for TCB bonds. When the maturity date falls on a non-business date, the
principal payment date will be considered when doing the day difference. As a result, price to yield or discount, or
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yield to discount or price will change accordingly.

5.35.3 Pr icer Measures
The pricer measures DIRTY_PRICE_SCALED and TRADE_DIRTY_PRICE_SCALED allow displaying these prices in a
different base as they are controlled by the Issue Price Base product code.

See " Issue Price Base" above for details.

Pricer
Measures

Description

DIRTY_
PRICE_
SCALED

Class tk.pricer.calculators.PricerMeasureBond.

Per local market practice, the face value for a TWN bill should set up with 100,000, while the price
base for the same bill should be in 10,000.

The base is controlled by the Issue Price Base product code. If Issue Price Base = 10,000, then:

DIRTY_PRICE_SCALED = DIRTY_PRICE * 100

TRADE_
DIRTY_
PRICE_
SCALED

Class tk.pricer.calculators.PricerMeasureBond.

Per local market practice, the face value for a TWN bill should set up with 100,000, while the price
base for the same bill should be in 10,000.

The base is controlled by the Issue Price Base product code.

While DIRTY_PRICE_SCALED is the market price, i.e. the market quote on valuation date, TRADE_
DIRTY_PRICE_SCALED is the price of the original trade, i.e. what you paid for the bond. It does not
change over time.

5.35.4 Matur i ty Rol l
The "Maturity Roll" flag allows specifying which date is used to calculate the price. When checked, the maturity
principal payment Pmt Dt is used to calculate the price. If not checked, the maturity principal payment Pmt End is used
to calculate the price.
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5.35.5 Withhold ing Tax
 See Withholding Tax Generation.

5.36 Specifying US Treasury Float ing Rate Notes
United States Treasury floating rate notes (UST FRNs) are issued for a term of two years and pay varying amounts of
interest quarterly until maturity. Interest payments rise and fall based on discount rates in auctions of 13-week
Treasury bills.
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5.36.1 Rate Index Def in i t ion

 Ⓘ [NOTE: No index calculator is needed]

5.36.2 Quotes
Quotes are published weekly on Mondays, effective the following business day. The quote published on Monday must
be populated on the next business day through the following Monday.

In the example below, the quote of 0.1100305950 published on Monday, May 4 is populated in Calypso from Tuesday,
May 5 through Monday, May 11.
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5.36.3 Coupon Panel
Select the Coupon panel.

» Set Reset Days to 0 if the quotes published on Mondays are entered on Tuesdays (as described above), or set to
1 if the quotes published on Mondays are entered on Mondays (the same day). In the latter case, setting Reset
Days = 1 tells the system to pick the observed index value one day before for any given day.

» Check the "Reset In Arrear" checkbox as the final coupon rate for the period is not known in advance.

» Check the "Average Resets" checkbox and specify the reset sampling frequency details as shown above.
Averaging and compounding cannot be used together on UST FRNs.

» In the Cut-Off Lag field, enter the number of lockout days.

5.36.4 Market Panel
Select the Market panel.

Nasdaq Calypso
Fixed Income Trading / Version 18



» Configure the Daily Interest rounding rule as shown above. The rounding is applied to each calendar day. Note
that the samples table will continue to show aggregated numbers on non-business days but the rounding will be
applied to each calendar day behind the scenes.

5.36.5 Specia l Panel
The Floor feature is not supported on UST FRNs.

5.36.6 Pr ic ing
These bonds have a specific pricer, PricerBondUSTFRN, which supports the lockout and reopening functionality. All
price and accrual calculations are based on the valuation date.

The pricing parameter FORECAST_FROM_CURVE must be set to false.

Added flooring functionality to UST FRN Bonds to floor the negative rates and extended the support to cash flow
interest calculation.

5.37 Specifying When-Issue Bonds
The lifecycle of every Treasury coupon security begins with the announcement of the security (announcement date),
the subsequent auction of the security (auction date), and the subsequent issuance of the security (issue date).
During the period between the announcement date and the auction date, Treasury Coupon securities are considered
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to be in ‘when-issued’ (WI) status. At that time, no coupon rate is defined for the security and the Yield to Price
calculation will be done using an "expected coupon rate".

You need to add “When-Issued” to the available product codes as a string using Configuration > Product > Code.

You can create Bond products as well as BondMMInterest products that you will trade as WI.

The system will recognize that the Bond is WI if the issue date is after the Announce Date and the Auction Date. Note
that the Auction Date must be before the current date.

In the Coupon panel, leave the Coupon rate field empty as shown below.

Select the Market panel, and set the following information:

» Enter the Announce Date and the Auction date as shown below.

» Specify "Quote Type" as Yield.

» Check the "When Issue Bond" checkbox.

When you save the Bond, the system automatically set the product code "When-Issued" = "When-Issued".

Upon saving, the system also creates the Bond name with "When-Issued" attached to it, and creates a special quote
for the Expected Coupon rate. This quote should be entered for each date from the Announcement Date up to (and
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including) the Auction date, or this can be propagated automatically each day using the PROP_RATE_1BUSDAY
scheduled task.

See Capturing When-Issue Bond Trades for details.
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6. Withholding Tax Generation
When you set the environment property SEC_WITHHOLDINGTAX=true, the withholding tax will be automatically
withdrawn from the coupons, and reclaim fees will be automatically generated.

The setup is described below.

6.1 Bond Definit ion
Bonds are defined using Configuration > Fixed Income > Bond Product Definition.

In the Bond Definition window, select "Apply Withholding Tax" in the Market panel.

» You can click ... next to the Withholding Tax field to set up the withholding tax rates and reclaim rates per bond's
country (country paying income) and position holder's country (country receiving income). It brings up the
Withholding Tax Config window.

The Withholding Tax Config window can also be accessed from Configuration > Fees, Haircuts, & Margin Calls >
Withholding Tax Config.

See Withholding Tax Rates Configuration for details.

6.2 Tax Authority Setup
You need to define a legal entity of role TaxAuthority that will receive the reclaim fee if any.

Nasdaq Calypso
Fixed Income Trading / Version 18



6.3 Processing Org Setup
A processing org could be exempt from paying the withholding tax.

Set the legal entity attribute IsExempt=Yes to exempt the processing org.

6.4 Withholding Tax Rates Configurat ion
The Withholding Tax Config window can be accessed from Configuration > Fees, Haircuts, & Margin Calls >
Withholding Tax Config, or by clicking ... next to the Withholding Tax field in the Market panel of the Bond Definition
window.
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» Click New to add a new configuration, and enter the details in the Details area. The details are described below.

» Then click Save to save your changes. You can specify multiple rates for the same issuing country using static
data filters to determine the context of application of the rates.

Note that if the Authorization mode is enabled, an authorized user must approve your entry, provided that
"WithholdingTaxConfig" has been added to the classAuthMode domain.

Details

Fields Description

Id The ID is unique to each configuration. The system generates the ID when the
configuration is saved.

Issuer Country Select the country of the bond.

Holder Country Select the country of residence of the processing org that purchased the bond.

Rate Enter the withholding tax rate.

The withholding tax amount will be withdrawn from the coupon amount when the
corporate actions are generated.

Reclaim Rate Enter the reclaim rate if applicable.

The reclaim fee will be generated on the internal coupon CA for P&L impact, and on the
agent coupon CA for payment to the Tax Authority.

Static Data Filter Select a static data filter if applicable. This is mostly needed if you have multiple rates for
the same issuer country.

You can also use the static data filter to restrict the corporate actions to which the
withholding tax is applied.

The static data file must be defined with Groups = CA and must contain CA-related
attributes.

Effective From

Effective To

Select a start date and end date for the configuration.

This applies if the rates change on a certain date.

TaxAuthority Select the legal entity that will receive the reclaim fee if any - This is only used when a

Nasdaq Calypso
Fixed Income Trading / Version 18



Fields Description

Reclaim Rate is set.

Date Rule Select the date rule that determines the payment frequency of the reclaim fee if any -
This is only used when a Reclaim Rate is set.

Custody If Custody is checked, the CA process, when calculating the net interest amount, checks
if the CA trade book has the attribute “Custody Book” set to true. If so, it selects the
WHT config (if any) where the Holder Country is the CA trade’s client/counterparty
country.

If Custody is not checked, the Holder Country is the country of the PO.

WHT Decimal Enter the number of decimal places to round the withholding tax amount as needed.

Rounding Select the rounding method for the withholding tax amount as needed.

6.5 Fee Definit ion
Reclaim fees are defined using Configuration > Fees, Haircuts, & Margin Calls > Fee Definition.

There is one fee for the PO to impact the P&L on the internal CA trade: It must be named RECLAIM.

There is another fee for the Tax Authority to generate a transfer on the Agent CA trade: It must be named RECLAIM_
TAX.
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 Ⓘ [NOTE: You don't need to actually define a fee grid; they will use the Withholding Tax Rates Config]

6.6 Corporate Action Generat ion
From the Calypso Navigator, navigate to Trade Lifecycle > Corporate Action > Corporate Action.

Generate a coupon on the bond.

Internal Trade (for P&L impact purposes)
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The Gross Amount shows the full coupon, and the Settlement Amount shows the coupon reduced by the withholding
tax.

In the Fees panel, you can see the reclaim fee.

Agent Trade
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Similarly, the Gross Amount shows the full coupon, and the Settlement Amount shows the full coupon reduced by the
withholding tax.

In the Fees panel, you can see the reclaim fee paid to the tax authority.

If the settlement of the agent trade fails, a CA claim trade is generated with the Counterparty instead of the Agent
trade.

You can use the domain applyWHTClaimSameCountry to manage the application of Withholding Tax in case of CA
claim trade generated by a failed transfer:

• If the domain is not configured, WHT is applied on CA trade with Counterparty.

• If the domain contains Value = true, WHT is applied on CA trade with Counterparty only if issuer's country =
holder's country.

• If the domain contains Value = false, no WHT is applied on CA trade with Counterparty.

6.7 Accounting Setup
The following accounting events allow generating postings for the WHT:

• WHT Amount = Quantity * CA Unit Amount * WHT Rate

• Net WHT Amount = Quantity * CA Unit Amount * (WHT Rate - Reclaim Rate)

• Full Coupon = Quantity * CA Unit Amount

• Refund Amount = Quantity * CA Unit Amount * Reclaim Rate

Accounting Events Dates Amount Triggering Events Properties

FULL_COUPON

To book the amount of the full
coupon in case of WHT
(coupon corporate action).

If there is no WHT, FULL_
COUPON = INTEREST.

Booking Date - Today or
coupon payment date,
whichever is later

Effective Date - Coupon
end date

Full Coupon
amount to be paid
by agent

LIQUIDATED_
POSITION

UNLIQUIDATED_
POSITION

Retroactivity -
FULL

Booking Type -
N/A

Event Class -
BALANCE

Event Property
- NONE

NET_WITHHOLDINGTAX

To book the amount of the
withholding tax amount less

Booking Date - Today or
coupon payment date,
whichever is later

Full coupon
amount * (WHT
rate – Reclaim

LIQUIDATED_
POSITION

UNLIQUIDATED_

Retroactivity -
FULL

Booking Type -
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Accounting Events Dates Amount Triggering Events Properties

the reclaim amount. Effective Date - CA trade
settle date

rate) POSITION N/A

Event Class -
REALIZED

Event Property
- NONE

WITHHOLDINGTAX

To book the WHT tax amount
to be deducted.

Booking Date - Today or
coupon payment date,
whichever is later

Effective Date - Coupon
end date

WHT amount =
Full coupon *
WHT rate

LIQUIDATED_
POSITION

UNLIQUIDATED_
POSITION

Retroactivity -
FULL

Booking Type -
N/A

Event Class -
BALANCE

Event Property
- NONE

RECLAIM_TAX

To book the tax amount to be
reclaimed.

Booking Date - Today or
coupon payment date,
whichever is later

Effective Date - CA trade
settle date

Full coupon
amount * Reclaim
rate

LIQUIDATED_
POSITION

UNLIQUIDATED_
POSITION

Retroactivity -
FULL

Booking Type -
N/A

Event Class -
REALIZED

Event Property
- NONE

6.8 Prepaid Withholding Tax and Tax Al lowance
Withholding tax can also be prepaid on the trades by the counterparty.

This requires the following setup.

6.8.1 Counterparty Setup
The withholding tax rate is based on counterparty and the bond's country.

You need to define the following legal entity attributes:

LegalEntityTaxRate_<COUNTRY> where <COUNTRY> is the bond's country.

They contain the withholding tax rate in percentage.

Example:
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6.8.2 Fee Def in i t ions

WITHHOLDINGTAX_PREPAID

You need to set:

• Role = CounterParty

• Default Calculator = FeeGrid

• Settlement Amount = Checked

• Property PrepaidWHT = true

TAX_ALLOWANCE

You need to set:

• Role = CounterParty

• Default Calculator = FeeGrid
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• Settlement Amount = Checked

• Property TaxAllowance = true

WITHHOLDINGTAX_REALIZED
Used for redemptions.

6.8.3 Fee Gr id Conf igurat ions

WITHHOLDINGTAX_PREPAID

You can use the following variables:

TradeAccrual correspond to the Accrual field of the trade.

LegalEntityWHT gets the WHT rate from legal entity attribute LegalEntityTaxRate_<COUNTRY>.
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TAX_ALLOWANCE

WITHHOLDINGTAX_REALIZED
You can use the following variable:

WHTRate gets the WHT rate from the withholding tax configuration.

6.8.4 Pr icer Measures
You can add the following pricer measures:

WITHHOLDINGTAX_PREPAID (fee pricer measure)

Class Name = tk.pricer.PricerMeasureGenericFee

TAX_ALLOWANCE (fee pricer measure)

Class Name = tk.pricer.PricerMeasureGenericFee

WITHHOLDINGTAX_REALIZED (fee pricer measure)

Class Name = tk.pricer.PricerMeasureGenericFee

ACCRUAL_WHT returns the amount of WHT for the ACCRUAL pricer measure (based on Withholding Tax
Configuration rate)

ID = 918

Class Name = tk.pricer.calculators.PricerMeasureBond

Nasdaq Calypso
Fixed Income Trading / Version 18



ACCRUAL_SETTLE_DATE_WHT returns the amount of WHT for the ACCRUAL_SETTLE_DATE pricer measure (based
on Withholding Tax Configuration rate)

ID = 919

Class Name = tk.pricer.calculators.PricerMeasureBond

Accounting Events
You can add the following accounting events:

WITHHOLDINGTAX_PREPAID

TAX_ALLOWANCE

WITHHOLDINGTAX_REALIZED

ACCRUAL_WHT

ACCRUAL_SETTLE_DATE_WHT

ACCRUAL_REAL_WHT returns the amount of WHT for the ACCRUAL_REAL accounting event (based on Withholding
Tax Configuration rate)

6.9 Withholding Tax Trade Window Panel
In the Bond Trade window and the Money Market Trade window, an optional Withholding Tax panel is available for
displaying the withholding tax amounts.

From the trade window, choose View > Withholding Tax to add the Withholding Tax panel.
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Withholding Tax Details

Fields Description
Withholding Tax Sum of fees with fee definition property PrepaidWHT = true.

Tax Allowance Sum of fees with fee definition property TaxAllowance = true.

Post-Tax Settlement
Amount

Post-Tax Settlement Amount = Settlement Amount + Withholding Tax + Tax Allowance
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Fields Description
Maturity Amount Only displayed for BondMMInterest and BondMMDiscountWithAI.

Whether or not the "Apply Withholding Tax" checkbox is selected on the bond definition
Market panel determines if the tax amount is removed or not.

When "Apply Withholding Tax" is selected, Maturity Amount is calculated as:

• For BondMMInterest: Maturity Amount = Notional + Total Accrual - RoundDown(Total
Accrual * WHT Rate)

Where Total Accrual = Round(Notional * Coupon Rate * Days/365, 0) (this is the interest
cashflow)

• For BondMMDiscountWithAI: Maturity Amount = Notional - RoundDown(Total Accrual *
WHT Rate)

Where Total Accrual = (100 - Issue Price) /100 * Notional

When "Apply Withholding Tax" is not selected, Maturity Amount is calculated as:

• For BondMMInterest: Maturity Amount = Notional + Total Accrual

• For BondMMDiscountWithAI: Maturity Amount = Notional

The amount is saved in the trade keyword MaturityAmount.
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7. Defining Bond Spreads
Bond spreads are used as underlying instruments for generating interest rate curves. A bond spread is basically a
swap on a bond.

To define a bond spread product, navigate to Configuration > Fixed Income > Spread (menu action
product.BondSpreadWindow) from the Calypso Navigator.

You can also manually change a spread on a bond when pricing.

See Bond Discount Spread for more details.

Contents

- Fields Details

- Adding a Spread to an Underlying
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Bond Spread Window

» Click Load to load the existing bond spreads.

Select a bond spread and modify the fields described below as applicable.

» Click New and enter the fields described below to create a new bond spread.

» Click Delete to delete a spread.

» Click Save to save your changes.

You can also click Save As New to save the bond spread as a new bond spread.
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7.1 Fields Detai ls
Enter a currency for the spread. Loading a saved spread will populate the currency and Id fields.

(Fixed Side)

Fields Description

Maturity Select the maturity of the swap.

The first field corresponds to the number of years, and the second to the number of months.

For example, a 2.5 years maturity will be defined as:

Date Roll Select the date roll convention to apply when the maturity date falls on non business days.

Frq Select the payment frequency of the swap.

Holidays Click ... to select the payment holiday calendar.

Day Count Select the daycount convention for calculating the interest rate.

(Float Side)

Fields Description
Maturity Select the maturity of the swap.

The first field corresponds to the number of years, and the second to the number of months.

For example, a 2.5 years maturity will be defined as:

Date Roll Select the date roll convention to apply when the maturity date falls on non business days.

Frq Select the payment frequency of the swap.

Cmp Compounding frequency schedule. Click the checkbox and choose an interval from the drop
down menu.

Holidays Click ... to select the payment holiday calendar.

Day Count Select the daycount convention for calculating the interest rate.

Id Unique id given by the system when the bond spread is saved.
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Fields Description
Rate Index Select the reference index of the swap.

Bond Click ... to select the bond underlying the bond spread.

Interpolate Check the Interpolate checkbox to specify a second bond and interpolate the interest rate
between the two maturities.

You will be prompted to select a second bond as shown below.

» Click ... next to the Interpolate field to select a second bond.

7.2 Adding a spread to an Underlying
You can open the swap the spread is on by double-clicking and holding ctrl in the curve window. The swap used to
generate the spread will open.
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» Define a bond spread in the Bond Spread Window. Add fixed/float details.

» Open a curve in a Curve Window. In the underlying tab, add instrument type "Spread" from the drop down.

» Select the defined spread with Id and double-click while holding the ctrl button. A swap window with the
fixed/float details will open.
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8. Bond Spread Adjustment
You can view issuer, issue spread and funding cost on bond products. Spreads are stored in the bond product
definition and are used to discount cashflows. Issue spread is stored in the legal entity attribute table. You must first
define a spread on a bond to use Configuration > Fixed Income > Spread from the Calypso Navigator, in order to
manipulate a spread to a bond for pricing.

Adjusting issue spreads expresses credit risk on a bond issue as well as an issuer. In order to price a trade or position,
base points can be adjusted for the notes. Issuer and issue adjustment spreads are summed for the total spread.
Spreads can be manually overwritten for pricing.

From the Calypso Navigator, navigate to Reports > Securities Reports > Bond Discount Spread (menu action
reporting.ReportWindow$ProductDiscountSpread) to navigate to the window.

Contents

- Defining an Issuer Spread

- Configuring the Window

- Calculations

See Defining Bond Products for more details.

See Bond Spread for more details.

8.1 Defining an Issuer Spread
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Bond Discount Spread window

8.1 .1 Add a Product
You can define a spread by loading a bond product and adding base points. Hover over Criteria to enable the search
panel.

Product Search panel

From here you can search by date and product. Click ... to bring up the product chooser panel.

8.1 .2 Add a Spread
You can select ProductDiscountSpread from the menu or click Add New in the tool bar.

Add Spread window

Add a spread or modify the effective date for the product.

8.2 Configuring the Window
You can configure the report in the viewer.

l You can click Data and select configure data columns.
l You can click View and select a table view, frame and layout. You can save a layout as a template. Click Save as

Default Layout.
l You can save your configuration as a template. Click Save as Template and choose a name.
l You can export your report to .xls, .csv, etc.

Hover over the Progress tab to view job progress running in the engines.
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8.3 Calculat ions
Spreads are adjusted according to the following calculations:

• N is the total number of cashflows generated

• N - 1 ≥ n ≥ 0 is the index of the last coupon payment time

• Ci is the coupon payment for the time index 'i'

• F is the face value (redemption principal)

• dfi is the discount factor for the time index 'i', which discounts a cashflow from the time 'i' to the given settle date.
It is in the form of- 'i', whole payment period in the time interval between the valuation date to the cashflow
payment date, and 'w'- remaining fractional period not covered by the whole periods for odd coupons.
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9. Bond Report
This document describes how to use the Bond report.

• Loading Bonds

• Updating Product Codes in Bulk

• Bond Report Menu

• Bond Composite Report

The bond report allows loading bonds that share common criteria, and saving the selection as a template to be used in
trade windows. Bonds are created using Configuration > Fixed Income > Bond Product Definition.

From the Calypso Navigator, navigate to Reports > Securities Reports > Bond Report (menu action
reporting.ReportWindow$Bond) to bring up the Bond report.

Bond Report Window
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9.1 Loading Bonds
» Enter search criteria using the panels described below, and click to load the corresponding bond products.

A star (*) next to the panel title indicates what search panel is used to load data.

» Choose Report > Save As Template to save the search criteria as a template. You will be prompted to enter a
template name and specify whether the template is public or private.

Bond report templates are available for selection in the Bond Trade window, Repo Trade window, and Margin Call
Configuration window.

» You can select a template, and click to display the number of objects that will be loaded from the database,
before loading the report.

» Click to print the report results.

NOTE: For the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

9.1 .1 Propert ies F i l ter Panel
The Properties Filter panel is selected by default. It allows selecting criteria from bond static data — bond class, bond
sub-type, bond currency, bond status (for bonds imported from Bloomberg), bond country, bond issuer, bond
maturity date.

It also allows:

• Selecting bonds based on the INDUSTRY attribute of the issuer.

• Setting a range of ratings for the rating agencies to select bonds from the corresponding issuers.

• Setting a range of tenors for the remaining maturity as of the current date, and for the original maturity.

• Including or excluding matured bonds using the “Include Matured Securities” checkbox.

• Selecting a book to filter bonds that have a position in the selected book. Note that the selection is checked
against the economic position (calculated by the Liquidation engine).

• Including or excluding bonds with active flat positions using the "Include Active Flat Positions" checkbox. Select
this checkbox to show active flat positions. This is dependent on the "In Inventory of Book" attribute and requires
a book to be specified there before the report can generate these positions.

9.1 .2 Speci f ic Secur i t ies Panel
Select the Specific Securities panel to choose specific securities to add to a bond template.

» Select a product code and type in a few characters of the code value in the adjacent field, then hit Enter. Note
that the Name product code searches the bond short names.

The system searches all the bonds defined in the system, unless a quick entry template has been specified, in
which case the system only searches the bonds filtered by the quick entry template.
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See Bond Report Menu for information on setting up a quick entry template.

Also, if the environment property USE_SUBSTRING_IN_BOND_NAME_QUERY=true is set, the system searches all
the letters in the product code values. Otherwise, it only searches from the start.

The bonds that satisfy the request are displayed in a list.

» You can also enter a bond product id in the Product Id field and hit Enter.

» Check the “Specific Bonds Exclusively” to load in the report results only the bonds selected in this panel. Criteria
specified in other panels will not be taken into account. This allows setting a static list of bonds.

» Then click to load the bonds selected in this panel in the report results.

9.1 .3 Sec Codes Fi l ter Panel
Select the Sec Codes Filter panel to select bonds based on the values of security codes. Security codes are created
using Configuration > Product Configuration > Product Code.

9.1 .4 Issuer Att r ibutes F i l ter
Select the Issuer Attributes Filter panel to select bonds based on the values of issuer attributes. Issuer attributes are
specified in the Issuer static data under Configuration > Legal Data > Legal Entities, Attributes button.

9.2 Updating Product Codes in Bulk
You can use the Bond Report to update product codes in bulk.

Load the bonds for which you want to update a product code from any panel, and choose Bond Report > Toggle
Product code update panel to display the Product Code update panel as shown below.
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» Select a product code and set its value as needed. Then click Update product Code.

The product code will be updated for ALL the bonds currently loaded.

9.3 Bond Report Menu
The menu items of the Bond Report menu are described below.

Menu Items Description
Apply to Specific
Securities
(Alt+DblClick)

In the bond report results, you can select a row and choose Bond Report > Apply to
Specific Securities (Alt+DblClick) to add the corresponding bond to the Specific Securities
panel.

You can also hit Alt and double-click a row to add the corresponding bond to the Specific
Securities panel.

Set Quick Entry
Template

To select a bond report template for quick entry.

When a quick entry template is set, the product code search will only apply to the bonds
filtered by the quick entry template. Otherwise the product code search applies to all the
bonds defined in the system.

You will be prompted to select a template name.

Note that only one bond report template can be set for quick entry.

Disable Quick Entry
Template

To disable quick entry from a bond report template.
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Menu Items Description
Load Quick Entry
Template

To load the quick entry template, if any.

Toggle Product code
update panel

To update product codes in bulk.

See Updating Product Codes in Bulk for details.

9.4 Bond Composite Report
The Bond Composite report allows displaying the underlying bonds that compose a bond benchmark. Bond
benchmarks are created using Configuration > Fixed Income > Bond Benchmarks.

See Specifying Benchmarks for details.

Add the Bond Composite Report menu item using Main Entry Customizer, the action is
reporting.ReportWindow$BondComposite.

Then choose the Bond Composite Report menu item.

» Select a bond benchmark from the Benchmark Selector and click Add. Then click to load the corresponding
products.

You can also load individual bonds using the Bond Selector area.
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You can enter a value date to only load the benchmarks effective after that date.

» Choose Report > Save As Template to save the search criteria as a template. You will be prompted to enter a
template name and specify whether the template is public or private. Bond Composite report templates are
available for selection in the Bond Front Trade window, and Repo Front Trade window.
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10. Defining a Bond Browser
The Bond Front and Repo Front trade windows allow using a special product browser for selecting products.

Prior to specifying a product browser, you need to specify bond report templates.

See Bond Report for details.

When you click Browse from the Bond Front window or the Repo Front window, the product browser window will
appear as shown below.

» Right-click the “default” label and choose “Add Report”. You will be prompted to select a bond report template or
a bond composite report template as shown below.

Select a template, enter a display name for the template in the Name field, and click OK.

» You can also group the report templates. Right-click the “default” label and choose “Add Report Grouping”. You
will be prompted to enter a group name. You can then add report templates under a given group.

» Then right-click the “default” label and choose “Save Tree” to save the product browser. You will be prompted to
enter a name. The selected name will replace the “default” label.
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» You can right-click a report and choose “Set As Default” to have the report selected by default when you open the
product browser.

» You can click Search to open the Bond Report.
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11. Multi Quote Mapping
In some countries such as Argentina, a bond can be trade in multiple markets, generating different quotes for the
same bond. The quotes can vary by source (market), settle days, and currency. The quotes for a bond may also have
different quote types (clean price, yield, etc). The valuation of the bond position must be done by only one quote,
which is determined by regulators and may change over time.

The Multi Quote Mapping window (menu action marketdata.MultiQuoteMappingWindow) allows mapping multiple
quote sources to the same bond and prioritizing in which order these quotes, if available, should be used.

11.1 Defining a Bond Quote Mapping Set

» Click New to being defining a new quote mapping set.

» Select a bond.

» Specify the quote attributes.

Specify the Source, Settle Days, and Currency in the Mapping Attributes area as needed, then click Add. A row for
that quote's attributes is added.

Repeat for each different quote as needed to add a row for each.

You can highlight a row and modify attributes as needed in the Mapping Attributes area, then click Update to apply
the changes to the row.
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You can highlight a row and click to delete the row.

You can click to begin a new set and delete all rows.

» Prioritize the quotes.

Highlight a row and use to arrange the rows into order of priority in which the quotes should be
used. If the first quote is not available, it will look for the second priority quote, and so on.

» Click Save when you are done. The bond quote mapping set is saved and populated in the lower half of the
window.

It also creates a quote name for each row of the quote mapping set in the format "Bond.<Bond
Name>.<Source>.<Settle Days>.<Currency>".

» You can double-click a quote mapping row to open the individual quote in the Quotes window.

» You can double-click a bond quote mapping set row in the lower half of the window to open the bond in the Bond
Product Definition window.

» You can import or export bond quote mapping sets as xml or csv using Utilities > Import or Utilities > Export. You
can also export using Export in the Quote Mappings area.

To import, it is recommended for first export a set in order to get the correct format.

11.2 Populat ing Values from Quote Mapping Sets via Scheduled
Task
The scheduled task APPLY_BOND_QUOTE_MAPPING allows populating values for standard bond quotes and some
bond definition fields based on the quotes defined in the Multi Quote Mapping window.

If a targeted bond has a quote mapping set defined, the system will look for quotes in the order listed in the set. When
a quote is found, that value is populated into the standard bond quote. The bond definition "Quoting Ccy" and "Settle
Days" fields are also updated with the corresponding values from the quote mapping set.
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APPLY_BOND_QUOTE_MAPPING first checks the current bond definition and if the "Quoting Ccy" and "Settle Days"
fields will not be updated, then no updates will be made to the bond definition. The standard bond quotes will still be
updated as applicable.

The scheduled task must be run on the quote date of the quotes from which you want to populate values.

If no quotes are found in the entire mapping set, a message will be logged that no quote was found for the bond, and
processing will continue onto the next bond.

Scheduled tasks are added in the scheduledTask domain.

Common Attributes
Select a pricing environment.

Task Attributes
• Static Data Filter – Select a static data filter to define the scope of bonds to be processed.

• Skip Settle Days Update – If set to false, the bond definition ‘Settle Days’ field is updated based on the bond’s
multi quote mapping attribute ‘Settle Days’. If set to true, ‘Settle Days’ is not updated, and all other attributes will
continue to be updated. Default is true.
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12. Fixed Income Products
This section describes the various types of Fixed Income products supported by Calypso. Help is available from all
trade worksheets - Choose Help > Trade Help in any trade worksheet for complete details.

Functions common to all trade worksheets are described under Calypso Front Office Tools documentation: trade
functions, trade menus, Details panel, Cashflows Panel, Fees panel, etc.

Trades can be captured from the Trade > Fixed Income menu in the Calypso Navigator or in a Trade Blotter.

Bonds

Product Name Definition Trade Worksheet
Bond All types of bond products and interest money markets. Trade > Fixed Income > Bond

Bond Forward An OTC forward contract on a bond product. Trade > Fixed Income > Bond
Forward

Bond Future A future on a bond product. Trade > Fixed Income > Bond
Future

Bond Future
Option

A future option on a bond product. Trade > Fixed Income > Listed
Future Options

Issuance A bond issue from the perspective of the processing
organization.

Trade > Fixed Income >
Issuance

OTC Bond Option An OTC option on a bond product. Trade > Fixed Income > OTC
Bond Options

Deal Capture Only
For the following products, support includes capture of trade properties and cashflow generation - No native pricing
is available - There is no risk computation.

Product Name Definition Trade Worksheet
Bond Cap/Floor/Collar on bond payout.

Multi-currency bond (quanto).

Trade > Fixed Income > Bond

Asset/Mortgage
Backed Securities

US Government Agency (15 and 30 year) pass through securities
only.

Trade > Fixed Income > Bond
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13. Capturing Bond Trades
This document describes how to capture basic bond trades using the Bond worksheet.

Navigate to Trade > Fixed Income > Bond (menu action trading.TradeWindow$BondFront) to open the Bond
Trade window, from the Calypso Navigator or from the Trade Blotter.

Bond Quick Reference

Ente r ing Trade Deta i l s
» Hit F10 to load a template to populate the worksheet with default values. Then modify

the fields as applicable.

Or you can enter the trade fields directly. They are described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

You can also hit F12 to save the trade using any action available in the workflow, or
choose Trade > Save Action. You will be prompted to select an action.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» You can choose Pricing Env > Check to check if all required pricing data are available

in the Pricing Environment.

» Click Price to price the trade.

F inanc ing a Trade
» Once a bond trade has been saved, you can choose Bond > Finance Trade to enter a

related repo trade. If the bond belongs to a bundle, the repo trade will be added to the
bundle as well.

Or you can click Finance in the Bundle Entry area.
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In the Bundle Entry area, you can also enter an asset swap by clicking Asset Swap, a
performance swap by clicking Performance Swap, or an interest rate swap by clicking IR
Swap – Help is available from these windows.

Trade L i fecyc le
» You can allocate the trade to multiple books and legal entities using Back Office >

Allocate.

» You can terminate the trade using Back Office > Terminate.

» You can apply corporate actions using Trade Lifecycle > Corporate Action > Corporate
Action, or using the CORPORATE_ACTION scheduled task.

» You can assimilate issuance trades.

See Assimilating Issuance Trades for details.
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13.1 Bond Trade

Bond Trade Window

You can click the links below for information on capturing specific types of bonds:

Asset Backed Bonds

Danish Mortgage Bonds

Floating Rate Notes

Inflation Bonds

Money Market Bonds

Taiwanese Bonds

When Issue / Re-Issue Bonds
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Trade Details

Fields Description
Buy / Sell / Issue /
Upsize / Re-Open /
Close

Select Buy or Sell as applicable to indicate the direction of the trade from the book’s
perspective.

You can switch between the trade directions using the space bar (note that the space bar is not
active in the Speed Entry Panel).

You can also select Issue / Upsize / Re-Open / Close for activity related to bond issues from the
processing org.

See Issuance Activity for details.

You can also select Cover / Short instead of Buy / Sell. It allows identifying trades with trade
keyword LongShort = Short whereas Buy / Sell allows identifying trades with trade keyword
LongShort = Long. This can be used in the context of Asset Management for filtering and
reporting purposes.

Product code

Product description

You can select a bond using one of the following methods: Product Code Selection or Browser
Selection, they are described below.

Once you have selected a bond, the value of the alternative product code is displayed in the
field adjacent to the Browse button. The alternative product code is specified in the User
Defaults.

You can click Show to view the details of the selected bond, or to create a bond - Save the bond
and click Apply in the Bond Product window if you have made any modification - Help is
available from that window.

Product Code Selection
The product code defaults to the security code specified in the User Defaults. You can select
another product code as applicable.

Note that the Name product code searches the bond short names.

» Type in a few characters of the code value in the adjacent field.

The system searches all the bonds defined in the system, unless a quick entry template has
been specified, in which case the system only searches the bonds filtered by the quick
entry template.

See Specifying a Bond Browser for information on setting up a quick entry template.

Also, if the environment property USE_SUBSTRING_IN_BOND_NAME_QUERY=true is set,
the system searches all the letters in the product code values. Otherwise, it only searches
from the start.

The bonds that satisfy the request are displayed in a list.
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Fields Description
» Select a bond from the list.

Browser Selection
Click Browse to select a product from a user-defined bond browser.

See Specifying a Bond Browser for information on setting up a bond browser.

» Select a report template to display the corresponding bonds, and double-click a bond from
the list to select it.

If you do not have report templates, simply click Search to browse all existing bonds.

» You can right-click any column and choose Configure Columns to customize the display.

Nominal/Quantity Enter the amount of nominal that is traded. This is the original nominal. Double-clicking the label
will change it to Quantity (nominal/face value). You can enter the quantity if the quote type on
the bond is set to "Price", "UnitaryPrice", or "GrossUnitaryPrice".

The adjacent field displays the product’s currency.

Clean Price The label actually displays the quote type of the bond product.

Defaults to the market quote as of the trade date if any. Modify as applicable. See Clean Price,
Yield and Dirty Price below for details.

If there is no market quote and BOND_FROM_QUOTE is false, we price the bond from curve to
produce an initial price for trading.

For BondMMDiscount and BondMMInterest, the pricing parameter MMKT_FROM_QUOTE is
used instead of BOND_FROM_QUOTE.

Settle Date The settlement date defaults to the trade date + the number of settle days specified in the bond
product.

The settlement date uses the holiday calendar of the bond product to identify business days.

If you change the trade date in the Details panel, double-click the Settle Date label to update
the settlement date accordingly.

Cash Date In order to display the cash settlement date in the bond trade window, you need to set the
environment property BOND_CASH_DATE=true. It is false by default.

The field Cash Date will be added next to the Settle Date field, and stored in the field “Alternate
Date”.

To force the transfers to DAP, you need to set the trade keyword SWIFTDAP = true.
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Fields Description
The static data filter element “Has Cash Date (true/false)” allows selecting bond trades with a
cash settlement date, for messaging purposes.

Proceeds Details

Fields Description
Principal The principal amount is calculated as Nominal * Clean Price.

Accrual The amount of accrued interest is calculated based on the Accrual Days.

You can double-click the Accrual label to make the Accrual field editable.

Settlement The settlement amount is calculated as Principal + Accrual.

To enter a settlement amount instead of calculating it, see “Calculate” below.

Bonds issued in one currency and settled in another will have the settlement amount
rounded using the settlement currency.

Note that for Mexican cross currency bonds, the settlement amount is calculated as Nominal
* Dirty Price * FX Rate.
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Fields Description
Calculate Allows capturing trades based on settlement amount.

Trade Capture by Settlement Amount
To capture a trade based on settlement amount, enter the following fields:

• Settle Date

• Settlement

• Calculate

• If Calculate = “Quantity or Nominal”, enter one of the following: Clean Price, Dirty Price,
Yield, Discount

• If Calculate = “Price”, enter the Nominal / Quantity

Dual currency is supported in 'Calculate = Price', for the case where there is cross
currency settlement (bond currency and trade settlement currency are different).

• If Calculate = Settlement and Nominal, Principal and Price will be editable whereas
Settlement and Nominal will be greyed out and will be calculated once the user enters
values in the fields (Quote type i.e. CP or Yield or DP, Settle Date, Principal).

To note that, "Calculate = Settlement and Nominal" is limited only to the Australian
Market. This implementation is done for bonds where a price/yield formula applies for
calculating a price from an interest rate (yield or margin): Fixed Rate Bonds, Floating
Rate Notes, Capital Indexed Bonds, Callable Bonds, and RFR Bonds, and pricers:
PricerBondAUSCPI, PricerBondFRNAUD, PricerBondCGS, PricerBondGeneric, and
PricerBondFRN.

In certain cases, users may see Principal and / or Nominal rounding up or down by 1 cent
due to the already existing round trip calculation logic. In such cases, users are
requested to set Nominal rounding to 3 decimals in the Bond definition > Market Tab.

The Nominal / Quantity, or the Price, depending on your “Calculate” selection, and
accrued interest if any, will be calculated. The entered Settlement amount may be
modified to adjust for having rounded down the Nominal / Quantity to a whole number
as needed.

• If Calculate = Fractional Quantity, the settlement amount is the user entered value and
the price details section is editable.

To note that, "Calculate = Fractional Quantity" is limited only to the Australian Market.
With the new calculation type, in certain cases, the users may see a 1 cent difference
and they are requested to change the nominal decimal to a higher number. This support
is provided only to the classic bond trade window.

BondMMDiscount and BondMMInterest
For BondMMDiscount and BondMMInterest products, if Calculate = Price or is left blank, and
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Fields Description
you enter a settlement amount, the dirty / clean price and yield will be calculated
accordingly. The settlement amount is stored in the trade keyword
“ManualSettlementAmount”. The bond pricer will return this amount as settlement amount
for settlement calculation.

If Calculate = “Quantity or Nominal”, then this keyword is not stored and the Nominal /
Quantity and Settlement amounts behave as described above.

Ccy The settlement currency defaults to the bond’s currency.

When settling a cross currency bond trade, the settlement currency specified in the bond
trade window will be used to round the settlement amount, not the currency specified in the
bond product definition.

Modify as applicable.

FX The FX field is enabled when the settlement currency is different from the bond’s currency.

The FX field defaults to the FX quote on Trade Date. For UDI/MXN bonds, the FX Rate
defaults to the FX quote on Settle Date (This is only done for Mexican Bonds).

» Enter the FX rate between the settlement currency and the bond’s currency. The
settlement amount is recalculated accordingly.

Price Details

Fields Description
Clean Price

Yield

Dirty Price

Enter the clean price, yield, or dirty price, and the other fields will be calculated accordingly.

When a bond is not quoted in Yield, and you manually enter the yield, the manual yield is
stored in the trade keyword "Entered Yield". This is used for PREM_DISC_YIELD calculations.

The dirty price is clean price + unit accrual.

For bonds quoted using Price32, you can enter the trade’s price with two, three, or four
digits after the dash. The first two digits represent the number of thirty-seconds (between 1
and 31).

If the price contains 3 digits, the third digit represents the number of eighths of a thirty
second (or 1/256, between 1 and 7). A bond price entered as "99-022" will be read as [99 +
2/32 + 2/8(1/32)], or 99.0703125. The third digit can also be +, indicating 4/8 of a thirty
second.

If the price contains 4 digits, the last two digits represent the number of sixteenths of a thirty
second (or 1/512, between 1 and 15).

Note that the four-digit logic only applies to bonds with the tick size 512.

For convertible bonds quoted in Price, the Clean Price label switches to Unit, and you can
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Fields Description
enter the monetary units.

For non-callable bonds with MM_ACT30 yield method, the Yield label switches to Monthly
Yield.

For callable bonds, select the effective call method from the drop down next to the Yield
field: Worst, Best, Next, Maturity, or Custom. The trade prices and settlement amount will
reflect the effective call.

Note that to use Custom, you must have Effective Call = Custom, and a Call Date set in the
Call Schedule panel.

Refer to Calypso Zero Curve documentation for complete details on Agency Option
Adjusted Spread (AOAS) pricing for bonds.

Gross Price Only used for Gilt RPI indexed bonds.

Margin Only appears for floating rate bonds. It displays the DISC_MARGIN pricer measure, which
calculates the spread added to current rates to equal the bond yield. Ref: Stigum and
Robinson, “Money Market and Bond Calculations” (1996), Ch. 17. For the average rate
needed for that formula, the Calypso implementation uses the index rate as of the valuation
date.

You can enter a discounted margin to solve for the clean price.

Prepay Speed Only used for BondAssetBacked.

<Secondary Ccy>
Clean Price

<Secondary Ccy> Dirty
Price

They allow entering a bond trade in any currency, and only appear if the
BondEnableSecondaryCcy domain is set to true.

When the trade currency is different from the bond currency, you can enter either one and
the other will be calculated.

• <Secondary Ccy> Clean Price = Clean Price * FX Rate * Pool Factor

• <Secondary Ccy> Dirty Price = Dirty Price * FX Rate * Pool Factor

For PIK bonds:

• <Secondary Ccy> Clean Price = [Clean Price + (PIK Accrual * Clean Price)] * Pool Factor
* FX Rate

• <Secondary Ccy> Dirty Price = [Dirty Price + (PIK Accrual * Clean Price)] * Pool Factor *
FX Rate

They are rounded according to the "Price Dec." field.

Benchmark Details
These fields only appear if the selected bond is associated with a benchmark.

Fields Description
Clean Price Displays the price and yield of the Benchmark associated with the selected bond if any.
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Fields Description
Yield If you modify those values, the Clean Price, Yield and Dirty Price of the trade will be

calculated accordingly.

When saving a bond trade that has an underlying benchmark bond, the benchmark yield is
saved in the keyword "Benchmark Yield".

When loading a trade that has the "Benchmark Yield" keyword, the original benchmark clean
price and yield are displayed as read-only.

Note that you will only see the keyword if you add the value “Benchmark Yield” to the
tradeKeyword domain.

Spread Enter the spread over the benchmark. The Clean Price, Yield and Dirty Price of the trade will
be calculated accordingly.

Name Displays the name of the benchmark selected in the bond product.

You can choose Bond > Show Benchmark to display the benchmark details.

Security Code The label actually displays the security code selected in the User Defaults.

Displays the security code value of the Benchmark associated with the selected bond if any.

ISIN Displays the security code of the product.

Market Price Displays the quote of the Benchmark associated with the selected bond if any.

Bond Details

Fields Description
Market Quote Displays the latest quote as of the trade date, if any.

If there is no quote, and BOND_FROM_QUOTE is false, we do not try to calculate a quote
from curve.

For BondMMDiscount and BondMMInterest, the pricing parameter MMKT_FROM_QUOTE is
used instead of BOND_FROM_QUOTE.

 Ⓘ [NOTE: The locale used for quote type generation is set in the domain
LocaleForBondQuotes. If no value exists in this domain, the locale set in the user
environment properties will be used]

Next Coupon Displays the next coupon date.

Accrual Days Displays the number of days between the last coupon date and the settlement date.

Accrual Rate Displays the current period calculated accrual rate based on observations until the
settlement date for calculation of the current accrual. Only available when using a Daily
Compounded RFR Reset Index (using bond types BondFRN, UST FRN and
BondAssetBacked). Not available when the settlement date is earlier than the value date.

Current Nominal Displays the current nominal and pool factor for bonds with variable notional.
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Fields Description
Pool Factor

Current Coupon Displays the current coupon rate.

Pool Factor Displays the pool factor when the bond issuer defaults (for ABS and MBS type of Bonds).

Settlement Details

Fields Description
Legal entity The first field identifies the legal entity role. The default role is specified using Utilities > Set

Default Role. However, you can change it as applicable.

You can select a legal entity of specified role from the second field provided you have set up
favorite counterparties. You can also type in a character to display the favorite
counterparties that start with that character. Favorite counterparties are specified using
Utilities > Configure Favorite Counterparties.

Otherwise, click ... to select a legal entity of specified role from the Legal Entity Chooser. You
can also type Ctrl-F to invoke the Legal Entity Chooser, or directly enter a Legal Entity short
name.

Click Show to display the details of the selected legal entity. You can also choose Utilities >
Selected Counterparty Info.

If the trade counterparty is a processing organization that owns the trade’s book, and if trade
keyword BondNoXferRule=true, the trade does not generate any transfer rules.

Id

Ext Ref

Int Ref

Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load an existing trade by typing the trade id into this field, and pressing [Enter].

You can also display the internal reference or external reference. The default trade
reference to be displayed can be selected in the User Defaults.

The internal reference and external reference can be set in the Details panel of the trade
worksheet.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
You can modify as applicable.

You can select a book provided you have set up favorite books. You can also type in a
character to display the favorite books that start with that character. Click ... to specify
favorite books or Utilities > Configure Favorite Books.

The processing org of the book identifies the processing org of the trade.

Trade Date Displays the trade date specified in the Details panel.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.
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Fields Description
The status will change over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Bundle Entry Details
You can associate the trade with a bundle. Bundles are created under Configuration > Books & Bundles > Trade Bundle.
Opening and existing trade, adding a trade bundle name and selecting 'Save as New' will not save the trade bundle name to the new
trade.

You can also finance the trade, capture an asset swap, or capture a performance swap.

Fields Description
Types Select a bundle type.

Names Select a bundle.

Additional Details

Fields Description
Mirror Book Select a mirror book if you want to mirror the current trade.

You can select the mirror trader from the Details panel.

A mirror trade will be saved with the current trade to the selected book, and you can view
the mirror trade id from the Details panel.

Market Type Defaults to the market type selected in the User Defaults. For when-issued and re-issue
trades, the system automatically sets the corresponding market type to “When-Issued” and
“Re-Issue” respectively.

You can modify as applicable.

Market types are created in the marketType domain.

Trade Classification The values for that field come from the domain keyword.TradeClassification, and this field is
stored in the trade keyword “TradeClassification”.

The “Trade Classification” column can be configured in the following reports: Trade Browser,
Pair Off Manager, Transfer Report, Message Report and Postings Report.

This column can also be configured in the BO Browser, task station, and netting manager.

“KEYWORD.TradeClassification” can be used in Calypso filters.

Comment Enter a free comment as applicable.

13.2 Issuance Activity

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 168 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 169 / 250

13.2 .1 Issu ing a Bond
The issue corresponds to the sale of a bond from the perspective of the processing org. You can click Show to create
the bond on-the-fly.

For an issue, the bond should have the following characteristics:

• The Issuer should be the processing org of the selected book.

• The Issue Paying Agent (legal entity or role IPA) should be populated on the bond. The IPA handles the coupon
payments for the issuer, and will be used in the corporate action process. SDIs should be defined for the bond’s
IPA for the IPA role.

13.2 .2 Upsiz ing a Bond
Once a bond has been issued but not yet settled, you can use that action to modify the total issued on the bond.

Select the bond that has been issued, and enter a nominal amount to increase the total issued.

13.2 .3 Re-Opening a Bond
After the settlement date of the issue, you can still increase the total issued of the bond using that action. You can
enter a different price and accrued interest will be computed.

13.2 .4 Clos ing a Bond
This action allows buying back the bond.

13.3 Assimi lat ing Issuance Trades
You can assimilate issuance trades on multiple bonds into one bond using the scheduled task ISSUANCE_
CONSOLIDATION based on assimilation keys.

13.3 .1 Def in ing Ass imi lat ion Keys
The following assimilation keys are used by default: Bond Class, Bond Type, Issue Date, Dated Date, Maturity Date,
Issuer, Country, Issue Price, Issue Yield, Currency, Redem Price, Redem Currency, Face Value, Min. Purchase Amount,
Coupon details, Market Details, Special details.

However, you can add more assimilation keys for bond legal entities and product codes as needed.

Add a menu item for menu action util.BondAssimilationKeysWindow to bring up the Assimilation Keys window.
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Click ... to select additional keys, then click Save.

13.3 .2 Running the Scheduled Task ISSUANCE_CONSOLIDATION
Configure the scheduled task ISSUANCE_CONSOLIDATION.

The trade filter should contain Product Type = Issuance.

Task Attributes
• TransferFilter - You can select a static data filter based on transfer criteria.
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• Bundle Type - You can select a bundle type to set the bundle type on the assimilated trades. The bundle name will
be set to the product ID of the target product.

• One Msg Checked - Only applies if a bundle type has been selected. Set to true if you want the bundle to
generate one confirmation, or set to false otherwise (default).

• Mirror Bundle - Only applies if a bundle type has been selected. Set to true to save a mirror bundle, or set to false
otherwise (default).

• Apply Trade Action - Select the action to be applied on the assimilated trades.

The scheduled task must be run on the Issue date of the bond products that you want to assimilate. The system loads
all the trades that match the assimilation keys and selects one of the products as the target product. It updates the
trades with the target product, and sets the trade keyword "AssimilatedFrom" to the product ID of the original bond
product.

It also updates the trade type to Upsize if the bond total issue is less than the quantity of the trades, and sets a trade
bundle if specified.

On the assimilated bond products, the system shows the product into which they have been assimilated in the Special
panel.
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13.3 .3 Undoing an Issuance
From the Trade Browser, you can right-click an Issuance trade, and choose Process > Unconsolidate. from the popup
menu.

The system brings up all the trades that have been assimilated into a target product.

Check "Selected" for the trades you want to remove from the assimilation, and click Unconsolidate.
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14. Capturing Asset Backed Bond Trades
Navigate to Trade > Fixed Income > Bond to open the Bond Trade window, from the Calypso Navigator or from the
Trade Blotter.

Prior to capturing an ABS bond trade, you need to define an ABS bond product.

See Defining Bond Products for details.

14.1 Sample Asset Backed Bond Trade
When trading an asset backed bond (ABS bond), the pool factor on the settlement date will appear on the window
after pricing as shown below.

Bond Trade Window

See Capturing Bond Trades for complete details on capturing trades.
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For an ABS bond trade:

• The trade amount is the quantity multiplied by the pool factor on the settle date.

• The Accrual (%) is expressed as a 100 basis. It represents the accrual value/pool factor.

• The pricer measures are computed as follows:

– NPV_NET: It computes the NPV without taking the accrual into account. (This can be considered as a “clean”
NPV whereas the NPV is a “dirty” one.)

The NPV calculation takes into account: the accrual with pool factor impact, the factored cost, and the
market cost with current factor application.

NPV_NET = (Market Price * Quantity * Pool Factor) - Factored Cost

Where Factored Cost = Quantity * Trade Clean Price * Pool Factor

– NPV: The NPV calculation takes into account: the accrual with pool factor impact, the factored cost, and the
market cost with current factor application.

NPV = [(Market Price + Accrual) * Quantity * Pool Factor)] - Dirty Factored Cost

Where Dirty Factored Cost = Quantity * Trade Dirty Price * Pool Factor

– PREM_DISC: The Premium Discount calculation takes the Pool Factor into account.

Premium/Discount = Trade Quantity * (Trade Price - Redemption Price) * Pool Factor

The accrual/amortization of the premium takes into account: the WAL date or the early redemption date, and
the pool factor.

Amortization = Premium/Discount * (Val Date - Trade Settle Date) / (Maturity Date - Trade Settle Date)

Where the Maturity Date is calculated using either the WAL Date or the Early Redemption Date.

– ACCRUAL: The coupon amount is calculated with using the pool factor. However, if the pool factor is
changing during the coupon period, the coupon is calculated by adding the different pool factor periods. All
the accrual pricer measures are following the same rules.

– WAL: Average time to receive the principal cashflows of the bond weighted by the individual principal
payments.

14.2 Book Attr ibutes
By default, accretion (PREM_DISC_YIELD) is calculated using the Retrospective Method, where the original trade yield
is retroactively recalculated due to prepayments. This behavior can be modified using book attributes (Calypso
Navigator > Configuration > Books & Bundles > Trading Book > Attributes ...):

• FixedBondAccretion – Allows specifying how to calculate the yield and cashflows used for accretion for fixed rate
BondAssetBacked products. If set to ContractualToMaturity, the original accretion trade yield is calculated based
on the original trade price and trade settle date, and this original yield will not change over time. The projected
accretion cashflows are calculated using the standard mortgage constant payment formula based on the original
contractual maturity date and the coupon rate, ignoring all prepayment assumptions and external cashflows.

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 174 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 175 / 250

If set to Default or not set, the default Calypso behavior is used. Note that pricing behavior is not affected by this
book attribute.

• FloatingBondAccretion – Allows specifying how to calculate the yield and cashflows used for accretion for floating
rate BondAssetBacked products. If set to ProspectiveToMaturity, the current accretion yield is calculated by
setting the present values to match between the previous accretion yield and the new index rates. The projected
accretion cashflows are calculated using the standard mortgage constant payment formula based on the original
contractual maturity date and the index rate, ignoring all prepayment assumptions and external cashflows.

If FloatingBondAccretion is set to Default or not set, the default Calypso behavior is used. Note that pricing
behavior is not affected by this book attribute.

14.3 External Cashflows
When using external cashflows, the full forecasted Bloomberg cashflow schedule is integrated into Calypso. This
includes future principal and interest payments based on the requested prepayment type and speed.

The trade cashflows, external flows and yield settle date flows will now display the same consistent cashflows (BAM
100 prepayments).
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Additional updates based on later requests will update the cashflows to either the known (historical) cashflows and/or
update the forecasted cashflows based on new prepay assumptions.

14.3 .1 Analyt ics and Posi t ions
When using external cashflows, analytics and downstream processes will use the external cashflows.

Pricer measures are calculated based on the forecasted external cashflows. This includes, but is not limited to, WAL,
PV, NPV, BOOK_VALUE, MARKET_VALUE and PREM_DISC_YIELD.

Position based analyses and reports use forecasted external cashflows.

14.4 Paydown Corporate Actions
The Corporate Action type PAYDOWN renders the pool factor change. It is generated through the standard Corporate
Action process. It impacts the position and generates realized P&L.

To generate the Corporate Actions, navigate to Trade Lifecycle > Corporate Action > Corporate Action.
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» Enter a start date and end date.

» Click Select Product to select a product.

» Click Generate to generate the corporate actions for the selected dates and product.

PAYDOWN corporate actions are generated for the notional and CASH corporate actions are generated for the
coupons.

» Then select the Apply panel to apply the corporate actions to the product position.

The generated CA trades have an impact on both the realized P&L (see the Position report) and the cashflows
(see the Back Office Position report, Cash panel).

When the position of an ABS bond is sold after the CA has been run for paydown and coupon, the paydown is
incorrectly reversed. In order to consider the CA paydown record date as inclusive, you need to add the following
value to the domain CA_PAYDOWN_RECORD_DATE_INC:

Value = recordDateInclusive

Comment = true
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In this case, the CA paydown is not reversed as the record date is inclusive. The domain is empty by default (CA
paydown record date is not inclusive).

14.4 .1 Pos i t ion Report

If you double-click a row, you can see the details of the realized P&L as shown below.

You can see that the paydowns actually impact the realized P&L.

14.4 .2 Back Off ice Posi t ion Report

» Double-click a cell to see the details.
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14.5 Shortfal l Reimbursement Corporate Actions
The Corporate Action types PRINCIPAL_REIMBURSE, PRINCIPAL_SHORTFALL, INTEREST_REIMBURSE, and
INTEREST_SHORTFALL are generated through the standard Corporate Action process.

To generate the Corporate Actions, navigate to Trade Lifecycle > Corporate Action > Corporate Action.

» Enter a start date and end date.

» Click Add to select a product.

» Click Generate CA to generate the corporate actions for the selected dates and product.

The corporate actions produced by the Shortfalls and Reimbursements are as follows:

INTEREST_SHORTFAL: MODEL=CASH | SUBTYPE=INTEREST_SHORTFALL

INTEREST_REIMBURSE: MODEL=CASH | SUBTYPE=INTEREST_REIMBURSE

PRINCIPAL_SHORTFAL: MODEL=CASH | SUBTYPE=PRINCIPAL _SHORTFALL

PRINCIPAL_REIMBURSE: MODEL=CASH | SUBTYPE=PRINCIPAL _REIMBURSE

» Then select the Apply panel to apply the corporate actions to the product position.

14.6 Accounting Events
The accounting event PAYDOWN_PL renders the realized P&L on paydowns.
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15. Capturing Danish Mortgage Bond
Trades
Navigate to Trade > Fixed Income > Bond to open the Bond Trade window, from the Calypso Navigator or from the
Trade Blotter.

Prior to capturing a Danish Mortgage bond trade, you need to define a Danish Mortgage bond product.

See Defining Bond Products for details.

15.1 Sample Danish Mortgage Bond Trade

See Capturing Bond Trades for complete details on capturing trades.

15.2 Drawing Corporate Action
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If domain "DMBS_DrawsOnRepos" contains Value = True, include Repos in CA Trades against Processing Org (built
from PL Position) on events with model/subtype REDEMPTION/DRAWING - If Value = false or empty, exclude Repos in
CA Trades against Processing Org.

15.2 .1 Legacy Drawing Corporate Act ion
To generate the Corporate Actions, navigate to Trade Lifecycle > Corporate Action > Corporate Action.

At drawing date, the position on the master bond is amortized by the drawn amount, and a drawn position is
generated on the drawn bond. Both bonds can be traded.

Generating the Corporate Action
Select the Generate panel, and generate the corporate action at drawing date on the master bond.

If "Generate Drawn Bond" is checked, the system will automatically create the drawn bond (in case it has not been
created in the bond product definition).

If "Generate Drawn Bond" is clear, the system will not create the drawn bond but will stop the CA process in case the
drawn bond does not exist.

Applying the Corporate Action
Select the Apply panel.

The master bond is amortized by the amount of the drawing (drawing rate applied to the open position) using a
REDEMPTION corporate action.
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It creates two CA trades:

• One CA trade type REDEMPTION / DRAWING between the book and the PO in order to update the P&L. Setting
the environment property BOND_REDEMPTION_TRADE=true will generate a Sell trade instead.

The clean price is computed using the market price of the drawing schedule.
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• The other trade type REDEMPTION / DRAWING between the book and the Agent will carry out the SECURITY
transfer to the agent as well as the message and accounting entries.

A position is created on the drawn bond through the DRAWING corporate action. Two CA trades are created:

• One CA trade type DRAWING / DRAWING between the book and the PO in order to update the P&L. Setting the
environment property BOND_REDEMPTION_TRADE=true will generate a Buy trade.

The trade is created on the same book as the "master" book by default, or on the book specified in book attribute
"Drawn MM Book" on the "master" book.
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• The other CA trade type DRAWING / DRAWING between the book and the Agent will carry out the SECURITY
transfer from the agent as well as the message and accounting entries.

15.2 .2 TARGET2 Compl iant Corporate Act ions
To generate the Corporate Actions, navigate to Trade Lifecycle > Corporate Action > Corporate Action.
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The system creates two corporate actions for Danish Mortgage Bonds on the same payment date:
REDEMPTION/DRAWING in order to amortize the bond by the drawn amount, and CASH/INTEREST in order to
generate the coupon amount.

The corporate actions should be applied by payment date so that they can be created together.
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16. Capturing Floating Rate Notes
Trades
Navigate to Trade > Fixed Income > Bond to open the Bond Trade window, from the Calypso Navigator or from the
Trade Blotter.

Prior to capturing an FRN bond trade, you need to define an FRN bond product.

See Defining Bond Products for details.

16.1 Sample FRN Bond Trade
When trading the bond in between two coupon payment dates, the system calculates the accruals and coupon
payment at settlement date based on the past fixing rates since last coupon payment.

Based on the bond definition, BOND_12010 (no compounding method), Selling 1,000,000 shares traded at a
settlement date = 07/21/03.

See Capturing Bond Trades for complete details on capturing trades.
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At Settlement date:

• Coupon Amount: 16,777.89

= ((91 * 3.2 * 1,000,000.00)/ 36000) + ((92 * 3.4 * 1,000,000.00)/36000)

• Accrual: 9,127.78

= ((91 * 3.2)/360 + (11 * 3.4)/360) * 1,000,000.00

• Accrual (%): 0.912778

= ((91 * 3.2%)/ 36000) + ((11 * 3.4%)/36000)

• Dirty Price: 97.382328

= Clean Price + accrual (%) = 96.46955 + 0.912778

• Prem/Disc: 35,304.5

= (Redemption Price - Clean Price) / 100 * Quantity

= ((100 - 96.46955)/100) * 1,000,000

At Value date:

• NPV: 5,587.83

Discounting the coupon amount calculated previously at value date (07/21/03)

= (Dirty Price at Settle Date * Quantity) – (Dirty Price at Value Date * Quantity)

= ((99.382328 – 97.941111) / 100) * 1,000,000

• PREM_DISC = 35.52

= (((96.46955 – 100) / 100) / 994) * 1,000,000

• ACCRUAL_FIRST = 9,222.22

= ((91 * 3.2)/360 + (12 * 3.4)/360) * 1,000,000.00

• DIRTY_PRICE = 97.941111

= 97 + 0.941111

By looking at the cashflows of the trade, you have the option to see the internal flows from which the coupon is
composed of.
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On the same bond, if the compounding method = flat, the results become:
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17. Capturing Inflation Bond Trades
Navigate to Trade > Fixed Income > Bond to open the Bond Trade window, from the Calypso Navigator or from the
Trade Blotter.

Prior to capturing an Inflation bond trade, you need to define an Inflation bond product.

See Defining Bond Products for details.

17.1 Quotes Specif icat ion
Prior to trading this type of bond, you need to check the quotes. Choose Pricing Env > Check to check the quotes.
The Check Pricing Env window will appear as shown below.

You need quotes for the index “Inflation.Currency.Index” 3 months before and 2 months before, a quote for the bond,
and a quote for the index factor.

17.2 Sample Inf lat ion Bond Trade

See Capturing Bond Trades for complete details on capturing trades.

» Enter a gross price and a quantity. We consider that the gross price already takes the index factor into account.
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The yield, dirty price and clean price will be computed. The Clean Price in the Market Price (quote entered on the
bond). The Accrual (%) is the accrual amount multiplied by the index factor on the settlement date.

» Choose Market Data > Utilities > CPI Calculator to simulate the notional factor calculation as shown below.

– Enter the CPI value 3 months ago (CPIm), the CPI value 2 months ago (CPIm+1), and the base CPI value
(specified in the Special panel of the bond). Enter a number of decimal places in the Rounding field as
applicable. Then click Calculate.

17 .2 .1 CPI Pr icer Measures
NPV = (Dirty Price on Val Date - Dirty Price of Buy Trade) * Nominal Amount

Notional Factor = Index Factor on Val Date (interpolation of the index values from 3 months and 2 months)

Price = Market Price on Val date * Index Factor on the settlement date

Dirty Price = Price + (Accruals * Index Factor on the settlement date)

17 .2 .2 RPI Pr icer Measures
Index Ratio = (RPI figure 8 months prior to last coupon date) / (RPI figure 8 months before issuing date (base RPI))

English Market rounding rules:

• Interest and redemption payments for the 2% Index-linked Treasury Stock 2006 (ISIN GB0009061317) and 2.5%
Index-linked Treasury Stock 2011 (ISIN GB0009063578) are rounded DOWN to 2 decimal places per £100
nominal.

• For all other index-linked gilts with first issue dates before 2002 the Interest and redemption payments are
rounded DOWN to 4   decimal places per £100 nominal.
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• For index-linked gilts with first issue dates of 2002 onwards, the Interest and redemption payments are rounded
TO THE NEAREST 6 decimal places per £100 nominal.

Interest Rate for each payment = Coupon rate (usually fixed rate) adjusted to the RPI movement = (Coupon rate / n)*( 
RPI 8cp / Base RPI)

where n = number of annuities /year (usually 2), Base RPI = RPI figure 8 months before issuing date (figure to be used
for the calculations of interest payments during the bond life), and RPI 8cp = RPI figure 8 months prior to last coupon
date.

Coupon = adjusted Coupon rate (rounded down to 4 decimals) * nominal

Accrued interests = Adjusted coupon rate * (number of days since last coupon date / number of days in coupon
period) * nominal

Redemption Payment = Nominal holding * (RPI 8cp / Base RPI)

UK Gilt already has the indexation built into the quoted price. As a result, the indexation calculation applies only to
accrued interests.

RPI values are published monthly, around the 17th of each month. It is entered into Calypso under the quote name:
“Inflation.GBP.RPI.Tenor” every first of each month.

17 .2 .3 ABS Inf lat ion Bonds
Inflated coupon = (RPI/CPI index relative to coupon end date) / Index value specified on bond * coupon rate / #
periods per year (e.g. 2 for SA)

Accrual = Inflated coupon * [(accrued # of days / # of days in the period) * Trade Quantity] / 100 * Face Value (accrual
date).

17 .2 .4 Valuat ion of Inf lat ion Bonds
Note that TIPS should use PricerBondUST.

Example of valuation on 04/25/04, settlement date 04/26/2004.

» When pricing using index values, you only need the market price of the bond on 04/25/2004.

– PRICE = Market Price of the bond on val date * Index Factor on settle date
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– ACCRUAL = Accrual as of settle date * Index Factor on settle date

– NPV = (Dirty Price * Open Position) – Initial settlement amount

– ACCRUAL_BO = Accrual as of the 05/29/02 * Index Factor 05/29/02
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18. Capturing BondMMInterest and
BondMMDiscount Trades
Navigate to Trade > Money Market > CD/CP/DN (menu action trading.TradeMoneyMarketFrontWindow) to open
the Money Market Trade window, from the Calypso Navigator or from the Trade Blotter.

These bonds can also be traded using the standard Bond Trade window.

Prior to capturing bond MM trades, you need to specify bond product templates using Configuration > Fixed Income
> Bond Product Definition for bond products BondMMInterest, BondMMDiscount, and BondMMDiscountWithAI. The
bond products will be created on-the-fly from the Money Market window. You can also create the bond MM products
directly.

For certain MM Discount products (Chinese bonds), you can use the bond selector window to choose a product.

See Defining Bond Products for details.

Bond MM Quick Reference

Ente r ing Trade Deta i l s
» By default, the window is configured in "Quick Entry" mode. In that mode, you can

select a bond product template and the actual bond product will be created on-the-fly.
Then enter the fields as needed, they are described below.

» Or you can disable the "Quick Entry" mode, and hit F10 to load a trade template to
populate the worksheet with default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

You can also hit F12 to save the trade using any action available in the workflow, or
choose Trade > Save Action. You will be prompted to select an action.
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A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» You can choose Pricing Env > Check to check if all required pricing data are available

in the Pricing Environment.

» Click Price to price the trade.

F inanc ing a Trade
» Once a bond trade has been saved, you can choose Bond > Finance Trade to enter a

related repo trade. If the bond belongs to a bundle, the repo trade will be added to the
bundle as well.

Or you can click Finance Trade in the Bundle Entry area.

In the Bundle Entry area, you can also enter an asset swap by clicking Asset Swap, a
performance swap by clicking Performance Swap, or an interest rate swap by clicking IR
Swap – Help is available from these windows.

Trade L i fecyc le
» You can allocate the trade to multiple books and legal entities using Back Office >

Allocate.

» You can terminate the trade using Back Office > Terminate.

» You can apply corporate actions using Trade Lifecycle > Corporate Action > Corporate
Action, or using the CORPORATE_ACTION scheduled task.

18.1 Quick Entry Mode

» Select the direction of the trade and select a bond product template from the adjacent field. The actual bond
product will be created on-the-fly. Then enter the other fields as needed.

» You can enable the other areas of the trade using the View menu.
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See Capturing Bond Trades for complete details on the other areas.

» Since those trades do not use the standard Bond Trade window, you need to specify their trade window so that
when you open the trade from any report or blotter in the system, it will know which window to display.

See Trade Window Setup for details.

» You can click Save to save the trade and create the bond product. Then if you modify any fields, choose the
desired outcome:

– Create a new bond product and amend the previously saved trade: Click Save again.

– Create a new bond product and save a new trade: Click Save As New Bond.

– Save a new trade and do not modify the previously created bond product: Hit F3 or choose Trade > Save As
New.

Speed Entry - Fields Details

Fields Description
Buy / Sell / Issue Select Buy or Sell as applicable to indicate the direction of the trade from the book’s

perspective.

You can also select Issue to issue a bond from the processing org.

You can switch between buy, sell, and issue using the space bar.

For an issue, the bond should have the following characteristics:

• The Issuer should be the processing org of the selected book.

• The Issue Paying Agent (IPA) should be populated on the bond. The IPA handles the
coupon payments for the issuer, and will be used in the corporate action process. SDIs
should be defined for the bond’s IPA for the IPA role.

Bond Product
Template

Select a bond product template for a "BondMMInterest", "BondMMDiscount" or
"BondMMDiscountWithAI" bond product.

Bond product templates are created using the Templates button in the Bond Definition
window using Configuration > Fixed Income > Bond Product Definition.

The Calypso Navigator must be restarted in order to load the template into the drop down
menu.

Issuer Displayed from the bond product template.

Coupon Coupon rate displayed from the bond product template.

Maturity Displayed from the bond product template, but you can enter a different maturity if desired.

Nominal/Quantiity Enter the amount of nominal that is traded. This is the original nominal. Double-clicking the
label will change it to Quantity (nominal/face value). You can enter the quantity if the quote
type on the bond is set to "Price", "UnitaryPrice", or "GrossUnitaryPrice".

Quote Type Defaults to the quote type of the bond product, but you can select a different quote type if
desired.
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Fields Description
Defaults to the market quote as of the trade date if any. Modify as applicable. If there is no
market quote and MMKT_FROM_QUOTE is false, we price the bond from curve to produce
an initial price for trading.

For bonds quoted using Price32, you can enter the trade’s price with two, three, or four
digits after the dash. The first two digits represent the number of thirty-seconds (between 1
and 31).

If the price contains 3 digits, the third digit represents the number of eighths of a thirty
second (or 1/256, between 1 and 7). A bond price entered as "99-022" will be read as [99 +
2/32 + 2/8(1/32)], or 99.0703125. The third digit can also be +, indicating 4/8 of a thirty
second.

If the price contains 4 digits, the last two digits represent the number of sixteenths of a thirty
second (or 1/512, between 1 and 15).

Note that the four-digit logic only applies to bonds with the tick size 512.

Settle Date The settlement date defaults to the trade date + the number of settle days specified in the
bond template.

The settlement date uses the holiday calendar of the bond template to identify business
days.

If you change the trade date in the Details panel, double-click the Settle Date label to update
the settlement date accordingly.

Cpty You can select a counterparty provided you have set up favorite counterparties. You can
also type in a character to display the favorite counterparties that start with that character.
Favorite counterparties are specified using Utilities > Configure Favorite Counterparties.

Otherwise, click ... to select a counterparty from the Legal Entity Chooser. You can also type
Ctrl-F to invoke the Legal Entity Chooser, or directly enter a Legal Entity short name.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
You can modify as applicable.

You can select a book provided you have set up favorite books. You can also type in a
character to display the favorite books that start with that character. Click ... to specify
favorite books or Utilities > Configure Favorite Books.

The processing org of the book identifies the processing org of the trade.

Issue Date Displayed from the bond product template, but you can enter a different issue date if
desired.

Dated Date Displayed from the bond product template, but you can enter a different dated date if
desired.

Issue Price Displayed from the bond product template, but you can enter a different issue price if
desired.

Issue Price Base
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Fields Description
You can specify a different base to use for Issue Price and Redemption Price using the
product code "Issue Price Base". If left blank, the default is base 100.

Example: Taiwanese bills are entered in base 10,000.

Look For Existing Bond If checked, when you enter a template and maturity, the system attempts to find an existing
bond. If none are found, a temporary dummy bond is created. When a bond (not a dummy
bond) is loaded, that bond definition is used rather than the template.

If un-checked, the system always creates a dummy bond, rather than looking for an existing
one.

You can control the defaulting behavior of this checkbox using the domain
BondSpeedEntryNewBond. If set to true, "Look For Existing Bond" defaults to un-checked. If
set to false or not set, it is checked by default.

Code Displays the default code selected in Configuration > User Access Control > User Defaults,
and its associated value in the adjacent field.

Click Codes to enter the actual code values.

» Double-click the Value field corresponding to a code and enter its value.

» Then click Apply.

You can create product codes using Configuration > Product > Code.

You can add security codes to the domain securityCode.ReprocessTrades that require
checking if trades need to be reprocessed if the security codes are modified.

You can update security codes in bulk using the Bond report.

See Bond Report for details.
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18.2 Sample Bond MM Trade

See Capturing Bond Trades for complete details.

18.3 Trade Window Setup
By default, all bond trades are captured using the standard bond window.

Since those trades do not use the standard Bond trade window, you need to specify their trade window so that when
you open the trade from any report or blotter in the system, it will know which window to display.

From the Calypso Navigator, navigate to Configuration > User Access Control > Trade Window.
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» Enter a configuration name and click Add.

Select the product type BondMMDiscount, the sub-type "Discount" or ALL, and enter the complete class name
trading.TradeMoneyMarketFrontWindow.

» Then click Add, and repeat for the product type BondMMInterest and sub-type "Interest" or ALL.

» Click Save.

Now you need to associate this window configuration with every user who needs it.

From the Calypso Navigator, navigate to Configuration > User Access Control > User Defaults.

» Select a user and select the window configuration from the field "Trade Window Config".

» Click Save.

 Ⓘ [NOTE: You need to restart the Calypso Navigator in order for this change to take effect]
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19. Capturing Taiwanese Money Market
Bond Trades
Navigate to Trade > Fixed Income > Bond (Custom) (menu action trading.TradeBondCustomFrontWindow) to
open the Bond (Custom) Trade window, from the Calypso Navigator or from the Trade Blotter.

These bonds can also be traded using the standard Bond Trade window.

Prior to capturing Taiwanese money market bond trades, you need to specify bond product templates using
Configuration > Fixed Income > Bond Product Definition for bond products BondMMInterest, BondMMDiscount, and
BondMMDiscountWithAI. The bond products will be created on-the-fly from the Bond (Custom) Trade window. You
can also create the bond MM products directly.

See Defining Bond Products for details.

There is specific functionality for Taiwanese bonds that can be configured.

See Specifying Taiwanese Bonds for details.

Taiwanese Bond Quick Reference

Ente r ing Trade Deta i l s
» The first time you open the Bond (Custom) Trade window, you need to select the

panels to be displayed from the View menu.

» In "Quick Entry" mode you can select a bond product template and the actual bond
product will be created on-the-fly. Then enter the fields as needed, they are described
below.

» Or you can disable the "Quick Entry" mode, and hit F10 to load a trade template to
populate the worksheet with default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.
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You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

You can also hit F12 to save the trade using any action available in the workflow, or
choose Trade > Save Action. You will be prompted to select an action.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» You can choose Pricing Env > Check to check if all required pricing data are available

in the Pricing Environment.

» Click Price to price the trade.

F inanc ing a Trade
» Once a bond trade has been saved, you can choose Bond > Finance Trade to enter a

related repo trade. If the bond belongs to a bundle, the repo trade will be added to the
bundle as well.

Or you can click Finance Trade in the Bundle Entry area.

In the Bundle Entry area, you can also enter an asset swap by clicking Asset Swap, a
performance swap by clicking Performance Swap, or an interest rate swap by clicking IR
Swap – Help is available from these windows.

Trade L i fecyc le
» You can allocate the trade to multiple books and legal entities using Back Office >

Allocate.

» You can terminate the trade using Back Office > Terminate.

» You can apply corporate actions using Trade Lifecycle > Corporate Action > Corporate
Action, or using the CORPORATE_ACTION scheduled task.

19.1 Quick Entry Mode
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» Select the direction of the trade and select a bond product template from the adjacent field. The actual bond
product will be created on-the-fly. Then enter the other fields as needed.

» You can enable the other areas of the trade using the View menu.

See Capturing Bond Trades for complete details on the other areas.

» Since those trades do not use the standard Bond Trade window, you need to specify their trade window so that
when you open the trade from any report or blotter in the system, it will know which window to display.

See Trade Window Setup for details.

» You can click Save to save the trade and create the bond product. Then if you modify any fields, choose the
desired outcome:

– Create a new bond product and amend the previously saved trade: Click Save again.

– Create a new bond product and save a new trade: Click Save As New Bond.

– Save a new trade and do not modify the previously created bond product: Hit F3 or choose Trade > Save As
New.

Speed Entry - Fields Details

Fields Description
Buy / Sell / Issue Select Buy or Sell as applicable to indicate the direction of the trade from the book’s

perspective.

You can also select Issue to issue a bond from the processing org.

You can switch between buy, sell, and issue using the space bar.

For an issue, the bond should have the following characteristics:

• The Issuer should be the processing org of the selected book.

• The Issue Paying Agent (IPA) should be populated on the bond. The IPA handles the
coupon payments for the issuer, and will be used in the corporate action process. SDIs
should be defined for the bond’s IPA for the IPA role.

Bond Product
Template

Select a bond product template for a "BondMMInterest", "BondMMDiscount", or
"BondMMDiscountWithAI" bond product.

Bond product templates are created using the Templates button in the Bond Definition
window using Configuration > Fixed Income > Bond Product Definition.

The Calypso Navigator must be restarted in order to load the template into the drop down
menu.

Issuer Displayed from the bond product template.

Coupon Coupon rate displayed from the bond product template.

Maturity Displayed from the bond product template, but you can enter a different maturity if desired.

Nominal/Quantiity Enter the amount of nominal that is traded. This is the original nominal. Double-clicking the
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Fields Description
label will change it to Quantity (nominal/face value). You can enter the quantity if the quote
type on the bond is set to "Price", "UnitaryPrice", or "GrossUnitaryPrice".

Quote Type Defaults to the quote type of the bond product, but you can select a different quote type if
desired.

Defaults to the market quote as of the trade date if any. Modify as applicable. If there is no
market quote and MMKT_FROM_QUOTE is false, we price the bond from curve to produce
an initial price for trading.

For bonds quoted using Price32, you can enter the trade’s price with two, three, or four
digits after the dash. The first two digits represent the number of thirty-seconds (between 1
and 31).

If the price contains 3 digits, the third digit represents the number of eighths of a thirty
second (or 1/256, between 1 and 7). A bond price entered as "99-022" will be read as [99 +
2/32 + 2/8(1/32)], or 99.0703125. The third digit can also be +, indicating 4/8 of a thirty
second.

If the price contains 4 digits, the last two digits represent the number of sixteenths of a thirty
second (or 1/512, between 1 and 15).

Note that the four-digit logic only applies to bonds with the tick size 512.

Settle Date The settlement date defaults to the trade date + the number of settle days specified in the
bond template.

The settlement date uses the holiday calendar of the bond template to identify business
days.

If you change the trade date in the Details panel, double-click the Settle Date label to update
the settlement date accordingly.

Cpty You can select a counterparty provided you have set up favorite counterparties. You can
also type in a character to display the favorite counterparties that start with that character.
Favorite counterparties are specified using Utilities > Configure Favorite Counterparties.

Otherwise, click ... to select a counterparty from the Legal Entity Chooser. You can also type
Ctrl-F to invoke the Legal Entity Chooser, or directly enter a Legal Entity short name.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
You can modify as applicable.

You can select a book provided you have set up favorite books. You can also type in a
character to display the favorite books that start with that character. Click ... to specify
favorite books or Utilities > Configure Favorite Books.

The processing org of the book identifies the processing org of the trade.

Issue Date Displayed from the bond product template, but you can enter a different issue date if
desired.

Dated Date Displayed from the bond product template, but you can enter a different dated date if
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Fields Description
desired.

Issue Price Displayed from the bond product template, but you can enter a different issue price if
desired.

Issue Price Base
You can specify a different base to use for Issue Price and Redemption Price using the
product code "Issue Price Base". If left blank, the default is base 100.

Example: Taiwanese bills are entered in base 10,000.

Code Displays the default code selected in Configuration > User Access Control > User Defaults,
and its associated value in the adjacent field.

Click Codes to enter the actual code values.

» Double-click the Value field corresponding to a code and enter its value.

» Then click Apply.

You can create product codes using Configuration > Product > Code.

You can add security codes to the domain securityCode.ReprocessTrades that require
checking if trades need to be reprocessed if the security codes are modified.

You can update security codes in bulk using the Bond report.

See Bond Report for details.

Trade Entry Changes the Speed Entry panel to the Bond Speed Entry panel.
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19.2 Sample Taiwanese Bond Trade

See Capturing Bond Trades for complete details.
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 Ⓘ [NOTE: Trade Proceeds total is calculated as Dirty Price * Nominal for bonds with no pool factor. In the
standard Bond Trade window, intermediate rounding may slightly change the value]

19.3 Secondary Currency Fields Setup
The optional secondary currency fields in the Bond (Custom) Trade window allow entering the trade in any currency.

To enable them, set the domain XMMEnableSecondaryCcy to true.

When the trade currency is different from the bond currency, you can enter either one and the other will be
calculated.

• <Secondary Ccy> Clean Price = Clean Price * FX Rate * Pool Factor

• <Secondary Ccy> Dirty Price = Dirty Price * FX Rate * Pool Factor

They are rounded according to the "Price Dec." field.

19.4 Pricer Measures
The pricer measures DIRTY_PRICE_SCALED and TRADE_DIRTY_PRICE_SCALED allow displaying these prices in a
different base as they are controlled by the Issue Price Base product code.

See Specifying Taiwanese Bonds for details on Issue Price Base.
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Pricer
Measures

Description

DIRTY_
PRICE_
SCALED

Class tk.pricer.calculators.PricerMeasureBond.

Per local market practice, the face value for a TWN bill should set up with 100,000, while the price
base for the same bill should be in 10,000.

The base is controlled by the Issue Price Base product code. If Issue Price Base = 10,000, then:

DIRTY_PRICE_SCALED = DIRTY_PRICE * 100

TRADE_
DIRTY_
PRICE_
SCALED

Class tk.pricer.calculators.PricerMeasureBond.

Per local market practice, the face value for a TWN bill should set up with 100,000, while the price
base for the same bill should be in 10,000.

The base is controlled by the Issue Price Base product code.

While DIRTY_PRICE_SCALED is the market price, i.e. the market quote on valuation date, TRADE_
DIRTY_PRICE_SCALED is the price of the original trade, i.e. what you paid for the bond. It does not
change over time.

19.5 Trade Window Setup
By default, all bond trades are captured using the standard bond window.

Since those trades do not use the standard Bond trade window, you need to specify their trade window so that when
you open the trade from any report or blotter in the system, it will know which window to display.

From the Calypso Navigator, navigate to Configuration > User Access Control > Trade Window.

» Enter a configuration name and click Add.

Select the product type BondMMDiscount, the sub-type "Discount" or ALL, and enter the complete class name
trading.TradeBondCustomFrontWindow.

» Then click Add, and repeat for the product type BondMMInterest and sub-type "Interest" or ALL.
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» Then click Add, and repeat for the product type BondMMDiscountWithAI and sub-type "Discount" or ALL.

» Click Save.

Now you need to associate this window configuration with every user who needs it.

From the Calypso Navigator, navigate to Configuration > User Access Control > User Defaults.

» Select a user and select the window configuration from the field "Trade Window Config".

» Click Save.

 Ⓘ [NOTE: You need to restart the Calypso Navigator in order for this change to take effect]
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20. Capturing Bond Forward Trades

 Ⓘ [NOTE: Using Bond Forwards requires a specific license agreement. Please contact your Adenza
representative for more information]

Bond forwards are OTC derivatives and settlement can be either cash or physical.

Navigate to Trade > Fixed Income > Bond Forward (menu action trading.TradeBondForwardWindow) to open the
Bond Forward Trade window.

Prior to capturing bond forward trades, you need to specify bond products using Configuration > Fixed Income >
Bond Product Definition.

See Defining Bond Products for details.

Currently, bond forwards support generic fixed rate bonds, for example, Colombian TES bonds, UST, Mexican M-
bonds, and UVR (dual currency bonds specific to the Colombian market).

Note that Calypso currently does not support fixed rate bonds with inflation adjustment, flipper type, call schedule,
amortization, dual currency, etc, or bonds with coupon type as floating, exotic, etc.
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20.1 Sample Bond Forward Trade

Bond Forward Trade Window

In the Type field, the default value is Standard, unless the underlying is a UVR bond, then the value is Colombian.

Bond Forward now supports to valuation methods :

• Colombian, which is a legacy method that was initially introduced for Colombian market.

• Standard, which is the new standard way of pricing a bond forward.

In the new Standard methodology, following new features have been added :

• Bond Forward trade can be captured using 'Yield, Clean Price and Dirty Price'

• Both fixed rate and floating rate bonds (including compounded and Non-compounded bonds) will be supported
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• The calculations used for 'Standard' methodology is different from that of 'Colombian'.

Other lifecycle methodologies, like Exercise, Rollover, terminate etc. stays the same for both methodologies.

 Ⓘ Users already using the Colombian methodology can continue using the same methodology without any
disruption (Execute SQL will upgrade the existing trades valuation methodology to 'Colombian'). Only in the
DTUP files a new field has to be added specifying the valuation methodology for existing clients.

20.2 Pricing
Bond forward trade capture is based on Clean Price, while valuation and settlement are based on Dirty Price.
BondForward Quote type as 'Yield' can be set and with YIELD pricer measure for bond forward, under the valuation
method as ‘Standard’.

Now when Quote Type = Yield/Instrument Spread, then Clean Price = Computed Bond’s Dirty Price as of future
settlement date – Accrual of the future setting Bond using the cashflows as of Valuation Date.

Resets / Fixings
The following resets / fixings are required:

• Non-UVR bond forwards:

– Price of the bond

– FX reset, if settlement currency is different from that of the bond (only needed on exercise date)

– FX spot between bond and bond forward settlement currency

• UVR bond forwards:

– Reset of the price of the bond

– Reset of UVR

– FX reset, if settlement is offshore

– FX spot between UVR and COP

– FX spot between COP and bond forward settlement currency

– FX reset between COP and bond forward settlement currency (only needed on exercise date)

Exchange Rates
The settlement currency drives the exchange rate if different from the bond currency.

The FX forward rate, or Strike, also needs to be calculated when there is a foreign currency.
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Pricer Config
Ensure that PricerBondForward is used for the BondForward product.

The forecast curve is set in the product specific tab for bond currency.

The discount curve is in the bond forward settlement currency.

For bond currency not equal to bond forward currency, the discount curve is needed for both currencies to calculate
the FX forward rate.

The underlying bond should also have the necessary discount curves, i.e. the bond should successfully price in a
Bond Trade window.

Pricer Measures
The following pricer measures are unique to Bond Forwards.

Pricer Measures Description

PV_COUPONS_
UNDERLYING

PV of all coupons on the underlying bond during the term of the bond forward.

NPV_FORWARD PV of forward.

NPV_
UNDERLYING

PV of underlying.

DIRTY_PRICE_
UNDERLYING

If the value date is less than the fixing date, it is the projected forward dirty price of the
underlying, otherwise, it is the spot dirty price of the underlying.

20.3 Standard Sett lement
The Bond Forward Exercise window is used to handle standard settlement of bond forwards, but note that it can only
be used to settle the trade on the fixing date.

From the Bond Forward Trade window, select Bond Forward > Exercise to open the Bond Forward Exercise window.
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» Currently, only the Process Date field and Apply button are used.

20.3.1 Cash Sett lement
The following fixings are required to calculate the settlement amount:

• Price

• FX rate

• FX reset between the bond currency and bond forward settlement currency

• UVR to COP spot (for UVR bonds only)

The settlement amount and date will be shown once the fixings are set. Once the action is applied and the bond
forward trade is moved to EXERCISED status, the fee is generated based on the settlement amount and settlement
date.

Scheduled Task AUTOMATIC_EXERCISE_BONDFORWARD is used to auto-exercise Bond Forward trades.

20.3.2 Phys ica l Sett lement
For physical settlement of bond forward trades, a new bond trade is created on the bond forward fixing date and
contains the following information:

• Notional

• Currency

• ISIN/bond identifier
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• Trade price: The bond price on the fixing date

• Trade date: The fixing date of the forward

• Settle date: Trade date + bond settlement lag

• Book: Same book as the bond forward trade

• Bond maturity date

The settled bond trade id is linked to the original bond forward trade.

The traded price of the new bond is the spot price on the fixing date.

A fee with the settlement amount is set on the bond forward trade. It is calculated as Notional * (Forward Price - Spot
Price). The fee currency is in the bond forward settlement currency, and conversions are done accordingly.

The physical bond trade has the keywords BOND_FWD_PRICE_TYPE = CleanPrice and BOND_FWD_PRICE = <clean
price value>.

Tax Calculation
For physical settlement of bond forward trades, the resulting bond trade is created with the forward price, and the
following pricer measures are calculated if the counterparty requires tax calculation:

COL_TAX_BASIS = (Coupon Rate * Notional * Day Count) / Days + (1 - Clean Price) * Notional / (Days - Accrual Days)

COL_TAX = COL_TAX_BASIS * Tax Rate

The tax rate is set in the PO legal entity attribute BondIncomeTaxRate in the format n%, for example 4%.

The counterparty requires tax calculation if the CP legal entity attribute SelfWithholding.Bond = false.

For information on the associated accounting events, please refer to Calypso Accounting Events documentation.

20.4 Early Sett lement
Early settlement, whether full or partial, can be applied to both physical delivery and cash settled bond forwards.

Make sure that the transition VERIFIED - ROLLOVER - ROLLOVERED is configured in the trade workflow with Create
Task checked.

 Ⓘ [NOTE: You can only rollover a trade in VERIFIED status (out-of-the-box)]

From the Bond Forward Trade window, select Bond Forward > Roll Over to open the Bond Forward Rollover window.
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» The Rollover Date defaults to the fixing date of the bond forward, but you can modify it as needed.

» Select the Roll Type: Full or Partial.

» Modify the Rolled Fixing Date and/or Rolled Settle Date if needed.

» For partial early settlement, in the Notional field, enter the amount to be early settled. Otherwise, for full
settlement, this field is not editable.

Increasing the notional amount to greater than the original notional is not supported.

» Enter the agreed upon new clean price in the Agreed Clean Price field.

» In the Fee Report area, click Add to add a rollover fee if needed. Complete the fee details fields as applicable.

The Calculate button is not used for rollovers.

» Click Apply.

A new trade is created with the details specified in the Rollover window, including the new price and new fixing date.

For partial early settlement, two new trades are created, one for the notional and agreed clean price for the early
partial redemption, and the other for the remaining notional with the original trade terms.

The original trade is changed to status ROLLOVERED. The RolledOverTo keyword on the original trade shows the
trade id of the new trade(s).

The RolledOverFrom keyword on the new trade(s) shows the id of the original trade.

Any fee specified is attached to the original trade.

The new trade(s) can then be handled through the Bond Forward Exercise window for standard settlement based on
the fixing date(s).

See Standard Settlement for details.

20.5 Termination
The Bond Forward Termination window is used to handle full or partial termination of bond forwards.
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From the Bond Forward Trade window, select Back Office > Terminate to open the Bond Forward Termination
window.

» Modify the Termination Trade Date Time and/or Effective Date if needed.

» Select the Termination Reason.

Please refer to Calypso Termination documentation for details on termination reasons.

» For partial termination, select the "Partial" checkbox. Otherwise, leave it unselected for full termination.

» Enter the Termination (%) and the Notional will be calculated, or you can just enter the Notional amount.

» The Termination Action is defaulted to TERMINATE.

» In the Fee Report area, click Calculate to calculate the termination fee as applicable.

» You can click Add to manually add a termination fee if needed. Complete the fee details fields as applicable.

» Click Apply.

For partial early settlement, a new trade is created for the remaining notional.

The original trade is changed to status TERMINATED. The TransferTo keyword on the original trade shows the trade
id of the new trade.

The TransferFrom keyword on the new trade shows the id of the original trade.

Any fee specified is attached to the original trade.

The new trade can then be handled through the Bond Forward Exercise window for standard settlement based on the
fixing date.

See Standard Settlement for details.
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21. Capturing When-Issue and Re-Issue
Bond Trades
Prior to capturing a When-Issue or Re-Issue bond trade, you need to define a When-Issue or Re-Issue bond product.

See Defining Bond Products for details.

During the period between the announcement date and the auction date, Treasury coupon securities are considered
to be in "when issued" (WI) status and trading takes place by quoting a bond-equivalent yield.

The calculation of a dollar price (needed to establish the dollar value for the settlement date) from the bond-
equivalent yield requires that a coupon value be defined for the security. This is done by using an "assumed" coupon
value.

In order to propagate the assumed coupon value over the when-issue period, you can run the PROP_RATE_1BUSDAY
scheduled task. It requires a pricing env, holidays, and an attribute called "Quote Name Contains" (similar to the
Quotes Window). It will use the valDate and the "Quote Name Contains" to find the quotes to be propagated. You can
set the value of "Quote Name Contains" to "When-Issued.ExpectedCoupon".

21.1 Capturing When-Issue Trades

21.1 .1 Sample When- Issue Bond Trade
Navigate to Trade > Fixed Income > Bond to open the Bond Trade window, from the Calypso Navigator or from the
Trade Blotter.

The system expects an "assumed coupon rate" to be present, in order to calculate the trade’s price from the entered
yield - See "Pricing" below for details.
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The settlement date of WI trades is automatically set to the Issue date.

By default, WI trades are NOT eligible for liquidation to generate realized PL. They are marked to market individually.
This is true even if a Buy and a Sell for the same WI security exist in the same book.

You can however enable the liquidation of WI trades to generate realized PL using environment property
WHENISSUED_LIQUIDATION=true.

See Capturing Bond Trades for complete details on capturing trades.

Pricing
You need the following quotes to price the trade during the When Issue period (between the announcement date and
the auction date): The Bond's yield and the expected coupon.

For the expected coupon, you can enter the quote everyday, or you can use the PROP_RATE_1BUSDAY scheduled
task to copy the quote to the following day.

21.1 .2 Auct ion Process
When the coupon rate is announced for the WI security (on the auction date), you should follow the steps below.

To have the list of upcoming auction dates, you can run the Trade Diary (Reports > Trade Diary) with the Diary Type
"WI Auction".
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Step 1 - Update the Bond Product
Go to the Bond Definition window, and update the bond as follows:

» Enter the actual coupon rate in the Coupon panel.

» Change the quote type from Yield to CleanPrice in the Market panel, and uncheck the "When Issue bond"
checkbox.

» Save the bond.

After saving the bond, the system will ask you if you want to re-process affected trades. You can reply YES
(provided you have completed the workflow setup as described in Step 2), or you can reply NO and process the
trades later using the PROCESS_TRADE scheduled task or the Process Trades window.

If asked to reprocess affected Corporate Actions, reply NO.

You will be asked if you want to save the new Quote Type, reply YES.

The product code "When-Issued" is cleared on the Bond definition.

Step 2 - Update the Settlement Amount on the Existing Trades
You should first set up a workflow transition with the action: WI-PROCESS and the trade rule WhenIssuedProcess.
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Then run Processing > Process Trades (or the PROCESS_TRADE scheduled task), and apply the action WI-PROCESS.

Sample Process Trade Window
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Sample PROCESS_TRADE Scheduled Task

After applying the WI-PROCESS on the trade, the trade keyword "WI-Yield" stores the trade's original yield.

The trade's price is now shown as Clean Price, and the trade is no longer a WI trade.

21.2 Capturing Re-Issue Trades

21.2 .1 Sample Re- Issue Bond Trade
Re-Issuance trades are entered to Calypso in exactly the same way as any other trade. Note that the settlement date
cannot be prior to the Re-Issuance security’s Issue Date.
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Note that:

• Market Type shows ‘Re-Issue’

• The security name shows on the trade screen with ‘Re-Issue appended to it

As with WI trades, trades in a RI security are not liquidated against each other to generate realized PL. This is true
even if a Buy and Sell for the same RI security exist in the same book.

See Capturing Bond Trades for complete details on capturing trades.

21.2 .2 Ass imi lat ion Process
This is accomplished by using the scheduled task PROCESS_TRADE to convert Re-Issue trades to the assimilation
product.

This scheduled task should run during start of day processing (i.e. before the real-time day begins, but after the
business date has been rolled forward for the new business day), and the Trade Filter should specify ONLY Re-
Issuance trades.
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The scheduled task is set up as follows:

The Trade Filter setup is as follows:
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Note that only the Product(s) and the Market Type "Re-Issue" should be specified.

Re-Issue trades will be automatically modified (retaining the original trade id) to specify the original security in place
of the re-issuance security. The trade's audit trail information will reflect this change.

Re-Issue trades are assimilated into the original security at start of day on the business day prior to the Re-Issue date.

Please note that the Re-Issue process views "today" to be the date specified in the Legal Entity Attribute "ACC_
BUSINESS_DATE" in the Legal Entity Attributes of the Processing Org Legal Entity to which the Re-Issue trade's Book
belongs. If the Processing Org does not use "ACC_BUSINESS_DATE", then the Re-Issue process will view today to be
the server date.

To have the list of the upcoming Re-Issues, you can launch a Trade Diary with the Diary Type "Re-Issue".

Nasdaq Calypso
Fixed Income Trading / Version 18

February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 226 / 250



February 2025
Revision 7.0 / Approved

Proprietary and Confidential
Page 227 / 250

Nasdaq Calypso
Fixed Income Trading / Version 18



22. Capturing Bond Option Trades
This document describes how to capture bond option trades using the Bond Option worksheet.

Navigate to Trade > Fixed Income > OTC Bond Options to open the Bond Trade window, from the Calypso Navigator
or from the Trade Blotter.

Prior to capturing bond trades, you need to specify bond products using Configuration > Fixed Income > Bond
Product Definition.

See Defining Bond Products for details.

Bond Option Quick Reference

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» You can choose Pricing Env > Check to check if all required pricing data are available

in the Pricing Environment.

» Click Price to price the trade.

» You can hit F9, or choose BondOption > Solve to solve for the implied volatility.
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– Enter a target NPV and click Solve. It computes the corresponding volatility.

– You can click Apply to apply the volatility to the deal. It sets the pricing parameter
VOLATILITY on the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books and legal entities using Back Office >

Allocate.

» You can terminate the trade using Back Office > Terminate.

» You can exercise the bond option using Back Office > Exercise, or using the
AUTOMATIC_EXERCISE scheduled task.
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22.1 Sample Bond Option Trade

Bond Option Trade - Fields Details

Fields Description

Trade Details
Role / Cpty The first two fields of the worksheet identify the trade counterparty.

The first field identifies the trade counterparty’s role. The default role is specified using
Utilities > Set Default Role. However, you can change it as applicable.

You can select a legal entity of specified role from the second field provided you have set up
favorite counterparties. You can also type in a character to display the favorite
counterparties that start with that character. Favorite counterparties are specified using
Utilities > Configure Favorite Counterparties.

Otherwise, click ... to select a legal entity of specified role from the Legal Entity Chooser. You
can also type [Ctrl-F] to invoke the Legal Entity Chooser, or directly enter a Legal Entity
short name.
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Fields Description
Status Current status of the trade. The status is automatically assigned by the system based on the

workflow configuration.

The status will change over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Id

Ext Ref

Int Ref

Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load an existing trade by typing the trade id into this field, and pressing [Enter].

You can also display the internal reference of external reference. The default trade
reference can be selected in the User Defaults.

The internal reference and external reference can be set in the Details panel of the trade
worksheet.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
You can modify as applicable.

You can select a book provided you have set up favorite books. Favorite books are specified
using Utilities > Configure Favorite Books.

Otherwise, click ... to select a book.

The owner of the book (a processing organization) identifies your side of the trade.

Broker Displays the broker if a broker fee is captured in the Fees panel.

Template You can select a template from the Template field to populate the worksheet with default
values. Then modify the fields as applicable.

Underlying Bond Details
Product code

Product description

You can select a bond using one of the following methods: Product Code Selection or
Browser Selection, they are described below.

Once you have selected a bond, the value of the alternative product code is displayed in the
field adjacent to the Browse button. The alternative product code is specified in the User
Defaults.

You can click Show to view the details of the selected bond.

Product Code Selection
The product code defaults to the security code specified in the User Defaults. You can
select another product code as applicable.

Note that the Name product code searches the bond short names.

» Type in a few characters of the code value in the adjacent field.

The system searches all the bonds defined in the system, unless a quick entry template
has been specified, in which case the system only searches the bonds filtered by the
quick entry template.
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Fields Description
Also, if the environment property USE_SUBSTRING_IN_BOND_NAME_QUERY=true is
set, the system searches all the letters in the product code values. Otherwise, it only
searches from the start.

The bonds that satisfy the request are displayed in a list.

» Select a bond from the list.

Browser Selection
Click Browse to select a product from a user-defined bond browser. See Defining Bond
Browsers for information on creating bond browsers.

» Select a report template to display the corresponding bonds, and double-click a bond
from the list to select it.

If you do not have report templates, simply click Search to browse all existing bonds.

You can right-click any column and choose Configure Columns to customize the display.

Liquidity Enter the liquidity factor of the bond.

Option Details
BUY/SELL Direction of the trade from the book’s perspective. Double-click the BUY label to switch to

SELL as applicable.

CALL/PUT Direction of the option. Double-click the CALL label to switch to PUT as applicable.

Exercise Type Select European or American.

Style Only VANILLA is available.

Delivery Type Select the delivery type: Mix, Cash or Physical.

Auto Exercise Check the “Auto Exercise” checkbox to allow automatic exercise. Bond options can be
automatically exercised using the AUTOMATIC_EXERCISE scheduled task, provided they are
in-the-money.

Otherwise, choose Back Office > Exercise to exercise the option. Help is provided from that
window.

Expiry Date Enter the expiration date. It is also the last exercise date for American options.

Delivery Date Enter the delivery date. It defaults to Expiry Date + bond’s Settle Days.
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Fields Description
First Ex Date This field is only active for American options.

Enter the first exercise date.

Expiry Time Enter the time at which the option expires, in the selected timezone.

TimeZone Select the timezone for the expiration time.

Holidays Click ... to select holiday calendars.

Notional Enter the notional amount of the underlying bond.

Currency Select the currency you are using to buy or sell.

Strike Enter the strike price.

Quote Type Select the quote type of the strike price. It defaults to the quote type of the selected bond.

Note that the strike is always considered as a dirty price.

Price Enter the option price.
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23. Capturing Issuance Trades
An issuance trade allows configuring issues offered by a processing org.

To configure an issuance trade, navigate to Trade > Fixed Income > Issuance (menu action
trading.TradeIssuanceWindow).

Issuance Quick Reference

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» You can choose Pricing Env > Check to check if all required pricing data are available

in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books and legal entities using Back Office >

Allocate.

» You can terminate the trade using Back Office > Terminate.

» You can apply corporate actions using Trade Lifecycle > Corporate Action > Corporate
Action, or using the CORPORATE_ACTION scheduled task.
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23.1 Sample Issuance Trade

Issuance Trade - Fields Details

Fields Description
Cpty Trade counterparty. It will control the settlement and delivery instructions of the trade.

The Trade counterparty is a Legal Entity. The default role is Counterparty, however, you can
change this role as applicable. Double-click the Counterparty label to change the role. You
will be prompted to select a role.

You can select a legal entity of specified role provided you have set up favorite
counterparties. You can also type in a character to display the favorite counterparties that
start with that character. Favorite counterparties are specified using Utilities > Configure
Favorite Counterparties.

Click ... to select a legal entity of specified role from the Legal Entity Chooser. You can also
type Ctrl-F to invoke the Legal Entity Chooser, or directly enter a Legal Entity short name.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.

The processing org of the book identifies the processing org of the trade.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.
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Fields Description
The status will change over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Id

Ext Ref

Int Ref

Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load an existing trade by typing the trade id into this field, and pressing [Enter].

You can also display the internal reference or external reference. The default trade
reference to be displayed can be selected in the User Defaults.

The internal reference and external reference can be set in the Details panel of the trade
worksheet.

Issuance / Closing Type of trade.

Double-click the Issuance label to change to Closing as applicable.

Closing actually corresponds to ending the Issuance.

Product Click ... to open the Product Chooser window for selecting a bond.

The bond should have the following characteristics:

• The Issuer should be the processing org of the selected book.

• The Issue Paying Agent (IPA) should be populated. The IPA handles the coupon
payments for the issuer, and will be used in the corporate action process. SDIs should be
defined for the bond’s IPA for the IPA role.

You can click Show to display the bond’s details.

Security Id Type

Value

Defaults to the product code selected in the User Defaults, and displays its value.

You can select another product code as applicable.

Trade Currency Defaults to the bond’s currency.

You can select another currency as applicable.

Market type Defaults to Primary.

Price Enter the issue or closing clean price. The Dirty Price and Yield fields will be computed
accordingly.

Yield Displays the issue or closing yield.

Dirty Price Displays the issue or closing dirty price (price + accrual as applicable).

Prem/Disc Displays the issue premium discount (difference between the issue and the redemption
price).

Quantity Defaults to the issued quantity of the selected product.

Nominal Defaults to the issued nominal of the selected product.

The nominal should not be higher than the issued nominal.

FX Only applies when the settlement currency is different from the trade currency.
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Fields Description
Enter the FX rate between the settlement currency and the trade currency as needed.

Total Amt Displays the settlement amount in settlement currency.

Settle Date Settlement date of the trade.

The settlement date defaults to the trade date.

Double-click the Start Date label to apply the number of settlement days specified in the
selected product.

The settlement date uses the holiday calendar selected in the User Defaults to identify
business days.

You can modify the settlement date as applicable.

Settle Currency Defaults to the trade currency.

You can modify the settlement currency as applicable.

You can use the environment property USE_ISSUANCE_CCY. When true, transfers use the
product currency regardless of the settlement currency. When false, transfers use the
settlement currency. Default is false.

Accrual Accrual amount.

Commission % Percentage of issuance commission. This percentage will be applied to the position at the
time of coupon.

Use the Fee panel, if a commission has to be paid at the beginning of the issuance.

23.2 Issuance Posit ion
From the Calypso Navigator, navigate to Position & Risk > Positions to view the open position of the issuance,
provided the liquidation is running.

Note that the system creates an Issuance product linked to the bond, when the Issuance Trade is validated.

23.3 Issuance Corporate Actions
From the Calypso Navigator, navigate to Trade Lifecycle > Corporate Action > Corporate Action to generate
corporate actions. The Corporate Action window will appear as shown below.
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The characteristic of corporate actions on issuance trades is that they are generated on the Issuance product created
by the system and not on the bond of the issuance trade.

» Enter the start and end dates as applicable.

» Click Select Product and choose the Issuance product as shown below.

» Then click Generate to generate the corporate actions.

23.4 Closing an Issuance
You can close an issuance by entering a Closing trade on the bond using the Issuance window to buy back the bond.
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The Closing trade will liquidate the entire open position of the bond.
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24. Domiciliation
The Domiciliation module is used to help Banks with their domiciliation activity (i.e. carrying out of external issuances
for non financial institutions).

Contents

- Setup

- Domiciliation Process

- Domiciliation Report

24.1 Setup

24.1 .1 Setup of the Legal Ent i ty
First, add for the Legal Entity the role of Issuer, with the following attributes:

• COMMISSION — with the commission amount, the field should be filled in as CCY AMOUNT

• TAX — with the VAT percentage to be applied

Legal Entity Attributes Window

Second, you need to define your Processing Organization with the Role = Trustee in Configuration > Legal Data >
Legal Entities.
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Legal Entity Window

24.1 .2 Setup of the Bond Products
When you enter an issue for which your processing organization handles the domiciliation activity, you need to fill in
the Trustee with the name of the Processing Org.
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Once the commission has been generated for this bond, the Commission Paid flag will be switched to ON by the
system.

24.1 .3 Domain Values Setup
In order to automatically generate Simple Transfers of COMMISSION type, add the COMMISSION value to the
flowType domain:

24.2 Domici l iat ion Process
The Domiciliation process generates the Domiciliation commissions. It works through the Legal Entity and Product
setup.

From the Calypso Navigator, navigate to Trade Lifecycle > Corporate Action > Domiciliation to bring up the
Domiciliation window as shown below.
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» Enter search criteria as applicable and click Load to display the positions per issuer that need to be invoiced. If
some issues have already been invoiced, they will no longer appear in this window.

» You can check the amount of commission per issuer by right-clicking on each row to see details of the issues:

» If you agree with the amount of commission, check the Process checkbox and click Generate. This will generate a
Simple Transfer with the sub-type = COMMISSION.
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24.2 .1 Ut i l i t ies Menu
The menu items of the Utilities menu are described below.

Menu Items Description
Show Products To show details of the displayed position, product by product (same view as when you right-

click a row).

Show Trade To display the generated Simple Transfers.

Generate To generate the Simple Transfers for the rows with the Process checkbox checked.

Print

Print Landscape

To print the report.

Close To close the window.

24.3 Domici l iat ion Report
The Domiciliation Report displays products or trades for which a processing org is handling the domiciliation activity
(issuances for non financial institutions).

A product is qualified for domiciliation provided the Trustee is defined in the product definition (processing org of role
Trustee). A trade is qualified for domiciliation if the product is qualified for domiciliation.

The Domiciliation report can be launched from Reports > Securities Reports > Domiciliation Report either daily or
monthly or as frequently as you require.

Domiciliation Report

» Specify search criteria as applicable and click Load to load the corresponding products or trades.
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Check the By Trade checkbox to load qualified trades, or uncheck the By Trade checkbox to load qualified
products.

The Commission Paid checkbox should be checked if the domiciliation commissions have been generated.

» Click Print to print the report results.

» Click HTML to export the report results to an HTML page.

» Click Excel to export the report results to an Excel spreadsheet.

Fields Description
Issue Start / End Allows you to display the issues that are issued between the Issue start and the Issue end

dates.

For example, if you need to display for a given day the issues of the day, put the given day as
Issue Start and Issue End.

Maturity Start / End Allows you to display the issues that mature between the Maturity Start and End dates.

Processing Org Choose the Processing Org which is the Trustee of the issues.

Issuer You can either display all issuers or a specific one.

Including Commission
Paid

If you click on Commission Paid, the report will include the issues for which you already had
launched the invoice process.

Including Commission
Not Defined

If you click on Commission Not defined, the report will include the issues for which the
attribute Commission of the issuer is either not filled in or is wrongly filled in.

24.3.1 Tools Menu
The menu items of the Tools menu are described below.

Menu Items Description
New Refreshes the screen before launching a new report.

Load Same as the Load button at the bottom of the screen: displays the report.

Save as template Allows you to save your selection.

Load template Allows you to load a saved selection.

Delete template Allows you to delete a saved selection.

Show Product Goes directly to the Product Definition and displays the description of the chosen product.

Configure Columns Allows you to define the columns you wish to see in your report.

24.3.2 Domic i l ia t ion Report Resul ts by Product
You can click any column heading to sort the results based on that column.
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Product Details
Double-click a product to display its details.

24.3.3 Domic i l ia t ion Report Resul ts by Trade

You can click any column heading to sort the results based on that column.

Trade Details
Providing you add the Trade Id to the column configuration, you can double-click a trade to view its details.
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25. Eligible Securities Messages
You can generate reda.025 messages to request the eligibility of securities for auto-collateralisation, and integrate
reda.028 messages to obtain the status of the request.

25.1 Setup Requirements

25.1 .1 Domain Values

Domain "MX.Versions"

Value = reda.025.001.T2S

Domain "messageType"

Value = REDA025

Domain "Reda025CollatCurrency"

Value = <list of collateral currencies>

Example - Value = USD,DKK,EUR

Domain "Reda025Receiver"

Value = <receiver Swift code>

Domain "Reda025Sender"

Value = <sender Swift code>

Domain "Reda025OnTheFlyGateway"

Value = MX

Domain "incomingType"

Value = REDA028, Comment = POS_RECON
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25.1 .2 Stat ic Data F i l ter
You need to define a static data filter to select the eligible securities to be requested, with the currencies specified in
domain "Reda025CollatCurrency" and the ISIN codes.

Example:

Incoming Message Workflow for POS_RECON

25.2 Generat ing reda.025 Messages
reda.025 messages are generated using the scheduled task UPDATE_ELIGIBLE_SECURITIES.
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Attributes
• Eligible Securities Filter - Select a static data filter that contains the eligible securities to be requested.

• Sender - Select a processing org - The Swift code must match the code defined in domain "Reda025Sender".

• Receiver - Select a counterparty - The Swift code must match the code defined in domain "Reda025Receiver".

• Address Type - Select the SWIFT address type.

• Gateway - Select the gateway defined in domain "Reda025OnTheFlyGateway".

Sample Message
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25.3 Integrat ing reda.028 Messages
You can integrate reda.028 messages using the scheduled task MESSAGE_MATCHING to obtain the status of
request.

The incoming reda.028 message is linked to the outgoing reda.025 message using the message attribute
MessageRef = Tag <CollDataStsAdvc><OrgnlMsgId><Id>, which should be the Message Id of the reda.025 message.

The message attribute ReturnStatus (Tag <CollDataStsAdvc><StsRsn><Sts>)

indicates the status of the request:

COMP - Creation completed

QUED - Creation queued

REJT - Creation rejected
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