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Introduction

The Calypso Reuters RFA Module serves as a connector component which integrates Calypso with Refinitiv Real-
Time-Optimized (RTO), so that Calypso can capture market data sending from RTO cloud.

The module also supports entitlement check by EMA Open DACS Entitlement when user subscribes market data
from RTDS (Refinitiv Real-Time Distribution System) (formerly TREP (Thomson Reuters Enterprise Platform)).

This user guide covers the installation and configuration of the Calypso Reuters RFA Module.
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Refinitiv Components Setup

2.1 Refinitiv Real Time Optimized (RTO)

Please ensure that access to RTO cloud instance is available for connectivity.

Calypso will connect to RTO and CIAM enabled RTO using EMA library.

2.2 Refinitiv Real-Time Distribution System (RTDS)

Please ensure that the RTDS is installed and configured properly.

Calypso can also connect to the Advanced Distribution Server (ADS) in the RTDS, using EMA library.

2.3 DACS Server

For users who require Open DACS Entitlement, please ensure that the DACS Server is installed and configured
properly. Refer to the corresponding document for Reuters installation details.

Calypso will connect to the DACS Server at dacs_lib port.

2.4 EMA Configuration

You can configure EMA properties in calypso_ema_config.xml

For more details on the EMA Configuration, please refer to the Refinitiv documentation (EMAJ_ConfigGuide).
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Calypso Setup

3.1 Installing Calypso Reuters RFA Module and Refinitiv Libraries
Please install the Calypso Reuters RFA interface.

Update the Calypso database by running Execute SQL. When you run Execute SQL as part of your installation, the
Reuters RFA schema file (ReutersRFASchemaData.xml) is already loaded.

3.2 Modes of Usage

Calypso provides two modes of accessing market data from an external source, which are direct client access and
access through Calypso Market Data Server.

For direct client access, Calypso client applications (e.g. Feed Quotes Window in Navigator) connect directly to
RTDS/RTO and handle incoming market data items.

For access through Calypso Market Data Server, Calypso client applications (e.g. Trade Window in Navigator)
connect to the Calypso Market Data Server for market data. In this mode, the Calypso Market Data Server
connects to the RTDS/RTO and handles incoming market data items.

Configurations for the two modes will be introduced in the next sections.

3.3 Direct Client Access

3.3.1 Domain Value (Feed Type)
Ensure that EMA and EMAOpenDACS exist in the “feedType” domain.

3.3.2 Feed Configuration

From the Calypso Navigator, navigate to Configuration > Market Data > Feed Configuration. You can click Load to
load existing feed configurations. The image below displays a sample configuration for EMA.
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&\ FeedConfig Window X
Name |[EMA_RTO_FEED Type  EMA ~ | [ Is Default
Name Value
ConfigFileName calypso_ema_config.xml
ConsumerName Consumer_RTO
UserName GE-A-00495411
Password 000000000000
Clientld d06234d2a74b42f79516b3a28
ClientSecret 000000000000
Q FeedConfig Window >
Name EMA_TREP_ODACS Type | EMAOpenDACS ~ | O Is Default
Name Value
ConfigFileName calypso_ema_config.xml
ConsumerName Consumer_TREP
UserName calbode
Password 000000000000
Clientld
ClientSecret o000000OOGOS

QUOTE_AGE_OUT_DAYS (Default 0)

Enter a feed name in the Name field, and select EMA from the Type field (or EMAOpenDACS if you would like to use
Open DACS for entitlement check).

The Name is a way to refer to the feed within Calypso and Calypso configuration files.

Tip: If you already had a Reuters Feed configured to use the earlier Calypso Reuters feed type, load it and select
EMA from the Type field to replace the Reuters type to avoid re-configuring the feed addresses.

Set the parameters as applicable.

ConfigFileName: The location of the EMA configuration file previously created. This location is with respect to
the CLASSPATH as it will be retrieved using the Java ClassLoader. For example, if the EMA configuration
file path is <calypso_dir>/client/resources/ema_config.xml, fill ema_config.xml in the field.

ConsumerName: The name of one of the Consumers defined in the EMA configuration file. This is used by EMA
to determine the connectivity details to use for this particular client. Please refer to the sample EMA
configuration file for consumer names defined in the configuration file.

UserName: Machine account username required across RTO enabled with Version 1 Authentication (also known
as “oAuthPasswordGrant” or “V1 Password Credentials”.

Password: Machine account password required across RTO enabled with Version 1 Authentication.

Clientld: Service Account client ID required across RTO enabled with Version 2 Authentication (also known as
“oAuthClientCredentials” or “V2 Client Credentials”.

ClientSecret: Service Account client Secret required across RTO enabled with Version 2 Authentication.

QUOTE_AGE_OUT_DAYS: The number of days for a particular quote stored in Calypso to be "aged out" (the
default value is 0). If the stored quote has lasted longer than the number specified in this field, the
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entitlement check will be bypassed and it will be available to every Calypso user (applicable to
EMAOpenDACS feed only).

You can check the “Is Default” checkbox to make this feed your default feed source. Click Save to save the
changes.

To enable Open DACS Entitlement for the feed, please also add the feed name to the domain
“EntitlementCheckFeed”.

[NOTE: This only applies to feeds of type EMAOpenDACS]

3.3.3 Feed Addresses

The Feed Address Window allows mapping Calypso quote names to ELEKTRON quote names.

From the Calypso Navigator, navigate to Configuration > Market Data > Feed Address Mapping to bring up the
Feed Address window.

The following images show examples for feed address mapping (applicable to both feed type EMA and
EMAOpenDACS):

Q Feed Address Window - O X
Feed EMA_RTO_FEED v Quote Address FX.EUR.GBP
Quote Type | price v Feed Address ELEKTRON_DD|EURGBP=R * 1 + 0
Names Like Bid |BID Ask  ASK High |BID_HIGH_1 Last
Open |OPEN_BID Close Low BID_LOW_1 Date ACTIV_DATE
Addresses : Quote Address  Type  Feed Feed Address Mult Add BidName AskName Open Na
BRL/BM&F Corn/C A FX.EUR.GBP EMA_RTO_FEED |ELEKTRON_DD|EURGBP... 1 0BID OPEN_BID
BRL/BM&F Feeder FX.EUR.INR Price  |[EMA_RTO_FEED |[ELEKTRON_DD|EURINR... 1 0|BID ASK OPEN_BID
BRL/BM&F Live Ca FX.EUR.USD Price  |[EMA_RTO_FEED |[ELEKTRON_DD|EUR= 1 0[BID ASK OPEN_BID
BRL/Brazilian Yellc FX.USD.INR Price |[EMA_RTO_FEED [ELEKTRON_DD|INR= 1 0[BID ASK OPEN_BID
BRL/Hydrous Etha FX.USD.IPY Price |[EMA_RTO_FEED |[ELEKTRON_DD|JPY= 1 0BID ASK OPEN_BID
BasisFactor.LIBOR ¥
< > £ >
Refresh Load for Filter Load All Add Modify Feed Address Delete Close

Select the Feed Configuration that you have defined for EMA or EMA Open DACS from the Feed field.
Click Load All to display existing mappings (if you are using an existing Refinitv feed source).
Click Refresh to load the list of Calypso quote names.

You can filter the list by selecting a quote type from the Quote Type field and entering a search string in the Names
Like field (MM.USD.LIBOR for example).

To add a new mapping:

Select a Calypso quote name from the Addresses list.

Enter the corresponding EMA quote name in the Feed Address field. Enter a multiplier value and spread value
as applicable.
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The quote name can be in the format of [Service Name]|[|tem Name] (e.g. ELEKTRON_DD|EUR=).
Enter EMA instance names as applicable.

NOTE: The date that the system saves with the quote defaults to today’s date. However, you may want to save
a different date with the quote, such as yesterday’s date. You can map the date to a DATE field used by the
Refinitiv Market Data Feed. For example, ACTIVE_DATE, VALUE_DT1, VALUE_DT?2, etc.

For field details on Reuters Market Data Feed, please refer to FID lookup in Reuters website.

NOTE: Map Calypso price fields (Bid, Ask, Low, High, Open, Close, Last) to PRICE filed used by the Refinitiv
Market Data Feed.

Click Add.

Repeat for other quote names.

Here is a field mapping example:

Calypso Field Reuters Field Description

Bid BID Latest bid price

Ask ASK Latest ask price

Low LOW_1 Today's lowest trade price

High HIGH_1 Today's highest trade price

Open OPEN_PRC Today's opening price

Close HST_CLOS Most recent non-zero closing price

Last PRV_LAST The previous trading day's or session's last
value.

Date ACTIV_DATE The date when the time in TIMACT was
updated.

Copy Feed Addresses from Source feed to Target feed

Users can run the MIGRATE_FEED_ADDRESS_MAPPING Scheduled Task, which is available in 18 Aug24MR to copy
the feed address mappings from a source feed to a target feed.

Example ST configuration shown below will copy the Feed Address Mappings from ReutersRFA feed to RTO Feed.
ST parameters are explained below.
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Task Description

Task Type: MIGRATE_FEED_ADDRESS_MAPPING

External Reference: | Testing
Comments:
Description: | Testing

Execution Parameters
Aftempts: |1 Retry After: 0

JVM Settings: |-XmsS12m -Xmx1024m
Log Settings:

Task Notfication Options
[[] send Emails [ ] Publish Business Events

[=] Common Attributes
Task ID
Processing Org
Trade Filter
Filter Set
Pricing Environment
Timezone
Valuation Time Hour
Valuation Time Minute
Undo Time Hour
Undo Time Minute
Valuation Date Offset
From Days
To Days
Pricer Measures
Business Holidays

[=l Task Attributes
Source Feed
Target Feed
Include Feed Like
Exclude Feed Like
Service Name to Replace
Service Name Replacement

e Source Feed - Name of the Feed to copy the feed address mapping from.

e Target Feed - Name of the Feed to save/update the feed address mappings.

minutes

To User:

Expected Execution Time (SLA): |1 minutes

14120
PO

default

America/New_York

ReutersRFA
RTO
FX.EUR.USD*

|1on_ROF
ELEKTRON_DD

e Include Feed Like - Pattern to select the feed address mappings to copy. It is a mandatory parameter.

e Exclude Feed Like - Pattern to exclude the feed address mappings from copy.

e Service Name to Replace - Service name in the source feed to be replaced when copied to the destination
feed. It is an optional parameter, If blank, the feed address mapping will be copied as it is from source to

destination feed.

e Service Name Replacement - New Service name to use when saving the feed addresses to the destination

feed.

3.34 Define Calypso User Attributes for Open DACS

For users who require Open DACS Entitlement, navigate to Configuration > User Access Control > User Defaults
from the Calypso Navigator, and click on Attributes. The screenshot below shows a configuration example.
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& User Attributes Window calypso_user X
Name Value

Default Ad-Hoc Calculation Server RISKDEV A
Default Ad-Hoc Presentation Server RISKDEV

Default Dispatcher NONE

Default Pricing Grid Auto Update Dispatcher

EMA Open DACS Appld 450

EMA Open DACS Daemon hostname:8211

EMA Open DACS ForceUserNameLowerCase true

EMA Open DACS Retry Rate 10

EMA Open DACS Site SANFRANCISCO

EMA Open DACS UsagelLoggingType ALWAYS

EMA Open DACS User IP

EMA Open DACS User Mode N

EMA Open DACS User Name dacsuser v

Specify the following attributes.

Attribute Name Value

EMA Open DACS Appld

EMA Open DACS Daemon

EMA Open DACS
ForceUserNamelLowerCase

EMA Open DACS Retry Rate

EMA Open DACS Site

EMA Open DACS User IP

EMA Open DACS User Mode

Mandatory
DACS Application ID

Mandatory

Host name and port of remote DACS daemon

Flag to convert username to lower case before sending it
to DACS.

Default is false.

Time (in seconds) at which DACS Library will attempt to
reconnect to the DACS Daemon. Default value is 10.
Mandatory, alphanumeric.

Enter the name of DACS site used by this Calypso user.

Optional, IP address format.

The IP address of the machine used by the Calypso user. If
this field is left blank then local host IP address will be
picked up.

Mandatory. Accepts values of Y or N.

Y: This Calypso user is using EMA in User Mode.

User Mode is used when the EMA Feed Handler acts as a
client and connects to the feed directly. For example, from
the Feed Window in Main Entry.
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Attribute Name Value

EMA Open DACS Username

N: This user is using the EMA in Server Mode.

Server Mode is when the EMA Feed Handler acts as a
server to provide access for multiple clients who need
access to the feed. For example, the Market Data Server.

Optional, alphanumeric.
The DACS username of this Calypso user.

If this field is left empty, the corresponding Calypso
username will be used for DACS authentication.

If the Calypso user is not authorized for any subscription to
Reuters data items, it is suggested that a DACS user with
no item permitted is created first. Then set the DACS
username in this field. This setting can help avoid known
performance issue.

3.35 Debug Logging

To switch on debug logging for tracing issues, in Calypso user properties, set Yes for DEBUG, and add the
following categories (separated by comma):

EMA

EMAOpenDACS
EMAEventitem
EMAEventitemDetails

To avoid flooding log files with market data logs, the module supports writing market data log to the file at a certain
interval. Add REUTERS_RFA_LOG_INTERVAL to the Calypso user properties and give an integer value for the

logging interval (in seconds). Zero, negative, non-integer or empty value will disable this feature and all market data
logs will be written to the log file once they comes in.

.- REMOVE_LINKED_MSG_ON_ACK
# REUTERS_RFA_LOG_INTERVAL

@ RISKSERVER_NAMING_PROVIDER_URL

true

remote:lllocalhost:4647
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Logging and RTO Region configuration
Logging

User can enable logging for Reuters EMA module for debugging purpose. All we have to do is to add following
property in calypsouser.property.<env> file: calypso.logging.ema-logging-level.

If above property is not passed, still we will see error logs from EMA end for navigator, ST and riskServer. Example
usage of the property: calypso.logging.ema-logging-level=trace

The following are possible values for the above property:

Value Description

Trace FINEST logs which include region, request, client,
response, etc.

INFO Shows only INFO logs
ERROR Only Error logs
RTO Region

For cloud deployment, it is not always feasible to change calypso_ema_config.xml for RTO based EMA
configuration when user wants to use different region for different configuration.

Calypso now introduced a new property that can be added in calypsouser.properties.<env> to tackle the above
problem: calypso.feed.ema.configs.<feed-name>.rto-region

feed-name: It is the value that we give in Feed config window. For example, RTO_CIAM

A FeedConfig Window X
Name |RTO_CIAM Type EMA v | [[]1s Default

Mame Value

ConfigFileName :calypso_ema_confiu.xml

ConsumerName |Consumer_RTO

UserName

Password

Clientld =

ClientSecret

Save Save As Remaove Clear Close

The possible values can be as follows:

ap-northeast-1
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VEIE

ap-southeast-1
eu-central-1
eu-west-1
us-east-2

us-east-1

The usage of the property for above SS-1 screenshot Feed config can be as follows:

calypso.feeds.ema.configs.RTO _CIAM.rto-region=us-east-2

So, say if you have created feed configuration RTO_CIAM and given Consumer_RTO as the Consumer Name, it will
find the associated Channel name as Channel_RTO
s CUlloulle L -~
<Consumer>
<Name value=”Consumer_BTO"/>
<Channel value="Channel RTO"/>
<Dictionary value="Dictionary 1"/>
<MaxDispatchCountApiThread value="6500"/>
<MaxDispatchCountUserThread value="6500"/>

</Consumer>
<Consumer>
<!-— Name is mandatory -->
<Name value=”Consumer_LPC"/>
<!-- Channel is optional: defaulted to "RSSL SOCKET + localhc
<!l—— Channel or ChannelSet mav be snecified -->

Then it will locate Channel_RTO and replace region property with the property that was defined

<TcpNodelay value="1"/>
<Host value="colocalypsotrep.calypso.com" />
<Port wvalue="14009"/>
</Channel>
= <Channel>
<Name value="Channel RTO"/>
<ChannelType value="ChannelType::RSSL ENCRYPTED"/>
<CompressionType value="CompressionType: :None" />
<GuaranteedOutputBuffers value="5000"/>
= <!-- EMA discovers a host and a port from RDP service discovery for the specified location
- when both of them are not set and the session management is enable. -->
<Location value="us-east-2"/>
<EnableSessionManagement wvalue="1"/>
<ObjectName value=""/>
= </Channel>
| </ChannellList>
-</ChannelGroup>

If above property is not provided in the property file , then it will default to reading the region present in
calypso_ema_config.xml.
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As the property is feed-name dependent, please ensure the following tips:

Please avoid using spaces within the feed name.

Please take care of whitespaces in and around the feed-name

If it is a must to use spaces between , we discourage it and we recommend changing the feed name in
feed config window, but if it is not an option you can do following:

For example, if feed name is EMA RTO CIAM then calypso.feeds.ema.configs.EMA\ RTO\ CIAM=us-east-2

3.4 Access through Calypso Market Data Server

The entitlement service in Calypso system is responsible for entitlement check in this mode of usage.
Corresponding configurations will be introduced in this section.

3.41 Engine Configuration for Open DACS

For feeds of type “EMAOpenDACS”, add the feed name to the domain “EntitlementCheckFeed”, and the entitlement
service for the particular feed will be registered to the Entitlement Server.

£\ Domain Values — O >
.;:;?' Reload [ Save Q Save Al | 13| Constraints Setup (7}
Search (Cirl+0of 0@ @ | [] value
: Mame: |EntitementCheckFeed
Elj EntitlementCheckFeed P

_ Ot XFMA_TREP ODACS Value: EMA_TREP_ODACS
j Equity . Pricer

[ B === T WA B S

< >

W Comment:
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Subscribing to Quotes

4.1 Direct Client Access

You can use the Feed Window to check that you are receiving quotes from the feed source.

L4 Feed Window — O X
Feed EMA_RTO_FEED ~ | Pricing Env | default ~ | default Configure
Mame Containg Select All [ Auto Publish Every |0 (5ec)

BID [JAsk [FoPEN [ cLOSE FLast  [AHIGH [FLow [ DATE

Name Type  Address Bid Ask Open Close  High Low Last  Source Name  Price Source Date Entilement Check
[ELEKTRON_DD [EURGEP =R . |0 " o 0.8618...| 0.856... ... [ELEKTRON_DD|... [0117/2024 E |

. ELEKTRON_DDJEURI L 90.38 ./90.449 . k. 1T ... ELEKTRON_DD|... 0117/2024

FX.EUR.. [ELEKTRON_DD [ELUR.= | .| L0878 " 1.0884...| 1.085... _RTO_FE... ELEKTRON_DD|... [01/17/2024

FX.USD.INR. Price  [ELEKTRON_DD|INR = 83.0940...|83.1490...| 83.0570... 83.167... .0L.. EMA_RTO_FE... ELEKTRON_DD|... [01/17/2024

FX.UsD.JPY Price  [ELEKTRON_DD|JPY= 147.650...|147.680...| 147.180... 147.95...| 147.0... EMA_RTO_FE... ELEKTRON_DD|... [01/17/2024 N
Load Unsubscribe Subscribe Publish Publish Selected Close

From the Calypso Navigator, navigate to Market Data > Market Quotes > Feed Quotes to subscribe to quotes from
the feed source.

Select the Feed and Pricing Environment.

Click Load to load the feed addresses previously configured.

You can filter the list by typing a search string in the Name Contains field (MM.USD.LIBOR for example).

Select quote names as applicable (click to select one quote name, Ctrl-click to select multiple quote names).
You can also click Select All to select all the quote names.

Click Subscribe to subscribe to the quotes for the selected quote names.

The quotes will be populated accordingly if the system is configured properly and if the quotes are entitled to the
user.

To save quotes to the system, please use the SAVE_QUOTES scheduled task. The screenshot below shows a
configuration example of SAVE_QUOTES scheduled task for EMA Feeds.
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[ Task Description

Task Type: |SAVE_QUOTES

External Reference: |5Q1504201437
Comments: |SAVE QUOTES SCHEDULED TASK
Description: |SAVE QUOTES SCHEDULED TASK (Feed: EMA)

Execution Parameters

Attempts: |1 Retry After: |0 minutes  Expected Execution Time (SLA): |5 minutes

VM Settings: |-¥ms512m -¥mx1024m

Log Settings:

Task Notification Options

[]5endEmails [ ] Publish Business Events  To User: ~

[ Task Attributes ~
Feed EMA_RTO_FEED
Exdude Backdated Quotes False

Waiting Minutes

Wait For Maximum Time False
Indude Quote Names Like

Exdude Quote Names Like

BID True
ASK True
OPEN True
CLOSE True
HIGH True
Low True
LAST True
DATE True
Skip Existing Quotes False ]

For details on configuring a scheduled task, please refer to the Calypso User Guide for Scheduled Tasks.

In the direct client access mode, Open DACS Entitlement Check will happen in the Calypso component subscribing
to the quotes (e.g. Feed Window in Navigator, Scheduled Task).

Before making subscription, Calypso system will check whether the DACS user (defined in section 3.3.5) is
entitlement to the quote, based on the subject name of the feed address (Subject Based Entitlement, SBE).
Subscription will be submitted only if the user is entitled.

After subscription started, incoming market data items will be preceded by their corresponding entitlement
information. Calypso will submit the market data items together with the entitlement information to DACS Server
for checking (Content Based Entitlement, CBE). Calypso system will process the item only if the user is entitled.
For some cases, in which the entitlement information is not supplied by RTDS, the system will bypass CBE and the
item will be available to all users.

4.2 Access through Calypso Market Data Server
You can subscribe to real-time quotes using the Market Data Server.
You need to define a Market Data Server based on the feed that you have setup.

Sample market data server configuration:
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L% Market Data Server - O *
Configuration Mame: |RISKDEV R "I‘[}
Server Name: |RISKDEV w ""[;
Generation Policy: | RISKDEV ~ "i‘[}
Quote Source Mame: EMA_TREP_FEED R
Edit Maode Apply Close

You can then select the Market Data Server in the User Defaults attribute "Market Data Server Config” and start the
corresponding Risk Server to subscribe to the quotes.

Please refer to the Calypso Installation Guide for details on defining and starting risk servers, and refer to the
Market Data Server User Guide for details on using a Market Data Server.

In this mode, the entitlement service in Calypso system (section 3.4) will handle the Open DACS Entitlement Check.

When a market data item reaches the Calypso system (e.g. at Trade Window) through the Calypso Market Data
Server, the Calypso component receiving the item (e.g. Trade Window) will submit the item, entitlement information
and DACS user (defined in section 3.3.5) to the entitlement service for checking.

CBE, or SBE, or both will be done on the item, depending on the type of entitlement service supported by the
Reuters service supplying that item. The market data item will only be available for further processing if the user is
entitled.

Please refer to corresponding Reuters documentations on Open DACS.
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