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All content in this document is owned, or licensed, by Nasdaq, Inc. or its affiliates (‘Nasdaq’). Unauthorized use is 
prohibited without written permission of Nasdaq.  

While reasonable efforts have been made to ensure that the contents of this document are accurate, the document 
is provided strictly “as is”, and no warranties of accuracy are given concerning the contents of the information 
contained in this document, including any warranty that the document will be kept up to date. Nasdaq reserves the 
right to change details in this document without notice. To the extent permitted by law no liability (including liability 
to any person by reason of negligence) will be accepted by Nasdaq or its employees for any direct or indirect loss 
or damage caused by omissions from or inaccuracies in this document. 
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Overview 
The structured finance security market is characterized by a voluminous amount of static and dynamic data to 
define the securities and to derive cash flows for the securities. Intex Solutions, Inc. is a major supplier of security 
data and subroutines that may be employed to both define the securities and to derive cash flows under user-
supplied assumptions. Intex has amassed a database of over 20,000 structured deals and has been a leader in this 
field since starting business in 1985. Intex coverage includes the following asset classes: 

• Residential Collateralized Mortgage Obligations (Agency and Non-Agency CMO) 

• Asset Backed Securities (ABS) 

• Commercial Mortgage-Backed Securities (CMBS) 

• Pass-through Securities (Ginnie Mae, Freddie Mac and Fannie Mae MBS) 

• Collateralized Debt Obligations (CDOs, CBOs and CLOs) 

1.1 Organization of Intex Database 

Storage and management of the Intex database is the client’s responsibility. The database is typically stored locally 
on the client’s network. The actual content of asset classes and individual bonds in the client’s Intex database is 
negotiated between the client and Intex. Intex will deliver the agreed upon current data at the outset of your 
contractual arrangement and then decide to setup a Data Download process to obtain new deals and updates to 
existing deals. Typically, the client configures the Intex Data Download to take place daily before the 
commencement of any Scheduled Tasks that are dependent on Intex data. The Data Download is a relatively 
simple ftp process that also checks the integrity of the database to prevent the client from having an incomplete 
database from a missed download. 

There are two main directories in the Intex database. These are cmo_cdi and cmo_cdu. The cmo_cdi directory 
contains all the files that are created to describe a deal at its inception. This directory is organized into 
subdirectories that utilize the naming convention, yyMM. Within each subdirectory are deals that were issued 
during that month. These files typically employ the “.cdi” suffix. The IntexDealName.cdi files describe the original 
collateral assumptions, the bond characteristics, and the bond payment rules in sufficient detail to allow the Intex 
subroutines to calculate predictions of future cash flows. 

The cmo_cdu directory contains files and subdirectories. The subdirectories are also named using the convention 
of yyMM. Within each subdirectory, there are IntexDealName.cdu files that represent the updated information for 
a deal. Most deals pay monthly and therefore are updated monthly with new “.cdu” files. The most important 
information on the “.cdu” files are the updated collateral, the new bond factors and new interest rate resets on 
floating rate bonds. One must have all the historical “.cdu” files in order to accurately report the historical coupons 
and bond factors (unless these were available at one time and written to the Calypso database). For example, in 
order to report the last six month cash flows for a deal that started six months ago, one would need the “.cdi” file 
and the five “.cdu” files for the most recent five historical months. To report the last six month cash flows for a deal 
that started more than six months ago, one would need the original “.cdi” file and the last six months “.cdu” files. 
Note that the original “.cdi” file might be from many years ago; however, it is still necessary as it contains indicative 
data that the Intex subroutines must have to be able to generate cash flows. 
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Besides the yyMM subdirectories in the cmo_cdu directory, there is also an mbspools directory that contains all 
the data for the various agency pass-throughs. In addition, there are other files that are important to the cash flow 
generation process or integral to identification and classification. For instance, there are several CUSIP files that 
are constantly being updated by Intex with cross references for Intex Deal Names and CUSIP identifiers. 

1.2 Summary of the Intex Integration 

The Calypso integration with Intex does not only involve the Intex database. The Intex subroutines are necessary to 
interpret the Intex data and to be able to dynamically compute predicted cash flows for analysis, valuation, and risk 
management purposes. The integrated process between Calypso software and Intex software to produce cash 
flows generally follows this outline: 

• 1. Identify the bond via CUSIP, ISIN or INTEX_NAME. 

• Supply a future interest rate environment to the Intex Subroutines via Market Data and the Pricing 
Environment. This is necessary for any resets on underlying adjustable collateral and for resets on floating 
rate bonds. Indices that are most frequently required include 1-month LIBOR, 3-month LIBOR, 1-year CMT, 
Prime and 11th District COFI. 

• If desired, supply the other parameters that will directly affect the collateral and bond amortization. The 
most obvious parameter would be a Prepayment Quote or a Prepayment Curve. Many MBS, ABS and CMBS 
securities are backed by mortgage loans or home equity loans that have an uncertain amortization 
schedule. This is because the borrowers associated with the loans have an option to pay some or the entire 
outstanding principal earlier than required. Amortizing principal payments that are received earlier than the 
agreed minimum amortization schedule is referred to as “prepayments”. Additionally, Calypso will allow one 
to enter Default Curves and Recovery Curves. Default and recovery have the same meanings in structured 
finance as in the rest of the capital markets. Default means that the borrower has stopped making 
payments and recovery refers to the amount that the lender is able to recoup through foreclosing upon the 
property and a subsequent sale. 

• The Intex subroutines directly supply historical cash flows of principal and interest from which Calypso 
calculates historical amortization factors and coupons. 

• The Intex subroutines utilize the Market Data and Curves (Prepayment, Default, and Recovery) to calculate 
the future cash flows of the underlying collateral of the entire deal in which the bond in question resides. 
The Intex subroutines then allocate the cash from the collateral via the Intex-stored bond payment rules 
(also called the “waterfall”) to provide future principal and interest cash flows for the bonds in the deal. 
Again, Calypso calculates the predicted factors and coupons of the bonds from the principal and interest 
cash flows supplied by Intex. 

The Calypso software then has the cash flows to be able to do any analytical calculations that are requested, such 
as weighted average life (WAL), duration and convexity, etc. When interest rates or prepayment rates, etc. are 
perturbed to supply certain analytical measures, the process described above is repeated as many times as 
necessary to obtain different cash flow scenarios from the Intex Server. 

The Intex integration is supplied as an independent module. To use this facility, a customer must obtain the Intex 
Integration Module from Calypso and arrange for the delivery of Intex data directly with Intex Solutions, Inc. 
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General Installation 

2.1 Module Installation 

The Intex Integration module is installed as part of the Calypso Installer when you select the "Intex Integration" 
interface AND the “Structured Finance” optional module. 

It contains the runtime libraries required to access the Intex deal and cash flow models via the Intex subroutines. 
The Intex subroutines C library, however, is not distributed as part of this package. Customers must separately 
obtain and install the subroutines library from Intex. 

You also need to add the Intex libraries cmosub32.dll or cmosub32.so (Windows or Unix library) to the Calypso 
Installer. These libraries are obtained from Intex. 

  Please refer to the Calypso Installation Guide for details on using the Calypso Installer. 

2.2 Database Synchronization 

When you run Execute SQL as part of your installation, the Intex database files will be already loaded. 

2.3 Demo Data Set 

The Database Synchronization creates the following data elements in your database: 

• All the Domain Names and Values that are included in the Demo Data and are described below. This 
includes pricers that may be used with the BondAssetBacked Product in conjunction with Intex. These are 
“PricerIntexBondAssetBacked” and “PricerIntexComplexABS”. 

• Pricing parameters that may be used with the “PricerIntexBondAssetBacked” 
“PricerIntexCreditDefaultSwapABS” or “PricerIntexComplexABS”. 

• The intex_values and intex_bond_map tables required to store the configurable Intex-to-Calypso mapping 
values. 

• The basic mapping setup for calendar, legal entity, reset index, and seniority. 

• The default legal entity named “INTEX”, which will be used as the ABS bond issuer if the Intex issuer name 
is not mapped and does not exist in the Calypso database and if the INTEX_CREATE_ISSUER environment 
property is set to “False”. 

• A Security Code called “INTEX_NAME” in the domain values. This security code is a unique identifier using 
the Intex assigned deal name and tranche name. 

• The scheduled task “INTEX_UPDATE”. This scheduled task may be used to import periodic updates of Intex 
data into Calypso. 

• The exception types, “INTEX_INFORMATION” and “INTEX_EXCEPTION” generated by the Intex Server. 
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Setup 

3.1 Setting Environment Properties 

Set the following environment properties as applicable by using the User Environment file: 

Environment Property Description 

INTEX_CDI_PATH This is the path to the directory which contains the Intex files 
with the extension, “.cdi”. This directory must be named, 
“cmo_cdi”. The Intex “.cdi” files are the “initial” files that are 
published by Intex when the deal is first modelled. The “.cdi” 
files contain the static data for the deals and the information 
to be able to model the cash flows of all the bonds in the deal 
based on how the deal was originally structured, i.e. with the 
original collateral and with the original bond coupons, etc. 

INTEX_CDU_PATH This is the path to the directory which contains the Intex files 
with the extension, “.cdu”. This directory must be named, 
“cmo_cdu”. The Intex “.cdu files” are the “update” files that 
are typically published monthly by Intex. The first “.cdu” file 
for a new deal is published following the first payment date 
for the deal and typically monthly thereafter, depending on 
the payment periodicity of a deal. 

INTEX_CUSTOM_PATH Directory containing custom “.cdi” files for custom import. 

RMI registry port The RMI Registry Port, “8777” for example. 

INTEX_SERVER_RMI_PORT The same value as the RMI Registry Port. 

INTEX_SERVER_RMI_HOST The host computer on which the Intex Server is running. 

INTEX_LIBRARY_PATH This is the path to the directory which contains the Intex 
runtime libraries. 

INTEX_CREATE_ISSUER When a bond is imported from Intex, Calypso first tries to 
match the Issuer to a pre-existing Legal Entity matching on 
Short Name. 

If that fails and environment property INTEX_CREATE_ISSUER 
is set to True, Calypso creates the Issuer legal entity. 

If INTEX_CREATE_ISSUER is set to False, Calypso will use 
what is in environment property INTEX_DUMMY_ISSUER as 
the Issuer legal entity. 

If INTEX_DUMMY_ISSUER is not set, “INTEX” is used as the 
Issuer Legal Entity. 
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Environment Property Description 

INTEX_DUMMY_ISSUER If set, this will be used as the Issuer Legal Entity, depending 
on the logic described above under INTEX_CREATE_ISSUER. 

INTEX_CACHE_MAX_SIZE The number of deals to be held in cache (memory). 

INTEX_CDO_USE_PRECALC_AMORT_SCHEDULE True = the underlying CDOs in a CDO Squared will use a pre-
calculated amortization schedule to speed performance. 

False = the underlying CDOs in a CDO Squared will calculate 
all levels of the amortization schedules. This could take a 
significant amount of time. 

INTEX_ENGINE_MANAGER_NAME No longer used – Use STANDALONE_INTEX_SERVER_URL 
instead. 

For reference - Used to route client invocations to the create 
intexserver instance in the case that Intex is hosted on a 
separate engine server. 

This should be set to the Engine Manager Configuration 
created for hosting the Intex Engine in the environment file. 

For example, if the new Engine Manager Configuration is 
named intexserver, the setting should be 
INTEX_ENGINE_MANAGER_NAME = intexserver. 

STANDALONE_INTEX_SERVER_URL URL of the Intex Server. 

Alternatively, you can set the environment property 
STANDALONE_INTEX_RMI_BIND_ADDRESS on the server side 
to bind the remote object on a specific IP address. 

Sample configuration on a standalone PC: 

Environment Property Example Value 

INTEX_CDI_PATH C:\intex\cmo_cdi 

INTEX_CDU_PATH C:\intex\cmo_cdu 

RMI registry port 8777 

INTEX_SERVER_RMI_PORT 8777 

INTEX_SERVER_RMI_HOST  

INTEX_LIBRARY_PATH C:\calypso\software\release\modules\intex\lib\win32; 
C:\calypso\software\release\modules\intex\target\lib 

INTEX_CREATE_ISSUER True 
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Environment Property Example Value 

INTEX_DUMMY_ISSUER  

INTEX_CACHE_MAX_SIZE 200 

INTEX_CDO_USE_PRECALC_AMORT_SCHEDULE False 

3.2 Running the Intex Loader and Intex Server 

The Intex Server is started using “intexServer.bat” on Windows platforms, or “intexServer.sh” on *nix 
platforms.  

The Intex Server is used to compute forecasted cash flows for ABS bonds using the Pricer 
PricerIntexBondAssetBacked or PricerIntexComplexABS. 

The Intex Loader can be started from the Calypso Navigator, provided you add it to the menu using the Main Entry 
Customizer – menu action intex.IntexLoaderWindow. 

The Intex Loader may be used to import securities from the Intex Database either for the first time or for update 
purposes. During the import process in the Intex Loader, Intex data items are mapped to Calypso data items. The 
configurable value mapping from Intex values to Calypso values is described below. 

Note that the Intex Loader is not the only way to load Intex securities from the Intex database into the Calypso 
database. It is also possible to use the INTEX_UPDATE scheduled task or the Bond Product window. The 
integration process is described below. 

3.3 Domain Values 

Certain Domain Names and Domain Values are necessary for the proper functioning of the Intex Module. All the 
Domain Names are part of the Demo Data that is imported during the database synchronization (ExecuteSQL). The 
user will want to customize many of the Domain Values as their values will be specific to the client’s portfolio 
content and organization. The Domain Names and Values listed here are specific to the Intex module. If the Intex 
Module is used in conjunction with the Structured Finance Module, there will be additional Domain Names and 
Values that are documented in the Calypso Structured Finance User Guide. 

Domain Names and Values are accessed via Configuration > System > Domain Values. 

3.3.1 Deal Sector (ABSDeal.extendedType) 

Deal Sector is defined by ABSDeal.extendedType. Deal Sector is designed to be a sub-categorization of Deal Type 
(see next section). ABSDeal.extendedType populates the Deal Sector drop-down on the Intex Mapping Window so 
that Intex data may be mapped into this Calypso field. Deal Sector is displayed on the ABS Tab of the 
BondAssetBacked Product. If one is using the Structured Finance Module, Deal Sector is also viewable on the Deal 
Summary Panel of the Structured Finance Deal. 
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It is expected that the user will configure the Domain Values as needed; however, the Demo Data supplies the 
following Domain Values: 

• ABS 

• Aircraft 

• Auto Leases 

• Auto Loans 

• Credit Cards 

• Equipment Leases 

• Floor Plan 

• Franchise 

• High Yield Bonds 

• High Yield Bonds and Loans 

• High Yield Loans 

• Home Equity 

• Hybrid 

• Investment Grade Bonds 

• Large Commercial 

• Manufactured Housing 

• Marine 

• Mixed Properties 

• Motorcycle 

• Multifamily 

• Prime 

• Private Label US Agency CMO 

• Private Label Whole Loans 

• RV 

• Receivables 

• Small Business 

• Student Loans 

• Subprime 

• US Agency CMO 

• US Agency Pass Through 

3.3.2 Deal Type (ABSDeal.subtype) 

Deal Type is defined by ABSDeal.subtype. ABSDeal.subtype populates the Deal Type drop-down on the Intex 
Mapping Window so that Intex data may be mapped into this Calypso field. Deal Type is displayed on the ABS Tab 
of the BondAssetBacked Product. If one is using the Structured Finance Module, Deal Type is also viewable on the 
Deal Summary Panel of the Structured Finance Deal. 
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It is expected that the user will configure the Domain Values as needed; however, the Demo Data supplies the 
following Domain Values: 

• ABS 

• CBO 

• CDO 

• CLO 

• CMBS 

• RMBS 

3.3.3 Curves (absMktDataUsage) 

The absMktDataUsage Domain Name is used to define the four different curves that may be employed in pricing 
ABS securities. Usage of these curves is defined in Section 6.1 – Setting Market Data. These curves are Default, 
Delinquency, Prepayment and Recovery as defined by the following Domain Values that are supplied by the Demo 
Data: 

• DEFAULT 

• DELINQUENCY 

• PREPAY 

• REC 

3.3.4 Default Curve (absMktDataUsage.DEFAULT) 

This Domain Name defines the Default Curve. The following Domain Value is supplied in the Demo Data: 

• CurveDefault 

3.3.5 Delinquency Curve (absMktDataUsage.DELINQUENCY) 

This Domain Name defines the Delinquency Curve. The following Domain Value is supplied in the Demo Data: 

• CurveDelinquency 

3.3.6 Prepayment Curve (absMktDataUsage.PREPAY) 

This Domain Name defines the Prepayment Curve. The following Domain Value is supplied in the Demo Data: 

• CurvePrepay 

3.3.7 Recovery Curve (absMktDataUsage.REC) 

This Domain Name defines the Recovery Curve. The following Domain Value is supplied in the Demo Data: 

• CurveRecovery 

3.3.8 Collateral (BondAssetBacked.collateralType) 

BondAssetBacked.collateralType populates the Collateral drop-down on the ABS Tab of the BondAssetBacked 
Product. 
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It is expected that the user will configure the Domain Values as needed; however, the Demo Data supplies the 
following Domain Values: 

• Auto Loans 

• Commercial Home Equity Loans 

• Credit Card 

• Mortgages 

• Residential Home Equity Loans 

• Student Loans 

3.3.9 Pricers 

The Domain Name, BondAssetBacked.Pricer is used to define the three Pricers that may be used to price ABS. The 
following Pricer Domain Values are supplied in the Demo Data: 

• PricerBondAssetBacked (default pricer) 

• PricerIntexBondAssetBacked (Intex pricer) 

• PricerIntexComplexABS (complex Intex pricer) 

The Domain Name, CreditDefaultSwapABS.Pricer is used to define the pricers that may be used to price CDS ABS 
trades. 

• PricerCreditDefaultSwapABS (default pricer) 

• PricerIntexCreditDefaultSwapABS (Intex pricer) 

3.3.10 Bond Type (BondAssetBacked.subtype) 

Bond Type is defined by BondAssetBacked.subtype. BondAssetBacked.subtype populates the Bond Type drop-
down on the Intex Mapping Window so that Intex data may be mapped into this Calypso field. Bond Type is 
displayed in a drop-down on the Bond Tab of the BondAssetBacked Product. 

It is expected that the user will configure the Domain Values as needed; however, the Demo Data supplies the 
following Domain Values: 

• AUDMBS 

• CMO 

• IO (Interest Only) 

• PO (Principal Only) 

• Pass Through 

• Principal + Interest 

• Stripped 

Note that IO (Interest Only) and PO (Principal Only) are mandatory to be included as Domain Values if the portfolio 
contains IOs or POs as the BondAssetBacked Product uses this information in logic for calculating and displaying 
cash flows. 
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3.3.11 Import Data Level (IntexMapping.datalevel) 

The Domain Name, IntexMapping.datalevel populates the Import Data Level on the Intex Loader and the Intex 
Mapping Window. “Bond Only” would be used exclusively if the Intex Module is being used without the Structured 
Finance Module. If both modules are being employed, then all the methods would be available. The Domain Values 
supplied in the Demo Data are as follows: 

• ABS Deal 

• ABS Deal & Collateral 

• Bond Only 

3.3.12 Seniority (securityCode.DebtSeniority) 

The Domain Values of securityCode.DebtSeniority may be used on the Intex Mapping Window for mapping the 
Seniority from Intex data. The user may want to do this for customized use of this field; however, at present it is not 
employed in the standard Calypso functionality. 

It is expected that the user may configure the Domain Values as needed; however, the Demo Data supplies the 
following Domain Values: 

• LIEN1 

• LIEN2 

• LIEN3 

• SENIOR_SECURED 

• SENIOR_UNSECURED 

• SUBORDINATE 

3.3.13 Setting Missing Domain Names and Values 

If any of the above-mentioned Domain Names are missing or the user wishes to configure Domain Values, one may 
simply follow this example for the absMktUsage Domain Name and its Domain Values, “DEFAULT”, 
“DELINQUENCY”, “PREPAY” and “REC”: 

» Navigate to Domain Values via: Configuration > System > Domain Values. 

» Add the Domain Name “absMktDataUsage”. Click Save All. 

» Then click Load. 

» In the Domain Name “absMktDataUsage”, add the values “DEFAULT”, “DELINQUENCY”, “PREPAY” and 
“REC”. Each of these indicates that the item is a Default Curve, a Prepayment Curve or a Recovery Curve 
respectively. Click Save All. 

3.4 Setting Bond Templates and Product Codes 

The steps to set up a Bond Product are detailed in the Fixed Income User Guide. Depending on the mix of ABS and 
MBS securities of interest, there may be some specific default settings that are desirable to be set up in a Bond 
Template or perhaps several different Bond Templates for different market segments. Bond Templates may be 
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used to fill in defaults for some values that Intex may not provide. Examples of data items that Intex does not 
typically supply are Issue Price, Redemption Price and the number of decimals of precision and rounding rules for 
various numerical values. 

From the Calypso Navigator, navigate to Configuration > Fixed Income > Bond Product Definition to setup bond 
templates as needed. 

 

The Templates button in the upper right hand corner may be used to create a new Template or to load an existing 
Template. Specifically, the Templates button displays the following dialog: 
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From this window, you may: 

• Convert Defaults – Uses the current data on the Bond Product Window to create a Template. 

• Load Template – Brings up a list of previously defined Templates from which to choose to load. 

• Remove Template – Will delete a previously defined Template. 

• Save Template – Saves a new or modified Template. 

You may also save Product Codes as part of a Template. Product Code manipulation is explained in the Calypso 
Fixed Income Trading User Guide. 

From the Calypso Navigator, navigate to Configuration > Product > Code to define product codes: 

 

The Product Codes that are particularly relevant to ABS or MBS securities are CUSIP, INTEX_NAME and ISIN. If you 
open the “Codes” window from the Bond Product Window, you will have access to the specific codes for this bond: 
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Once one or several Templates for ABS or MBS securities are defined, they may be associated with the Product 
Type (aka Bond Class) and Product Subtype (aka Bond Type) in the Intex Mapping (described below). With the 
Template defined and associated in this manner, there is no need to load the Template when loading securities 
from the Intex database. This all happens automatically during the Intex import. 

3.4.1 Private Labeled Securities 

Private labeled securities may require a key code (password) provided by the dealer to allow pricing them. The key 
code must be entered in the Bond Product Definition window using the product code “DealKeyCode”. 
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Setting Intex Mapping Values 
The Intex Loader is used to map Intex values to Calypso values. To accomplish the mapping, the relevant Domain 
Values must already have been created. 

The mapping process is accessed via Intex Loader Window > Utilities > Intex Mapping Setup. 

Following this navigation will reveal the window pictured below. The two main mapping sections are Intex Values 
and Products. Many of the Intex mappings will be necessary for Intex without Structured Finance and there are a 
few mappings that are specific to Structured Finance. Rather than forcing the reader to flip back and forth between 
the Calypso Intex User Guide and the Calypso Structured Finance User Guide, this section, Setting Intex Mapping 
Values, is duplicated in its entirety in both guides. For clarity, the mapping values that are only available in the 
Structured Finance module are labeled as such. 

The mapping values are defined in alphabetical order, as they are listed in the Intex Mapping Window. 

 

4.1 Value Name 

A top level listing of all the mapping categories for Intex. The list is identical to the mapping categories in the 
window above. 

4.2 Calendar 

The Intex Calendar values must be mapped to Calypso Calendar values. As this is very standard, the relationship is 
frequently a mapping of identical values as in the New York City example shown below. 
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4.3 Collateral Loan Attributes 

This is an Intex Value Mapping that is specific only to the Structured Finance Module. 

These are the values that Intex assigns to the individual mortgage loan collateral. The codes along with their 
translations are as follows: 

• DC0 -- Other/Unknown 

• DC1 -- None 

• DC10 -- Mortgage Verification Only 

• DC11 -- Reduced 

• DC12 -- Underwriting Doc Incomplete 

• DC13 -- Program Violation 

• DC14 -- EZ/Simplified 
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• DC15 -- Alternative 

• DC16 -- Streamline 

• DC2 -- Full 

• DC3 -- Income, Asset & Mortgage Verification 

• DC4 -- Low/Limited 

• DC5 -- Income & Mortgage Verification 

• DC6 -- Income & Asset Verification 

• DC7 -- Asset & Mortgage Verification 

• DC8 -- Income Verification Only 

• DC9 -- Asset Verification Only 

• IC0 -- Other/Unknown 

• IC1 -- No Mortgage Insurance 

• IC10 -- Financial Guaranty 

• IC11 -- Foremost 

• IC12 -- GE 

• IC13 -- GMAC 

• IC14 -- Home Guaranty 

• IC15 -- Insured Credit Serv 

• IC16 -- Integon 

• IC17 -- Investor's Mtg Ins 

• IC18 -- Kodak 

• IC19 -- Liberty 

• IC2 -- Alaska Housing 

• IC20 -- Maryland Housing 

• IC21 -- MGIC 

• IC22 -- Mortgage Guaranty Ins 

• IC23 -- NYC Rehabilitation 

• IC24 -- PMI Mortgage Ins 

• IC25 -- Policy Holders Benefits 

• IC26 -- Republic Mortgage Ins 

• IC27 -- Ticor 

• IC28 -- Triad Guaranty Ins 

• IC29 -- United Guaranty 

• IC3 -- Amerin 

• IC30 -- US Mortgage Ins 

• IC31 -- VA 

• IC32 -- Verex Assurance 
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• IC33 -- Vermont Home Mortgage 

• IC34 -- Wisconsin Mortgage Assurance 

• IC4 -- California Housing 

• IC5 -- Cavalier 

• IC6 -- Commonwealth 

• IC7 -- Dupont 

• IC8 -- FGIC 

• IC9 -- FHA 

• LP0 -- Other/Unknown 

• LP1 -- Purchase 

• LP2 -- Refi-Cash Out 

• LP3 -- Refi-No Cash Out 

• LP4 -- Second Mortgage 

• LP5 -- Refi-Unknown Cash 

• LP6 -- Construction 

• LP7 -- Home Improvement 

• LP8 -- Purchase or Construction 

• LP9 -- Remortgage 

• LT0 -- Other/Unknown 

• LT1 -- Conventional 

• LT10 -- Non-Conforming 

• LT11 -- Subprime 

• LT12 -- Contract for Deed 

• LT13 -- Alt-A 

• LT14 -- FNMA 

• LT15 -- HELOC 

• LT16 -- Conforming 

• LT17 -- Jumbo 

• LT18 -- Commercial 

• LT2 -- FHA 

• LT3 -- VA 

• LT4 -- Conventional with PMI 

• LT5 -- Government (Unknown) 

• LT6 -- Affordable Housing Initiative 

• LT7 -- Consumer - Motorized 

• LT8 -- Consumer - Non-motorized 

• LT9 -- Multifamily 
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• OC0 -- Other/Unknown 

• OC1 -- Primary (Owner Occupied) 

• OC2 -- Secondary (Owner Occupied) 

• OC3 -- Investor (Non-owner Occupied) 

• OC4 -- Buy to Let 

• OC5 -- Business 

• PT0 -- Other/Unknown 

• PT1 -- Single Family Residence 

• PT10 -- Bungalow 

• PT11 -- Detached 

• PT12 -- Semi-Detached 

• PT13 -- Terraced 

• PT2 -- Condominium 

• PT3 -- Co-op 

• PT4 -- 2-4 Units 

• PT5 -- Townhouse 

• PT6 -- PUD 

• PT7 -- 5+ Units 

• PT8 -- Commercial 

• PT9 -- Manufactured Housing 

4.4 Collateral Statistic 

This is an Intex Value Mapping that is specific only to the Structured Finance Module. 

These are the values that Intex assigns to either summary collateral statistics or to individual collateral instruments. 
The codes along with their translations are as follows: 

• AbsSummaryInfo.1MO_ACCUM_NET_LOSS -- collat realizedloss%. 

• AbsSummaryInfo.1MO_ACCUM_NET_LOSS_RATE -- Sum of realized loss($) / original collateral bal($) in 
percentage. 

• AbsSummaryInfo.1MO_BANKRUPT_RATE -- Loans in bankruptcy, %. 

• AbsSummaryInfo.1MO_COLLAT_BAL -- Current collateral balance, $. 

• AbsSummaryInfo.1MO_CPR -- Annual prepayment rate, % CPR. 

• AbsSummaryInfo.1MO_DELINQ_30_PLUS -- Number of loans 30 plus days delinquent. 

• AbsSummaryInfo.1MO_DELINQ_60_PLUS -- Number of loans 60 plus days delinquent. 

• AbsSummaryInfo.1MO_DELINQ_90_PLUS -- Number of loans 90 plus days delinquent. 

• AbsSummaryInfo.1MO_FORECLOSURE_RATE -- %Loan balance in foreclosure. 

• AbsSummaryInfo.1MO_REO_RATE -- Loans in real estate offering, %. 
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• AbsSummaryInfo.1MO_WAC -- Gross collateral coupon, %. 

• AbsSummaryInfo.1MO_WAM -- Weighted average remaining term to stated maturity, months. 

• AbsSummaryInfo.3MO_CPR -- 3-month CPR, %. 

• AbsSummaryInfo.NUMBER_OF_LOANS -- Number of Outstanding Loans. 

• Current WAS 

• DSCR 

• LoanAttr.Asset Doc -- Loan documentation (full, limited, none, etc.). 

• LoanAttr.Asset Name -- Asset Name. 

• LoanAttr.Asset Purpose -- Loan purpose (purchase, refinance, cash out.). 

• LoanAttr.Insurer -- Insurer. 

• LoanAttr.Lein Position -- Lein Position. 

• LoanAttr.Loan Type -- Loan Type. 

• LoanAttr.Modification Code -- Loan Modification Code. 

• LoanAttr.Occupancy -- Occupancy Status. 

• LoanAttr.Property Code -- Loan Property type (single-family, PUD, condo, etc.). 

• LoanAttr.Servicer -- Servicer. 

• LoanData.APPR_VALUE -- Appraisal Value. 

• LoanData.APPR_VALUE_ASOF -- Appraisal Value As Of. 

• LoanData.ASSET_FREQUENCY -- Pay Frequency. 

• LoanData.ASSET_SUBTYPE -- Asset Subtype. 

• LoanData.ASSET_TYPE -- Asset Type. 

• LoanData.BORROW -- Borrower. 

• LoanData.CITY -- City. 

• LoanData.COUNTRY -- Country. 

• LoanData.CUSIP -- CUSIP. 

• LoanData.DEBT_SERVICE -- Debt Service. 

• LoanData.DEBT_SERVICE_ASOF -- Debt Service As Of. 

• LoanData.DEFAULT_FLAG -- Default Flag. 

• LoanData.DSCR -- DSCR. 

• LoanData.DSCR_ASOF -- DSCR As Of. 

• LoanData.EMERGING_MARKET -- Emerging Market. 

• LoanData.FICO -- Fico Score. 

• LoanData.FIX_FLT -- Fix or Float. 

• LoanData.FUNDED_STATUS -- Funded Status. 

• LoanData.HIRESBDTYP -- Hi-Res Bond Type. 

• LoanData.INDUSTRY_FITCH -- Fitch Industry Code. 

• LoanData.INDUSTRY_MOODY -- Moody's Industry Code. 
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• LoanData.INDUSTRY_S&P -- S&P Industry Code. 

• LoanData.INTEX_DEALTYPE -- Intex Deal Type. 

• LoanData.ISIN -- ISIN. 

• LoanData.ISSUER_CODE -- Issuer. 

• LoanData.LOANX -- LoanX Id. 

• LoanData.MATUR_DATE -- Asset Maturity Date. 

• LoanData.NOI -- Net-Operating-Income. 

• LoanData.NOI_ASOF -- As Of Date for Net-Operating-Income. 

• LoanData.ORIGINATOR -- Loan Originator. 

• LoanData.PAID_THRU -- Paid-through Date. 

• LoanData.PIK -- PIK. 

• LoanData.REGION_MOODY -- RATING: Moody Region. 

• LoanData.SPONSOR -- Sponsor. 

• LoanData.STREET -- Street Address. 

• LoanData.STRUCTURED_FINANCE -- Structured Finance Security. 

• LoanData.SYNTHETIC -- Synthetic. 

• LoanData.TENANT1 -- The three largest tenants. 

• LoanData.TENANT2 -- The three largest tenants. 

• LoanData.TENANT3 -- The three largest tenants. 

• LoanData.TIER1FLAG -- Tier 1. 

• LoanData.TIER2FLAG -- Tier 2. 

• LoanData.UW_APPR_VALUE -- Underwritten Appraisal Value. 

• LoanData.UW_APPR_VALUE_ASOF -- Underwritten Appraisal Value As Of. 

• LoanData.UW_NOI -- Underwritten NOI. 

• LoanData.UW_NOI_ASOF -- Underwritten NOI As Of. 

• LoanStat.Delinquency Status -- Delinquency Status. 

• PoolInfo.12MO_CPR -- historical 1 year prepay rate in CPR units. 

• PoolInfo.12MO_PSA -- historical 1 year prepay rate in PSA units. 

• PoolInfo.1MO_PSA -- historical 1 month prepay rate in PSA units. 

• PoolInfo.3MO_PSA -- historical 3 month prepay rate in PSA units. 

• PoolInfo.6MO_CPR -- historical 6 month prepay rate in CPR units. 

• PoolInfo.6MO_PSA -- historical 6 month prepay rate in PSA units. 

• PoolInfo.ARM: Gross Margin/Spread -- ARM: Gross Margin/Spread. 

• PoolInfo.ARM: Index -- ARM: Index. 

• PoolInfo.ARM: Life Cap -- ARM: Life Cap. 

• PoolInfo.ARM: Life Floor -- ARM: Life Floor. 

• PoolInfo.ARM: Payment Cap -- ARM: Payment Cap. 
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• PoolInfo.ARM: Payment Floor -- ARM: Payment Floor. 

• PoolInfo.ARM: Rate Formula -- ARM: Rate Formula. 

• PoolInfo.ARM: Rate Reset Period -- ARM: Rate Reset Period. 

• PoolInfo.Amort Type -- Amorization rule. 

• PoolInfo.Asset Age -- The number of months that have elapsed since the pool/loan was issued. 

• PoolInfo.Balloon -- Number of balloon months. 

• PoolInfo.Cashflow Stratification -- Collateral cash flow type. 

• PoolInfo.Coupon -- Coupon. 

• PoolInfo.Current Amort Term -- The Pools' weighted-average remaining term, in months. 

• PoolInfo.Current Balance -- Current Balance. 

• PoolInfo.Current Factor -- Current Factor. 

• PoolInfo.Current LTV -- Pools' current LTV, in %. 

• PoolInfo.Day Count -- Day Count. 

• PoolInfo.Gross Coupon -- Gross Coupon. 

• PoolInfo.Group Number -- Group Number. 

• PoolInfo.Is Balloon -- Is Balloon. 

• PoolInfo.Issue Date -- Asset Issue Date. 

• PoolInfo.Item Number -- Item Number. 

• PoolInfo.LIFE_CPR -- historical lifetime prepay rate in CPR units. 

• PoolInfo.LIFE_PSA -- historical lifetime prepay rate in PSA units. 

• PoolInfo.MSA -- MSA. 

• PoolInfo.Maturity Date -- Asset Maturity Date. 

• PoolInfo.Net Coupon -- Annual pass-through interest rate, in percent. 

• PoolInfo.Orig LTV -- Orig LTV. 

• PoolInfo.Orig Term -- Orig Term. 

• PoolInfo.Original Balance -- Original Balance. 

• PoolInfo.Original IO -- Original IO. 

• PoolInfo.PSA 1M -- historical 1 month prepay rate in PSA units. 

• PoolInfo.PSA 3M -- historical 3 month prepay rate in PSA units. 

• PoolInfo.PSA 6M -- historical 6 month prepay rate in PSA units. 

• PoolInfo.Property Type Stratification -- Property type. 

• PoolInfo.Region -- MSA Region. 

• PoolInfo.Rem Term -- Rem Term. 

• PoolInfo.Remaining IO -- Remaining IO. 

• PoolInfo.State -- State. 

• PoolInfo.State Stratification -- This field holds the pools' location in state/province. 

• PoolInfo.Unique Name -- Unique Name. 
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• PoolInfo.Zip Code -- Zip Code. 

• Source 

4.5 Columns 

Lists the columns that are viewable in the Intex Loader and able to be mapped. These are: 

• ASSETBACK_TYPE 

• COLLATERAL_TYPE 

• DEAL_CATEGORY 

• TRANCHE_TYPE 

4.6 Columns.ASSETBACK_TYPE 

Within the Intex subroutines, the Intex database is classified into three major classes: 

• CMOs - They are either Agency Issued with Agency Collateral or Private Label Issued with Agency 
Collateral deals backed by residential mortgages. The agencies are Fannie Mae, Freddie Mac or Ginnie 
Mae. 

• Whole Loans – This term has become a misnomer. The structured finance market has many examples of 
terms being invented and used for an original purpose that may evolve or blur over time. Some market 
participants may use the original meanings of these terms and other market participants may use different 
interpretations. It can be argued that Intex uses one of these variants for how it classifies “Whole Loans” at 
the database level. In Intex jargon, any deal that is not backed by agency collateral is considered to be a 
“Whole Loan” deal. 

• Pass-throughs (or “MBSPOOLS”) – These are securities that are issued by Fannie Mae, Freddie Mac or 
Ginnie Mae where the cash flows are not “structured” with rules. The cash flows of the underlying mortgage 
simply “pass-through” the structure to the bond holders. 

Intex provides data describing the underlying collateral types for all Whole Loan deals. We have provided a means 
to map the Intex descriptor values for these collateral types to configurable Calypso values. As of this writing, the 
available Intex values that are contained in the Intex data item, “icmo_assetback_type” are documented by Intex to 
be the following: 

Intex Values Description 

ICMOASSETBACK_LOAN Normal whole loans 

ICMOASSETBACK_CREDITCARD Credit card receivables 

ICMOASSETBACK_AUTOLOAN Car loans 

ICMOASSETBACK_HOMEEQUITY Home equity loans 

ICMOASSETBACK_MANUHOUSE Manufactured housing loans 

ICMOASSETBACK_FLOORPLAN Floorplans 
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Intex Values Description 

ICMOASSETBACK_EQUIPMENT Equipment loans 

ICMOASSETBACK_STUDENTLOANS Education loans 

ICMOASSETBACK_RECEIVABLES Receivables 

ICMOASSETBACK_COMMERCIAL Commercial mortgages (CMBS) 

ICMOASSETBACK_AGRICULTURE Farmer Mac loans 

ICMOASSETBACK_FRANCHISE Franchise loans 

ICMOASSETBACK_RV Recreation vehicle loans 

ICMOASSETBACK_MARINE Marine loans 

ICMOASSETBACK_MOTORCYCLE Motorcycle loans 

ICMOASSETBACK_AUTOLEASE Auto leases 

ICMOASSETBACK_AIRPLANE Airplane loans 

ICMOASSETBACK_CLO Collateralized loan obligations 

ICMOASSETBACK_HEALTHRECEIVABLES Healthcare receivables 

ICMOASSETBACK_CLN Credit linked notes 

ICMOASSETBACK_CDO Collateralized debt obligations 

ICMOASSETBACK_SMALLBUSINESS Small business loans 

ICMOASSETBACK_CONSUMER Consumer loans 

ICMOASSETBACK_TAXLIEN Tax liens 

ICMOASSETBACK_PROJECT Project loans 

ICMOASSETBACK_TIMESHARE Timeshare loans 

ICMOASSETBACK_STCD Single Tranche Credit Derivative 
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4.7 Columns.COLLATERAL_TYPE 

These are the collateral categories that Intex uses to describe the overall deal collateral. These collateral types are 
stored in the Intex field, “ICMOADDLINFO_COLLAT_TYPE”. 

Intex Values Applicable Group Description 

ABS CDO  

ABS/REIT CDO  

ALT_A Whole Loan, HEQ Alt-A and Alt-A-Minus loans. Alt-A loans are loans 
made to borrowers with good credit, but with non-
conforming underwriting ratios, limited documentation, 
or other characteristics which don't meet the 
standards for prime loans. Alt-A pools may have lower 
FICOs (700-730), higher LTVs (> 75), and higher 
percentages of loans with limited or no documentation 
(30-50%) than typical prime jumbo pool. Alt-A-minus 
loans fall between Alt-A and subprime. Alt-A-minus 
pools may have lower FICOs (660-700), higher LTVs (> 
80), and higher percentages of loans with limited or no 
documentation (>50%) than typical Alt-A pools. 

ARREARAGE Whole Loan, HEQ Previously delinquent loans restructured with an 
arrearage component. Newer arrearage deals are put 
on the HE database but a handful of older deals 
originally put on the WL database in the late 1990s are 
still classified as WL. 

Agency Multifamily CMBS  

CDO Securities CDO  

CDO Securities/ABS CDO  

CDO^2 CDO  

CMBS CDO  

CMBS/Loans CDO  

CMBS/Loans/REIT CDO  

CMBS/REIT CDO  

CRE CDO  

Conduit CMBS  
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Intex Values Applicable Group Description 

Development CMBS  

Emerging Market CDO  

Enterprise Franchise  

Equipment Franchise  

Fee Simple Franchise  

Fee Simple - 2nd Franchise  

Fusion CMBS  

Ground Lease Franchise  

HELOC Whole Loan, HEQ Home Equity Lines of Credit. These are normally kept 
on the HE database but some deals with mixed HE/WL 
collateral types exist. 

HIGH LTV HEQ First or second liens with combined LTVs greater than 
100% of property value (typically 115%-125%). 

High Yield CDO  

High Yield/CDO Securities CDO  

High Yield/Emerging Market CDO  

High Yield/Investment Grade CDO  

High-Grade Structured Finance CDO  

High-Yield Bonds CDO  

High-Yield Loans CDO  

Investment Grade CDO  

Investment-Grade Bonds CDO  

Kickout CMBS  

LOT LOAN Whole Loan Loans made on unimproved land 

Large Loan CMBS  

Lease-Backed CMBS  
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Intex Values Applicable Group Description 

Leasehold Franchise  

Loans to Microfinance 
Institutions 

CDO  

Long-Term Floating Rate CMBS  

MIXED USE HEQ Loans for mixed use buildings where the 
commercial/small business portion is small relative to 
the residential portion. 

Market Value CDO  

Mezzanine CDO  

Mezzanine Structured Finance CDO  

Middle Market CDO  

Military Housing CMBS  

Mixed CDO, CMBS  

Mixed - Conduit And Re-
Securitization Of One Conduit 
Deal 

CMBS  

Mixed - Fusion And Re-
Securitization Of One Single-
Borrower Deal 

CMBS  

Mixed - Seasoned Loan And Re-
Securitization Of Three 

CMBS  

Mixed - Short-Term Floating 
Rate And Re-Securitization Of 
Two 

CMBS  

NA Whole Loan, 
Franchise, HEQ 

Other/Unable to determine. 

NIM Whole Loan, HEQ Net Interest Margin, typically a resecuritization of 
residuals from other deals 

NON-CONFORMING   

NON-PERFORMING HEQ Sub-Performing and Non-Performing mortgages. 
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Intex Values Applicable Group Description 

PRIME Whole Loan Loans made to borrowers with good credit that 
generally meet the lender's strictest underwriting 
criteria. Intex may also classify some limited 
documentation pools made to very high-quality 
borrowers (typically with weighted-average pool 
FICOs of 740+) as Prime instead of ALT_A. 

Project Finance Loans CDO  

REIT CDO  

REPERFORMING Whole Loan Loans insured by the FHA/VA that were previously 
delinquent 

REREMIC Whole Loan Resecuritization of other securities of multiple 
collateral types. Note: resecuritizations will normally be 
tagged with the collateral type of the underlying 
securities, the "reremic" collat type will only be 
assigned to deals backed by multiple collateral types. 

RMBS CDO  

Re-Securitization - Agency 
Multifamily 

CMBS  

Re-Securitization - B-Piece CMBS  

Re-Securitization - Conduit CMBS  

Re-Securitization - Large Loan CMBS  

Re-Securitization - Mixed CMBS  

Re-Securitization - Seasoned 
Loan 

CMBS  

Re-Securitization - Swap CMBS  

Royalty Franchise  

SBA ASSISTANCE HEQ SBA Assistance loans. 

SCRATCH & DENT Whole Loan, HEQ May include many different loan types in one deal, 
including delinquent loans, re-performing loans, 
repurchases, loans with document or other 
deficiencies, and seasoned loans. Loans may either be 
acquired from various unaffiliated sources of the 
Seller, or may be loans originated by an affiliate of the 
Seller which do not conform to that Seller's standard 
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Intex Values Applicable Group Description 

guidelines for securitization. These are normally kept 
on the HE database but some deals with mixed HE/WL 
collateral types exist. 

SECOND LIEN Whole Loan, HEQ Second lien mortgages. These are normally kept on 
the HE database but some deals with mixed HE/WL 
collateral types exist. 

SLA/PPA CDO  

SMALL-BALANCE COMMERCIAL 
MORTGAGE 

HEQ, CMBS Small-balance commercial mortgages 

SUBPRIME Whole Loan, HEQ Loans to borrowers with poor credit, typically have 
weighted-average pool FICOs of 620 or less. These 
are normally kept on the HE database but some deals 
with mixed HE/WL collateral types exist. 

SYNTHETIC: INDEX HEQ, CMBS Synthetic indices such as the ABX index. 

Seasoned Loan CMBS  

Short-Term Floating Rate CMBS  

Short-Term Floating Rate Deals   

Single Borrower - Lease-Backed CMBS  

Single Borrower - Multiple 
Properties 

CMBS  

Single Borrower - Single 
Property 

CMBS  

Single-Borrower Deals   

Structured Finance CDO  

Structured Finance/REIT CDO  

Synthetic: ABS CDO  

Synthetic: ABS/RMBS CDO  

Synthetic: CDO Securities CDO  

Synthetic: CMBS CDO  
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Intex Values Applicable Group Description 

Synthetic: CMBS Commercial 
Pool - Mixed 

CMBS  

Synthetic: CMBS/REIT CDO  

Synthetic: Conduit CMBS  

Synthetic: Derivative Contracts CDO  

Synthetic: Emerging Market CDO  

Synthetic: High Yield CDO  

Synthetic: Investment Grade CDO  

Synthetic: Mezzanine CDO  

Synthetic: Mixed CDO  

Synthetic: REIT CDO  

Synthetic: RMBS CDO  

Synthetic: RMBS/CDO CDO  

Synthetic: Revenue-Backed CMBS  

Synthetic: Single Borrower - 
Multiple Properties 

CMBS  

Synthetic: Small-Balance 
Commercial Mortgage 

CMBS  

Synthetic: Structured Finance CDO  

Synthetic: Trust-Preferred CDO  

TIMESHARE HEQ Loans made on timeshare properties. 

Tax-ExempTrust-Preferred CDO  

Tax-Exempt CDO  

Unsecured REIT Debt CMBS  

VENDEE Whole Loan A "vendee loan" is a sale by the United States 
Department of Veterans Affairs on the credit terms of 
a residential property acquired following the 
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Intex Values Applicable Group Description 

foreclosure of a mortgage that was guaranteed by the 
United States Department of Veterans Affairs. 

4.8 Columns.DEAL_CATEGORY 

DEAL_CATEGORY (icmo_deal_category), as defined by Intex, may be one of the following seven choices: 

• 0- AGENCY_ADMIN 

• 1- PRIVATE 

• 2- WHOLE_LOAN 

• 3- POOL_MBS 

• 4- SWAP 

• 5- BOND 

• 6- DEBENTURE 

These are defined in Columns.DEAL_CATEGORY as seen below: 

 

In actuality, the only selections from this list that have relevance with ABS and MBS are AGENCY_ADMIN, PRIVATE, 
WHOLE_LOAN and POOL_MBS. Calypso does not support SWAP, BOND nor DEBENTURE. 
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4.9 Columns.TRANCHE_TYPE 

TRANCHE_TYPE (icmo_tranche_types) is defined by Intex as an array which concatenates the different applicable 
types for Principal Types, Interest Types, Residual Types, Whole Loan Class Types, and Agency Callable Types. As 
of this writing, the available Intex Tranche Types that are employed to describe the tranche characteristics are the 
following: 

Intex Principal Types 

Intex Types Description 

AD Accretion Directed 

AFC Available Funds Class 

AMZ Amortizing 

AS Accelerating Senior 

BUL Bullet Maturity 

CAC Controlled Amortization 

CMP Companion 

CPT Component 

EDC Extended Delay Class 

LIQ Liquid Asset 

MEGA Agency Mega, Giant or Platinum 

NAS Non-Accelerating Senior 

NIM Net Interest Margin 

NSJ Non-Sticky Jump 

NTL Notional 

PAC or PAC1 … PAC4 Planned Amortization 

PT Pass-Through 

RTL Retail 

SCH or SCH1 … SCH4 Scheduled Payments 

SEG Segment 
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Intex Types Description 

SEQ Sequential Pay 

SJ Sticky Jump 

SP Single Payment 

SPP Shifting Payment Percentage 

STP Pro 

SUP Support 

TAC or TAC1 ... TAC4 Targeted Amortization 

XAC Index Allocation 

 

Intex Interest Types 

Intex Types        Description  

AFC Available Funds Class 

ARB Ascending Rate Bond 

CAB Capital Accretion Bond 

CAP Fixed rate, but capped to collateral net rate 

DLY Float Delay 

DRB Declining Rate Bond 

EXE Excess 

FIX Fixed 

FLT Floating 

IDC Index Differential 

INV Inverse Floating Rate 

IO Interest Only 

PEN Prepayment Penalty tranche 
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Intex Types        Description  

PO Principal Only 

PRT Participating Tranche – receives excess interest 

PZ Partial Accrual 

SUB Equity tranche. Receives excess interest 

W Coupon related to collateral interest rate 

WAC Coupon related to collateral interest rate 

Z Accrual 

 

Intex Residual Types 

Intex Types Description 

NPR No-Pay Residual 

R Residual 

RES Residual 

RL Residual 

RS Residual 

 

Intex Whole Class Types 

Intex Types Description 

JUN Junior 

MEZ Mezzanine 

SPR Super Senior 

SEN Senior 

WAC_IO Weighted-average Coupon Interest Only 

XRS_IO Excess-Ratio Strip Interest Only 
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Intex Types Description 

XRS_PO Excess-Ratio Strip Principal Only 

 

Intex Agency Callable Types 

Intex Types Description 
 

CALLABLE With respect to a callable deal (FHL and GNM convention), a class of callable 
certificates or callable pass-through certificates representing the beneficial 
ownership of specified contributing assets, subject to optional redemption by a 
related call class. 

CALL With respect to a callable deal (FHL and GNM convention), a class of certificates 
representing the right to direct the agency to redeem a related callable class and 
to acquire the contributing assets underlying such callable class. 

REDEEMABLE With respect to a redeemable deal (FNM convention), a class of redeemable 
certificates representing the beneficial ownership of specified contributing assets, 
subject to optional redemption by a related redemption class. 

REDEMPTION With respect to a redeemable deal (FNM convention), a class of certificates 
representing the right to direct the agency to redeem a related redeemable class 
and to acquire the contributing assets underlying such redeemable class. 

RDM With respect to a redeemable deal (FNM convention), a class of redeemable pass-
through certificates representing the right to direct the agency to redeem a 
related redeemable class and to acquire the contributing assets underlying such 
redeemable class. 

 

Intex Other Types 

Intex Types Description 
 

FEE Trustee fee, financial guarantee, or other expense 

FG Financial Guarantee 

FND Reserve Fund 

NO Non-Offered 

OC Overcollateralization 

PP Private Placement 
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Intex Types Description 
 

RND Rounding Account 

RSV Reserve Fund 

SC  Structured Collateral 

 

The Tranche Types are defined in Columns.TRANCHE_TYPE, as partially shown below: 
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4.10 Legal Entity 

The Intex Issuers (icmo_deal_issuer) must be mapped to Calypso Legal Entities that have the role of Issuer and that 
have a status of being “Enabled”. One accomplishes this by first creating the Legal Entity in Calypso through the 
following navigation path: 

Configuration > Legal Data > Entities 

 

One can create new Legal Entities on this window, assign the role of Issuer and change the status to “Enabled”. For 
example, here is Fannie Mae as an Issuer: 
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Alternatively, if you are trying to look up previously created entities, one may use the Load button on this window 
and obtain a dialog window that allows the entry of the beginning of the Short Name, resulting in a list to choose 
from: 

 

After the Legal Entities are established, one sets up the mapping in the Intex Mapping Window. 

 

Note that the Intex mapping is presently case sensitive and that Intex does store the agencies in both mixed case 
and upper case, so there are two mappings in this example that associate to the Calypso Legal Entity, FANNIE 
MAE. 
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It is not always necessary to set up a Legal Entity as previously described. This is because there is a hierarchy in 
automatically associating an Issuer with a Legal Entity. The hierarchy is as follows: 

• When a bond is imported from Intex, Calypso first tries to match the Issuer to a pre-existing Legal Entity 
matching on Short Name. 

• If that fails and the environment property INTEX_CREATE_ISSUER is set to True, Calypso creates the Issuer 
Legal Entity. 

• If INTEX_CREATE_ISSUER is set to False, Calypso will use what is in the environment property, 
INTEX_DUMMY_ISSUER as the Issuer Legal Entity. 

• If INTEX_DUMMY_ISSUER is not set, the final default is “INTEX” is used as the Issuer Legal Entity. 

4.11 ResetIndex 

The Intex Reset Indices values have to be mapped to Calypso Indices values. 
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4.12 Seniority 

It may be desirable to designate the seniority of a bond separately from the Product Sub Type (Bond Type in the 
Bond Window). This may be accomplished by mapping the Intex Tranche Type to a Product Code called, 
DebtSeniority. Product Codes may be found in the center of the Bond Tab of the Bond Window. 

 

If one clicks on Codes …, the window below is displayed. This contains fields that are defined by the Product Code 
Window. In this instance, the most used Product Codes would probably be the CUSIP, DebtSeniority, INTEX_Name 
and the ISIN. 
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 Please refer to the Calypso Fixed Income Trading User Guide for how Product Codes are defined (see the section 
“Specifying Product Code Definitions”). 

The following Product Code Window displays which Product Codes are defined to be available for different 
Products. The Product Code may be accessed via Configuration > Product > Code. 
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The first step in structuring the mapping of Seniority is to define the DebtSeniority and securityCode.DebtSeniority 
Domain Values. These are illustrated in the window that follows. One navigates to these Domain Values via 
Configuration > System > Domain Values. 

 

The Intex values for the Tranche Type are mapped to the Calypso values for securityCode.DebtSeniority. 

In the following example, we have set up the Seniority values JUN, MEZ, SEN, SPR and SUB to map to the 
appropriate Calypso values which will appear in the Product Codes. 
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4.13 TestName 

This is an Intex Value Mapping that is specific only to the Structured Finance Module. 

Test Name may be used to map an Intex Test Name to a Calypso Test Name in a one-to-one or a many-to-one 
fashion. 

4.14 TestSubType 

This is an Intex Value Mapping that is specific only to the Structured Finance Module. 

These are the subtype values that Intex assigns to the various deal tests. The codes along with their translations 
are as follows: 

• 0 -- Unspecified CASHFLOW Test type. 

• 1 -- Interest coverage test. 

• 2 -- Over Collateralization test. 

• 3 -- Additional Coverage test. 

• 4 -- Delinquency test. 

• 5 -- Current Loss test. 

• 6 -- Cumulative Loss test. 

• 7 -- FG Draw test. 

• 8 -- Excess Interest test. 

• 9 -- Event of Default. 

4.15 TestType 

This is an Intex Value Mapping that is specific only to the Structured Finance Module. 

These are the type values that Intex assigns to the various deal tests. The codes along with their translations are as 
follows: 

• 0 -- Unspecified Test type. 

• 1 -- Test impacts the waterfall of cash in the structure. 

• 2 -- Test determines if current collateral portfolio meets predefined compliance measures. 

• 3 -- Test determines whether a new collateral item can be purchased into an existing portfolio. 

• 4 -- Test is expected to occur at some point (FAIL status is expected and does not indicate a negative 
condition). 
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4.16 Defining Products 

Mapping for Structured Finance and for Bond Asset Backed Products is a two-step process: 

First one maps the appropriate Intex values to Calypso values to define the Deal information. This is not a one-to-
one mapping of fields; but rather it is a group of three fields mapped to four attributes in Calypso. 

Specifically, the mapping is for the fields: 

• DEAL_CATEGORY 

• ASSET_BACK_TYPE 

• COLLATERAL_TYPE 

To: 

• Deal Type 

• Deal Sector 

• Import Data Level 

• Default Bond Template 

The Import Data Level that is chosen sets the default when this deal is fetched via the Intex Loader. One may use 
the Import Data Level drop-down to subsequently change this setting before the “Update” or leave it as the setting 
has been mapped. 

The Default Bond Template is the Bond Template that will be used to import and save the bonds associated with 
the deal unless one changes this in the next step. These are the bonds or tranches that are the liabilities of the 
deal. 

The instructions that follow will illustrate this mapping process to produce a product that has the following 
characteristics: 

• Deal Type = CDO 

• Deal Sector = High Yield Bonds 

• Import Data Level = ABS Deal & Collateral 

• Bond Template Name = intexdealdefault 

• Bond Type = CDO Senior Fixed 

In the next window picture, the following values: 

• DEAL_CATEGORY = WHOLE_LOAN 

• ASSETBACK_TYPE = CDO 

• COLLATERAL_TYPE = High Yield 

Have already been mapped to: 

Deal Type = CDO “CDO” is selected from a drop-down list 
defined by the Domain Value, 
ABSDeal.subtype. 
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Deal Sector = High Yield Bonds “High Yield Bonds” is selected from a 
drop-down list defined by the Domain 
Value, ABSDeal.extendedType. 

Import Data Level = ABS Deal & Collateral “ABS Deal & Collateral” is selected from 
a drop-down list defined by the Domain 
Value, IntexMapping.datalevel to be: 

ABS Deal 

ABS Deal & Collateral 

Bond Only 

Default Bond Template = intexdealdefault “intexdealdefault” is selected from a 
drop-down list of the possible Bond 
Templates that have been defined. 

 

For the second step, the tranche must be defined to be “Senior Fixed”. This is done by right clicking on the 
WHOLE_LOAN/CDO/High Yield Product entry and the button to choose to set a “New Tranche Type” is displayed: 
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Using this button supplies a new tranche entry that is to be defined: 

 

Use the ellipsis (…) next to TRANCHE_TYPE to select both the Tranche Types, SEN and FIX: 
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Change the Bond Type to CDO Senior Fixed, make sure the Bond Template Name is set to the desired value and 
“Add” it to the Product mapping list: 

 

This completes the definition of the mapping for a CDO – High Yield Bonds – Senior Fixed with the bond template, 
intexdealdefault. 



Nasdaq Calypso 
Intex Integration Guide / Version 17 - 18 

 

 

 

 

December 2022 Revision 12.0 / Approved Page 52 / 85 
Private and Confidential 

 

Importing Data from Intex 
You can import Intex bond data using the Intex Loader, using the INTEX_UPDATE scheduled task, or using the Bond 
Product window. 

The domain “Intex.IsLoadCollateralInfo” allows controlling which data is imported from Intex. When Value = false, or 
not set (default), the following information is not loaded: Collateral Info, Clear Structured Deal Stats and Collateral 
Group Stats. You need to set Value = true to import these data. 

5.1 Using the Intex Loader 

Bring up the Intex Loader using menu action intex.IntexLoaderWindow. 

 

You can click Test Connection to test the connection to the Intex Server. The log provides information about the 
connection. 

5.1.1 Whole Deal or Single Security Mode 

The Intex Loader is a separate process that may be used to import securities from the Intex database. The mapping 
from Intex values to Calypso values has already been illustrated in previous examples. This mapping facility is 
under the Utilities menu. 
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To import a single security: 

» Select the drop-down choice of CUSIP/ISIN (this is the default). 

» Enter either the CUSIP or ISIN of the security and click on the “Query” button. 

If the security is successfully fetched from the Intex database, the “Status” at the bottom of the window will read, 
“Query request completed successfully” and the single security line item will appear in the body of the window as 
illustrated below. 

 

To update the Calypso database with the information from the Intex database click Update. The “Status” will change 
to “Processing update request …” and then to “Update request completed successfully” if the update is successful. 

To import several bonds or all the bonds from an entire structured finance deal: 

» Select the drop-down choice of “Deal Name”. 

» Enter the Intex Deal Name and either hit Enter or click on the “Query” button. 

Note that once the bond list is displayed, you can “Select All” (the default), “Unselect All” or individually choose 
which bonds to update via the Selection checkbox. 

The window below shows the partial result from querying the Freddie Mac CMO with the Intex Deal Name, 
FHL2777. 
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Note that within the Intex Loader, you may double-click on any of the bonds and the Bond Window will display the 
information for that specific bond. 

In the examples discussed, the Import Data Level has been set to “Bond Only”. The other drop-down choices of 
“ABS Deal” and “ABS Deal & Collateral” are reserved for importing the entire Structured Finance Deal. To 
understand and use this capability, please refer to the Structured Finance User Guide. 

5.1.2 Bulk Loader 

Within the Intex Loader you can also import several securities from a file using the “Bulk load” tab. 

 

If you already know the path to a file that contains securities to be uploaded, then enter the path in the “Intex File” 
field and click Import. 

If you want assistance in generating the path to the file where you have stored the security identifiers, you may 
click Query and the following dialog window will appear: 

 

On this window, you may use the “Look in:” drop-down to help you browse and select the correct directory path to 
the import file that you have constructed. The import file must have the file extension, “.out”. An example of such a 
file follows. 

! Testing Bulk Loader Functionality 

! DealName,TranchName or CUSIP 

31393UY98 

FNM04001,GT 
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FNM04001,GU 

31393UZ22 

FNM04001,HA 

Note that an exclamation point (!) or a pound sign (#) at the beginning of a line designates that line as a comment. 
To import securities, you need to list the Intex Deal Name, followed by the Intex Tranche Name delimited by a 
comma or just the CUSIP. The sample file shows alternating between using the CUSIP or the Deal Name and 
Tranche Name. 

5.1.3 Custom Management 

The Custom Management functionality is used to manage custom “.cdi” files that are supplied by dealers. Clients 
may purchase newly issued securities that Intex has not yet modeled. Many dealers have specialized Intex 
software which enables them to model a deal and produce an Intex-compatible file, referred to here as the 
custom.cdi file. For the custom.cdi file to be used in the Calypso software, the file must be uploaded to a common 
folder that Calypso can access. The specific bonds to be traded are then updated in the standard fashion with the 
Intex Loader utilizing custom.cdi. 

When Intex has officially modeled the deal, there is a process within the Custom Management tab of the Intex 
Loader to “Reprocess” the custom.cdi to use the official Intex .cdi file name. That process enables the saved bonds 
to inherit the CUSIPs, ISINs, and INTEX_NAME from the Intex database. After reprocessing, the custom.cdi should 
be put in DELETED status. This is necessary because Calypso first looks in the directory for custom.cdi files before 
querying the Intex database for the official Intex .cdi file. If the filenames are the same, stale information may come 
from a cstom.cdi file that has not been deleted. To guard against reprocessed custom.cdi files not being deleted, 
check the “Delete on Reprocess” checkbox to have an automatic delete occur when a custom.cdi is reprocessed. 

When this box is checked, a Reprocess Action will automatically trigger a simultaneous Delete Action. The 
Reprocess Action is accomplished by checking the box to the left of the custom.cdi, entering the Official Intex cdi 
file name in the “New Deal Name” column and clicking on the double arrow in the window heading. The checkbox 
“Delete on Reprocess” will default to be checked on. The custom.cdi will be reprocessed and take on the 
“DELETED” status in one step. 

 

» Select the status to filter on from the “Show” dropdown: 

• To Be Reprocessed 

• Reprocessed 
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• Deleted 

• All 

» Click  to import Intex files from the directory specified in the environment property 
INTEX_CUSTOM_PATH. 

» Check “Delete on Reprocess” to guard against reprocessed custom.cdi files not being deleted by having an 
automatic delete occur when a custom.cdi is reprocessed. 

5.1.4 Rename Deal 

 

Intex may sometimes rename a deal, and if you have an existing trade using the old name, you will get an error from 
Intex saying “Deal Name has been renamed”. 

The “Rename Deal” tab allows updating a deal name and the tranches and copies the old quote values to the new 
quote name. 

5.2 Using the INTEX_UPDATE Scheduled Task 

You can also bulk load Intex securities in a scheduled task that may be timed to run after the Intex Auto Download 
has been completed. Follow the steps below to set up and automate the execution of the scheduled task. 

» Create the input file in the same format as the one for the Bulk Loader. 

» From the Calypso Navigator, navigate to Configuration > Scheduled Tasks > Scheduled Tasks. 

The Scheduled Task Window depicted below has been set up with a saved task. Detailed instructions on how to 
use this window may be found in the Calypso Scheduled Tasks User Guide. A simple summary to enter a basic task 
for Intex data would be as follows. 
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Select the “INTEX_UPDATE” task type. 

Appropriately set the Time Zone, Execution Time, From Days, To Days, Valuation Time, etc. 

The Static Data Filter may be used to select the bonds to be updated. If a Static Data Filter is used, it will take 
precedence and any Input File entered will not be used. You can create a Static Data Filter via 
Configuration > Filters > Static Data Filter. 

Enter the value for the Input Directory where the Input File may be found. Example “C:\calypso”. 

Enter the value for the Input File Name or Names. Example “CUSIP_BULK-RELEASE.txt”. Note that the file 
extension is the choice of the user and should be entered. You may enter more than one Input File Name 
delimited with commas. 

Save the task. 

 Note: The Calypso Scheduler must be running at the time that the Task is scheduled to execute, or it will 
not run. 
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5.3 Using the Bond Product Window 

5.3.1 Fetching an Intex Security from the Calypso Database 

When an Intex Security has already been saved to the Calypso database either via the Intex Loader or from the 
Bond Window itself, you may fetch the bond in the Bond Window. This is accomplished by the following steps. 

From the Calypso Navigator, navigate to Configuration > Fixed Income > Bond Product Definition. 

Choose the identifier that you want to use to fetch the bond via the Security Code drop-down menu. This will 
typically be either CUSIP, INTEX_NAME or ISIN. After entering the value for the Security Code, either just hit “Enter” 
or click Load to fetch the bond from the Calypso database. 

In the window which follows, the CUSIP, 31394WKJ6, has been used to fetch a Freddie Mac CMO PAC Floater. 
Since customized mapping has been configured, the Bond Tab displays the Bond Class to be BondAssetBacked, 
the Bond Type to be CMO PAC_FLT and the Issuer to be Freddie Mac. The Total Issued and other indicative data 
are also displayed. Note that the Comment provides the last date and time that this bond was updated from the 
Intex database. 

 

Alternatively, you can use the INTEX_NAME or the ISIN to fetch the bond. The format for the INTEX_NAME is Intex 
Name-Tranche Name. For this example, the INTEX_NAME is “FHL2777-FD”. For this purpose, the INTEX_NAME may 
be entered in upper case or lower case. 

You can click Help for complete details on the Bond Window. However, it might be useful here to point out some of 
the tabs in this window that are populated by Intex data when an Intex security is fetched, thus alleviating the user 
from the task of hand entering most of the security static data. 
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The next window shows the Coupon Tab pre-filled with Intex data. It is obvious that the security in the example is a 
monthly floater, resetting off the 1-month USD LIBOR index with a spread of 30 basis points. All of the details in the 
following example were supplied by the Intex database. 

 

The other major panel where you can view data that has been populated from the Intex database is the ABS tab. 
This tab is only enabled for bonds of class “BondAssetBacked”. 

 

The ABS Tab has essentially four sub-panels, i.e. ABS Identification, Principal Payments, Quotes, and the Factor 
Schedule. 
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ABS Identification 

This section provides the Series, Class and Collateral Groups for all structured finance securities sourced from 
Intex. 

The Series provided is how the information is stored in Intex. Most of the time this will not be just the official series 
as denoted on the prospectus, but it will be Intex version which usually contains a prefix to identify the issuer. For 
the example of CUSIP, 31394WKJ6, Intex publishes the series to be FHL2777, indicating Freddie Mac as the issuer 
of the 2777 series. Since the issuer information is captured elsewhere, the user may choose to edit this field to just 
contain the official series of “2777” and save that information. This field is mandatory. 

The Class displayed is the official class (or tranche) of the security as denoted in the prospectus or private 
placement memorandum. For an essentially one-class security, such as a pass-through, this field is populated with 
a “1” as supplied by Intex. This field is mandatory. 

The Groups field displays the name(s) of the collateral group(s) that contribute cash flows to the bond identified. 
The collateral group or groups are the Intex names, which are usually identical or like the names that one would see 
in the prospectus. For a pass-through, the Groups field is pre-filled with a “0” because there are no collateral group 
distinctions with pass-throughs. 

The Collateral field is populated by loading in an Intex Security if the Category is WHOLE_LOAN and the user has 
mapped the Columns.ASSETBACK_TYPE to a Calypso Value that is also listed as a Domain Value in the 
BondAssetBacked.collateralType domain. Intex does not use the Asset Backed Type field to describe the collateral 
for any deal that does not have the Category, WHOLE_LOAN (Deal Category = AGENCY_ADMIN, PRIVATE or 
POOL_MBS). This means that for AGENCY_ADMIN, PRIVATE and POOL_MBS, the user may have to supply the 
Collateral field value, if desired, by editing and saving it on this window. 

If the Collateral field did not successfully map by using Columns.ASSETBACK_TYPE, then Calypso attempts to use 
a mapping in Columns.COLLATERAL_TYPE. If the security being imported has an Intex value in 
Columns.COLLATERAL_TYPE and it maps to a Calypso value that is also listed as a Domain Value in the 
BondAssetBacked.collateralType domain, then that Calypso value is used to populate the Collateral field. 

Principal Payments 

This section describes attributes of the principal payments of the bond. 

The Schedule Types may be Fixed Schedule, Variable or Variable Schedule. For ABS and MBS securities, this is 
most often set to Variable. 

Factor Delay Days is for the convenience of the user to enter the number of days between the Payment Date and 
the publication of the Factor. This field is not provided by Intex. 

The Principal Fraction is set to 100% for all bonds that pay principal and especially for Principal Only securities 
(POs). Conversely, it is set to 0% for bonds that are Interest Only (IOs). The attribute of being a PO or an IO is 
designated by the Bond Type (Product Subtype) with the settings of PO (Principal Only) or IO (Interest Only). It is 
very important for POs and IOs to be set up with the appropriate Bond Types to calculate and display the correct 
cash flows for the bonds. 

Early Redemption Date is displayed here for the user to enter if the bond is retired before the Stated Maturity Date. 
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Quotes 

There are two different types of Quotes that may be entered on the ABS Panel of the Bond Window. These are 
Prepayment Quotes and Weighted Average Life Quotes. 

The Prepayment Quote is used as a simple constant value (scalar) at which to calculate future cash flows. This may 
be used if there is no need for varying prepayment assumptions in the future as is facilitated by the Prepayment 
Curve (vector). The Prepayment Quote consists of selecting the Prepayment Type (CPR or PSA) and the Speed 
Assumption (magnitude in percentage). 

The Weighted Average Life (WAL) Quote may be used to designate an assigned WAL rather than using a dynamic 
calculation. 

Both the Prepayment Quote and the Weighted Average Life Quotes are entered for a specific date by using the 
associated Edit buttons. 

Factor Schedule 

The Factor Schedule is imported from Intex when the bond is loaded from the Intex database. The amount of 
history imported is dictated by the amount of history that you have available in your local Intex database. Namely, 
the history will go back in time as far back as the earliest “.cdu” file for that security in your Intex database. 
Similarly, the Factor Schedule will only be as current as your local Intex database. 

 NOTE: After pool factors are updated on a bond, you need to run Process Trades to update the trades 
accordingly. 

A brief description of the columns in the Factor Schedule follows: 

Column Heading Description 

Effective Date The date which is the start date of the accrual period when the factor is employed 
in determining the current balance or notional amount of the security. 

Known Date Used for Credit Derivatives on ABS – the date that the factor is published. 

Factor The factor, expressed as a decimal (1.00000000 = 100%), which defines the 
current balance or notional amount of the security when multiplied by the Original 
Face. 

Coupon The interest rate for the security for the accrual period that starts on the Effective 
Date. 

End Date The start date for the subsequent accrual period. 

Factor at End The factor at the start date of the subsequent accrual period (the Factor at End 
for the first period is the same as the Factor for the second period). 

Net Used for Credit Derivatives on ABS – Sum of Interest Shortfall, Interest 
Reimbursement, Principal Shortfall, Principal Reimbursement, Writedown, and 
Writedown Reimbursement. 
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Column Heading Description 

Interest Shortfall Used for Credit Derivatives on ABS – the amount the interest payment is less than 
that specified by the coupon and accrual days. 

For MBS, both Interest Shortfalls and Interest Reimbursements are displayed in 
the Interest Shortfall column. Shortfalls are positive numbers and Reimbursements 
are negative numbers in keeping with the convention that Intex employs. 

Interest Reimbursement Used for Credit Derivatives on ABS – the amount that previous Interest Shortfall is 
reimbursed. 

Principal Shortfall Used for Credit Derivatives on ABS – the amount that the principal payment is less 
than scheduled and unscheduled amortization. 

Principal Reimbursement Used for Credit Derivatives on ABS – the amount that the previous Principal 
Shortfall is reimbursed. 

Writedown Used for Credit Derivatives on ABS – the amount of bond principal that is written 
off as a loss. 

For MBS, both Principal Shortfalls and Principal Reimbursements are displayed in 
the Writedown column. Shortfalls are positive numbers and Reimbursements are 
negative numbers in keeping with the convention that Intex employs. 

Writedown Reimbursement Used for Credit Derivatives on ABS – the amount of previous writedown that is 
reimbursed. 

WAC Weighted Average Coupon. 

WAM Weighted Average Maturity. 

Additional Settings 

The domain "PoolPrefixesForFactorBasedOnPayDate" contains prefixes for factors based on payment date instead 
coupon start date. 

If domain “BondAssetBacked.DC30_360_SpecialDiscountingFor31” contains Value = true, for 30/360 bonds settling 
on the 31st of the month, the yield is calculated based on discounting to the 1st of the next month. 

The domain “FixedRateTrancheTypeUsingComputedCoupon” should contain the list of tranche types for fixed rate tranches for 

which you need to use computed coupon instead of coupon. By default, it contains the values SEN_WAC, SEN_FLT, SEN_CPT, and 

SEC_WAC_CAP. 

5.3.2 Fetching an Intex Security from the Intex Database 

The Bond Window may also be used to fetch securities directly from the Intex database. This is very handy when 
the bond in question has not yet been imported via the Intex Loader or if the bond has been previously imported 
but is stale and is in need of an update. 

To fetch directly from the Intex database, change the Security Code to the identifier that you wish to use, enter the 
value of the identifier (e.g., CUSIP, INTEX_NAME or ISIN) and click Import from Intex. Note that the Import from Intex 
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button does not display if the Intex Module is not available in your runtime environment. The fetch will employ the 
same logic as defined in the Intex Loader and as customized in the Intex Mapping. 

The results displayed on the Bond Window are transient data and must be “Saved” for the information to be written 
to the Calypso database. If the bond already exists in the Calypso database, the bond is first fetched from the 
Calypso database and then updated with current Intex data. In this manner, any enriched data from the Calypso 
database is preserved. You may take the information as is or edit certain fields and “Save” the newly updated bond 
to the Calypso database. 
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Capturing and Pricing ABS Trades 
Prior to capturing and pricing ABS Trades, you need to set up several market data items. 

6.1 Setting Market Data 

6.1.1 Prepayment Curves 

Prepayment Curves are Market Data Items with a term structure that may be associated with a security or a group 
of securities using the Pricer Configuration. Most ABS and MBS securities are self-amortizing bonds that pay 
monthly, quarterly, or semi-annual scheduled principal. In addition to scheduled principal, many bonds pay 
unscheduled principal due to the underlying collateral paying off earlier than scheduled. These unscheduled 
principal payments are known as prepayments. There are various units employed to measure prepayments. 
Calypso has integrated all the various units that are supported by Intex. The following table lists the acronyms that 
Intex employs for prepayment measures along with a brief description. 

Prepayment Units Description 

PSA Percent of the PSA Model, first defined by the Public Securities Association. 

CPR Constant Prepayment Rate based on an annual percentage. 

SMM Single Monthly Mortality based on a monthly percentage. 

CPY Same as CPR; however, prepayments will be locked out for any period that yield 
maintenance is in effect. Used primarily for CMBS deals. 

CPP Same as CPR; however, prepayments are locked out for any period that 
prepayment penalties are in effect. Used primarily for CMBS deals. 

CPB Like CPR, except that ARM pools prepay in full at their next reset date. 

ABS Percent of Asset Backed Securities prepayment rate. Used primarily with auto 
deals. 

HEP Percent of Home Equity Prepayment Model. 

PPC Percent of Prospectus Prepayment Curve (if modeled, otherwise reverts to PSA). 

SCRIPT Percent of User-defined Prepayment Script model. If this is selected as the 
prepayment type, it should be noted that if the script within the deal model has a 
default CDR curve, you cannot override the default/loss scenario. 

MHP Percent of Manufactured Housing model. 
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To define a prepayment curve, choose Market Data > Credit Curves > Prepayment Curve. 

 

The Prepayment Type is used to select the prepayment units to use. You may select monthly or yearly Tenors, e.g., 
1M, 6M, 1Y, etc. and associate the Prepayment Speed with the Tenor Points. The Prepayment Speeds are 
expressed as a percentage. The interpolation method between curve points is a constant, in other words, the 
Prepayment Speed for the first Tenor will be employed for all payment periods between two consecutive curve 
Tenors. As well, the last Prepayment Speed entered will be used for the remaining life of the bond. The window 
above shows an example of a Prepayment Curve Window. Note that there is also a tab to show a graph of the 
prepayment curve. 

See below for associating prepayment curves with the pricing environment. 

6.1.2 Delinquency Curves 

Delinquency Curves may be defined in much the same manner as Prepayment Curves. Delinquency Curves are also 
Market Data Items with a term structure that may be associated with a security or a group of securities using the 
Pricer Configuration. To define a delinquency curve, choose Market Data > Credit Curves > Default Curve. 

Since the default modeling in Calypso is that the servicer advances interest and principal, delinquencies only affect 
the cash flows of a bond if a trigger event is present and is tripped by the delinquency assumption. For example, in 
many home equity deals, the subordinate bonds and the senior bonds receive principal simultaneously if the 
underlying collateral is performing well. However, if the delinquency exceeds a certain pre-set percentage (the 
trigger) of the outstanding balance, then prepayment principal is used to pay down the senior bonds and not the 
subordinate bonds. This trigger event serves to protect the senior bonds and potentially lengthens the weighted 
average lives of the subordinate bonds. 
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The following is an example of a definition of a delinquency curve: 

 

You may select monthly or yearly Tenors, e.g., 1M, 6M, 1Y, etc. and associate the Delinquency Rate with the Tenor 
Points. The Delinquency Rate is expressed as a percentage. The interpolation method between curve points is a 
constant, in other words, the Delinquency Rate for the first Tenor will be employed for all payment periods between 
two consecutive curve Tenors. As well, the last Delinquency Rate entered will be used for the remaining life of the 
bond. The window above shows an example of a Delinquency Curve Window. Note that there is also a tab to show 
a graph of the delinquency curve. 

See below for associating delinquency curves with the pricing environment. 

6.1.3 Default Curves 

Default Curves are also Market Data Items with a term structure that may be associated with a security or a group 
of securities using the Pricer Configuration. Default Curves affect the projected cash flows of a security by defining 
assumptions regarding expected losses on the underlying collateral which supports the bond. The following table 
lists the acronyms that Intex employs for default measures along with a brief description. 

Default Units Description 

MDR Losses are a percentage of performing balance. 

CDR Losses are an annualized percentage of performing balance. 

SDA Losses are a percentage of the Standard Default Rate model. 

SDR Losses are given as a non-compounded annual rate. The application of the loss 
depends on the frequency of the asset: if applied to a monthly loan, an SDR of 3% 
would lose 0.25% of the current balance on a monthly payment date, but the 
same SDR forecast on a semiannual loan would lose 1.5% of the current balance 
on semiannual payment date. E.g., 3.0. 

ORIGMDR Losses are a percentage of the original loan balance. 

ORIGCDR Losses are an annualized percentage of the original loan balance. 
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Default Units Description 

ORIGSDR Losses are given as a non-compounded annual rate, based on the original balance 
of the loan. Actual loss amounts on a payment date recognize the payment 
frequency of the loan, as with SDR. 

SCHMDR Losses are a percentage of the amortized balance. 

SCHCDR Losses are an annualized percentage of the amortized balance. 

AGGMDR Losses of a specified percentage of the outstanding collateral balance as of the 
start of cash flow generation are distributed pro-rata among the loans. Intex can 
supply further details for the description of this mode. 

PHM Percent of collateral distributed over a span. 

To define a default curve, choose Market Data > Credit Curves > Default Curve. 

 

The Default Type is used to select the default units to use. You may select monthly or yearly Tenors, e.g., 1M, 6M, 
1Y, etc. and associate the Default Rate with the Tenor Points. The Default Rates are expressed as a percentage. 
The interpolation method between curve points is a constant, in other words, the Default Rate for the first Tenor 
will be employed for all payment periods between two consecutive curve Tenors. Also, the last Default Rate 
entered will be used for the remaining life of the bond. The window above shows an example of a Default Curve 
Window. Note that there is also a tab to show a graph of the Default Curve. 

See below for associating default curves with the pricing environment. 

6.1.4 Recovery Curves 

The Intex integration employs the existing functionality of Recovery Curves in Calypso to assign loss recovery 
assumptions to the underlying collateral and thus to the cash flows of the bonds. For a more detailed explanation 
of the functionality of Recovery Curves, please see the Calypso Market Data User Guide. 

To define a recovery curve, choose Market Data > Credit Curves > Recovery Curve. The Definition tab of the 
Recovery Curve Window is the initial display. 
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On the Offsets tab, you select the Tenor Offsets by highlighting and using the double arrow (“>>”) to form a 
Selection: 

 

Then select the Points tab and click Generate to generate the points. 

 

You can then enter the recovery rates. 

Like the Prepayment Curve and the Default Curve, the Graph tab may be used to display a graphical representation 
of the Recovery Rates: 
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See below for associating recovery curves with the pricing environment. 

6.2 Associating Market Data with a Pricing Environment 

Market data are associated with a pricing environment through the Pricer Configuration. 

From the Calypso Navigator, navigate to Market Data > Pricing Environment > Pricer Configuration and load a 
pricer configuration. 

6.2.1 Pricers 

BondAssetBacked 

Select the Pricers tab to define the pricers to be used. For the Intex integration to function, it is necessary that the 
pricer PricerIntexBondAssetBacked (or the pricer, PricerIntexComplexABS) be added to this list with for the Product 
Type BondAssetBacked, and the Extended Type and Subtype both set to ANY. In summary, this pricer is used to 
support cash flow forecasting using the Intex subroutines and the Prepayment Curve (or Quote), Delinquency 
Curve, Default Curve and Recovery Curve. 
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 NOTE: The Intex Server must be running in order to compute forecasted cash flows for ABS bonds. 

PricerIntexComplexABS has virtually the same functionality as PricerIntexBondAssetBacked with the exception that 
it does not default to doing all the calculations for the Trade Window unless specifically requested. 
PricerIntexComplexABS was created to increase performance of the Trade Window by eliminating unwanted 
calculations. 

CreditDefaultSwapABS 

For the product CreditDefaultSwapABS, you must associate PricerIntexCreditDefaultSwapABS to use the Intex 
pricer. 

6.2.2 ABS Market Data 

Select the ABS tab to select named Prepayment Curves, Delinquency Curves, Default Curves and Recovery 
Curves. This panel only appears if the domain absMktDataUsage is defined. See Domain Values for details. 
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Curves can be associated by issuer, series, class, and group. 

» Select an issuer and a series, then select a class or ANY and a group or ANY. 

You can only select an issuer and a series if an ABS bond exists in the system for which the issuer and series 
are populated. 

» Select a usage as defined in the domain absMktDataUsage. 

» Then click Select to select an actual curve. 

Prepayment curves are created using Market Data > Credit Curves > Prepayment Curve. 

Delinquency curves are created using Market Data > Credit Curves > Delinquency Curve. 

Default Curves are created using Market Data > Credit Curves > Recovery Curve. 

Recovery curves are created using Market Data > Credit Curves > Recovery Curve. 

» Click Add to add the selected curve for the selected usage. Then click Save to save the Pricer Configuration. 

Note that one may associate and save any of these curves at a high level, such as for the specific Issuer and Series 
and then also save a different curve for at a lower level for the Issuer, Series, and Class. The curve or curves 
defined at the lower Class level would override the curves associated at the Series level. The more granular 
association overrides the higher level association. 

6.3 Capturing an ABS Trade 

Bring up a trading environment and choose Trade > Fixed Income > Bond. 

 

» Select the bond you want to trade using the security code of your choice (CUSIP, INTEX_NAME, ISIN, etc.). 
Enter the nominal, settlement date, book, etc. as needed. 

» Choose Help > Trade Fields for complete details. 
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» Click Price to price the trade – The pricing details are described below. 

6.3.1 Market Data 

The market data are loaded from the Pricer Configuration of the selected pricing environment into the trade 
window. 

 

6.3.2 Pricing Parameters 

There are several Pricing Parameters that are specific to Intex and may be used with the Intex pricers. The 
following table describes their use. 

Pricing Parameter Description 

ABS_EXERCISE_DATE Exercise if the date entered is in the past and the option conditions 
as defined in the prospectus and modeled by Intex have been met. 

ABS_OPTION_EXERCISE NEVER - The option would not be exercised even if the conditions of 
exercise as defined in the prospectus and modeled by Intex are true. 

ASAP - The option would be exercised as soon as the conditions of 
exercise as defined in the prospectus and modeled by Intex are true. 
This might be when the collateral is at a small enough percentage 
compared to the original collateral amount or when all the bonds in 
the deal are at a small enough percentage compared to the original 
total bonds outstanding. Alternatively, the condition may be 
associated with a date. 

DATE - If this is set, the parameter ABS_EXERCISE_DATE will be used 
as part of the logic to decide to exercise or not. 

ACCRETION_CALC_METHOD Calculator for constant prepayment accretion for PREM_DISC_YIELD 
computation: ContractualToMaturityWithConstantPrepayment. 

When saving a floating rate trade, the floating rate is stored in the 
trade keyword INDEX_RATE, and in the trade open quantity. This rate 
is used for accretion calculation. 

The scheduled task INTEX_YIELD_UPDATE needs to be run to update 
the trade keywords Yield and INDEX_RATE as of trade settle date. 

COLLATERAL_AGGREGATION TYPICAL - Intex groups the underlying collateral in a more granular 
fashion than the WAVG method. This collateral grouping can produce 
more accurate results at potentially the cost of more calculation time. 
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Pricing Parameter Description 

WAVG - Intex groups the underlying collateral and uses the weighted 
averages of the groups to compute cash flows. This is the method 
most employed to best balance the cost of the calculations with the 
benefit of the accuracy. 

CLUSTERS - Intex groups the underlying collateral into homogeneous 
coupon and maturity clusters before performing cash flow 
calculations. 

PRICING - Intex uses the collateral assumptions from the time the 
deal was priced to compute cash flows. These are usually grosser 
assumptions that produce fast results. 

PREPAYMENT Quote - The cash flows are derived from the level prepayment speed 
supplied in the Bond Window. If there is an association with a 
Prepayment Curve, it is not used, and the Prepayment Curve is 
hidden from the Market Data 

Curve - If there is a Prepayment Curve associated with the pricing 
environment, then it is viewable in the Market Data and it is employed 
in calculating cash flows. 

None - Neither the Quote nor the Prepayment Curve is used for 
prepayments. The Prepayment Curve is not viewable in the Market 
Data. 

RECOVERY The assumed number of months lag time from the date of default to 
the date of liquidation and recovery. 

SOLVER_MAXIMUM_DEFAULT An upper bound when solving for an implied default rate, beyond 
which the calculation should halt. 

SOLVER_MAXIMUM_ITERATIONS Sets the number of iterations for the solver to try before giving up on 
establishing an answer. 

SOLVER_MAXIMUM_PREPAYMENT An upper bound when solving for an implied prepayment rate, beyond 
which the calculation should halt. 

SOLVER_MINIMUM_DEFAULT A lower bound when solving for an implied default rate, beyond which 
the calculation should halt. 

SOLVER_MINIMUM_PREPAYMENT A lower bound when solving for an implied prepayment rate, beyond 
which the calculation should halt. 

SOLVER_PRECISION Sets the precision of the solver 

SOLVER_TARGET_TYPE PRICE - Sets Price as the Target for the solver. 

YIELD - Sets Yield as the Target for the solver. 

WAL - Sets WAL as the Target for the solver. 
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Pricing Parameter Description 

TOTAL_WRITEDOWN - Sets Total Writedown as the Target for the 
solver. 

TOTAL_LOSS - Sets Total Loss as the Target for the solver. 

SOLVER_TARGET_VALUE Enter the value of Price, Yield, WAL, Total Writedown or Total Loss 
here, depending on the selection for the Target Type. 

USE_INTEX_ANALYTICS With this parameter checked on, many of the pricing results (Pricer 
Measures) are sourced from calculations by the Intex Subroutines. 
These Pricer Measures are listed in the next section, Pricing Results. 
In addition to enabling the Pricer Measures to be computed with Intex 
Subroutines, this parameter will also enable the solvers to be 
computed. 

6.3.3 Pricing Results 

Using Intex Analytics 

If the USE_INTEX_ANALYTICS pricing parameter is checked on, then the following Pricer Measures are sourced 
from calculations performed by the Intex Subroutines: 

• PRICE 

• DIRTY_PRICE 

• ACCRUAL 

• YIELD 

• YIELD_BEY 

• DISC_MARGIN 

• WAL 

• MODIFIED_DURATION 

• CONVEXITY 

• Z_SPREAD 

• PRINCIPAL_WRITEDOWN 

• NPV 

• PV01 

• DELTA 

In addition, the following solver results will use the Intex Subroutines: 

• IMPLIED_CDR 

• IMPLIED_CPR 

• IMPLIED_PSA 

• IMPLIED_SDR 

• BREAK_EVEN_DEFAULT_RATE (equivalent to the IMPLIED_CDR) 
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Weighted Average Life 

 

The WAL (Weighted Average Life) Pricer Measure is available for all the Bond Pricers. It can be added to the results 
using Bond > Configure Results. 

The formula for Weighted Average Life of a bond is defined as the average time to receive the principal cash flows 
of the bond weighted by the individual principal payments. The formula for the WAL is as follows: 


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Where: 

• t = Period subscript, t = 1, … N 

• tPRINCIPAL  = Principal arriving at time t 

• N = Number of periods until last principal flow 

• 
SDateCFDatet − = the number of days between the principal cash flow at time t and the Settlement Date 

(day count employed is the same as the bond) 

• D = the number of days in a year as specified by the day count used by the bond 

6.4 Using Scenario 

Curves can be added to scenario market data items in order analyze the impact on bond prices if they are shifted. 
For a full definition of how to use Scenario Analysis, please see the Scenario Analysis User Guide. A summary with a 
Prepayment Curve shift follows to illustrate the changes introduced by the Intex integration. 

» Have a pre-defined Prepayment Curve that you want to shift in Scenario Analysis. 

» Bring up the Scenario Editor using Configuration > Reporting & Risk > Scenario Editor. 

» Add a Market Data Group under the Market Data Sets Tab. 

Usage = ABS 

Curve Type = Prepay (Delinquency, Default and Recovery are also available) 

Type = any of the Prepayment Units 

Name = a pre-defined Prepayment Curve 
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» Create shifting rules – the following window shows the rule to shift the Prepayment Curve up by a relative 10%. 

 

» Create the risk measures you want to compute – the following window shows NPV and WAL. 

 

» Create a Trade Filter via Configuration > Filters > Trade Filter. 
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The following window just selects Trade Id 1001 and names the filter, FHL2777-DB-1001. 

 

» Run the Scenario analysis – There are multiple ways to run a risk analysis – Refer to the Calypso Risk Analyses 
User Guide for details. 

Here is the Risk Analysis window: select the risk analysis type “Scenario”, the trade filter you have created, and 
the analysis configuration created above using the Scenario Editor. 

You can click Risk in the Calypso Navigator to bring up the Risk Analysis Config window. 
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Run the analysis and configure the results as desired. 

 

6.5 Using Scenario Sensitivity 

Curves have also been added as a Parameter Set so that prepayments may be shifted in a Scenario Sensitivity. An 
example of running a Scenario Sensitivity on prepayments is as follows. 

You can bring up a trading environment that shows your trade and configure the risk analysis from there. 
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» Select ScenarioSensitivity from the Analysis field and click ... next to the Params field to configure the analysis. 

The following window shows the Viewer after having selected the Shift to be Prepayment (a newly introduced 
selection) and set the Amounts to be -30 to +30 in 10% intervals: 

 

» Then click Run to run the analysis. 

 

It shows the change in NPV for each shift. 
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Intex Data Mapping Reference 

7.1 Bond Products 

Each ABS tranche modeled by INTEX can be imported into Calypso as a BondAssetBacked product. The data fields 
in the INTEX deal structure are internally mapped to the Calypso product fields according to the following table: 

 

ICMO Structure 

INTEX Calypso (BondAssetBacked 
Product) 

Comment 

icmo_deal_category 

icmo_assetback_type 

ICMOADDLINFO_COLLAT_TYPE 

icmo_tranche_types 

ABSDeal.DealType 

ABSDeal.DealSector 

Bond.BondType (always 
BondAssetBacked) 

BondAssetBacked.SubType 

Based on custom product mapping 
values. 

icmo_deal_is_pure_io BondAssetBacked.PrincipalPerc
entage 

Set to 0% for interest-only 
tranches. 

icmo_dealname BondAssetBacked.ABSSeries Deal name. 

icmo_tranche_names BondAssetBacked.ABSClass Tranche name. 

icmo_dealname 

icmo_tranche_names 

Bond.Name 

SecCode.INTEX_NAME 

Calypso name is the concatenation 
of Intex deal and tranche names. 

icmo_tranche_cusips SecCode.CUSIP  

ICMOADDLINFO_TR_ISIN SecCode.ISIN  

ICMOADDLINFO_TR_CURRENCY Bond.Currency 

Bond.CouponCurrency 

 

ICMOADDLINFO_DEAL_COUNTRY_CO
DE 

Bond.Country Country ISO code. 

icmo_deal_issuer Bond.IssuerId Must be valid issuer legal entity in 
Calypso or based on custom 
mapping values. 

icmo_vcollat_grps BondAssetBacked.CollateralGro
ups 

Collateral group names supporting 
the tranche. 
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INTEX Calypso (BondAssetBacked 
Product) 

Comment 

icmo_assetback_type BondAssetBacked.CollateralTyp
e 

Based on custom mapping values. 

icmo_tranche_dateds Bond.DatedDate 

Bond.IssueDate 

Tranche dated date. 

icmo_tranche_statedmatdates Bond.MaturityDate Stated maturity date of the tranche. 

icmo_deal_paid_down_date BondAssetBacked.EarlyRedempt
ionDate 

If paid down date is earlier than 
stated maturity. 

icmo_pay_dd 

icmo_tranche_delays 

Bond.RollingDay Calypso’s payment cycle day is the 
nominal pay day unadjusted by any 
payment delay. 

icmo_tranche_coupons Bond.Coupon Fixed coupon rate. 

icmo_first_eventdate 

icmo_tranche_firstdates 

Bond.FirstCouponDate Front stub. 

icmo_collat_freq 

icmo_tranche_freqs 

Bond.CouponFrequency Payment frequency. 

icmo_collat_curmonth   

icmo_tranche_origbals Bond.TotalIssued  

Icmo_tranche_delays Bond.CouponOffset 

BondAssetBacked.PayDownOffs
et 

Payment delay for principal and 
interest. 
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BLOCK_INFO Structure 

INTEX Calypso (BondAssetBacked 
Product) 

Comment 

 

bi_flt_indextype Bond.RateIndex Rate index for CMO floaters. 

bi_flt_const Bond.RateIndexSpread  

bi_flt_cap Bond.CapStrike Intex can supply a value of 0, 99, 
999, or 9999 and these all mean 
there is no Cap. 

If the Cap field value is 0, negative, 
or 99 or greater, this is interpreted 
as the bond not having a Cap. 

bi_flt_cap_expr Bond.CapStrike 

Bond.FloorStrike 

Bond.OptionType 

If Intex supplies a Periodic Cap and 
no Life Cap (bi_flt_cap_expr is non-
NULL), Calypso populates the Cap 
as 0 and this is interpreted as not a 
Cap. For example, Freddie Mac 
Structured Pass Through Floaters 
(Freddie Mac “K” bonds). 

If bi_flt_cap_expr is NULL, then 
Calypso populates the Cap field 
with the value Intex supplies. 

The Type will either be Floor or 
Collar as there will never be an ABS 
or MBS without at least a Floor. 

There will never be a Type that is a 
Cap because there will always be a 
Floor and the Cap + Floor results in 
a Collar. 

bi_flt_floor Bond.FloorStrike The Floor field will always come in 
as either a “0” or a non-zero value 
as supplied by Intex. 

bi_daycount_method Bond.DayCount 

Bond.AccrualDayCount 

See Daycount Conventions. 

bi_bd_center_name Bond.Holidays Based on custom mapping values. 

bi_businessday_method Bond.DateRoll See Date Roll Conventions. 
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ARM_INFO Structure 

INTEX Calypso (BondAssetBacked 
Product) 

Comment 

 

armi_index Bond.RateIndex  

armi_netmargin Bond.RateIndexSpread  

armi_caplife Bond.CapStrike  

armi_flrlife Bond.FloorStrike  

7.2 Daycount Conventions 

INTEX Daycount Calypso Daycount Comment 

ICMO_DAYCOUNT_30360 DayCount.D_30_360  

ICMO_DAYCOUNT_30365 DayCount.D_30_365  

ICMO_DAYCOUNT_ACTUAL360 DayCount.D_ACT_360  

ICMO_DAYCOUNT_ACTUAL365 DayCount.D_ACT_365  

ICMO_DAYCOUNT_ACTUALACTUAL DayCount.D_ACT_ACT  

7.3 Date Roll Conventions 

INTEX Business Day Method Calypso Date Roll Comment 

ICMO_BUSINESSDAY_NONE DateRoll.R_NONE No business day adjustment 
convention. 

ICMO_BUSINESSDAY_FOLLOWING DateRoll.R_FOLLOWING Pay on the day after the 
weekend/holiday. 

ICMO_BUSINESSDAY_PRECEDING DateRoll.R_PRECEDING Pay on the day before the 
weekend/holiday. 

ICMO_BUSINESSDAY_MFOLLOWING DateRoll.R_MOD_FOLLOWING Pay on the "modified following" 
day. 

ICMO_BUSINESSDAY_EOMFOLLOWING DateRoll.S_END_MONTH Pay on the "modified following" 
end-of-month day. 
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INTEX Business Day Method Calypso Date Roll Comment 

ICMO_BUSINESSDAY_EOMPRECEDING DateRoll.S_END_MONTH Pay on the "modified" end-of-
month day of the previous month. 
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Troubleshooting 
• The Intex integration is of course highly dependent on Intex data. Occasionally, Intex revises some 

discrepancies in their data files after the data has already been published. The user should be cognizant of 
this possibility when reviewing Factor Schedules that may have changed after an update, etc. or when 
doing user acceptance testing with results obtained at different times. 

• Interest Only (IO) and Principal Only (PO) securities must be mapped to their respective Bond Types 
(Product Subtypes) appropriately as IO (Interest Only) or PO (Principal Only) or inconsistencies in cash flow 
generation may result. 

• If there appears to be a problem with the Bond Type (Product Subtype), be sure to consult the Tranche 
Name, Tranche Type, Deal Category and Asset Back type that import from Intex and are all listed on the 
Intex Loader window. 

 

 

 


