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1. Warrants Overview
Reference Data and Setup
• Domain Values

• Workflow: Mirroring

• Accounting

• Product Definition

Market Data
Generally, you will need the following market data (Help is available from all market data windows):

• Discount and Forecast curves - See Calypso Navigator > Market Data > Interest Rate Curves > Zero Yield
Curve.

• Quotes - See Calypso Navigator > Market Data > Market Quotes > Quotes.

Warrant Type Extended Type Default Pricers

TradingWarrant European PricerBlack1FAnalyticVanilla

TradingWarrant American PricerBlack1FFiniteDifference

IndexWarrant European PricerBlack1FAnalyticVanilla

IndexWarrant American PricerBlack1FFiniteDifference

CBBC ANY PricerWarrant (from Quote
Only)

MINI ANY PricerWarrant (from Quote
Only)

Compo/Quanto ANY PricerBlack1FAnalyticVanilla
(from Quote Only)

InternationalWarrant ANY PricerWarrant (from Quote
Only)

InvestmentWarrant ANY PricerWarrant (from Quote
Only)

InstalmentWarrant ANY PricerWarrant (from Quote
Only)

Capped ANY PricerWarrant (from Quote
Only)
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Warrant Type Extended Type Default Pricers

CurrencyWarrant ANY PricerWarrant (from Quote
Only)

Exotic ANY PricerWarrant (from Quote
Only)

Vanilla (legacy) ANY PricerWarrant (from Quote
Only)

Trade Capture
• Trading Warrants and Certificates

• Issuing Warrants and Certificates

• Issuance Mirroring

Trade Lifecycle
• Corporate Actions
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2. Warrants Domain Values
The following domain values should be reviewed:

• Warrant.Status – Status codes of the products.

• Warrant.Deliverable – Types of underlying products that can be physically delivered.

• Warrant.UnderlyingEditable – Warrants with underlyings not managed in Calypso for which the user will have to
capture the description.

• Certificate.UnderlyingEditable – Certificates with underlyings not managed in Calypso for which the user will have
to capture the description.

Below are the default warrant domain values related to warrant definition.

• Warrant.Attributes – CBBC, CurrencyWarrant, IndexWarrant, InternationalWaarrant, InvestmentWarrant, MINI,
TradingWarrant, Capped, and Exotic

• Warrant.AveragePrice – TradingWarrant and IndexWarrant

• Warrant.Barrier – CBBC, IndexWarrant, MINI, and TradingWarrant

• Warrant.BuyBackPeriod – MINI

• Warrant.Covered – CBBC, CurrencyWarrant, IndexWarrant, InternationalWaarrant, InvestmentWarrant, MINI,
TradingWarrant, and Capped

• Warrant.Deliverable – BondConvertible and Equity

• Warrant.DeliveryUnderlying – InternationalWarrant

• Warrant.DivPassThrough – InstalmentWarrant

• WarrantFxType – CurrencyWarrant, IndexWarrant, InternationalWaarrant, and TradingWarrant

• Warrant.Pricer – PricerBlack1FAnalyticDiscreteVanilla, PricerBlack1FFiniteDifference, PricerWarrant

• Warrant.SpecialQuote – IndexWarrant, TradingWarrant, InvestmentWarrant, and InstalmentWarrant

• Warrant.Status – NONUPDATE, PENDING, and VERIFIED

• Warrant.subtype – CBBC, Capped, CurrencyWarrant, Exotic, IndexWarrant, InstalmentWarrant,
InternationalWarrant, and TradingWarrant

• Warrant.Type – Certificate and Warrant

• Warrant.Underlying – Equity, EquityIndex, and FX

• Warrant.UnderlyingEditable – Equity, Equity, and FX

• WarrantIssuance.Pricer – PricerWarrantIssuane
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3. Workflow - Mirroring
In order to manage Issuances and to simplify the capture of the trades, Calypso allows using a workflow rule which will
generate:

• an Issuance trade when capturing a Buy/Sell with the Issuer, or

• a Buy/Sell trade with the Issuer when capturing an Issuance.

The goal is to simplify the capture of the trades for the “in house” Warrants when the bank has to provide facilities to
the issuer.

Since the Mirroring functions cannot work on two different product classes in Calypso, it will be managed with a
Workflow Rule. Thus, it will be possible to manage different workflows for each kind of trade, even if some status
codes could be linked (a modification or a cancellation can be replicated to the linked trade).

The workflow rule IssuanceMirror can be set on each transition where the relationship between both trades is needed.
The rule is set on theMasterworkflow which can be either theWarrant or the Issuance.

By default, the workflow rule is active only when:

• On the Buy/Sell trade, the Counterparty of the trade is a ProcessingOrg and is the Issuer of the product, or

• On the Issuance trade, the Counterparty of the trade is a ProcessingOrg and the Issuer of the product is the
owner of the Book.

The workflow rule can also be activated when the Counterparty of the trade is the Issuer of the product and has an
Attribute AUTO_ISSUANCE_MIRROR= true.

 Ⓘ [NOTE: The workflow rule IssuanceMirror must never be setup on both products (e.g. Warrant and
WarrantIssuance)]

Nasdaq Calypso
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4. Warrants Accounting
The following accounting events can be used for warrants:

OFF_BALANCE: To book the off balance amount

• Retro-Activity = FULL

• Event Class = OFF

• Booking Type = N/A

• Event Property = NONE

• Trigger Events: VERIFIED_TRADE, CANCELED_TRADE

This amount depends on the product type and is calculated as follows:

• Vanilla, CBBC, MINI, Index, TradingWarrant, Investment, and Instalment: (Quantity * Strike) / (Parity 1 / Parity 2)

• Exotic: Quantity * Unit Off-Balance

• Capped: (Quantity * ValAbs[(Strike - Strike2)])/(Parity 1 / Parity 2)

• Quanto: (Quantity * Strike) / FX Rate * (Parity 1 / Parity 2)

EXERCISE_FEE provides the performance amount.

• Retro-Activity = FULL

• Event Class = BALANCE

• Booking Type = N/A

• Event Property = NONE

• Fee Related Event = true

• Trigger Events: VERIFIED_TRADE, CANCELED_TRADE

The following events are available for Warrants and Certificates: COT, COT_REV, CST, NOM_FULL, NOM_CLEAN,
NOM_FULL_REV, NOM_CLEAN_REV, REALIZED_PL, REALIZED_CLEAN_PL, MTM_FULL, POSITION_VALUATION, OFF_
BALANCE, EXERCISE_FEE.

Basic Warrant Accounting Setup
The screen shots below are meant to give you to a brief look at some of the windows involved in warrant accounting.
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The Accounting Rule window is where you can specify the accounting treatment and define the accounting that will
be applied.

Choose Calypso Navigator > Configuration > Accounting > Rules (menu action refdata.AccountingRuleFrame)
to open the Accounting Rule window.

Accounting Rule - Definition

In the Configuration Panel, you can define the relationship between an accounting rule, an accounting event, and an
account.
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Accounting Rule - Configuration

In the Book Link panel, you can associate an accounting rule with a trading book.
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Accounting Rule - Book Link

The Accounting Link window allows you to create and/or modify an account book, which collects postings that share
the activity of one or more trading books.

Choose Calypso Navigator > Configuration > Accounting > Books (menu action refdata.AccountingBookFrame)
to open the Accounting Link window.

Nasdaq Calypso
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Accounting Link

In the Book Window, you can define trading books, which are collections of deals that represent business activity
within an organization.

Choose Calypso Navigator > Configuration > Books & Bundles > Trading Book (menu action
refdata.BookWindow) to open the Book Window.
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Book Window

Choose Calypso Navigator > Trade > Equity > Warrant/Certificate (menu action trading.TradeWarrantWindow) to
open the Warrant Trade window and modify the trade information as needed.
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Warrant Trade Window

The Back Office Browser allows viewing the back office activity of trades.

Choose Calypso Navigator > Reports > BO Browser (menu action reporting.bo.BOWorkspaceWindow) to open
the Back Office Browser.

Nasdaq Calypso
Warrants / Version 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 14 / 55



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 15 / 55

Back Office Browser
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5. Warrant Product Definition
Prior to trading a Warrant or Certificate, you need to create the product in the Warrant/Certificate window.

Warrant Types
• CBBC: A CBBC warrant (or Callable Bull Bear Contract) is a warrant with a barrier usually different from the strike.

The CBBC is knocked out if the barrier is triggered, and the final reference price is determined by taking the low or
the high of two consecutive trading sessions (depends on potential market disruption events). The underlying can
be an equity or an equity index and the CBBC is settled in cash or physically. It is possible to store quotes
computed during the two sessions following the barrier triggering.

• Currency Warrant: The underlying is an currency pair. At expiry, if the warrant is in the money, the holder is only
able to exercise into cash.

• Exotic Warrant: Generic Warrant

• Index Warrant: The underlying is an equity index. At expiry, if the warrant is in the money, the holder is only able to
exercise into cash.

• Installment Warrant: An Installment Warrant is a European warrant with an embedded call or put option. At expiry,
if the warrant is in the money, the holder is able to exercise into cash or shares, depending on the terms of the
warrant. Regular dividends are passed to the holder of the warrant (dividend pass through) in cash. For
Installment Warrants with the checkbox "Dividends Passed Through" selected, a corporate action
CASH/DIVIDEND will be created on the dividend ex-date. [NOTE: This only applies to Installment Warrants with an
Equity as the underlying.] The dividends are inputted in Calypso as regular corporate action dividends on an
equity, and there is a corresponding impact on the equity dividend schedule.

• International Warrant: At expiry, if the warrant is in the money, the holder will receive a stock different than the
underlying.

• Investment Warrant: Usually, there is a low strike, long maturity, and no barrier. At expiry, if the warrant is in the
money, the holder is able to exercise into cash or shares.

• MINI: A MINI is a barrier warrant with no expiry delivery cash in case of knock out. The warrant strike and barrier
level are recomputed daily. The initial strike and level are captured on the warrant product. If the barrier is
triggered, the holder can sell back the MINI to the issuer during the stop loss period, which starts at the stop loss
date and usually ends one business later (or more, depending of the buy back period tenor set on the warrant). On
the period end date, the final reference price (stop loss termination reference price) is determined.

• Trading Warrant: At expiry, if in the money, the holder is able to exercise into cash or shares (depending on the
terms of the warrant).

5.1 Defining a Warrant or a Cert if icate
From Calypso Navigator choose Configuration > Equity > Warrant/Certificate to open the window as shown below.
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Sample Warrant Definition

» To load an existing Warrant or Certificate, select a product code from the Security Code list, and enter the actual
code value in the adjacent field as shown below.

Then click Load to load the corresponding product.

You can also click Load at the bottom of the window to open the Product Chooser window. Help is available from
that window.

Otherwise, click New and enter the fields in the product panel and other panels as applicable. The fields are
described below.

Nasdaq Calypso
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» Click Save to save your changes. You will be prompted to enter a product name.

You can also click Save As New to save the product as a newWarrant or Certificate. You will be prompted to enter
a new name.

You can click Update Name to modify the product’s name. You will be prompted to enter a new name.

Fields Details

Fields Description
Name Name given by the user when the Warrant or Certificate is saved.

Product Id Unique id given by the system when the Warrant or Certificate is saved.

Class Select a product class:Warrant or Certificate.

The class cannot be changed once the product is saved.

Type Options for Warrant: CBBC, Capped, CurrencyWarrant, Exotic, IndexWarrant,
InstalmentWarrant, InternationalWarrant, InvestmentWarrant, MINI, Quantofixe, Quantovar,
TradingWarrant, or Vanilla. By default, the field type is set to "TradingWarrant".

For Certificate, the only option is Exotic.

Call/Put Select CALL or PUT. This field is available only for Warrants.

Exercise Type Select a type of exercise: American, European, or Bermudan.

Strike Enter the Warrant strike.

This field is available only for Warrants.

The value represents the exercise price.

Strike 2 This field is available only for Capped Warrants.

The Strike 2 value represents the cap level.

Price Type Select the type of price: Price, PriceC, or CleanPrice.

Covered Available for Warrants (expect Exotic, Quantofixe, Quantovar, and Vanilla).

The checkbox indicates whether or not the warrant is covered.

A covered warrant, unlike a regular warrant, is issued by a financial institution and not the
company that issued the underlying security. Usually the underlying shares are placed in a
trust.

[NOTE: No processing is associated with this field; it is just for information.]

Underlying Type Select the type of underlying product.

For Currency Warrants, the underlying must be a currency pair.

Underlying Product If the underlying product is managed in Calypso, click ... and select a product with the
Product Chooser window. Following the selection, the code and description are displayed.

For the products not managed in Calypso, the description must be entered by the user. This
field is editable if the underlying product type belongs to the domain
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Fields Description
Warrant.UnderlyingEditable or Certificate.UnderlyingEditable.

Underlying Description For the products managed in Calypso, a double-click on the underlying description opens
the window of the related product.

Underlying Currency This field is editable only for the products not managed in Calypso.

For the others, this field displays the currency of the underlying product.

Underlying Exchange This field is editable only for the products not managed in Calypso, or products that have no
exchange place (e.g. FX, Basket).

For the others, this field displays the exchange place of the underlying product.

Issue Date Enter the issue date.

Announcement Date Enter the Announcement date.

Maturity Date Fixed maturity date.

For open end maturity warrants, such as MINI, this field is not mandatory.

Tenor Maturity date expressed as Tenor relative to the issue date.

Last Trading Days Number of days prior to Maturity Date in which the warrant is no longer traded.

Buy-Back Period Only applies to MINI. When a MINI is knocked out, the issuer can buy back the MINI during
the buy-back period. The period starts at the knock out date and usually last several
business days.

The warrant can only be sold to the issuer at the Remaining value, which is calculated as:

Remaining Value = (Stop Loss Termination Price - Current Price) / Conversion Price

Observation Dates Click Observation Dates to enter the different notification and maturity dates. This screen
allows generating a range of dates depending on a frequency. It also allows adding specific
dates.

All these dates will appear in the Trade Diary report.

Nasdaq Calypso
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Fields Description

Issue Size Enter the total face amount of the issue.

Trade Size Enter the minimum nominal tradable. Default value = 1.

Expiry Size Enter the expiry size. Default value = 1.

Tick Size Enter the nominal tradable beyond the minimum trading size. Default value = 0.

Issue Price Enter the issue price.

Face Value This field is only editable if the Price Type is "PriceC" or "CleanPrice". Enter the price with the
variable nominal. Default value = 1.

Unit Off Balance Enter the face value variation.

Only used for warrants that have a nominal different from the face value.

Delivery Type Select the delivery type in case of exercise/assignment of the product. The options include
Cash,Mix, Not Known, and Physical. The default value is Cash.

[NOTE: For International Warrants, the Delivery Type field defaults to "Physical".]

Currency Select the settlement currency. The default is the underlying currency.

[NOTE: For International Warrants, the Currency field defaults to the currency of the
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Fields Description
“Underlying to deliver”.]

Automatic Exercise Tick the checkbox for products eligible for automatic expiry / exercise / knock out by
dedicated scheduled task.

Expiry Average Tick the checkbox to use an average price as the final reference level. If the box is ticked,
the Average Price Schedule tab will be enabled.

Special Quote Instead of using the final closing price or an average final price, a warrant can use a special
quote as the final reference level. At expiry / exercise, the warrant is settled against the
special quote.

FX Type Available for Currency Warrant, Index Warrant, International Warrant, and Trading Warrant.

Field can only be selected if the Settlement currency is different than the Underlying
currency.

Select Quanto or Compo.

Underlying to deliver Only available for International Warrants. Specify the equity to deliver if the warrant is "in the
money" at expiry.

Dividend Pass Through Tick the checkbox if the warrant is eligible for ordinary dividends, in which case, the
corporate action module will generate a CASH Dividend CA.

FX Rate or FX Reset For Quanto, enter an FX Rate. For Compo, select an FX Reset.

Parity Select the quantity of warrant to exercise (From) to obtain a quantity of underlying (To).

5.2 Specifying Special characterist ics
Select the Special panel to capture additional characteristics.
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Warrants/Certificate window - Special panel

» Enter the fields described below as needed.

Fields Details

Fields Description
Primary Value Date Enter the settlement date for trades on the Primary/Grey Markets.

If the field is left blank, the settlement date of the Primary trades will be the Issue Date.

Secondary Days Number of days to calculate the settlement date of trades on the Secondary Market.

Don’t forget to setup calendar(s) on the Market Place.

Maturity Days Number of days to calculate the settlement date of trades generated at maturity.

Issue Paying Agent Name of the Issue Paying Agent for a new issue. The agent should be previously created as
a Legal Entity with the role IPA.

The Issue Paying Agent will be used for issuance trades.

Double-click on the Issue Paying Agent description displayed in red to open the Legal Entity
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Fields Description
screen.

Calculator Agent Name of the Calculator Agent for events. It should be previously created as a Legal Entity
with the role Calc_Agent.

Only for information at the moment.

Double-click on the Calculator Agent description displayed in red to open the Legal Entity
screen.

Guarantor Name of the Guarantor. It should be previously created as a Legal Entity with the role
Guarantor.

Double-click on the Guarantor description displayed in red to open the Legal Entity screen.

Governing Law Select the country in which the product issued belongs.

Selling Restriction Filter Enter here a Static Data Filter. The goal is to have a workflow rule which will alert the user in
case of trades with a non-allowed counterparty.

Click ... to select a Static Data Filter.

Click the heading of this field to create a new Static Data Filter or to modify an existing Static
Data Filter.

Active From … To … Range of dates when the product can be used in the system.

Certificate Coupon Tick this checkbox to capture the coupon characteristics. It is editable only for Certificates.

Then, click ... to open a new screen.

The coupon characteristics will be captured as a bond (with a dedicated class =
BondCertificate) linked to the Certificate. The main fields are initialized (Issue Date, Dated
Date, Maturity Date, Total Issued, Face Value, Issuer, Country) and the Comment displays
the Name and the Id of the Certificate.

Nasdaq Calypso
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Fields Description
Help is available from that window.

5.3 Applying Changes through the Paydown Tab
Select the Paydown tab to create, edit, and remove Face Value variation.

[NOTE: The Paydown functionality can only be applied to certificates.]

To enable the functionality, you must add the following domain values:

• Warrant.Variable

• Certificate.Variable

The subtypes listed under the domain can have a variable face value.
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Warrants/Certificate window - Paydown panel

» Click to bring up the Warrant Paydown window.

Specify the Effective Date (application date) and Factor Change. The Face Value and Unit Off Balance will be
calculated automatically.

Click Apply to update the Paydown Schedule and return to the Paydown panel.

» Click to configure columns, reset configurations to default, or save configurations.

» Click to export to HTML, Excel, or CSV.

Nasdaq Calypso
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5.4 Displaying Events
Select the Event panel to display all events in the life of the product.

• The first part of the screen displays the Corporate Actions and all other events: Exercise, Assignment, Expiry,
Barrier Deactivation.

• The second part displays the events on the Issuance product: Issuance, Mark-up, Mark-Down.

Warrants/Certificate window - Events panel

5.5 Specifying Legal Entit ies
Select the Legal Entities panel to specify product codes by legal entity as shown below.
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Warrants/Certificate window - Legal Entities panel

You can use this panel to specify, for example, specific product codes by market place.

» Click to add a legal entity, then select a role, a legal entity, a security code (product code), and enter a product
code value. Repeat as needed.

» Click Save to save your changes.

5.6 Specifying Average Price Schedule
Warrants can be settled using an average price calculation as the final reference level. The Average Price Schedule
tab is used to specify the dates to include in the computation, usually the 5 days prior to the maturity date.

The Holidays Field defaults to the holiday calendar associated with the selected underlying.
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The fixing on the last days can be overridden by the Specific Reset tab.

5.7 Displaying Floating Str ike
[NOTE: Functionality only applicable for MINI warrants.]

» Right-click inside the Floating Strike panel to add a row.

» Specify the Date and time along with corresponding strike price.

The WARRANT_PROCESSING scheduled task can be used to automatically copy the MINI strikes to the Floating tab of
the MINI warrant.
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5.8 Specifying Issuer
Select the Issuer/Info panel to specify the Issuer and related information.

Fields Description
Exchange Select the exchange where the product is issued.

Issuer Choose the Issuer.

Codification Select a Product Code.

Codes Click Codes to specify code values using the Code Window.

Status Select a status for the product.

Comment Enter a comment as applicable.

Templates Click Templates to select a template operation.

Attributes Click Attributes to bring up the Attributes Window.
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5.9 Defining Barr iers
Select the Barrier tab to define the barrier attributes.

Fields Description
Has Barrier Tick the checkbox if the warrant has a barrier.

Type Select IN or OUT.

Direction Select UP or DOWN.

Level Enter an absolute value to represent the barrier level.

For simple knock out warrants, the barrier level is usually equal to the strike price.

Monitoring Select CLOSING or CONTINUOUS. CLOSING is set as the default. In terms of processing,
the monitoring type does not impact the settlement.

5.9.1 CBBC Barr iers
For CBBC warrants, the barrier level can be different from the strike price. An external system is responsible for
notifying the Calypso system when a barrier is triggered. The external system will publish the high/low prices and the
CBBC call level will be monitored against them. If the CBBC barrier is triggered, the valuation period is separated into
two consecutive trading sessions (assuming there are no market disruption events), during which the high/low of
each session is published. One special quote for each session is created, published, and used for CBBC settlement.

When computing the knockout settlement amount, the final reference level will be determined as follows:

• For bull CBBC, the final reference level is the lowest of the two special quotes.

• For bear CBBC, the final reference level is the highest of the two special quotes.

The session quotes are named: XXXX.SQ.Session1 and XXXXX.SQ.Session2 where XXXX is the Warrant name.

5.9.2 MINI Barr iers
The barrier level is a stop-loss to protect against a negative MINI price. The level is recomputed daily and published by
the issuer prior to the open of each day.
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The initial strike and level are captured on the warrant product.

The daily strike is stored as a quote named XXXX.STRIKE and the daily barrier level as XXXX.STOPLOSS where XXXXX
is the warrant name.

Nasdaq Calypso
Warrants / Version 18



6. Trading Warrants and Certificates
Choose Trade > Equity > Warrant/Certificate to open the Warrant Trade window, as shown below, from Calypso
Navigator or from a Trade Blotter.

Sample Warrant Trade
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The Trade panel is selected by default.

To enter a Warrant or Certificate trade, you can enter trade details or use the speed entry panel. In any case, you can
load a template to populate the fields of the Trade panel.

Loading a Trade Template
» Hit F10 to load a Warrant trade template. You will be prompted to select a template name.

Entering Trade Details
You can select what areas of the Trade panel you want to display. This is particularly useful if you have loaded a
template and only want to modify certain areas of the trade.

» To select areas of the Trade panel for display, choose the View menu. All menu items operate as checkboxes.
Check all the menu items corresponding to the areas you want to display.

Then modify the corresponding fields described below.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

» Then hit F5 to save the trade or choose Trade > Save.

You can also hit F12 to save a trade using any action available in the workflow, or choose Trade > Save Action.
You will be prompted to select an action.

Using the Speed Entry Panel
» Choose the View menu, and check the “Speed Entry Panel Only” menu item. The Speed Entry Panel will appear. It

allows specifying the trade direction, the security, the book, the nominal, the trade price, the settlement date, and
the counterparty. The fields are described below.

Then click Save to save the trade.

You can use the other menu items of the View menu to configure the layout of the Warrant window.

Pricing
» Click Price to price a trade. A warrant requires a discount curve and a quote.

Financing
» Once a trade has been saved, you can chooseWarrant > Finance Trade to enter a related repo trade. If the

Warrant belongs to a bundle, the repo trade will be added to the bundle as well.

You can also click Finance in the Bundle Entry area.

Nasdaq Calypso
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Fields Description

Warrant Details
Product Code

Product Description

You can select the product using one of the following methods.

Once you have selected a Warrant or a Certificate, the value of the alternative product code
is displayed in the field adjacent to the Browse button. The alternative product code in
specified in the attributes of the User Defaults.

You can click Show to view the details of the selected product.

Product Code Selection
Select a product code and type in a few characters of the code value in the adjacent field.
The products that satisfy the request will be displayed as shown below.

» Select a product from the list.

The product code defaults to the security code specified in Calypso Navigator >
Configuration > User Access Control > User Defaults. You can specify as many product
codes as applicable.

If the environment property USE_SUBSTRING_IN_BOND_NAME_QUERY is True, it will search
anywhere in the product name. Otherwise, it will only search from the start of the product
name.

If you have specified a quick entry template, the search will look into the products of the
quick entry template.

Browser Selection
Click Browse to select a product from a user-defined product browser as shown below.

» Click a report template to display the corresponding products, and select a product from
the list.

» Right-click any column and choose Configure Columns to configure the columns. You
can also choose Configure Sort and Set Column Names.

Id Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.
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Fields Description
You can load an existing trade by typing into this field the trade id, the external reference or
the internal reference.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.

The status will change over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Refer to the Calypso Workflow User Guide for information on configuring the workflow and
applying actions to a trade.

Product
Characteristics

Once the product is selected, the main characteristics of the product are displayed:

– Type (Call/Put)

– Strike

– Issue Date

– Maturity Date

– Issuer Description

Trade Date The Trade Date is displayed from the Details panel.

Trade Details
Buy / Sell Select Buy or Sell as applicable to indicate the direction of the trade from the book’s

perspective.

You can switch between Buy and Sell using the space bar.

Quantity Enter the quantity of warrants to trade.

You can adjust the number of decimals, up to 8, using the attribute NOMINAL_DECIMALS.
Default is 2. Warrant attributes are defined at the product level - On the Issuer/Info panel,
click Attributes.

Price Enter the price negotiated.

Settle Date On Primary/Gray Markets (i.e., if the Trade Date is before the Issue Date of the product), the
settlement date defaults to the Primary Value Date specified in the product.

On Secondary Market, the settlement date defaults to the trade date + the number of settle
days specified in the product.

The settlement date uses the holiday calendar of the product's market place to identify
business days.

Nasdaq Calypso
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Fields Description
If you change the trade date, double-click the Settle Date label to update the settlement
date accordingly.

Current Nominal Currently not used.

Settle Currency The settlement currency defaults to the product's currency.

Modify as applicable.

Trade Amount Calculated from the quantity and price.

The adjacent field displays the product’s currency.

Pool Factor Currently not used.

Currency Quote This field is enabled if the Settle Currency is different from the product’s currency.

Click the currency pair to obtain the last known quote. The adjacent field displays whether
the quote Multiplies or Divides the trade amount.

Modify as applicable.

Settle Amount Calculated from the Trade Amount and the Currency Quote.

Legal Entities
Legal Entity The trade counterparty will control the settlement and delivery instructions of the trade.

The first field identifies the legal entity role. The default role is specified using Utilities > Set
Default Role. However, you can change it as applicable.

You can select a legal entity of specified role from the second field, provided you have setup
favorite counterparties. Otherwise, click ... to select a legal entity of specified role from the
Legal Entity Chooser. You can also type Ctrl+F to invoke the Legal Entity Chooser, or directly
enter a Legal Entity short name.

You can choose Utilities > Selected CounterParty Info to show the Legal Entities Window
for the selected trade counterparty, or click Show.

Broker The first field identifies the legal entity role. The default role is Broker.

Click ... to select the broker in the Legal Entity Chooser, or enter the legal entity short name
in the field.

Click Show to open the Legal Entity window for the selected trade broker.

Book Trading book to which the trade belongs. Defaults to the book selected in Calypso
Navigator > Configuration > User Access Control > User Defaults. You can modify as
applicable.

You can select a book you that have setup as favorite books in Utilities > Configure favorite
booksor by clicking ....

The processing organization of the book identifies the processing organization of the trade.

Bundle Entry
Bundles are created using Calypso Navigator > Configuration > Books & Bundles > Trade Bundle.
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Fields Description
You can finance the trade, capture an asset swap, capture a performance swap, or capture an IR swap by clicking the
corresponding button.

Trade Date The Trade Date is displayed from the Details panel.

Types You can select a bundle type.

Names You can select a bundle.

Finance Click Finance to enter a related repo trade. If the product belongs to a bundle, the repo trade
will be added to the bundle as well.

Additional
Mirror Book Select a mirror book if you want to mirror the current trade.

You can select the mirror trader from the Details panel.

A mirror trade will be saved with the current trade to the selected book, and you can view
the mirror trade id from the Details panel.

Do not forget that this functionality doesn’t handle the mirroring with the issuance product
which is managed with a workflow rule. See Workflow: Mirroring.

Market Type Defaults to the market type selected in Calypso Navigator > Configuration > User Access
Control > User Defaults.

You can modify as applicable.

Market types are created in theWarrant.marketType domain. If this domain does not exist,
the values belong to themarketType domain.

Trade Classification You can select a classification for the trade as applicable. This classification is for
informational purposes only.

It is stored in the trade keyword "TradeClassification", and available values can be set in
domain keyword.TradeClassification.

It can be used in filters to filter trades for various processes, and can be viewed in reports
throughout the system.

Comment Enter a free-form comment as applicable.
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7. Issuing Warrants and Certificates
Choose Trade > Equity > Warrant/Certificate Issuance to open the Warrant Issuance Trade window from Calypso
Navigator or from a Trade Blotter.

The Warrant Issuance Trade window is very similar to the Warrant Trade window. The main difference is the direction:
Issuance/Closing (instead of Buy/Sell).

Sample Warrant Issuance Trade

See Capturing Warrants and Certificates for details.

The other differences between the Warrant Issuance Trade window and Warrant Trade window:

• There is no History Panel.

• In the Legal Entities section, there is only one field for specifying a Legal Entity, as opposed to the two fields in the
Warrant Trade.

The transfers of the warrant/issuance trades are automatically set to DFP.
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You can use the domain “Warrant_mono_Currency_support” with Value = true to force transfers to be DAP for
warrant/issuance trades.
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8. Issuance Mirroring
See Workflow: Mirroring for the setup details.

Trading a Warrant or a Certificate with the Issuer can automatically generate the corresponding issuance trade. The
workflow rule IssuanceMirror can be setup on each transition of the workflow where both trades have to work
symmetrically. The transition must be the same on both workflows (i.e., same Orig Status, Result Status and Action).

The workflow rule can be setup on the workflow related to the Issuance products (WarrantIssuance,
CertificateIssuance) or on the workflow related to the products (Warrant, Certificate), but never on both workflows.

Saving a trade using a workflow which has the rule IssuanceMirror generates a second trade. They are linked
together:

• The “source” trade has the system keyword issuanceMirrorToId initialized with the “result” trade Id.

• The “result” trade has the system keyword issuanceMirrorFromId initialized with the “source” trade Id, and its
comment mentions that this trade was created by a workflow rule.
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9. Generating Corporate Actions for War-
rants
Several events can occur in the life of Warrants and Certificates:

• Mark-Up: The issuer increases the size of its issuance. It will be captured as a new trade similar to an issuance.

• Mark-Down: The issuer decreases the size of its issuance. It can be captured as a closing trade on the issuance
product. Calypso also allows for generation of these trades with a Corporate Action.

• Expiry: At maturity, if the product is “out the money” (i.e., the underlying does not reach the strike), a Corporate
Action will close all liquidated positions and inventory positions on the related product.

• Exercise: When the product is “in the money”, the issuer can totally or partially close its issuance and pay
performance or/and deliver the underlying product to the owners of the Warrants. A Corporate Action will close all
liquidated positions and inventory positions, and will create a transfer for the payment of the performance and/or
a new trade for the buy/sell of the underlying product.

• Assignment: Once the underlying product reaches the strike of the Warrant, each owner can assign the issuer in
order to receive the performance and/or the underlying product. A Corporate Action on the issuance product will
close all positions, and will create a transfer for the performance and/or a trade on the underlying product.

• Barrier Deactivation: Once the strike is reached, the product is deactivated. It is not tradable anymore. At maturity,
a Corporate Action will close all positions and will create a transfer for the performance and/or a trade on the
underlying product.

• Strike / Parity / Name / ISIN change: The product can be updated in the Static Data. But if accounting events are
needed, a new product will be created, and a Corporate Action will transfer all positions from the old product to
the new one.

• Maturity Date change: The product is updated in the Static Data and the new maturity date is propagated to the
trades using the Process Trade.

• For warrants in which dividends are passed, a Corporate Action will be created on the dividend ex-date. This only
applies to warrants with an equity as an underlying.

• Coupons on Certificates: Use the same Corporate Action used for Bonds.

Exercising European Warrants
If the domain “Allow_Warrant_Exercise_On_Any_Date” does not exist or is empty, European Warrants cannot be
exercised before Maturity. If it contains Value = true, Warrants can be exercised on any date.

9.1 Creating Corporate Actions
Choose Trade Lifecycle > Corporate Action > Corporate Action to open the Corporate Action window as shown
below.

For coupons on certificates, the Corporate Actions can be automatically generated.
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Refer to Calypso Corporate Actions documentation for details.

Otherwise, you can define the Corporate Actions manually, as described below.

To define a Corporate Action, choose Calypso Navigator > Trade Lifecycle > Corporate Action > Corporate Action
and select the Create panel as shown below.

When capturing a Corporate Action on a Warrant or a Certificate, if an issuance position exists on this product, a
second Corporate Action is automatically created on the Issuance product. The opposite is not true when capturing a
Corporate Action on an Issuance product.

Sample Warrant Corporate Action

» To define a Corporate Action on a Warrant or a Certificate, enter the fields described below.

» See Option Corporate Action below for delivery options for Corporate Actions.

» Then click Save.

Fields Details
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Fields Description
Product Select a Warrant or a Certificate from the product chooser ....

Model Select the model:

EXERCISE: The product is "in the money”. Cash performance could be paid and underlying
product could be delivered. The Warrant positions are closed.

EXPIRY: The product is “out the money”. The Warrant positions are closed.

Sub Type Select the model’s subtype.

For model EXERCISE

• EXERCISE: The Corporate Action is related to the product and its issuance (if relevant).

• ASSIGNMENT: The Corporate Action is only related to the issuance.

For model EXPIRY

• MARK DOWN: Concerns “in house” products. The issuer decreases its issuance and
reimburses the bank which provides facilities. The positions are partially or totally closed
at historical price.

• EXPIRY: The product reaches the Maturity date. The positions are reversed to zero.

• BARRIER DEACTIVATION: Once the underlying product reaches the Strike, the Warrant
is deactivated. The positions are reversed to zero.

• MDE: With MDE (Market Disruption Event), a series of Corporate Actions will be created
to roll the expiry according to the default adjustment rule.

When the IPA is defined on the WarrantIssuance product or CertificateIssuance product, the
CA Option trades are generated with the counterparty role IPA instead of Agent.

This only applies to CA Option trades EXERCISE and EXPIRY for the EXERCISE_FEE.

Other fields The other data are managed in the same way as the other Corporate Actions.

9.1 .1 Opt ion Corporate Act ion
Choose Action > CA Option to bring up the Option Corporate Action window.

Nasdaq Calypso
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Option Corporate Action window

» Enter the fields described below, then click Apply.

Delivery Details

Fields Description
Delivery Type Initialized by default from the product.

It should be changed only for products which have the delivery type “Not known”.
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Fields Description
Delivery Parity Initialized by default from the product.

It could be changed for products with “Mix” or “Physical” delivery.

Unit Performance Enter the unit performance amount to pay, or click the heading to calculate it.

• Vanilla products: Unit Performance = Abs(Underlying quote - Strike) / Parity

• Capped Call: Unit Performance = [Min(Underlying quote, Strike2) - Strike] / Parity

• Capped Put: Unit Performance = [Strike - Max(Underlying quote, Strike2)] / Parity

• Quantovar and quanotfixe: Unit Performance = Abs(Underlying quote - Strike) / Parity * 1
/ FX rate

• Exotic warrant and certificate: No unit performance.

• Barrier: Unit Performance = Abs(Underlying quote - Strike) / Parity

• MINI: Unit Performance = Abs(Underlying quote - Strike) / Parity

• CBBC: Unit Performance = Abs(Underlying - Strike) / Parity

This field is not editable for products with “Physical” delivery.

Quotes Details

Fields Description
Option Quote Enter a quote when you want to close your Warrant positions at a fixed price, instead of zero.

Click the heading to feed the field from the product quotes (at Ex Date).

Default value is zero.

Use Historical Prices Tick this checkbox when you want to close your Warrant positions at historical price. It
should be used only in case of Barrier Deactivation.

Underlying Quote Enter a quote which will be used to calculate the Unit Performance.

Click the heading to feed the field from the product quotes (at Ex Date).

This field is not editable for products with “Physical” delivery. Default value is zero.

Adjustment Quote This quote will be used to valuate the Adjustment position.

Click the heading to feed the field from the product quotes (at Ex Date).

Default value is zero.

Delivery Quote Enter the delivery price of the underlying product.

This field is not editable for products with “Cash” delivery. Default value is the Strike of the
product.

You can disable the automatic population by setting the environment property AUTO_FEED_
DELIVERY_QUOTE to false.
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Partial Execution Details

Fields Description
Option Position Enter a number of Warrants if you want to apply the Corporate Action to a specified quantity.

Default value is zero and means that the Corporate Action is related to the whole position.

Agent When the previous field is fed, you must capture a Corporate Action by position managed in
Calypso. Enter the Agent of your Inventory Position.

A click on the red heading resets the field.

Book When the previous field is fed, you must capture a Corporate Action by position managed in
Calypso. Enter the Book of your Inventory Position.

A click on the red heading resets the field.

Legal Entities Details

Fields Description
Counterparty This field should be filled only in case of Assignment. If you need to identify it, enter the

Counterparty which wants to Assign the Issuer.

A click on the red heading resets the field.

Tools Menu
You can choose Tools > Check Quotes to check if quotes are missing (at Ex Date) on Warrants and Underlyings, and
you can capture them directly by clicking Set Quotes.
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9.2 Corporate Action Process

9.2 .1 Check ing for Miss ing Informat ion
Prior to applying the Corporate Actions, you can run the scheduled task WARRANT_PROCESSING. It allows checking
that all information is available prior to applying the Corporate Actions.

It generates exceptions for any missing information.

This only applies to expiring or knocking out CBBC and MINI warrants.
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» Set the attributes as needed.

"Operation = Upgrade floating strike (MINI)"
Only applies to the MINI subtype.

You can run the scheduled task with "Operation = Upgrade floating strike (MINI)" and "Barrier knock-out = false". If
either strike or stoploss (barrier) quotes are missing, an exception is created: “strike <quote name> for warrant
<description> <product id> is missing on value date <value date>”.

"Operation = Warrant CA"
Only applies to the MINI and CBBC subtypes.

You can run the scheduled task with "Operation = Warrant CA" and "Barrier knock-out = true".

• For the MINI subtype – If either strike or stoploss (barrier) quotes are missing then an exception is created: “barrier
<quote name> for warrant <description> <product id> is missing on value date <valuation date>”.

• For the CBBC subtype – If session1 or session2 quotes are missing, an exception is created: “Missing <quote
name1> & <quote name2> for warrant <description> <product id> are missing on value date <value date>”.

9.2 .2 Apply ing the Corporate Act ions
To apply a Corporate Action, from Calypso Navigator choose Trade Lifecycle > Corporate Action > Corporate Action
and select the Apply panel as shown below.
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Corporate Action window - Apply panel

» Click to display Corporate Actions corresponding to criteria specified in the upper section of the

Apply panel. You can click to add Corporate Actions using the Product Chooser Window.

» Click to retrieve the positions and compute the Corporate Action trades to be created. Positions
are calculated based on transfers by the Inventory Engine.

Refer to the Calypso Cash Management User Guide for information on generating back office positions.

» Click to create the Corporate Action trades.

Number of Securities
Firstly, the Corporate Action process calculates the number of securities which can be processed, depending on the
Expiry Size set up in the product.

Number of expiry size lot exercised = INT [Warrant Position / expiry size]
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When the product is “in the money” and if the position is not a multiple of the Expiry Size, the exceeding part of the
position (lost quantity) cannot participate to the Corporate Action calculations (performance and/or underlying
delivered). But the whole position is closed.

Lost Quantity = Warrant Position - Exercised Quantity

Physical and mix warrant or certificate, the number of underlying securities to deliver is calculated by warrant, based
on the expiry quantity.

Delivered Quantity = INT [Parity2 / Parity1 * expiry size] * number of expiry size lot exercised

If the Warrant position is not a multiple of the parity, a part of this position cannot be converted into the underlying
product. But it often happens that the Issuer converts this part into cash.

Adjustment Quantity = [(Parity2 / Parity1 * expiry size * number of expiry size lot exercised) - Delivered Quantity]

When the product is “in the money”, the Issuer will pay the owner(s) as follows.

Performance
Calculated in case of “Cash” or “Mix” delivery. The Unit Performance is related to one Warrant held.

Vanilla products:

Unit Performance = Abs(Underlying quote - Strike) / Parity

Capped Call:

Unit Performance = [Min(Underlying quote, Strike2) - Strike] / Parity

Capped Put:

Unit Performance = [Strike - Max(Underlying quote, Strike2)] / Parity

Quanto:

Unit Performance = Abs(Underlying quote - Strike) / Parity * 1 / FX rate

Exotic Warrant and Certificate:

No unit performance.

Compo products:

The Unit Performance is calculated in the product currency, taking into account the FX rate set up in the product.

Performance = Exercised Quantity * Unit Performance
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Barrier:

Unit Performance = Abs(final reference price - Strike) / Parity

MINI:

Unit Performance = Abs(final reference price - Strike) / Parity

CBBC:

CBBC = Abs(final reference price - Strike) / Parity

For bull CBBC, the final reference level is the lowest of the two special quotes.

For bear CBBC, the final reference level is the highest of the two special quotes.

Adjustment Valuation
In case of “Physical” or “Mix” delivery, if the Warrant position is not a multiple of the parity, the part of the position that
cannot be converted into the underlying product is valuated with the underlying quote or a specific quote captured in
the CA for Option panel.

Adjustment Valuation = Adjustment Quantity * Underlying Adjustment Quote

Both amounts will generate a fee linked to the closing trades.

 Ⓘ [NOTE: Physical delivery of International Warrants is a manual process. The delivery price and currency
must be provided in Corporate Action options in order for the settlement to be completed]

9.3 Expirat ion Process
Warrant expiration can be done manually or by using scheduled tasks.

9.3.1 Manual Expi rat ion

Generating the Corporate Action
First you need to generate the Corporate Action.

Choose Calypso Navigator > Trade Lifecycle > Corporate Action > CA Warrant Generation to open the
CAWarrantGeneration Report window.
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CAWarrantGeneration Report window - Filter panel

» Enter the expiry date in the Application Date field.

» Click .

CAWarrantGeneration Report window - Process panel

» Select the Process panel.

» Tick the Underlying checkbox.
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» Click Update Quotes.

» Click Validate All.

» Click Apply.

Applying the Corporate Action
After you have generated the Corporate Action, you need to apply it.

Double-click the Corporate Action to open it.

Corporate Action window - Apply panel

» Select the Apply panel.

» Select the Corporate Action and click .

» Click .
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9.3.2 Scheduled Task Expi rat ion
Warrant expiration can be done with a sequence of two scheduled tasks which first generate and then apply a
Corporate Action.

Generated Corporate Action

» Open the Scheduled Task Definition window and define a WARRANT_PROCESSING scheduled task with Task
Attributes as shown below.

» Run the scheduled task to generate the Corporate Action.

» Then define a CORPORATE_ACTION scheduled task.

– The MODEL and CATYPE Task Attributes both need to be set to EXERCISE.

– Set the other Task Attributes as needed. An example is shown below.
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» Run the scheduled task to apply the Corporate Action.
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