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1. Overview
This user guide describes the tasks of a typical day at the clearing member when using the Calypso Clearing
module:

• Completing the processes of the previous day

• Importing the trades of the current day

• Generating intraday margin calls

• Computing account positions

• Computing fees

• Importing the CCP files

• Running regulatory reporting

• Replicating initial margins

Before you Begin
You first need to install and configure the Clearing module.

Refer to the Calypso Clearing Member Setup Guide for installation and configuration details.
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2. Daily Tasks

2.1 Complet ing the Processes of the Previous Day
The following tasks need to be performed in order to complete the processes of the previous day :

• Checking that the EOD processes were successfully executed

• Sending the client statements to the clients

• Processing the margin calls

Make sure that the following engines and services are running:

• Exchange Feed Bridge engine

• Import Message engine

• Transfer engine

• Inventory engine

• Message engine

• Sender engine

• Margin Call engine

• Billing engine

• Scheduler engine

• ERS Web Services

• Limits engines

2.1 .1 Ver i fy ing Scheduled Tasks Execut ion
You first need to check that the EOD processes of the previous day were successfully executed.

You can view scheduled tasks exceptions in the Task Station.
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You can also select the "WARNING" exceptions to monitor warnings that will give you more details about the
execution.

Possible errors and solutions include the following:

• Missing CCP files - Make sure that the files are in the right location, and run the scheduled tasks again.

Refer to the Calypso Clearing Member Setup Guide for information on the files expected by the
scheduled tasks.

• Missing Data, like accounts, margin call contracts, attributes - Define the missing data, and run the
scheduled tasks again.

Refer to the Calypso Clearing Member Setup Guide for information on configuration requirements.

2.1 .2 Sending Cl ient Statements
If the client statements were successfully generated, you need to send them to the clients.

See Generating the Client Statements for details on the client statements generation.

From the Calypso Navigator, navigate to Reports > Message Reports > Message Report to view the client
statements that have been generated.

Select the message type "CLEARING_STATEMENT" for the previous day, and load the messages. They should
appear in status TO_BE_SENT.
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» Right-click the statements you want to send, and choose Action > SEND.

The statements will be sent to the clients electronically.

2.1 .3 Process ing Marg in Cal ls
Once the clients receive their statement for the previous day's activity, they can determine if there is a margin
deficit in their account which would require the deposit of additional funds. They will contact you (the clearing
member) during the day to let you know how they will meet the call: with cash, securities, or a combination of
both.

On the clearing member side, margin call trades have been generated for each client by the COLLATERAL_
MANAGEMENT scheduled task for the previous day as part of the EOD process on the IM and VM contracts,
and have been posted to the client statements.

These margin call trades are generated by default for the exact amount of the excess or deficit in the
currency in which it is reported. The currency is driven by the configuration of the Margin Call contracts for
each client.

See Computing Margin Calls for details on margin call trade generation.

When you (the clearing member) are contacted by the client with the details of how the margin calls will be
met, you can use the Collateral Manager to update the margin call trades according to the client's request.

Clients can choose to meet the margin calls that appear in the statement as follows:

• Scenario 1 - Meet the margin calls with cash for the exact amount and the same currency.

• Scenario 2 - Meet the margin calls with an excess of cash in the same currency (the client may want to
keep an excess of cash to avoid daily margin calls).

• Scenario 3 - Meet the margin calls in a different currency.

• Scenario 4 - Meet the margin calls by posting collateral securities (this only applies to IM margin calls).

• Scenario 5 - Meet the margin calls with a combination of cash and collateral securities (this only applies to
IM margin calls).

Scenario 1 only requires settling the margin call trades already generated.

The other scenarios require using the Collateral Manager to modify the margin call trades.

The scenarios are detailed below.
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Scenario 1
Meet the margin calls with cash for the exact amount and the same currency.

In this case, you just need to settle the margin calls that have been generated as of the day before. You can
do this using the Transfer Report, or the Task Station.

For example, navigate to Reports > Fees & Settlements > Transfer Report from the Calypso Navigator.

Set the start and end date to the client statement's date, and select the MarginCall product type, then load
the corresponding transfers.

» Right-click the margin call transfers that you want to settle, and choose Action > SETTLE.

Scenario 2
Meet the margin calls with an excess of cash in the same currency (the client may want to keep an excess of cash to
avoid daily margin calls).

From the Calypso Navigator, navigate to Processing > Collateral Management > Collateral Manager.

Set the process date to the client statement's date (the previous day), and load the Collateral Manager report
template used to run the COLLATERAL_MANAGER scheduled task.
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Select the contract you want to modify, it will show additional panels at the bottom of the Collateral Manager.

Select the Allocation panel to view the actual margin call trade.

» Open the Margin Call trade - You can double-click the trade, or right-click the trade and choose Show >
Trade.
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Modify the Principal amount as needed, and save the trade.

The margin call trade is modified accordingly.

» Right-click the contract and choose Action > AMEND to save the changes.

» You can now settle the margin call transfers as described in Scenario 1.

Scenario 3
Meet the margin calls in a different currency.

From the Calypso Navigator, navigate to Processing > Collateral Management > Collateral Manager.
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Set the process date to the client statement's date (the previous day), and load the Collateral Manager report
template used to run the COLLATERAL_MANAGER scheduled task.

Select the contract you want to modify, it will show additional panels at the bottom of the Collateral Manager.

You can select the Allocation panel to view the actual margin call trade.

» Click Allocate to bring up the Allocation window. It allows you to modify the margin call.

Select the Daily Allocation panel.
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You can enable the Daily Allocation panel from the "Window > Show View" menu if it does not appear.

» Select the row that you want to substitute, and click the substitute icon. It creates a reverse row in the
Allocation panel.
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In the Cash panel, double-click the currency that you want to use from the list of eligible currencies, and
the system creates a new row in the selected currency.

Eligible currencies are defined in the margin call contract.

Click Applywhen you are done.

The margin call trades are created accordingly: the reverse trade and the new trade.

» Right-click the contract and choose Action > SUBSTITUTE to save the changes.

» You can now settle the margin call transfers as described in Scenario 1.

Scenario 4
Meet the margin calls by posting collateral securities (this only applies to IM margin calls).

From the Calypso Navigator, navigate to Processing > Collateral Management > Collateral Manager.

Set the process date to the client statement's date (the previous day), and load the Collateral Manager report
template used to run the COLLATERAL_MANAGER scheduled task.
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Select the contract you want to modify, it will show additional panels at the bottom of the Collateral Manager.

You can select the Allocation panel to view the actual margin call trade.

» Click Allocate to bring up the Allocation window. It allows you to substitute the margin call.

Select the Daily Allocation panel.
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You can enable the Daily Allocation panel from the "Window > Show View" menu if it does not appear.

» Select the row that you want to substitute, and click the substitute icon. It creates a reverse row in the
Allocation panel.
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In the Security panel, load the eligible securities. Then double-click the security that you want to use, and
the system creates a new row.

Enter the nominal.

Repeat for other securities as needed.

Eligible securities are defined in the margin call contract.

Click Applywhen you are done.

The margin call trades are created accordingly.
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» Select the contract and choose Action > SUBSTITUTE to save the changes.

» You can now settle the margin call transfers as described in Scenario 1.

Scenario 5
Meet the margin calls with a combination of cash and collateral securities (this only applies to IM margin calls).

From the Calypso Navigator, navigate to Processing > Collateral Management > Collateral Manager.

Set the process date to the client statement's date (the previous day), and load the Collateral Manager report
template used to run the COLLATERAL_MANAGER scheduled task.

Select the contract you want to modify, it will show additional panels at the bottom of the Collateral Manager.
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You can select the Allocation panel to view the actual margin call trade.

» Click Allocate to bring up the Allocation window. It allows you to substitute the margin call.

Select the Daily Allocation panel.

You can enable the Daily Allocation panel from the "Window > Show View" menu if it does not appear.
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» Select the row that you want to substitute, and click the substitute icon. It creates a reverse row in the
Allocation panel.
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Modify the nominal of the reverse row, so that you don't reverse the whole cash margin call but you
reverse it partially.

In the Security panel, load the eligible securities. Then double-click the security that you want to use, and
the system creates a new row.

Enter the nominal.

Repeat for other securities as needed.

Click Applywhen you are done.

The margin call trades are created accordingly.
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In this example, you a have USD 100,000 cash margin call, and two collateral securities.

» Select the contract and choose Action > SUBSTITUTE to save the changes.

» You can now settle the margin call transfers as described in Scenario 1.
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2.2 Import ing Trades
The trades are captured on the Affirmation Platform and are automatically imported into Calypso.

All the steps between the trade capture on the Affirmation Platform and the VERIFIED status in Calypso, are
executed in straight-through processing. They may happen without any user intervention if all the conditions
are met. The role of the user is to monitor the proper execution of the processes.

2.2 .1 Process ing Messages through the Exchange Feed
Trades are captured on the Affirmation Platform and routed to Calypso through the CCP and Exchange Feed
using Trade Event messages of type BRIDGEMSG.

Based on the BRIDGEMSG workflow shown below, the messages are first created in status PENDING. Then
they advance through the workflow as they meet the specified conditions, and trigger additional processes.

 Ⓘ [NOTE: Transitions highlighted in blue are STP transitions]

PENDING Status
The BRIDGEMSGmessage is transformed into an Upload Document through the "TransformBridge" rule.

If the transformation is successful, the message automatically moves to status TRANSFORMED, and the
ExchangeFeedBridgeEngine creates a GATEWAYMSGmessage that triggers the Data Uploader. See below.

If the transformation is not successful, the trade remains in status PENDING and an exception is raised in
the Task Station. You can monitor the messages in status PENDING.
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Once you fix the error, you can manually apply the action LOAD that will attempt to transform the message
again, and move the trade to status COMPLETED if it is successful.

TRANSFORMED Status
Once the message is in status TRANSFORMED, and if the creation of the trades has been successful, the
Exchange Feed Bridge engine will update the message with the Trade ID and the GATEWAYMSGmessage
status through the "MergeTradeId" rule. The BRIDGEMSGmessage moves to status COMPLETED.

If the creation of the trades is not successful, the Exchange Feed Bridge engine cancels the message, and it
moves to status CANCELED.

COMPLETED Status

The COMPLETED status reflects messages for which the trades have been created.

Once the messages are completed, they have reached the end of their lifecycle.

You can view COMPLETED BRIDGEMSGmessages in the Message report.

From the Calypso Navigator, navigate to Reports > Message Reports > Message Report.

You can select today's messages of type "BRIDGEMSG" and status COMPLETED.

Sample trade messages received from the CCP.
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When you double-click a message, you can view the actual message document sent by the CCP.
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2.2 .2 Process ing Messages through the Data Uploader
The GATEWAYMSGmessages are processed by the Data Uploader to create the trades.

Based on the GATEWAYMSG workflow shown below, the messages are first created in status PENDING_
VALID. Then they advance through the workflow as they meet the specified conditions, and trigger additional
processes.
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 Ⓘ [NOTE: Transitions highlighted in blue are STP transitions]

PENDING_VALID Status
The GATEWAYMSGmessage is validated and the trades are created through the "Validate" rule. Two trades
are created in Calypso: a trade to reflect the clearing member position at the CCP, and a trade to reflect the
client / house position at the clearing member. See below for details on the trade workflow.

If the trades are successfully created, the GATEWAYMSGmessage moves to status PENDING_TRADE and
COMPLETED.

If the trades are not created, the GATEWAYMSGmessage remains in status PENDING_VALID, and an
exception is raised in the Task Station. You can monitor the messages in status PENDING_VALID.

COMPLETED Status
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Once the messages are completed, they have reached the end of their lifecycle.

2.2 .3 Navigat ing the Trade Workf low
Based on the trade workflow shown below, the trades are first created in status PENDING. Then they
advance through the workflow as they meet the specified conditions, and trigger additional processes.

 Ⓘ [NOTE: Transitions highlighted in blue are STP transitions]

PENDING Status
The limits are checked on the PENDING trades against the ERS Limits of the previous day, and the trades
automatically move to status LIMIT_CHECK and REQUIRES_CONSENT. Trade keywords are set on the trades
to indicate if the limits have passed or not, see below.

REQUIRES_CONSENT Status
If the limits check passes, the trades automatically move to status CONSENT_GRANTED and CREDIT_
CONSENTED.

If the limits check fails, the trades automatically move to status LIMIT_FAILED.

CREDIT_CONSENTED Status

Nasdaq Calypso
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You can view trades in CREDIT_CONSENTED status in the Trade Browser or in the Task Station, while they
are awaiting to be cleared.

You can double-click a trade to bring it up, and choose Trade > Trade Attributes to check the trade keywords.

When a trade reaches this status, a consent message is sent to the CCP.

Sample Calypso CONSENT message sent to the CCP.

The CCP replies with a message indicating if the trade is cleared or not.

Sample "CLEARED" message received from the CCP.
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If the trade is cleared, the trade keywords are amended to reflect the cleared status, and the trade
automatically moves to status CLEARED, and to status VERIFIED provided the settlement instructions are
properly set on the trades.

If the trade is not cleared, it automatically moves to status REJECTED.

LIMIT_FAILED Status

You can view trades in LIMIT_FAILED status in the Trade Browser or in the Task Station, and manually
accept or reject the trades.

You can double-click a trade to bring it up, and choose Trade > Trade Attributes to check the trade keywords.
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To accept a trade in the Trade Browser, right-click a trade and choose Action > ACCEPT. The trade will move
to status CONSENT_GRANTED and CREDIT_CONSENTED.

To reject a trade in the Trade Browser, right-click a trade and choose Action > REJECT. The trade will move
to status CONSENT REJECTED.

CONSENT REJECTED Status
When the trades reach the status CONSENT REJECTED, a reject message is sent to the CCP.

You can view trades in CONSENT REJECTED status in the Trade Browser or in the Task Station, and manually
reject the trades. They will move to status REJECTED.

REJECTED Status

You can view trades in status REJECTED in the Trade Browser or in the Task Station.

Trades maybe rejected because they failed the limits check, or because they were refused by the CCP.

Once the trades are rejected, they have reached the end of their lifecycle.

CLEARED Status

If the settlement instructions are not set on the trades, the trades remain in status CLEARED, and an
exception is raised in the Task Station. You can monitor the trades in status CLEARED.
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VERIFIED Status

You can view trades in status VERIFIED in the Trade Browser using the "New Trades" trade filter for
example.

In this example, the first 2 trades are the mirror trades created for a client trade, and the last 2 trades are the
mirror trades created for a house trade.

Once the trades are verified, they trigger various processes in the system: Account positions, fees
computation, etc. See details below.
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2.3 Generat ing Intraday Margin Cal ls
This currently only applies to LCH.

You can generate intraday margin calls as margin calls are made by LCH during the day.

The margin call trades are generated by the scheduled task CLEARING_INTRADAY_MARGIN which is
automatically executed throughout the day by the Scheduler engine.

The margin call trades are associated with the IM contracts (client or house) of the clearing member facing
the CCP, and can be viewed in the Collateral Manager as “previous margin”.

Sample LCH report:

Margin call trade generated by the scheduled task:

The trade keyword "ITDTimestamp" shows the time of the margin call.

Margin call entry in the Collateral Manager:
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In this example, it would result in a return of collateral at EOD.
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2.4 Computing Account Posit ions
Trades in status VERIFIED update the account positions using the Transfer engine, the Inventory engine, and
the Margin Call engine:

• CASH_SETTLEMENT clearing transfers update:

– The Client - Cash Account @ Clearing Member positions

– The Internal Counterparty - Cash Account @ Clearing Member positions

– The Margin_Call positions

– The Clearing Member - House Nostro Account @ Agent positions

– The Clearing Member - Agent Nostro Account @ Agent positions

You can view account positions using the Inventory Position report.

From the Calypso Navigator, navigate to Reports > Nostro/Custodian Positions > Inventory Position.

Sample inventory positions:
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2.5 Computing Fees
Fees are computed on the trades based on the fee configuration:

• Daily fees - Clearing Member COMMISSION_FEE and Clearing Member EXECUTION_FEE

Daily fees are automatically computed on the trades when the trades move to status VERIFIED through
the AutomaticFees rule.

• Periodic fees - CCP COMMISSION_FEE, CCP MAINTENANCE_FEE, Clearing Member MAINTENANCE_FEE

Periodic fees are automatically computed on billing trades.

• Initial margin fees - IM_BASED_FEE, automatically computed on billing trades.

You can monitor fees in the Consolidated Fee Report.

From the Calypso Navigator, navigate to Reports > Fees & Settlements > Consolidated Fee Report.
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2.6 Import ing the CCP Fi les
The CCP files are imported into Calypso using scheduled tasks. The scheduled tasks are automatically
executed by the Scheduler engine.

The scheduled tasks perform the following:

• CDML files processing - You first need to store the files into the system using the scheduled task
CLEARING_TRANSLATE_TO_CDML. Then you can process the files using the scheduled task CLEARING_
PROCESS_FROM_CDML.

The scheduled task CLEARING_PROCESS_FROM_CDML consumes the imported tradeValuationReport
and initialMarginRreport CDML reports.

• A set of scheduled tasks allow importing market data:

– CLEARING_IMPORT_MARKET_DATA

– CLEARING_IMPORT_SCENARIO_SHIFTS

If any error occurs during the scheduled tasks processing, an exception is raised in the Task Station.

If the scheduled tasks are successful, you can view the trades in the Trade Browser, and double-click a trade
to view its details.

Sample Clearing Transfer trade of type CASH_SETTLEMENT.
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Sample Collateral Exposure trade.

Sample PL Marks for CollateralExposure trades are displayed using Position & Risk > Official P&L Marks >
Official P&L Mark Report from the Calypso Navigator.
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2.6.1 Import ing Market Data
Market data are used to compute margin call requirements, and to replicate margins.

The following scheduled tasks are automatically executed by the Scheduler engine to import market data:

• CLEARING_IMPORT_MARKET_DATA:

– Variation margin curves

– Initial margin curves

– Rate Index quotes and FX quotes

• CLEARING_IMPORT_SCENARIO_SHIFTS:

– Curve shifting scenarios for ERS Risk calculations

Setup examples are described in details in the Calypso Clearing Margin Estimation Guide.

2.6.2 Comput ing Marg in Cal ls
By default, the margin calls are computed in Cash on the initial margins and variation margins using the
scheduled task COLLATERAL_MANAGEMENT.

This scheduled task is automatically executed by the Scheduler engine.

 Ⓘ [NOTE: The template is a Collateral Manager template]

For IM contracts, the scheduled task loads the corresponding Collateral Exposure trades.
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For VM contracts, the scheduled task loads the cash accounts associated with the margin call contracts. The
exposure is the inventory THEORETICAL Margin_Call position that has been updated by the CASH_
SETTLEMENT Clearing Transfer trades.

You can use the Collateral Manager to view the exposure on the various contracts. See examples below.

From the Calypso Navigator, navigate to Processing > Collateral Management > Collateral Manager.

Sample IM Contract

Sample VM Contract - Single Currency Scenario
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All the positions are converted to the base currency.
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Sample VM Contract - Multi Currency Scenario
There is one VM contract for each currency, and a margin call for each currency.

USD

GBP

Based on the generated cash margin calls, IM requirements and VM requirements will be posted to the client
statement, and the clients can choose how to meet those requirements.

See Process Margin Calls for details.

2.6.3 Generat ing the Cl ient Statements
The scheduled task CLEARING_STATEMENT generates the client statements.

This scheduled task is automatically executed by the Scheduler engine.
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From the Calypso Navigator, navigate to Reports > Message Reports > Message Report to view the client
statements.

You can double-click a CLEARING_STATEMENT message to view the actual statement.
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2.6.4 "Defau l t " C l ient Statement

Partial view of a "Default" client statement

The fields of the client statement are described in details below.

All the fields are populated for the client statement’s date unless otherwise specified.

Clearing Cash Flows Summary
The clearing cashflows are displayed in the Client Statement based on the Fee transfer dates using the logic
described below.

Logic of Non-NPV Flows (fees other than CS_NPV_ADJUSTED and CS_NPV_REV)

The following non-NPV Clearing Cashflows are included in the Client Statement: any fee where, Known Date
≤ Statement Date ≤ Available Date < Settle Date.
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From this set of fees, we determine whether they are pending or not using the Available Date. When the
Available Date of the Fee is equal to the Statement Date, they are not pending and are included in the
Financial Summary section of the statement. In all other cases, the amounts are considered pending and re
included in the pending section of the statement.

Logic of NPV Flows (CS_NPV_ADJUSTED and CS_NPV_REV fees)

The logic is slightly different because these amounts are a snapshot of the position valuation at one point in
time. Therefore we only want to include this amount in the statement on one and only one date.

The criteria for including NPV flows in the statement is to include only those fees whose Known Date is equal
to the Statement Date.

From this set of fees, if the Available Date of the Fee is equal to the Statement Date, the fee is included in the
non-pending section of the statement. If the Available Date is not equal to the Statement Date, the fee is
included in the pending section of the statement.

Client Statement Field Calypso Source

Beginning Cash
Balance

= Starting Balance from Account Activity report - NPV - Cash Initial Margin.

Starting Balance from Account Activity report for Client Cash Accounts based on
ACTUAL Client positions.

The system uses the Account Activity report template provided when running the
scheduled task.

 Ⓘ [NOTE: ACTUAL positions are based on settled transfers from CASH_
SETTLEMENT clearing transfer trades]

NPV is NPV from previous day (CS_NPV_ADJUSTED transfers for which Available
Date = Statement Date - 1 business day, based on the Clearing Business Calendar).

Initial Margin is the “Value” column of the Margin Call Position report.

Commissions/Fees Non pending fees.

COMMISSION from CASH_SETTLEMENT clearing transfer trades.

TERM_FEES from CASH_SETTLEMENT clearing transfer trades.

FEE from CASH_SETTLEMENT clearing transfer trades.

IM_BASED_FEE from billing trades.

PAI Non pending fees.

CS_PAI from CASH_SETTLEMENT clearing transfer trades.

Coupons Non pending fees.

CS_COUPON from CASH_SETTLEMENT clearing transfer trades.

CS_CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.

CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.
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Client Statement Field Calypso Source

CS_INTERESTS from CASH_SETTLEMENT clearing transfer trades.

FRA Settlements Non pending fees.

CS_FRA_PAYMENT from CASH_SETTLEMENT clearing transfer trades.

Upfront Fees Non pending fees.

CS_FEES from CASH_SETTLEMENT clearing transfer trades.

CS_CONSIDERATN from CASH_SETTLEMENT clearing transfer trades.

Cash Movements Settled COLLATERAL, SUBSTITUTION, and MARGIN_CALL cash movements from
Account Activity report for Client Cash Accounts based on ACTUAL Client positions.

Available Date = Statement Date.

Ending Cash Balance = Beginning Cash Balance + Commissions/Fees + PAI + Coupons + FRA Settlements
+ Upfront Fees + Cash Movements

<CCP> <Product
Type> NPV

Non pending fees.

CS_NPV_ADJUSTED from CASH_SETTLEMENT clearing transfer trades.

Total NPV Total of all <CCP> <Product Type> NPV rows.

Total Equity = Ending Cash Balance + Total NPV

Pending
Commissions/Fees

Pending fees.

COMMISSION from CASH_SETTLEMENT clearing transfer trades.

TERM_FEES from CASH_SETTLEMENT clearing transfer trades.

FEE from CASH_SETTLEMENT clearing transfer trades.

IM_BASED_FEE from billing trades.

Pending PAI Pending fees.

CS_PAI from CASH_SETTLEMENT clearing transfer trades.

Pending Coupons Pending fees.

CS_COUPON from CASH_SETTLEMENT clearing transfer trades.

CS_CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.

CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.

CS_INTERESTS from CASH_SETTLEMENT clearing transfer trades.

Pending FRA Set-
tlements

Pending fees.

CS_FRA_PAYMENT from CASH_SETTLEMENT clearing transfer trades.

Pending Upfront Fees Pending fees.

CS_FEES from CASH_SETTLEMENT clearing transfer trades.
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Client Statement Field Calypso Source

CS_CONSIDERATN from CASH_SETTLEMENT clearing transfer trades.

Pending Cash
Movements

The Pending Cash Movements row is sourced from the transfers of type
COLLATERAL, SUBSTITUTION and MARGIN_CALL based on the following criteria:
Xfer Trade Date <= Statement Date, Xfer Trade Date < Xfer Settle Date, and Xfer
Settle Date > Statement Date.

Pending NPV Pending fees.

CS_NPV_ADJUSTED from CASH_SETTLEMENT clearing transfer trades.

Total Pending Cash = Sum (Pending: Commissions/Fees, PAI, Coupons, FRA Settlements, Upfront Fees,
NPV)

Total Equity plus
Pending Cash

= Total Equity + Total Pending Cash

FX Rates FX rate.

Separate Settlements
Only appears when you have chosen to breakdown variation margins by components.

Same as "Financial Summary - Clearing Cash Flows" for the cashflows associated with the variation margin
contract.

Initial Margin Summary
There is one section per currency.

Client Statement Field Calypso Source

Margin Requirement Initial margin amount calculated by the CCP. Amount from the CCP files.

Net Balance from margin call contract.

Cash Collateral Current market value of cash deposited as collateral for IM contracts from Margin
Call Position report "All in Value" for IM cash.

Non Cash Collateral Current market value of securities deposited as collateral from Margin Call Position
report "All in Value" for securities.

Total Collateral = Cash Collateral + Non Cash Collateral

Excess/Deficit = Margin Requirement + Total Collateral

Pending Cash
Collateral

Unsettled CASH margin call trade with Settlement Date > Statement Date + 1
business day.

Pending Non-Cash
Collateral

Unsettled SECURITY margin call trade with Settlement Date > Statement Date + 1
business day.

Nasdaq Calypso
Clearing Member User Guide / Version Suite 17 and Suite 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 46 / 72



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 47 / 72

Client Statement Field Calypso Source

Total Pending
Collateral

= Pending Cash Collateral + Pending Non-Cash Collateral

Total Collateral Plus
Pending Collateral

= Total Collateral + Total Pending Collateral

Excess/Deficit
Including Pending
Collateral

= Excess/Deficit + Total Pending Collateral

Summary of Payments

Client Statement Field Calypso Source

Clearing Cash Flows = Total Equity plus Pending Cash

Initial Margin = Sum (Excess/Deficit Including Pending Collateral)

Net Excess/Deficit = Clearing Cash Flows + Initial Margin

FX Rates FX rates.

Trading Activity
There is one section per product type.

The system uses the Trade Browser report templates "New Trades for IRS", "New Trades for FXNDF", "New
Trades for CDX" provided when running the scheduled task CLEARING_STATEMENT.

It shows trades cleared on the client statement's date.

Open Trades
There is one section per product type.

The system uses the Trade Browser report templates "Open Trades for IRS", "Open Trades for FXNDF", "Open
Trades for CDX" provided when running the scheduled task CLEARING_STATEMENT.

It shows trades cleared before the client statement's date.

Terminated Trades
There is one section per product type.

The system uses the Trade Browser report template "Terminated Trades for IRS", "Terminated Trades for
FXNDF", "Terminated Trades for CDX" provided when running the scheduled task CLEARING_STATEMENT.

It shows trades terminated on the client statement's date.
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Matured Trades
There is one section per product type.

The system uses the Trade Browser report template "MaturedTrades for IRS", "Matured Trades for FXNDF",
"Matured Trades for CDX" provided when running the scheduled task CLEARING_STATEMENT.

It shows trades matured on the client statement's date.

Account Activity
The system uses the Account Activity report template "Account Activity Template" provided when running
the scheduled task CLEARING_STATEMENT.

It shows the Client ACTUAL cash positions.

It shows the following:

• Clearing fees (e.g. PAI, Coupons, Upfront fees, etc.), provided they are settled (as the template uses the
ACTUAL cash positions)

• VMmargin call trades (Cash Movements).

• FCM’s fees

• Other amounts (e.g. interests, adjustments, rebates, etc.)

Pending Account Activity
The system uses the Account Activity report template "Account Activity Template" provided when running
the scheduled task CLEARING_STATEMENT.

It shows however the Client THEORETICAL cash positions on position date = Trade Date.

It shows the cashflow types: INTEREST, PAYDOWN, COLLATERAL, SUBSTITUTION, MARGIN CALL for Margin
Call Type “VM”.

The Pending Account Activity can be reconciled with the pending sections of the Separate Settlements and
Clearing Cash Flow Summary sections.

Margin Call Activity
The system uses the Collateral Manager "Allocation" report template "Collateral Allocation Template"
provided when running the scheduled task CLEARING_STATEMENT.

It shows the margin calls generated by the scheduled task COLLATERAL_MANAGEMENT.
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Margins on Deposit
The system uses the Collateral Manager "Margin Call Position" report template "Collateral Position Template"
provided when running the scheduled task CLEARING_STATEMENT.

It shows the Margin_Call ACTUAL positions.

For a description of the templates used by the scheduled task CLEARING_STATEMENT, please refer to the
Calypso Clearing Member Setup Guide.
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2.6.5 "Condensed" Cl ient Statement

Partial view of a "Condensed" client statement

The fields of the client statement are described below.

All the fields are populated for the client statement’s date unless otherwise specified.
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Clearing Cash Flows Summary

Client Statement Field Calypso Source

FX Rates FX rate.

Intraday Funding
Amount

ITD margin calls.

Beginning Cash
Balance

= Starting Balance from Account Activity report - NPV - Cash Initial Margin -
Beginning Cash Balance from separate settlements

Starting Balance from Account Activity report for Client Cash Accounts based on
ACTUAL Client positions.

The system uses the Account Activity report template provided when running the
scheduled task.

 Ⓘ [NOTE: ACTUAL positions are based on settled transfers from CASH_
SETTLEMENT clearing transfer trades]

NPV is NPV from previous day (CS_NPV_ADJUSTED transfers for which Available
Date = Statement Date - 1 business day, based on the Clearing Business Calendar).

Initial Margin is the “Value” column of the Margin Call Position report.

<clearing member>
Commissions

Non pending fees.

Fees from billing trades and simple transfer trades:

<clearing member>_<CCP>_TRANS_FEE

<clearing member>_<CCP>_MAINT_FEE

<clearing member>_<CCP>_CUSTODY_FEE

<clearing member>_<CCP>_IM_FEE

<CCP> Fees Non pending fees.

IM_BASED_FEE from billing trades and simple transfer trades.

PAI Non pending fees.

CS_PAI from CASH_SETTLEMENT clearing transfer trades.

Coupons Non pending fees.

CS_COUPON from CASH_SETTLEMENT clearing transfer trades.

CS_CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.

CASH_DELIVERY from CASH_SETTLEMENT clearing transfer trades.

CS_INTERESTS from CASH_SETTLEMENT clearing transfer trades.

FRA Settlements Non pending fees.
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Client Statement Field Calypso Source

CS_FRA_PAYMENT from CASH_SETTLEMENT clearing transfer trades.

FX Settlements PRINCIPAL from CASH_SETTLEMENT clearing transfer trades.

Upfront Fees Non pending fees.

UPFRONT_FEE from CASH_SETTLEMENT clearing transfer trades.

CS_FEES from CASH_SETTLEMENT clearing transfer trades.

CS_CONSIDERATN from CASH_SETTLEMENT clearing transfer trades.

Interest INTEREST from interest bearing trades, billing trades, and from Account Activity
report for Client Cash Accounts based on ACTUAL Client positions.

Cash Movements Settled PAYDOWN, COLLATERAL, SUBSTITUTION, and MARGIN_CALL cash
movements from Account Activity report for Client Cash Accounts based on
ACTUAL Client positions.

Available Date = Statement Date.

Ending Cash Balance = Beginning Cash Balance + Commissions + Fees + PAI + Coupons + FRA
Settlements + FX Settlements + Upfront Fees + Interest + Cash Movements

<CCP> <Product
Type> NPV

Non pending fees.

CS_NPV_ADJUSTED from CASH_SETTLEMENT clearing transfer trades.

Net VM Excess/Deficit = Ending Cash Balance + Total of all <CCP> <Product Type> NPV rows.

Pending Settlements Pending:

<clearing member> Commissions

<CCP> Fees

PAI

Coupons

FRA Settlements

FX Settlements

Upfront Fees

Cash Movements

NPV

Net VM Excess/Deficit
(Incl. Pending)

= Net VM Excess/Deficit + All pending settlements

<CCP> <product> Mar-
gin Requirement

Initial margin amount calculated by the CCP. Amount from the CCP files.

= Net Balance (no buffer) from margin call contract

The domain "Collateral.Multiplier" must contain the value “Buffer” so that the system
can report margin requirements based on collateral multipliers.
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Client Statement Field Calypso Source

<clearing member> IM
(%)

= Net Balance (with buffer) - Net Balance (no buffer)

<clearing member>
Buffer

= Buffer

Total IM Requirement = Margin Requirement + IM (%) + Buffer

IM Cash Balance Cash collateral position.

IM Non Cash Balance Non cash collateral position.

Total Collateral = IM Cash Balance + IM Non Cash Balance

Net IM Excess/Deficit = Total Collateral - Total IM Requirement

IM Cash (Pending) = Cash Theoretical Position Valuation – Cash Actual Position Valuation

IM Non-Cash
(Pending)

= (Non-Cash Theoretical Position Valuation) – (Non-Cash Actual Position Valuation)

Total IM Collateral
(Pending)

= IM Cash (Pending) + IM Non-Cash (Pending)

Net IM Excess/Deficit
(Incl. Pending)

= Net IM Excess/Deficit + Total IM Collateral (Pending)

Net Excess/Deficit = Net IM Excess/Deficit (Incl. Pending) + Net VM Excess/Deficit (Incl. Pending)

Separate Settlement
<VM flow>

Separate VM flow.

Net Excess/Deficit
Separate Settlement

Total of all Separate Settlements

Trading Activity
There is one section per product type.

The system uses the Trade Browser report templates "New Trades for IRS", "New Trades for FXNDF", "New
Trades for CDX" provided when running the scheduled task.

It shows trades cleared on the client statement's date.

Open Trades
There is one section per product type.

The system uses the Trade Browser report templates "Open Trades for IRS", "Open Trades for FXNDF", "Open
Trades for CDX" provided when running the scheduled task.

It shows trades cleared before the client statement's date.
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Terminated Trades
There is one section per product type.

The system uses the Trade Browser report template "Terminated Trades for IRS", "Terminated Trades for
FXNDF", "Terminated Trades for CDX" provided when running the scheduled task.

It shows trades terminated on the client statement's date.

Matured Trades
There is one section per product type.

The system uses the Trade Browser report template "MaturedTrades for IRS", "Matured Trades for FXNDF",
"Matured Trades for CDX" provided when running the scheduled task.

It shows trades matured on the client statement's date.

Account Activity
The system uses the Account Activity report template "Account Activity Template" provided when running
the scheduled task.

It shows the Client ACTUAL cash positions.

Margin Call Activity
The system uses the Collateral Manager "Allocation" report template "Collateral Allocation Template"
provided when running the scheduled task.

It shows the margin calls generated by the scheduled task COLLATERAL_MANAGEMENT.

Margins on Deposit
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The system uses the Collateral Manager "Margin Call Position" report template "Collateral Position Template"
provided when running the scheduled task.

It shows the Margin_Call ACTUAL positions.

2.6.6 Comput ing EOD Limits
The EOD limits are computed using the ERS_ANALYSIS scheduled task. It is automatically executed by the
Scheduler engine.

You can view the availability in ERS Limits.

Sample Availability

The EOD availability will be used the day after for pre-deal limit checks on the trades.
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2.7 Running Regulatory Report ing

2.7 .1 Parent / Chi ld Relat ionships
When a parent/child relationship is defined between accounts, it must also be defined between the legal
entities. The reports Liquidity Deficit and Aged Margin will aggregate information under the parent.

Example:

CYP_HF1_1 is linked to the parent CYP_HF1.

Both reports will show aggregated information under CYP_HF1, representing data for CYP_HF1 and CYP_HF1_
1.

2.7 .2 CFTC Min imum Net Capi ta l Requi rement
This report is obtained using the Minimum Capital Requirement window (menu action
reporting.ReportWindow$MinimumCapitalRequirement).

Define the report template. Typical setup of the report template should be:

• Activity: 0d to run the report for today's activity (to run the report for the previous day, use -1d instead).

• CMF: Select the clearing member.

• CCP: Select the CCP.

Nasdaq Calypso
Clearing Member User Guide / Version Suite 17 and Suite 18

February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 56 / 72



February 2024
Revision 1.0 / Approved

Proprietary and Confidential
Page 57 / 72

You can use the scheduled task EOD_CMF_REPORT to generate a PDF or HTML document at the required
format.

REPORT TYPE = MinimumCapitalRequirement

Sample Report
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NOTE: Data can also be exported from the report window or the REPORT scheduled task in the usual Calypso
formats (XLS, CSV, etc.). In this case the export only contains raw data, without the above formatting.

2.7 .3 Sequestrat ion Fund Requi rement
This report is obtained using the Sequestration Fund Requirement window (menu action
reporting.ReportWindow$SequestrationFundRequirement).

Define the report template. Typical setup of the report template should be:

• Activity: 0d to run the report for today's activity (to run the report for the previous day, use -1d instead).

• CMF: Select the clearing member.

• CCP: Select the CCP.

• CCY: Select a currency to run the report for a given currency, or none for all currencies.

• Collateral Context: Select "default".
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You can use the scheduled task EOD_CMF_REPORT to generate a PDF or HTML document at the required
format.

REPORT TYPE = SequestrationFundRequirement

You can set "GENERATE SUPPORTING REPORTS? = TRUE" to generate individual reports for each eligible
currency, in addition to the multi-currency report. Otherwise, only the multi-currency report is generated.

Eligible currencies are currencies with currency attribute “ClearingEligible” = True.

When multiple currencies are selected, the values are reported in native currency and in base currency.

Sample Report
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NOTE: Data can also be exported from the report window or the REPORT scheduled task in the usual Calypso
formats (XLS, CSV, etc.). In this case the export only contains raw data, without the above formatting.

The report details are described below.

Column Formula

1-A Cash Net
Ledger
Balance

= Sum of closing balances from client cash account activity at Trade Date D-1 minus Sum of
CS_NPV_ADJUSTED fees from the client CASH_SETTLEMENT Clearing Transfer trades at
Trade Date D-1, for which the fee known date is equal to the trade’s settlement date

1-B Securities
Net Ledger
Balance

= Sum of market values (converted to USD) from ACTUAL client security margin call positions

2 Net
Unrealized
Profit

= Sum of fees defined in domain "NPVFlows" from the client CASH_SETTLEMENT Clearing
Transfer trades at Trade Date D-1, for which the fee known date is equal to the trade’s
settlement date

The domain "NPVFlows" contains CS_NPV_ADJUSTED and NPV_ADJUSTED by default.

3-A Market
Value of Open
Contracts
Purchased

Defaults to 0.

3-B Market
Value of Open
Contracts
Sold

Defaults to 0.

4 Net Equity = Line 1-A + Line 1-B + Line 2 + Line 3-A + Line 3-B

5-A Accounts
Gross Amount

= Sum of closing balances in deficit from client cash account activity at Trade Date D-1minus
Sum of CS_NPV_ADJUSTED fees from the client CASH_SETTLEMENT Clearing Transfer
trades at Trade Date D-1, for which the fee known date is equal to the trade’s settlement date

Displayed as positive amount.

5-B Accounts
Amount Offset
by Customer
Securities

If Line 5-A (absolute value) < Line 1-B

= Line 5-A

Otherwise

= Line 1-B

5-C Accounts
Balance

= Line 5-A (absolute value) - Line 5-B

6 Sequestered
Amount

= Line 4 + Line 5-C

7-A Cash
Deposited

= Sum of closing balances from sequestered accounts activity (converted to USD)
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Column Formula

Accounts with account attribute SequesteredAccount = Bank.

7-B Securities
of Customers
Funds
Deposited

From the Inventory Position Report as of previous day’s close of business (T-1), take all
accounts that have the "SequesteredAccount" attribute set to "BANK" as well as the attribute
"Collateral Investment" set to True, and calculate the values of any securities that fall into the
aforementioned account criteria converted to USD based on FX Rate from quote set. The
values will be determined by using the balance type defined in domain
"SFR7BMovementType": CleanVal(MTM) OR DirtyVal(MTM).

Please refer to the Calypso Clearing Member Setup Guide for setup details - "Collateral
Investment Program".

7-C Securities
of Customers
Held

From the Inventory Position Report, take security collateral positions (other than funds) for
books with BookType in domain “SFR7CBookType”, using the balance type defined in domain
“SFR7CMovementType”: CleanVal(MTM) OR DirtyVal(MTM).

Please refer to the Calypso Clearing Member Setup Guide for balance type setup details -
"Collateral Investment Program".

8-A Margin
Cash
Deposited

= Sum of ACTUAL client cash margin call positions between the clearing member and the
CCP (converted to USD), including IEF5 security collaterals (funds with product code "SFR-
8A = True").

8-B Margin
Securities of
Customers
Funds

= Sum of ACTUAL client security margin call positions between the clearing member and the
CCP

Displayed as a positive amount.

Any securities with product code “Collateral Investment = True” and "SFR-8B = True" as of
previous day’s close of business (T-1) converted to USD based on FX Rate from quote set.

Please refer to the Calypso Clearing Member Setup Guide for setup details - "Collateral
Investment Program".

8-C Margin
Securities in
Lieu of Cash

= Sum of ACTUAL client security margin call positions between the clearing member and the
CCP

Displayed as a positive amount.

Any securities with product code “Collateral Investment = False or not set”.

9 Net
Settlement

= Sum of principal amounts (converted to USD) from client cash settlement trades between
the clearing member and the CCP

10-A Value of
Open Long
Contracts

Defaults to 0.

10-B Value of
Open Short
Contracts

Defaults to 0.

11-A Net = Sum of closing balances from sequestered accounts activity
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Column Formula

Liquidating
Equity with
Other FCMs

Accounts with account attribute SequesteredAccount = CMF.

11-B Net
Securities of
Customers
Funds

Defaults to 0.

11-C Net
Securities in
Lieu of Cash

Defaults to 0.

12 Cleared
OTC
Derivatives
Customer
Funds

Defaults to 0.

13 Total
Amount in
Sequestration

= Line 7-A + Line 7-B + Line 7-C + Line 8-A + Line 8-B + Line 8-C + Line 9 + Line 10-A + Line
10-B + Line 11-A + Line 11-B + Line 11-C + Line 12

14 Excess
Funds in
Sequestration

= Line 13 - Line 6

2.7 .4 Col latera l Va luat ion Report
This report allows satisfying the LSOC regulation. It computes the valuation of the collaterals.

This report is obtained using the Collateral Valuation Report worksheet (menu action
clearing.cvr.worksheet.Worksheet), or using the scheduled task CLEARING_EXPORT_CVR_
WORKSHEET.

Sample Collateral Valuation Report Worksheet
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» You can click New to create a new report. You will be prompted to select a processing organization, a CCP
and a clearing service.

Clearing services are defined in domain "mccAdditionalField.PRODUCT_TYPE".

» You can select a collateral context at the bottom f the screen. It is "default" by default.

» Then click Calculate to compute the report.

Once the report is displayed, you can click Generate CVR to export the report to a file.

» You can also click Load Saved to load an existing report. You will be prompted to select a processing
organization, a CCP, a clearing service, a date, and click Load.

The existing reports for that date will be displayed.

Double-click a report to display it.

Sample Scheduled Task CLEARING_EXPORT_CVR_WORKSHEET
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» Select a CCP.

» Select a product (clearing service).

Clearing services are defined in domain "mccAdditionalField.PRODUCT_TYPE".

» Enter the folder where the file containing the report will be saved.

You can then load the file in the Collateral Valuation Report worksheet as needed.

The "File name" is pre-populated. It allows dynamic placeholders, in the form _${placeholder}_, so users
can customize the final file name.

» Select a collateral context, "default" by default.

The default file name is:

LSOC.CVR.${CCP}.${firmId}.${serviceCode}.${datetime}.xml

For instance, for a CME IRD worksheet, for the 4Q0 firm, the filename would be:
LSOC.CVR.CME.4Q0.01.20130822130000.xml.

Possible placeholders are:

• CCP: CCP name

• firmId: member firm Id

If the legal entity attribute “<CCP>CVRSenderCode” is populated, it is used as firm Id to identify the CVR
sender, otherwise the legal entity “<CCP><Clearing Service>FirmId” or “<CCP>FirmId” is used. These
attributes are set on the Clearing Member legal entity.

• date (in yyyyMMdd format): worksheet generation date

• datetime (in yyyyMMddHHmmss format): worksheet generation datetime

Nasdaq Calypso
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• serviceCode: a representation of the clearing service being reported.

Clearing Service Codes:

Used in the ${serviceCode} name placeholder. It is defined per CCP and product type. The out-of-the-box
codes are:

• CME-IRD : 01

• CME-NDF : 02

• LCH-IRD : 03

These codes can be overridden in the configuration file “<calypso
home>/client/resources/config/clearingServiceCodes.properties”. A sample file is included in
the Clearing distribution.

The Collateral Valuation report can be sent directly through MQ Series if configured accordingly.

Please refer to the Calypso Clearing Member Setup Guide for details.

2.7 .5 LSOC CVR Stat ic Data
The LSOC CVR Static Data report provides detailed information about clients margin accounts.

You need to configure the following attributes on the client legal entities: CFTCID (Required - CFTC
Reportable Number), LEID (Optional - US LEI of the client), OfficeCode (Optional) and CustAccountType
(Optional - H for hedger, M for member, O for omnibus, or S for speculator).

The report is run using the scheduled task CLEARING_EXPORT_CVR_LE_DATA.
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» Select the CCP.

» Select the product: IRD or NDF.

» The mode can only be Client.

» Select the legal entity contact from which the information will be retrieved.

» Select the export folder.

The scheduled task generates FIXML files:

• For IRS, the file name is in the form “CME.MarginAccounts.01.Firm<CMEFirmID>.xml”.

• For FX NDF, the file name is in the form “CME.MarginAccounts.02.Firm<CMEFirmID>.xml”.

It also generates a message of type CVR_LE_DATA.

2.7 .6 Aged Margin Cal l
The Aged Margin Call report shows accounts with unpaid margin calls.

The report is run using the scheduled task CLEARING_CFTC_REPORTING.

Make sure that you have define the CFTC_REPORTING message workflow as described in the Calypso
Clearing Member Installation and Setup Guide.

The Processing Org, the Pricing Environment, and the Timezone are mandatory.
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» Select the report type "Aged Margin Call".

» Select the CCPOriginCode: All, Client, or House.

» Select the location of the file.

» Select the report format.

» Select today's cutoff time

» Select tomorrow's cutoff time

Determination of the Valuation date is based on the following logic:

• If the Valuation Date of the scheduled task is in <= CUTOFF TIME and < 12:00:00AM, then T = Valuation
Date + 1 Business day. We use USD calendar to determine the business days.

• If the valuation date is in the range between >= 12:00:00AM and < CUTOFF TIME T+1, the T = Valuation
Date.

It generates a file that contains the report, and saves the report as a message of type CFTC_REPORTING with
"Msg_Attr.CFTCReport" = Aged Margin Call.

Sample Report
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• Legal Name: “Full Name” of the parent account Legal Entity definition.

If an account belongs to a legal entity with a parent, the report shows the margin call at the parent level.
Make sure that your legal entity hierarchies are adequately defined.

• Closing Balance: Aggregated cash accounts of the parent and all its child accounts. All currencies are
converted into dollar using the quote set associated to the Pricing Environment from the scheduled task
CLEARING_CFTC_REPORTING.

AMC [Closing Balance] = Activity Report [Closing Balance] – NPV – IM Cash Collateral

Activity Report [Closing Balance] - The Closing Balance is computed from an Account Activity template
crated on the fly and based on the following criteria:

– Position Date: Available

– Position Class: Client

– Position type: Actual

– Start/End Date: T-1.

– The Account ID field includes all the account Ids determined in the set of Parent Legal Entity
accounts (children + parent accounts).

NPV - From each closing balance of the Parent’s accounts we back out the transfers sourced from the
Account Activity report output, which are contained in the list of domain MTMFlows and convert the
results into USD.

IM Cash Collateral - Source the data from the report MarginCallPositionValuation:

– Position Type: ACTUAL

– Underlying Type: Cash

– Date: T-1

If the Contract Currency is USD, back-out the sum of all the amounts in the column Contract Value.
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Else, convert the sum of all the amounts from column Contract Value and back-out the result from the
Closing Balance.

• Open Trade Equity: Aggregated NPV of the parent and child positions. All currencies converted into USD
using the quote set associated to the Pricing Environment from the scheduled task CLEARING_CFTC_
REPORTING. We use the account activity report to source this amount:

– Position Date: Available

– Position Class: Client

– Position type: Actual

– Start/End Date: T-1.

– The Account ID field includes all the account Ids determined in the set of Parent Legal Entity
accounts (children + parent accounts).

• Total Equity: Closing Balance + Total Equity

• Collateral: Settled collateral, cash and non-cash, from the parent and child accounts. All amounts
converted into USD. We source this amount from the MarginCallPositionValuation report based on a
template created on the fly with the following criteria:

– Position Type: ACTUAL

– Underlying Type: Cash and Security

– Date: T-1

If the Contract Currency is USD we report the sum of all the amounts in the column Contract Value.

Else, we convert into USD and report the sum of all the amounts from column Contract Value.

• Net Liquidating Equity: Total Equity + Collateral

• Initial Margin: Net Balance of the parent and its children margin call contracts.

• Amount under Maintenance (AUM):

AUM = Net Liquidating deficit – Initial Margin IF (Net Liquidating deficit – Initial Margin) <0, Else “0”

• Call: This can be a new call or an outstanding call (age >1).

New Call: It is created when the Net Liquidating Deficit plus the sum of outstanding calls doesn’t cover
the initial margin.

IF (Net Liquidating Equity + Outstanding Calls) – Initial Margin < 0, then New Call = (Net Liquidating Equity
+ Outstanding Calls) – Initial Margin, Else 0.

When a call is aged for more than one day, it is considered as outstanding.

When the client sends collateral to the Clearing Broker, the system uses it to cover the oldest Calls based
on a FIFO method. When the amount fully cover a call, such a call is DELETED and it doesn’t appear on the
report anymore, when the remaining of the allocated collateral partially covers the call, this one is said
REDUCED but it continues to be aged.

• Age: Increases of one business day as long as the call is not DELETED. The USD calendar is used for aging
the calls.
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• C/H: Value of the account attribute CCPOriginCode of the parent account in the following way:

– If the value is CLIENT, populate with “C”

– If the value is House, populate with “H”

2.7 .7 L iqu idat ing Def ic i t
The Liquidity Deficit report shows accounts whose Net Liquidating Equity is negative.

The report is run using the scheduled task CLEARING_CFTC_REPORTING.

Make sure that you have define the CFTC_REPORTING message workflow as described in the Calypso
Clearing Member Installation and Setup Guide.

The Processing Org, the Pricing Environment, and the Timezone are mandatory.

» Select the report type "Liquidating Deficit".

» Select the CCPOriginCode: All, Client, or House.

» Select the location of the file.

» Select the report format.

» Select today's cutoff time
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» Select tomorrow's cutoff time

Determination of the Valuation date is based on the following logic:

• If the Valuation Date of the scheduled task is in <= CUTOFF TIME and < 12:00:00AM, then T = Valuation
Date + 1 Business day. We use USD calendar to determine the business days.

• If the valuation date is in the range between >= 12:00:00AM and < CUTOFF TIME T+1, the T = Valuation
Date.

It generates a file that contains the report, and saves the report as a message of type CFTC_REPORTING with
"Msg_Attr.CFTCReport" = Liquidating Deficit.

Sample Report

• Legal Name: “Full Name” of the parent account Legal Entity definition.

If an account belongs to a legal entity with a parent, the report shows the margin call at the parent level.
Make sure that your legal entity hierarchies are adequately defined.

• Closing Balance: Aggregated cash accounts of the parent and all its child accounts. All currencies are
converted into dollar using the quote set associated to the Pricing Environment from the scheduled task
CLEARING_CFTC_REPORTING.

• Open Trade Equity: Aggregated NPV of the parent and child positions. All currencies converted into USD
using the quote set associated to the Pricing Environment from the scheduled task CLEARING_CFTC_
REPORTING.

• Total Equity: Closing Balance + Total Equity

• Collateral: Settled collateral, cash and non-cash, from the parent and child accounts. All amounts
converted into USD.

• Net Liquidating Equity: Total Equity + Collateral
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