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Revision Published Summary of Changes
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3.0 September 2024 Third edition for version 18 - Updates for Commodity Swap.
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Averaging methods.
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This document guides you through the setup and capture of commodity derivatives trades.
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1. Setup Requirements
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2. Commodity Product Definition
The commodity product stores information that is used to set defaults for trade capture and valuation. It links market
data to pricing through its designation as an underlying in forward curves, volatility surfaces, future contracts and
forward point instruments.

Commodities are typically referenced throughout the system using a naming convention of Currency/Name/Location.

 Ⓘ [NOTE: The commodity trade windows require that you create the commodity product, and then create the
commodity reset definition using Configuration > Commodities > Commodity Reset from the Calypso Navigator.
Trade capture is based on the commodity reset definition]

From the Calypso Navigator, choose Configuration > Commodities > Commodities.

» Existing commodity products are loaded by default. Select a commodity product to view the product details in the
fields described below. You can modify the details and click Save as needed.

» To search for a commodity product in the list, enter some letters in the search box. You can click the icon to
specify the search.
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» To create a new commodity product, click or choose File > New, complete the details described below, and
click Save to save the commodity product.

» Click ... to add values to the drop-down menus in the window.

Commodity Details

Field Description

Currency Select the currency in which the commodity is quoted.

Note that the commodity currency and the future contract currency must be the same. The
commodity currency and the commodity forward point currency must also be the same.

Name Select a name for the commodity.

You can click ... to add a new name as needed.

Location Select the delivery location of the commodity.

You can click ... to add a new location as needed.

Settings Details

Field Description

Source Select the entity responsible for releasing official prices for the commodity or for the
associated future contract. Typically this would be a commodities exchange, but could also
be a publication or an over the counter marketplace.

You can click ... to add a new source as needed.

Quote Unit Select the commodity unit of measure in which the price is given. Units can be converted
using a conversion table, but values in the quote set will always be given in this unit.

You can click ... to add a new quote unit as needed.

Code You can select a product code from the drop down and view its value.

Click ... to set product code values as needed.

A variety of important defaults can be set from the code field including: Commodity Fixing
Calendar, Commodity Decimal Precision, Commodity Family/Group, and Market and data
feed codes.

Example:

COMM_FIX_PRICE_DEC— The number of decimal places to which the floating price of a
commodity derivative will be rounded.

Type Select the type of commodity. The default type is Commodity.

Additional types are available out-of-the-box. They are associated with additional attributes
used in pricing.
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Field Description

• Electricity - Please refer to Calypso Electricity Commodity documentation for setup
details

• Storage Based - Please refer to Calypso Storage Based Commodity documentation for
setup details

• Emission - Please refer to Calypso Emission Commodity documentation for setup details

• Freight - Please refer to Calypso Freight Commodity documentation for details

Risk Config Details

Field Description

Risk Unit Select the unit of risk for the commodity.

You can click ... to add a new risk unit as needed.

Settlement Days Details

Field Description

Physical

Cash

Enter the number of lags days for physical and cash settlement.

Lag information for Forward trade entry is taken from the underlying commodity on the
reset.

For emission resets where there are potentially multiple underliers, the lag information is
taken from an arbitrarily chosen underlying.

Quantity Config Details

Field Description

Decimals Enter the number of decimals that can be captured in trade quantity. This field has no
impact on rounding or any report displays.
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3. Commodity Index
Define the Commodity Index as a Market Index by choosing Configuration > Product > Market Index from Calypso
Navigator. (product.MarketIndexWindow).

Commodity Market Index can have constituents - Commodity Spot and Commodity Futures.

Commodity Market Index can be of type Weight and Quantity.

Example:

You can define the basket of commodities in the Constituents tab:
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Please refer to Calypso Getting Started documentation for details on defining market indices.
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4. Commodity Unit Conversion
Throughout the system, commodities reference prices and quantities in particular commodity units. To be able to
convert these values to other units, you must enter conversion factors into the Commodity Unit Conversion table.

Define the commodity unit conversions by choosing Configuration > Commodities > Commodity Conversion from
Calypso Navigator (product.CommodityUnitConversionWindow).

» Enter the factor for converting a commodity from one unit type to another in the Commodity Unit Conversion
window. The following equation describes the factor:

From Units * Conversion Factor = To Units

Note that the system also does the inverse conversion:

To Units * 1/Conversion Factor = From Unit

» Click Save to save the commodity unit conversion.

For example, if you define a conversion of Barrels * 42 = Gallons, then the system also calculates the inverse of
Gallons * 1/42 = Barrels.

The commodity trade uses this conversion definition when you enter a trade and choose a quantity unit of measure
that is different than the product definition quote unit.

Note that some risk analyses require a conversion of units to contracts. To do this, simply choose 'Contracts' as the
commodity unit to convert to and enter the standard future contract size for the commodity as the conversion factor.
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5. Commodity Reset Definition
The commodity reset represents the reference price against which a financial transaction is settled.

It designates which Forward Price Method will be used to project forward prices, and it is used to set the floating price
for a commodity fixing that should have occurred.

You can select the commodity reset definition during trade capture, and define additional fixing details in the trade.
The actual prices for commodity resets are set using Trade Lifecycle > Reset > Price Fixing from Calypso Navigator,
or the PRICE_FIXING scheduled task.

Create the Commodity Reset Definition using Configuration > Commodities > Commodity Reset from Calypso
Navigator (refdata.CommodityResetFrame).

» Existing commodity reset definitions are loaded by default. Select a reset to view the details. You can modify the
details and click Save as needed.

» To create a new commodity reset definition, click New, complete the details described in the table below, and
click Save.
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Note that if the Authorization mode is enabled, an authorized user must approve your entry, provided that
"CommodityReset" has been added to the "classAuthMode" domain. Click Show Pending to display any
commodity reset definitions pending authorization.

» Commodity Reset quotes are saved as Commodity.<currency>.<commodity reset>.

The following table describes the fields to complete in the commodity reset definition.

Field Description

Name Unique user defined name. Name should be descriptive to allow the selection of the proper reset
without having to refer to the reset definition.

Click ... to add a new commodity reset name to the drop-down menu.

Id When you save the commodity reset definition, the system automatically assigns it an id and displays it
in this field.

Reset Type Select either Commodity or Emission.

With the Emission reset type, you are able to specify multiple possible commodity underlyings, allowing
for the capture of a trade where several different allowances are eligible for delivery.

Commodity Link to the underlying commodity of the reference price.

Click ... to select the underlying commodity product.

The commodity reset definition requires a commodity product that you can create by choosing
Configuration > Commodities > Commodities from Calypso Navigator.

Allowance
Criteria

When Emission is selected as a Reset Type, select an allowance criteria for the reset. This criteria
defines what type of allowances are designated in the commodities used for the reset. Only
commodities using the selected allowance type are eligible. This list is populated from the
EmissionAllowanceType domain.

After you have selected the Allowance Criteria, select the appropriate compliance and vintage
information to further define the commodities contained in the reset.

Currency The currency in which the reference price is quoted, i.e. USD/Barrel.

Quote Unit The commodity unit in which the reference price is quoted, i.e. USD/Barrel.

Quote Type The type of quote used, in most cases this will be Price.

Time / Time
Zone

The global time that the commodity reset is expected to be known. This can be, but doesn't have to be,
the time zone of the actual exchange or publication.

Future
Contract

The future contract that is associated with this commodity. This information is used to determine the
available futures for the forward price lookup logic described below.

You can create future contracts by choosing Configuration > Listed Derivatives > Future Contracts.

You can also create a commodity resetwithout an associated future contract. This allows creating
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Field Description

resets for commodities that are traded OTC, and creating resets if not trading on an exchange.

Forward
Price

Select a method for finding the forward price.

For forward price methods intended to reference a futures contract price, the price method finds a
single date. The logic looks for the expiry date of the next expiring future (using the future contract
specified on the Commodity Reset), and requests a forward price from the curve. The curve logic then
looks up a price on the curve for the requested date. For those price methods, it is necessary to specify
the future contract series on the commodity reset. These methods are: Nearby, IceNearby,
SecondNearby, NearbyNonDelivered, FirstAndSecondNearby and Fixed. If no future contract is
selected on the Commodity Reset for any of these forward price methods, the curve will return prices
for each of the fixing dates. The default interpolator on the Commodity Forward Curve is NONE.

For all other methods, the forward price is retrieved from the forward curve.

Calypso out-of-the-box provides the following forward price methods:

Nearby — The Nearby (aka Prompt) future is the future in a given contract listing which is closest to
expiration on a specified date. This future is typically the most liquid and contains the highest open
interest, making it the primary choice for a derivative reference price. In Calypso, the projected price
returned by the Nearby method is equal to the the price of the first sequentially available curve point on
or after the fixing date.

Lme3M— The LME 3 Month price is similar in concept to the LmeCash price. In Calypso, the projected
price returned by the LME3Mmethod is equal to the value on the curve which corresponds to the date
3 calendar months after the fixing date according to the Fixing Holiday Calendar subject to the Forward
Price Holiday Calendar. Note: this value may correspond to an actual curve point, or may be
interpolated using the interpolation method specified in the forward curve.

LmeCash— Futures listed on the London Metals Exchange (LME) have daily expiries, whereas most
other commonly traded commodity futures have monthly listings. Because of this, LME products tend
to be quoted in terms of tenor-based futures such as Copper Cash Buyer's Price or Lead 3 Month
Buyer's Price. In keeping with this convention, derivatives settled using the LME Cash reference price
require a method which can project the price of the official cash settlement price on a given fixing date.
In Calypso, the projected price returned by the LMECash method is equal to the value on the curve
which corresponds to the date 2 business days after the fixing date according to the Fixing Holiday
Calendar subject to the Forward Price Holiday Calendar. Note: this value may correspond to an actual
curve point, or may be interpolated using the interpolation method specified in the forward curve.

SecondNearby — The Second Nearby future on a given date is the future which is next to expire after
the prompt. In Calypso, the projected price returned by the Second Nearby method is equal to the price
of the second sequentially available curve point on or after the fixing date.

NearbyNonDelivered — The projected price for a fixing date will be equal to the value of the
chronologically closest point on the forward curve which is equal to or greater than the fixing date
subject to the restriction that the fixing date is not after that underlying's first delivery date, or for
commodity forward points, the pillar date. If the fixing date falls after the nearby underlying's first
delivery (or pillar) date, but before the underlying's last trading date, the value of the next
(chronologically) curve point will be used.
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Field Description

Many agriculture future contracts have first delivery dates which fall BEFORE the last trading day,
meaning that if you hold a short position in one of these contracts, even if the future is still trading, you
may be notified by the exchange that you are required to deliver the physical commodity. Therefore,
financial players in the agriculture markets always make sure that they exit future positions before the
first delivery date to avoid that scenario. Likewise, financial derivatives, such as swaps and options,
take a similar approach and will typically fix off of the nearest future which has not already passed its
first delivery date.

For example, look at 2 consecutive CBOTWheat futures:

Future First Delivery Dt Last Trade Dt
MAR08 March 3, 2019 March 14, 2019
MAY08 May 1, 2019 May 14, 2019

For a commodity fixing on March 1, you would expect the NEARBY forward price method to use the LTD
of 3/14/19 from the curve to project the price, and for a commodity fixing on March 5, you would STILL
expect the NEARBY forward price method to use March 14, as the fixing has not passed the last trade
date (aka the MAR08 curve date on the forward curve).

In terms of the above example, for a commodity fixing on March 1, you would expect the
NearbyNonDelivered forward price method to use the LTD of 3/14/19 from the curve to project the price
since it is before the MAR19 future's first delivery date. For a commodity fixing on March 5, you would
expect the NearbyNonDelivered forward price method to use May 14 as the curve date from which to
project the price as it is after the first delivery date of the nearby curve point.

Fixed— In some cases, derivatives are traded which agree upon a specific future as the reference
price, regardless if that future is prompt, second prompt, etc. For these situations, we offer the Fixed
forward price method. Using this method, the user must specify a date which corresponds to the date
on the forward curve whose price will be used for all fixing dates for any derivative which uses that
Commodity Reset. Any example would be a 3 month averaging swap over the months of Jan - Mar 2008
which references the Dec 2008 future. Each day of this swap will settle off of the price of the Dec 2008
future, therefore the projected price of all future fixing dates will be the same, based on the curve date
chosen in the reset definition.

IceNearby — The convention of many swaps traded on the The Intercontinental Exchange (ICE) is to fix
off of the prompt future up to, but not including, that future's last trading day. On that day, the price will
fix off of the second prompt contract. The theory behind this is that there is uncharacteristic volatility
associated with a future on it's last trading day due to market forces trying to reconcile positions before
the future ceases trading. In Calypso, the projected price returned by the ICENearby method is equal to
the price of the first available curve point after, but not equal to, the fixing date.

InterpolatedPrice — The forward price calculation is delegated to the interpolation method set on the
underlying Market Data item, of which only curves are currently supported. If there is no interpolator set
on the underlying market data item, "Nearby" forward price lookup method is used.

FirstAndSecondNearby — Finds the expiry dates of the first and second nearby future contracts
specified on the commodity reset, and request forward prices from the forward curve for both of these
dates. The arithmetic average of the two prices is used as the fixing price.
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Field Description

NearbyThirdWednesday — The forward price date one is the first curve point, which is the 3rd
Wednesday after the fixing date.

NearbyAndSecondNearby — The forward price is the average of the first and second expiries, equal to
or greater than the fixing date.

LmeCashToday - Specific to LME futures contracts. Price is taken on same day.

LmeCashTom - Specific to LME futures contracts. Price is taken one business day ahead.

Note: You can add custom methods by creating a class named
tk.product.commodities.priceselector.<ForwardPriceMethodName> that implements
com.calypso.tk.product.commodities.priceselector.ForwardPriceMethod. Compile the
class, and register the method name in the "commodity.ForwardPriceMethods" domain.

Type:Tenor Based - For the tenor based method, forward date will be equal to fixing date + tenor
specified on the CMD Reset.

On CMD reset, if the tenor based method is selected, a dropdown is provided where one can select the
tenor such as - 0D, 1D, 2D etc. instead of dates. Tenor in the dropdown will be populated from the
domain.

Tenor Based under Type: Fixed - If Fixed Method is selected and if tenor based checkbox is ticked, a
dropdown is provided where one can select the tenor such as - 0D, 1D, 2D etc. instead of dates. Tenor
in the dropdown will be populated from the domain. The Forward Date in this case would be the
valuation date plus the tenor provided in the CM Reset.

Fixing
Holiday

The default calendar used to determine eligible commodity fixing dates for a derivative using the
specified commodity reset. You can select a different calendar in the trade worksheet.

Fwd Price
Holiday

For use with LMECash and LME3M fixing methods to determine the US holidays to be used to
determine if a LME business day is also a good NY business day. Required since LME products are
quoted in USD.

Nasdaq Calypso
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Field Description

Click ... to select a holiday calendar(s) for the forward price method.

Code Select a Reset Code and a value for that code in this field. The reset code is used to generate
confirmation keywords in the confirmation templates. These keywords are directly associated with a
specific reset.

You can create a reset code by clicking on the and then adding a code name. This code is then
added as a domain value in the "CommodityResetCode" domain.

You can also add a reset code based on a confirmation keyword in the confirmation template by
prepending the name of the reset with "COMMODITY_RESET_". This works the same way as the
functionality for using trade keywords in a confirmation by appending KEYWORD_ to the beginning.

Details Enter a description of the commodity reset to be used in confirmations.

NOTE: Commodity Linear pricers are able to price on the reset date without a reset.

If a commodity quote for the valuation date and fixing date is present, and if the valuation date is the same as the
reset date then Calypso is taking that quote for further calculations from the environment, irrespective of time. If the
commodity quote is not present in the environment, it is forecasted from the curve.

If the FX Reset quote for the valuation date and fixing date are present and if the valuation date is the same as the
fixing date, Calypso takes that quote for further calculations, irrespective of time. If the FX Reset quote is not present
in the environment, then the quote from the FX spot quote is used.
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6. Commodity Quote Creator
Pricing commodity certificates requires a certain number of quotes such as the commodity quote, the location
differential, the grade differential and the storage cost. These quotes are associated with a unit and a currency. The
Quote Creator allows you to create quote names for commodities. In order for a certificate to use a particular
commodity, a quote name for the commodity must have been specified in the Quote Creator prior to certificate
creation.

Open the Commodity Quote Creator window (menu action marketdata.CommodityQuoteNameCreationWindow).

Storage Based Commodities

» Select a commodity from the Commodity field. When a commodity has been selected, the Currency and Quote
Unit of the commodity is populated automatically. These two fields are editable though, if you wish to create a
quote using something other than the currency and quote unit of the commodity.

» Click in the Location field to select as many locations as you would like. The available locations are populated
from the CommodityStorageLocation domain.

» Click in the Grade field to select the desired grades for the quote. More than one grade can be selected. The
available grades are populated from the CommodityGrade domain.

» Click . The quote names necessary for this quote are displayed below. There will be three quotes, a Grade
Differential, Storage Cost and Location Differential. Click to save the quote names. They will be then displayed
in the Quote window and you are able to enter quotes for these quote names.

Nasdaq Calypso
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Freight Commodities
The window looks slightly different for freight commodities. You need only enter the From and To Years after
selecting the Commodity since the rates for these commodity types are set for a year at a time.

Entering Quotes
You can enter quotes for the created quote names from the Quote Window (Market Data > Market Quotes > Quotes).
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7. Commodity Fixing

7.1 Fixing Pol icies
Depending on the payment frequency, you can generally select one of the following types of fixing policies: date
fixing or future fixing. You can create new fixing date policies for the FutureContractLTD payment frequency.

The calendar(s) used to determine the business days in the cash flow period are specified in the Swap Leg panel as
described above.

After pricing the trade, in the Cashflows you can view the fixing dates for a cash flow period in the Commodity Fixings
dialog window. Right-click the cash flow period and choose Show Fixings in the Cash Flow Menu. You can also
customize the fixing dates in this dialog window.

Date Fixing
Determines which fixing dates to use during the cash flow period.

Policy Description

Whole Period There is a fixing date for each business day during the cash flow period. It is also supported
for pay frequency FutureContractLTD/FND.

Last Day The fixing date occurs on the last day of the cash flow period.

First Day The fixing date occurs on the first day of the cash flow period.

Third Wednesday This fixing date policy is used with the Periodic payment frequency.

The Third Wednesday policy would be very commonly used for strips of LME bullet swaps
due to the fact that the Third Wednesday future is the most liquid contract of each month.

In order to replicate the physical market which would deliver on the Third Wednesday of
each month, the fixing date should be set to the Monday before the Third Wednesday of the
month, which would therefore result in the LMECash forward price method projecting the
price for the cash date, which would be the Third Wednesday.

If the Monday before the third Wednesday is a holiday according to the fixing date calendar,
the fixing date should fall on the previous business day according to that same calendar.

- No need to consider the FX holidays.

- The fixing day is normally the third Monday of the Month, but could be the second Monday
if the beginning of the Month is a Tuesday.

- Partial month should give you a Warning, and if the end date is too short, an error message
box.

Weekday When selected, the Fixing Day of Week needs to be entered, which can be any of the seven
days of the week. Additionally, Fixing Date Roll specifies what to do if the day of the week is
a non-business day on the fixing calendar. This fixing policy is only available when the
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Policy Description

Payment Frequency is set to Periodic.

Custom Fixing Policy
You can code a custom fixing date policy class, and register it in the CommodityFixingDatePolicy domain, so that it
appears in the Fixing Date Policy drop-down menu.

Step 1 - For the custom Fixing Date Policy, the code should reside in
calypsox/tk/product/commodities/schedulegeneration/fixing and be compiled. For reference, please check:
calypsox/tk/product/commodities/schedulegeneration/fixing/PreviousDayFixingDatePolicy.java

Step 2 - Add the custom fixing date policy name to the domain CommodityFixingDatePolicy.

Future Fixing
When you select a contract-based payment frequency, you can select the first and last named contract to determine
the starting and ending fixing for the swap. There is a cash flow period for each contract between the start and end
contract (inclusive). For the fixing date, you can select one of the following policies.

Policy Description

Last Four Days The fixing dates are the last four business days of the cash flow period.
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Policy Description

Last Three Days The fixing dates are the last three business days of the cash flow period.

Penultimate The fixing date is the business day before the end of the cash flow period.

Contract Last Day The fixing date is the last day of the cash flow period.

Custom Fixing
You can create new fixing policies for the FutureContractLTD payment frequency in the Commodity Fixing Date Policy
Maintenance window. To display this window, from Calypso Navigator, choose Configuration > Commodities >
Fixing Date Policy (product.CommodityFixingDatePolicyWindow).

» Click New to crate a new fixing policy.

» Define a name. The Fixing Days column represents how many total fixing dates per period you want, and the
Excluded Days is the number of days, starting from the future expiration date, to shift those fixing dates
backward.

» Click OK to save the policy. The new policy appears in the maintenance window, and in the Fixing Date Policy
drop-down menu in the CommoditySwap2 and OTCCommodityOption2 trade worksheets.

Nasdaq Calypso
Commodities Trading / Version 18



For example, if you wanted to have prices fixed on the last three days of a future contracts listing, INCLUDING the day
the future expires, you would set Fixing Days = 3 and Excluded Days = 0.

If you wanted to have fixings on the last four days before a future’s expiration, NOT INCLUDING the expiration date
itself, then you would set Fixing Days = 4 and Excluded Days = 1.

7.2 Fixing Panel
After pricing the trade, in the Cashflows you can view the fixing dates for a cash flow period in the Commodity Fixings
dialog window. Right-click the cash flow period and choose Show Fixings in the Cash Flow Menu. You can also
customize the fixing dates in this dialog window.

In this window, the Fixing Date, Forward Date, FX Fixing Date, Quote Name, Price, FX Quote and FX Spot Price are
displayed.

The FX Fixing Date is the date that is determined by the FX settlement information and used to calculate the forward
FX rate. It is populated for future resets only, and only for floating legs.

The Forward Date is the date that is determined by the forward price method (which is selected in the Commodity
Reset), and is used to look up the price on the curve. It is populated for future resets only, and only for floating legs.
Below is a description of how each Forward Date is calculated based on the Forward Price Method.

Forward Price Method Forward Date Calculation

Nearby Expiry date of the next expiring future contract on or after the fixing date

Fixed The date specified on the Commodity Reset

LME3M Fixing date plus 3 calendar months rolled to the next business day

NearbyAndSecondNearby The expiry date of the second expiring future contract

NearbyNonDelivered The expiry date of the next expiring future contract on or after the fixing date

LMECash Fixing date plus two business days

NearbyThirdWednesday The next third Wednesday of the month on or after the fixing date

InterpolatedPrice The fixing date

ICENearby The expiry date of the next expiring future contract after the fixing date

SecondNearby The expiry date of the second expiring future contract on or after the fixing date
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8. Commodity Intraday Policies
Select the Intraday Policy, and you can view graphs of the Business Day Distribution and Holiday Distribution.

Click OK to select the Intraday Policy in the trade worksheet.
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Period distributions are defined in the Period Distribution window. To view this window, from Calypso Navigator,
choose Configuration > Commodities > Period Distribution.

See Setting up Electricity Commodities for details.

Intraday Policies are defined in the Intraday Configuration window. This window is viewed from Calypso Navigator by
selecting Configuration > Commodities > Intraday Configuration.

See Setting up Electricity Commodities for details.

Nasdaq Calypso
Commodities Trading / Version 18

March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 26 / 145

CommodityElectricity.htm
CommodityElectricity.htm


March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 27 / 145

9. Certificate Template
In the Commodity Forward trade worksheet you can enter details with the certificate, such as the Storage Date,
Maturity Date, Grade of the commodity (for storage-based commodities), Handling Fee, and select the Future
Delivery Set. These attributes are used to calculate the NPV and the Price of the forward itself. From Calypso
Navigator, choose Trade > Commodities > Forward (trading.TradeCommodityForwardWindow).

If you want to add additional attributes to the certificates, then build a template to store the details of the certificate.
You can select the template in the Commodity Forward trade worksheet in the Details panel.

From Calypso Navigator, choose Configuration > Commodities > Certificate Template
(refdata.template.PropertyTemplateBuilder).

Step 1 - Click New in the bottom of the window to start a new template.

Step 2 - Enter a Name for the template and select the property template type.
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Step 3 - Click to add a new attribute.

Step 4 - Enter the attribute details in the input fields and click Save to add the attribute to the table on the left.

Step 5 - Set the order that the attributes appear in the template. Select an attribute and click to add it to the order
list on the right.

Step 6 - You can edit the attributes. Select an attribute in the table on the left, and click to edit the attribute.

Step 7 - Click Save in the bottom of the window to save the template.
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10. Period Distributions
Define period distributions to be used in building intraday policies.

For example, for electricity derivatives trading, define period distributions for on-peak and off-peak settings. Define
an interval of 24 and assign weights to build the hourly reset support.

From Calypso Navigator, choose Configuration > Commodities > Period Distribution (
configuration.split.SplitConfigurationWindow$perioddistribution.PeriodDistributionConfigur
ableObjectLoader).

» Click and enter a name for the period distribution.

» Define the number of intervals.

» Enter a weight for each interval.

» Click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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11. Daylight Savings Time
For electricity swaps and futures, you have the option to create a daylight savings time rule. The purpose of this rule is
to compensate for the hour that is gained or lost during spring and fall on an electricity swap that has hourly resets.

To create a daylight savings time rule, from Calypso Navigator, select Configuration > Commodities > Daylight
Savings Time.

» Click New to create a new configuration and enter the fields describe below.

» Then click Save to save the configuration.

Field Description

Id System assigned id for the daylight savings time rule

Name Enter a name for the rule

Spring DateRule Enter a name for the date rule that applies to spring daylight savings time

Spring hour Select the hour at which the spring date rule is to take effect

Fall DateRule Enter a name for the date rule that applies to fall standard time

Fall hour Select the hour at which the fall date rule is to take effect
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12. Intraday Configuration
Define the intraday policies to be used in derivatives trading.

For example, for electricity derivatives trading, define the Electricity intraday policy.

From Calypso Navigator, choose Configuration > Commodities > Intraday Configuration (
configuration.split.SplitConfigurationWindow$intradayconfiguration.IntradayConfigurationco
nfigurableObjectLoader).

» Click and enter a name for the Intraday Configuration.

» Click the Holiday field to select a calendar to use in defining the business days and the holidays.

» Click the Business Day Distribution field to select a period distribution for business days. Period distributions are
created in the Period Distribution window. From Calypso Navigator, choose Commodities > Period Distribution.

» Click the Holiday Distribution field to select a period distribution for holidays. Period distributions are created in
the Period Distribution window. From Calypso Navigator, choose Commodities > Period Distribution.

» Click Save.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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13. Future Delivery Set
Define a future delivery set to use in the valuation of certificates for physical commodities. You may select the future
delivery set in the commodity forward trade in an attribute on the certificate.

The valuation methodology is a standard cost-of-carry formula that adjusts the price of the future against which you
could deliver the certificate by the cost of storing the commodity, the various discounts (location, grade, etc), and
finally by the cost of the money required to purchase the certificate.

The futures that you select in the future delivery set should be ones that are generated by the future contract
associated with the commodity reset selected in the commodity forward. You can select a single future, a set of
consecutive futures, or a set of non-consecutive futures.

If the certificate is not associated with a future, then the pricer uses the future that is nearby on the value date, and
continues to roll to the next nearby future as long as the certificate remains in inventory. The pricer also uses the
nearby future if all of the futures that were originally associated with a given certificate have expired.

The pricer uses the futures from the Default Delivery Contract if futures in the future delivery set are not available. In
the future contract for the physical commodity, you can set the Default Delivery Contract attribute to Yes to specify
that the contract is the default one for that product.

Note: There is another configuration that exists in the Attributes part on the Definition tab.
IsDefaultDeliverableFutureContract performs the same function as Default Delivery Contract. When one is set to Yes,
the other is set to Yes as well.

Define the future delivery sets by choosing Configuration > Commodities > Future Delivery Sets from Calypso
Navigator (
configuration.split.SplitConfigurationWindow$futuredeliveryset.FutureDeliverySetConfigurab
leObjectLoader).
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» Click and enter a name for the set.

» Next, select the futures in the set. Click to select the futures in the Select Future window.

» Click on an exchange name, currency and contract name to sort the list of futures that display in the Filtered
Future List.

Highlight the futures you would like to include in the set and click Select Futures.

» A list of the futures will then be displayed in the future set window. Click Save to save the set.
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14. Commodity Futures Overview
In general, the contracts require the following configuration:

• Legal entity for the exchange where the futures and future options are listed.

• Holiday calendar to determine the business days of the exchange.

• Date rules (can be used for the expiration date, first delivery date, last delivery date, and first notification date).

• Underlying commodity or commodity index product.

Note: the following sections describe the basic requirements for setting-up future and future option contracts. Refer
to Calypso Futures Documentation for complete details (including setting-up market places, brokers, clearers,
accounts, SDIs, fees, workflow, contracts, processing, and account management).

Contents

- Legal Entity

- Calendar Definition

- Date Rules

- Future Contracts

- Future Option Contracts

14.1 Legal Entity
Define the market place where the futures and future options are listed as a legal entity with the roles MarketPlace,
Agent, and Clearer by choosing Configuration > Legal Data > Legal Entities from Calypso Navigator. Help is available
from that window.
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» Choose Help > Legal Entities from Calypso Navigator for details.

14.2 Calendar Definit ion
Define the holiday calendar for the exchange by choosing Configuration > Definitions > Calendar Definition from
Calypso Navigator. Help is available from that window.
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14.3 Date Rules
Define the date rules for the future contracts by choosing Configuration > Definitions > Date Rule Definitions from
Calypso Navigator. Help is available from that window, it includes a list of out-of-the-box custom date rules for
commodity products.
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15. Future Contracts
Define the commodity future contracts by choosing Configuration > Listed Derivatives > Future Contracts from
Calypso Navigator (menu action refdata.FutureDefinitionWindow).
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15.1 Creating & Edit ing Future Commodity Contracts
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» Contract size must equal Tick Value * Tick Size.

Tick size must equal 1/Min Move (Ticks). To extend the Tick Size list, add new values to the tickSize domain by
choosing Configuration .> System > Domain Valuesfrom Calypso Navigator.

Tick Value should be the absolute price change for one contract subject to the minimum price fluctuation as
defined by the exchange.

» You can define how the Future and Future Option trade windows display the list of available contracts. Click
Attributes and set the Date Format attribute to 'MMM yy' (the value is case sensitive) . to specify that the windows
display a list of contracts by delivery month using the month and year format.

» The Last CCP Date is a reference date that indicates the last day the Clearinghouse will have any exposure to the
future position. This date is represented by the Last CCP Date Lag, as a number of days after the expiration date.
If you set a CCP Lag, the future maturity date is the last CCP date instead of the expiration date.

» You are able to select a Daylight Savings rule to be applied for electricity future contracts.

Out of the Box Attributes
Added out of the box Attribute in Future contract specification window with 4 attributes; 2 attributes for long direction
for Payment & Physical, similarly 2 attributes for short direction for Payment & Physical.

Ex., FWD_Long_Payment_Lag, FWD_Long_Physical_Lag, FWD_Short_Payment_Lag, FWD_Short_Physical_Lag.

Attributes should be added in Domain value > FutureContractAttributes out of the box as can be seen in thebelow
image:
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The values will be available as shown below:

Values in these attributes should be used only while creating a commodity forward resulting out of expiration process
of physical settling futures. Manual as well as via ST FUTURE_EXPIRY must use the values in attributes. E.g., of the
Attribute, Future trade as well as resultant commodity forward trade with direction wise lag as below:
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Contract Attribute Setup
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Buy & Sell Trade

Below are examples of resultant commodity forward trade with different lags (Long and Short respectively) based on
direction of future trade:
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 Ⓘ Note: All existing contracts physically settling are migrated with blank values in the attribute. For existing
migration contract new attribute value will be reflected on trade window only after clearing cache of commodity
reset from webadmin.

 Ⓘ The solution may need one time setup in contract attributes which must be set by user manually as a one
time process.

15.2 Commodity Index Futures
Complete the following steps to create a future contract based on a commodity index:

Step 1 - Add CommodityIndex to theMarketIndex.subtype domain value.

Step 2 - Create a new market index in the Market Index window (Configuration > Product > Market Index) using
CommodityIndex as the Market Index Type.
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Step 3 - Create a Futures contract, setting the Type toMarketIndex.
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Commodity Index Future contracts can be traded using the Future trade window or the Pricing Sheet. When using the
Pricing Sheet, us the FutureMarketIndex strategy. The only pricing implemented for Commodity Index Futures is
FROM_QUOTE, therefore, the futures quote will need to be entered to get an NPV and generate numbers in Risk and
PL.

15.3 Commodity Spread Futures Contract Definit ion
Futures contracts can be configured for Market and Calendar spreads. These spreads are only applicable for futures
contracts of Type Commodity. In the Underlying panel, designate which type of spread to use in the Spread Type
field. The default setting is NONE.

NOTE: The BASIS_SPREAD option is informational only.
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For MARKET_SPREAD and CALENDAR_SPREAD, an underlying futures contract must be specified rather than an
underlying commodity or product. Price fixing for spread futures is always At Maturity, though the underlying futures
contract can have Price Fixing set to Asian.

15.3 .1 Market Spread
When a future contract is a Market Spread, it settles either physically by generating multiple future contracts on
expiry, or financially by calculating a price based on the price of multiple future contracts on expiry.

For example, the most common market spreads in the commodities markets are crack spreads, where the settlement
is based on the price of the underlying crude future contract. The market spread functionality allows for multiple
contracts, each with its own factor. This makes up a formula for calculating the price of the future.
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» The Contract Unit is the unit in which the price will be calculated. The Contract Unit must be the Quote Unit of
one of the underlying future contracts that have been chosen in the Market Spread selection window. All chosen
future contracts must be in the same currency.

» The price will be calculated as the sum of the prices for each row of the of the prices for each row of the formula.
Where the price for each row of the formula will be calculated by:

– Getting the market price for the underlying future contract

– Converting the Unit of Measurement of the price into the Contract Unit

– Multiplying the resulting price by the Factor

» The underlying future in each row is determined using the expiry date of the Market Spread Future. The
underlying futures with an expiry date on or after the expiry date of the Market Spread Future will be used.

Curve Underlyings
Commodity Future curve underlyings cannot be created for Market Spread Futures.

Market Data Required to Price
If the future is priced with FUTURE_FROM_QUOTE = False, the pricer looks for forward price curves for each of the
underlying future contracts in the market spread.

Nasdaq Calypso
Commodities Trading / Version 18



Futures Expiry
On expiry, an offsetting future trade to close out the original expiring trade is created using the closing quote on the
value date for the fixed price. The logic for creating the offsetting future is no different from any other non-spread
future.

On expiry, if Settlement Type of the market spread future is Physical, in addition to creating the offsetting future trade
to close out the original expiring trade, futures trades are created for each o the underlying futures contracts.

The additional futures are created with a fixed price equal to the closing quote price for the future being created on
the value date.

15.3 .2 Calendar Spread
When a future contract is a Calendar Spread, it settles either physically by generating two future contracts on expiry,
or financially by calculating a price based on the price of two future contracts on expiry. The two futures contracts will
have the same contract specification, but different delivery dates.

Calendar Spread Futures are not very common in commodities. However, in order to create Calendar Spread Options
wich are much more common, Calendar Spread Futures need to be created to define the underlying.

The Market Spread functionality, together with a Calendar Spread, which is an integer that determines the delivery
period offset, allows for a single underlying future contract. This makes up a formula for calculating the price of the
future.

So, if the Calendar Spread is 1, the price will be calculated as the price of the nearby future minus the price of the
second nearby future.
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Curve Underlyings
Commodity Future curve underlyings can be created for market spread futures, and forward curves can be created
using these Calendar Spread underlyings.

Market Data Required to Price
If the future is priced with FUTURE_FROM_QUOTE = False, the price looks for forward price curves for both underlying
future contracts in the market spread.

Futures Expiry
On expiry, an offsetting future trade to close out the original expiring trade is created. The logic for creating the
offsetting future is no different from any other non-spread future.

On expiry, if the Settlement Type of the market Spread Future is Physical, in addition to creating the offsetting future
trade to close out the original expiring trade, futures trades are created for both underlying futures contracts.

The additional futures are created with a quantity equal to the quantity of the original future trade. The nearest
expiring future is in the same direction as the original future, and the second future is in the opposite direction.
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The additional futures are created with a fixed price equal to the closing quote price for the future being created on
the Value Date.

15.4 Physical Commodity Contract Definit ion
In the Underlying panel, set the Default Delivery Contract attribute to Yes if this contract should be used as the default
contract for delivery for valuing the commodity certificate. The nearby future will be used to value the certificate if a
future not specifically associated with the certificate is available.

See Future Delivery Sets for details.
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15.5 Asian Future Contract Definit ion
Examples include the First Line Brent and WTI Asian Swaps traded on the InterContinentalExchange (ICE). They are all
cash settled, typically based on the average of a market price over a calendar month.

In the Underlying panel of the Future Contract Definition, when you select the “Commodity” type of future, you may
select when the price fixing occurs: At Maturity (Vanilla) or Asian.

When you select the Asian price fixing, you can then double-click the Commodity Reset attribute value field to
associate a Commodity Reset Definition with the contract.

Note that in the Underlying panel, the Commodity Reset attribute displays the name of the Commodity Reset
Definition. However, in the Definition panel, if you click Attributes to open the future contract Attributes Window, the
CommodityReset attribute displays the Commodity Reset Id.
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Asian Averaging Period
The averaging period for an Asian settled future is determined by the First Delivery Date and Last Delivery Date of
each future. These dates are set through the use of date rules, and can be further customized by overwriting the
dates in the Future Definition if needed. The Averaging Period is inclusive of the first and last delivery dates.

Asian Fixing Calendar
The determination of business days during the Averaging Period of the future is based on the holiday calendar(s)
associated with the commodity reset specified in the future contract definition. Daily observations will be expected on
the business days according to that calendar.

15.6 Electr icity Future Contract Definit ion
The commodity product should be defined as the Electricity commodity type. Cash and Physical settlement are now
supported for electricity futures. Peak setting option along with delivery interval frequency is used to determine the
contract size of the trade as per below.
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When setting up the Future Contract Definition, check the Variable contract size, and define the PeakSetting attribute
with one of the following: On Peak, Off Peak, Base Load.

In the Underlying panel:

» Click ... to select the underlying commodity electricity product.

» Set the Peak Setting attribute to define the contract size. For Hourly delivery frequency, the following
calculations are used to define the contract size:

On Peak - Contract Size = Hourly MWh Quantity * peak hours per bus day * No of bus day in Future Delivery
Period (Hourly MWh Quantity is taken from Commodity Definition)

Off Peak - Contract Size =Hourly MWh Quantity * Total Off Peak Hours in the Future Delivery Period. (To calculate
off peak hours we use 24*(holiday and weekends) + (24-no of peak hours)*no of bus days.

Base Load Contract Size = Hourly MWh Quantity * 24 * No of days in future delivery period.

» For Daily delivery frequency, only base load peak setting is supported as of now. The calculation method of
quantity with base load peak setting and daily delivery interval is as follows:

Base Load Contract Size = Daily MWh Quantity * No of days in future delivery period.
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Sample Natural Gas Contract
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15.7 FX Future Contract Definit ion
The Standard convention for precious metals around the world is to quote a price in US dollars per Troy Ounce.
However, it is not uncommon to quote metals in other currencies and units. Calypso gives you the ability to capture
and price FX Future trades based on various quoting units and currency.

Described below are required fields in the precious metal future contract definition.
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Step 1 - You must define all precious metal future contracts with the FX product type and with a currency pair as the
underlying asset.

Step 2 - The settlement currency of the future contract can be either the quoting currency of the currency pair, or
possibly a third currency. I can never be the precious metal currency.

Step 3 - The contract size of the FX future is denoted in the primary currency unites of the metal and is equal to the
value entered into the contract size field in the future contract definition.

Step 4 - The currency pair used as an underlying in an FX future contract is the standard precious metal currency (i.e.
XAU, XAG, XPT, etc...) along with any quoting currency.
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Step 5 - Select the Precious Metal Unit in which the primary currency is to be measured. The conversion factor will
automatically populate when the unit is selected.

NOTE: The price of the future is derived from the forward price of the underlying currency pair (in Troy Ounces) and
then converted using the provided conversion factor. In cases where the secondary currency is not USD, the forward
price is triangulated based on the Triangulation Currency Rule defined in the pricing environment.

15.8 LME Contracts
To distinguish between Forward and Future style contracts using LME, the contract attribute isDiscountedVM can be
set to True. when this is set, the Pricer FutureCommodity will discount the VM using the native pricer from the
imported Discount Curve.

Discounting will only take place if the FUTURE_FROM_QUOTE pricing parameter is set to True. In this case, Calypso
uses prices from the exchange and discounts using the Discount Factors (DF) from the curve. (The curve is not used
to price, only to apply the discount.)

For the above logic to take effect, in the Legal Entity Attributes window for LME, the attributeMICmust be set to
XLME.
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16. Future Option Contracts
Define the commodity future option contracts by choosing Configuration > Listed Derivatives > Future Contracts
Options from Calypso Navigator (menu action refdata.FutureOptionDefinitionWindow).

Date Time Definition

Field Description

Last Trading Time Enter the time of day that trading will end on the last trading day. Use twenty-four hour time
notation (for example 16:30 is four-thirty in the afternoon).

Time Zone Select the time zone of the trade

Expiration Date
Schedule

Last Trade Date
Schedule

You can select a date rule to generate the schedule corresponding to each date, or you can
select a manual date schedule.
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Field Description

First Delivery Date
Schedule

Last Delivery Date
Schedule

First Notification Date
Schedule

Last notification Date
Schedule

» You can click Open to view the selected date rule or manual date schedule.

Date rules are created by choosing Configuration > Definitions > Date Schedule
Definitions > Date Rule from Calypso Navigator. Help is available from that window.

Manual date schedules are created by choosing Configuration > Definitions > Date
Schedule Definitions > Manual Date Schedule - Help is available from that window.

Define the option products by choosing Configuration > Listed Derivatives > Future Optionsfrom Calypso Navigator
(menu action product.FutureOptionWindow).

Note: Add the product type FutureOptionCommodity to the productType domain by choosing Configuration >
System > Domain Values from Calypso Navigator so that you can select the products in the Product Chooser Window

16.1 Spread Options
When the option's underlying future is a Calendar Spread or Market Spread, the option is called a Spread Option. An
underlying future spread specification must be created for every spread option, even if the spread future is not listed
on the exchange.

The option can be set up to settle either physically or financially. For financially settled options, the expiry logic is no
different from any non-spread future option. For physically settled spread options, the expiry logic creates multiple
futures upon exercising the option.
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16.1 .1 Spread Opt ion Pr icer
The FutureOptionCommodity pricer is used to price Calendar Spread Options. At this time, NPV is calculated but
implied volatility and greeks are not. The volatility and underlying spot price of both the near and far expiry future can
be overridden manually. The pricer uses the Kirk model to price Calendar Spread Options. The volatilities of the two
underlying positions is not calculated and can be overridden as well.

The FutureOptionCommodityMarketSpread pricer is used to price Market Spread Options. At this time, NPV is
calculated but implied volatility and greeks are not. The volatility and underlying spot price of both the futures can be
overridden. The pricer uses the Kirk model to price Market Spread Options. the pricer looks for the correlation
between the commodities of each future. The pricer limits the number of underlyings to two.

16.1 .2 Spread Opt ion Expi ry
On expiry, an offsetting future option trade to close out the original expiring trade is created, using the close quote on
the expiry process value date.
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16.1 .3 Spread Opt ion Exerc ise
If an option is exercising into futures, the option exercise process creates new futures trades.

For Calendar Spreads, the exercise process creates a future trade for the near expiring contract, and a future trade for
the far expiring contract.

For Market Spreads, the exercise process creates a future trade for the near expiry contract of each underlying.

» To determine the quantity and trade price of the new future trades, the logic is the same for Calendar Spreads
and Market Spreads. If a Market Spread Future has multiple underlyings, each with a factor, then the calendar
spread is considered as having two underlyings, the first with a factor = 1 and the second with a factor = -1.

» Calculation of the quantity of a new future begins with the unsigned quantity of the option, multiplied b y the
factor of the underlying. If the option is short, it should be multiplied by -1. Then, if the option is a put, it should be
multiplied by -1. If the number is positive, the future is a buy. Otherwise, the future is a sell.

» The trade price of each new future except the last one being created is the closing price for that future on the
process date. The trade price of the last future must take into account the strike of the option. First, the expected
closing quote of the last future, given the closing quote of the spread, is calculated as well as all other futures. For
example, if the spread is expected to equal (future1 closing price * future 1 factor) +...+ (future n closing price *
future n factor), then the expected closing quote of the last future = [closing spread - (future 1 closing price *
future 1 factor) - ... - (future n-1 closing price * future n-1 factor)] ÷ future n factor. With the closing price of the
last future, it can be adjusted for the strike. Therefore, the trade price of the last future is equal to the expected
closing quote of the last future - option strike ÷ future n factor.

16.2 Sample LME Option Contract
The convention for LME Vanilla Exchange Traded Options is for monthly option expiration occurring on the first
Wednesday of the month with physical exercise into the Future with a delivery date of the Third Wednesday of the
month. For most future option contracts, this is no problem, because the monthly option expirations match the
monthly future expiries. However, due to the fact that the LME base metal future contracts have daily expirations,
while the options have the monthly exercise described above, there needs to be a link between the future option to
the correct underlying future.

You can associate a date rule with the underlying future contract. Double-click in the Underlying Date Schedule field
to select the date schedule.
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16.3 Weekly COMEX Future Options
It is possible to map a COMEX Gold weekly future option to its underlying future in the Future Option commodities
contract. This logic is based on mapping the weekly future option expiry to the underlying future based on the
expiration date of the future option and the first notice date of the underlying future series.

In the Future Option contract window, in the Underlying Dates field, the option Underlying NoticeDate Schedule
should be chosen to generate futures for COMEX future contracts.
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» The date schedule selected in the Underlying NoticeDate Schedule field should be that of the underlying Future
Notice Dates.

» An additional attribute calledMthlyExpLagForWklyOpt should be defined for weekly option mapping. A setting of
3 is suggested for COMEX weekly options.

» If the weekly expiry of the future option is mapped to a future with the First Notice Date greater and nearest to
the Weekly Option Expiry, or greater than the First Notice Date of a future, it would map to the First Notice Dated
future.

Logic is in place to prevent both the weekly and monthly gold options from mapping to the same underlying future:

• The nearest notice date that is greater than the Weekly Option Expiry is retrieved from the Future Notice Dates
date rule (Date B)

• TheMthlyExpLagForWklyOpt days attribute is subtracted from Notice Date B (this is Date A)

• If Date A >= the Weekly Option Expiry < Date B, then the Weekly Option Expiry maps to the next date in the Future
Notice Dates date rule, greater than Date B

• I f the Weekly Option Expiry is < Date A, then the Weekly Option Expiry maps to Date B, First Notice Dated future
from the Future Notice Dates date rule
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17. Commodity Hierarchy
Commodity Hierarchy allows organization of commodity products in a hierarchical manner which can be used in
various reports and modules (for example: Sensitivity report, DTCC modules, Regulatory Risk module).

To access the Commodity Hierarchy window from the Calypso Navigator, select Configuration > Commodities >
Commodity Hierarchy (gui.widget.CommodityCategorizer).

» Existing hierarchies are loaded by default. Select the Dropdown Bar to view pre-configured hierarchies.

» To create a new hierarchy, click New and enter a name for your new hierarchy.

» To add a new folder in the hierarchy, click on and enter the name of the folder.

» To add elements to the folder, drag the required elements from the All Elements panel and drop it in the required
folder.

» Click on Save to save the hierarchy.

For example, in the following figure a new hierarchy TEST is created with various folders containing elements.
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Additional configuration options:

» Click on Delete to delete a hierarchy.

» - Delete a specific folder or element in a hierarchy.

» - Rename a folder in a hierarchy.

» - Re-arrange the order of folders or elements in a hierarchy.

» - Expand or Collapse the hierarchy.
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18. Capturing Commodity Derivatives
Trades
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19. Commodity Products Overview
The following types of commodity products are supported by Calypso.

It is recommended to use Pricing Sheet to book commodity trades. See Capturing CMD Trades.

Commodities — Derivatives

Product Name Definition Trade Worksheet
Swaps The Commodity Swap product uses the

Commodity Reset Definition to define what
values to use for both known and projected
commodity prices. You can select the
commodity reset definition during trade
capture, and define additional fixing details in
the trade.

A Commodity Swap is an exchange of payments
between two parties based on either of the
following:

Asian Swaps, Lookalike Swaps— fixed
commodity price versus a floating price, such as
an index of futures contracts.

Basis Swap— floating price versus floating
price.

The Commodity Swap can be a cross-currency
deal where the payment currency is different
than the underlying commodity product
currency.

To capture Commodity Swap Trades, please
use the Pricing Sheet - Commodity Swap.

Trade > Commodities > Swap

trading.TradeCommoditySwap2Window

OTC Options The Commodity OTC Option product uses the
Commodity Reset Definition.

A Commodity OTC Option is a strip of Cash
settled Asian or Average Rate Options. The
payoff depends on an average of Reference
Prices relative to a fixed Strike.

You can capture one of the following option
types: PUT, CALL, Put Spread, Call Spread,
Straddle, Strangle, Risk Reversal, and Synthetic
Forward, as described below. The physical
exercise types American and European are

Trade > Commodities > OTC Options

trading.TradeOTCCommodityOption2Window
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Product Name Definition Trade Worksheet
supported for PUT and CALL options.

To capture Commodity OTC Option Trades,
please use the Pricing Sheet - Commodity
Vanilla.

Listed Futures A trade capturing commodity futures or
commodity index futures that are listed on an
exchange.

Commodity exchange traded Asian products
are supported.

Note: the Future Commodity is now supported
in exDesigner.

Trade > Commodities > Listed Future

trading.TradeWindow$Future

Listed Future
Options

A trade capturing options on commodity futures
or options on commodity index futures that are
listed on an exchange.

Trade > Commodities > Listed Future
Options

trading.TradeWindow$FutureOption

Forwards A Commodity Forward Trade is a contract to
buy or sell a fixed quantity and quality of a
particular commodity for delivery at a fixed date
in the future at a fixed price. A forward contract
differs from a futures contract in that the former
is a once-only deal, for example for an odd
number of barrels which may not be available
on an exchange, while futures contracts are
standardized contracts.  These contracts
cannot be closed out by a matching transaction
for hedging purposes.

The Commodity Forward now supports cross
commodity unit conversion of the price units,
deal units, and units for the certificates. The
valuation is supported.

For example, the trade capture, valuation, and
risk now support entering physically delivered
commodity Forwards where the price is quoted
in reference currency and reference units, but
the quantity is entered in terms of the number of
future contract equivalents. This is standard in
the LME Base Metal OTC market, where OTC
Forwards and Listed Futures are
interchangeable.

In the Commodity Forward trade worksheet,
you can now set the Price currency and unit

Trade > Commodities > Forward

trading.TradeCommodityForwardWindow
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Product Name Definition Trade Worksheet
independently from the currency of the
underlying commodity and the deal units.
Added the currency and units fields to the Price
panel.

For physical commodities, the storage
certificate(s) may be entered in units that are
different from the physical commodity.

The conversion details should be configured in
the commodity conversion table.

You can enter a Commodity Forward, generate
the proper valuation, then change the units of
the price and quantity (while changing the
values of the price and quantity such that the
new value is the equivalent of the old value) and
not see a change in trade value.

You can enter Commodity Certificates in any
unit which can be converted from the deal or
strike units and compute the correct Discount
Amount and generate the correct valuation.

You can run the Certificate Stock Report and
see the correct valuation of the commodity
inventories, with prices in reference
currency/reference unit and quantities in the
units of the individual certificate quantity units.

To capture Commodity Forward Trades, please
use the Pricing Sheet - Commodity Forward.

Index Swaps A Commodity Index Swap is a swap in which the
counterparties agree to exchange cash, based
on a commodity index and a money market rate.

Note: the Commodity Index Swap trade
worksheet is deprecated. The Performance
Swap trade worksheet should be used instead.

Trade > Commodities > Index Swap

trading.TradePerformanceSwapWindow

Swaptions The Commodity Swaption product uses the
Commodity Reset Definition. Capture it in the
Pricing Sheet.

A Commodity Swaption is an option to enter into
an underlying commodity swap at a future date.

To capture commodity swaption trades, please
use the Pricing Sheet - Commodity Swaption.

Pricing > Pricing Sheet
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Product Name Definition Trade Worksheet
Cap Floors Cap— See “Call” under OTC Options above.

Floor — See “Put” under OTC Options above.

Trade > Commodities > OTC Options

trading.TradeOTCCommodityOption2Window

Commodities — Exotic Structured Products

Product Name Definition Trade Worksheet
Swaps An exotic swap is a swap where the structure of coupon and principal

payments is customized using the Calypso eXSPress language. It allows
you to define exotic payout formulas on the fly. The payout formulas
require the definition of exotic variables. The Commodity Reset is
supported as a quotable variable.

Trade > Interest
Rates > Swap

trading.TradeSwap
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20. Capturing Commodity Forward
Trades
See Commodity Forwards Migration for details on Commodity Forwards to Spot Migration.

To capture Commodity Forward Trades, it is recommended to use the Pricing Sheet - Commodity Forward.

You can also choose Trade > Commodities > Forward to open the Commodity Forward worksheet, from the Calypso
Navigator. The commodity forward trade is based on the commodity reset, not the commodity itself. You must define
a commodity reset to construct a commodity forward trade.

Commodity forward trades without certificates do not update the position by default. You need to run the scheduled
task CMD_FWD_SETTLE on the settlement date to terminate the commodity forward trade and create a commodity
spot trade. If you want to update positions for commodity forward trades without certificates, you need to set the
environment property NEW_CMD_FWD_NO_POSITION = false.

 Ⓘ [NOTE: For transactions involving future physical deliveries of commodities, the Commodity Forward
product is best suited.]

Commodity Forward Quick Reference

When you open a Commodity Forward worksheet, the Trade panel is selected by default.

Conf igu ra t ion
» Define the commodity product by choosing Configuration > Commodities >

Commodities from Calypso Navigator

» Define the commodity reset definition by choosing Configuration > Commodities >
Commodity Reset from Calypso Navigator

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below, see Field
Description.

Note that the Trade Date is entered in the Details panel.
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» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» A commodity forward trade requires the following market data: a discount curve, a

forecast curve, price quotes.

Note that a cross-currency commodity forward also requires an FX curve, an FX rate,
and an FX reset.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade using Back Office > Allocate. Allocation is not supported for

a forward with a commodity certificate.

» You can terminate the trade using Back Office > Terminate

» You can fix the prices by choosing Trade Lifecycle > Reset > Price Fixing from Calypso
Navigator

» Refer to Settlement Delivery Instructions for Physical Commodities to configure SDIs for
Commodity Forwards.

Deal units are in reference units in trade window.
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20.1 Field Descript ions
Fields Description

Role/Cpty The first two fields of the worksheet identify the trade counterparty.

The first field identifies the trade counterparty's role. The default role is specified using
Utilities > Set Default Role. However, you can change it as applicable.

You can select a legal entity of specified role from the second field provided you have setup
favorite counterparties. You can also type in a character to display the favorite
counterparties that start with that character. Favorite counterparties are specified using
Utilities > Configure Favorite Counterparties.

Otherwise click ... to select a legal entity of specified role from the Legal Entity Chooser. You
can also type [Ctrl-F] to invoke the Legal Entity Chooser, or directly enter a Legal Entity
short name.

Book Trading book to which the trade belongs. Defualts to the book selected in the User Defaults.
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Fields Description

You can modify as applicable.

You can select a book provided you have setup favorite books Favorite books are specified
using Utilities > Configure Favorite Books.

Otherwise, click ... to select a book.

The owner of the book (a processing organization) identifies your side of the trade.

Id Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load an existing trade by typing the trade id into this field and press [Enter].

Ext Ref You can also display the internal reference or external reference. The default trade
reference to be displayed can be selected in the User Defaults.

Int Ref The internal reference and external reference can be set in the Details panel of the trade
worksheet.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.

The status will change over the lifetime of the trade according to the workflow configuration
and he actions performed on the trade.

Broker Displays the broker if a broker fee is captured in the Fees panel.

Template You can select a template from the Template field to populate the worksheet with default
values. Then modify the fields as applicable.

Dates Details

Fields Description

Trade Date and Time Enter the start date and time of the trade. The trade date defaults to the current date.

Check Current to use the current system time.

Settle Date Enter the maturity date for the trade. (For most emissions trades, the settle date is equal to
the allowance delivery date.)

Commodity Details

Fields Description

Comm. Reset Select the commodity reset which will drive the forward. When the reset is selected, fields
specific to the reset pre-fill with the appropriate information.

Delivery Location This is the delivery location for storage based commodities. It is populated from the
CommodityLocation domain value. The pricer recognizes the delivery location and prices
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Fields Description

the forward according to the relevant location differentials.

NOTE: The location spread of the location indicated is used to adjust the projected forward
price of the commodity taken from the forward curve and will have a valuation impact on the
trade. Changing the delivery location has a pricing impact but does not have an impact on
the fixed price of the forward, which is a saved trade attribute.

Deal Details

Fields Description

Buy / Sell Select the direction of the trade.

Quantity The quantity of the certificate in commodity units.

Quantity Unit Unit of measure that the quantity represents. You can use a different unit type than the unit
in the product definition. The quantity unit defaults to the unit defined in the commodity
definition.

If a unit other than the default unit is chosen, the application requires a conversion definition
to correctly convert the units for the cashflows. Commodity positions are always kept in the
default unit in the Position Keeper. To define the conversion definition, from Calypso
Navigator, choose Configuration > Commodities > Commodity Conversion.

Forward Price The Forward Price is automatically displayed based on the commodity reset that has been
chosen.

Calypso out-of-the-box provides the following forward price methods:

Nearby — The Nearby (aka Prompt) future is the future in a given contract listing which is
closest to expiration on a specified date. This future is typically the most liquid and contains
the highest open interest, making it the primary choice for a derivative reference price. In
Calypso, the projected price returned by the Nearby method is equal to the the price of the
first sequentially available curve point on or after the fixing date.

Lme3M— The LME 3 Month price is similar in concept to the Cash price. In Calypso, the
projected price returned by the LME3Mmethod is equal to the value on the curve which
corresponds to the date 3 calendar months after the fixing date according to the Fixing
Holiday Calendar subject to the Forward Price Holiday Calendar. Note: this value may
correspond to an actual curve point, or may be interpolated using the interpolation method
specified in the forward curve.

LmeCash— Futures listed on the London Metals Exchange (LME) have daily expiries,
whereas most other commonly traded commodity futures have monthly listings. Because of
this, LME products tend to be quoted in terms of tenor-based futures such as Copper Cash
Buyer's Price or Lead 3 Month Buyer's Price. In keeping with this convention, derivatives
settled using the LME Cash reference price require a method which can project the price of
the official cash settlement price on a given fixing date. In Calypso, the projected price
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Fields Description

returned by the LMECash method is equal to the value on the curve which corresponds to
the date 2 business days after the fixing date according to the Fixing Holiday Calendar
subject to the Forward Price Holiday Calendar. Note: this value may correspond to an actual
curve point, or may be interpolated using the interpolation method specified in the forward
curve.

SecondNearby — The Second Nearby future on a given date is the future which is next to
expire after the prompt. In Calypso, the projected price returned by the Second Nearby
method is equal to the price of the second sequentially available curve point on or after the
fixing date.

NearbyNonDelivered — The projected price for a fixing date will be equal to the value of the
chronologically closest point on the forward curve which is equal to or greater than the fixing
date subject to the restriction that the fixing date is not after that underlying's first delivery
date, or for commodity forward points, the pillar date. If the fixing date falls after the nearby
underlying's first delivery (or pillar) date, but before the underlying's last trading date, the
value of the next (chronologically) curve point will be used.

Many agriculture future contracts have first delivery dates which fall BEFORE the last trading
day, meaning that if you hold a short position in one of these contracts, even if the future is
still trading, you may be notified by the exchange that you are required to deliver the
physical commodity. Therefore, financial players in the agriculture markets always make
sure that they exit future positions before the first delivery date to avoid that scenario.
Likewise, financial derivatives, such as swaps and options, take a similar approach and will
typically fix off of the nearest future which has not already passed its first delivery date.

For example, look at 2 consecutive CBOTWheat futures:

Future First Delivery Dt Last Trade Dt
MAR08 March 3, 2008 March 14, 2008
MAY08 May 1, 2008 May 14, 2008

For a commodity fixing on March 1, you would expect the NEARBY forward price method to
use the LTD of 3/14/08 from the curve to project the price, and for a commodity fixing on
March 5, you would STILL expect the NEARBY forward price method to use March 14, as the
fixing has not passed the last trade date (aka the MAR08 curve date on the forward curve).

In terms of the above example, for a commodity fixing on March 1, you would expect the
NearbyNonDelivered forward price method to use the LTD of 3/14/08 from the curve to
project the price since it is before the MAR08 future's first delivery date. For a commodity
fixing on March 5, you would expect the NearbyNonDelivered forward price method to use
May 14 as the curve date from which to project the price as it is after the first delivery date of
the nearby curve point.

Linear — The linear method is not a commonly used method. The projected price that it
returns is the price from the curve for the date which is equal to the fixing date. For a curve
which uses no interpolation between points, the Linear method will resemble the Nearby
method.
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Fields Description

Fixed— In some cases, derivatives are traded which agree upon a specific future as the
reference price, regardless if that future is prompt, second prompt, etc. For these situations,
we offer the Fixed forward price method. Using this method, the user must specify a date
which corresponds to the date on the forward curve whose price will be used for all fixing
dates for any derivative which uses that Commodity Reset. Any example would be a 3 month
averaging swap over the months of Jan - Mar 2008 which references the Dec 2008 future.
Each day of this swap will settle off of the price of the Dec 2008 future, therefore the
projected price of all future fixing dates will be the same, based on the curve date chosen in
the reset definition.

IceNearby — The convention of many swaps traded on the The Intercontinental Exchange
(ICE) is to fix off of the prompt future up to, but not including, that future's last trading day.
On that day, the price will fix off of the second prompt contract. The theory behind this is
that there is uncharacteristic volatility associated with a future on it's last trading day due to
market forces trying to reconcile positions before the future ceases trading. In Calypso, the
projected price returned by the ICENearby method is equal to the price of the first available
curve point after, but not equal to, the fixing date.

InterpolatedPrice — The forward price calculation is delegated to the interpolation method
set on the underlying Market Data item, of which only curves are currently supported. If
there is no interpolator set on the underlying market data item, "Nearby" forward price
lookup method is used.

Note: You cvan add custom methods by creating a class named
tk.product.commodities.priceselector.<ForwardPriceMethodName> that
implements
com.calypso.tk.product.commodities.priceselector.ForwardPriceMethod.
Compile the class, and register the method name in the commodity.ForwardPriceMethods
domain by choosing Configuration > System > Domain Values from Calypso Navigator.

Fixing Holidays Click ... to select the holiday calendar for the fixing method.

It defaults to the holiday calendar defined for the deliverable reset.

Price Details

Fields Description

Unadjusted Enter the unadjusted price.

Discount Enter any discount.

The discount may be calculated in the case of storage-based commodities. Complete the
certificate details as described below, and click Compute Certificate Discount.

Note: The Final price is the only price used in the valuation of the commodity forward.
Adding a discount only impacts the NPV of the trade if the discount is allowed to alter the
final price.
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Fields Description

Final The Final field displays the final price.

Price Type Select either a Fixed or Floating price, the currency and the units.

The Price currency and unit default to the currency and unit of the selected commodity.
However, you can set these independently.

The Commodity Forward supports cross commodity unit conversion of the price units, deal
units, and units for the certificates. The valuation is supported.

For example, the trade capture, valuation, and risk support entering physically delivered
commodity Forwards where the price is quoted in reference currency and reference units,
but the quantity is entered in terms of the number of future contract equivalents. This is
standard in the LME Base Metal OTC market, where OTC Forwards and Listed Futures are
interchangeable.

The conversion details should be configured in the commodity conversion table.

Comm. Reset Select a commodity reset. You are able to select a different reset than the one that is being
used to book the Forward.

Spread Enter a Floating price spread.

Date Schedule Click the drop down box to display and select a desired date schedule for the float side of
the forward.

The summary of what is chosen in the Date Schedule window is then displayed.

Payment Details
Define the payment lag details for the cash payments (the COMMODITY flows).
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Fields Description

Date Roll Select the date roll convention to roll the payment dates when they fall on non-business
days. The payment calendar is used to determine business days.

From Calypso Navigator, chooseHelp > Date Roll Conventions for a description of date roll
conventions.

Holidays Click ... to select the calendar(s) the application uses to determine the business days.

Lag Specify lag days from the end date of the payment period (in business or calendar days) for
the actual payment to take place. By default, business days are used to calculate the
payment date. To specify calendar days, double-click the Bus label to toggle to Cal.

Payment Day Select to enter a specific payment date.

Physical Details
Define the payment lag details for the security transfer (the SECURITY flows).

Fields Description

Date Roll Select the date roll convention to roll the payment dates when they fall on non-business
days. The payment calendar is used to determine business days.

From Calypso Navigator, chooseHelp > Date Roll Conventions for a description of date roll
conventions.

Holidays Click ... to select the calendar(s) the application uses to determine the business days.

Lag Specify lag days from the end date of the payment period (in business or calendar days) for
the actual payment to take place. By default, business days are used to calculate the
payment date. To specify calendar days, double-click the Bus label to toggle to Cal.

Payment Day Select to enter a specific payment date.

Certificates & Delivery
checkValidCertificateWorkflow Rule

The checkValidCertificate workflow rule can be used for validation on commodity certificates for buying and selling on
Commodity Forward trades.

For a Buy deal, this workflow rule checks:

• If there is an existing inventory with the same Identifier. If so, then: 

– if there is an open quantity on the existing inventory, the certificate is not valid and is rejected with a
message, "Cannot amend inventory with the same certificate identifier on trade window."

– if there is no open quantity, the trade is allowed if the buyingSameCmdCertificate keywoard is set to true.

• If there is no inventory with this existing name, then the new certificate is allowed.
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For a Sell deal: 

• When the certificate is selected to sell using the Certificate Selector window, all of the fields on the certificate are
non.-editable except for the Price field. The price is automatically set as the contract/trade price when the
certificate is selected.

• The checkValidCertificateworkflow rule verifies the following for the sell deal:

– if the quantity on the Commodity Forward trade matches the quantity on selected certificate. If it does not
match, it is rejected with an error message.

– if the price on the Commodity Forward trade matches the price on the selected certificate. If it does not
match it is rejected with an error message.

– if there is an existing inventory of the same identifier name. If not, it is rejected with an error message.

Additionally:

» When using this workflow rule for a Buy/Sell Commodity trade, if the Commodity Forward trade settle date plus
the lag is not equal to the certificate settle date, an error message is received and the trade cannot be saved.

» The Delivery Location on the Commodity Forward trade should be the same as the location on the certificate
attached to the Buy and Sell trade. This validation is part of this workflow rule.

Buying/Defining a Certificate - Storage Based
l Use with storage-based commodities.
l Buy trades require the user to create a new certificate. Sell trades require the user to select a certificate from

the current certificate inventory.
l To add a certificate to the trade, the direction of the trade should be set to Buy.
l The valuation currency of the certificate is always the currency of the underlying commodity.
l You can save a trade without a certificate, and add the certificate later, as needed.
l When you save the trade without a certificate, the trade and associated transfers are promoted to the next

status based on the workflow configuration. However, the transfers should not be authorized until the
certificate is actually set on the trade. To prevent the authorization of the transfers, you can add the rule
CheckRealCommodityCertificate to the transfer workflow transition PENDING – AUTHORIZED – VERIFIED.

 Ⓘ NOTE: The Certificate & Delivery panel is not required for Emission commodities

The following is an example for storage-based commodities.

» Click to add a certificate.

» Enter the certificate quantity, units, price, select the location, and enter the certificate details. Certificate details
are:

Storage Date - The date through which storage has been paid.

Maturity Date - The end date of the storage contract.
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Grade - The quality rating of the commodity. Lower quality indicates lower value. This list is populated from the
CommodityGrade domain value.

Handling Fee - This is a fee in the commodity currency, associated with the physical movement of the
commodity.

Future Delivery Set - The future against which the certificate is eligible to be valued, for certificates hedged
against a specific future delivery period.

» Additional details may be recorded in the Details panel by selecting a custom-built template. See Certificate
Templates for details.

NOTE: The Location field in the Certificates and Delivery panel is populated from the CommodityLocation domain
value. (From Calypso Navigator, choose Configuration > System > Domain Values)

» Quote names for the location differential, storage cost and grade differential needed for the certificate are
created in the Quote Creator.

» Choose Market Data > Market Quotes > Quotes or Pricing Env > Check and click Get Quotes to view or edit the quotes
for the grade differential, location differential, and storage cost.
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» In the forward trade, click Compute Certificate Discount to calculate the actual price that the bank is paying for the
certificate. NPVY = Q * [(F – SC– LD – GD- Handling)*df – SD], where

– NPVY = The present value of the Certificate in Currency Y, which is the Trade Currency of the Certificate

• Q = Quantity of the commodity in unit X, which represents the unit of the Certificate

• F = Market price of the specified future in currency Y and commodity unit X

– If the future quote is not in unit X, it should be converted using the value in the Commodity Conversion table.

– If the future quote is not in currency Y, it should be converted to currency Y using the Forward FX Rate on
the First Delivery Date of the future, unless the value date is between the first delivery date and the last
trade date of the future, in which case the future price should be converted to currency Y using the spot
rate.

• SC = Cost to store commodity from value date until first delivery date of F in Currency X and commodity unit Y

– SC = 0, if no future is specified, AND there is no future contract which is defined as the
"IsDefaultDeliverableFutureContract" (To define a default deliverable contract, set the
IsDefaultDeliverableFutureContract attribute to Yes in the Future Contract window of the desired contract,
accessible from Calypso Navigator by selecting Configuration > Listed Derivatives > Future Contracts),

or

– SC = 0, if no future is specified, AND the value date is between the First Delivery Date and the Expiry Date of
the Nearby Future, otherwise,

– SC = (TF – TD) * S, where

– TF = First Delivery Date of F, or the First Delivery Date of the Nearby Future if no future is specified,
otherwise

– TF = TV if TV is after the first delivery date and before the last trading date of F, otherwise

– TF = TV if there is no future specified and no future is define as "IsDefaultDeliverableFutureContract"

– TD = Value Date or Certificate Storage Date, whichever is greater

– S = Storage rate in currency Y per commodity unit X

If the storage rate is not in currency Y, then it needs to be converted at the forward FX Rate at TF

If the storage rate is not in commodity unit X, then it needs to be converted using the factor available in the
commodity conversion table

• LD = Location Differential in currency Y per commodity unit X

– If the Location Differential is not in currency Y, then it needs to be converted at the forward FX Rate at TF
(using definition of TF above)

– If the Location Differential is not in commodity unit X, then it needs to be converted using the factor
available in the commodity conversion table

• GD = Grade Differential in currency Y per commodity unit X
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– If the Location Differential is not in currency Y, then it needs to be converted at the forward FX Rate at TF
(using definition of TF above)

– If the Location Differential is not in commodity unit X, then it needs to be converted using the factor
available in the commodity conversion table

• Handling = Handling fee as defined above

• df = 1 if no future is specified, AND there is no future contract which is defined as the
"IsDefaultDeliverableFutureContract", or

• df = 1, if no future is specified but there is a future defined as "IsDefaultDeliverableFutureContract", AND the value
date is between the First Delivery Date and the Expiry Date of the Nearby Future, otherwise

• df = Discount factor from Tv to TF from the zero curve of currency Y

• SD = Accrued storage cost in currency Y

– SD = S * (Tv – Ts), if TS < TV

– SD = 0 if Ts > Tv

– TV = Value date

– TS = Storage Date on the Certificate

– S = Storage rate in currency Y per commodity unit X

If the storage rate is not in currency Y, then it needs to be converted at the forward FX Rate at TF

If the storage rate is not in commodity unit X, then it needs to be converted using the factor available in the
commodity conversion table

» Hit F5 to resave the trade with the certificate.

 Ⓘ [IMPORTANT NOTE: If you want to remove a Certificate from a Commodity Forward trade, you need to
cancel the trade and capture a new trade without the Certificate - It is not supported to remove a Certificate
from an existing trade]

20.2 Defining an Emission Cert if icate
When an Emission commodity reset is chosen in the Comm Reset field, the Certificates and Delivery area reflects this
type of trade. The pricer automatically calculates the cheapest allowance to deliver which becomes the default
allowance type for delivery. This is displayed in the Cheapest to deliver field. When the time for delivery comes or
when the actual delivery specifications are known, the user selects the Set delivery check box and is able to
designate the actual number and allowances for delivery.
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Selling a Certificate
Certificates may be sold when the direction of the deal is set to Sell. When a certificate is sold, it must be chosen from
a list of certificates that are currently available.
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» Load a forward trade in the worksheet.

» Set the deal direction to Sell, and click to open the certificate selection window.

» Use the filter field at the top of the window to quickly find certificates that meet your desired criteria.

» Highlight a certificate and click Select.

The certificate loads in the certificate panel.

Only the Price field is editable when selected and is automatically set as the contract/trade price.

» Save the trade.

You can amend, split and merge certificates from the Certificate Management window.

20.3 Floating Rate Forward
The Commodity Forward trade can be configured to use a floating price at which to purchase or sell the underlying
commodity. This can be achieved by changing the Price Type from “fixed” to “floating”. The user can then choose a
commodity reset as well as the date or dates over which that reset will be observed. If more than one date is chosen,
the floating price will be calculated as an arithmetic average of the observed rates. Once all of the observations have
occurred, the calculated price will now act as the fixed price for the transaction. The user has the ability to apply a
fixed spread to the floating price if they desire.
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» Future FX cashflows for Commodity Forward trades are discounted using a zero curve for each currency. The
result is converted to a single currency.

» When FX_POINTS is False, the discount curves for both the traded / deal currency and the settlement currency
need to be configured.
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21. Capturing Commodity Swap Trades
To capture Commodity Swap Trades, please use the Pricing Sheet - Commodity Swap.

Choose Trade > Commodities > Swap to open the Commodity Swap worksheet, from Calypso Navigator or from the
Calypso Workstation.

Commodity Swap Quick Reference

When you open a Commodity Swap worksheet, the Trade panel is selected by default.

Conf igu ra t ion
» Define the commodity product by choosing Configuration > Commodities >

Commodities from Calypso Navigator

» Define a commodity reset definition by choosing Configuration > Commodities >
Commodity Reset from Calypso Navigator

» Define a future contract definition by choosing Configuration > Listed Derivatives >
Future Contracts from Calypso Navigator

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below, see Field
Description.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

» You can set up commodity confirmation keywords for disruption events via Commodity
Swap2 > Commodity Confirm Keywordswithin the Commodity Swap window. For
more information on this, see the Confirmation Messaging documentation.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.
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Pr ic ing a Trade
» A commodity swap trade requires the following market data: a discount curve, a

commodity forward curve for forecasting the prices, and commodity reset quotes.

Note that a cross-currency commodity swap also requires an FX curve, an FX rate, and
an FX reset.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books using Back Office > Allocate

» You can terminate and partially terminate the trade using Back Office > Terminate

» You can fix the prices by choosing Trade Lifecycle > Reset > Price Fixing from Calypso
Navigator
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21.1 Commodity Swap

» When both legs are floating, the details for the Date Schedule, FX Conversion, Quantity Schedule, and Payment
Schedule can either be the same for each floating leg, or you may define different details for each floating leg.

The locked padlock icon indicates both legs are the same.
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» Click the padlock icon to turn it to the unlocked position, and the trade worksheet opens separate entry fields for
the left leg and the right leg, respectively. You can specify different details for each leg.

» Choose Help > Trade Help for complete details.

Nasdaq Calypso
Commodities Trading / Version 18

March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 96 / 145



March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 97 / 145

21.2 Electr icity Swap

» View the Business Day and Holiday distributions when you pull down Electricity from the Intraday Policy menu.
See Intraday Policies for details.
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» With Electricity swaps, you are also able to select a Daylight Savings Time rule. The purpose of this rule is to
compensate for the hour that is gained or lost during spring and fall on an electricity swap that has hourly resets.

Nasdaq Calypso
Commodities Trading / Version 18

March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 98 / 145



March 2025
Revision 6.0 / Approved

Proprietary and Confidential
Page 99 / 145

21.3 Gas Oil Indexation Swap
Unlike other policies where the fixing dates are always within the range of the start and end date, fixing for natural gas
is in the start and end date range of the days on which natural gas is delivered. Because of this, natural gas trades
need to have their own fixing policy, payment frequency and averaging method.

The fixing dates for natural gas are generally offset by one day or by calendar month increments. A day-ahead trade
will have fixing dates offset from the delivery dates by on one business day. A month-ahead trade will have fixing
dates offset from the deliver dates by 1 calendar month. The number of fixing dates will not necessarily equal the
number of delivery dates. Gas often prices every delivery day using the average of the prices for a calendar month.
The total quantity of a gas swap is often expressed per day. The number of days refers to the number of delivery
days, not fixing days.

It is also common in Natural Gas contracts to price against the oil market. In this case, fixing dates can be several
months prior to the delivery period. For example in [3,0,3] pricing, each month is priced using the average of three
months average prices for three months prior to delivery. So a year-16 swap would have:

Jan-16, Feb-16 and Mar-16 pricing on average of Oct-15, Nov-15 and Dec-15 prices,

Apr-16, May-16 and Jun-16 pricing on average of Jan-16, Feb-16 and Mar-16 prices,

Jul-16, Aug-16 and Sep-16 pricing on average of Apr-16, May-16 and Jun-16 prices,

Oct-16, Nov-16 and Dec-16 pricing on average of Jul-16, Aug-16 and Sep-16 prices.

Nasdaq Calypso
Commodities Trading / Version 18



» The Gas Oil Indexation Payment Frequency specifies that there is a cash flow for every calendar month. It is
possible that several calendar months will have the same payment due date. When using the Gas Oil Indexation
Payment Frequency, the only Fixing Policy available is Gas Oil Indexation.
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» When the Gas Oil Indexation Fixing Policy is selected, the trade window displays three additional Indexation fields
for the Averaging Period, Time Lag and Recalculation. These are all required integer values with no default.
Additionally, the settlement period must be monthly.

» The Gas Oil Indexation Averaging Method causes the commodity price fixings to be averaged for each calendar
month. After that, the month averages are averaged. If the trade is settling in a different currency from the index
currency, an FX Averaging Period, FX Indexation Lag and FX Recalculation are required. The FX resets are
averaged in a similar way. Finally, the averaged commodity price is converted using the averaged FX rate.

21.4 Fields Descript ion
Fields Description

Role / Cpty The first two fields of the worksheet identify the trade counterparty.

The first field identifies the trade counterparty's role. The default role is specified using Utilities > Set
Default Role. However, you can change it as applicable.

You can select a legal entity of specified role from the second field, provided you have setup favorite
counterparties. You can also type in a character to display the favorite counterparties that start with
that character. Favorite counterparties are specified using Utilities > Configure Favorite
Counterparties.

Otherwise, click ... to select a legal entity of specified role from the Legal Entity Chooser. You can also
type [Ctrl-F] to invoke the Legal Entity Chooser, or directly enter a Legal Entity short name.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults. You can
modify as applicable.

You can select a book provided you have setup favorite books. Favorite books are specified using
Utilities > Configure Favorite Books.

Otherwise, click ... to select a book.

The owner of the book (a processing organization) identifies your side of the trade.

Id Unique identification number of the trade. The trade id is automatically assigned by the system when
the trade is saved.

Ext Ref

Int Ref

You can load an existing trade by typing the trade id into this field and pressing [Enter].

You can also display the internal reference or external reference. The default trade reference to be
displayed can be selected in User Defaults.

The internal reference and external reference can be set in the Details panel of the trade worksheet.

Status Current status of the trade. The status is automatically assigned by the system based on the workflow
configuration.

The status will change over the lifetime of the trade according to the workflow configuration and the
actions performed on the trade.

Broker Displays the broker if a broker fee is captured in the Fees panel.
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Template You can select a template from the Template field to populate the worksheet with default values. Then
modify the fields as applicable.

Swap Type Select the type of fixed/floating convention for the swap.

Type Description

Buy (Pay Fixed) The pay/floating leg is on the left, the receive/fixed leg on the right.

Sell (Rec Fixed) The pay/rec labels switch positions. The receive/floating leg is on the left, the
pay/fixed leg is on the right.

Float/Float Both legs are floating. The details for the Date Schedule, FX Conversion, Quantity
Schedule, and Payment Schedule can either be the same for each floating leg, or you
may define different details for each floating leg.

The locked padlock icon indicates both legs are the same.

Click the padlock icon to turn it to the unlocked position, and the trade worksheet
opens separate entry fields for the left leg and the right leg, respectively. You can
specify different details for each leg.

Payment
Currency

Select the currency in which the payments occur.

If the payment currency is different than the reference currency, you can enter details for the FX
Conversion, as described below.

Floating Swap Leg
Rec / Pay The application automatically sets these labels based on the selected Swap Type.
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Pay / Rec

Commodity
Reset /
Future

Select either the commodity reset or future for the trade.

When Reset is selected, you may select from available resets in the drop-down box to the right.

When Future is selected, click the to display the Select Future window and choose the future
desired future.
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Reference
Currency

Displays the reference currency as defined in the commodity reset definition.

This field cannot be modified.

Fwd Price Displays the forward price method as defined in the commodity reset definition.
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Method This field cannot be modified.

Fixing
Calendar

Displays the calendar(s) to use when calculating the fixing dates. These default from the commodity
reset definition.

You can modify the calendars. Click ... to select the calendars.

Factor This allows multiple swap legs to be structured to create a pricing formula with varying contributions
from multiple index prices.

Spread Optional. Enter a spread based on the delivery location. This spread is added directly to the fixing price
in Payment CCY. The spread amount appears in the Spread Adjusted Price Diff column of the Cashflows
tab of the trade window.

The spread should be entered as a straight percentage rate.

It is possible to specify a Spread Schedule by clicking the ellipsis button. This action displays a Spread
Schedule window where you can designate specific spread for each time period.

Note: Spread schedule is supported for Periodic, FutureContractFND, FutureContractLTD, Daily, Daily
Rule and Third Wednesday Pay frequency only.

Fixed Swap Leg
Rec / Pay The application automatically sets the Rec/Pay labels based on the selected Swap Type.
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Strike Ccy When Swap type is Buy (Pay Fixed)/Sell (Rec Fixed) and the Commodity Type is Reset or Future,this
drop-down is available when the Payment currency selected is different from the Reference currency.
The default value is the Reference currency. The drop-down menu consists of the Reference and
Payment currencies.

When the Payment currency is the same as the Reference currency, the Strike Currency is the Payment
currency.

If Swap type is Buy(Pay Fixed)/Sell(Rec Fixed) and Commodity Type is Future, the Strike Currency is the
Payment Currency.

Strike Enter the price per unit.

You can enter as many decimal places as needed to get the payments to the desired amount. There is
no rounding of the strike when calculating the payments.

It is possible to specify a Strike Schedule by clicking the ellipsis button. This action displays a Strike
Schedule window where you can designate specific strike for each time period.

Note: Strike schedule is supported for Periodic, FutureContractFND, FutureContractLTD, Daily, Daily
Rule and Third Wednesday Pay frequency only.

Buy/Sell
Units

Specifies the quote unit, which defaults from the commodity reset definition. However, you can select a
different unit.
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Par Strike The Single Fixed Strike denominated in DealCurrency per StrikeUnit which would result in the same PV
as the Strike(i).

Date Schedule
Define the fixing dates for the floating prices, settlement dates, and how many swaplets (swap
periods) are valued over the life of the swap.
Pay Freq. See Payment Frequencies for details.

Fixing
Policy

See Fixing Policies for details.

Intraday
Policy

See Intraday Policies for details. This field is displayed for swaps with Electricity resets. You need to
enter an intraday policy for this type of swap, because resets can be at various times of the day,
depending on the peak hour schedule.

Quantity Schedule
Specify the details about the deal quantity schedule. Details about the deal quantity and the
reference quantity can be viewed in the Cashflows.
Quantity Specify the deal quantity to trade for a specified frequency.

It is possible to specify a Quantity Schedule by clicking the . This action displays a Quantity Schedule
window where you can designate specific quantities for each time period.
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Click Generate to generate the dates after selecting the frequency from the drop-down menu. After
entering the quantities, click Apply. When a Quantity Schedule is in place, an * will appear next to the
Quantity field.

Bullet payment frequency is not supported with this feature.

 Ⓘ [NOTE: For a Float/Float commodity swap, the quantity is displayed in absolute value,
regardless of the trade direction]

Quote Unit Unit of measure that the deal quantity represents.

Per Period Specify the frequency that the deal quantity is traded.

For Pay Frequency – Future Contract LTD/FND, user can select below options for ‘Per Period’:

• Future Contract Period - Specified Quantity is applied to each period.

• DLY - Specified Quantity is applied to each day in a period. Total Quantity for the period will be
Quantity * Number of Days in the period.

• DLY Delivery Period - Specified Quantity is applied to each day of Delivery period of Contract. Total
Quantity for the period will be Quantity * Number of Days in Delivery period of Future Contract.
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Total Qty The total deal quantity traded for the swap.

After Conv Set to ‘Round’ to indicate that the reference unit to deal unit conversion of the price should be rounded
prior to calculating the amount for the cash flow.

The default is ‘Don't Round’, which means the rounding occurs after the amount is calculated.

FX Conversion
The FX Conversion is required when the payment currency is different than the reference currency.
You can select the rounding method for both cross currency and single currency deals in the FX
Conversion panel.
FX Reset
Rate

Select the FX Reset to use for conversion of prices from the reference currency to the payment
currency.

Avg
Method

See Averaging Methods for details.

Rounding
After

See Rounding Policies for details.

FX Reset
Cal

Displays the calendar(s) used to determine business days for the FX reset.

The calendars are defined in the FX rate definition. You cannot modify this field.
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FX End Lag Used to price a quanto swap where the commodity average is calculated in the commodity reference
currency and then converted to the settlement currency using a single FX reset observed on a date
which is relative to the last commodity fixing date.

The FX lag is the business day lag with respect to the last fixing date in the fixing period. All fixing days
during this period will take this FX fixing.

Payment Schedule
Define when the payment occurs for each swaplet.
Calendar Click ... to select the holiday calendar(s) used to determine the business days when calculating the

payment date.

Payment
Lag

Specify lag days from the end date of the swaplet (in business or calendar days) for the actual payment
to take place.

Enter N days for the payment to occur N days after the swaplet end date.

Enter 0 for the payment to occur on the swaplet end date.

Enter –N days for the payment to occur N days before the swaplet end date.

Payment Select to enter payment details. This makes a field available next to the Day label where you can specify
which day the payment should take place. For example, enter “5” to specify that the payment date
occurs on the 5th of the month following the swaplet end date.

Double-click the Day label to switch to Rule and select a date rule for determining the payment date if
required. Click ... to select the payment date rule.

Date Roll Select the date roll convention to roll the payment dates when they fall on business days. The payment
calendar is used to determine business days.

For a description of date roll conventions, from Calypso Navigator, choose Help > Date Roll
Conventions.

The cashflow column ‘Days’ is modified to store number of days in Delivery Period i.e. days in between cashflow
column 'Und Future First Del date' and 'Und Future Last Del date' including first and last date in the period when Date
Schedule Pay Frequency is FutureContractLTD or FutureContractFND and Per Period - 'DLY - Future Contract
Delivery Period' is selected.
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22. Capturing Commodity Index Swap
Trades
Choose Trade > Commodities > Index Swap to open the Performance Swap worksheet, from the Calypso Navigator.

Two types of Total Return Swap on Market Index can be captured:

• Index level - the Fixing Type is Price. Performance is calculated as (end index level/start index level -1)*notional.

• Index spread – the Fixing Type is Spread. Performance is calculated as (end spread- start spread)*start modified
duration*notional.

Commodity Market Index Level will be either calculated using its constituents or from quote.

Index Level depends upon Pricing parameter 'USE_BASKET_COMPONENT_PRICING' in conjunction with pricing
parameters 'NPV_FROM_QUOTE' & 'FUTURE_FROM_QUOTE'.

When USE_BASKET_COMPONENT_PRICING (default = false) is set to False, Market index level is equal to
MarketIndex Quote from Quoteset.

When USE_BASKET_COMPONENT_PRICING is set to True, Market index level is calculated using sum of weighted
price of the constituent and divided by divisor set on Market Index definition. Index level is calculated using latest
effective date’s constituents’ weight as per Value Date.

1. NPV_FROM_QUOTE (default = false)

Applicable when MarketIndex constitutes a Commodity Spot, if the Parameter is set to true, spot quote from
Quoteset will be used, else price from commodity forward curve will be used.

2. FUTURE_FROM_QUOTE (default = false)

Applicable when MarketIndex constitutes a Commodity Future, if the Parameter is set to true, future quote from
QuoteSet will be used, else price from commodity forward curve will be used.

Note: Recommended pricer is PerformanceSwapAccrual for Swap on Commodity Market Index.

Commodity Index Swap Quick Reference

When you open a Performance Swap worksheet, the Trade panel is selected by default.

Conf igu ra t ion
» Define the exchange where the commodity index trades by choosing Configuration >

Legal Data > Entities from Calypso Navigator
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» Define the holiday calendar by choosing Configuration > Definitions > Calendar
Definitions from Calypso Navigator

» Define the commodity index as a market index by choosing Configuration > Product >
Market Index from Calypso Navigator. A basket of commodities may be attached to the
index to model the index. Click … next to the Basket field to define the basket.

See Commodity Index for a sample commodity index.

» Define the reference index by choosing Configuration > Interest Rates > Rate Index
Definitions from Calypso Navigator. For the TBILL index, the TBillDailyCompound and
LiborDailyDecompound calculators are available out-of-the-box

» Define the management fee types in the defaultCISManagementFeeType domain.
Define the fee definitions from Calypso Navigator by choosing Configuration > Fees,
Haircuts & Margin Calls > Fee Definition. For example, the PREMIUM can be defined
using the Commodity default calculator. The MANAGEMENT_FEE can be defined using
the AnnualPercentage default calculator; add the AnnualPercentage calculator to the
feeCalculator domain. The AnnualPercentage fee amount is nominal * (fee percentage *
daycount/365), where the daycount is the Fee Start Date – Fee End Date. The fee
percentage is entered in the trade in the Fees panel

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» For pricing Total Return Swap on Market Index we use the accrual method. In this

method we calculate:

- The funding leg NPV as the accrual of interest from last payment date to today.

- The performance leg:

On Index level: (Valuation dates index level/period start index level -1)*notional

On Index spread: (Valuation dates index spread/period start index spread -
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1)*period start modified duration*notional

» The PricerPerformanceSwapAccrual is used for accrual pricing. Register the pricer for
the PerformanceSwap product and MarketIndex subtype:

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade using Back Office > Allocate

» You can terminate the trade using Back Office > Terminate

» You can reset the floating interest rates by choosing Trade Lifecycle > Reset > Rate
Reset from Calypso Navigator, or using the RATE_RESET scheduled task

» You can fix prices by choosing Trade Lifecycle > Reset > Price Fixing, or using the
PRICE_FIXING scheduled task
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22.1 Sample Commodity Index Swap Trade

It is to be noted that, the check to ensure weights of all constituents amounts to 100%, is accurate upto 10 decimal
places for weight type as ‘Percentage’.
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Important Note
The notional is fixed at trade inception and does not change when the index is reset.

If you want the notional to change based on the index reset, you may want to consider Equity Swaps instead (and
define an Equity Index rather than a Market Index).

22.2 Sample TBILL Index - TBi l lDai lyCompound Calculator
From Calypso Navigator, choose Configuration > Interest Rates > Rate Index Definitions.
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22.3 Sample TBILL Index - LiborDai lyDecompound Calculator

From Calypso Navigator, choose Configuration > Interest Rates > Rate Index Definitions.

22.4 Sample Management Fee
The fee calculator AnnualPercentage can be used with the management fee accrual in Performance Swap pricing.
The fee amount is nominal * (fee percentage * daycount/365). The fee percentage is entered in the trade.

Add the calculator to the feeCalculator domain in Domain Values.

Add the MANAGEMENT_FEE to the defaultCISManagementFeeType domain in Domain Values.
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To set up the fee definition, choose Configuration > Fees, Haircuts & Margin Calls > Fee Definition from Calypso
Navigator.
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23. Capturing Commodity OTC Option
Trades
To capture Commodity OTC Option Trades, please use the Pricing Sheet - Commodity Vanilla.

Choose Trade > Commodities > OTC Options to open the Commodity OTC Option worksheet, from Calypso
Navigator or from the Calypso Workstation.

Commodity OTC Option Quick Reference

When you open a Commodity OTC Option worksheet, the Trade panel is selected by default.

Conf igu ra t ion
» Define the commodity product by choosing Configuration > Commodities > Commodities from Calypso

Navigator

» Define the commodity reset definition by choosing Configuration > Commodities > Commodity Reset from
Calypso Navigator

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with default values. Then modify

the fields as applicable.

Or you can enter the trade fields directly. They are described below, see Field Description.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As New.

A description will appear in the title bar of the trade worksheet, a trade id will be assigned to the trade, and the
status of the trade will be modified according to the workflow configuration.

The description is in the form of ProductType/OptionTypeOptionStyle/UnderlyingCommodityMaturityDate
Strike

Pr ic ing a Trade
» The following pricers are available for Commodity OTC Options out-of-the-box:

PricerCommodityOTCOption2LTBlack, PricerCommodityOTCOptionAnalytic and
PricerCommodityOTCOption2Clewlow.
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» You can add the following pricer measures for the option strategies if they do not appear in the system by
default: LOWER_PAR_STRIKE and UPPER_PAR_STRIKE. To do this, from Calypso Navigator, Configuration >
System > Add Pricer Measure.

» A commodity otc option trade requires the following market data: a discount curve, a commodity forward curve
for forecasting the prices, a commodity volatility surface, and commodity reset quotes.

Note that a cross-currency commodity otc option also requires an FX curve, an FX rate, and an FX reset.

» You can choose Pricing Env > Check to check if all required pricing data are available in the Pricing
Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books using Back Office > Allocate

» You can terminate and partially terminate the trade using Back Office > Terminate

» Prices can be fixed from Calypso Navigator by choosing Trade Lifecycle > Reset > Price Fixing

» For physically settled options, you can exercise the option from the trade worksheet using Back Office >
Exercise

» For cash settled options, the option can be exercised using the Price Fixing function, either through the Price
Fixing window Trade Lifecycle > Reset > Price Fixing, or the PRICE_FIXING scheduled task.

» For cash settled options, it is possible to choose not to exercise in-the-money options by manually de-
selecting the Exercise? checkbox for the option in the Price Fixing window.
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23.1 Sample Commodity OTC Option Trade

» ChooseHelp > Trade Help for complete details and more sample trades

23.2 Commodity Option Types Table
Option Type Number of

Strikes
Strike Components of Option Structure

Buy Sell

Put 1 x Buy Put Option with Strike x Sell Put Option with Strike x

Call 1 x Buy Call Option with Strike x Sell Call Option with Strike x

Put Spread 2 x,y, where x>y Buy Put Option with Strike x and Sell Put Option with Strike x and
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Option Type Number of
Strikes

Strike Components of Option Structure

Buy Sell

Sell Put Option with Strike y Buy Put Option with Strike y

Call Spread 2 x,y, where x<y Buy Call Option with Strike x and

Sell Call Option with Strike y

Sell Call Option with Strike x and

Buy Call Option with Strike y

Straddle 1 x Buy Call Option with Strike x and

Buy Put Option with Strike x

Sell Call Option with Strike x and

Sell Put Option with Strike x

Strangle 2 x,y, where x>y Buy Call Option with Strike x and

Buy Put Option with Strike y

Sell Call Option with Strike x and

Sell Put Option with Strike y

Risk Reversal 2 x,y, where x>y Buy Call Option with Strike x and

Sell Put Option with Strike y

Sell Call Option with Strike x and

Buy Put Option with Strike y

Synthetic
Forward

1 x Buy Call Option with Strike x and

Sell Put Option with Strike x

Sell Call Option with Strike x and

Buy Put Option with Strike x

23.3 Barr iers
You are able to add a barrier (knock-in or knock-out) to a cash settled OTC Commodity Option. The barrier is active
for the entire life of the option, or until triggered. To set the Barrier details, click the Edit button next to the Barrier
field.

The Barriers Details window is then displayed.
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The Barrier is considered when calculating cashflows.

• Type UP & IN, cashflows will be paid/received only if the barrier is hit

• Type UP & OUT, cashflows will be paid/received until the barrier is hit

• Type DOWN & IN, cashflows will be paid/received only if the barrier is hit

• Type DOWN & OUT, cashflows will be paid until the barrier is hit

Field Description

Barrier Count The default setting is 'No Barrier'. Click in this field and select 'Single' to add a barrier to the
option.

Type Select the type of barrier: 'UP & IN', 'UP & OUT', 'DOWN & IN', 'DOWN & OUT'

Level This is the absolute price level of the barrier. This price is understood to be quoted in the
option strike units per option settlement currency.

Level % This field is not yet implemented.

Rebate A rebate can be paid if an option is knocked out. To include a rebate, set this field to 'Yes'.

Amount The amount of the rebate per commodity unity. The rebate is entered in amount per strike
unit. For example, a rebate may be entered as "0.35 per barrel" by entering 0.35 in this field.

Currency The currency of the rebate. This should always be equal to the settlement currency of the
option.
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Field Description

Payment Timing The payment schedule of the rebate. This can be paid at the original option maturity (At
Maturity) or on a date relative to the knock out event (At Instant).

Note: The commodity barrier option is compatible with the Option Lifecycle Analysis, where you can monitor the
barriers, flag for trigger or exercise as well as other useful features. You must also be sure to configure the appropriate
workflow to allow commodity options to be triggered and exercised.

Field Description

The cashflow column ‘Days’ is modified to store number of days in Delivery Period i.e. days in between cashflow
column 'Und Future First Del date' and 'Und Future Last Del date' including first and last date in the period when Date
Schedule Pay Frequency is FutureContractLTD or FutureContractFND and Per Period - 'DLY - Future Contract
Delivery Period' is selected.
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24. Capturing Commodity Swaption
Trades
To capture Commodity Swaption Trades, please use the Pricing Sheet - Commodity Swaption.

To capture commodity swaption trades in the Pricing Sheet, select the Commodity Swaption strategy and set the
properties as needed. You can also select a strategy template to populate default values.

The following categories of properties are common to all types of strategies:

• Trade properties

• Product Amount properties

• Market Data properties

• Solver properties

• Dealt Data properties

• Keyword properties

• Pricer properties

Please refer to Calypso Strategy Properties documentation for details.

Commodity Swaption Quick Reference
Pricing Sheet Strategy drop-down menu for selection.

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.
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Or you can enter the trade fields directly.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» Please use PricerCommoditySwaption2.

» A commodity swaption trade requires the following market data: a discount curve, a
forecast curve, a commodity volatility surface, reset rates.

Note that a cross-currency commodity swaption also requires an FX curve, an FX rate,
and an FX reset.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books using Back Office > Allocate

» You can terminate and partially terminate the trade using Back Office > Terminate

» You prices by choosing Trade Lifecycle > Reset > Price Fixing

» You can exercise the option using Back Office > Exercise or from Calypso Navigator by
choosing Trade Lifecycle > Expiration & Exercise > Options Exercise
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25. Capturing Commodity Listed Future
Trades
Choose Trade > Commodities > Listed Future to open the Future worksheet, from Calypso Navigator or from the
Calypso Workstation.

Future Commodity Quick Reference

When you open a Future worksheet, the Trade panel is selected by default.

 Ⓘ [NOTE: The trade counterparty must be a clearer, so you must have defined a
legal entity of role Clearer]

Conf igu ra t ion
» Define the exchange where the commodity trades by choosing Configuration > Legal

Data > Entities from Calypso Navigator

» Define the holiday calendar by choosing Configuration > Definitions > Calendar
Definitions from Calypso Navigator

» Define date rules by choosing Configuration > Definitions > Date Rule Definitions
from Calypso Navigator

» Define the commodity product by choosing Configuration > Commodities >
Commodities from Calypso Navigator

» Define the future contracts by choosing Configuration > Listed Derivatives > Future
Contracts from Calypso Navigator

See Commodity Futures Setup for details.

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below, see Field
Description.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
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» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» A future commodity trade requires the following market data: a zero curve for

discounting the cash flows, a commodity forward curve for forecasting the price. The
future price quote is not used in pricing when the FUTURE_FROM_QUOTE pricing
parameter is set to false.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade to multiple books using Back Office > Allocate

» You can terminate the trade using Back Office > Terminate

» You can liquidate the trade manually using Back Office > Manual Liquidation

» You can expire futures by choosing Trade Lifecycle > Expiration & Exercise > Future
Expiry from Calypso Navigator, or the FUTURE_POSITION_EXPIRY scheduled task

» You can compute margin calls on the clearing accounts in real-time or in batch mode –
Refer to Calypso Futures Documentation for details
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25.1 Sample Future Commodity Trade

» Choose Help > Trade Help for complete details.
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25.2 Sample Asian Future Commodity Trade

The current value (PRICE) of the future is the average of both the known and unknown fixings.

The NPV of the trade is: NPV = (Current Value – Unit Price) * Notional.

Click Asian Fixings to view the fixing details.
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25.3 Future Contract Display - Time Zone
This section describes how the future contract is displayed in the trade window according to the time zone selected.

The Future trade window displays the first available contract based on the trade date defined in the Future trade
window, and the Last Trading Date defined in the future contract. The contract display uses the following logic:

» The TradeDate of the Future trade is based on the TimeZone defined in the Locale window. From Calypso
Navigator, choose Configuration > Definitions > Locale Configuration.

» It converts the TradeDate to the TimeZone defined in FutureContract window, and then compares it to the
LastTradingDate of the Future.

» Choose Help > Trade Help for complete details
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26. Capturing Electricity Future Trades

Electricity Future Quick Reference

When you open a Future worksheet, the Trade panel is selected by default.

Conf igu ra t ion
» Define the exchange for the commodity trades by choosing Configuration > Legal Data

>Entities from Calypso Navigator

» Define the holiday by choosing Configuration > Definitions > Date Rule Definitions
from Calypso Navigator

» Define date rules by choosing Configuration > Definitions > Date Rule Definitions from
Calypso Navigator

» Define the commodity product by choosing Configurations > Commodities >
Commodities from Calypso Navigator

» Define the future contracts by choosing Configuration > Listed Derivatives > Future
Contracts from Calypso Navigator

See Defining Future Contracts for details.

» Define the commodity reset definition by choosing Configuration > Commodities>
Commodity Reset from Calypso Navigator

» Define the FX rate definition as needed by choosing Configuration > Foreign Exchange
FX Rate Definitions from Calypso Navigator

» Define the period distributions using by choosing Configuration > Commodities >
Period Distribution from Calypso Navigator

» Define the intraday policy by choosing Configuration > Commodities > Intraday
Configuration from Calypso Navigator

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable. Or, you can enter the trade fields
directly.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Nasdaq Calypso
Commodities Trading / Version 18



Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description appears in the title bar of the trade worksheet and a trade id will be
assigned to the trade. The trade status will be modified according to the workflow
configuration.

Pr ic ing A Trade
» An electricity derivative trade requires the following market data: a zero curve for

discounting the cash flows, a commodity electricity hypersurface and electricity quotes.

Note that a cross-currency trade also requires an FX curve, an FX rate and an FX reset.

For Natural Gas futures, you need a forward curve generated using the CommodityNG
algorythm.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» Allocate the trade to multiple books using Back Office > Allocate.

» Terminate the trade using Back Office > Terminate

» Liquidate the trade manually using Back Office > Manual Liquidation

» You can expire futures by choosing Trade Lifecycle > Expiration & Exercise > Future
Expiry from Calypso Navigator. Or you may use the FUTURE_EXPIRY scheduled task.

» You can compute margin calls on the clearing accounts in real-time or in batch mode.
Refer to the Calypso Futures User Guide for details.

Sample Electricity Future Trade
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27. Capturing Commodity Listed Future
Option Trades
Choose Trade > Commodities > Listed Future Options to open the Future Option worksheet, from Calypso Navigator
or from the Calypso Workstation.

Future Option Commodity Quick Reference

When you open a Future Option worksheet, the Trade panel is selected by default.

[NOTE: The trade counterparty must be a clearer, so you must have defined a legal entity of
role Clearer]

Conf igu ra t ion
» Define the exchange where the commodity trades by choosing Configuration > Legal

Data > Entities from Calypso Navigator

» Define the holiday calendar by choosing Configuration > Definitions > Calendar
Definitions from Calypso Navigator

» Define date rules by choosing Configuration > Definitions > Date Rule Definitions from
Calypso Navigator

» Define the commodity product by choosing Configuration > Commodities >
Commodities from Calypso Navigator

» Define the future option contracts by choosing Configuration > Listed Derivatives >
Future Contracts Options from Calypso Navigator

See Commodity Future Options Setup for details.

Ente r ing Trade Deta i l s
» You can select a template from the Template field to populate the worksheet with

default values. Then modify the fields as applicable.

Or you can enter the trade fields directly. They are described below, see Field
Description.

Note that the Trade Date is entered in the Details panel.

» Proceed to the other panels as applicable.

Sav ing a Trade
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» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As
New.

A description will appear in the title bar of the trade worksheet, a trade id will be
assigned to the trade, and the status of the trade will be modified according to the
workflow configuration.

Pr ic ing a Trade
» A future option commodity trade requires the following market data: a zero curve for

discounting the cash flows, a commodity forward curve for forecasting the price, a
COMMODITY volatility surface.

The future price quote is not used in pricing when the FUTURE_FROM_QUOTE pricing
parameter is set to false.

» You can choose Pricing Env > Check to check if all required pricing data are available
in the Pricing Environment.

» Click Price to price the trade.

Trade L i fecyc le
» You can allocate the trade by choosing Back Office > Allocate

» You can terminate the trade using Back Office > Terminate

» You can liquidate the trade manually using Back Office > Manual Liquidation

» You can exercise future options by choosing Trade Lifecycle > Expiration & Exercise >
Future Option/ETO Exercise

» You can compute margin calls on the clearing accounts in real-time or in batch mode –
Refer to Calypso Futures Documentation for details

Sample Future Option Commodity Trade
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» Choose Help > Trade Help for complete details.
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28. Commodity Certificate Management
A Commodity Certificate is a document issued by a storage owner to identify the owner of a commodity in their
storage facility. It also contains information about the commodity such as the type of commodity, the quality and the
location and storage costs. These certificates can be bought and sold on the open market thereby transferring
ownership of the physical commodity by the transfer of the certificate.

The Certificate Management window is used to split, merge and amend certificates. To display this window, from
Calypso Navigator, select Configuration > Commodities > Commodity Certificate Management.

» Click the Refresh Certificates button to display certificates in your inventory as of the date displayed. Certificates
entered after this date will not appear. You may click in this field and enter whatever date you desire.

» You are able to filter your display further with the Filters area by selecting a Commodity, Location or Originating
Book for the certificates that you would like to display. Entering filter information is not required in order to display
certificates in this window.

» You may Amend, Merge and Split any of the certificates in the top portion of the window.

 Ⓘ Note: For certificates to populate in this window, Back Office Transfer status for certificates must be
SETTLED and the following engines need to be running: Transfer, Inventory and Liquidation.

28.1 Spl itt ing Cert if icates
To split a certificate, select the certificate in the top portion of the window and click the Split radio button.
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Enter the number of certificates into which you would like to split the selected certificate and the Book in which you
would like the new certificates

placed. Click Apply.

The new certificates appear below and you can then enter the appropriate information and details and click Save.
After you click Save, the new certificates move to the top of the screen.
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Newly created certificates are automatically settled.

28.2 Merging Cert if icates
To merge certificates, select the certificates you would like to merge in the top portion of the window by holding down
the Ctrl button on your keyboard and select either the Merge All or Merge to Lot radio button.

Merge to Lot allows you to merge multiple certificates into a specific lot size. When you select this option, select the
option the window displays a field where you can enter the lot size. Quantity above the lot size appears in a separate
certificate in the table below.

Enter the details to merge the certificates, and click Apply. The newly created certificates appear below. Edit the
certificate details as needed and click Save. They will then move to the top portion of the window.
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Merge Allmerges the selected certificates into one new one.

 Ⓘ Note: You must click Save at the bottom of the window after performing any changes or the amendments or
newly created certificates will not be saved.

28.3 Cert if icate Audit
You are able to right-click on any certificate in the Certificate Management window and display audit information for
that certificate.
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