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The nostro management capability allows the treasurer and settlements department to
understand current and future cash requirements, thereby minimizing costs and maximizing
profits by reducing payment defaults. The module provides the following functionality:
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l Account maintenance for an Agent with a Processing Organization
l Standard Settlement Instruction maintenance
l Account Statement maintenance and generation
l Review and authorization of cash requirements (using the Inventory Position report),
and capture of appropriate funding trades

l Automated generation of cash movements (principal exchanges, interest, management
fees, upfront fees, termination fees, collateral, etc.)

l Payment default monitoring
l Automated cash sweeping between accounts
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1. Overview
The nostro management capability is based on SETTLE accounts. A SETTLE account is associated with the agent that
settles the trades of a processing organization.

Inventory positions are calculated by the Inventory engine based on transfers of cash and securities into SETTLE
accounts. They can be monitored through the Inventory Position report which computes funding requirements over a
user-defined period. Multiple types of positions are computed by the Inventory engine and viewed from the Inventory
Position report.

Each position is calculated by trade date and by settlement date.

Account statement events are generated by the scheduled task ACCOUNT_STATEMENT based on inventory
positions, and account statement configurations. The Message engine subscribes to account statements events and
generates account statement messages based on statement message configurations.

Account interest trades (interest bearing trades) are generated by the ACCOUNT_INTEREST scheduled task based
on inventory positions and interest bearing rules.

Account billing events are generated by the scheduled task ACCOUNT_BILLING based on inventory positions and
account billing configurations. The Billing engine subscribes to account billing events to generate account
management fees (billing trades) based on billing grids and fee billing rules.

Billing trades and interest bearing trades are generated on the funding book of the processing organization.
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2. Configuration Requirements

2.1 Processing Organizat ion Setup
Billing trades and Interest Bearing trades are generated on the funding book of the processing organization.

The funding book is set on the legal entity attribute "FUNDING BOOK".

From the Legal Entity window, load the processing organization, and click Attributes.

» Select the attribute "FUNDING BOOK" and enter the book name in the Value field. Then click Save.

If the attribute does not exist, click ... next to the Attribute Type field and add it. Note that attribute types and
values are case sensitive.

2.2 Sett le Account Setup
A settle account is associated with the agent that settles the trades of the processing organization. You need to
associate a settle account with each agent.

From the Legal Entity window, load an agent, click Account, and select the Account panel.

Nasdaq Calypso
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» Enter the account name, and select the type SETTLE.

» Enter the Processing Organization, the Legal Entity (the agent), the role Agent, and select the currency.

The processing organization identifies the owner of the account, and the legal entity identifies the holder of
the account.

Please note that for a SETTLE account, you must specify a currency (USD in this example), and the role of the
holder (Agent in this example).

» You can also set the funding book at the account level in the account property "FUNDING BOOK". It takes
precedence over the funding book set at the Processing Org attributes level.

» Save this account.

» You can choose Help > Account configuration for details.

2.3 Sett lement and Del ivery Instructions (SDIs)
The link between a trade and a settle account is done through the SDIs of the processing organization.

In this example, SDIs are specified for the processing organization PO through the agent AGENT.

From the Calypso Navigator, navigate to Configuration > Legal Data > Entities, open the Legal Entity window and
load PO. Then click SDI’s, and select the Edit panel to enter the SDI details.
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» Select the role ProcessingOrg, and select the processing organization from the Beneficiary field.

» Select the settlement method from the Method field.

» If you want the SDIs to be automatically assigned to trades, check the Preferred checkbox.

» Select all other criteria as needed.

» In the Agent panel, click ... to select an agent in the code field.

» In the A/C field, enter the account number of the processing organization at the agent.

» In the GL A/C field, click ... to select the settle account that you have previously created (the agent’s account at
the processing organization).

» Save the SDIs.
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» You can find details on how to setup SDIs in the Calypso Settlements documentation .

At this point, if you enter trades using these SDIs, the inventory position of account AGENT will be populated.

2.4 Workflow
You need to modify the transfer workflow so that once a statement is created, the transfers that were taken into
account should not be amendable or cancelable.

» Thus, a workflow rule can be added on the transitions for the CANCEL and AMEND actions in order to forbid any
modifications on transfers: CheckStatementFlag. A message will alert the user when trying to apply those actions.

» Another solution is to reverse the initial transfer in case of update or cancel. The engine parameter XFER_USE_
REVERSE must be set to true using Utilities > Maintenance > Monitoring > Engine Thread from the Calypso
Navigator.

The same condition applies in the case of back valued trades. The Real Settle date should be greater than the last
Statement run date.

» In this case, the workflow rule CheckSettleDate can be set on all transitions for which the resulting status is
SETTLED.

» Make sure that the CheckStatementFlag is in the "mandatoryTransferRule" domain.

» Make sure that the Transfer engine uses the XFER_USE_REVERSE logic (engine parameter XFER_USE_REVERSE
set to true using Utilities > Maintenance > Monitoring > Engine Thread from the Calypso Navigator.
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3. Generating Inventory Positions
Inventory positions are computed by the Inventory engine based on transfers of cash and securities. They can be
monitored through the Inventory Position report which reports funding requirements over a user-defined period.

Inventory Position Flow

3.1 Inventory Engine Configurat ion
The Inventory engine is configured in the Engine Manager of Web Admin: event subscription and engine parameters.

The Inventory engine can subscribe to the following events:

• PSEventTransfer

• PSEventProcessTransfer

The Inventory engine uses the following engine filter:

• InventoryEventFilter. It only accepts known transfers related to a processing organization.

The behavior of the Inventory engine may be modified with the following engine parameters and environment
properties.

Nasdaq Calypso
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If a parameter is not available for setup, you can register it in the "engineParam" domain.

Environment properties are specified in your Environment.

Parameters and Properties Description
EXCLUDE_STATUS Engine Parameter

Comma-separated list of status codes that are included in the "failed position".

INIT_DATE No longer used as of version 14.1.

INV_MAX_POSITION Engine Parameter
Number of positions that will be kept in memory by the Inventory engine. For
example, a value of 10000 will allow a maximum of 10000 cash positions and 10000
security positions to be kept in the Inventory Engine memory. The default value of 0
means no limit.

INVENTORY_LOAD_TRADE Environment Property
True or False. When false, trades are not loaded in the inventory engine. Default is
True.

MAX_BATCH_EVENT Engine Parameter
Maximum number of persistent events loaded at one time by an engine in batch
mode. The engine will load events in MAX_BATCH_EVENT chunks until all events are
processed. Persistent events received after MAX_QUEUE_SIZE is reached will be
processed in batch mode.

Allows controlling engine memory usage, therefore improving the performance.

MAX_QUEUE_SIZE Engine Parameter
Maximum number of events buffered on an engine event queue.

When this number is exceeded, real time events are discarded and the engine
restarts based on the restart timer (TIMEOUT_RESTART), in order to process the
unprocessed persistent events using batch mode. This parameter can be useful for
controlling the engine’s memory usage. If not set, the default value for this
parameter is no limit on queue size.

Allows controlling engine memory usage, therefore improving the performance.

ORACLE12_BATCH_MODE Environment Property
True or false. Default is true.

When true, and database is Oracle 12 (or greater), the saving of inventory positions
is optimized by using batch mode for events processing and engine_process table.

POSITION_FILTER Engine Parameter
If value equals CASH the inventory engine calculates only cash positions, if value
equals SECURITY it calculates only security positions, otherwise it calculates both.

Default is empty.
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Parameters and Properties Description
PricingEnv Engine Parameter

Pricing environment used by the engine. If not set, the default Pricing Environment
of the user running the engine will be used.

PROJECTED_DAYS No longer used as of version 14.1.

TIMEOUT_RESTART Engine Parameter
Number of seconds to wait before an engine restarts after MAX_QUEUE_SIZE has
been reached. The default value is 3600 seconds (1 hour).

TWO_PHASE_ENGINE_
NUMBER_OF_RETRY

Environment Property
Number of times the engine will retry to process the list of events in the
TwoPhaseEngine used by Inventory engine, Margin Call Position engine and Position
engine. Default value is 3.

3.2 Start ing the Inventory Engine
The Inventory engine can be started from the Engine Manager in Web Admin.

The Inventory engine publishes the following events:

• PSEventInventoryCashPosition

• PSEventInventorySecurityPosition

Please refer to Calypso Web Admin documentation for complete details.

3.2 .1 Inventory Pos i t ions Def in i t ion
Inventory positions are computed based on transfers of cash and securities.

Multiple types of positions are computed by the inventory engine and viewed from the Inventory Position report.

Actual Position
The actual position contains transfers that have settled.

Bank Confirmed Position
The "bank confirmed" position is the cash position confirmed by bank statements MT940/950.

Failed Position
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The failed position contains transfers for which the settlement has failed. Status codes corresponding to failed
transfers should be set in the domain "transferFailedStatus".

You can also use domains "transferSettledStatus" and “transferCashSettledStatus” (for cash transfers only) as
described below.

If domain “transferFailedStatus” is not empty, then the failed position is determined based on the status codes in that
domain. The other status codes populate the actual position.

If domain “transferFailedStatus” is empty, the system considers domain “transferCashSettledStatus” instead.

• If domain “transferCashSettledStatus” is not empty, the status codes in that domain populate the actual cash
position, and the status codes in domain “transferSettledStatus” populate the actual security position. The other
status codes populate the failed position.

• If domain “transferCashSettledStatus” is empty, the status codes in domain “transferSettledStatus” populate the
actual cash and security positions. The other status codes populate the failed position.

Note that the transfer status codes set in the engine parameter EXCLUDE_STATUS are also added to the failed
position.

Theoretical Position
The theoretical position contains all transfers regardless of their status (except status codes set in engine parameter
EXCLUDE_STATUS).

Forecast Position
The forecast position shows the position of forecasted unknown transfers.

Expected Position
The expected position shows the positions based on the Available Date of the transfers when not settled, else it is
based on the Real Settle Date. However, if Available Date < Settle Date, the expected position is still based on
Available Date when the transfer is settled.

By default, the Available Date is set to the Trade Date.

You can set it to Value Date + number of days using domain "XferAvailableDate". Add a value that gives the number of
days for a given static data filter in the following way: “<Number of Days>.<Static Data Filter>”.

For example: “1.MyEquityFilter”, and “2.MyBondFilter”.

If the transfer is accepted by MyEquityFilter, "1" business day is added to the Value Date using the Book holidays of
the transfer to compute the Available Date.

For MyBondFilter, it would be 2 business days.

You can also add the number of days to the Trade Date, if you set the Comment to "TradeDate".

For example, if you set: Value = "1.MyFilter" and Comment = "TradeDate", then the Available Date is Trade Date + 1
business day.
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 Ⓘ [NOTE: As soon as this domain contains 1 value, the Available Date defaults to the Value Date. Make sure
that you configure ALL your transfers accordingly]

You can add Value = SetDefault to the "XferAvailableDate" domain.

If Comment = true, the XferAvailableDate is defaulted based on the configuration when a transfer is modified (default
behavior).

If Comment = false, the XferAvailableDate is not defaulted when a transfer is modified.

Statement Position
The statement position shows back-value movements and back-value failed movements (transfer value date is
before transfer settlement date).

See Back-dated Movements for setup details.

Position Calculation
Each position is calculated by book / agent / agent account, and for the following dates:

• trade date

• settlement date

• available date (for client positions only). Client positions are calculated on transfers with a given legal entity, for
which the processing org and the agent are the same.

• settlement frozen date, allows simulating a snapshot

Settlement Frozen Date for setup details

All inventory positions to be monitored by the Inventory engine are stored in the domain “InventoryPositions” in the
form “<position class>-<position type>-<position date>”. For example, “INTERNAL-ACTUAL-SETTLE”.

3.2 .2 Process ing Transfers
If the transfer is a new transfer or is in CANCELED status, the THEORETICAL positions by SETTLE date and TRADE
date are updated.

If the transfer has a status of SETTLED or the transfer is in CANCELED status and was previously in SETTLED status,
the ACTUAL position by SETTLE date is updated.

You can define the list of transfer status codes to be considered as CANCELED in the domain
"transferCanceledStatus".

If the transfer is in status FAILED or is in another status but was previously in a FAILED status (or any status in the
"transferFailedStatus" domain), the FAILED position by SETTLE date is updated.
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As described above, you can also define a domain "transferSettledStatus" that contains all settled status codes, and
remove the domain "transferFailedStatus". All status codes not in "transferSettledStatus" will be considered not
settled.

The failed position is updated by checking the value date and the settle date of the transfers. To update the settle
date on a failed transfer, you can run the scheduled task FAILED_TRANSFERS and it will modify the settle date of
failed transfers to the following day.

If a failed transfer is later settled, it will then appear in the ACTUAL position.

3.2 .3 Updat ing Posi t ions
The positions corresponding to the SETTLE DATE or TRADE DATE of the transfer are retrieved.

If no position exists for the given transfer, a new position is created by duplicating the latest known position before
that date. If no position existed before, a new position is created.

If the transfer is in CANCELED status (or any status in the domain "transferCanceledStatus"), amounts are removed
from the positions. Otherwise, the amounts are added to the positions.

When the positions are updated, all future positions which may depend on the updated position are updated.

3.2 .4 Comput ing Custom Posi t ions
In addition to computing positions by Book / Agent / Agent Account, you can add custom criteria to compute and
display the positions. For example, Book / Agent / Agent Account / Product Type.

For this, you need to define the custom criteria using a Netting Config that contains the IsAggregation criteria. From
the Calypso Navigator, navigate to Configuration > Settlements > Netting.

Sample setup for computing positions by Product Type: You need to define a netting config with keys "IsAggregation"
and "ProductType".
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Then add the netting config to the domain "InventoryAggregations".

Then restart the Inventory engine.

In the Inventory Position report, select the aggregation type “Agg. Config = Product Type” (the netting config you
have created) to view the positions by product type.

You can also configure aggregation related columns using Data > Configure Columns.

You can define which positions are computed for a given aggregation using the domain
“InventoryPositions<aggregation name>” , for example “InventoryPositionsProduct Type”. Then you can define the
positions in the form “<position class>-<position type>-<position date>”. For example, “INTERNAL-ACTUAL-
SETTLE”.

Create a domain for the "InventoryPositions<aggregation name>", then add the positions you want to compute as
values.
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In that case, it will only compute that position. If the "<aggregation name>" domain is not defined, it will compute all
positions.

3.2 .5 Back-dated Movements
In order to monitor back-value movements in statements, a STATEMENT position has been added. You need to add
“INTERNAL-STATEMENT-SETTLE” to the domain “InventoryPositions”.

The domain "transferStatementStatus" has also been added – It should contain the transfer status codes that
populate the position “INTERNAL-STATEMENT-SETTLE”: FAILED – SETTLED – VERIFIED.

The environment property XFER_BV_REAL_SETTLE_DATE must be set to true.

The statement account can be triggered for this type of position:

The following rule must be added to the transfer workflow:
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In case the Statement Config is NOT based on Payment, iterator MT950NonPaymentIterator should be used instead
of MT950Itereator in the MT950 XML template - MT950NonPaymentIterator iterates over the netted transfers rather
than the Underlying Transfer.

3.2 .6 Sett lement Frozen Date
In order to activate this position you need to:

• Add INTERNAL-THEORETICAL-SETTLE(FROZEN) to the domain “InventoryPositions”.

• Add the rule CheckAllowCancel to the domain “mandatoryTransferRule”.

The rule ensures that the transfer is not UPDATED or ends up in a Canceled status once it is part of the Frozen
position. It is possible to CANCEL a future transfer up to the value date of the transfer.

This position is using the transfer settlement amount and the position date as follows:

• Settlement Frozen Date = Booking Date of the transfer when Booking Date > Value Date

• Settlement Frozen Date = Value date of the transfer otherwise.

3.3 Inventory Snapshots
The INVENTORY_SNAPSHOT scheduled task allows freezing an inventory position at any time. You can run the
Inventory Position report and BO Position Reconciliation report on inventory snapshots.
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Please refer to Calypso Scheduled Tasks documentation for details.

3.4 Inventory Posit ion Check
This function allows checking the inventory position before accepting a trade. The inventory position is checked by
the LifeCycle engine based on Inventory Check configurations. The Inventory Check configuration allows selecting
the workflow transition where the check should be performed and the nature of the check. If the Inventory Check
configuration is satisfied, the action of the selected workflow transition is applied, otherwise the action is not applied
and the LifeCycle engine generates an EX_INVENTORY_CHECK exception task.

3.4.1 Setup Requi rements

Domains
Domain name = lifeCycleEntityType, Value = InventoryCheck

Domain name = exceptionType, Value = INVENTORY_CHECK

Domain name = eventType, Value = EX_INVENTORY_CHECK, Comment = "Exception generated by Inventory Check"

Domain name = groupStaticDataFilter, value = BOPosition

LifeCycle Engine
Please make sure you have started the LifeCycle engine as it is not started by default.

The LifeCycle engine must be subscribing to PSEventTrade and use the event filter LifeCycleEngineEventFilter.
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3.4.2 Inventory Check Conf igurat ion
Bring up the Inventory Check Configuration window using menu action
refdata.inventory.InventoryCheckConfigWindow.

» Click New to create a configuration and enter the fields described below as needed.

» Click Save to save the configuration.

Fields Description

Config ID Given by the system upon saving.

Is Security
Check

Check to check security positions, or clear to check cash positions.

Treat mir-
ror as one

Check to check that both the trade and the mirror trade (if any) satisfy the configuration, or clear to
ignore the mirror trade (if any).

Task Com-
ment

Enter a comment as needed.

SDFilter Mandatory.

Select a static data filter to restrict the trades to which the check is applied.

Example: For Bond Buy trades you want to check that the Cash Position is sufficient, and for Bond Sell
trades you want to check that the Security Position is sufficient.

Workflow Mandatory.
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Fields Description

Transition Select the Trade workflow transition to which the check applies. If the configuration is satisfied, the
action of the selected transition is applied, otherwise the action is not applied and an EX_INVENTORY_
CHECK exception task is generated.

Inventory
Template

Mandatory.

Select an Inventory Position report template to determine which position needs to be checked.

The system only uses the template to get the class/type/date, the movement type and the aggregation.
Please make sure that the Inventory Aggregation in your template if applicable, matches the other
criteria in the Inventory Check Configuration.

Operator Mandatory.

Select an operator to check the position. The trade quantity (for security positions) / settlement amount
(for cash positions) is added to / subtracted from the position (depending on the trade direction) and
compared to 0 using the operator.

Examples:

• If you select Greater (>), the check is Trade Quantity/Settlement Amount +/- Position > 0

• If you select Less or Equal (<=), the check is Trade Quantity/Settlement Amount +/- Position <= 0

Account
check

Mandatory.

Select the aggregation level to be checked.

Make sure that the selection matches the criteria of the Inventory Position report template.

• Book/Agent/Account - Check is done at Book/Agent/Account level.

• Book - Check is done at book level.

• GL Account (from XferRule) - Check is done at Agent/Account level on PO Accounts

• ClientAccount - Check is done at Agent/Account level on trades with trade keyword ClientAccount

• Payer Pledge Account - Check is done at Agent/Account level. When selected, for margin calls and
simple transfers with POPledgeSDI non null or PledgeSDI=true:

– If the transfer rule direction is Pay, check the PO GL Account.

– If the transfer rule direction is Receive, check the Cpty Intermediary Account.

Reference
Date check

Select SettleDate or TradeDate - The date on the trade to use as a reference date for the inventory
check.

Default is SettleDate.

Period
check

Select 0D, 1D, 2D, TradeDuration.

This defines the Period End Date to check the position.

Default is TradeDuration.

The system checks positions from Period Start Date until Period End Date with:
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Fields Description

Period Start Date = Reference Date check

Period End Date = Trade End Date if Period check=TradeDuration, Period Start Date + 0D/1D/2D Cal or
Bus if Period check=xD

For Repo/SecLending trades, you need to set Period check = 0D so that securities are not checked after
substitution.

For an OPEN Repo, Trade End Date = Current date + Notice days.

Is Bus. Day Only applies if Period check is 0D, 1D or 2D.

Check to indicate that the days are business days, or calendars otherwise.

Holidays Only applies if Is Bus. Day is checked.

Holiday calendar to determine the business days.

3.5 Custom Posit ion Type
You can setup the computation of a custom position based on a custom transfer attribute. Custom position types can
be defined for Internal positions and Client positions.

3.5.1 Conf igurat ion Requi rements

Example with "Disbursed" position.

In the domain "cashInventoryCustomPositionType", add Value = Disbursed.

In the domain "InventoryCashBucketFactory", add Value = CustomBucketInventoryCash.

In the domain "cashInventoryCustomPositionType.Disbursed", add the transfer status codes eligible for this position:

Value = ALLOCATED

Value = SETTLED

In the domain cashInventoryCustomBucket, add the buckets. You can define up to 10 buckets (from Bucket0 to
Bucket9).

Example:

Value = Bucket0

Value = Bucket1
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etc.

In the domain "cashInventoryCustomBucket.Bucket#", define the actual name of the buckets:

Example:

Domain = cashInventoryCustomBucket.Bucket0

Value = Capital Retain

Domain = cashInventoryCustomBucket.Bucket1

Value = Treasury

etc.

In order for the Inventory engine to populate those buckets, the transfer attribute "Custom Bucket" must contain the
bucket name.

Example: Custom Bucket = Capital Retain

You can add "Custom Bucket" to the "XferAttributes.UPDATE_XFER_ATTR.Editable" domain so that you can set the
value of the attribute when applying action UPDATE_XFER_ATTR to a transfer.

This way, the Inventory engine will create a bucket named "Capital Retain" for the Disbursed position type and the
transfers with Custom Bucket = Capital Retain.

3.5.2 Inventory Report
Select the cash movement types: Balance <bucket name> and Movement <bucket name> as needed.

Example:
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4. Viewing Inventory Positions
From the Calypso Navigator, navigate to Reports > Nostro/Custodian Positions > Inventory Position (menu action
reporting.ReportWindow$BOPosition) to review the inventory positions.

You can display real-time Inventory positions computed by the Inventory engine (nostro positions), or inventory
snapshots generated by the INVENTORY_SNAPSHOT scheduled task.

• Transfer and Inventory engines should be running to compute inventory positions.

• Liquidation engine should be running to perform Positions reconciliation.

• Margin Call engine should be running for collateral positions.

Refer to Calypso Cash Management documentation for details on generating inventory positions.

Refer to Calypso Collateral Management documentation for information on generating margin call positions.

Menus common to all reports are described under Help > Menu Items.

4.1 Report Example
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Partial picture of Inventory Position report

The report shows two panels: Cash for cash positions, and Security for security positions.

Use one of the following methods to run the report:

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Enter selection criteria at the top of the report window and click to load both cash and security positions. The
selection criteria are described below.

When you select the Cash panel, you can view selection criteria specific to cash positions only.

When you select the Security panel, you can view selection criteria specific to security positions only.

You can also click in each panel to only load the corresponding positions.

You can configure the columns of the report. See Help > Menu Items for details.

» You can also choose Report > Load Template, select a template then click Load.

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Criteria Details

Criteria Description
Class

Type

Date

Click to add a combination of position class, type, and date.

You can select a combination of Internal, External and SnapShot positions (see Snapshot below
for details on selecting snapshots).

You can also select Client positions or Margin_Call positions. These positions cannot be
combined with other positions as the display fields are not compatible.

Position Class
The following values are available:

• External – View positions imported into the system from external sources.
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Criteria Description
• Internal – View positions calculated by the Inventory Engine.

• Client – View client positions calculated by the Inventory Engine.

• Margin_Call – View margin call positions calculated by the Margin Call Engine.

• SnapShot – View positions from an inventory snapshot, provided you have selected an
inventory snapshot.

Position Type
Click ... to select a position type. The following values are available:

• Actual – View the position of settled transfers, based on the real settlement date and real
settlement amount.

• Bank Confirmed – Cash position confirmed by bank statements MT940/MT950.

• Expected – View the positions based on the Available Date of the transfers when not
settled, else it is based on the Real Settle Date.

Refer to Calypso Cash Management documentation for details on the Available Date.

• Forecast – View the forecasted position of unknown transfers.

• Theoretical – View the positions of any transfers, based on the expected settlement date
and expected settlement amount.

• Not settled – View the positions of unsettled /failed transfers.

Refer to Calypso Cash Management documentation for details on failed transfers.

You can set the environment property KEEP_OPPOSITE_XFER_FROM_INVENTORY_DETAIL
to true to display both legs of a repo when both the start and end legs are failed. Only one
failed transfer is displayed otherwise.

Default is False.

• Statement – View the position of back-value movements and back-value failed movements
(transfer value date is before transfer settlement date).

• Rolled_Interest – Only applies to margin call interests rolled into "Margin_Call" positions.

Refer to Collateral Management documentation for details.

Position Date
Select a position date. The following values are available:

• Trade – To load the position by trade date.

• Settle – To load the position by settlement date.

• Available – To load the position by available date. The available date applies to client
positions only. It defaults to the trade date but can be customized.

Snapshot
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Criteria Description
To select an inventory snapshot:

1. Click . You will be prompted to select a snapshot generated by the scheduled task
INVENTORY_SNAPSHOT.

2. Then select the Type and Date of the snapshot.

Please refer to Calypso Scheduled Tasks documentation for details on generating inventory
snapshots.

Start Date Enter the start date from which you want to see the positions. You may input a date in the past
or in the future.

End Date Enter the end date for the positions.

When holiday calendars are selected under Data > Configure Holidays:

• If Data > Calendar > Calendar is checked, the dates that correspond to business days
appear with a red background in the report results

• If Data > Calendar > Business is checked, the dates that correspond to business days are
removed from the report results

Use Tenor Check “Use Tenor” to use a tenor instead of an end date. The Tenors field will appear.
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Criteria Description
Click ... to select tenors for which you want to see the positions.

You can now display the tenors as columns names by choosing Data > Tenors > Display
columns by tenor name.

You can also choose the following menu items:

• Data > Tenors > Roll Tenor to next date – When not selected and Calendar > Business is
selected, the Tenors that fall on business days are not shown. Example - If Tenor 3D is a
business day, the report will show 1D, 2D, 4D, etc.

When selected and Calendar > Business is selected, the Tenors are rolled and shown as
business days. Example - If Tenor 3D is a business day, the report will show 1D, 2D, 3D
(which represents 3 business days), 4D (which represents 4 business days), etc.

• Data > Tenors > End Of – This only applies to W, M and Y tenors for end of the week, end of
the month, end of the year. When not selected, 1W is Start Date + 7 calendar or business
days depending on Data > Calendar. Example – Sept 27 + 1W = Oct 4 in Calendar days and
Oct 6 in Business days.

When selected, 1W is the end of the week following the start date depending on Data >
Calendar – Example Sept 27 + 1W = Oct 3 in Calendar days and Oct 1 in Business days.

Template
Description

Displays the template description if a template has been loaded, and a template description is
set on the template. Template descriptions can be set using Configuration > Reporting & Risk
> Report Templates from the Calypso Navigator.

Books Click ... to select a set of books as needed. You can also enter a comma-separated list of books.

 Ⓘ [NOTE: Book names are case-sensitive]

ProcessingOrg Click ... to select a set of processing organizations as needed. You can also enter a comma-
separated list of processing organizations.

 Ⓘ [NOTE: Processing organization codes are case-sensitive]

Include Child POs When checked, the positions of the child POs are included in the report, if any, when a PO is
selected.

Aggregation Select the aggregation level of the positions: Book/Agent/Account, Agent/Account, Agent,
Book, Client, ProcessingOrg, Global, or Book/Agent.

Currencies

Securities

The Currencies label on the Cash panel switches to Securities when you select the Security
panel.

Click ... to select a set of currencies for cash positions, or click ... to select a set of securities for
security positions.

Account Template You can select an Account Selector template as needed. When selected, the underlying
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Criteria Description
accounts are loaded.

You can click ... next to the drop down list to define Account Selector templates. It opens the
Account Selector Templates window where you can manage the templates.

Security Template On the Security panel, you can select a type of security template to be loaded:

• Bond – To select a Bond Report template.

• Equity – To select an Equity Report template.

• SecurityFilter – To create a security filter on-the-fly.

See Securities Filter for details.

• Warrant – To select a Warrant Report template.

Sec Code On the Security panel, you can select a security code and enter a value in the adjacent field to
select all securities with that security code value.

Include Issuances On the Security panel, you can check the "Include Issuances" checkbox to include issuance
trades.

SD Filter On the Security panel, you can select a static data filter to filter the securities that can be loaded
in the report.

Agent

Cpty Id

The Agent Id label switches to Cpty Id when the position class is set to Client or Margin_Call.

Click ... to select an agent / counterparty as applicable to view the positions for that agent /
counterparty only.

Account Id

Contract Id

The Account Id label switches to Contract Id when the position class is set to Margin_Call.

Click ... to select an account / contract as applicable to view the positions for that account /
contract only.

Agg. Config Select a custom aggregation config as needed.

You can then specify the individual criteria.

 Ⓘ [NOTE: You can only select a custom aggregation config if you have configured the
Inventory engine to compute custom positions – Refer to Calypso Inventory Engine
documentation for details]

Sample Inventory Position Report with Positions computed by Product Type
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Criteria Description

You can configure aggregation related columns using Data > Configure Columns.

Position Value This only applies to security positions.

Select a position display value. The following values are available:

• Quantity – The Security panel displays quantities.

• Nominal – The Security panel displays current nominal values (based on the pool factor if
any).

• Nominal (Unfactored) – The Security panel displays original nominal values.

You can select the default amount by setting ONE of the following environment properties to
true: INV_QUANTITY, INV_NOMINAL, or INV_NOMINAL_UNFACTORED.

Custom Filter You can select a custom filter for filtering inventory positions.

To create a custom filter, create a class named apps.reporting.<filter_name> that
implements the interface com.calypso.apps.reporting.BOPositionFilter. Register the
filter name in the BOPositionFilter domain.

Sample in calypsox.apps.reporting.SecurityFilter.

Display Only
Multiple Agent

Select this checkbox to display only those positions that are held at more than one Agent.

Explode Position This only applies to security positions.

If you have created custom movement types and balance types, you can view the details of the
computation by checking the Explode Position checkbox.

In this example, we choose to display “Collateralized Movements”, the created “parent”
movement type, and check the Explode Position checkbox so that the details of the
computation are shown.

Alternatively, you can display the "parent" movement type, like "Collateralized Movement", and
clear "Explode Position". Then you right-click the position and choose Show > Explode Position
to display the details of the position. The Explode Position report can use templates named
"BOExplode_<template name>".
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Criteria Description
Aggregate Agg.
Config

Check "Aggregate Agg. Config" to aggregate custom positions.

For example, you have defined custom positions by product type, and selected the
corresponding Aggregation Config.

On the Security panel, you want to see the positions by product type, and on the Cash panel,
you don't want to see the breakup by product type.

You can check "Aggregate Agg. Config" on the Cash panel to aggregate the custom positions.

Position Direction Select All, Shorts or Longs.

If you select Shorts, you can check “Offset Pos.” to only show short positions for which there is a
long position available that can offset the short position. In this case, both the short position and
potential offset position are shown.

In this example, you can transfer the position from agent AGENT to agent CEDEL to cover part
of the short position on agent CEDEL.

Cash / Sec The following values are available:

• Both – The report displays both cash and security positions.

• Cash – The report displays cash positions only.

• Security – The report displays security positions only.

Movement Type Select the movement types you want to display.

Cash Positions
For Cash, the following values are available:

• Balance— Running balances - The net of all position components - Total net position,
based on all transfers

• Available Balance— Balances + Overdraft Limit on the account

• Movements — Balance on the start and end dates, and the movements in between

• Callable Balance = Usable Balance = Balance

Security Positions
For securities, movement types are more detailed based on the type of collaterals.

• Balance – Total net security position, based on all transfers

• Balance Collateralized In – Position based on transfers representing Reverse Repos and
LONGMargin Call positions

Nasdaq Calypso
Nostro Management / Version 18



Criteria Description
• Balance Collateralized In NON CA – Position based on transfers representing Reverse Repos

• Balance Collateralized In NON Substitutable – Position based on transfers representing
Reverse Repos and LONGMargin Call positions, where the securities are designated on the
trade as NOT substitutable

• Balance Collateralized In Substitutable – Position based on transfers representing Reverse
Repos and LONGMargin Call positions, where the securities are designated on the trade as
substitutable

• Balance Collateralized Out – Position based on transfers representing Repos and SHORT
Margin Call positions

• Balance Collateralized Out NON CA – Position based on transfers representing Repos

• Balance Collateralized Out NON Substitutable – Position based on transfers representing
Repos and SHORT Margin Call positions, where the securities are designated on the trade
as NOT substitutable

• Balance Collateralized Out Substitutable – Position based on transfers representing Repos
and SHORT Margin Call positions, where the securities are designated on the trade as
substitutable

• Balance In NON Substitutable – Position based on transfers representing Reverse Repos,
Pledges (In), Security Borrows, and LONGMargin Call positions, where the securities are
designated on the trade as NON substitutable

• Balance In Substitutable – Position based on transfers representing Reverse Repos, Pledges
(In), Security Borrows, and LONGMargin Call positions, where the securities are designated
on the trade as substitutable

• Balance Margin Call – Position based on transfers representing Security Margin Calls except
Triparty Allocations

• Balance Margin Call Non Rehypotheticable – The portion of the Margin Call Balance that is
designated as not able to be re-hypothecated

• Balance Margin Call Rehypotheticable – The portion of the Margin Call Balance that is
designated as able to be re-hypothecated

 See Margin Call Contracts documentation for details on re-hypotheticable collateral.

The Margin Call Rehypotheticable balance types will only be computed if the value
MarginCallInventorySec is set in the "InventorySecBucketFactory" domain.

• Balance NON Substitutable – The portion of the Balance that is designated as NON
substitutable

• Balance Out NON Substitutable – Position based on transfers representing Repos, Pledges
(Out), Security Loans, and SHORT Margin Call positions, where the securities are
designated on the trade as NON substitutable

• Balance Out Substitutable – Position based on transfers representing Repos, Pledges (Out),
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Criteria Description
Security Loans, and SHORT Margin Call positions, where the securities are designated on
the trade as substitutable

• Balance PayToHoldIn – Position based on transfers representing Security Borrows Hold (In)
and Pay to Hold (In)

• Balance PayToHoldOut – Position based on transfers representing Security Loans Hold
(Out) and Pay to Hold (Out)

• Balance Pledge – Position based on transfers representing Pledges

• Balance PledgedIn – Position based on transfers representing Pledges (In)

• Balance PledgedIn NON Substitutable – Position based on transfers representing Pledges
(In), where the securities are designated on the trade as NON substitutable

• Balance PledgedIn Substitutable – Position based on transfers representing Pledges (In),
where the securities are designated on the trade as substitutable

• Balance PledgedOut – Position based on transfers representing Pledges (Out)

• Balance PledgedOut NON Substitutable – Position based on transfers representing Pledges
(Out), where the securities are designated on the trade as NON substitutable

• Balance PledgedOut Substitutable – Position based on transfers representing Pledges
(Out), where the securities are designated on the trade as substitutable

• Balance Repo Callable In – Position representing open Reverse Repo trades

• Balance Repo Callable Out – Position representing open Repo trades

• Balance Buy Sell Back – Position based on transfers representing BSB Reverse Repos

• Balance Sell Buy Back – Position based on transfers representing BSB Repos

• Balance Repo Triparty – Position based on transfers representing Triparty Repos (Repos
and Reverse Repos) and Triparty Allocations

• Balance Repo Triparty In – Position based on transfers representing Reverse Triparty Repos
and Triparty Allocations (In)

• Balance Repo Triparty Out – Position based on transfers representing Triparty Repos and
Triparty Allocations (Out)

• Balance RepoTrackingIn – Position based on transfers representing Repos in securities
designated as subject to Repo Tracking

• Balance RepoTrackingOut – Position based on transfers representing Reverse Repos in
securities designated as subject to Repo Tracking

• Balance SecLending Callable In – Position representing open Security Borrows

• Balance SecLending Callable Out – Position representing open Security Loans

• Balance SecurityBorrowed – Position based on transfers representing securities borrowed
through Sec Lending Borrow trades, excluding Hold (Out) and Pay to Hold (Out)
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Criteria Description
• Balance SecurityBorrowed Collateral – Position based on transfers representing the

collateral leg on Sec Lending Sec Vs Sec Borrow trades

• Balance SecurityBorrowed NON Substitutable – Position based on transfers representing
securities borrowed through Sec Lending Borrow trades, where the securities are
designated on the trade as NON substitutable

• Balance SecurityBorrowed Substitutable – Position based on transfers representing
securities borrowed through Sec Lending Borrow trades, where the securities are
designated on the trade as substitutable

• Balance SecurityLent – Position based on transfers representing securities borrowed
through Sec Lending Loan trades, excluding Hold (In) and Pay to Hold (In)

• Balance SecurityLent Collateral – Position based on transfers representing the collateral leg
on Sec Lending Sec Vs Sec Loan trades

• Balance SecurityLent NON Substitutable – Position based on transfers representing
securities borrowed through Sec Lending Loan trades, where the securities are designated
on the trade as NON substitutable

• Balance SecurityLent Substitutable – Position based on transfers representing securities
borrowed through Sec Lending Loan trades, where the securities are designated on the
trade as substitutable

• Balance Simple Transfer – Position based on transfers representing Simple Transfers

• Balance Substitutable – Total net position, based on ALL transfers, where the securities are
designated on the trade as substitutable

• Balance SecurityBorrowed Auto / Balance SecurityLent Auto – Balances from "autoloan" sec
lending trades created from the integration of MT535 messages.

Refer to Calypso Message Matching for details.

• Balance Trading – Net position resulting from BUY and Sell trades

• Balance Triparty Margin Call – Position based on transfers representing Security Margin
Calls from Triparty Allocations

• Balance Unavailable – Net position resulting from Unavailability Transfer trades

• Movements – All security transfers between the start and end dates

Same movement types as balance types for the actual transfers.

Callable (Open) Positions
The scheduled task PROCESS_CALLABLETRADE allow rolling callable trades every day.

Substitutable Positions
You also have the ability to identify whether the transfers that created the position are
substitutable or not.
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Criteria Description

In the example above, of the total of this Security taken in as Collateral (3,150,000) only
3,000,000 can be substituted out by the counterparty.

It is also possible to add custom movement types.

See Inventory Position - Process Menu for details.

Filter Zero Balance Select this checkbox to exclude dates from the report that have a zero balance.

Propagate to
Security

Propagate to Cash

When checked, which is the default behavior, the criteria saved in the template are the same for
both the Cash and Security panels.

When unchecked, both the criteria from the Security panel and the criteria from the Cash panel
are saved in the template.

Closing Bal. When checked, the following columns will be populated on the start date:

• Opening Balance – Balance carried the day before the start date

• Settled – Total movements on the start date

• Closing Balance – Sum of opening balance and settled on the start date

» Double-click on Opening Balance to show the trades that caused a movement on the
previous day.

» Double-click on Settled to show the trades that cause a movement on the start date.

» Double-click on Closing Balance to show the trades that cause a movement on the start
date (same as Settled).

Legal Ag. / Contract
Id

On the Security panel, you can select legal agreements and margin call contracts associated
with the trades (repo, security lending) to display corresponding information.

Filter Matured
Securities

On the Security panel, you can check "Filter Matured Securities" to exclude matured securities.

Display Past
Prepaid Transfers

Only applies to Statement positions.

On the Cash panel, you can check "Display Past Prepaid Transfers" to display transfers that
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Criteria Description
were paid before their settlement date.

For example, a transfer has a settlement date of 07/10/2014, and is paid on 07/09/2014. The
transfer attribute "InitSettleDate" is set to the original settlement date 07/10/2014, so that it can
be loaded in the Inventory Position on 07/10/2014 using this checkbox.

Pricing Env

Valuation Date

These selections will only appear if the column use_pricing_env = 1 in table report_win_def for
def_name = BOPosition – Contact your database administrator to set this up.

This allows converting cash positions into the base currency of the selected pricing
environment.

The base currency will appear next to the total amount if the FX quote is known, or an error will
be displayed otherwise. The menu item Process > Check FX Quotes allows checking FX quotes
only.

You need to configure grouping by Currency, and setup subtotals by Dates with the function
SumFX (you can add it to the domain “REPORT.Functions” if it is not available for selection).

4.1 .1 Dr i l l Down Disp lay Opt ion
When you right-click a position and choose the Showmenu, a number of drill down reports are available for selection.

You can view the selected drill-down report below the Inventory Position report, as shown in the example below.
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4.1 .2 Transfer Report Dr i l l Down
When drilling down to the transfer report from a position, you can select a transfer report template that starts with
“BOPosition”.

In particular, you can configure a transfer report that shows COLLATERAL transfers, and CollateralTrade columns to
view the underlying collaterals of a given position.

To drill-down to the transfer report, right-click a position, and choose Show > Transfer Report. The list of BOPosition
templates will be available for selection.

By default, you will only see the movements of the day for cash balances and security balances.

To see all movements, you need to add the balances for which you want to see all movements to the domains
“BOPosition.DrillDown.Cash.Balance.ShowAllMovements” for cash balances, and
“BOPosition.DrillDown.Securiy.Balance.ShowAllMovements” for security balances.

You can show archived transfers in the Transfers drill-down if the menu item Report > Include Archived Transfers to
Drilldown is checked.

4.1 .3 Navigat ing to Another Inventory Pos i t ion Report
To open another Inventory Position report based on an existing template, create an Inventory Position report template
that starts with “BOPosition”.

When you right-click a position, the template will be available for selection under Show > BOPosition Report.
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4.1 .4 Explod ing a Posi t ion
If you have created custom movement types and balance types, you can view the details of the computation by
exploding the position.

Right-click the position and choose Show > Explode Position to display the details of the position. The Explode
Position report can use templates named "BOExplode_<template name>".

4.1 .5 Interest Entr ies
In the cash panel, you can right-click a position and choose Show > Interest Entries to bring up the Interest Entries
window.

This will display in the Inventory Position Report what Interest will be capitalized to the client accounts on the next
payment date, and allow the Interest amounts to be broken down into the daily constituents.

This only applies if the cash account is configured for interest bearing.

4.1 .6 Aggregat ion Disp lay Example
To aggregate based on any column (book attribute for example), select the book attribute as a sort column and
column heading, then choose View > Set Table > Aggregation.

You can also check “Explode Position” and aggregate by Parent Balance to view the details of movement types that
you have created.

4.1 .7 Pos i t ions Aggregat ion
You can also aggregate positions based on any criteria using Data > Configure Aggregation.

Select the criteria you want to use to aggregate positions and the positions are aggregated accordingly.

Example:

With no aggregation - Multiple rows are shown for each currency per account, book, etc.
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With currency aggregation, only one row is shown per currency:

It does not show any details. Grouping by currency with a subtotal in Aggregation view would give similar results.

 Ⓘ [NOTE: If you have multiple currencies, it is recommended to select the currency in the aggregation criteria
as it will not aggregate positions across currencies]

4.2 Inventory Posit ion - Process Menu
The menu items of the Process menu are described below.

Menu Items Description
Create Movements
Type

This only applies to security positions.

Enter a movement type, for example “Collateralized Movements”.
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Menu Items Description

It populates the domain “InvSecMovementType”. You then need to define the movement
type using Process > Define Movement Type. See below.

Create Balance Type This only applies to security positions.

Enter a balance type, for example “Usable Balance”.

It populates the domain “InvSecBalanceType”. You then need to define the balance type
using Process > Define Balance Type. See below.

Define Movements
Type

This only applies to security positions. You first need to create a movement type using
Process > Create Movement Type.

Select a movement type and build the formula using basic position types, composite position
types (existing custom movement types), and specific values. You can specify conditions as
needed.

Then click Apply.

Example
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Menu Items Description

This example will compute Collateralized Movements = Movements Collateralized In +
Movements Collateralized Out.

Define Balance Type This only applies to security positions. You first need to create a balance type using Process
> Create Balance Type.

Select a balance type and build the formula using basic position types, composite position
types (existing custom balance types), and specific values. You can specify conditions as
needed.

Then click Apply.

Example 1

Example 1 will compute Usable Balance = Balance + Balance_Collaterized_In + Balance_
Collaterized_In_Substitutable.
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Menu Items Description

Example 2

Example 2 will compute Cash Value = Balance * DirtyPrice * FXRate.

Example 3

Example 3 will compute the position with haircut: Repo Value = Balance * DirtyPrice * FXRate
* Haircut.

In this case, make sure to select a legal agreement or margin call contract to retrieve haircut
information.

Example 4
The MaturityFactor returns 0 if Position Date > Product Maturity Date; or 1 otherwise.

It allows computing a zero balance after bond maturity using a formula like
Balance*MaturityFactor.

Check FX Quotes See search criteria Pricing Env and Valuation Date for details.

4.3 Popup Process Menu
When you right-click a position, the following menu items are available in the Process menu.
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Menu Items Description
Details Displays the distribution of the security position.

Reconcile Position Reconcile the selected position with the position computed by the Liquidation Engine. To
use this feature, select the "Book" level aggregation in the Aggregation field.

Red rows indicate positions that are not reconciled.

You can also use the scheduled task RECON_INV_PL_POSITIONS to reconcile inventory
positions with PL positions.

Please refer to Calypso Scheduled Tasks documentation for details.

Reserve Position Select a security position, and choose Reserve Position to make the position unavailable.

» Enter the following fields as needed:

– Nominal Reserved: Nominal amount to be made unavailable
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Menu Items Description
– Start Date and End Date: Duration of unavailability

– Usage: Reason of unavailability

» Then click Save reservations(s). It creates Unavailability Transfers for the reserved
position. Such transfers populate the position types “Balance Unavailable” and
“Movements Unavailable”.

You can set the default book for the reserved position. The default book is the book with
book attribute Custody=True.

You can click to load all existing unavailability transfers regardless of the book.

Transfer Agent Select two security positions on the same security, and choose Transfer Agent to display the
Transfer Agent window for entering a transfer between the selected agents.

Position Adjustment Select a security position, and choose Position Adjustment to display the Security Transfer
window for entering a security transfer.

Unavailability Transfer Select a position (cash or security), and choose Unavailability Transfer to make this position
unavailable by creating an unavailability transfer. You can specify an unavailability reason.

Unavailability transfers populate the position types “Balance Unavailable” and “Movements
Unavailable”.

The system checks for a default trade template for the user.

If no default template exists, then the Unavailability Transfer trade will be Open by default.

If a default template exists, then the system will check to see if the default template is Open
or Term. If the template is Term, then the system will insert the position start date plus 1D
(next business date) as the end date of the trade. If the template is Open, then the trade will
be Open.

Repo Sweeping With book aggregation selected in the Security panel, you can select a position and choose
Process > Repo Sweeping to open the repo trade capture screen. It automatically
completes the following details based on the position you have selected in the report:
security, start date, book, and nominal.

Account Sweeping >
On All Selected
Positions

To perform account sweeping on all selected positions.

Refer to Account Sweeping Documentation for setup details.

Account Sweeping >
On Specific Date

To perform account sweeping on a given position cell.

Refer to Account Sweeping Documentation for setup details.

Pool Consolidation To perform account sweeping on an account hierarchy.

Refer to Account Sweeping Documentation for setup details.

Financing Select a position and choose Process > Financing to capture financing repo trades.

For a cash position, you will capture MONEY FILL trades.
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Menu Items Description

Default values for these trades can be specified through a legal agreement between the
processing organization (owner of the selected book) and the selected counterparty. Legal
Agreements are defined using Configuration > Legal Data > Agreements from the Calypso
Navigator, and default values for financing repo trades are defined in the Details panel.

You can also set default values configurations (created using Configuration > Legal Data >
Default Values from the Calypso Navigator) in the following domains:

• Domain = "Financing.MoneyFillConfig" - Value = Config name

• Domain = "Financing.CloseAfterSave" - Value = true (to automatically close the window
when the trades are saved)

Enter and modify the fields as needed.

Add trades as needed.

Click Savewhen you are done.

The Default Values Configurations window is described in Calypso Fixed Income
documentation.

Margin Call For a margin call position, creates a margin call trade.

4.4 Environment Propert ies
The following environment properties apply to the Inventory Position report.

Environment Properties Description
AGG_CONFIG_
PLACEOFSAFEKEEPING

True or false. Default is false.

When true, it allows computing the external position by Book / Agent / Account /
PlaceOfSafekeeping.

When false, it allows computing the external position by Book / Agent / Account.

BO_POSITION_FORCE_
TRANSACTION_SERIALIZABLE

True or false. Default is false.

Inventory positions are stored in multiple tables. If you are loading large past
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Environment Properties Description
positions, there might be changes to those tables while the report is running,
therefore causing inconsistent results.

When true, it allows preventing changes in the inventory tables between different
queries by increasing the isolation level to SERIALIZABLE (instead of
TRANSACTION_READ_COMMITTED by default).

In the case of Oracle, the parameter INITRANS (default is 1) should be increased for
tables (and indexes) linked to inventory tables to allow multiple SQL queries running
at the same time.

inv_cash_movement

inv_cash_balance

inv_sec_movement

inv_sec_balance

inv_cust_cash_movement

inv_cust_cash_balance

inv_cust_sec_movement

inv_cust_sec_balance

inv_cash_query

inv_sec_query

inv_agg

inv_temp_config_id

inv_product_temp

product_temp

BO_POSITION_REPORT_
ACCEPT_IN_DATASERVER

True or false. Default is true.

When set to true, it allows accepting the inventory positions inside the Data Server
to prevent too many RMI calls. Set to false to disable (accepting done in Calypso
Navigator in this case).

Accepting corresponds to selecting the inventory positions based on the Inventory
Position report criteria.

BO_POSITION_REPORT_
FILTER_IN_DATASERVER

True or false. Default is true.

When set to true, it allows filtering the inventory positions inside the Data Server to
prevent too many RMI calls. Set to false to disable (filtering done in Calypso
Navigator in this case).

Filtering corresponds to removing applicable zero positions (based on date range).

BO_POSITION_REPORT_
CLEAR_POSITION

True or false. Default is true.
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Environment Properties Description
Allows reducing memory usage in Inventory Position report – Disabled in case of
real-time updates.

BO_POSITION_REPORT_
CLEAR_DISPLAYABLE

True or false. Default is true.

Allows reducing memory usage in Inventory Position report – Disabled in case of
real-time updates.

BO_POSITION_REPORT_
CLEAR_ROW_VECTOR

True or false. Default is true.

Allows reducing memory usage in Inventory Position report – Disabled in case of
real-time updates.

BO_POSITION_REPORT_
PRELOAD_SECURITIES_IN_
DATASERVER

BO_POSITION_REPORT_
PRELOAD_SECURITIES_MIN_
IN_DATASERVER

If set to true, preload the securities when a Custom Filter or a SD Filter is used in the
Inventory Position Report. Default is false.

Minimum number of securities to activate the preloading of the product cache
(default is 10). Only applies when BO_POSITION_REPORT_PRELOAD_SECURITIES_
IN_DATASERVER is true.

BO_POSITION_REPORT_
REALTIME_LOG_SIZE

Size of the real-time logs (default value is 50000). If set to 0, the logs are not limited.

BO_POSITION_LOAD_
PRODUCT_BY_IDS

True or false. Default is true.

Allows loading the products by ID in the Inventory Position report.

KEEP_OPPOSITE_XFER_FROM_
INVENTORY_DETAIL

Used in the Inventory Position report.

True or false. Set to true to display both legs of a repo when both the start and end
legs are failed. Only one failed transfer is displayed otherwise.

Default is false.

MAX_INVENTORYPOSITIONS_
PER_USER

Maximum number of inventory positions to be loaded.

Default is 500000.

Can also be set per user using User attribute Max.InventoryPosition.

These limits do not apply to Admin users.

PRODUCT_REPORT_CACHE_
MAX_SIZE

Max size of Secondary Market Products cache – Default is 50000.
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5. Reconciling Inventory Positions
From the Calypso Navigator, navigate to Processing > Reconciliation > BO Position Reconciliation to reconciling
inventory positions against each other (menu action reporting.ReportWindow$BOReconciliation).

Any combination of the following types of positions can be reconciled: Client positions, Internal positions, and External
positions.

You can reconcile real-time inventory positions computed by the Inventory engine, or inventory snapshots generated
by the INVENTORY_SNAPSHOT scheduled task.

You can also run the RECONCILE_INVENTORY scheduled task to perform reconciliation on a regular basis.

5.1 Import ing External Posit ions
Calypso allows importing MT950 messages for realized balances – They are identified as external positions and can
be reconciled with internal positions.

See Integrating Payment Messages and Statements for details.

5.2 Sample BO Posit ion Reconci l iat ion Report

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

Nasdaq Calypso
Nostro Management / Version 18

April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 52 / 192



April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 53 / 192

» Specify search criteria as applicable and click to load the corresponding positions. The selection criteria are
described below.

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Criteria Details

Criteria Description
Report Date Enter a report date. Positions on or before that date will be selected.

Agent Select an agent (the owner of a settlement account).

Processing Org Select a processing organization (the holder of a settlement account).

Aggregation Select an aggregation level: Book/Agent/Account, Agent/Account, Agent, Book, Global, or
Margin Call.

Use Issuance
Underlying

Check to allow reconciling an internal Issuance position with an external Security position on
the same security by converting the Issuance Product id to the Underlying Security id.

Position Date Select a position date:

• TRADE— To load a position by trade date.

• SETTLE— To load a position by settlement date.

• AVAILABLE—Only applies to Client positions. Its purpose is to maintain the amount of
cash or security available for trading in real-time, based on the client operations, The
available position is computed based on the available date specified in the transfer.

Position Class Select a position class:

• EXTERNAL— To load external positions.

• INTERNAL— To load internal Calypso-generated positions, which reflect the positions
of the processing organizations.

• CLIENT— To load client Calypso-generated positions, which reflect the accounts of the
clients.

Client positions are calculated on transfers with a given legal entity, for which the
processing org and the agent are the same.

• MARGIN_CALL— To load margin call positions. Refer to the Calypso Collateral
Management User Guide for details.

Position Type Select a position type:
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Criteria Description
• ACTUAL— To load actual positions that contain transfers that have settled.

• THEORETICAL— To load theoretical positions that contain all transfers regardless of
their status.

• FAILED— To load failed positions that contain transfers for which the settlement has
failed. Status codes corresponding to failed transfers should be set in the
transferFailedStatus domain.

You can also define a domain transferSettledStatus that contains all settled status codes,
and remove the domain transferFailedStatus. All status codes not in transferSettledStatus
will be considered not settled.

Note that the behavior described here is the out-of-the-box behavior. You can customize
the inventory engine to build positions based on any status or any date, including new types
of positions.

Label Enter a label for identifying each position. The labels default to Base and Target. They will
appear in the reconciliation results for the dates and totals columns.

Use SnapShot Check to load the positions from an inventory snapshot, you will be prompted to select a
snapshot.

Inventory snapshots generated by the INVENTORY_SNAPSHOT scheduled task.

Please refer to Calypso Scheduled Tasks documentation for details.

Otherwise, real-time positions are loaded.

Show Differences Only Check to only display positions where there is a difference.

Include Cash Check to display cash positions.

Include Security Check to display security positions.

Reconcile Payments Check to load actual payments. To reconcile the payments, right-click a row and choose
Process > Reconcile Payments – Payments will appear in the Payment panel.

Filter Matured Security Check to select the securities having Maturity Date > Report Run Date. Checkbox enabled
only when “Include Security” checkbox is checked.

Filter Zero Balance Check to filter zero positions from both sides of the reconciliation.
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5.3 Reconci l iat ion Results

 Ⓘ [NOTE: The columns can be configured. Sort columns, subheadings and subtotals have to be explicitly
specified. Choose Help > Menu Itemsfor details]

The default columns are described below.

You can click any column heading to sort the results based on that column.

You can right-click any row to invoke the functions of the report menus. Menus common to all reports are described
under Help > Menu Items. The Process menu is described below.

5.3.1 Defau l t Columns
The default columns are the following.

Columns Description
Account Position's account.

Book Position's book.

Product Position's currency.

<Base-Label> Date Base position's date.

<Base-Label> Total Base position's amount.

<Target-Label> Date Target position's date.

<Target-Label> Total Target position's amount.

Difference =Target Total - Base Total.

Since Break Number of days since the position has not been reconciled. The first time it is not reconciled,
Since Break = 1.

Note that this column will only be populated if a reconciliation run for this position has been
previously saved using Process > Save Run.

Since Change Number of days since the position has had movements. The first time it has a movement,
Since Change = 1.
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Columns Description
Note that this column will only be populated if a reconciliation run for this position has been
previously saved using Process > Save Run.

Key The key is the product id for a security position and the currency for a cash position.

Comment You can select a comment from the drop-down list. The default choices are “Match Found”
and “No Match”. You can specify additional comments as applicable in the domain
"ReconcileInventoryComment".

Assigned You can enter a user name in this column.

5.3.2 Process Menu
The menu items of the Process menu are described below.

Menu Items Description
Show Quantity

Show Nominal

Show Nominal
(Unfactored)

These menu items operate as a checkbox - You can check only one at a time.

Check "Show Quantity" to display the quantity for position-based trades, or check "Show
Nominal" to display the actual nominal amount, or check "Show Nominal (Unfactored)" to
display the unfactored nominal amount.

Load Run To load an existing reconciliation. You will be prompted to select a previously saved
reconciliation.

New Run To clear the selection criteria.

Save Run To save the current reconciliation results. You will be prompted to enter a reconciliation
name.

Save As New Run To save the current reconciliation results as a new reconciliation. You will be prompted to
enter a reconciliation name.

Delete Run To delete an existing reconciliation. You will be prompted to select a previously saved
reconciliation.

Reconcile Payments When the “Reconcile Payments” checkbox is checked, you can right-click a position and
choose Process > Reconcile Payments. The payments will be displayed in the Payment
panel.

Position Detail To bring up the Inventory Position report for a given position. You will be prompted to select
a position label.

Explain Difference Only applies if one of the positions is a snapshot, and if there is a difference between the
base and target positions.
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Menu Items Description
The Explain Difference report will be displayed.

Generate Difference To generate a Simple Transfer for a given position for which there is a difference.

This only applies if the target position is of type EXTERNAL.

The legal entity attributes DEFAULT_BOOK and DEFAULT_CTPY can be set on the PO of the
selected position.

Simple Transfer for Cash Position
• Type = Cash

• PO = PO of the BOOK

• BOOK = LE Attribute DEFAULT_BOOK

• Counterparty = LE Attribute DEFAULT_CTPY

• Direction = Deducted from the sign of the difference (negative=PAY/positive=RECEIPT)

• Principal = Absolute value of the difference

• Trade keyword TradeSource = MT950_ADJUSTMENTS

• Trade and Settlement date = Base Date in BO Reconciliation Report

Simple Transfer for Security Position
• Type = Security

• Transfer Type = Security

• PO = PO of the BOOK

• BOOK = LE Attribute DEFAULT_BOOK

• Counterparty = LE Attribute DEFAULT_CTPY

• Direction = Deducted from the sign of the difference (negative=PAY/positive=RECEIPT)

• TradeKeyword TradeSource = BORecon_MANUAL_SEC_ADJUST

• Quantity = Absolute value of the difference (follow current logic for Principal)

• Security = Selected security

• Trade and Settlement date = Base Date in BO Reconciliation Report
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5.4 Troubleshooting
If you have the error, "Cannot find bucket RepoTrackingIn", when performing a BO Reconciliation on Security
positions, you need to add RepoTrackingInventorySec to the domain "InventorySecBucketFactory".
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6. Generating Account Statements
Account statement events are generated by the scheduled task ACCOUNT_STATEMENT based on actual cash
account positions, and account statement configurations. The Message engine subscribes to account statements
events and generates account statement messages based on statement message configurations.

Accoun t S ta tement Genera t ion F low

6.1 Before you Begin
When a cash account is defined, the Statements panel will become available to let you configure Statements for this
account.

The Statements panel is used to specify that the account can generate regular statements based on your
configuration.

Please note that statements can be created only for accounts that have a processing organization, a currency, and a
holder (legal entity and role must be specified).

The setup of the statements can be done individually account by account or globally for a range of accounts.

6.1 .1 Ind iv idua l Setup
For Global Setup, choose Help for details.
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» Enter the fields described below and click Add.

You can add multiple statement configurations to generate statements for multiple positions as needed.

» Then click Save.

Fields Details - General

Fields Description
Statement Type Select the statement type: Default for an outgoing statement, or Incoming for an incoming

statement.

Incoming statements are described as part of the integration process.

Refer to Calypso Integrating Payment Message and Statements documentation for
details.

You can add values via the menu Process > Statements > Add Statement Type Domain
that can be used for outgoing statements only. They belong to the domain StatementType.

For information on Clearing Statements, please refer to Calypso Clearing Member
documentation or Calypso ETD Clearing documentation.

Numbering Enter a rule to generate statement numbers. New values can be added via the menu
Process > Statements > Add Statement Numbering Domain. They belong to the domain
StatementNumbering.

The different values available are as follows:
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Fields Description
• yy or RR: last 2 digits of the year – yyyy: Century + Year

• MM: Month

• DD: Day

• DDD: Day Number

• NNN (any length): Number - Re-initializes the statement ID at the beginning of the year.

• CCC (any length): Number - Does not reinitialize the statement ID at the beginning of
the year.

• ZZZ (any length): Number resets to zero at the beginning of the year.

They can be combined (i.e. yyyyMMDD, yyyyDDD, yyyyZZZ).

Zero Balance If this checkbox is ticked, a statement will be created even if the balance is zero and if no
movement occurs in the specified period. In that case, it also means that it is a “Dormant”
account. Default value = true.

No Movement If this checkbox is ticked, a statement will be created even if no movement occurs in the
specified period, whatever the balance. Default value = true.

Interim Generation Check to allow generating multiple intraday statements (camt.052).

Make sure that you select CHECK_FREQUENCY = false when running the scheduled task
ACCOUNT_STATEMENT.

Last Statement Displays the number of the last statement.

Double-click on the heading to display the Id of the last statement created.

Last Date Displays the date when the last statement was edited.

When creating a new statement rule, the date specified will be used to calculate the
original balance.

Active From/To Enter dates if the statement rule is available only in a limited period.

Fields Details - Frequency

Fields Description
Freq

Rule

You can select a frequency to determine when to generate / integrate account statements.

For the weekly / monthly frequency, you can select the day of the week / month, and select
a date roll convention to roll the statement date as needed when it falls on a holiday.

You can also double-click the Freq label to select a date rule instead.

Frequency Populated Select the frequency supported by Swift. It only applies to MT535 messages and populates
tag 22F::/SFRE/.
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Fields Details - Position

Fields Description
Cash/Sec Select the position type to which the statement applies: Cash or Security

Class Select Internal, or Client.

Type Select the type of position you want to report in the statement: Actual, Statement, or
Theoretical.

Date Select the position date: Settle, Trade, or Booking.

If you select the date type “Booking”, you can specify the strategy to determine the
Booking date using the domain “ProcessingConfig” for the value “BookingDateManager”.
The setup is described below.

If you do not specify a strategy, the default strategy is LastStatementDateStrategy.

LastStatementDateStrategy
Default strategy.

Booking Date = System Date if last Booking Statement Date < System Date. Otherwise
Booking Date = Last Statement Date + 1 day

LegacyLastStatementDateStrategy
Domain = ProcessingConfig

Value = BookingDateManager

Comment = com.calypso.tk.bo.bookingdate.LegacyLastStatementDateStrategy

Booking Date = Value Date if last Booking Statement Date < Value Date. Otherwise Last
Statement Date + 1 day

AccountingStrategy
Domain = ProcessingConfig

Value = BookingDateManager

Comment = com.calypso.tk.bo.bookingdate.AccountingStrategy

Booking Date = Accounting Business Date as defined in the Legal Entity attribute/Book
attribute ACC_BUSINESS_DATE, or If not set the EOD of the Book

Value For Security accounts, select the position Value: Quantity, Nominal, Nominal (Unfactored),
or From Product.

When "From Product" is selected, the system will check the product’s quote type to
determine the position value:

• CleanPrice, DirtyPrice: Position Value = FAMT (nominal)

• Price, PriceC, UnitaryPrice and GrossUnitaryPrice: Position Value = UNIT (quantity)

Payment Based If checked the Statement is based on actual settlements. Otherwise, it is based on
expected transfers.
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Fields Description
CAAdjustBook If checked the Statement only selects CAAdjustBook transfers (transfer type is CA and

transfer book has a CAAdjustBook book attribute).

Otherwise, any transfer that satisfies the other criteria is selected.

This is used for MT566 reconciliation. Please refer to Calypso Corporate Actions
documentation for details.

Field Details - Message Config
Click Config to bring up the Message Configuration window. You can select an existing configuration or setup a new
one.

The product type should be N/A and the event type should be STATEMENT.

You can choose Help > Message Configuration Help for details.

» Select the STATEMENT event type and an account statement message type. Select the Agent role and select an
agent or ALL. You can use a standard swift template (MT940, MT950, MT535, MT536), MX template (camt.053,
camt.052) or an HTML template (AccountStatement.html).

The following account statement message types are available:

– ACC_STATEMENT - Cash Statement Messages for both text and Swift Messages
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– ACC_SEC_STATEMENT - Security Statement Messages for text Messages

– ACC_SEC_POS_STATEMENT - For Swift MT535

– ACC_SEC_TRAN_STATEMENT - For Swift MT536

» Save the message configuration.

» When you close the Message Configuration window, you will be prompted to update the message configuration
information in the statement configuration. Click Yes.

Call Account Statement

 Ⓘ [NOTE: For a call account, the role should be the role defined in domain "AccountHolderRole", the message
type should be ACC_STATEMENT, and the template should be "CallAccountStatement.html" - Refer to Calypso
Call Account documentation for information on defining call accounts]

For interest bearing trades, the fee comment is stored in the transfer description. So if you display the transfer
description in the HTML message, you will see the fee comment. If you display the transfer type, you will see the fee
name.

The message keyword ACCOUNT_LEGAL_ENTITY_FULLNAME shows the account holder full name.

If you want to separate the interest cashflows from the interest rate change, you can use the RateChange iterator.

In order to have a more personal transfer description, the system provides the ability to customize the narratives.

If a DDA Xfer is generated by another product (MM or FX trade for example), instead of having the MM standard Xfer
description like "PAYMENT USD CASH INTEREST" you can replace CASH by a trade keyword value or a predefined
mapping value:

Define the domain "StatementKeyword" with Value = "Narratives" (to use the trade keyword Narratives as the value to
display instead of Product Type).

Or define the domain "StatementMapping" with Value = <Product Type> and Comment = <value to display> (then if
Value ="Cash" and Comment = "Money Market" , the system will display Money Market instead of Cash).

You can set the environment property USE_AGENT_IN_XFER_DESCRIPTION to false if you want to remove
agent/account in xfer description for CustomerTransfer (default is true).

To remove extra Net transfer in case of WHT tax (default is true), you can set in domain "AccountSetup":

• Value = USE_TAX_IN_STATEMENT

• Comment = false

Account Attributes
The domain “statementAccountAttributes” may contain account attributes to be copied to statement messages as
message attributes in the form “Account.<account attribute>”.
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For example, to copy the account attribute StatementTransmission to the statement message, add
StatementTransmission to the domain “statementAccountAttributes” and add “Account.StatementTransmission” to
the domain “msgAttributes”. The value of account attribute StatementTransmission will be copied to message
attribute “Account.StatementTransmission”.

You can then define static data filters on those message attributes.

6.2 Account Statement Processing
The scheduled task ACCOUNT_STATEMENT generates statement events based on account statement
configurations and cash account positions computed by the Inventory engine. The statement events are then
processed by the Message engine for the actual generation of the statement document.

You can also click Generate in the Account window, Statements panel to generate the statement events. You will be
prompted to select a date range.

From the Calypso Navigator, navigate to Configuration > Scheduled Tasks to open the Scheduled Tasks window,
and select the ACCOUNT_STATEMENT scheduled task (menu action scheduling.ScheduledTaskListWindow).

Select a trade filter, a user, a pricing environment, and a processing organization.

In the scheduled task, you can specify the agent for which you want to generate a statement, and the type of
message (it must be the same as the message configuration selected in the statement configuration).

• MESSAGETYPE – Select an account statement message type for this type of message to be generated (ACC_
STATEMENT, ACC_SEC_STATEMENT, ACC_SEC_POS_STATEMENT or ACC_SEC_TRAN_STATEMENT).

• ROLE – Select the Legal Entity role “Agent”, the same as in the Accounts Definition window.

• LEGAL ENTITIES – Select legal entities as needed or leave blank for all Agents.

• CURRENCIES – Enter a currency or multiple currencies, or leave blank for all currencies.

• STATEMENT_TYPE - Applies to ETD Clearing - Leave blank.

Nasdaq Calypso
Nostro Management / Version 18



• FREQUENCY - Select Daily, Date Rule or Monthly.

• CHECK_FREQUENCY - Select true or false to check the statement frequency according to the following logic:

– Daily Statements - Whether true or false, there is no impact on daily statements. Intraday statements will be
regenerated.

– Periodic Statements (Monthly for example) - When True, the system will check that the date matches the
date rule in the account definition. If it does, it will produce the expected statements.

When False, it will generate an inter-month statement at the date the scheduled task is executed.

Note that periodic statements are not regenerated on or before the last statement date - See "Regenerating
a Statement" below for details.

• EXCLUDE_ACCOUNT_STATUS – List of account status codes for which the account statement will not be
generated (from the accountStatus domain).

• Prerequisite Check – Leave empty or select "SubsidiaryAccount".

• SD_FILTER – Select a static data filter as needed to restrict the application scope of the scheduled task.

• Override Open Balance Date to D - Select true to set the opening balance date to the valuation date. It is the Last
Date from the Account – Statements panel otherwise (Valuation Date - 1 business day for daily statements).

• PRODUCT CACHE MAX SIZE - Enter the size of the product client cache (default size is 10000 if not set).

• THREAD COUNT - Enter number of threads to parallelize the process (default is 1).

• DISABLE SECTIONS – Select the sections that you do not want to generate in the ETD Clearing statement.

• Save file types – Select the file types that you want to generate.

• Save location – Select the files location.

Processing of Late Settlements
Late settlements can be included in the next statement, provided the statement is configured as follows.

The statement config attached to the account for which we produce the statement must be in "Booking" date. The
booking date will be populated on the transfers for accounts linked to such statements as follows:

Booking Date = Value Date except if Last Statement Date <= Value date, in which case this will be Last Statement
Date + 1 day.

In addition, to manage cases where only SETTLED transfers are included in the statement (which is usually the case),
the UpdateBookingDate workflow rule can be added on SETTLE and MATCH actions to update the Booking Date as
follows:

If the Booking Date of the transfer is <= Last Statement Date the rule updates the Booking Date to Last Statement
Date + 1 to include that transfer in the next day statement.

Regenerating a Statement
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To regenerate a statement, you can regenerate it manually from the Statement panel of the Account window, or
regenerate it using the scheduled task ACCOUNT_STATEMENT provided you modify the Last Statement date in the
Statement panel of the Account window to a date prior to the regeneration date.

6.3 Message Report
The Message Report displays messages that have been generated by the Message engine. In particular, the message
engine generates statement messages for the statements created by the ACCOUNT_STATEMENT scheduled task.

From the Calypso Navigator, navigate to Reports > Message Reports > Message Report (menu action
reporting.ReportWindow$Message) to display the Message Report as shown below.

» Specify search criteria as applicable (for example, Type = ACC_STATEMENT) and click Load to load the
corresponding message.

» Double-click a message to view the actual document.

Nasdaq Calypso
Nostro Management / Version 18



This message type (MT950) is sent by an account servicing institution to an account owner. It is used to transmit
detailed information about entries, whether or not caused by a Swift message, booked to the account.

The Swift messages MT940 and MT950 are by default created with 20 lines per message. If you want to manage
a different number of lines, add the property MAX_LINE_PER_SWIFT_STATEMENT and specify the value you
require.

Account statement messages can be manually edited by the user via the Message report. For more details about
editing message, refer to the Calypso Messages Documentation.
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7. Viewing Account Statements
From the Calypso Navigator, navigate to Reports > Accounting Reports > Account Statement (menu action
reporting.ReportWindow$AccountStatement) to view all statements created by the scheduled task ACCOUNT_
STATEMENT, or via the Account Statement Config report.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Enter search criteria as needed and click to load the corresponding statements.

It also allows filtering the Statements by Closing Date. A double click on the headings Statement Date Min
orStatement Date Max displayed in blue resets the date to the system date.

You can configure the columns of the report. See Help > Menu Items for details.

» You can double-click a statement to display the associated transfers in the Transfers panel. Note that it only
displays transfers occurring during the statement period.

» You can right-click a statement and choose Show > Linked Messages to display the Message report for the
associated statement message generated by the message engine. If you double-click the statement message in
the Message report, it displays the actual statement message.
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» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.
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8. Integrating Payment Messages and
Statements
The system allows integrating incoming MT103, pacs.008.001, MT202, pacs.009.001, MT202COV, MT204, MT205,
MT205COV, MT210, MT900, MT910, camt.054 (camt054) messages and reconciling the incoming messages with
Calypso transfers. The process is described below.

The system also allows integrating incoming MT940, MT942, MT950, MT970, camt.053 (camt053), camt.004
(camt004) and reconciling the incoming statement entries with Calypso transfers. The configuration is described
below.

For pacs.008.001, pacs.009.001 integration, please refer to Calypso MX Payment Messages documentation for
details.

8.1 Setup Requirements

8.1 .1 Env i ronment Property
You need to set the following environment property:

SPLIT_CASH_STATEMENT = True

It splits every MT940/MT950 message into sub-statements. Each sub-statement representing individual financial
transactions.

8.1 .2 Process ing Org Attr ibutes
Set the following legal entity attributes on the processing organization as needed:

Fields Description
CASH_
MANAGEMENT

Set to true for advanced checks, or false otherwise.

Advanced Checks
When set to true, the system will perform specific prerequisite checks before processing an
incoming statement MT940/MT950/camt053. These prerequisite checks are the following:

• Check if all start-balances match the previous end-balances.
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Fields Description
• Check that all intermediate balances for an account are matching (Tag 60M/62M for a n-page

statement).

• Check that opening + movements = closing balance.

• Check statement completeness and order (number of pages and existence of Tag 62F).

• Check if all accounts exist in MT940 and vice-versa.

• Check if date of end balance is not in the future.

• Check if there is only one end-balance (and so MT940) per day.

When set to true, you will need to run two scheduled task to integrate and process incoming
MT940/MT950/camt053: first MESSAGE_MATCHING to save the incoming
MT940/MT950/camt053 globally as a BO Message into the system, then INC_CASH_STATEMENT
to run the checks and process the incoming MT950/camt053. When set to true, only statements
marked as Valid are processed into the system. If one at least of the checks failed, the system raises
a Process Status exception type StatementIntegration and stops the process. The user will have to
check into the ProcessStatus report to know what check has failed and rerun the integration.

No Check
When set to false, the system will not perform any specific check and will process all statements
MT940/MT950/camt053 as they come. In that mode, you will only need to run MESSAGE_
MATCHING.

DEFAULT_
BOOK

Default Book used by the system when creating a missing movement (Simple Transfer) from the
"Match with Creation" function available in the Matching Manager.

DEFAULT_
CPTY

Default Counterparty used by the system when creating a missing movement (Simple Transfer)
from the "Match with Creation" function available in the Matching Manager.

8.1 .3 Domain Values
Make sure the following domain values are set.

Domain "incomingType"
• Value = MT103, Comment = INC_MT103

• Value = MT202, Comment = INC_MT202

• Value = MT204, Comment = INC_MT204

• Value = MT205, Comment = INC_MT205

• Value = MT210, Comment = INC_MT210

• Value = MT900, Comment = INC_MT900

• Value = MT910, Comment = INC_MT910
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• Value = MT940, Comment = INC_MT940

• Value = MT942, Comment = INC_MT942

• Value = MT950, Comment = INC_MT950

• Value = CAMT053, Comment = INC_CAMT053

• Value = CAMT054, Comment = INC_CAMT054

• Value = CAMT004, Comment = INC_CAMT054

Domain "Swift.UserHeader.Service Identifier.<currency>"
Settlement platforms such as Target need to have a special logic to retrieve the GL Account. The settlement platform
is the value of the Swift header's block 3 tag 103.

The domain "Swift.UserHeader.Service Identifier.<currency>" defines the list of supported service codes in Tag 103
of Swift header's block 3.

For example, create the domain "Swift.UserHeader.Service Identifier.EUR" for incoming EUR MT103/MT202 with the
values:

• Value = EBA

• Value = STC

• Value = TGT

Domain "IncomingSwiftTrade"
In order for incoming amend or cancel messages to be linked to the original message that they are
amending/canceling, the respective message types need to be added to the domain "IncomingSwiftTrade". If a
message type is not in IncomingSwiftTrade, when receiving an AMENDmessage for that message type, the matching
framework will not attempt to un-match the original message which the AMEND is replacing.

Value = CAMT053

Domain "MX.Templates"
• Value = CAMT053

Domain "ExternalMessageField.MessageMapper"
• Value = CAMT053

• Value = CAMT054
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8.1 .4 Sett lement Account
The account where the processing organization receives and processes
MT103/MT202/MT204/MT205/MT210/MT900/MT910/camt054 (and MT940/MT942/MT950/camt053) messages is
configured as a standard SETTLE account for that specific Processing Organization, Currency and Agent.

The account must be attached to the processing org's settlement instructions.

The name of the account can be generic, for example "PO@AGENT-CCY".

Account Attributes
Set the following account attributes.

XferAgentAccount - The system stores the value of Tag 25 used by the Agent when sending intraday
MT900/MT910/camt054 and T+1 MT940/MT950/camt053 in this account attribute.

Platform.<service code>

For the service codes defined in domain "Swift.UserHeader.Service Identifier.<currency>", you also need to set the
account attributes "Platform.<service code>" to True to map the Tag 103 value of the block 3 of the incoming
MT202/103.

For example, in domain "SwiftUserHeader.Service Identifier.EUR" we have the values EBA, STC, and TGT. So you
need to create the account attributes: "Platform.EBA", "Platform.STC", and "Platform.TGT".

For camt053 / camt054 integration, it should be "Platform.<jurisdiction>".

When multiple accounts have account attribute “Platform.TGT = true”, the system needs to use the account with
account attribute "Addressee11carBIC = <Receiver BIC minus ninth character>".

Example: Receiver BIC = NATXFRPPAMAR, Addressee11carBIC must be set to NATXFRPPMAR (it should not include
the ninth character).

IgnoreDuplicateStatement - Applies to camt053 messages only.

In order to process incoming camt053 messages that contain multiple statements with same statement id, you need
to set account attribute IgnoreDuplicateStatement = true.
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Alternatively, you can use the domain name "camt053DuplicateStatement" with value allowDuplicate and comment
true as shown in snapshot below:

The account attribute, if set, takes precedence over the domain value.

Incoming Statement Configuration
Settlement accounts are taken into account by the reconciliation process only if an incoming statement configuration
is attached to the account.

To add an incoming statement configuration, select the Statements panel, and add a statement configuration of type
"Incoming".

The frequency is used to determine when we expect an incoming MT940/MT950/camt053 for this account. The
system does not process an incoming MT940/MT950/camt053 if the frequency does not expect such a statement for
a specific date; inversely, the system raises an exception in the ProcessStatus report if a statement expected by the
date rule is not received.
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The incoming statement configuration also allows specifying the following options.

Options Description
Initialize with Statement
Message
(MT940/MT950/MT970)

If not checked, there is no creation of an EXTERNAL inventory position.

If checked, you have two options:

• When "Booked Funds (tag 62F)" is checked, the system uses the balance amount as
confirmed in the statement MT940/MT950/camt053 or 970 tag 62F to save "on a daily
basis" an EXTERNAL-BANK CONFIRMED-SETTLE DATE inventory position.

• When "Available Funds (tag 64)" is checked, the system uses the balance amount as
confirmed in the statement MT940/MT950/camt053 or 970 tag 62F to save "on a daily
basis" an EXTERNAL-BANK CONFIRMED-AVAILABLE DATE inventory position.

Update with Settlement
Confirmation Message
(MT900/MT910/
MT942/camt.054)

If not checked, incoming MT900/MT910/MT942/camt054 are only used to reconcile
Calypso transfers.

If selected, the same incoming MT900/MT910/MT942/camt054 are used to reconcile
Calypso transfers and to compute an EXTERNAL/BANK CONFIRMED/SETTLED DATE
inventory position in real-time. Combined with the initialization mode from the statement,
this allows computing in real-time into the system the balance of the account as confirmed
by the bank, taking into account only movements which are confirmed (whether reconciled
or not)

Create
BOCashSettlement from
the Statement Message
(MT940/MT950/MT970)

If checked, the system will create a specific trade on a product type = BOCashSettlement.

If checked, a BOCashSettlement trade is created per statement:

• Transfers associated with that trade are aggregated by value date (1 transfer per value
date).

• Transfers associated with that trade are of type EXTERNAL and only create an
EXTERNAL-ACTUAL-SETTLE DATE position.

• This option must be used when you want to recompute the external balance per value
date and not per booking date as confirmed in Tag 62F or 64. This is particularly useful
to calculate interest bearing trades using the exact same value date balance as the
bank to check the amount.

Define the Processing Organization and Bank/Agent SWIFT Codes (LE Contact)
To be able to map an incoming message, you need to setup the related SWIFT Codes for the Processing Organization
and Agent/Bank. As we reconcile outgoing SWIFT Messages, block 1 identifies the Receiver (Processing Organization)
and block 2 the Sender (Bank/Agent). Thus, to be able to process the incoming messages you need to set in the LE
Contact Window the SWIFT Address of the Processing Organization (to map block 1 swift address of the message
receiver), and the SWIFT Address of the Agent (to map block 2 swift address of the message sender).

The LE Contact must be defined with Contact Type = ALL by default.
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You can use another contact type for MT9xx and MT202 integration.

You need to add the contact type you want to use to the domain “MappingIncomingWithContact” (it applies to both
the PO and the Agent):

Value = <message type>

Comment = <LE Contact type to be used to lookup the GL account>

Example:

Value = MT950

Comment = Settlement

If there is no contact with this contact type, the first contact found is used.

The logic to determine which account is impacted for a specific incoming message is the same for MT900/MT910 and
MT940/MT950. We look for a unique account belonging to the processing organization which has a BIC Code = Block
1 BIC at the Agent = BIC Sender for the Account Number listed in Tag 25 and stored as XferAgentAccount account
attribute for that Processing Organization's Agent.

In case environment property LOOK_PARENT_CONTACT = true, if the PO of the incoming message with proper BIC
Code is a parent PO, then we look at accounts associated with children PO for which XferAgentAccount = Tag 25 of
MT900/MT910 or MT940/MT950 to set the proper PO.

If the PO’s agent has legal entity attribute MultipleAccountName = true, the system will look up multiple accounts
(defined in "XferAgentAccount.1", "XferAgenAccount.2", ..., XferAgentAccount.9"), not just XferAgentAccount.

If the currency of the message is different from the currency of the account it will check if it matches the
corresponding ISO currency.

The logic is slightly different for incoming MT103/MT202/MT204/MT205/MT210 where we only consider the specific
value set in Tag 103 of the Header/Block3 and map it with the Platform attribute of the account.

For camt053/camt054 messages, the identifiers are taken from the following tags.

The Incoming Linked Message Identifier is linked to the outgoing Message Identifier.

Refer to Calypso MX Payment Messages documentation for information on setting up those identifiers.

Message Attributes CAMT.054 Path

Busi-
nessMessageIdentifier

From Business Header: field BizMsgIdr

LinkedInstructionId /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/NtryDtls/TxDtls/Refs/InstrId

LinkedEndToEndId /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/NtryDtls/TxDtls/Refs/EndToEndId

LinkedUETR /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/NtryDtls/TxDtls/Refs/UETR
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Message Attributes CAMT.054 Path

LinkedSettlementAmount /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/Amt

LinkedSet-
tlementAmountCcy

/Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/Amt

LinkedSettlementDate /Document/BkToCstmrDbtCdtNtfctn/NtFctn/Ntry/ValDt/Dt

OR /Document/BkToCstmrDbtCdtNtfctn/NtFctn/Ntry/ValDt/DtTm

AccountId /Document/Ntfctn/Acct/Id/Othr/Id

OR /Document/Ntfctn/Acct/Id/IBAN based on SDI attributes SDI Attributes IBAN.Agent,
IBAN.Intermediary

DrCrIndicator /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/CdtDbtInd

InstructingAgentBIC /Docu-
ment/BkToCst-
mrDbtCdtNtfctn/Ntfctn/Ntry/NtryDtls/TxDtls/RltdAgts/InstgAgt/FinInstnId/BICFI

InstructedAgentBIC Docu-
ment/BkToCst-
mrDbtCdtNtfctn/Ntfctn/Ntry/NtryDtls/TxDtls/RltdAgts/InstdAgt/FinInstnId/BICFI

NtryStatus Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/Sts/Cd

Money Amount /Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/Amt is mapped with tag 32A (in
context : MT900 & 910).

For +/- in the below tag

/Document/BkToCstmrDbtCdtNtfctn/Ntfctn/Ntry/CdtDbtInd

- If the Debit then it would be -

- If Credit then it would be +

Setup Example
An example is presented below for a standard bank account for the processing organization PARENT_COMPANY
(Swift is PARNTCPY) with the agent BARCLAYS BANK PLC (BARCGB22) second block displays the Account
Statement Config:

Nasdaq Calypso
Nostro Management / Version 18

April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 78 / 192



April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 79 / 192

8.1 .5 Sett lement Instruct ions
Each processing organization bank account is attached to a SDI for the Role = Processing Organization and a SETTLE
Method = SWIFT (for instance).

Below an example for the standard account of the processing organization PARENT_COMPANY with the agent
BARCLAYS BK PLC:
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8.1 .6 Incoming Intraday Message Workf low
Define the incoming workflow for intraday reconciliation as shown below for incoming MT900 using Configuration >
Workflow > Workflow Configuration from the Calypso Navigator.

All intraday messages (incoming MT103/MT202/MT204/MT205/MT210/MT900/MT910/camt054) follow the same
workflow.

8.1 .7 Incoming Statement Message Workf low
Define the incoming workflow for T+1 reconciliation as shown below for incoming statements using Configuration >
Workflow > Workflow Configuration from the Calypso Navigator.

All T+1 incoming statements (incoming MT940/MT942/MT950/MT970/camt053) follow the same workflow.

The MT942 is saved as a statement and immediately split into sub-statements as soon as it is integrated into the
system. Only the sub-statements are eligible for matching with the related transfer. All pending incoming MT942 sub-
statements will be shown in the matching monitor to be reconciled manually with 1 or n transfers.

Simple Workflow
The workflow presented below can be used when processing incoming statements without prerequisite checks
(scheduled task MESSAGE_MATCHING only + Processing Organization Attribute CASH_MANAGEMENT = false).

Static Data Filter Statement
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Static Data Filter NotStatement

Static Data Filter SubStatement Nostro

Advanced Check Workflow
If you are working with prerequisite checks before processing the incoming statements (scheduled tasks MESSAGE_
MATCHING and INC_CASH_STATEMENT + Processing Organization Attributes CASH_MANAGEMENT = true), you will
need additional transitions to process the statement versus substatements created for each entry.

Specific transitions are needed to put the statement message into specific status depending on the result of the
prerequisite checks. These actions (PROCESS/UNPROCESS) in the workflow below are applied by the scheduled task
INC_CASH_STATEMENT.
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INC_CAMT053 Workflow

8.1 .8 Outgoing Message Workf low
For outgoing payment/receipt messages sent by Calypso, you will need to add the following transition / workflow rule
to be able to handle the matching on reference:
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8.1 .9 Transfer Workf low
The transfer workflow presented below is only an example to be used as a starting point. Clients must then adjust
based on their business process, especially in terms of manual and automatic write-off.

Static Data Filter WriteOff
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This Static Data Filter allows automatically triggering the write off transfers when we are below the automatic
tolerance (if set).

8.1 .10 Att r ibutes
Transfer attributes:

• CYSettleRef - Tag 21 of the MT103/MT202 sent by Calypso for reference matching with confirmation of debit
sent by the correspondent bank.

Tag 20 of incoming message (when using message rule AddTransferBusinessReference), or message attribute
REF_PO (if set), or Message ID otherwise.

• MatchedWith - Populated by the matching process: message id matched with the transfer.

Message attributes:

• PORef - Reference of the message sent by Calypso and confirmed by the agent.

• MatchedWith - Populated by the matching process; transfer id matched with the incoming message.

• AgentRef - Tag20 of the incoming MT900/MT910.

The following matchable object attributes are stored to process the cutoff of the intraday matching:

• Expected Cutoff - Expected date for the next cutoff. This allows integrating back value movement into the
matching, even when previous cutoff/statement for that date has been received.

• Account Lastest CutOff - Last statement received and processed for that account.

Matching Transfer Attributes to Swift Message Fields Tag 86 and Tag 61
Tag 86 of a MT940 - Information to Account Owner

Tag 61 of a MT940 or MT950 - Statement Line.Supplementary Details

The following domain have been added: “MatchingKeyFromXferAttr.Information_to_Account_Owner” and
“MatchingKeyFromXferAttr.Statement_Line.Supplementary_Details”.

They should contain the corresponding transfer attributes to be used. They must belong to the domain
“XferAttributes”.
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The transfer attributes should also be defined as trade keywords and should be added to the domain
“PropagateTradeKeyword”.

Matching keys have been added for these attributes:

• Information to Account Owner

• Statement Line.Supplementary Details

The tolerance rule “Contains” should be added to the domain “MatchingContext.Field.Tolerance” and can be selected
on the new matching keys.

It checks if the Incoming Matching key contains the Outgoing Matching Key or if the Outgoing Matching Key contains
the Incoming Matching key.

8.1 .11 Globa l Payments Innovat ion (GPI) F ie lds
The fields 111 (Service Type Identifier) and 121 (Unique End-to-End Transaction Reference (UETR)) can be added to
header block 3 based on the following configuration.

The message types for which the fields 111 and 121 should be added are defined in the domain
“SWIFT.Templates.GPI”.

By default, it contains the following messages: MT103, MT202, MT202COV, MT205, MT205COV.

You also need to set the following Processing Org attribute:

SWIFT_GPI – true to populate field 111 (it is false by default).

Field 111 is populated with 001 by default or with the Comment specified for a given message in the domain
“SWIFT.Templates.GPI” if any. You can also set Comment = NONE to not populate field 111 for that message.

Field 121 is populated with the UETR for outgoing messages and is set in the message attribute UETR for incoming
messages.

If the agent cannot receive the UETR, set the following Agent attribute:

SWIFT_ExcludeUETR = true to remove the UETR from field 121.

8.1 .12 Message Setup
To avoid issues with reference matching when doing a Match With Creation, you need to filter the generation of
messages for a Simple Transfer created from the matching manager using the Match with Creation function.

This can be done by adding a static data filter on the message setup to avoid the generation of payment messages for
simple transfer, as shown below:
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Static Data Filter TradeSourceIsNull

8.1 .13 Intraday Matching Context Def in i t ion
Define the matching context for intraday reconciliation using the Matching Context Definition window (menu action
refdata.MatchingContextConfigurationWindow).

Intraday Matching Context - Scope
Define the Scope of the intraday matching context as shown below:
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Intraday Matching Context - Matching
Define the Matching panel of the intraday matching context as shown below:

The actions are applied to both the incoming message and the outgoing transfer, hence they must be defined in the
Incoming Message workflow and the Transfer workflow.

For each matching criteria selected in that panel, the user needs to define using the Usage cell if the criteria is used
for All (automatic and manual matching), Automatic matching only, Manual matching only, or None.
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For each matching criteria selected in that panel, the user needs to define the weight and any specific tolerance he
would like to apply for that criteria.

The examples below are indicative only. You may want to use different rules/tolerances based on your business
processes.

Settlement Amount (criteria must be cumulative to allow n to m matching). Tolerance can be of different Type
(Percentage/Unit/UnitPerAmount and Currency. When using currency, the system allows using the LE Tolerance table
to set different tolerance per currency, processing organization and correspondent/bank).

Settle Date

Ccy

GLAccount
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POReference (PO reference is only used for payments)

Intraday Matching Context - Matching Options
Define the Matching Options panel of the intraday matching context as shown below:
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Options Description
Request
Comment

Activate the Request Comment option when you want to make a user comment mandatory when a
matching is performed manually from the matching manager.

Allow Match
with Creation

Activate the Allow Match With Creation when you want to add the possibility for a user to create a
missing movement into the system from an incoming message when choosing that menu in the
matching manager.

The system will create a Simple Xfer with the DEFAULT_BOOK and DEFAULT_CPTY set as attributes
on the processing organization.

Choose the Reversal Mode (when there is a difference of value date to reverse/new the flow from the
matching manager).

Choose the Auto Creation mode (the system will ask you to specify the default flow type) when you
want to automatically create a missing movement from incoming messages.

Allow Partial
Match

Activate the Allow Partial Match function (with Config Name = CashSettlement) when you want to
allow a manual partial match. For example, Incoming Msg confirms USD 900,000.00 while you have a
transfer for USD 1,000,000.00. You can manually partial match these two entries: It will settle USD
900,000.00 confirmed by the Agent and will Fail the remaining USD 100,000.00 that will remain as
"item to reconcile" in the matching manager.

Partial Match requires specific Transfer Workflow actions (PARTIAL_SETTLE) to work correctly. See
workflow section for details.

Activate the mode write off to create a specific flow for small differences going to a specific status to
trigger specific postings/accounts. There again, refer to the Transfer Workflow section for additional
actions required for that mode. The WriteOff Mode allows you to automatically write offs some small
differences.

The flow type is taken from domain “flowTypeWriteOff”.

Allow Same
Side
Matching

Activate the Same Side Match function when you want to allow the user to match n entries within the
same category. We usually only activate that options for incoming messages. The system allows Same
Side Match within several incoming messages if the global amount is zero.

Allow
Investigation

Activate the Allow Investigation when you want to add the possibility for a user "from the matching
manager" to mark an item to reconcile as "under investigation" and add a specific comment.
Next user will be able to see the comment history and to act as this mode leave the item into the list of
"pending reconciliation".

The additional mode "AllowWith Creation" allows to impact your balance for that amount without
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Options Description
having to wait for the real correction of the trade from your front desk (creation of a specific Simple
Transfer into the system).

Propagation Activate the Propagation mode if you want to propagate (when your tolerance allows it) the real
settlement amount and/or real settle date on the transfer when matching an incoming message with a
transfer having a different date and/or value. Specific inventory position types will reflect these
changes.

The manual actions proposed by the system in the matching manager are based on tolerance and matching options
defined in the matching context when selecting incoming and outgoing objects.

Intraday Matching Context - Best Matching
Define the Best Matching panel of the intraday matching context as shown below:

Intraday Matching Context - Investigation
Define the Investigation panel of the intraday matching context as shown below:
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Intraday Matching Context - More Options
Define the More Options panel of the intraday matching context as shown below:

Eligibility CutOff must be set on the intraday matching context to clean automatically un-reconciled items intraday
once the statement for that specific account/date has been received and processed by the system.

Options Description
Config Name Select CashSettlement.

CutOff Time Select the starting cutoff time - Format is 1500 (for 3pm); 1530 (for 3.30pm),

Frequency
(Hour)

Select frequency when the system must automatically rerun the cutoff from the initial cutoff
time (min is 1h).
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Options Description
TimeZone Select the reference Time Zone.

EOD Context Select the End of Day context linked to intraday (must be the one for
MT940/MT950/MT970/camt053).

Run CutOff Possibility to run manual cutoff from that screen.

8.1 .14 camt054 Math ing Context
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UETR is the supported matching key.

8.1 .15 Statement Match ing Context
To reconcile statements at T+1.

Statement Matching Context - Scope
Define the Scope of the T+1 matching context as shown below (we currently support
MT940/MT950/MT970/camt053):
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Statement Matching Context - Matching - Matching Options - Best Matching
Define these panels of the T+1 matching context with the same criteria/options as the intraday matching context.

Statement Matching Context - Investigation
Define the Investigation panel of the T+1 matching context as shown below:

Statement Matching Context - More Options
Define the More Options panel of the T+1 matching context as shown below:
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8.1 .16 Matching Manager Setup
You can monitor the progress of the integration process using the Matching Monitor (menu action
reporting.MatchingUILauncher Matchable) - [NOTE: There is space before Matchable].

Define the matching manager templates for Intraday and statement matching contexts.

The system provides several views from the general Summary view of intraday and statement matching items.

Click to load matchable objects.

You can adjust the search criteria as needed.

To configure the system, you need to initialize the categories with incoming and outgoing items and then select the
view to drill-down to the default template. Then, you can define for each report the default template.

The Investigate panel provides a summary view of un-reconciled incoming sub-statements in the top-part and un-
reconciled calypso transfers in the bottom-part. This is the default view used to reconcile incoming messages and
outgoing transfers.

Additional views are available for additional investigation or action:

• The Linked panel provides a summary view of matched/reconciled items with the possibility to unmatch wrongly
reconciled items.
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• The Details panel provides a simple view of a specific matching category. When selecting unmatched items
(=transfers not reconciled), the system allows to use the Best Match option and provides a list of possible
messages for a specific payment with rating and matching score.

Matching Categories
Different matching status codes are used by the system to categorize incoming messages and outgoing transfers
based on their reconciliation status.

• Incoming Message Matchable Status

– Alleged = Identifies all incoming messages waiting for reconciliation.

– Notification (Orphan) = Identifies all incoming MT103/MT202/MT204/MT205/MT210 for which the system
was not able to identify the account (For example, copy of a MT202 received from the counterparty). These
messages are integrated for information purposes and can be attached to any specific transfer for
audit/investigation.

– Notification = Identifies all notifications when attached to a transfer (they are considered as processed).

• Outgoing Transfer Matchable Status

Unmatched = Identifies all calypso transfer waiting for reconciliation.

• Incoming and Outgoing Matchable Status

– Matched = Identifies all reconciled items.

– Canceled = Identifies all items not eligible to matching anymore

All MT210 are considered notifications. The Nostro lookup is done as follows:

• Agent = Tag 56, or Tag 52a if Tag 56 is empty.

• Processing Org = Receiver of the Swift

• Currency = Tag 32

Investigate View Setup
You can click Investigate to get the default view of all "packed" un-reconciled items. You can then, split and filter your
table using the Split and Filter functions available in that panel.

Without panel split and filter all unmatched items are mixed as shown below:
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To configure the default layout of that screen, press the split panel icon . This will display the "incoming" un-
reconciled items at the top and the "outgoing" un-reconciled items at the bottom (as shown below).

Then define the filter as needed.
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You can click the  icon to show the filter on the Investigate panel. Please note that the Matching Manager is using
a docking framework, and as such, can be configured as desired by the end-user. Thus, the view displayed here can
be entirely customized by the user.

It is recommended to save your configuration as a template using Report > Save As Template, and make this
template the default template using Report > Set Default Template.

Contextual Action Buttons
Based on the configuration of the Matching Context options and the elements selected as incoming and outgoing, the
system will propose the possible actions (Match, Same Side Match, Partial Match, Match with Creation, Attach).

Possible actions are the following (they are proposed by the system based on configuration and items selected in the
Investigate panel):

• Match

• Match With Creation

• Partial Match

• Investigate

• Attach

• Force Match

The system allows matchingm incoming message with n outgoing messages manually from the Matching Manager
using tolerances.

Linked Panels
The Linked panel or Details panel of your Matching Manager allow seeing the matched items and undo the matching.
The Details panel also allows doing a Best Match from unmatched transfers to propose the possible incoming
message with a rating.

The system shows the category (Automatically Matched, Manually Matched, Manually Matched With Creation,
Partially Matched) and the Matching couple (transfer/message).

You can use the Unmatch button to undo a matching from that screen.

Example for the Alleged category.

Nasdaq Calypso
Nostro Management / Version 18



From the Alleged details, the user can select a message and click Potential Match. The system will then present the list
of possible outgoing transfers with their score for that message.

You can also bring up the details of the Unmatched category. When you click Potential Match, the system will present
the list of possible incoming messages with their score for that transfer.

8.2 Integrat ion and Reconci l iat ion of Incoming Messages
In order to start the integration and reconciliation process, the following engines must be running:

• Transfer Engine

• Message Engine

• Inventory Engine

• Matching Engine

• MatchableBuilder Engine

To import incoming payment messages, run the scheduled task MESSAGE_MATCHING.

Once imported, the incoming messages are saved to the Calypso database as a standard bo_message, then go
through the matching process.
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Automatic matching will be performed if applicable. For the unmatched messages, you will need to go to the Matching
Manager to manually match messages and transfers (menu action reporting.MatchingUILauncher Matchable)
- [NOTE: There is space before Matchable].

The system supports two modes for the integration of statements:

• No Check Mode - No check on statement format and completeness (PO attribute CASH_MANAGEMENT = false).
In that mode, you only need to run the MESSAGE_MATCHING scheduled task to integrate and process incoming
statements. Once saved as incoming statements, the system splits the global message (identified with Msg
Attribute = Statement) into sub-statements (identified with Msg Attribute = "Substatement.Nostro") and each
sub-statement is then processed by the matchable builder and matching engines for reconciliation.

• Prerequisite Check Mode - Check on statement format and completeness (PO attribute CASH_MANAGEMENT =
true). In that mode, you need to run the MESSAGE_MATCHING scheduled task to integrate the statement and
INC_CASH_STATEMENT to process the incoming statements. Once saved as incoming statement by MESSAGE_
MATCHING, the INC_CASH_STATEMENT splits the global message (identified with Msg Attribute = Statement)
into sub-statements (identified with Msg Attribute = "Substatement.Nostro") and each sub-statement is then
processed by the matchable builder and matching engines for reconciliation. The split process, with that mode,
only occurs if all prerequisite checks on statement format and completeness are validated. In that case, the
system throws a valid Statement Integration process status. If one check fails, split of statement is not performed
and an invalid Statement Integration process status is generated. The statement is blocked in a certain status and
manual action must be taken to proceed. This mode requires additional message workflow actions as specified in
workflow configuration section.

The Process Status report displays exceptions/errors blocking all or part of the statement integration and intraday
cleaning process.

See Process Status Report for details.

8.2 .1 Scheduled Task MESSAGE_MATCHING
The import of the incoming message files is done through the MESSAGE_MATCHING scheduled task.

This scheduled task is used to import all incoming messages (intraday matching
MT103/MT202/MT204/MT205/MT210/MT900/MT910 and statements MT940/MT950/MT970/camt053) in batch
mode.

Scheduled Task Attributes
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• Swift Message Delimiter - Enter the delimiter between messages in the text file as specified in the environment
property CALYPSO_SWIFT_LINE_SEPARATOR (should be blank if the property is not used).

• Swift File - Specify the Swift File Name (eg.20090325_BARC_0052.txt) to integrate one specific file. To integrate
all incoming MTxxx, the user has to set the value *.txt on that field. The system will then try to save as "bo_
message" all .txt files that are located under the InputDir.

• InputDir - Specify the Swift File Path and Directory where txt files are saved.

• File Rename - Select true/false. When set to true add a timestamp to the Swift File once processed.

• Gateway/ExternalMessageType - If the default implementation for processing MT940 is not satisfying, the
CashStatementHandlerFactory tries to retrieve a Handler respecting the order Gateway "ExternalMessageType"
as specified in these attributes.

The MESSAGE_MATCHING scheduled task does not perform any validation; it only saves the incoming message as
Calypso Messages.

8.2 .2 Scheduled Task INC_CASH_STATEMENT
This scheduled task is only needed for the "prerequisite checks" mode. It is only when the PO Attribute CASH_
MANAGEMENT is set to true that this mode is activated. This scheduled task is only processing statements (Intraday
incoming messages only need MESSAGE_MATCHING to be processed).

In that mode, once the scheduled task MESSAGE_MATCHING is reported as successful, it is necessary to run the INC_
CASH_STATEMENT scheduled task to process the incoming statements.

Thus, with the prerequisite check mode activated, the statement (MT940/MT950/MT970/camt053) integration
process is a two-step process:

• We first save the complete incoming statements using the MESSAGE_MATCHING.

• We then check the consistency and completeness of these statements, split the MT940/MT950/MT970/camt053
into sub-statements by entry using the INC_CASH_STATEMENT.

Then, the matching process is performed by the matchable builder and matching engines.

For corporate cash management, the INC_CASH_STATEMENT execution is a two-step process. You only need step 1
otherwise.

Step 1 - Process Incoming Statements
• Load all statement messages (initially saved by the MESSAGE_MATCHING) applying the "Statement statuses

restriction" attribute for the scheduled task's Valuation Date (= Tag 62F statement date, or tag
<Document><BkToCstmrStmt>/<Stmt>/<Bal>/<Tp>/<dt> for camt053).

• Group the statement messages by GL (SETTLE) Account.
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The correspondence between the MT940/MT950/MT970 Tag 25 for a specific Processing Organization
(Receiver BIC) + Agent (Sender BIC) and the Calypso GL Account is done using the GL Account Attribute
"XferAgentAccount" where we store the value of Tag 25.

For camt053 messages, the GL account is stored in tag <Document><BkToCstmrStmt>/<Stmt>/<Acct>/<Id>.

• Check the Group consistency (Sequence Numbering/Intermediary Balances/Statement Opening Balance =
Previous Statement Closing Balance, etc.).

• Create Account Statement summarizing the group information.

• Create Sub-Statement Messages (with specific types).

• Create BOCashSettlement Trade for each valid statement.

• Apply the "Valid/Invalid Statements Action" on Account Statement summarizing the group information:

– INC_MT940/MT950/MT970/camt053 Message Workflow Valid Action is applied on complete and consistent
grouped statements

– INC_MT940/MT950/MT970/camt053 Message Workflow Invalid Action is applied on incomplete and/or
inconsistent grouped statements

Step 2 - Exclude FORECAST Transfer Types
Corporate Cash Management only.

FORECAST transfer types must be excluded from the Cash Position for the Processing Organization Bank Accounts
successfully processed in Step 1.

• Load all simple transfer trades with transfer type = FORECAST and related transfers type FORECAST having a
Settle Date <= Scheduled Task Valuation Date for the GL Accounts in the group applying the "Forecast statuses
restriction" attribute.

• Apply the "Forecast Action" set as attribute on the selected Simple Transfer trades type FORECAST and related
transfers.

The "Forecast Action" is an action that must be added to your trade and transfer workflows (on transition
VERIFIED - SUBSTITUTE- SUBSTITUTED for example).

• This resulting status (SUBSTITUTED in our example) must be set in the transferCanceledStatus and
ignoreTradeStatus to make the system treat them as a CANCEL and exclude transfers with that specific status
from the inventory position. This also allows building specific trade and transfer reports including or excluding
these forecasts.

Scheduled Task Attributes
These steps are driven by the attributes set on the INC_CASH_STATEMENT scheduled task.
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• GL Account Id - Specify the Processing Organization SETTLE account for which you want to run the process. If
left blank, the process is run for all the processing organization SETTLE accounts initially saved by the MESSAGE_
MATCHING scheduled task.

• Statement statuses restriction - Specify the statement message status to take into account for the for the
scheduled task's Valuation Date (= Tag62F statement date).

• Valid Statements Action - Specify the statement workflow action to apply on complete and consistent grouped
statements.

• Invalid Statements Action - Specify the statement workflow action to apply on incomplete and inconsistent
grouped statements.

• Check Statements Exhaustivity - True or false. When set to true, the system reports "missing statements" as
exceptions in the exception file (e.g. a statement is expected for a specific bank account according to the
incoming statement configuration date rule but the related MT940 is not received). When set to false, the system
only reports exceptions for received statements, without reporting missing statements (type missing page, wrong
opening balance, etc.).

• Forecast statuses restriction - Only applies to Corporate Cash Management - Specify the trade and transfer
status to take into account to load the FORECAST trades/transfers. The system will load all Simple Transfer trades
with type = FORECAST and related transfers type FORECAST which have a Settle Date <= Scheduled Task
Valuation Date for that/these status(es) (eg. no restriction in the above example).

THIS IS NOT NEEDED ANDMUST BE LEFT BLANK FOR STANDARD CASHMANAGEMENT

• Forecast Action - Only applies to Corporate Cash Management - Specify the trade and transfer workflow action
that the system must apply on the selected FORECAST trades and transfers (e.g. SUBSTITUTE trade and transfer
action will be applied on FORECAST transfers and Simple Transfer Trades with Transfer Type = FORECAST in the
above example). The "Forecast Action" is a trade and transfer action that must be added to your trade and
transfer workflows (e.g. VERIFIED - SUBSTITUTE - SUBSTITUTED for this type of trader/transfer using SD Filters
or Trade and Xfer workflow types). Then, one must add the resulting status in the domains
"transferCanceledStatus" and "ignoreTradeStatus" to make the system treat that status as a CANCEL and, as
such, exclude transfers with that specific status from inventory position.

THIS IS NOT NEEDED ANDMUST BE LEFT BLANK FOR STANDARD CASHMANAGEMENT
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• Exception Report Format - The Scheduled Task generates an Exception report which allows having a summary of
all the issues encountered during the processing. Define the format of that exception file in the "Exception Report
Format" attribute. Available format include: excel, html, csv, pdf.

• Email Exception Report to - This exception file can be sent by email. Specify the email address or alias using the
"Email Exception Report to" attribute.

Prerequisite Checks performed by the INC_CASH_STATEMENT scheduled task
The consistency checks performed by the INC_CASH_STATEMENT scheduled task are the following.

• Check if all start-balances match the previous end-balances.

• Check that all intermediate balances for an account are matching (Tag 60M/62M for a n-page statement).

• Check that opening + movements = closing balance.

• Check statement completeness and order (number of pages and existence of Tag 62F).

• Check if all accounts exist in MT940 and vice-versa.

• Check if date of end balance is not in the future.

• Check if there is only one end-balance (and so MT940) per day.
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9. Process Status Report
From the Calypso Navigator, navigate to Processing > Process Status to bring up the Process Status report (menu
action reporting.ReportWindow$ProcessStatus) displays exceptions/errors blocking all or part of the statement
integration and intraday cleaning process.

See Integrating Payment Messages and Statements for details on the integration process.

Sample process status report

 Ⓘ [NOTE: The columns of this picture have been configured. Sort columns, subheadings and subtotals have
to be explicitly specified. See Help > Menu Items for details]

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» Specify search criteria as applicable and click to load the corresponding fees.

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Process Sta tus Repor t Resu l t s
The Process Status report allows checking the status of the integration of the incoming statements when working
with "prerequisite checks" mode (PO Attribute CASH_MANAGAMENT = true).

Only incorrect or incomplete statements are blocked. Others are fully processed.

This report lists the following processing scopes with their status (warning/valid/invalid):

• Statement Integration - The report produces a line per PO Bank Account having an Incoming Statement
Configuration. If the statement is expected and received (based on the incoming statement date rule) the status
is valid, else the status is invalid and a comment (Info column) is provided to give the reason of failure. From that
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"status" line the user can reach all the information regarding the account, statement config. etc. and take further
action.

• Matching CutOff - This process status exception is created when the eligibility cutoff has run for a specific
account/statement. Each time a statement (MT940/950/970) is received and processed into the system, the
system removes all intraday items waiting for reconciliation for that account/expected cutoff date as only
movements confirmed into the statement are now finalizing the reconciliation. When the cutoff process has run,
the user can check that the Matching CutOff process status for that account has been produced to ensure the
cleaning of intraday items is finished. The cutoff process is automatic based on a start time and frequency. This
process is done within the MatchableBuilder engine.
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10. Generating Account Interests
Account interest trades (interest bearing trades) are generated by the scheduled task ACCOUNT_INTEREST based
on actual cash account positions and interest bearing rules.

Accoun t In te res t Genera t ion F low

10.1 Before you Begin

10.1 .1 Interest Bear ing Rules
From the Calypso Navigator, navigate to Configuration > Accounting > Interests (menu action
refdata.AccountInterestConfigWindow).
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The Browse panel is selected by default. Select the Edit panel to define an interest bearing rule.

» Enter all the necessary information. The fields are described below.

» To define a range, enter the parameters of the interest calculation, then click Add to add the range. Repeat for
other ranges as needed.

» Click Save to save the rule.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

Fields Description

Config Id Given by the system when the configuration is saved.

Name Set and name standard configurations to apply to groups of clients and/or accounts. Any changes to
the configuration will automatically be applied to all clients and/or accounts linked to the
configuration.

Type Select the type of configuration: Interest or Margin. Margin configurations only apply to call accounts.

See Margin Rules for details.

The other types of configurations (IM, ITD, VM) apply to clearing - Please refer to Calypso Clearing
documentation for details.

Valid From /
To

Enter the validity dates of the configuration.

Nasdaq Calypso
Nostro Management / Version 18



Fields Description

Config Type You can select No, Yes, or Both for Penalty. The penalty configuration is applied when the account
balance is below a certain amount.

Limits are defined in the Limits panel.

 Ⓘ [NOTE: When Processing Org attribute "ALWAYS_PAY_PENALTY_INTEREST" is False,
interest penalty is not paid if an account is defined with minimum balance and balance is below
the limit but positive. Default is True (interest penalty is paid)]

You can check Tiered Calculation to distribute the account balance over the range. Otherwise, it is
applied to the absolute range.

Account Fil-
ter

You can select an account, or none to apply the configuration to all accounts.

Filter It is possible to link an account interest config to:

• A processing org (PO)

• One or several trading books. The account interest config will thereafter be available for client
accounts that belong to one of these books.

• A legal entity of specified role.

• A list of currencies, or ANY.

• It is also possible to link an account interest config to one or several book attributes under the
Authorization field. This restriction is only used in the Interest Manager: a user is able to load the
interest bearing rules for which the user has the appropriate access permissions by book
attribute.

Interest Cal-
culation

Select rounding information and calculation.

You can check Daily to apply the rounding to each daily amount. Rounding is applied to the final
interest amount otherwise.

You can enter a threshold. If the account balance is below the threshold, interest will not be
computed.

If you check "Compound", you need to select a compound rule to compound the interest.

 Ⓘ [NOTE: When computing the interest, you need to select the retroactivity mode in order for
the compounding to occur: Check the "retro Activity" checkbox in the Account Interest Runner,
or set the attribute RETRO_ACTIVITY = True in the ACCOUNT_INTEREST scheduled task]

You can select a daycount for Fixed Rate configurations (for Floating Rate configurations, the
daycount of the Rate Index definition is used).

Including PARTIAL_SETTLE entries to Position
To add PARTIAL_SETTLE entries amount in interest calculation, you can set Account Property 'Add
PARTIAL_SETTLE to position' to true.
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Fields Description

Frequencies Select the calculation frequency, payment frequency, capitalization frequency and Incl. Holiday for
Daily Calc frequency (for Daily settlement of Interest).

When the calculation date is at the end of the month, the interest is calculated until the last day of the
month, regardless of which day it is. If the last day of the month is a Saturday, and you want to
calculate the interest until Sunday (or until the end of a holiday), you need to set the account property
CHECK_END_OF_MONTH = false (it is true by default).

Settle Date Generation Issue for Date Rule with Relative Month
There are two ways to use a date rule in Interest Bearing trades: next(date) provides the next date
generated by the date rule and generate(fromDate, toDate) provides all the dates generated by the
date rule between the from and to dates.

The “generate” method is used by default for all date rules as it has a better performance. The “next”
method is used for DAILY and RELATIVE using DAILY date rules.

You can use the “next” method for any date rule as needed by adding the date rule to the domain
"dateRuleInterestUseNext".

Daily Settlement of Interest
For daily settlement of Interest Bearing trades, weekend accruals are included on Interest Bearing
trades based on “Incl. Holiday for Daily Calc”:

- Following: Weekend Accruals are included in the Interest Bearing trade settling on the previous
business day

- Preceding: Weekend Accruals are included in the Interest Bearing trade settling on the next business
day

- BLANKS: Weekend Accruals are included in the Interest Bearing trade settling on the previous
business day (Default)

Config
Ranges

Select the account currency, inventory aggregation, and the balance type as needed.

Enter the minimum amount / maximum amount as needed to define the ranges.

Enter Active From / Active To date for the configuration. When the Active To date of the configuration
is in the past, you can set account property SKIP_INTEREST_BEARING = true to stop computing
interest bearing for that account.

You can double-click the Amount label to switch to Rate instead, in which case you can specify a fixed
rate or a floating rate.

Select the interest currency.

Amount

» Enter the interest amount.
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Fields Description

Fixed Rate

» Enter the interest rate.

Floating Rate

» Define the floating rate.

You can enter a spread in the field next to the currency.

You can define a floor rate (minimum rate). Note that if you allow negative rates, you should either
set a negative floor rate ("-1.2" for example), or no floor rate.

Negative Rates
If you set the pricing parameter ALLOW_NEGATIVERATE to true for the InterestBearing product type,
the system allows calculating interest with negative rates.

You can set the starting date to consider negative rates in the pricing parameter ALLOW_
NEGATIVERATE_DATE (provided ALLOW_NEGATIVERATE = true). The format should be MM-DD-
yyyy.

However, if the account attribute "NEVER USE NEGATIVE RATE” is set to true for a given account, the
system will not allow calculating interest with negative rates even if ALLOW_NEGATIVERATE is true.

Zero Interest
If you set the pricing parameter EXCLUDE_ZERO_TRADE to true for the InterestBearing product type,
the system does not generate trades with zero interest. They are generated otherwise.

Reset Rate
You can determine how the reset rate is used throughout the reset period using the value IB_USE_
RESET_DAY_FOR_DATE_RULE in the domain “AccountSetup”. If Comment = true, the reset rate is
used for the whole reset period. It is only used for the reset date otherwise.

You can determine how missing rates are handled based on the value of account attribute IB_
MISSING_RATE:

• Create or Blank (default behavior) - If rate is missing, entry created with interest rate set to zero,
task created alerting missing rate.

• NotCreate - If rate is missing, no entry created, task created alerting missing rate.

Margin Rules
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For call accounts, you have the ability to add a specific Margin (in bps) onto an account (not visible by the client):

• The margin is added on top of the interest configuration set on the Account.

• It can be entered as a pre-configured margin and the line can be added to the Interest list configuration, or can be
add as a Quick Entry Margin.

• A margin can only be entered if an account has a generic Interest Config (not a quick entry).

• It cannot be inherited from a Master Account (only the Interest configuration can be).

» Define the characteristics of the margin calculation and click Add.

» Then click Save to save the configuration.

10.1 .2 Associat ing an Interest Bear ing Rule with an Account
Once you have defined a rule, you need to associate it with the account that is receiving interest.

From the Calypso Navigator, navigate to Configuration > Accounting > Accounts, and load your account in the
Account panel.
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» Check the Interest Bearing checkbox - Once checked, the Interests panel becomes available.

Note that for call accounts, "Interest Bearing" is mandatory and checked by default.

If the interest bearing rule has a capitalization frequency, the interest is capitalized, and any adjustment due to
back-dated trades is capitalized as well. If you do not want to capitalize the adjustments, you can set the account
attribute "CAPITALIZE ADJUSTMENTS" to false.

» Then select the Interests panel. The interest rule can be defined for individual accounts or for master accounts.
See below for details.

» You can also associate an interest rule with multiple accounts using Process > Interest Bearing > Bulk Update
Interest Config.

Note that this function is only available for call accounts.

It brings up the Account report: Load the call accounts that you want to update and select them. Right-click and
choose Action > Update Current Interest Config. You will be prompted to select an interest / margin
configuration.

Click Apply to set the selected configuration on the selected accounts.

The account can be associated with a Margin Call Contract using the account attribute MC_CONTRACT_ID.

In this case, you can use the trade workflow rule UpdateIBSettleDate to automatically set the Settle Date Confirmed
field on the Interest Bearing trade. It shows the trade keyword ConfirmedSettleDate = Date action is applied + OffSet
Days from associated Margin Call Contract (Cash column of the Collateral Dates in the Dates & Times tab).

If the account of the Interest Bearing trade is not associated with a Margin Call Contract or the Offset Days are not
set, ConfirmedSettleDate = Settlement Date.

The Settle Date Confirmed can also be set manually on the Interest Bearing trade.

When set, this date is used as the settlement date in the associated transfers.
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Master Account Setup
For the master account, check the Master Account checkbox.

» Set the Aggregation to Individual to apply the interest rule to the master account’s balance only, or Aggregate to
apply the interest rule to the balance of all the accounts within the master account including the master account.

» Optional - Select the account where the interest will be posted from the Destination Account field (if different
from the account itself).

» Define a validity period.

» Select the type of configuration: Interest or Margin (Margin configurations only apply to call accounts). Then click
... next to the Config Name field to select an interest rule. If the interest rule is specific to a processing
organization, beneficiary, or account, it will only be available on the corresponding account.

So for example if the interest rule is specific to agent MYAGENT, you will only be able to associate this rule with
an account for legal entity MYAGENT and role Agent.

You can set additional parameters: "Split Xfers PAY/REC", "Split Adjustment/Interest", "Capitalizes Ib On Source",
"PayOut Externally", "Agg. Entries On Master Account".

See Additional Settings for details.

If the interest rule is defined as both interest and penalty, an interest will be computed when the balance on the
account is above its overdraft limit or minimum balance requirement, and a penalty will be computed otherwise.

Limits are defined in the Limits panel.

If the interest rule is defined as interest only (Penalty = No), an interest will be computed when the balance on the
account is above its overdraft limit or minimum balance requirement. In this case, you can also associate a
penalty configuration if you have defined one. Check the Penalty checkbox, and add a penalty configuration to
the account.

» Click Add to add the rule. Then click Save.
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To associate and account with a master account, clear the Master Account checkbox, and select the master account.
Select the account where the interest will be posted from the Destination Account field (if different from the account
itself).

There is no need to select an interest rule – The interest rule of the master account will be applied.

» Set the Aggregation to Individual to apply the interest rule to the individual account’s balance only, Master to
apply the interest rule to the master account’s balance only, or Aggregate to apply the interest rule to the balance
of all the accounts associated with selected the master account including the master account.

» Click Save.

Individual Account Setup
Same as for a master account but the Master Account checkbox is unchecked, and the Master Account field is empty.
The only available aggregation level is Individual.

» Optional - Select the account where the interest will be posted from the Destination Account field (if different
from the account itself).

» Define a validity period then add an interest rule as described in the Master Account Setup.

» Click Add to add the rule. Then click Save.

Additional Settings
Additional settings can be set for generating account interest.
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• You can check "Split Xfers PAY/REC" to create two transfers for a given Interest Bearing trade: one that
aggregates the PAY entries, and one that aggregates the REC entries. Otherwise all entries are aggregated into a
single transfer.

• “Split Adjustment/Interest” - When not checked, only Interest Bearing trades of type INTEREST are generated.
When checked, Interest Bearing trades of type INTEREST are generated for credit balances, and Interest Bearing
trades of type ADJUSTMENT are generated for debit balances.

• You can check "Capitalizes Ib On Source" to create the interest bearing trade on the source account - The
account can be transferred to an external account using the scheduled task ACC_TRANSFER_INTEREST. It can be
transferred to:

– The destination account if specified.

– The account associated with the external counterparty if "PayOut Externally" is checked. The external
counterparty is selected in the attributes of the scheduled task ACC_TRANSFER_INTEREST.

The transfer of interest is triggered by the scheduled task ACC_TRANSFER_INTEREST, or manually at the account
level when you choose Process Interest > Pay Interest.

See Transferring Interest for details.

If "Capitalizes Ib On Source" is not checked, the interest bearing trade is created directly on the external account:

– The destination account if specified.

– The account associated with the legal entity of the source account for role CounterParty if "PayOut
Externally" is checked.

For example, the source account is defined for legal entity AGENT1 with role Agent. If "PayOut Externally" is
checked, the system will look for an account defined for legal entity AGENT1 with role CounterParty.

• You can check "PayOut Externally" to transfer the interest to an external counterparty - See "Capitalizes Ib On
Source" for details.

• You can check "Agg. Entries On Master Account" to aggregate all entries from Master and Child accounts into a
unique Interest Bearing trade on the Master account. This is only applicable if the field Aggregation = Aggregate.

Call Accounts
When you associate an interest bearing rule with a call account, additional functions are available.

You can check "Interest Quick Entry" to define the interest configuration on-the-fly.
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» Define the characteristics of the interest calculation and click Add.

» When you save the account, the interest configuration is saved as well.

You can check "Margin Quick Entry" to define the margin configuration on-the-fly.
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» Define the characteristics of the margin calculation and click Add.

» When you save the account, the interest configuration is saved as well.

10.1 .3 Access Permiss ion and Author izat ion
The access permissions relating to account interest generation are: AddModifyAccountInterest and
RemoveAccountInterest.

In order for Authorization mode to apply to account interest configs, you need to add “AccountInterestConfig” to the
domain “classAuthMode”.

10.2 Generat ing Account Interest
You can process interest computation from the Interests panel in the Accounts window by clicking the Process Interest
button, or you can run the ACCOUNT_INTEREST scheduled task.

10.2 .1 Process Interest on the Fly

» When you click Process Interest, the Account Interest Runner dialog appears.
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Check “save Process” to generate the interest bearing trades, select the proper position criteria, and click Run.

You can save the information as a template.

For information on "retro Activity" and "init Mode", please refer to the ACCOUNT_INTEREST scheduled task
below.

10.2 .2 ACCOUNT_INTEREST Scheduled Task
From the Calypso Navigator, navigate to Configuration > Scheduled Tasks (menu action
scheduling.ScheduledTaskListWindow), and configure a task of type ACCOUNT_INTEREST.

Interest bearing trades are generated based on the inventory position computed by the Inventory engine on accounts
associated with an interest bearing rule.

Select a trade filter, a user, a pricing environment, and a processing organization.

In the scheduled task, you can specify the agent for which you want to generate account interest, and the inventory
position to select.
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Set the following attributes as needed.

• CHECK CONFIG ONLY - Set to true to check that all the selected accounts have a valid config from the valDate to
the valDate + “To Days” (default is 1 month). The expired config is displayed in the file given as attribute. This
produces a report which lists all the interest matrices that are attached to live accounts and that have expired or
are due to expire in the coming month (or number of days defined in the "To Days" of the Scheduled Task). If
attribute set to false, ACCOUNT_INTEREST exceptions will be generated instead.

• SAVE PROCESS - If False, the scheduled task will simulate the Interest bearing process and generate a report to
be checked by the users. If True, it will also save the Interest Bearing Trade.

• CALCULATION TYPE - Refer to the type defined on the matrix; choose Interest, Claim, etc. Interest in this
example.

• ACCOUNT ID - You can enter one particular account if you want to launch the process on one specific account
only.

• LEGAL_ENTITY - You can enter one particular Client name if you want to launch the process for one particular
Client only.

• SD FILTER - Define an SD Filter if you want to restrict the process to one given Processing Organization or Book.

• FileName - Set the name and the directory of the report displaying the interest trades.

• POSITION AGGREGATION - Define the type of position aggregation that will be used as the basis of interest
calculation: “Agent/Account” or “Book/Agent/Account”.

• POSITION CLASS - Client: To calculate interest on client accounts, Internal: To calculate interest on nostro
accounts, or External: To calculate interest on incoming positions for reconciliation purposes.
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• DATE TYPE - Trade: To calculate interest based on trade date positions, Settle: To calculate interest based on
settle date positions (real settle date), or Value: To calculate interest based on value date (theoretical settle date)
=> this Would be the most commonly used for interest calculations.

• POSITION TYPE - Actual: For interest calculations, Theoretical: Should not be used (it is available for flexibility
purposes in case one client wants to use it), or Failed: For claim calculation.

• INV_AGG_TYPE - Select an inventory aggregation type as applicable.

• INV_AGG_VALUE - Select an inventory aggregation value as applicable, or “_ANY_”.

• RETRO_ACTIVITY - True: The process will work in retro-activity mode, or False: The process will not apply any
retro-activity rules.

In retro-activity mode, the system generates adjustments for backdated movements (if any) between their value
date and their real settle date. To manage the adjustments, the system creates a new position ACTUAL in value
date.

Note that the retro-activity mode is required to compute interest compounding.

• RETRO_ACTIVITY_TYPE - Used in case the retro-activity is set - The default is "All Dates": We use one year in the
past or retro-activity date rule set on the account.

You can also select:

– Current month : Since the beginning of the month.

– Previous month: Since the beginning of the previous month.

– Current year: Since the beginning of the year.

– Previous year : Since the beginning of the previous year.

• INITIALIZATION MODE - Set to True: Normally you set this the first time you calculate interest in the system. This
will allow the system to create trades of interest without generating adjustments.

• OFFSET BALANCE DAYS - By default, the interest is calculated on the balance on the valuation date - You can
enter a number of days to calculate the interest on the balance on the valuation date minus the number of days.

• OFFSET IS CALENDAR - To specify if the offset of the balance is calendar or business days.

• EXCEPTION ON ZERO BALANCE - When there is an error due to a missing configuration, by default we publish an
exception only when the balance is not zero. You can set this attribute to true to generate an exception on zero
balances as well.

• PUBLISH EXCEPTIONS - If set to false, we do not create a task when there is an error of configuration / missing
quote. You can set to true to create a task in such a case.

• THREAD COUNT - Enter the number of threads for multi-thread processing by account. Default is 1 (no multi-
thread processing).

Once the scheduled task is defined, save it and run it.

 Ⓘ [NOTE: It is recommended to run the process with the Inventory engine off]
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The scheduled task retrieves all SETTLE accounts with the “Interest Bearing” checkbox checked, and the positions
corresponding to the selected attributes.

The position is stored each day and retrieves the corresponding interest bearing rule to compute the interest amount.
The scheduled task creates interest bearing trades.

Book Selection
If environment property IB_USE_BOOK_POSITION = true (default), the book associated with the cash position, if any,
is selected.

Otherwise:

• The book specified in the account attribute "FUNDING BOOK" is selected in priority.

• If not set, the book specified in the legal entity attribute "FUNDING BOOK" of the account's processing org is
selected.

• If no book is associated with the cash position, the User Defaults book of the user generating the trades is
selected.

Viewing Interest Bearing Trades
From the Calypso Navigator, navigate to Processing > Accounting Operations > Interest Bearing > Trade > Open to
view the interest bearing trades.

It opens the trade selector.

» Click Show Trades to view all interest bearing trades.

» Double-click a trade to view its details.
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You can select the Entries panel to view the calculation details.

You can click Pay Interest to transfer the interest to another account.

See Transferring Interest for details.

 Ⓘ [NOTE: To view interest bearing trades in the Trade Browser, you need to add 1 day to the valuation date
because the trades are created as of today at 11:59:00 PM]

10.2 .3 Interest Bear ing Trades Pr ic ing

Agent Accounts
Pricer measures are shown from the perspective of the Processing Org: positive when the PO receives interest from
the Agent, and negative when the PO pays interest to the agent.
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Client Accounts
Pricer measures are shown based on the environment property PO_VIEW_OF_CLIENT_IB.

If PO_VIEW_OF_CLIENT_IB = false (default), pricer measures are shown from the perspective of the Client: positive
when the Client receives interest from the PO and negative when the Client pays interest to the PO.

If PO_VIEW_OF_CLIENT_IB = true, pricer measures are shown from the perspective of the Processing Org: positive
when the Client pays interest to the PO and negative when the PO receives interest from the PO.

10.3 Transferr ing Interest
You can transfer the interest to another account by choosing Process Interest > Pay Interest in the Interests panel of
the Account window, or navigate to Configuration > Scheduled Tasks (menu action
scheduling.ScheduledTaskListWindow), and configure a task of type ACC_TRANSFER_INTEREST. It will
generate a customer transfer.

If you set the transfer workflow rule ApplyActionLinkedXfer on the transitions VERIFIED – SETTLE – SETTLED and
SETTLED – UNSETTLE – VERIFIED, both the interest payment and the interest transfer will be settled at the same
time.

Only positive interest amounts are transferred by default but the account can be setup to also receive interest by
setting the account attribute "PayInterestOnly=False".

The following trade keywords are populated:

• INTEREST_TRANSFER_FROM (on Customer Transfer trades)

• INTEREST_TRANSFER_TO (on Interest Bearing trades)

• TradeSource (on Customer Transfer trades)

10.3 .1 Pay Interest On-the-f ly

When you select Process Interest > Pay Interest, it brings up the Account Interest Payment Runner dialog.
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» Select the destination legal entity role and legal entity. This will determine the SDIs to be used, and therefore the
destination account.

» Select the source account.

» Enter an application date and click Apply.

10.3 .2 ACC_TRANSFER_ INTEREST Scheduled Task
Select a trade filter, a user, a pricing environment, and a processing organization.
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» Set the following attributes:

– LEGAL_ENTITY ROLE – Role of the legal entity to which the interest is transferred. In order to choose the
correct SDI, you must assign a new role to the legal entity (External for example). So this legal entity will
have a SDI for the role Agent and a SDI for the role External (which will contain the external account).

– ACCOUNT_ID - Id given by the system, not the account name. Source account.

– LEGAL_ENTITY - Name of the Legal Entity to which the interest is transferred.

– CHECK_PREVIOUS_DAYS - When set to true and the valuation date is not the payment date, the system
amends /creates the interest bearing trade if the payment date is a holiday. When set to false, the interest
bearing trade is amended / created only if the valuation date is the payment date.

– EXCLUDE_TRADE_STATUS - You can enter a list of comma-separated status codes to exclude the trades in
corresponding status.

» Once the scheduled task is defined, save it and run it.

10.4 Withholding Tax
To activate the Withholding Tax in Calypso, set the environment property WITHHOLDINGTAX to true.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Definition to define
the withholding tax fees. You can define as many fees as needed (a resident WHT fee, a non resident WHT fee, and an
XTRAWHT fee to handle the cases where no DTT treaty is signed).

Nasdaq Calypso
Nostro Management / Version 18



» You can click Help for complete setup details.

Then from the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Set Up to define
the related grids in the Fee Grid panel. Be sure the grid is flagged as WithholdingTax and defined with Role = ALL.
Thus the grid may be eligible for both Loan and Deposit trades (where client role is counterparty), and Interest Bearing
trades (where client role is the Account Holder role).

Note that if the Authorization mode is enabled, an authorized user must approve your entry.
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Then define the related accounting events.

From the Calypso Navigator, navigate to Configuration > Accounting > Events and define an event with event name
equals to the fee type:
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Make sure to check "Fee Related Event".

Withholding Tax transfers are created by the Scheduled Task ACCOUNT_INTEREST.

As soon as Withholding Tax applies to an Interest Bearing Trade, the system generates an additional transfer type
<WITHHOLDINGTAX FeeName>. In terms of messages, the WITHHOLDINGTAX related transfer should move to
SETTLED when the related INTEREST transfer is moved to SETTLED. Then it impacts:

• The account balance and is taken into account into the Asset/Liability and Reclassification Accounting process

• The account statement

10.5 Rate Change
Rate Change is currently only supported on call accounts.

10.5 .1 RATE_CHANGE Transfer
To be able to report rate changes in customer statements, the system creates a transfer of type "RATE_CHANGE",
attached to the interest bearing trade(s), based on its value date. If needed, please add it to the domain "flowType".

RATE_CHANGE transfers are created by the scheduled task ACCOUNT_INTEREST.

The system creates a RATE_CHANGE transfer type with a specific Xfer Description as stated below.

Example 1: INTEREST and withholding tax
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Example 2: INTEREST without withholding tax

The new rate is used in interest calculation (new adjustment) from its value date.

A RATE_CHANGE transfer can also be generated by the system if the floating rate index used in the configuration is
changing in the Quote Set. This Rate Index has to be defined as a Base Rate and its attribute GenerateRateChange
must be set to True.

 Ⓘ [NOTE: It must only be used in case of an annually or monthly reviewed rate (i.e. Base Rate or equivalent) in
order not to produce a daily RATE_CHANGE]

By default, a RATE_CHANGE transfer is generated for Interest Bearing Trades with zero amount.

If you do not want to generate those transfers, you can set the Comment to "false" in the domain “AccountSetup” for
the value "ADD_XFER_CONFIG_CHANGE".

10.5 .2 Backdated Rate Change
Back dated RATE_CHANGE transfers are also created by the scheduled task ACCOUNT_INTEREST, provided the
RETROACTIVITY attribute is set to True.

In such a case, the system creates a RATE_CHANGE transfer with Value Date = Initial Date of Rate Change and Settle
Date = Today (entered date of the rate change), provided you have set the property XFER_BV_REAL_SETTLE_DATE to
true.

That RATE_CHANGE transfer is attached to the Interest Bearing trade of the initial period where it should have been
confirmed and will be reported on the current period statement, based on its SETTLE DATE, provided it is in a
SETTLED status.
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10.5 .3 Rate Change Message
When generating a RATE_CHANGE transfer (on the current Interest Bearing trade), two Xfer Attributes are populated:

• RateChangeName: set to "FixedRate" or to the name of the floating rate +(spread+margin)

• RateChangeValue: All In rate at the related value date

This transfer can trigger a message based on message type "RATE_CHANGE_ADVICE".

Sample message setup:

The Static Data Filter RATE_CHANGE filters on the Xfer Type = RATE_CHANGE.

The following template keywords can be used:

• |TRANSFER_VALUEDATE| is the date at which the rate is changing

• |TRANSFER_SETTLEMENTCCY| is the currency of the customer account

• |CALL_ACCOUNT_TYPE|

• |CALL_ACCOUNT_SUBTYPE|

• |ACCOUNT_NAME|

• |ACCOUNT_ACTUALBALANCE|

• |TRANSFER_RateChangeValue|

• |TRANSFER_RateChangeName|

10.5 .4 Rate Change Workf low
The RATE_CHANGE transfer should have its own workflow to go directly to SETTLED and be part of the statement for
that period without creating any specific task in the Task Station.
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This transfer being created for "technical reasons", the end-user should not see that transfer into their task station,
and it should SETTLE automatically to make it appear as soon as created in the statements. For that reason, we advise
to add the following transfer workflow subtype for RATE_CHANGE transfers

First, define the following SD Filter:

Then, add the value RateChangeXfer to the domain "XferWorkflowType".

Then from the Calypso Navigator, navigate to Configuration > Workflow > Workflow, and add the following transfer
workflow for the Subtype RateChangeXfer:

RATE_CHANGE transfers will automatically go to a SETTLED status and will be reversed and NEW (using the Transfer
Engine param XFER_USE_REVERSE = true).
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 Ⓘ [NOTE: If you want to generate a Rate Change message, then the RATE_CHANGE workflow must have a
temporary status like VERIFIED to only reach the SETTLED status on value date (with a KickOff config) to avoid
the multi-generation of a message in case of floating rate]

10.6 Sett lement of Interest Bearing Adjustments
The early settlement of Interest Bearing trades can be done at Interest Bearing trade level or at the Account level as
shown bellow. It creates a Transfer on current Interest Bearing trade of the account with today's date and with an
amount equal to the sum of all adjustment entries initially planned at Interest Bearing Settle date.

Click Settle Adjustments - It brings up the Account Interest Payment Runner dialog.

You can also choose Process Interest > Settle Adjustment from the Interests panel of the Account window.

The window used to generate this transfer has also an additional checkbox "PayOut Adjustment" enabled if the
interest must be transferred to another account. If checked, it creates the related transfer to transfer the interest
which includes the calculated adjustment and related withholding tax.

Additionally, the accounting event ADJUSTMENT can be used to take into account any ADJUSTMENT amount early
settled between start and end date of the Interest Bearing trade.

Nasdaq Calypso
Nostro Management / Version 18

April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 134 / 192



April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 135 / 192

10.7 Chasing Interest Bearing Trades in Bulk
You can send chasers in bulk for interest bearing trades using an action with workflow rule IBBulkChaser and message
template “SubsidiaryICInterestAdviceBulk.html” (based on message keyword TRADE_BROWSER_TEMPLATE that
displays a Trade Browser report for the template defined in domain “BulkIBChaserTemplate”).

Domain BulkIBChaserTemplate
It must contain a Trade Browser template that contains the Interest Bearing trades for which you want to generate a
chaser.

InterestBearing Trade Workflow
Add action BULK_CHASE with trade workflow rule IBBulkChaser.

Example: VERIFIED - BULK_ACTION - TO_BE_AGREED

The workflow rule prevents the generation of the bulk message if:

• A Trade Browser template is not defined in domain "BulkIBChaserTemplate"

• No Interest Bearing trade is returned by the template

The action should be applied to a single Interest Bearing trade, and it will generate a chaser for all trades returned by
the specified template.

It is recommended to add the action BULK_CHASE to the domain "TradeActionNotAuthorizedInMultiSelection" so that
you can only apply it to 1 trade, otherwise you may generate duplicate chaser messages.

Chaser Message Setup

Product Type = InterestBearing

Event Type = <result status of BULK_ACTION>_TRADE - Example: TO_BE_AGREED_TRADE

Message Type = CHASE
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Template = SubsidiaryICInterestAdviceBulk.html

Static data filter:

When you apply the action BULK_CHASE to an interest bearing trade, the chaser is generated.
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11. Interest Manager
The interest manager is used to update account interest ranges (interest rates, spread, or amounts) from interest
bearing rules. This window does not allow a user to create a new interest bearing rule or range.

See Generating Account Interest for information on creating interest bearing rules.

11.1 Account Interest Manager Tour

• The Filters area allows setting search criteria to load interest bearing rules.

• The Results area shows the ranges of the interest bearing rules that correspond to the selected criteria.

• The Accounts area shows the accounts that use the selected interest bearing rules.

• The Cash Positions panel displays the inventory position on all accounts that are using the selected interest
bearing rules.

11.2 Interest Config Fi l ters
This panel is used to narrow the list of interest bearing rules to be loaded.

Process Date

Fields Description
Process Date Defaulted to today. This date is used to set the effective from/to dates to the account

interest ranges.

Pricing
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Fields Description
Pricing Env Select a pricing environment to load rate values for floating rates.

Config Filters

Fields Description
Processing Org If set, the system will load the Interest Bearing Rule defined for this particular PO.

Book If set, the system will load the Interest Bearing Rule defined for this particular book(s).

Legal Entity If set, the system will load the Interest Bearing Rule defined for this specific legal entity (i.e
account holder)

Currency If set, the system will load the Interest Bearing rule defined for this currency.

Type Amount, Fixed or Floating. If set, the system will only load the ranges defined with this type
of rate/amount.

Quick Entry If set, the system will only load the quick entry configurations. These configurations are
defined with an account id not null.

Penalty If set, the system will use the penalty flag as load criteria.

Range Filters

Fields Description
New ranges To only load the ranges for which the rate still needs to be set.

Submitted ranges To only load the ranges for which the new rate needs to be authorized/accepted.

11.3 Results Panel
All the interest ranges that match the criteria entered by the user are loaded in this panel.

The user will be able to specify the new rate, new spread, or new amount in the corresponding columns.

The range is automatically flagged as “Selected” as soon as a user changes the applicable rate/spread or amount.
Then, all changes are submitted once the user click Apply.

The status is updated from New to PendingAcceptance and the changes need to be accepted or rejected to be
effective.
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Another user can load all submitted ranges, decide to accept/reject the changes, and click on Apply to save the
results.

Once accepted, the interest bearing rule is updated, taking the new rate and effective date into account.

Old range is updated with ActiveTo date = Process Date – 1 day.

New range is created with ActiveFrom date = Process Date.

11.4 Accounts Panel
This panel is used to display the list of accounts that are using the selected interest bearing rules.

It is possible to configure several templates and set default templates, using the Report Menu of the panel.

11.5 Cash Posit ion panel
This panel is used to display the inventory position on all accounts that are using the selected interest bearing rules.

It is possible to configure several templates and set default templates, using the Report Menu of the panel.
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11.6 Access Permissions
SubmitAccountInterestUpdate: give the right to a user to submit changes.

ValidateAccountInterestUpdate): give the right to a user to validate changes.
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12. Generating Account Fees
The Cash Management activity requires invoicing of Nostro / Client accounts:

• Management Fees relating to account transactions

• Management Fees on account positions

Accoun t Fees F low
Account billing events are generated by the scheduled task ACCOUNT_BILLING based on actual account positions
and account billing configurations. The Billing engine subscribes to account billing events to generate account
management fees (billing trades) based on billing grids and fee billing rules.

View ing B i l l i ng Trades
You can view billing trades using Reports > Fees & Settlement > Billing Fee Report from the Calypso Navigator -

Help is available from that window.

Before you Begin
An account can generate fees if the account has the “Billing” checkbox checked.
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Sample account definition

The ACCOUNT_BILLING scheduled task will only process accounts for which the Billing checkbox is checked.

You can set a default book for billing trades in the legal entity attribute "FUNDING BOOK" of the legal entity that pays /
receives the fee (broker, counterparty, agent, etc.).

Billing Trade Workflow
Billing trades follow the standard trade workflow. However, make sure that the AMEND action is available, as new
billing fees will be added to the same trade during the billing period, and the billing trade will therefore be amended.
Also, it is recommended to move the billing trade to a status that can no longer be amended at the end of he billing
period.

Authorizing Billing Grids
In order for the Authorization mode to apply to billing grids, you need to add “BillingGrid” to the domain
“classAuthMode”.

12.1 Defining a Bi l l ing Grid
The billing grid allows automating the fee calculation for accounts.

From the Calypso Navigator, navigate to Configuration > Fees, Haircuts & Margin Calls > Fee Set Up (menu action
refdata.FeeSetUpWindow), and select the Billing Grid panel.
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Sample billing grid for account fee

» Enter the fee application criteria as needed and select the event type for which the fee will be generated:
Account (account management) or MaintenanceTrade (account transaction)

Enter the validity dates of the grid - They apply to the selected "Fee Value Date" of the related object.

The “Fee Value Date” determines which date on the billing event should be used to select the Billing Grid, the
Billing Rule, and to set the value date on the billing trade.

By default, it can be set to the following values: CurrentDate (Today), or CustomDate (if the Fee Value Date of the
billing event has been customized) – You can add more types of dates to the domain
“billingAccount.feeValueDates”.

Fill in the Description field to describe the grid. This field is mandatory.

You can check "Use Multiple Calculators" to generate a fee for each applicable calculator. Otherwise, a fee is
generated only for the first applicable calculator.

» Select a calculator (Default or FeeConfig), and click Add to define the calculator.

– For the Default calculator, the fee will be computed based on the amount defined here.
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Enter a description and an amount. The amount can be signed: "-" means the PO pays the fees, "+" means
the PO receives the fee.

You can check "use Time Period" to select a date rule to generate the fee.

Then click Apply.

– For the FeeConfig calculator, the fee will be computed based on the fee defined in the Fee Config panel.

See Defining Account Fees for details on defining invoice fees.

You can check the "Split by book" checkbox to allocate the fees to the original books, and click Apply.

You can check the "Split by security" checkbox to allocate the fees based on the security which is split by
each security, and click Apply.

» Save the billing grid.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

12.2 Defining Account Fees
The Fee Config panel of the Fee Set Up window allows defining fees for the FeeConfig calculator in the context of
billing fees. When the FeeConfig calculator is set on the Billing Grid, the fee config is used to compute the fee.

Nasdaq Calypso
Nostro Management / Version 18

April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 144 / 192



April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 145 / 192

12.2 .1 Fee Def in i t ion
Define the fee using Configuration > Fees, Haircuts, & Margin Calls > Fee Definition (menu action
trading.FeeDefinitionWindow).

Make sure that you set the proper role. It should be Agent or Client.

12.2 .2 Fee Def in i t ion
From the Calypso Navigator, navigate to Configuration > Fees, Haircuts, & Margin Calls > Fee Set Up (menu action
refdata.FeeSetUpWindow) to open the Fee Configuration window.
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Sample account fee config

» Enter a configuration name and set the fee parameters as needed. They are described below.

» Then click Add to add an entry to the fee. It brings up the Formula Definition dialog. It is described below.

» Click to save the configuration. The configuration will be used when the FeeConfig calculator is set on a
Billing Grid, based on the selected filters.

Note that if the Authorization mode is enabled, an authorized user must approve your entry.

You can also click to bring up the Browse panel for loading existing configurations.

References
These parameters are used to compute the fee.

Fields Description
Config ID ID of the configuration given by the system upon saving.

Name Enter a configuration name.

Config Type Select "Billing Fee" to generate invoice fees.
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Fields Description
Rule Type Select the reference amount unit:

• Maintenance - (Number of transactions, Trade notional)

• Safekeeping - (Market position)

• CashSafekeeping - (Cash market position)

 Ⓘ [NOTE: These rules only apply to account management fees generated by the ACCOUNT_
BILLING scheduled task on inventory positions]

Scale By Select the reference amount of the fee:

• For Maintenance, you can select Count, Notional, or ConvNotional (Trade Notional converted to
the fee currency)

• For Safekeeping, you can select Average position (AvgMktPos), or End of Period position
(EopMktPos).

Range by
Tenor

Check to set the fee range by tenor, or clear to set the fee range by number of days.

Range by
ResidualMat

Check to set the fee range by residual maturity, or clear to set the fee range by product.

Tiered Only applies to Maintenance fees.

Check to indicate that the reference amount is distributed over the range, rather than applied to the
absolute range.

For example, you have the following range:

• 0 to 1,000 - Fee rate is 10%

• 1,000 to 5,000 - Fee rate is 5%

• 5,000 and up - Fee rate is 2%

The reference amount is 7,000.

• For the non-tiered method, the fee rate is 2% (5,000 and up range).

• For the tiered method, the fee rate is 10% for the first 1,000 - Then 5% for the next 4,000 - Then 2%
for the remaining 2,000.

Event Type Select the event type:

• For Maintenance, you can select Account or MaintenanceTrade (transactions on the account).

• For Safekeeping, you can only select Account.

 Ⓘ [NOTE: MaintenanceTrade events are only generated in the context of the Clearing module -
They rely on trade keywords specified in the Clearing module - Refer to Calypso Clearing
documentation for details]
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Fields Description
Fee
currency

You can select a fee currency, or leave empty for ANY.

Conversion Check if you want to convert the fee using the FX rate at the end of the billing cycle. It is converted
using the fee date FX rate otherwise.

For computing the converted fee at the end of the billing cycle, you need to run the scheduled task
EOD_REBATE_FEE.

See Conversion Process for details.

Select the pricing environment for loading the FX rates. If not set, the pricing environment defined in
the Billing engine will be used.

Day Count Select a daycount as needed.

Effective
From

Enter the effective start date of the configuration.

Effective To Enter the effective end date of the configuration (optional).

Description Enter a free form description as needed.

Rebate
Not applicable for account fees.

Filtering
These parameters are used to determine the conditions of application of the fee. You can use pre-defined filtering
criteria, or a filter template.

Pre-defined criteria:
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Fields Description
Processing
Org

Select a processing organization as needed, or ALL.

Legal Entity Select a legal entity of specified role, or ALL.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Exchange Select one or multiple exchanges (legal entity of role MarketPlace), or leave empty for ALL.

Product
Type

Select one or multiple product types, or leave empty for ALL.
Product groups are identified as "G. <group name>" and are created using Configuration > Product >
Group.

Security ID Enter one or multiple product IDs (separated by commas), or leave empty for ALL.

Book Select one or multiple books, or leave empty for ALL.

Book Attr Select one or multiple book attribute / attribute value, or leave empty for ALL.

Currency Select one or multiple currencies, or leave empty for ALL.

Account ID Only applies to account management fees.

Fee Date Only applies to account management fees.

Calc Period
End Date

It is a Date Rule only applies to Rule Type: Safekeeping and CashSafekeeping. When populated, the
amount is computed from the previous date before the current value date.

SD Filter Select a static data filter as needed, or leave empty.

Filter template:

» To add a new filter template, choose > Filter category > Add. You will be prompted to enter a filter category
name. Enter a name and click OK.

» Then choose > Filter fields template. You will be prompted to select a filter category previously created, and
to select the filter criteria you want to use.

Nasdaq Calypso
Nostro Management / Version 18



Fields Description
Filter Category Select a filter template previously created.

Role Select a role.

Fee Type Enter the fee type - The fee type must be defined in the Fee Definition window.

Filter Template Criteria Select the values for the filter criteria defined in the filter template.

In this example, the filter template contains the filter criteria Book.

Formula Definition
Click Add to bring up the Formula Definition dialog.

Sample formula

» Enter the parameters to define the ranges of the fee. They are described below.
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» You can type in the formula, or double-click variables and operators to add them to the formula. Only the
displayed variables and operators can be used in the formula.

» Click OKwhen you are done.

Fields Description
Min
Amount

Max
Amount

Enter the minimum and maximum amounts of the range. It refers to the reference amount defined by the
Rule Type and Scale By parameters: Count, Notional, AvgMktPos, or EopMktPos.

No value is considered as 0 for the minimum amount, and infinite for the maximum amount.

The minimum amount is inclusive.

The maximum amount is non inclusive.

Min Tenor

Max Tenor

Min Days

Max Days

You can also select a minimum tenor and a maximum tenor to scale the fee rates by product maturity
("Range by ResidualMat" is not checked), or by residual maturity ("Range by ResidualMat" is checked).

 Ⓘ [NOTE: For products without maturity date, the fee rates are scaled by settlement date
instead]

The minimum tenor is inclusive.

The maximum tenor is non inclusive.

If "Range by Tenor" is not checked, you can enter a number of days instead of selecting a tenor.

Calc Unit Enter a calculation unit when defining a fee expressed as an amount per unit.

For example 2 per million of notional: Calc Unit = 1000000 and Formula = 2*UnitNotional.

Variables You can use the following variables in the formula depending on the selected reference amount:
Quantity, Price, ContractSize, FaceValue, UnitNotional, Notional, ConvNotional (Trade Notional
converted to fee currency), Markup, Count, AvgMktPos, EopMktPos, CumulPos.

AvgMktPos only takes business days into account.

The Markup allows setting a markup percentage per legal entity. You can define the legal entity attribute
"Client Markup" and set a markup percentage on the attribute. For example, Client Markup = 120 for
120%. The Markup variable in the formula will be multiplied by 120%.

The CumulPos is the cumulated balance from the business days of calculation period start date until
current value date, quoted at current value date.

Operators You can use the following operators in the formula: Subtract(-), Multiply (*), Add (+), Divide (/), Absolute
Value, Max, Min, Round, Round Up, Round Down.

 Ⓘ [NOTE: If the fee is always paid, the formula should be defined as an absolute value]

Sample Fee Config for Cash Position
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Sample Fee Config for Client Position

12.3 Defining a Fee Bi l l ing Rule
The billing rule allows defining the billing frequency, and a billing threshold if needed.

Define the Billing rules using Configuration > Fees, Haircuts & Margin Calls > Fee Billing Rule from the Calypso
Navigator (menu action refdata.FeeBillingRuleWindow).
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Sample billing rule for account fee

» Enter the following fields:

– Select a legal entity, or double-click the Legal Entity label to set the legal entity to ALL.

– Select the same role as in the billing grid.

– Select the billing currency or ANY.

– Select the billing date rule to determine the billing frequency.

– Select the settlement date rule to determine the settlement frequency of the fee.

– Select the transfer type of the billing trade as needed. If not set, the transfer type is set to INTEREST. Note
that transfer types are defined in domain “flowType”.

 Ⓘ [NOTE: If the attribute EntryType is set, and the Default Transfer Type is not set, the transfer type defaults
to the EntryType]

» You also need to define the following attributes - This only applies if you have selected the FeeConfig calculator
in the Billing Grid.
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– BillingOnly - Set to True so that it is only used for billing trades.

– EntryType - Set to the fee type ,"ACCMGTFEE" for example.

– XferByBook - Set to True to create a transfer by book.

– BillingFeeFullPeriod - Set to True to have a single billing fee.

– MatchSecurity - Set to True to create a new billing trade when the Security Id is different. This is applicable
only when 'split by security' is selected.

» Save the billing rule.

12.4 Generat ing Account Fees
The Billing engine is used to generate the billing fees.

12.4 .1 B i l l ing Engine Conf igurat ion
The Billing engine is configured in the Engine Manager of Web Admin: event subscription and engine parameters.

You may need to add this engine if it is not available for configuration: Create a new engine called BillingEngine, with
class name com.calypso.engine.billing.BillingEngine.

The Billing engine can subscribe to the following events: PSEventAccountBilling and PSEventMaintenanceTrade –
This type of event is generated by the ACCOUNT_BILLING scheduled task for accounts that have the Billing checkbox
checked.

The behavior of the Billing engine may be modified with the following engine parameters.

If a parameter is not available for setup, you can register it in the domain "engineParam".

Parameters Description
BILLING_NOAMEND_
EXCEPTION

True or false. Default is true.

When set to false, no exception is generated when the AMEND action is not available on the
workflow of the existing Billing trade.
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Parameters Description
IGNORE_ACTION Comma-separated list of trade actions to be ignored by the engine.

MAX_BATCH_EVENT Maximum number of persistent events loaded at one time by an engine in batch mode. The
engine will load events in MAX_BATCH_EVENT chunks until all events are processed.
Persistent events received after MAX_QUEUE_SIZE is reached will be processed in batch
mode.

Allows controlling engine memory usage, therefore improving the performance.

MAX_QUEUE_SIZE Maximum number of events buffered on an engine event queue.

When this number is exceeded, real time events are discarded and the engine restarts
based on the restart timer (TIMEOUT_RESTART), in order to process the unprocessed
persistent events using batch mode. This parameter can be useful for controlling the
engine’s memory usage. If not set, the default value for this parameter is no limit on queue
size.

Allows controlling engine memory usage, therefore improving the performance.

PricingEnv Pricing environment used by the engine. If not set, the default Pricing Environment of the
user running the engine will be used.

TIMEOUT_RESTART Number of seconds to wait before an engine restarts after MAX_QUEUE_SIZE has been
reached. The default value is 3600 seconds (1 hour).

12.4 .2 Start ing the Bi l l ing Engine
The Billing engine can be started from the Engine Manager in Web Admin.

Please refer to Calypso Web Admin documentation for complete details.

12.4 .3 Generat ing Account B i l l ing Events and Bi l l ing Fees
Account billing events and trade maintenance events are generated by the scheduled task ACCOUNT_BILLING.

From the Calypso Navigator, navigate to Configuration > Scheduled Tasks (menu action
scheduling.ScheduledTaskListWindow), and select the type ACCOUNT_BILLING.

Select a trade filter, a user, a pricing environment, and a processing organization.
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» Enter the attributes below as applicable:

– ACCOUNT NAME – Enter the account name to reduce the scope of the Scheduled Task or leave blank.

– LEGAL_ENTITY – Enter the Legal Entity short name to reduce the scope of the Scheduled Task or leave
blank.

– SD_FILTER – Select a specific SD Filter to reduce the scope of the Scheduled Task. Note that this SD Filter
currently works only if you specify data directly related to the account definition.

– CHECK FEE CONFIG - Select true to check if you have specified fee configuration for account fees, or false
otherwise.

– PROCESS - Only applies if CHECK FEE CONFIG is true - Select Account to generate account billing events,
or Maintenance Trade to generate trade maintenance events.

– Inventory Type - Select Cash or Security.

For Cash, the fee should have Rule Type = CashSafekeeping.

– Balance Type - Enter the balance type as needed.

» Save and run the scheduled task.

 Ⓘ [IMPORTANT NOTE: The Billing engine should be running in order for the billing fees to be generated]

From the Calypso Navigator, navigate to Processing > Accounting Operations > Billing > Trade > Open to view
billing trades. It opens the trade selector. Click Show Trades to view all billing trades. Double-click a trade to view its
details.
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You can view the details of the fees in the Billing Fees panel.

12.4 .4 Convers ion Process
Conversion entries are generated using the scheduled task EOD_REBATE_FEE .

The conversion process converts the fee using the FX rate at the end of the billing cycle.

The scheduled task EOD_REBATE_FEE must be run daily. It retrieves the billing trades for which the end date falls on
the scheduled task valuation date.

The system creates new billing entries of type REBATE to book the difference between the billing fee amount
originally computed and the billing fee amount computed at the end of the period, once the actual FX rate is known.
There is one REBATE billing entry per trading book.

You can set the book attribute "Rebate Book" on the book of the original billing trade to book the rebate fee in the
rebate book. If this book attribute is not set, the rebate fee is booked in the same book as the original billing trade.
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Sample EOD_REBATE_FEE scheduled task setup

You need to set the following attributes:

• Contract Fee = False.

• Process = Conversion

• APPLY ACTION - It is possible to specify the action to be applied in the scheduled task. For example, the billing
trade could stay in PENDING status during the billing period and move to VERIFIED status once the rebate is
computed, if any. This could be achieved by setting the action to AUTHORIZE for example.

• LegalEntity - You can enter a legal entity ID as needed.
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13. Cash Sweeping
Treasurers, as part of their daily activity, need to optimize their liquidities by managing many accounts in different
banks, while minimizing fees (like overdrafts and commissions) and moving excess amounts to accounts which offer
the best conditions.

Banks can also provide similar facilities to their clients and offer automatic DDA (Direct) transfers depending on pre-
defined rules. Those transfers can be done automatically through the scheduled task TARGET_BALANCE (cash
sweeping on account basis) or through the scheduled task ACC_BOOK_SWEEPING (cash sweeping on book basis).

Both activities are managed through the Account Sweeping Configuration window and the scheduled tasks which
provide:

• The ability to automatically move cash from one/several account(s) or book(s) to another

• A completely automated process via a scheduled task

• The ability to partially automate the process (i.e. a scheduled task/report which allows modifying account
sweeping choices)

This process is based on the Inventory position. The result is the generation of:

• Transfer Agent trades (for Nostro Sweep)

• Simple Transfer trades (for Client Account Sweep)

• Customer Transfer trades (Call Accounts)

13.1 Setup

13.1 .1 Domain Values
Add value ACCOUNT_SWEEPING to domain "flowType".

13.1 .2 Account Sweeping Conf igurat ion
From the Calypso Navigator, navigate to Configuration > Accounting > Sweeping (menu action
refdata.AccountSweepingConfigWindow), or from the Account window choose Utilities > Sweeping.
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In the Config Detail section:

» You can select a config type - Config types are defined in domain "AccountSweepingRuleType".

For Active Sweeping configs (triggered manually from the Inventory Position), set Config Type = Internal.

For Passive Sweeping configs (triggered by the incoming statement MT940), set Config Type = External.

» Use the Priority field to manage “cascades” of sweepings. The lowest priority is 0.

» Use the Active From/To fields to indicate that the rule is available between these dates. It allows you to manage
changes in the rules and to enter new rules in advance.

» The Balance Type is only available for "By Book" with Usage = Target Balance. It allows sweeping custom
balances between a source account and its sweeping sub-account.

See Custom Position Type for information on setting custom balances.

See Inter PO Sweeping below for more details.

» Select the transfer type ACCOUNT_SWEEPING - Transfer types are defined in domain "flowType".

Intraday Config
You can check "Intraday Config" to define a kickoff time and a cutoff time in a given timezone.
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» Select a timezone, enter a kick-off time, and a cut-off time as needed.

The configuration will only be applicable within the Kick Off / Cut Off period.

If multiple configurations apply to the same account, the Kick Off Time / Cut Off Time must be exclusive, and
expressed in the same timezone. For example:

• Account A swept to Account B - Kick Off Time = 00:01AM / Cut Off Time = 04:00PM TimeZone = Europe/London

• Account A swept to Account C - Kick Off Time = 04:01PM / Cut Off Time = 00:00AM TimeZone = Europe/London

 Ⓘ [NOTE: The PO must be the same for the source account and the destination account, except for Inter PO
Sweeping, see below]

Source Section

» Click to select the accounts to be transferred. You can configure the columns of the display as needed.

Note that you cannot add an account which is part of another sweeping rule.

You can double-click an account to open the Account Definition window.

If you select multiple accounts, you can check Aggregate to generate one sweep transfer for all the selected
accounts. Otherwise, one sweep transfer is generated for each account.

If you check "By Book", you can select a book and book attributes to sweep only the related cash. When "By
Book" is checked, you can also select the Usage:

– "Target Balance" - To use the TARGET_BALANCE scheduled task to process the sweeping (see TARGET_
BALANCE scheduled task below). It generates simple transfer trades on the source book and the
destination book rather than transfer agent trades.

– "Acc Book Sweeping" - To use the ACC_BOOK_SWEEPING scheduled task to process the sweeping

Destination Section
» Click ... next to the Account field and select a Settle Account using the Account Browser. It will be the destination

account of the sweeping transfer.
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This Account cannot be part of the Source Account(s) if the rule is related to single Account(s) e.g. single
sweeping account or rule to “Apply to each account” (checkbox). Click the heading (displayed in blue) to reset
the field.

» Select a book as needed for the transfer trades.

The destination book is used only if its legal entity is the same as the Account Processing Org. But it is not used if
its legal entity is a child of the Account Processing Org.

You can set book attribute CheckParentForSweeping = true on the destination book - In this case, the book legal
entity can be a child of the Account Processing Org.

» Select a pivot account as needed - This only applies if the sweeping rule is related to a group of accounts. The
pivot account must be one of the selected accounts.

Threshold Section
» Enter the maximum and minimum limits and amounts you wish to achieve. You need to specify at least a minimum

balance or a maximum balance.

» Enter the rounding base of the transfer amount in the Tick field so that:

Rounded transfer amount = ceil(transfer amount / tick) * tick

(ceil rounds the decimal value to the next upper integer)

Note that the tick cannot be signed.

Example - If you want to round to the next 50 dollars, set tick = 50. 243 will be rounded to 250.

» Enter the minimum transfer amount. This amount cannot be signed.

When a Sweeping rule is set up for a group of accounts, the following scenarios may apply:

• If "Aggregate" is checked, the process applies the rule to the aggregated position of all the accounts:

– If a Pivot account is selected, the transfer is generated with this account, regardless of the balance of each
account.

– If no Pivot account is selected, the transfer is generated with the account which has the most “interesting”
amount: greatest creditor balance in case of maximum to apply or greatest debtor balance in case of
minimum to apply.

• If "Aggregate" is not checked, the process applies the rule to each account individually:

– If a Pivot account is selected, several transfers can be generated between all the accounts composing the
group. The final transfer is generated between the Pivot account and the Destination account.

– If no Pivot account is selected, all the transfers are generated with the Destination account.

Intra PO Sweeping
The PO is the same but the accounts and books are different.
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The recommended setup to perform Intra PO Sweeping is "By Book" with Usage = Target Balance.

It performs sweeping between the source account / source book and destination account / destination book using
two simple transfer trades on the source book and the destination book.

The TargetAccountId and RelatedAccountId trade keywords are populated and allow selecting specific SDIs.

Inter PO Sweeping
The POs, accounts and books are different.

The recommended setup to perform Inter PO Sweeping is "By Book" with Usage = Target Balance, and Balance Type
= <custom balance>.

It performs sweeping between the source account / source book and destination account / destination book using
two simple transfer trades on the source book and the destination book.

The TargetAccountId and RelatedAccountId trade keywords are populated and allow selecting specific SDIs.

If the domain "ProcessingConfig" contains Value = Sweeping.SweepSubAccount.IsActive and Comment = true, a
transfer is generated for the custom balance between the source account and its sweeping sub account.

The sub account must be defined with PO = Destination PO, Legal Entity = Source PO, Role = Client and must be set
on the source account in the field Sweep SubAccount:

You also need to set INVENTORY_POSITION_CUSTODY_MODE = true so that the ClientAccount trade keyword can be
set to the sweeping sub account on the Simple Transfer trade of the destination book, in order to generate a transfer
on the sweeping sub account for the custom balance.

13.1 .3 Access Permiss ion and Author izat ion
The access permissions relating to account sweeping are: AddModifyAccountSweeping and
RemoveAccountSweeping. For further details on access permissions, please refer to the Calypso Security User
Guide.
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In order for Authorization mode to apply to sweeping configs, you need to add “AccountSweepingConfig” to the
domain “classAuthMode”.

13.2 Account Sweeping Process

13.2 .1 Account Sweeping by Account
The scheduled task TARGET_BALANCE creates a series of Transfer Agent trades to rearrange money across a set of
nostro accounts. The Scheduled Tasks window is accessed using Configuration > Scheduled Tasks from the
Calypso Navigator (menu action scheduling.ScheduledTaskListWindow).

It can also be used for sweeping configurations by book with usage "Target Balance" to create two Simple Transfer
trades: one for the source book / source account and one for the destination book / destination account.

The Account Sweeping rules will be applied by this Scheduled Task which will do the following:

• Retrieve the available Sweeping Account rules and order them by priority from the highest to the lowest

• Retrieve the balances of all accounts concerned

• Priority by priority and starting by the highest, calculate the amounts to apply

• Create trades Transfer Agent or Simple Transfer

• When an account is concerned with transfers coming from sweeping rules that have highest priority, these
transfers are taken into account in the calculated balance, before applying the sweeping rule.

Select a trade filter, a user, a pricing environment, and a processing organization.

Specify the following attributes as applicable:

• Config Type – Select a sweeping config type as needed, or NONE.

• Retroactivity – Select true or false. Setting this field to true means that in case of back valued transfers, the
sweeping process will generate Trade transfers related to the back valued amounts and dates, instead of the
process date.

• Position Source - Select "Inventory Position" for account sweeping.

• Position Type – Select the type of position to retrieve the balances: ACTUAL, THEORETICAL, FAILED.

• Position Class – Select in the list the Position Class: INTERNAL, EXTERNAL, CLIENT.

• Position Date – Select the type of position in the list: TRADE, SETTLE, VALUE, AVAILABLE.
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• Context Position Filter - Only applies to context position sweeping.

• Legal Entity – Enter the name of the Legal Entity or leave it blank for all Agents. The process will retrieve the
sweeping rules that have accounts with this legal entity only.

• Lock Accounts - True or false.

If “Lock Accounts” = true, the accounts used in the scheduled task cannot be used in manual sweeping. If another
process is already using those accounts, the scheduled task cannot use them, and an exception task is generated
for those accounts.

If “Lock Accounts” = false, there is no check for locked accounts.

• By Book - Only applies for sweeping configurations by book with usage "Target Balance". Select True for such
configurations.

In this case, it creates two Simple transfers: One trade for the source book / source account and one trade for the
destination book / destination account.

The transfer amount is calculated as follows:

• If a tolerance amount is set-up, no transfer is generated when the balance is between the Minimum Balance or
Maximum Balance and its Tolerance amount.

• If the Balance is greater than the Maximum Balance + Tolerance, then

Transfer Amount = Maximum Balance – ABS(Balance)

• If the Balance is less than the Minimum Balance + Tolerance, then

Transfer Amount = Minimum Balance – ABS(Balance)

• The amounts are rounded to the nearest taking into account the Minimum and the Tick.

This process is based on the Inventory position. The result is the generation of:

• Transfer agent trades for Nostro Sweep

• Simple transfer trades for Client Account Sweep

• Customer transfer trades for Call Accounts
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From the Calypso Navigator, navigate to Processing > Accounting Operations > Transfer Agent > Trade > Open to
view the Transfer Agent trade.

It opens the trade selector.

» Click Show Trades to view all transfer agent trades.

» Double-click a trade to view its details.

The transfer type is ACCOUNT_SWEEPING and the linked Id is the Account Sweeping Configuration.

13.2 .2 Context Pos i t ion Sweeping
Sweeping context positions is only supported for sweeping configurations by account.

The scheduled task TARGET_BALANCE allows sweeping context positions using the following attributes:

• Position Source - Select "Context Position" for context position sweeping.

• Context Position Filter - Enter the name of a context position filter.
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It generates Transfer Agent trades between the accounts defined in the sweeping configuration. The transfer type is
ACCOUNT_SWEEPING and the linked Id is the Account Sweeping Configuration.

Additionally, context position sweeping can be done via the Calypso Workstation from a Cash Ladder report. Up to
two accounts may be selected. Right-click on the row to choose between Actual and Theoretical sweeping, then click
Sweep.

13.2 .3 Account Sweeping by Book
The scheduled task ACC_BOOK_SWEEPING will select all sweeping configurations flagged "By Book" and process
them in two steps:

• The system will first create Transfer Agent trades to put all account/book positions to 0, using the trading book of
the position.

• Then the system will maintain the min/max defined on the sweeping configuration using the destination book.

Select a trade filter, a user, a pricing environment, and a processing organization.

Specify the following attributes as applicable:
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• Config Type – Select a sweeping config type as needed.

• Book Position Type – Select the position type (ACTUAL or THEORETICAL for example) that needs to be set to 0.

• Position Type –Select the position type (ACTUAL or THEORETICAL for example) to be used to maintain the
min/max amounts.

• Book Position Date – Select the position date (TRADE or SETTLE for example) to be used to put the book/account
balance to 0.

• Position Date – Select the position date (TRADE or SETTLE for example) to be used to maintain the min/max
amounts.

• Legal Entity – Enter the name of the Legal Entity or leave it blank for all Agents. The process will retrieve the
sweeping rules that have accounts with this legal entity only.

• Config Id – you can select a config id to run the scheduled task for a single config.

It is possible to define a specific trade workflow (or workflow transition) for the transfer agent trades created from the
account sweeping process using a static data filter based on the attribute "KEYWORD.TradeSource" IN
AccountSweeping.

13.3 Active Sweeping vs. Passive Sweeping
Active Sweeping configs (triggered manually from the Inventory Position) have to be defined using the Config Type =
Internal.

Passive Sweeping configs (triggered by the incoming statement MT940) have to be defined using the Config Type =
External.

An example is presented below. Please note that when the same account belongs to two account sweeping configs
(one active/one passive), you must set a higher priority for Config Type = External.

Example with the following scenario:

• GUARFEES-EUR account is passively (External) swept to LOCAL-EUR account - Since LOCAL-EUR account is
involved in another sweeping config, the priority set on the External sweeping config is higher than the one
defined as Internal.
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• LOCAL-EUR account is actively (Internal) swept to MASTER-EUR account.

• B2-EUR account and B2LOCAL-EUR account are passively swept (External) to MASTER-EUR account
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You can perform manual sweeping from the Inventory Position report.

Configure the columns as follows:

• Add the columns "Sweeping Hierarchy.1" and "Sweeping Hierarchy.2" to the display.

• Add those columns to the sort columns and to the grouping columns.

• Display the results by Aggregation (View > Set Table > Aggregation).

• Set subtotals by Dates.

To sweep an aggregation node, select the node's subtotal, right-click and choose Process > Pool Consolidation.

You will be prompted to select an account sweeping configuration:
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» Select a configuration and click Next.

The Account Pooling Consolidation window is displayed.

Check "Apply Sweeping" for the account sweepings you want to process.

You can check "LastSweeping" to prevent the creation of additional sweeping trades for the same accounts and
the same date, including from the scheduled task TARGET_BALANCE. It sets the trade keyword
LastSweeping=true on the sweeping trades.

Click Next to process the account sweeping.

You can view the sweeping trades from the Trade Browser.
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14. Settle Accounts Dormant Process
The scheduled task ACCOUNT_DORMANT moves an account to the Dormant status if there is no activity (except
interest capitalization) for the last year (or using the "From Days" field) based on the "last movement date". It can also
be used to re-activate a dormant account.

To activate the dormant process for settle accounts, you need to add the transfer workflow rule SetAccountMvtDate
on the "SETTLE" transition in the transfer workflow. It sets the "last movement date" each time an account is debited /
credited as the Last Calendar Day of the month of the settle date of the transfer when the movement is settled.

The "last movement date" is displayed in the Account window.

A user can amend this date provided the user has the access permission UpdateAccountDormantDates.

You also need to set the account attribute DORMANT_ELIGIBLE = true on the settle accounts for which you want to
apply the dormant process.

When attribute DORMANT PROCESS = true, the system checks the CLIENT-ACTUAL-SETTLE position for which
Agent Id = Account PO Id. If the position is short, the account is ignored from the dormant process and its status does
not change.

Scheduled task attributes:

• DORMANT PROCESS - true or false. Select true to run the Dormant process, and false to run the re-activation
process.

• ACCOUNT STATUS - Resulting status of the process (Dormant if DORMANT PROCESS is true, or Active if
DORMANT PROCESS is false).

• DORMANCY TASK - true or false. Select true to run the Dormant process in Authorization mode. It will create an
authorization task.

You can use Process > Dormant Process > Accept Dormancy to accept the authorization task, if any, or Process
> Dormant Process > Reject Dormancy to reject it.
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• ACCOUNT TYPE - Select SETTLE_ACCOUNTS.

You can use Process > Dormant Process > Re-Activate to re-activate a dormant account.
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15. Viewing Account Activity
The Account Activity report shows the activity that occurs on a given client / nostro account including:

• The balances – Positions computed by the inventory engine

• All the transfers on behalf of a given client or against a given nostro account

• The interest computed on the balances

From the Calypso Navigator, navigate to Reports > Nostro/Custodian Positions > Account Activity.

Partial picture of Account Activity report

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Enter selection criteria and click .

You need to select the position criteria: Position Date, Position Class, and Position Type.

Select the Position Detail:

– Start/End – Displays the start and end balances, and the activity between the start and end dates.

– Daily – Displays daily balances and activity.

– Monthly – Display the start and end balances, monthly balances, and the activity between the start and end
dates.

You can select multiple processing organizations and accounts, and check “Detail by Account” to show the
opening /closing balances and movements by account.

You can select a custom aggregation config as needed, and you can specify the individual criteria.

[NOTE: You can only select a custom aggregation config if you have configured the Inventory engine to compute
custom positions – Refer to Calypso Inventory Engine documentation for details]
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Under the "Detail by Account" checkbox, you can select an Account Selector template as needed. When
selected, the underlying accounts are loaded.

You can click ... next to the drop down list to define Account Selector templates. It opens the Account Selector
Templates window where you can manage the templates.

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

» You can select the checkbox "Base Amount as of Value Date" as needed.

When checked, the following transfer fields are calculated based on the exchange rate for the Transfer Value
Date.

- Money Amt (Base)

- Real Cash Amt (Base)

- Xfer Money Diff (base)

When unchecked, the transfer fields are calculated based on the exchange rate of the valuation date set in the
report.

Activity Results
You can select a balance row and choose Process > Project Interest to compute the interest between the date of the
selected balance and a To Date. You will be prompted to select a To Date.

The Interest Amount is the projected amount for a given balance.

The Real Interest Amount is based on the Interest Bearing trades that have been generated for a given balance. The
columns Real Interest Amount and Total Real Interest Amount are calculated only when a single account is selected
for performance purposes.
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The Available Balance is the Balance + Overdraft Limit on the Account.
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16. Stock Record Report
The Stock Record report shows Long and Short positions in each CUSIP, based on the inventory positions computed
by the inventory engine. Long positions represent ownership or ‘source’ of securities, and Short positions represent
location or ‘use’ of securities. The sum of the Long positions in a given CUSIP should always exactly equal the sum of
the Short positions in that CUSIP.

Stock Record positions can arise from ANY securities activity, including (but not limited to) all of the following:
Purchases and Sales, Repos and Reverse Repos, Securities Lending vs Cash, Securities Lending ‘Free’, Securities
Lending vs Collateral, Buy/Sellbacks, Pledges, Free Deliveries of securities, etc.

Stock Record positions are settlement date positions - All trades/transactions with a ‘value date’ greater than the
current business date will be ignored.

From the Calypso Navigator, navigate to Reports > Nostro / Custodian Positions > Stock Record Report (menu
action reporting.ReportWindow$NewStockRecord) to bring up the report.

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» You can change the pricing details at the bottom of the window - By default, the pricing environment comes from
the User Defaults, and the valuation date is the current date and time.

» Enter search criteria as needed and click .
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By default, the report loads the full version, including every CUSIP in which a non-zero position exists.

You can check "Exception Report" to load only those CUSIPS where there is a "break" (the total of the LONG
positions does not equal the total of the SHORT positions).

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Each Stock Record position can be categorized as being one of the following types.

FIRM P/S Position
This represents a Firm Position resulting from P/S trades. Firm P/S positions may be either Long or Short. They are
computed by the inventory engine: THEORETICAL positions.

Firm securities (i.e. those owned by your firm) are fungible and shown by book.

FAIL Position
This represents a position of transfers in Failed status.

It is identified by FTD (failed to deliver) and FTR (failed to receive).

COLLATERAL Position
A collateral position is represented by individual financing trades (Repo, Reverse Repo, etc.), as well as margin call
positions computed by the inventory engine.

Note that for netted GCF Repo positions, the book is set to GCF - Original GCF Repo trade positions (i.e. against the
GCF Generic CUSIPS) are EXCLUDED from the Stock Record.

BOX Position
Position at a Depository (‘Agent’) Account computed by the inventory engine: ACTUAL positions.

See Inventory Position for information on computing inventory positions using the inventory engine.
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17. Securities Filter
The Securities Filter allows defining search criteria to filter bonds.

You can save the filter, it will be saved as a Bond Report template that can be used anywhere a Bond Report template
can be used.

» Enter search criteria in the Properties Filter panel and Sec Codes Filter panel as applicable. Then click Apply to
apply the search criteria and load the corresponding bonds.

» You can click Save to save the filter as a Bond Report template. You will be prompted to enter a filter name.

The Template menu allows loading / saving bond report templates.

Nasdaq Calypso
Nostro Management / Version 18

April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 180 / 192



April 2025
Revision 11.0 / Approved

Proprietary and Confidential
Page 181 / 192

18. Capturing Simple Transfer Trades
From the Calypso Navigator, navigate to Processing > Accounting Operations > Simple Transfer configure transfer
agent trades as shown below for a Cash transfer (menu action trading.TradeWindow$SimpleTransfer).

Simple Transfers allow users to exchange cash or security between two entities. These entities can be internal (two
Processing Organizations, two clients), or external (one Processing Organization versus an external counterparty, or
one Client versus an external entity).

Simple Transfer Quick Reference

- Enter transfer details in the Trade panel

- Hit F5 to save the trade

18.1 Capturing Simple Transfers
When you open a Simple Agent worksheet, the Trade panel is selected by default.

18.1 .1 Enter ing Trade Deta i ls
» You can select a template from the Template field to populate the worksheet with default values. Then modify the

fields as applicable.

See Simple Transfer Menu for information on saving templates.

Or you can enter the trade fields directly. They are described below.

» Proceed to the other panels as applicable.

18.1 .2 Sav ing a Trade
» Hit F5 to save the trade, or choose Trade > Save.

You can also hit F3 to save the current trade as a new trade, or choose Trade > Save As New.

A description appears in the title bar of the trade worksheet, a trade id assigned to the trade, and the status of the
trade modifies according to the workflow configuration.
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18.1 .3 F ie lds Deta i ls

Fields Description
To Click ... to select a legal entity of specified role – This is the receiver of the transfer.

The default role appears next to the To field. It is specified using Utilities > Set Default Role.
However, you can change it as applicable. Double-click the role to change it.

From Click ... to select a legal entity of specified role – This is the sender of the transfer.

The default role appears next to the From field. You can change it as applicable. Double-
click the role to change it.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
You can modify as applicable.

The processing org of the book identifies the processing org of the trade.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.

The status changes over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Id

Ext Ref

Int Ref

Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load an existing trade by typing the trade id into this field, and pressing [Enter].

You can also display the internal reference of external reference. The default trade
reference to be displayed can be selected in the User Defaults.

The internal reference and external reference can be set in the Details panel of the trade.

Trade Date Enter the trade date and time. It defaults to today.

Settle Date The settle date defaults to the spot date (number of spot days specified in the currency
defaults applied to the trade date).

You can modify the settle date as applicable.

Double-click the Settle Date label to adjust the settle date if the trade date is modified.

Pay/Receive Direction of the trade from the perspective of the From legal entity. Double-click the Pay
label to change to Receive as applicable.

Cash/Security Type of simple transfer. Double-click the Cash label to change to Security as applicable.

The rest of the fields will be different based on the Cash or Security.

Transfer Type Select the type of transfer.

Note that for a Security transfer, the transfer type must be set to SECURITY.

You can limit the list of transfer types by adding the transfer types you want to display to the
domain “SimpleTransfer.subtype”.

Linked Id Enter a trade id to which you want to link the simple transfer as applicable.
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Fields Description
Template You can select a template from the Template field to populate the worksheet with default

values. Then modify the fields as applicable.

Cash

Fields Description
Principal Enter the amount of cash to be transferred.

Currency Select the currency of the cash amount.

Security

Fields Description
Security You first need to select a security. Click ... to select the security.

The security currency will be displayed next to the SecCode field.

Quantity Enter the number of securities to be transferred, and the nominal will be computed
accordingly. Or enter the nominal.

Nominal Enter the amount of nominal to be transferred, and the quantity will be computed
accordingly. Or enter the quantity.

Price

Accrual

Dirty Price

Enter the clean Price of the security. The other fields will be computed accordingly.

SecCode Defaults to the security code specified in the User Defaults. You can select another product
code as applicable.

DAP Check the DAP checkbox if you want to associate an amount with the security transfer.

In that, case you can enter the following additional fields.

» Enter the DAP Cash Amount and select a settlement currency as needed. It defaults to
the bond’s currency.

» If the currency is different from the bond’s currency, you can enter the FX rate.

The transfer will be DAP only if the SDI handles DAP transfers for the selected settlement
currency (DAP_CCY attribute must be set to a comma-separated list of currencies, or ANY).

Returned Security

Pledged Security

Purpose of the transfer used in combination with the Pay/Receive direction for
confirmations.

Check the Returned Security checkbox OR the Pledged Security checkbox.

• Pay Pledged Security — pledging out a security.
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Fields Description
• Receive Pledged Security — taking in a pledged security.

• Pay Returned Security — giving back a security originally pledged to us.

• Receive Returned Security —taking back a security originally pledged out.

18.2 Simple Transfer Menu
The menu items of the Simple Transfer menu are described below.

Menu Items Description
Price (F4) To price the trade.

Solve (F9) The Solve function is not implemented by default. However, you can create a custom Solver.
Refer to the Calypso Developer’s Guidefor details.

Configure Results To configure the pricer measures for the Results panel. You will be prompted to select pricer
measures.

Save Result Config To save the pricer measures configuration.

Save As Template To save the trade as a template. You are prompted to enter a template name and specify
whether the template is private or public. Other users will not be able to use private
templates.

Delete Template To delete a template. You will be prompted to select a template.

Only the user who created a template (whether it is public or private) can delete it.

You can also delete templates using Utilities > Maintenance > Monitoring > Clean-up >
Clean-up Database - Products panel.

Please refer to Calypso Main Entry Utilities documentation for details.

Custom Product Data To open a custom data window provided product custom data are specified, and a custom
data window is implemented for this type of product.

Please refer to the Calypso Developer’s Guide for information on handling product custom
data.
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19. Capturing Transfer Agent Trades
From the Calypso Navigator, navigate to Processing > Accounting Operations > Transfer Agent to configure
transfer agent trades as shown below for a Cash transfer (menu action trading.TradeTransferAgentWindow).

A Transfer Agent trade is used to transfer Security or Cash from one Agent’s account to another. It is always carried
out from the perspective of the Processing Organization.

Transfer Agent Quick Reference

- Enter agent transfer details in the Trade panel

- Hit F5 to save the trade
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19.1 Sample Transfer Agent Trade

» Select the Processing Organization in the Cpty field and the book.

» Select the Transfer Type.

» Enter the Principal amount and the currency.

» Select the From and To agents. The corresponding SDIs will be displayed, along with the debited account (From)
and the credited account (To).

For SECURITY Transfer Agent trades, you can use a specific SDI for the external side.

You need to add the role POExternalParty to the PO.

On the PO SDI, set the SDI attribute POSdiExternalReference.

When SDI attribute POSdiExternalReference is set on the PO SDI, the system looks for an SDI with role
POExternalParty for the same PO and the same value of SDI attribute POSdiExternalReference for the external side
SDI.

Example:
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PO SDI

As POSdiExternalReference is set, the system looks for an SDI with role POExternalParty for the same PO and the
same value of SDI attribute POSdiExternalReference.

POExternalParty SDI
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19.1 .1 BO Browser
Once the Transfer Agent trade is entered and saved, you can view the transfers in the BO Browser by clicking Back
Office in the Details panel. You can also choose Back Office > BO Browser.

Select the Transfers panel to view the transfers.

 Ⓘ [NOTE: The Transfer engine should be running]
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19.1 .2 Trade Deta i ls

Fields Description

Cpty Displays the trading counterparty. The counterparty is a legal entity. The default role
appears next to the Cpty field. The default role is specified using Utilities > Set Default
Role. However, you can change it as applicable. Double-click the role to change it.

You can select a legal entity of specified role from the Cpty field provided you have setup
favorite counterparties. You can also type in a character to display the favorite
counterparties that start with that character. Favorite counterparties are specified using
Utilities > Configure Favorite Counterparties. You can also double-click the Cpty label.

Otherwise, click ... to select a counterparty of specified role from the Legal Entity Chooser.
You can also type [Ctrl-F] to invoke the Legal Entity Chooser.

Status Current status of the trade. The status is automatically assigned by the system based on the
workflow configuration.

The status changes over the lifetime of the trade according to the workflow configuration
and the actions performed on the trade.

Id

Ext Ref

Int Ref

Unique identification number of the trade. The trade id is automatically assigned by the
system when the trade is saved.

You can load a specific trade by entering the trade id in this field and pressing [Enter].

You can also load a specific trade by the external or internal reference. Select Ext Ref or Int
Ref, respectively, from the drop-down menu. Enter the reference in the adjacent field and
press [Enter] to load the trade.

Book Trading book to which the trade belongs. Defaults to the book selected in the User Defaults.
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Fields Description

You can modify as applicable.

You can also select a book provided you have setup favorite books. Favorite books are
specified using Utilities > Configure Favorite Books.

The processing org of the book identifies the processing org of the trade.

Template You can select a template from the Template field to populate the worksheet with default
values. Then modify the fields as applicable.

Cash / Security Double-click the Cash label to change to Security as applicable.

The fields are different for a cash transfer and for a security transfer. See Cash Transfer
Details and Security Transfer Details below.

Trade Date Enter the trade date and time. It defaults to today.

Settle Date The settle date defaults to the spot date (number of spot days specified in the currency
defaults applied to the trade date).

You can modify the settle date as applicable.

Double-click the Settle Date label to adjust the settle date if the trade date is modified.

Transfer Type For a cash transfer, you can select the transfer type.

For a security transfer, it is set to SECURITY.

You can limit the list of transfer types by adding the transfer types you want to display to the
domain “TransferAgent.subtype”.

Linked Id Enter a trade id to which you want to link the agent transfer as applicable.

Cash Transfer Details

Principal Enter the cash amount you want to transfer.

Ccy Select the currency of the cash amount.

Security Transfer Details

Security Click ... to select the security.

Nominal Enter the nominal of transferred security, and the quantity will be computed accordingly. Or
enter the quantity.

SecCode Defaults to the product code selected in the user defaults.

You can select another product code as applicable.

Product Codes are defined using Static Data > Reference Data > Product Code from the
Calypso Navigator.

Quantity Enter the quantity of transferred security, and the nominal will be computed accordingly. Or
enter the nominal.
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DAP Check the DAP checkbox if you want to associate a cash amount with the security transfer.

In that, case you can enter the following additional fields.

» Enter the Cash Amount and select a settlement currency as needed. It defaults to the
security’s currency.

» Check "Same side delivery" to deliver the cash amount in the same direction as the
security (Example: PAY Sec / PAY Cash).

The transfer will be DAP only if the SDI handles DAP transfers for the selected settlement
currency (DAP_CCY attribute must be set to a comma-separated list of currencies, or ANY).

Settlement Instructions

From

To

Select the From and To agents. The corresponding SDIs will be displayed, along with the
debited account (From) and the credited account (To). You can modify the SDIs as
applicable.

You can check the From or To "Msg" checkbox to send a message to the agent provided the
corresponding message setup is configured.

If From or To "Msg" checkbox is checked, a payment message can be generated for Role =
Addressee, provided the corresponding message setup is configured.

19.1 .3 Payment Message
The message template MT103XferAgent allows producing MT103 messages with tag 53B (Sender's Correspondent)
when “Msg” is checked in the SDIs.

You can use the message templates "Payment.selector” or "PaymentCOV.selector" otherwise.

Please refer to Calypso Settlements documentation for details.

19.2 Template Menu
The menu items of the Template menu are described below.

Menu Items Description
Save As Template To save the trade as a template. You are prompted to enter a template name and specify

whether the template is private or public. Other users will not be able to use private
templates.

Delete Template To delete a template. You will be prompted to select a template.

Only the user who created a template (whether it is public or private) can delete it.

You can also delete templates using Utilities > Maintenance > monitoring > Clean-up >
Clean-up Database, Products panel.
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Menu Items Description
Please refer to Calypso Main Entry Utilities documentation for details.
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