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1. V iew ing Invent ory Posi t ions

From the Calypso Navigator, navigate to Reports > Nostro/Custodian Positions > Inventory Position (menu action
reporting.ReportWindow$BOPosition) to review the inventory positions.

You can display real- time Inventory positions computed by the Inventory engine (nostro positions), or inventory
snapshots generated by the INVENTORY_SNAPSHOT scheduled task.

• Transfer and Inventory engines should be running to compute inventory positions.

• Liquidation engine should be running to perform Positions reconciliation.

• Margin Call engine should be running for collateral positions.

Refer to Calypso Cash Management documentation for details on generating inventory positions.

Refer to Calypso Collateral Management documentation for information on generating margin call positions.

Menus common to all reports are described under Help > Menu Items.

1.1 Re p o r t Ex am p l e
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Partial picture of Inventory Position report

The report shows two panels: Cash for cash positions, and Security for security positions.

Use one of the following methods to run the report:

» You can check / uncheck View > Show Frame > Criteria to display / hide the search criteria.

» Enter selection criteria at the top of the report window and click to load both cash and security positions. The
selection criteria are described below.

When you select the Cash panel, you can view selection criteria specific to cash positions only.

When you select the Security panel, you can view selection criteria specific to security positions only.

You can also click in each panel to only load the corresponding positions.

You can configure the columns of the report. See Help > Menu Items for details.

» You can also choose Report > Load Template, select a template then click Load.

» You can select a template and click to display the number of objects that will be loaded from the database
before loading the report.

» You can click to print the report results.

Note that for the Pivot view and the Aggregation view, the print icon is disabled.

You can use [Ctrl+P] or [Ctrl+L] to print the report, or you can export the report to Excel and print it from there.

Criteria Details

Criteria Description

Class

Type

Date

Click to add a combination of position class, type, and date.

You can select a combination of Internal, External and SnapShot positions (see Snapshot below
for details on selecting snapshots).

You can also select Client positions or Margin_Call positions. These positions cannot be
combined with other positions as the display fields are not compatible.

Posit ion Class

The following values are available:

• External – View positions imported into the system from external sources.
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Criteria Description

• Internal – View positions calculated by the Inventory Engine.

• Client – View client positions calculated by the Inventory Engine.

• Margin_Call – View margin call positions calculated by the Margin Call Engine.

• SnapShot – View positions from an inventory snapshot, provided you have selected an
inventory snapshot.

Posit ion Type

Click ... to select a position type. The following values are available:

• Actual – View the position of settled transfers, based on the real settlement date and real
settlement amount.

• Bank Confirmed – Cash position confirmed by bank statements MT940/MT950.

• Expected – View the positions based on the Available Date of the transfers when not
settled, else it is based on the Real Settle Date.

Refer to Calypso Cash Management documentation for details on the Available Date.

• Forecast – View the forecasted position of unknown transfers.

• Theoretical – View the positions of any transfers, based on the expected settlement date
and expected settlement amount.

• Not settled – View the positions of unsettled /failed transfers.

Refer to Calypso Cash Management documentation for details on failed transfers.

You can set the environment property KEEP_OPPOSITE_XFER_FROM_INVENTORY_DETAIL
to true to display both legs of a repo when both the start and end legs are failed. Only one
failed transfer is displayed otherwise.

Default is False.

• Statement – View the position of back-value movements and back-value failed movements
(transfer value date is before transfer settlement date).

• Rolled_Interest – Only applies to margin call interests rolled into "Margin_Call" positions.

Refer to Collateral Management documentation for details.

Posit ion Date

Select a position date. The following values are available:

• Trade – To load the position by trade date.

• Settle – To load the position by settlement date.

• Available – To load the position by available date. The available date applies to client
positions only. It defaults to the trade date but can be customized.

Snapshot
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Criteria Description

To select an inventory snapshot:

1. Click . You will be prompted to select a snapshot generated by the scheduled task
INVENTORY_SNAPSHOT.

2. Then select the Type and Date of the snapshot.

Please refer to Calypso Scheduled Tasks documentation for details on generating inventory
snapshots.

Start Date Enter the start date from which you want to see the positions. You may input a date in the past
or in the future.

End Date Enter the end date for the positions.

When holiday calendars are selected under Data > Configure Holidays:

• If Data > Calendar > Calendar is checked, the dates that correspond to business days
appear with a red background in the report results

• If Data > Calendar > Business is checked, the dates that correspond to business days are
removed from the report results

Use Tenor Check “Use Tenor” to use a tenor instead of an end date. The Tenors field will appear.
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Click ... to select tenors for which you want to see the positions.

You can now display the tenors as columns names by choosing Data > Tenors > Display
columns by tenor name.

You can also choose the following menu items:

• Data > Tenors > Roll Tenor to next date – When not selected and Calendar > Business is
selected, the Tenors that fall on business days are not shown. Example - If Tenor 3D is a
business day, the report will show 1D, 2D, 4D, etc.

When selected and Calendar > Business is selected, the Tenors are rolled and shown as
business days. Example - If Tenor 3D is a business day, the report will show 1D, 2D, 3D
(which represents 3 business days), 4D (which represents 4 business days), etc.

• Data > Tenors > End Of – This only applies to W, M and Y tenors for end of the week, end of
the month, end of the year. When not selected, 1W is Start Date + 7 calendar or business
days depending on Data > Calendar. Example – Sept 27 + 1W = Oct 4 in Calendar days and
Oct 6 in Business days.

When selected, 1W is the end of the week following the start date depending on Data >
Calendar – Example Sept 27 + 1W = Oct 3 in Calendar days and Oct 1 in Business days.

Template
Description

Displays the template description if a template has been loaded, and a template description is
set on the template. Template descriptions can be set using Configuration > Reporting & Risk
> Report Templates from the Calypso Navigator.

Books Click ... to select a set of books as needed. You can also enter a comma-separated list of books.

 Ⓘ [NOTE: Book names are case-sensit ive]

ProcessingOrg Click ... to select a set of processing organizations as needed. You can also enter a comma-
separated list of processing organizations.

 Ⓘ [NOTE: Processing organizat ion codes are case-sensit ive]

Include Child POs When checked, the positions of the child POs are included in the report, if any, when a PO is
selected.

Aggregation Select the aggregation level of the positions: Book/Agent/Account, Agent/Account, Agent,
Book, Client, ProcessingOrg, Global, or Book/Agent.

Currencies

Securit ies

The Currencies label on the Cash panel switches to Securit ies when you select the Security
panel.

Click ... to select a set of currencies for cash positions, or click ... to select a set of securit ies for
security positions.

Account Template You can select an Account Selector template as needed. When selected, the underlying
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Criteria Description

accounts are loaded.

You can click ... next to the drop down list to define Account Selector templates. It opens the
Account Selector Templates window where you can manage the templates.

Security Template On the Security panel, you can select a type of security template to be loaded:

• Bond – To select a Bond Report template.

• Equity – To select an Equity Report template.

• SecurityFilter – To create a security filter on- the- fly.

See Securit ies Filter for details.

• Warrant – To select a Warrant Report template.

Sec Code On the Security panel, you can select a security code and enter a value in the adjacent field to
select all securit ies with that security code value.

Include Issuances On the Security panel, you can check the "Include Issuances" checkbox to include issuance
trades.

SD Filter On the Security panel, you can select a static data filter to filter the securit ies that can be loaded
in the report.

Agent

Cpty Id

The Agent Id label switches to Cpty Id when the position class is set to Client or Margin_Call.

Click ... to select an agent / counterparty as applicable to view the positions for that agent /
counterparty only.

Account Id

Contract Id

The Account Id label switches to Contract Id when the position class is set to Margin_Call.

Click ... to select an account / contract as applicable to view the positions for that account /
contract only.

Agg. Config Select a custom aggregation config as needed.

You can then specify the individual criteria.

 Ⓘ [NOTE: You can only select a custom aggregat ion conf ig if you have conf igured the
Inventory engine to compute custom posit ions – Refer to Calypso Inventory Engine
documentat ion for details]

Sample Inventory Posit ion Report w ith Posit ions computed by Product Type
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You can configure aggregation related columns using Data > Configure Columns.

Position Value This only applies to security positions.

Select a position display value. The following values are available:

• Quantity – The Security panel displays quantit ies.

• Nominal – The Security panel displays current nominal values (based on the pool factor if
any).

• Nominal (Unfactored) – The Security panel displays original nominal values.

You can select the default amount by setting ONE of the following environment properties to
true: INV_QUANTITY, INV_NOMINAL, or INV_NOMINAL_UNFACTORED.

Custom Filter You can select a custom filter for filtering inventory positions.

To create a custom filter, create a class named apps.reporting.<filter_name> that
implements the interface com.calypso.apps.reporting.BOPositionFilter. Register the
filter name in the BOPositionFilter domain.

Sample in calypsox.apps.reporting.SecurityFilter.

Display Only
Multiple Agent

Select this checkbox to display only those positions that are held at more than one Agent.

Explode Position This only applies to security positions.

If you have created custom movement types and balance types, you can view the details of the
computation by checking the Explode Position checkbox.

In this example, we choose to display “Collateralized Movements”, the created “parent”
movement type, and check the Explode Position checkbox so that the details of the
computation are shown.

Alternatively, you can display the "parent" movement type, like "Collateralized Movement", and
clear "Explode Position". Then you right-click the position and choose Show > Explode Position
to display the details of the position. The Explode Position report can use templates named
"BOExplode_<template name>".
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Criteria Description

Aggregate Agg.
Config

Check "Aggregate Agg. Config" to aggregate custom positions.

For example, you have defined custom positions by product type, and selected the
corresponding Aggregation Config.

On the Security panel, you want to see the positions by product type, and on the Cash panel,
you don't want to see the breakup by product type.

You can check "Aggregate Agg. Config" on the Cash panel to aggregate the custom positions.

Position Direction Select All, Shorts or Longs.

If you select Shorts, you can check “Offset Pos.” to only show short positions for which there is a
long position available that can offset the short position. In this case, both the short position and
potential offset position are shown.

In this example, you can transfer the position from agent AGENT to agent CEDEL to cover part
of the short position on agent CEDEL.

Cash / Sec The following values are available:

• Both – The report displays both cash and security positions.

• Cash – The report displays cash positions only.

• Security – The report displays security positions only.

Movement Type Select the movement types you want to display.

Cash Posit ions

For Cash, the following values are available:

• Balance — Running balances - The net of all position components - Total net position,
based on all transfers

• Available Balance — Balances + Overdraft Limit on the account

• Movements — Balance on the start and end dates, and the movements in between

• Callable Balance = Usable Balance = Balance

Security Posit ions

For securit ies, movement types are more detailed based on the type of collaterals.

• Balance – Total net security position, based on all transfers

• Balance Collateralized In – Position based on transfers representing Reverse Repos and
LONG Margin Call positions

Nasdaq Calypso
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• Balance Collateralized In NON CA – Position based on transfers representing Reverse Repos

• Balance Collateralized In NON Substitutable – Position based on transfers representing
Reverse Repos and LONG Margin Call positions, where the securit ies are designated on the
trade as NOT substitutable

• Balance Collateralized In Substitutable – Position based on transfers representing Reverse
Repos and LONG Margin Call positions, where the securit ies are designated on the trade as
substitutable

• Balance Collateralized Out – Position based on transfers representing Repos and SHORT
Margin Call positions

• Balance Collateralized Out NON CA – Position based on transfers representing Repos

• Balance Collateralized Out NON Substitutable – Position based on transfers representing
Repos and SHORT Margin Call positions, where the securit ies are designated on the trade
as NOT substitutable

• Balance Collateralized Out Substitutable – Position based on transfers representing Repos
and SHORT Margin Call positions, where the securit ies are designated on the trade as
substitutable

• Balance In NON Substitutable – Position based on transfers representing Reverse Repos,
Pledges (In), Security Borrows, and LONG Margin Call positions, where the securit ies are
designated on the trade as NON substitutable

• Balance In Substitutable – Position based on transfers representing Reverse Repos, Pledges
(In), Security Borrows, and LONG Margin Call positions, where the securit ies are designated
on the trade as substitutable

• Balance Margin Call – Position based on transfers representing Security Margin Calls except
Triparty Allocations

• Balance Margin Call Non Rehypotheticable – The portion of the Margin Call Balance that is
designated as not able to be re-hypothecated

• Balance Margin Call Rehypotheticable – The portion of the Margin Call Balance that is
designated as able to be re-hypothecated

 See Margin Call Contracts documentation for details on re-hypotheticable collateral.

The Margin Call Rehypotheticable balance types will only be computed if the value
MarginCallInventorySec is set in the "InventorySecBucketFactory" domain.

• Balance NON Substitutable – The portion of the Balance that is designated as NON
substitutable

• Balance Out NON Substitutable – Position based on transfers representing Repos, Pledges
(Out), Security Loans, and SHORT Margin Call positions, where the securit ies are
designated on the trade as NON substitutable

• Balance Out Substitutable – Position based on transfers representing Repos, Pledges (Out),
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Criteria Description

Security Loans, and SHORT Margin Call positions, where the securit ies are designated on
the trade as substitutable

• Balance PayToHoldIn – Position based on transfers representing Security Borrows Hold (In)
and Pay to Hold (In)

• Balance PayToHoldOut – Position based on transfers representing Security Loans Hold
(Out) and Pay to Hold (Out)

• Balance Pledge – Position based on transfers representing Pledges

• Balance PledgedIn – Position based on transfers representing Pledges (In)

• Balance PledgedIn NON Substitutable – Position based on transfers representing Pledges
(In), where the securit ies are designated on the trade as NON substitutable

• Balance PledgedIn Substitutable – Position based on transfers representing Pledges (In),
where the securit ies are designated on the trade as substitutable

• Balance PledgedOut – Position based on transfers representing Pledges (Out)

• Balance PledgedOut NON Substitutable – Position based on transfers representing Pledges
(Out), where the securit ies are designated on the trade as NON substitutable

• Balance PledgedOut Substitutable – Position based on transfers representing Pledges
(Out), where the securit ies are designated on the trade as substitutable

• Balance Repo Callable In – Position representing open Reverse Repo trades

• Balance Repo Callable Out – Position representing open Repo trades

• Balance Buy Sell Back – Position based on transfers representing BSB Reverse Repos

• Balance Sell Buy Back – Position based on transfers representing BSB Repos

• Balance Repo Triparty – Position based on transfers representing Triparty Repos (Repos
and Reverse Repos) and Triparty Allocations

• Balance Repo Triparty In – Position based on transfers representing Reverse Triparty Repos
and Triparty Allocations (In)

• Balance Repo Triparty Out – Position based on transfers representing Triparty Repos and
Triparty Allocations (Out)

• Balance RepoTrackingIn – Position based on transfers representing Repos in securit ies
designated as subject to Repo Tracking

• Balance RepoTrackingOut – Position based on transfers representing Reverse Repos in
securit ies designated as subject to Repo Tracking

• Balance SecLending Callable In – Position representing open Security Borrows

• Balance SecLending Callable Out – Position representing open Security Loans

• Balance SecurityBorrowed – Position based on transfers representing securit ies borrowed
through Sec Lending Borrow trades, excluding Hold (Out) and Pay to Hold (Out)

Nasdaq Calypso
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• Balance SecurityBorrowed Collateral – Position based on transfers representing the
collateral leg on Sec Lending Sec Vs Sec Borrow trades

• Balance SecurityBorrowed NON Substitutable – Position based on transfers representing
securit ies borrowed through Sec Lending Borrow trades, where the securit ies are
designated on the trade as NON substitutable

• Balance SecurityBorrowed Substitutable – Position based on transfers representing
securit ies borrowed through Sec Lending Borrow trades, where the securit ies are
designated on the trade as substitutable

• Balance SecurityLent – Position based on transfers representing securit ies borrowed
through Sec Lending Loan trades, excluding Hold (In) and Pay to Hold (In)

• Balance SecurityLent Collateral – Position based on transfers representing the collateral leg
on Sec Lending Sec Vs Sec Loan trades

• Balance SecurityLent NON Substitutable – Position based on transfers representing
securit ies borrowed through Sec Lending Loan trades, where the securit ies are designated
on the trade as NON substitutable

• Balance SecurityLent Substitutable – Position based on transfers representing securit ies
borrowed through Sec Lending Loan trades, where the securit ies are designated on the
trade as substitutable

• Balance Simple Transfer – Position based on transfers representing Simple Transfers

• Balance Substitutable – Total net position, based on ALL transfers, where the securit ies are
designated on the trade as substitutable

• Balance SecurityBorrowed Auto / Balance SecurityLent Auto – Balances from "autoloan" sec
lending trades created from the integration of MT535 messages.

Refer to Calypso Message Matching for details.

• Balance Trading – Net position resulting from BUY and Sell trades

• Balance Triparty Margin Call – Position based on transfers representing Security Margin
Calls from Triparty Allocations

• Balance Unavailable – Net position resulting from Unavailability Transfer trades

• Movements – All security transfers between the start and end dates

Same movement types as balance types for the actual transfers.

Callable (Open) Posit ions

The scheduled task PROCESS_CALLABLETRADE allow rolling callable trades every day.

Subst itutable Posit ions

You also have the ability to identify whether the transfers that created the position are
substitutable or not.
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Criteria Description

In the example above, of the total of this Security taken in as Collateral (3,150,000) only
3,000,000 can be substituted out by the counterparty.

It is also possible to add custom movement types.

See Inventory Position - Process Menu for details.

Filter Zero Balance Select this checkbox to exclude dates from the report that have a zero balance.

Propagate to
Security

Propagate to Cash

When checked, which is the default behavior, the criteria saved in the template are the same for
both the Cash and Security panels.

When unchecked, both the criteria from the Security panel and the criteria from the Cash panel
are saved in the template.

Closing Bal. When checked, the following columns will be populated on the start date:

• Opening Balance – Balance carried the day before the start date

• Settled – Total movements on the start date

• Closing Balance – Sum of opening balance and settled on the start date

» Double-click on Opening Balance to show the trades that caused a movement on the
previous day.

» Double-click on Settled to show the trades that cause a movement on the start date.

» Double-click on Closing Balance to show the trades that cause a movement on the start
date (same as Settled).

Legal Ag. / Contract
Id

On the Security panel, you can select legal agreements and margin call contracts associated
with the trades (repo, security lending) to display corresponding information.

Filter Matured
Securit ies

On the Security panel, you can check "Filter Matured Securit ies" to exclude matured securit ies.

Display Past
Prepaid Transfers

Only applies to Statement positions.

On the Cash panel, you can check "Display Past Prepaid Transfers" to display transfers that
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were paid before their settlement date.

For example, a transfer has a settlement date of 07/10/2014, and is paid on 07/09/2014. The
transfer attribute "InitSettleDate" is set to the original settlement date 07/10/2014, so that it can
be loaded in the Inventory Position on 07/10/2014 using this checkbox.

Pricing Env

Valuation Date

These selections will only appear if the column use_pricing_env = 1 in table report_win_def for
def_name = BOPosition – Contact your database administrator to set this up.

This allows converting cash positions into the base currency of the selected pricing
environment.

The base currency will appear next to the total amount if the FX quote is known, or an error will
be displayed otherwise. The menu item Process > Check FX Quotes allows checking FX quotes
only.

You need to configure grouping by Currency, and setup subtotals by Dates with the function
SumFX (you can add it to the domain “REPORT.Functions” if it is not available for selection).

1.1.1 Dr i l l Do w n Di s p l a y Op t i o n

When you right-click a position and choose the Show menu, a number of drill down reports are available for selection.

You can view the selected drill-down report below the Inventory Position report, as shown in the example below.
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1.1.2 T r a n s f e r Re p o r t Dr i l l Do w n

When drilling down to the transfer report from a position, you can select a transfer report template that starts with
“BOPosition”.

In particular, you can configure a transfer report that shows COLLATERAL transfers, and CollateralTrade columns to
view the underlying collaterals of a given position.

To drill-down to the transfer report, right-click a position, and choose Show > Transfer Report. The list of BOPosition
templates will be available for selection.

By default, you will only see the movements of the day for cash balances and security balances.

To see all movements, you need to add the balances for which you want to see all movements to the domains
“BOPosition.DrillDown.Cash.Balance.ShowAllMovements” for cash balances, and
“BOPosition.DrillDown.Securiy.Balance.ShowAllMovements” for security balances.

You can show archived transfers in the Transfers drill-down if the menu item Report > Include Archived Transfers to
Drilldown is checked.

1.1.3 N a v i g a t i n g t o A n o t h e r In v e n t o r y Po s i t i o n Re p o r t

To open another Inventory Position report based on an existing template, create an Inventory Position report template
that starts with “BOPosition”.

When you right-click a position, the template will be available for selection under Show > BOPosition Report.
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1.1.4 Ex p l o d i n g a Po s i t i o n

If you have created custom movement types and balance types, you can view the details of the computation by
exploding the position.

Right-click the position and choose Show > Explode Position to display the details of the position. The Explode
Position report can use templates named "BOExplode_<template name>".

1.1.5 In t e r e s t En t r i e s

In the cash panel, you can right-click a position and choose Show > Interest Entries to bring up the Interest Entries
window.

This will display in the Inventory Position Report what Interest will be capitalized to the client accounts on the next
payment date, and allow the Interest amounts to be broken down into the daily constituents.

This only applies if the cash account is configured for interest bearing.

1.1.6 A g g r e g a t i o n D i s p l a y Ex a m p l e

To aggregate based on any column (book attribute for example), select the book attribute as a sort column and
column heading, then choose View > Set Table > Aggregation.

You can also check “Explode Position” and aggregate by Parent Balance to view the details of movement types that
you have created.

1.1.7 Po s i t i o n s A g g r e g a t i o n

You can also aggregate positions based on any criteria using Data > Configure Aggregation.

Select the criteria you want to use to aggregate positions and the positions are aggregated accordingly.

Example:

With no aggregation - Multiple rows are shown for each currency per account, book, etc.
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With currency aggregation, only one row is shown per currency:

It does not show any details. Grouping by currency with a subtotal in Aggregation view would give similar results.

 Ⓘ [NOTE: If you have mult iple currencies, it is recommended to select the currency in the aggregat ion criteria
as it w ill not aggregate posit ions across currencies]

1.2 In v e n t o r y Po s i t i o n - Pr o c e s s M e n u
The menu items of the Process menu are described below.

Menu Items Description

Create Movements
Type

This only applies to security positions.

Enter a movement type, for example “Collateralized Movements”.
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It populates the domain “InvSecMovementType”. You then need to define the movement
type using Process > Define Movement Type. See below.

Create Balance Type This only applies to security positions.

Enter a balance type, for example “Usable Balance”.

It populates the domain “InvSecBalanceType”. You then need to define the balance type
using Process > Define Balance Type. See below.

Define Movements
Type

This only applies to security positions. You first need to create a movement type using
Process > Create Movement Type.

Select a movement type and build the formula using basic position types, composite position
types (existing custom movement types), and specific values. You can specify conditions as
needed.

Then click Apply.

Example
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Menu Items Description

This example will compute Collateralized Movements = Movements Collateralized In +
Movements Collateralized Out.

Define Balance Type This only applies to security positions. You first need to create a balance type using Process
> Create Balance Type.

Select a balance type and build the formula using basic position types, composite position
types (existing custom balance types), and specific values. You can specify conditions as
needed.

Then click Apply.

Example 1

Example 1will compute Usable Balance = Balance + Balance_Collaterized_In + Balance_
Collaterized_In_Substitutable.
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Example 2

Example 2 will compute Cash Value = Balance * DirtyPrice * FXRate.

Example 3

Example 3 will compute the position with haircut: Repo Value = Balance * DirtyPrice * FXRate
* Haircut.

In this case, make sure to select a legal agreement or margin call contract to retrieve haircut
information.

Example 4

The MaturityFactor returns 0 if Position Date > Product Maturity Date; or 1otherwise.

It allows computing a zero balance after bond maturity using a formula like
Balance*MaturityFactor.

Check FX Quotes See search criteria Pricing Env and Valuation Date for details.

1.3 Po p u p Pr o c e s s M e n u
When you right-click a position, the following menu items are available in the Process menu.
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Menu Items Description

Details Displays the distribution of the security position.

Reconcile Position Reconcile the selected position with the position computed by the Liquidation Engine. To
use this feature, select the "Book" level aggregation in the Aggregation field.

Red rows indicate positions that are not reconciled.

You can also use the scheduled task RECON_INV_PL_POSITIONS to reconcile inventory
positions with PL positions.

Please refer to Calypso Scheduled Tasks documentation for details.

Reserve Position Select a security position, and choose Reserve Position to make the position unavailable.

» Enter the following fields as needed:

– Nominal Reserved: Nominal amount to be made unavailable

Nasdaq Calypso
Inventory Position Report / Version 18



Menu Items Description

– Start Date and End Date: Duration of unavailability

– Usage: Reason of unavailability

» Then click Save reservations(s). It creates Unavailability Transfers for the reserved
position. Such transfers populate the position types “Balance Unavailable” and
“Movements Unavailable”.

You can set the default book for the reserved position. The default book is the book with
book attribute Custody=True.

You can click to load all existing unavailability transfers regardless of the book.

Transfer Agent Select two security positions on the same security, and choose Transfer Agent to display the
Transfer Agent window for entering a transfer between the selected agents.

Position Adjustment Select a security position, and choose Position Adjustment to display the Security Transfer
window for entering a security transfer.

Unavailability Transfer Select a position (cash or security), and choose Unavailability Transfer to make this position
unavailable by creating an unavailability transfer. You can specify an unavailability reason.

Unavailability transfers populate the position types “Balance Unavailable” and “Movements
Unavailable”.

The system checks for a default trade template for the user.

If no default template exists, then the Unavailability Transfer trade will be Open by default.

If a default template exists, then the system will check to see if the default template is Open
or Term. If the template is Term, then the system will insert the position start date plus 1D
(next business date) as the end date of the trade. If the template is Open, then the trade will
be Open.

Repo Sweeping With book aggregation selected in the Security panel, you can select a position and choose
Process > Repo Sweeping to open the repo trade capture screen. It automatically
completes the following details based on the position you have selected in the report:
security, start date, book, and nominal.

Account Sweeping >
On All Selected
Positions

To perform account sweeping on all selected positions.

Refer to Account Sweeping Documentation for setup details.

Account Sweeping >
On Specific Date

To perform account sweeping on a given position cell.

Refer to Account Sweeping Documentation for setup details.

Pool Consolidation To perform account sweeping on an account hierarchy.

Refer to Account Sweeping Documentation for setup details.

Financing Select a position and choose Process > Financing to capture financing repo trades.

For a cash position, you will capture MONEY FILL trades.
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Menu Items Description

Default values for these trades can be specified through a legal agreement between the
processing organization (owner of the selected book) and the selected counterparty. Legal
Agreements are defined using Configuration > Legal Data > Agreements from the Calypso
Navigator, and default values for financing repo trades are defined in the Details panel.

You can also set default values configurations (created using Configuration > Legal Data >
Default Values from the Calypso Navigator) in the following domains:

• Domain = "Financing.MoneyFillConfig" - Value = Config name

• Domain = "Financing.CloseAfterSave" - Value = true (to automatically close the window
when the trades are saved)

Enter and modify the fields as needed.

Add trades as needed.

Click Save when you are done.

The Default Values Configurations window is described in Calypso Fixed Income
documentation.

Margin Call For a margin call position, creates a margin call trade.

1.4 En v i r o n m e n t Pr o p e r t i e s
The following environment properties apply to the Inventory Position report.

Environment Properties Description

AGG_CONFIG_
PLACEOFSAFEKEEPING

True or false. Default is false.

When true, it allows computing the external position by Book / Agent / Account /
PlaceOfSafekeeping.

When false, it allows computing the external position by Book / Agent / Account.

BO_POSITION_FORCE_
TRANSACTION_SERIALIZABLE

True or false. Default is false.

Inventory positions are stored in multiple tables. If you are loading large past
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Environment Properties Description

positions, there might be changes to those tables while the report is running,
therefore causing inconsistent results.

When true, it allows preventing changes in the inventory tables between different
queries by increasing the isolation level to SERIALIZABLE (instead of
TRANSACTION_READ_COMMITTED by default).

In the case of Oracle, the parameter INITRANS (default is 1) should be increased for
tables (and indexes) linked to inventory tables to allow multiple SQL queries running
at the same time.

inv_cash_movement

inv_cash_balance

inv_sec_movement

inv_sec_balance

inv_cust_cash_movement

inv_cust_cash_balance

inv_cust_sec_movement

inv_cust_sec_balance

inv_cash_query

inv_sec_query

inv_agg

inv_temp_config_id

inv_product_temp

product_temp

BO_POSITION_REPORT_
ACCEPT_IN_DATASERVER

True or false. Default is true.

When set to true, it allows accepting the inventory positions inside the Data Server
to prevent too many RMI calls. Set to false to disable (accepting done in Calypso
Navigator in this case).

Accepting corresponds to selecting the inventory positions based on the Inventory
Position report criteria.

BO_POSITION_REPORT_
FILTER_IN_DATASERVER

True or false. Default is true.

When set to true, it allows filtering the inventory positions inside the Data Server to
prevent too many RMI calls. Set to false to disable (filtering done in Calypso
Navigator in this case).

Filtering corresponds to removing applicable zero positions (based on date range).

BO_POSITION_REPORT_
CLEAR_POSITION

True or false. Default is true.
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Environment Properties Description

Allows reducing memory usage in Inventory Position report – Disabled in case of
real- t ime updates.

BO_POSITION_REPORT_
CLEAR_DISPLAYABLE

True or false. Default is true.

Allows reducing memory usage in Inventory Position report – Disabled in case of
real- t ime updates.

BO_POSITION_REPORT_
CLEAR_ROW_VECTOR

True or false. Default is true.

Allows reducing memory usage in Inventory Position report – Disabled in case of
real- t ime updates.

BO_POSITION_REPORT_
PRELOAD_SECURITIES_IN_
DATASERVER

BO_POSITION_REPORT_
PRELOAD_SECURITIES_MIN_
IN_DATASERVER

If set to true, preload the securit ies when a Custom Filter or a SD Filter is used in the
Inventory Position Report. Default is false.

Minimum number of securit ies to activate the preloading of the product cache
(default is 10). Only applies when BO_POSITION_REPORT_PRELOAD_SECURITIES_
IN_DATASERVER is true.

BO_POSITION_REPORT_
REALTIME_LOG_SIZE

Size of the real- time logs (default value is 50000). If set to 0, the logs are not limited.

BO_POSITION_LOAD_
PRODUCT_BY_IDS

True or false. Default is true.

Allows loading the products by ID in the Inventory Position report.

KEEP_OPPOSITE_XFER_FROM_
INVENTORY_DETAIL

Used in the Inventory Position report.

True or false. Set to true to display both legs of a repo when both the start and end
legs are failed. Only one failed transfer is displayed otherwise.

Default is false.

MAX_INVENTORYPOSITIONS_
PER_USER

Maximum number of inventory positions to be loaded.

Default is 500000.

Can also be set per user using User attribute Max.InventoryPosition.

These limits do not apply to Admin users.

PRODUCT_REPORT_CACHE_
MAX_SIZE

Max size of Secondary Market Products cache – Default is 50000.
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2 . Sec ur i t ies Fi l t er
The Securit ies Filter allows defining search criteria to filter bonds.

You can save the filter, it will be saved as a Bond Report template that can be used anywhere a Bond Report template
can be used.

» Enter search criteria in the Properties Filter panel and Sec Codes Filter panel as applicable. Then click Apply to
apply the search criteria and load the corresponding bonds.

» You can click Save to save the filter as a Bond Report template. You will be prompted to enter a filter name.

The Template menu allows loading / saving bond report templates.
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